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1: Welcome to PAC Display

Welcome to PAC Display™, Opto 22's human-machine interface (HMI), alarming, and trending software for
Microsoft® Windows® operating systems. PAC Display works with Opto 22 control programs (or strategies)
running on Opto 22 industrial controllers.

PAC Display lets you easily create graphical, on-screen operator interfaces to monitor and manage control
applications running on Opto 22 industrial control engines. With PAC Display, you can present real-time
control engine information to the operator, set alarms to notify the operator of changing data, visually track
trends in the data using graphs, and securely log data to local or remote computers. Additionally, you can
configure the interface to allow a specified operator or group of operators to change values such as alarm
thresholds.

PAC DISPLAY BASIC AND PAC DISPLAY PROFESSIONAL

Two versions of PAC Display software are available: Basic and Professional. PAC Display Basic provides all the
HMI functions that are listed above and documented in this user’s guide. PAC Display Professional adds several
capabilities that are important if you need to do the following:

«  Import projects created in Opto 22's OptoDisplay™ applications

«  Take advantage of redundant Ethernet networking features in Opto 22 SNAP PAC controllers.

o Access Scratchpad variables on a SNAP PAC controller or brain.

«  Have a PAC Display project connect to an Opto 22 controller that is running an OptoControl strategy.

This user's guide covers both PAC Display Basic and PAC Display Professional.
@ In this User's Guide, the “Pro”image indicates features or functions that apply only to PAC Display Professional.

ABOUT THIS GUIDE

This user's guide teaches you how to use PAC Display, including designing a PAC Display project, configuring
and connecting an Opto 22 control engine, and monitoring information in your operator interface.

This guide assumes that you are already familiar with Microsoft Windows on your personal computer,
including how to use a mouse, standard menus and commands, and how to open, save, and close files. If you
are not familiar with Windows or your PC, see the documentation from Microsoft and your computer
manufacturer.

Here's what is in this user’s guide:

1: Welcome to PAC Display—this introductory chapter.
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ABOUT THIS GUIDE

2: PAC Display Tutorial—a short lesson to get you up and running with a PAC Display project as quickly as
possible. You'll use a sample project to learn how to work with graphic objects, assign dynamic attributes, and
run a project.

3:What Is PAC Display?—an introduction to PAC Display, basic design and programming concepts, and PAC
Display controls and windows.

4: Working with Projects—an explanation of what PAC Display projects are, the files they're made of, and
how they're organized.

5: Configuring Control Engines and Tags—detailed procedures on configuring control engines and 1/0
from a PAC Control strategy for use in a PAC Display project.

6: Working with Graphic Objects—detailed steps for working with graphic objects—including assigning
animation attributes—and the windows in which objects appear.

7: Using Animated Graphic Objects—covers how to assign dynamic attributes to on-screen objects to
create an animated, real-time display of I/0 information.

8: Working with Trends—explains how to create and configure graphs to track data from I/O points over
time.

9: Configuring Trigger-Based Events—explains how to use historical logging, application launching,
sounds, recipes, and how to change window states based on events.

10: Configuring and Using PAC Display Runtime—describes how to customize configurable Runtime
features and what you'll see during a Runtime project session.

A: PAC Display Troubleshooting—gives tips for solving problems you may encounter while building and
using your PAC Display project.

B: PAC Display Errors—explains warnings and error messages you may see while running a program in PAC
Display Runtime.

C: PAC Display Files—lists all PAC Display files located in the PAC Display directory.
D: Menus—Ilists commands and other menu bar options.
E: International Characters—provides an alphabetical list of key words and their page locations.

F: Using the Old-Style Dynamic Attribute Dialog Boxes—describes an older method of configuring
dynamic attributes. The method was streamlined starting in PAC Display R10.0a, but the old method is still
available to those who prefer to use it.

Document Conventions

The following conventions are used in this document:

«  ltalic typeface indicates emphasis and is used for book titles. Example: “For details, see the PAC Control
User's Guide (form 1700)

«  Names of menus, commands, dialog boxes, fields, and buttons are capitalized as they appear in the
product. (Example: “From the File menu, select Print.")

«  File names appear either in all capital letters or in mixed case, depending on the file name itself.
(Example: “Open the file TEST1.txt.")

«  Keynames appear in small capital letters. (Example: “Press Shift.")

«  Key press combinations are indicated by hyphens between two or more key names. For example,
Shift+F1 is the result of holding down the Shift key, then pressing and releasing the F1 key. Similarly,
Ctrl+Alt+Delete is the result of pressing and holding the Ctrl and Alt keys, then pressing and releasing
the Delete key.
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CHAPTER 1: WELCOME TO PAC DISPLAY

«  "Click"means press and release the left mouse button on the referenced item. “Right-click” means press
and release the right mouse button on the item.

«  Menu commands are referred to with the Menu > Command convention. For example, “File > Open
Project” means to select the Open Project command from the File menu.

«  Numbered lists indicate procedures to be followed sequentially. Bulleted lists (such as this one) provide
general information.

OTHER PAC DISPLAY RESOURCES

Documents and Online Help

To help learn and use PAC Display, the following resources are provided:

«  Online Help is available in PAC Display, PAC Control, and in most of the utility applications. To open
online Help, choose Help > Contents and Index in any screen.

«  PAC Display User's Guide (this document)

Online versions (Adobe” pdf format) of PAC Display documentation are provided on the PAC Display CD and
are also available from the Help menu in PAC Display. To view a document, select Help > Manuals, and then
choose a document from the submenu.

PAC Display and PAC Project resources are also available on the Opto 22 website at www.opto22.com. You can
conveniently access this and other sections of the Opto 22 website from PAC Display’s Help menu. Select Help
> Opto 22 on the Web, and then select an online resource from the submenu.

For Developers: SNAP PAC REST API

If you're a developer who'd like to use PAC Control strategy tags in communications with other
devices, the Opto 22 SNAP PAC REST APl 'is a secure and powerful way to do just that. The APl is
available in SNAP PAC R-series and S-series controllers with PAC firmware R9.5a and higher. To
configure HTTPS access to your PAC's RESTful server and learn how to call the API, visit
developer.opto22.com.

Product Support

If you have any questions about PAC Display, you can call, fax, or e-mail Opto 22 Product Support.

Phone: 800-TEK-OPTO
(800-835-6786 toll-free in the U.S. and Canada)
951-695-3080
Monday through Friday,
7 a.m.to 5 p.m. Pacific Time

Email: support@opto22.com
Opto 22 website: WwWw.opto22.com

When calling for technical support, you can help us help you faster if you provide the following information to
the Product Support engineer:

«  Ascreen capture of the Help > About dialog box showing software product and version (available by
clicking Help > About in the application’s menu bar).

»  Opto 22 hardware part numbers or models that you're working with.
e Firmware version:
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- For groov EPIC processors and groov RIO modules: available in groov Manage by clicking Info and
Help > About.

- For SNAP controllers and brains: available in PAC Manager by clicking Tools > Inspect.
«  Specific error messages you received.
«  Version of your computer's operating system.

«  For PAC Control, PAC Display, OptoOPCServer, or PAC Manager, you may be requested to provide
additional information, such as log or dump files. You can find these files in a support files sub-folder:

a. On your Windows Desktop, double-click the PAC Project 10.5 folder.

b. Double-click Support Files.

c. Double-click on the appropriate shortcut to open the sub-folder containing the requested files.
Note: PAC Control, PAC Display, OptoOPCServer, and PAC Manager create appropriate sub-folders when they

create diagnostic log or dump files. If they have not created these files, the sub-folder may not exist; in this case,
the shortcut will not work.

INSTALLING PAC DISPLAY

4

PAC Display is a component of the PAC Project Software Suite, a comprehensive set of software tools for
industrial automation, remote monitoring, and data acquisition projects in any line of business.

Installation is easy and quick, and you can download PAC Project directly from the Opto 22 Support >
Downloads webpage.

The PAC Project installer includes both the Basic (free) version of the software suite, and the software for PAC
Project Professional. Click here for a comparison of PAC Project Basic and PAC Project Professional features.

To install PAC Display:
1. Download PAC Project from the Opto 22 Support > Downloads webpage.

2. Navigate to the folder where you downloaded PAC Project, and then double-click the installation file
(PAC_Project_<release number>.exe) to begin installation.

NOTE: You must have an OptoPassword to install the Professional version of PAC Display. For details, see the Opto 22
website, www.opto22.com, Support > Downloads tab, and click the link for OptoPassword (located in the text above
the Search field).

If you have trouble installing PAC Display, contact Opto 22 Product Support at 800-835-6786 (toll-free in the
U.S. and Canada) or 951-695-3080.

System Requirements

Here’s what you need to install and run PAC Display:

« A computer with at least the minimum processor and memory required for your version of Microsoft®
Windows®, and Ethernet capability. Additional memory and a better CPU may be required for some
configurations. We recommend staying away from low-end CPUs and using one of the following
operating systems:

—  Microsoft® Windows® 10 Professional (32-bit or 64-bit) or Windows 11 Professional

(OptoOPCServer and OptoDatalink) ® must install .NET Framework 4.0 prior to installing PAC Project on
these operating systemsNOTE: PAC Project cannot be installed on Windows XP or older Windows operating
systems. Other versions of Windows operating systems and embedded Windows operating systems are not
supported.
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Ethernet capability

VGA or higher resolution monitor. Minimum size: 800x600 with small fonts
Mouse or other pointing device

(Optional) Installed Windows printer

For PAC Display Basic: At least 141 MB available hard disk space.

For PAC Display Professional: At least 158 MB available hard disk space.

At least 500MB available RAM.

If your PAC Display project uses many basic trends, SuperTrends, or XY Plots, Opto 22 strongly
recommends adding RAM beyond the minimum requirement. For details, see “Memory
Requirements for SuperTrend Pens”on page 190.

If your PAC Display Professional project accesses an M4-series controller (such as a SNAP-LCM4 or M4RTU)
via an Ethernet connection, controller firmware version R4.1a or newer is required. In addition, in order to
access strings or string tables, controller firmware R4.1d or newer is required.

NOTE: If you're using an operating system such as Windows 10 that supports multiple monitors, you can display the
operator interface you create in PAC Display on more than one monitor as long as all monitors have identical video
cards.

Compatible Databases (Pro only)

Microsoft® SQL Server® 2022, 2019, 2017, 2016, 2014, 2012, 2008, 2005, and 2000
Microsoft Azure SQL Database

MySQL® 3.51 and 5.1 (32-bit only)

Microsoft Access® 2000-2003 and 2007-2016

NOTE: Microsoft has ended support for SQL Server 2005 (and lower) and for Access 2003 (and lower).
If you're using applications that Microsoft no longer supports, you should consider upgrading.
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2: PAC Display Tutorial

INTRODUCTION

The quickest way to become familiar with PAC Display is by working through a simple example. Our example
will use a cookie factory to show you how easy it is to use PAC Display. You'll learn how to start PAC Display,
open and save a project, and assign a PAC Control strategy to the project. Then you'll bring in a bitmap, add
some animation attributes, and watch your project in action. We'll repeat this process to fine-tune the visuals
and we'll end up with a final “working” cookie factory.

NOTE: Ifyou can’t access an Opto 22 control engine at the moment, you can still do everything in the Quick Start up
to the point of running your project. Or, you can simulate the control engine of an Opto 22 programmable
automation controller (PAC) using the Opto 22 SNAP PAC Sim software utility. For more information, visit the Opto 22
website, www.opto22.com.

InThis Chapter

Opening the Project page 7
Examining the Project page 9
Configuring a Control Engine page 10
Adding a Dynamic Attribute page 16
Downloading to the Control Engine page 20
Running the Project page 27
What's Next? page 29

OPENING THE PROJECT

Let's start by opening our sample project. PAC Display projects contain windows, graphic objects, and other
information needed to produce an animated operator interface.

1. Start PAC Display Configurator Basic:

- InWindows, press the Windows Start key )] type PAC Display Configurator Basic
10.5 and then press the Enter key.

PAC Display User's Guide 7


http://www.opto22.com/

OPENING THE PROJECT

The PAC Display main window opens.

7 PAC Display Configurator Basic

File Help

2. C(lick File > Open Project (or Ctrl+0), and then navigate to C:\Users\Public\Public
Documents\Opto 22\PAC Project\Display Basic Examples\Display\ioCookies.

1 Open Project *
Lookin: | | | ioCookies v @@ e m-
* MName - Date modified Type
g || PROJECT_BACKUP 5/11/201810:02 AM  File folder
Quickaccess &4 £ tory.UUI 5/10/20185:25PM  PAC Displ
Desktop
m
Libraries
2
This PC
‘ < I >
Metwork
File name: | - | I Open I
Files of type: | Al PAC Display Projects (*.UUI) | | cancel |

3. Double-click the project file cfactory.uui to open it.
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The main window should look like this:

L1 PAC Display Configuratar Basic- cfactory.UUI - [m} *
File Edit View Style Text Configure Tools Window Help

Cookie Factory

EXAMINING THE PROJECT

This particular PAC Display project models a simple cookie factory that uses the following components:

»  Atankof pre-mixed cookie dough

«  Atankof chocolate chips

« Anoven

«  Avisual inspection station

«  Some plant air to blow out bad cookies

«  Aconveyor belt to move material between the different components.

At the start of the process, a measured amount of dough is dropped onto the conveyor belt. The dough
moves first under the chip tank to receive some chips, and then into the oven to be baked. The next stop is an

inspection station, where rejected cookies are blown off the belt. The good cookies go to shipping. Should
anything go wrong, we also have some alarms built in to stop the process if necessary.
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The window for the cookie factory project should look like this:

L1 PAC Display Configuratar Basic- cfactary.UUI - [m} *
File Edit View Style Text Configure Tools Window Help

Cookie Factory

2 v :
W |D[O[O]O ||~

YPSIG

(o) =

This window is called a draw window, because in PAC Display Configurator this is where you can create and
position graphic objects and other elements for your operator interface. This is also where you assign
animation characteristics, or dynamic attributes, to graphic objects. Floating on top of the window is a toolbox
with all the tools you need to draw graphic objects.

CONFIGURING A CONTROL ENGINE

We'll start out by configuring a control engine so that our graphic objects are tied to actual values in a PAC

Control strategy. The strategy will be downloaded to your control engine later so we can actually see things
running. We'll briefly go through the configuration process, which is covered in greater detail in "Chapter 5:
Configuring Control Engines and Tags" on page 61.

If the Control Engine Already Exists

If you've already completed the Tutorial chapter in the PAC Control User’s Guide (form 1700), a control engine
named “Cookie Controller” should be available. Follow the instructions below to check if this control engine
already exists.

1. Choose the Configure > Control Engine(s) menu item.
The Control Engines dialog box opens.
2. Do the following:
- Ifthe control engine “Cookie Controller”is listed in this dialog box, continue to step 3 below.

- Ifthe control engine “Cookie Controller”is not listed in this dialog box, follow the steps in “Adding a
Control Engine”on page 12.
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3.

4.

5.
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Select “Cookie Controller”in the Control Engines dialog box, and then click Replace.

Contrel Engine Properties

Primary Contral Engine

Mame; |

Backup Contral Engine

Mame; | |

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl

Cancel Help

Browse...

Browsze. .

Browse...

Make Path Relative to Project [

x

In the Control Engine Properties dialog box that appears, click Browse in the Strategy section. At the

warning prompt, click OK to continue.

NOTE: This dialog box s slightly different in PAC Display Professional, but the Strategy section and corresponding

Browse button are the same.

The Strategy File Name Selection dialog box appears. This dialog box is much like the Open Project dialog

box we used to find our cookie factory project.

U Strategy File Mame Selection *
Look in: | ioCookies strategy v | (< )5 s A
* MName Date modified Type
i Cookies.idb 5/10/2018 5:24 PM  PAC Cont
Quick access
Desktop
m
Libraries
This PC
@ :
MNetwork
File name: Cookies idb - | Open
Files of type: PALC Control Strategy ("idb) ~ Cancel

Change directories to C:\Users\Public\Documents\Opto 22\PAC Project\Display Basic
Examples\Control\ioCookies strategy directory. Then, select the Cookies.idb file, and click Open.
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The Control Engine Properties dialog box should now show both the name of the control engine and the
PAC Control strategy that will be used.

Contrel Engine Properties x

Primary Contral Engine

Mame; |I:Dokie Controller | Browse...

Backup Contral Engine

Mame; | | Browsze. .

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl Browse. ..

Make Path Relative to Project [

Cancel Help

The PAC Display project is now configured to use your control engine for this Quick Start exercise. Skip the
next section, “Adding a Control Engine,” and continue with the steps in “Adding a Dynamic Attribute” on

page 16.
Adding a Control Engine

1. Choose the Configure > Control Engine(s) menu item.
The Control Engines dialog box appears.

B Control Engines x
Marne |.P. Address
Add...
Feplace...
Delete
< >
Cancel Help

2. Click the Add button.
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The Strategy File Name Selection dialog box appears. This dialog box is much like the Open Project dialog

box we used to find our cookie factory project.

tT Strategy File Mame Selection

Look in: | ioCookies strategy

v 0of e |

* Mame
4 Cookies.idb

Cuick access

Desktop
M
Libraries

4

This PC

$

MNetwork

Date modified
5/10/2018 5:24 PM

Type
PAC Cont

File name: Cookies idb

Files of type: PAC Control Strategy (*idb)

~ Cancel

Change directories to Program C:\Users\Public\Documents\Opto 22\PAC Project\Display Basic

Examples\ControNioCookies strategy directory.
Select the Cookies.idb file, and then click Open.

The Control Engine Properties dialog box appears. Notice that the PAC Control strategy you just picked is

shown in the Strategy field.

NOTE: This dialog box is slightly different in PAC Display Professional, but the Strategy section and corresponding

Browse button are the same.

Contrel Engine Properties

Primary Control Engine

M arme: | |

Backup Contral Engine

Mame; | |

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl

Cancel Help

Browsze. .

Browsze. .

Browse...

Make Path Relative to Project [

To define your control engine in the Primary Control Engine field, click the Browse button in the Primary

Control Engine group.
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The Select Control Engine dialog box opens.

Select Control Engine

Configured Control Engines:

- Add...
Maodify...
Delete
W

6. Click Add to add a control engine.
The Control Engine Configuration dialog box appears.

Control Engine Configuration

Configure Ethemet Connection

Configure control engine name and parameters:

Contral Engine Name: ||

System Type
(®) Standard
() Redundant Networks (PRO only)
() Redundant Contrallers (PRO anly)

Settings
IP Address/Hostname: [0.0.0.0

Controller Port:

Software Retries:

|

Software Timeout: msec

Cancel

7. Enter Cookie Controller as the control engine name.

The name can contain letters, numbers, spaces, and most other characters except colons and square

brackets. Spaces cannot be used as first or last characters.
8. Enter the control engine’s IP address or hostname.

On hardware such as a SNAP PAC R-series controller, IP address assigned to the device is usually written
on a sticker on the side of the unit. If an IP address has not been assigned to the control engine, see the

user’s guide for that device for configuration instructions.
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On a Soft PAC controller, if PAC Control and SoftPAC are on the same PC, use the loopback IP address,
127.0.0.1. However, if SoftPAC is on a different PC, use the address for that PC's network interface card
(NIC). In this case, the SoftPAC PC's NIC must be configured with a static IP address.

You can also configure a secondary IP address if your system has been designed to have link redundancy.
If a SNAP PAC control engine is used, the second IP address can be the controller's second Ethernet
interface.

9. Make sure that you have not changed the values in the Port, Retries, and Timeout, and then click OK.
The newly configured control engine appears in the Select Control Engine dialog box.

Select Control Engine

Configured Control Engines:
Cookie Controller

oK Cancel

10. Click the new Cookie Controller control engine to select it, and then click OK.

The Control Engine Properties dialog box appears with the new control engine listed in the Primary
Control Engine group.

Contrel Engine Properties x

Primary Contral Engine

Marne: |E00kieE0ntr0|Ier | I Browse. . I

Backup Contral Engine

Marne: | | Browse...

Strateqy: |c:'\users'\public\documenls'\opto 22\pac prniecl Browse. .

Make Path Relative to Project [

0k Cancel Help

11. Click OK.
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The Control Engines dialog box appears with the new control engine Cookie Controller.

B Control Engines x
MName |.P. Address
’ Add...
Cookie Controller 10.20.30.40
Replace...
Delete

<

Cancel Help

12. Click OK to finish configuring the control engine.

ADDING A DYNAMIC ATTRIBUTE

Dynamic attributes allow you to manipulate graphic objects; for example, to animate them, to use them to
read and write to the associated strategy, and to perform many other functions.

Let's assign a dynamic attribute to the button that starts the cookie factory display.
1. Click the Select tool in the PAC Display Configurator toolbox as shown below.

£ Tools L —Select Tool
] [m}{e]ta] CATAY

]

[ok]|[+]

Ao320 Yoo 32
W. 144 H: $

2. Double-click the Start button in the Cookie Factory window.
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Small black boxes—called sizing handles—appear around the button. They indicate that the button is
currently selected. The Graphic Dynamic Attributes dialog box also opens.

File Edit

View

Style Text Configure Tools Window Help

-

U..

ANl [s] [o]ia] T

(ox)| =

H X114 Y 319
. W 53 H: 19
| ] I--

M Graphic Dynamic Attributes
Pysh To Sta e J
ject: Tex -
TART

Control Engine Driven

[ Text Colar
[ visibility fBlink

/-

[ rotate

/

Sizing handles

Dynamic a

[] Harizontal Position
[ vertical Position
[ Text In from Control Engine

Operator Driven
O
[0 vertical Slider
[ ® send value
[ ® send Discrete
[J ® send String
OO windows

|
L |

< >

Horizontal Slider -

—

utes

Download Recipe

v

Focus-frame enabled
Beep enabled

Hotkey: []ctrl

[ shift

Cancel

<None>

Help

b, s 25
e T P Vi

e

Notice that the dialog box has two separate groups of attributes: Control Engine Driven attributes and
Operator Driven attributes.

Control engine-driven attributes are attributes that are driven by tag values from the PAC Control strategy
running in the controller. Operator-driven attributes are driven by an operator’s interaction with a graphic
object in PAC Display.

We're going to choose the operator-driven attribute Send Discrete to send a discrete value to the control
engine. The PAC Control strategy interprets the value as a signal to start the cookie factory.

In the Operator Driven list, click Send Discrete. (Note: Click its name, not its check box.)
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The features of the Send Discrete attribute are displayed.

Graphic Dynamic Attributes Tag Name field

Object: Text w[1a | Width: 53 Height:

Hint... | Secu
Control Engine Driven Operator Driven: Send Discrete
[ Text Color Tag
[] visibility /Blink Mame:
[ Rotate |

[] Horizontal Position
[ vertical Position

S
[] Text In from Control Engine s

(@ Fized data () Prompt for data

Fixed D ata Prompted D ata
Operator Driven

= (®) Set UIzer Message:
(] Horizontal Slider ~ O Clear
(] vertical Slider Set Button Text:
[ @ Send Vaue O Toggl Clear Button Text:
M) ) send Disarete () Reverse b
i N iy

4. There are two ways to configure a tag for a dynamic attribute:

- TheTag Selection dialog box

- QuickTag Entry

In this example, we'll use the Quick Tag Entry:

a. Clickanywhere in the Tag Name field.
Quick Tag Entry appears.

x: ‘r: Width: | 53 Height: | 1% Hint... Security. ..

Opergtor Driven. Send ¥screfe
Tag
Cantroller: Itern Mame: Field / Bit ]
1 |Eookie Contraller ~ t.[:hi \[isper w || \,\‘7\
I
Source

(@ Fixeddata () Prompt fior data

Fixed D ata Prompted Data
(® Set I zer Message
O Clear Set Button T ext
S Togole

-

b. Inthe ltem Name field, start typing: bStartFlag
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As you type, PAC Display filters the list of matching values, and the color of the attribute’s name
changes to green. This indicates that configuration is in progress and the changes have not yet been

saved.
Graphic Dynamic Attributes (
A
i
Object: Text X: = Width: 53 Height: = 15 Hint... ?
1
Control Engine Driven Operator Driven: Send Discrete :
[ Text Color Tag 4
[ visibility fBlink Controller: Item M ame: Field / Bit (\
[ rotate [PAC Sim ~ | [b B | ~[2 1
[] Horizontal Position :
[ vertical Position 5 i
[ Text In from Control Engine ourc.:e
(®) Fixed data (O Prompt for data As yOU type/ PAC Dlsplay
Fixed D1ata Frompted D1ata dlsplays matChmg tag names
Qperator Driven @ et 4
[0 Horizontsl Slider - O Clear (
[0 vertical Slider ‘
[ ® send value O Tongle 1
[ @ send Discrete O Reverse P
[ ® send string (O Direct {
OO windows ‘i
L] DomoadRepe £ The green color indicates 3
£ > - . . 4,
configuration is not complete i
Focus-frame enabled b
Beep enabled ;‘
— = J

c.  When bStartFlag appears in the field, press Tab to advance to the Field / Bit field.
d. Inthe Field / Bit, type: 1
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Then click the check box next to Send Discrete. If there are errors in your configuration, they are
displayed for you to correct. If there are no errors, the green color disappears from the attribute’s
name.

Graphic Dynamic Attributes \,
3
P
F|
Object: Text X: ¥: Width: 53\
Control Engine Driven Q'JqiL
[ Text Color Tag (1
[ visibility fBlink Mame: i
[ rotate | Cookie ControllerbStartFlag i
[ Horizontal Position ™
[ vertical Position g {
[ Text In from Control Engine ouree i

(® Fixed data () Prampt for dal
<

Fized Data Prompted qu'

Operator Driven @ Set e :{:

[ Horizontal Slider ~ O Clear i

[0 vertical siider 1 T8

[ ® send value O Toggle

@ O Reverse

[ ® send string ) Direct

|:| Windows

[0  oownload Recpe o
— i &

< >

Focus-frame enabled
Beep enabled

HotKey: [Jctl [Jshift | <Mome> v

Cancel Help

A, b iy,

5. Click OK to complete adding the dynamic attribute and close the dialog box.

ADDING A GRAPHIC OBJECT

Now let's add a portion of cookie dough underneath the first tank. Rather than drawing our cookie dough,
we're going to use a drawing of cookie dough saved as a bitmap graphics file (or bmp). This file is located in
the Display directory.

1. Click File > Choose Bitmap.
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The Choose a Bitmap dialog box appears.

1 Choose A Bitmap *
Look in: | inCookies strategy v| (€] %+ £ M~
i MName - Date modified Type

Mo items match your search.
Quick access

Desktop

m

Libraries

$ ;

File name: || ~ | Open

Files of type: All Btmaps (*.BMF) w Cancel

Navigate to C:\Users\Public\Public Documents\Opto 22\PAC Project\Display Basic
Examples\Display\ioCookies, and then double-click the Dough.bmp file.

Now choose the Bitmap tool in the PAC Display Configurator toolbox as shown below.

CiNOolo]owy

179

Click the cursor right above the conveyor belt and underneath the first vessel.

If the graphic object is a little out of place, it can easily be moved to the correct position using the Select
tool.

Choose the Select tool in the toolbox, and then click the bitmap graphic object to select it.
Nine square sizing handles appear around the graphic object.

Put your cursor within the sizing handles, click your mouse, and drag the cookie dough to the correct
position above the conveyor belt and underneath the first vessel.
Besides visually placing the graphic object, you can also use the arrow keys on the keyboard or use the X:

and Y: coordinates displayed in the toolbox to help you place the cookie dough. We suggest coordinate
locations X:151 and Y:257, but your coordinates may differ.

Now let's give the bitmap graphic object some attributes to animate it. To make the cookie dough look like it's
moving across the conveyor belt, we'll configure an attribute to affect its horizontal position.

7.

Double-click the cookie dough bitmap graphic object.
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The Graphic Dynamic Attributes dialog box opens.

Graphic Dynamic Attributes

Object: Bitmap Xz i Width: Height: H|r|t Security...

Control Engine Driven

[ visibility Blink

[ rotate

[ Horizontal Size {width)
[ vertical size (height)
[ Horizontal Position

[ vertical Position

Operator Driven

[l Horizontal Slider ~
[ vertical Slider

[] ® send value

[] ® send Discrete

[ ® send String

D Windows

D Download Recipe o
— bl “— ¥

< >

Focus-frame enabled
Beep enabled

HotKey: []ctl []shift |<Mone>  ~

Cancel Help

8. Inthe Control Engine Driven list, click Horizontal Position (—its name, not its check box).
The Horizontal Position features are displayed in the center area of the dialog box.

Graphic Dynamic Attributes

Object: Bitmap X Y: Width: Height: [ Hint. .. ) Security...

Control Engine Driven Coritrofl Engine Driven: Horizontal Position
[ visibility Blink Tag
[ rotate M ame:

[ Horizontal Size {width) |
[ vertical size (height)
M| Horizontal Position

[ vertical Position

Fea

WValue &t Left: l:l Movement Left: l:l
“alue At Right: l:l M ovement Right: l:l

Operator Driven
[J  Horizontal Shider ~ Reference
O Vertial Sider OlLeft  @®Center O Right Deacbard [0 |

D Send Value
D [+ Send Discrete
= e ” - . s 2 i ” i i -

9. We need to configure a tag to which we will connect the cookie dough bitmap graphic object. This time
we'll connect it to a value PAC Display reads from the control engine.
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We won't use Quick Tag entry because the Tag Selection dialog box has an additional field we want to
use. Instead, click the Tag Selection button | 7 |.

a.
b.
C.

In the Item Type field, select Down Timer.

In the Item Name field, select dtCookieMotionTimer.
In the Refresh Time drop-down list, select Group 1 (250 ms).

Value Tag Selection >
Contraller: ltem Type:
Cookie Controller Chart
Contral Engine
Float
Integer
Item Mame; :
S— Selected Fieldz
dationTimer
Field:
Element; Bit (0-21];
Start Index: Mum Elements:
Refresh Time: | Group 1 [250 ms) L
Cancel Help

Click OK. The Graphic Dynamic Attributes dialog box is displayed again.
In the features area, enter these values:

Value At Left: 7

Value At Right: 0
Movement Left: 0
Movement Right: 360
Reference: Left
Deadband: 0
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The dialog box should look something like the example below.

=0T

Graphic Dynamic Attributes :
;A.
:’
Object: Bitmap x: ¥: width: 24 | Height: [ 11 | Hint.. Securiti,
Control Engine Driven Control Engine Diven: Honzontal Position .\
[ visibility Blink Tag :\‘
[] Rotate Mame: P
[ Horizontal Size (width) Cookie Controller: dtCookietd ationT imer | 7 :\
[ vertical Size (height) 4
D Horizontal Position j
[] vertical Position b
Walue &t Left: Movement Left: I:I 7
1
Yalue At Right: I:I Movement Right: | 360 f
Operator Driven \ k
[0 Horizontal Slider ~ Reference 7
]
(]  vertical Slider ®Left (O Centsr () Right Dieadband: I:I <
(] @ send Value «
(] ® send Discrete (
e f 7 ; :
The attribute’s name is green because you haven't clicked its check box to save its settings.
12. Click the check box for Horizontal Position. Note that Not Available indicator ) appears next to Rotate
and Horizontal Slider. That's because they aren't applicable when Horizontal Position is configured.
Graphic Dynamic Attributes :
;n.
:’
Object: Bitmap X: Y: width: | 24 | Height: [11 | | Hint... securiti,
Control Engine Driven Control Engine Driven: Horizontal Position b
[ visibility Blink Tag :\*
@ Rotate MHame: [
[] Horizontal Size {width) |Cu:u:|kie Contraller: dtCookieb otion T imer | 7 :‘
[ vertical Size (height) 4
]
[ vertical Position L
Walue At Left: tovernent Left: ICI 7
1
Walue At Right: D Moverment Right: | 360 f
Operator Driven I\
@  Horizontal Slider A Reference {‘
] vertical Slider @ Left (O Center () Right Deadband: ICI <
[ ] ® Send Value a
(] ® Send Discrete (

13. Later, we'll configure an attribute that will make the cookie dough appear to drop out of the first vessel.
But for now, click OK to close the dialog box.

14. Save the project by selecting File > Save Project (or Ctrl+5).
15. Close PAC Display Configurator by clicking the Close button 4.
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DOWNLOADING TO THE CONTROL ENGINE

Let's try running our project and see if there's anything we need to change.

In order to see our animated display, we have to run the PAC Display Runtime program. But before we do that,
we need to download our PAC Control strategy to the control engine.

NOTE: PAC Control strategies are usually downloaded to a control engine for convenience using the PAC Control
application. However, we'll download our PAC Control strategy using a PAC utility called PAC Terminal. To learn more
about downloading strategies to a control engine, see the PAC Control User's Guide (form 1700).

1. Start PACTerminal.
- InWindows, click the Windows Start button, and then click Opto 22 > PAC Terminal 10.5.
The PAC Terminal window appears, displaying the name of our control engine.

1 PAC Terminal - O *
File Tools Configure View Help L\\)
Control Engines:
=
Controller Name System Type  Address 1 Address 2 Status & Configure Control Engines
¥ Cookie Contraller Standard +10.20.30.40 E-=3 & Add...
Status Scan
2, Scan Al
%, Scan Selected
v
£ >

2. Select Cookie Controller, and then choose File > Download Control Engine Forth File to download the
run file for our PAC Control strategy.
The Download File dialog box opens.

Download File I,\\S *

File to Download:

|| Browse... I

Download progress:

Download Cancel

3. (lick Browse and change directories to C:\Users\Public\Public Documents\Opto 22\PAC Project\Display
Basic Examples\ControNioCookies strategy.

4. Select "Cookies.crn”and click Open.
The file should be listed in the Download File dialog box.

5. Click OKto continue the download.

PAC Display User's Guide 25


http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165" target="_blank
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165

DOWNLOADING TO THE CONTROL ENGINE

The download progress is shown.

Download File % *

File to Download:

| C:\Wsers\Public\Documents\Opto 22VPAC Project ~ 1\Display Basic Examples\Control\joCookl Browse. ..

Download progress:

RANNNRRRRRANNNNRRRRANNN

Cancel

After the strategy has downloaded to the control engine, we'll start the strategy running on the control
engine. For convenience, we'll start the strategy using PAC Terminal's Inspecting dialog box. A more common
method is to start the strategy while running PAC Control.

6. When the download is finished, double-click the control Engine, Cookie Controller.
The Inspecting dialog box opens showing information about to the control engine.

Inspecting: Cookie Cantraller - x

o

Control Engine: Cookie Controller at 10,20.30.40

Firmware Version: R9.5g (10:59:51 April 10, 2018 )

Volatile RAM: 63,99 MB free

Battery-backed RAM: 5.00 ME free

File Storage RAM: Mot available

Up Time: 0 days, 0 hours, 2 minutes, 37 seconds

Device Time: 11:39:06 May 11, 2018 Sync time to PC
Message Queus: 0 messages

Strategy information
Active: Cookies  { 10:12:36 June 24, 2008 )
0 chart(s) running Archive: No

[ Run |l Stop B3 Store to Flash

Alternate: NotEnabled
I» Switch

ch and Fun @& Swvitch

BN Store to Flash

Stored in Flash: Mone

Autorun: Enabled Disabled
Communication
Loop Time: 0,20 msec

Comm Errors: None

Close

In addition providing information about the control engine, this dialog box allows you to start or stop the
active strategy.

7. Under Strategy information, click Run, and then click Yes on the confirmation dialog box.
The strategy in our control engine is now running.

8. Close the Inspecting dialog box by clicking the Close.

9. Close PAC Terminal by clicking the Close button E .
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RUNNING THE PROJECT

It's time to run the project and see what our display can do.
1. Start PAC Display Runtime:

- InWindows, press the Windows Start key ) type PAC Display Basic Runtime 10.5
and then press the Enter key.

The main window for PAC Display Runtime appears. The window is empty since we haven't loaded our
project yet.

NOTE: You can also start Runtime from within the Configurator. See “Using Runtime” on page 320.

2. Inthe Runtime window, choose File > Open Project, and then navigate to the C:\Users\Public\Public
Documents\Opto 22\PAC Project\Display Basic Examples\Display\ioCookies directory.

& Open Project *

Look in:| ioCookies V| @ ? # el

* PROJECT_BACKUP
Lf cfactory.UUI

Quick access

Desktop

m
Libraries

-

This PC

@

MNetwork

File name: - | Open

Files of type: All PAC Display Projects (=LY ~ Cancel

3. Double-click the cfactory.uui project.
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PAC Display Runtime appears, displaying the project, and the Event Log Viewer window appears,
displaying messages about the PAC Display Runtime session. You might see a message showing that the
control engine is connecting to PAC Display’s scanner.

G Event Log Viewer - O *

PAC Display Runtime Basic Rl

r version: Bl0.0a Build Date:

# PAC Display Runtime Basic- cfactory.UUI = m] *
File View Alarm Security Tools Window Help

Auto Restore On Mew Message

[JEnable ‘Awaiting Connection’ messages

T T
Clear

Close Help

At the bottom of the window, you'll see the Auto Restore on New Message option selected. This means
anytime PAC Display Runtime issues a message (that is, an error or status message), the Event Log Viewer
will become the active, or topmost, window on the Windows desktop. You'll also see the Enable
“Awaiting Connection” Messages option, which lets you choose whether to display some startup
messages.

4. C(lick the Close button to close the Event Log Viewer window.

5. Start the cookie factory by clicking the on-screen Start button.

Watch the cookie dough drop out of the first tank and move down the conveyor. Notice that the cookie
dough appears to move outside of the oven and inspection stations.

6. Close PAC Display Runtime by clicking the Close button E .

Fine-Tuning the Visuals

Remember how the cookie dough looked traveling in front of the oven and inspection stations? We'll quickly
fix that by making the cookie dough bitmap graphic object the rearmost object on the screen. This way, when
it travels by the stations, it will appear to go through them.

1. Start PAC Display Configurator.

The Cookie Factory project should open automatically. If it doesn't, open the project file using the File
menu.

2. With the Select tool, click the portion of dough on the conveyor belt.
3. Right-click the mouse, and from the pop-up menu that appears choose Z-Order > Send to Back.

The graphic object will now appear to travel through the oven and inspection stations, not in front of
them.

4. Tosave the project and start PAC Display Runtime to see the display working properly, click File > Save
Project and Load Runtime.
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There are a few more things you can explore on your own. Notice that when you pass your cursor over the
setpoint boxes (SP), a black outline appears. Click one of the boxes and an attribute dialog box appears. You
can go back to the Configurator and see how this attribute was set up. You might also want to look at the tank
flap attributes.

WHAT'S NEXT?

After stepping through this chapter, you should have a handle on how simple it is to use PAC Display. By taking
the time up front to step through our short demo, you're now ready to explore the many possibilities available.

Proceed to “Chapter 3: What Is PAC Display?,” to learn more about planning and designing an operator
interface. You'll also find out more about the windows and menus that make up PAC Display Configurator and
PAC Display Runtime.

At some point you may also want to take a look at the sample projects in the “Examples”folder under
C:\Users\Public\Public Documents\Opto 22\PAC Project. You'll get ideas for how to use different PAC Display
on-screen objects and learn about various graphic objects you can use within your own PAC Display projects.
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INTRODUCTION

This chapter provides a general overview of using PAC Display, including information on what it's used for,
project structure and design, and general terms you'll encounter.

PAC Display is a software package used to create human-machine interfaces (HMIs), or operator interfaces, for
monitoring control systems. You can use PAC Display to create an HMI that will monitor a PAC Control strategy
running on an Opto 22 control engine, providing real-time and historical information to the operator about
the performance of different parts of a control system.

PAC Display works with PAC Control, a flowchart-based control language for writing control applications. For
more information on using PAC Control to create strategies, the PAC Control User’s Guide (form 1700).

InThis Chapter

Configurator and Runtime Applications page 31
PAC Display Terminology page 32
Planning a Project page 32
Configurator and Runtime Environments page 34

CONFIGURATOR AND RUNTIME APPLICATIONS

Two primary software applications make up PAC Display: PAC Display Configurator and PAC Display Runtime.

PAC Display Configurator  Use PAC Display Configurator to define and configure the draw windows,
graphic objects, dynamic attributes, logs, alarms, and sounds that make up your project, and then to connect
these objects to the variables, /0 points, PID loops, and other items defined in your PAC Control strategy. The
project also defines how the graphic objects’attributes change as this data changes.

PAC Display Runtime Use PAC Display Runtime to run the project created in PAC Display Configurator. PAC
Display Runtime communicates with the control engine running the PAC Control strategy, and animates the
operator interface by changing the attributes (for example, color, size, and position) of on-screen graphic
objects based on how the values or states of linked items in the PAC Control strategy change. If controls such
as buttons and sliders are part of the PAC Display project, the operator can use on-screen controls to change
values that appear. This is how PAC Display is used to control processes as well as monitor them.

PAC Display also includes a separate “monitor-only”version of the PAC Display Runtime application. This
version of PAC Display Runtime is functionally identical to the regular Runtime application, except that it
cannot be used to send values to a control engine. This can be useful for industrial projects where no operator
intervention is required.
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PAC DISPLAY TERMINOLOGY

The Event Log Viewer, which is part of PAC Display Runtime, starts automatically when PAC Display Runtime
is started. The Event Log Viewer displays a window that posts messages about PAC Display communication
activity. Typically, it pops up above all other windows when a message is posted, but this feature can be
disabled.

PAC DISPLAY TERMINOLOGY

Project A collection of draw windows, data logs, sounds, recipes, graphic objects, and all their attributes
that has been developed with the PAC Display Configurator. When the project is saved, several files are
created.

«  The main project file, which has a .uui extension.

«  Draw window files are created automatically for each draw window used to display graphic objects in a
project. These files have sequentially numbered file extensions starting with an uppercase W (for
example, W0001, W0002, and so on). There is a limit of 5,000 draw windows per project.

These project files, together with PAC Display Runtime, present an animated graphic objects interface for a
control system. See Appendix, “C: PAC Display Files,” for a complete list of the files that make up a PAC Display
project.

Windows PAC Display projects have one or more draw windows inside the PAC Display main window. A
draw window is essentially a blank page on which you place, draw, or edit graphic objects and other elements
that will make up your operator interface. A draw window has static attributes of position, size, and color. It
also has visual states of open, closed, or iconified. Your project design determines the number of draw
windows and their contents.

A main window is the area of the display where you can view your application. Following the conventions
used in most Microsoft Windows applications, a main window contains a menu bar that allows you to select
various command options, and a title bar that displays the full project path.

Objects Objects include draw windows, graphic objects, alarm triggers, and trends (or graphs). There are
two types of objects: static and dynamic. Static objects do not change while PAC Display Runtime is running.
Dynamic objects change appearance, or cause the appearance of other PAC Display objects to change while
the project is running.

Tags A tag refers to data items, such as variables, I/0 points, or PID loops, from a PAC Control strategy. To
access tags in a project, select the PAC Control strategies for the project. All tags in the selected strategies are
then available to PAC Display. Tags are used to animate your operator interface through connections to
graphic objects and their dynamic attributes. As the values of tags change through control engine- or
operator-driven attributes, the appearance of the graphic objects change. Tags are also used as triggers to
initiate system events such as sounds, data logging, and window configurations.

Connections A connection is made in PAC Display when a PAC Control tag is selected as either the source
that will change a graphic object, or as the tag destination for any data changes entered by the operator.

PLANNING A PROJECT

A PAC Display project is made up of a collection of windows and other elements you create and configure in
PAC Display Configurator. You add graphic objects to the windows to create an operator interface, and then
connect to I/O data and variables in the tag name database of the associated PAC Control strategy (the control
program running on an Opto 22 control engine).
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Once the windows, associated PAC Control strategy and Opto 22 control engine, and other attributes of the
PAC Display project have been set up using PAC Display Configurator, you can run the project in PAC Display
Runtime. When PAC Display Runtime is started, the project communicates with one or more control engines.
As the strategy runs on the control engine, values and states of tag names in the PAC Control strategy
database are continuously updated. This changing data in turn modifies the attributes (such as size and
position) of the graphic objects that are connected to the tag names. The end result is an animated,
continually updated display that shows the status of a control process.

Project Design

The usefulness of your PAC Display project ultimately depends on how effective the display, or operator

interface, is. To create an effective operator interface, you may want to consider these tips when you're

designing your project:

«  Know your control process, including both the theoretical operation of the process and the “hands-on”
tasks required of the operator.

« ldentify the information the end user of your project, the operator, needs to know at different points in
time. Use this information to determine what will appear on the display.
«  Consider the following ways to use and organize windows in a display:

- Asingle window can display an overall picture of the control process, and is helpful in quickly
assessing the general state of all operations.

- Individual windows can display a closer look at the operations associated with different stations. The
individual windows can contain detailed information and provide controls that would be difficult to
present in a single window.

« ldentify the parts of the operator interface where you may want to restrict access or change what
appears on the window if the operator has a different level of authority over the control process.

Project and Operator Interface Security

PAC Display supports several important security features, including operator authentication, encrypted
logging of operator actions, and password protection for project files. You can configure your PAC Display
project to:

«  Allow or deny operator access to individual graphic objects, based on configured, authorized users and
groups. (See “Security Settings for Graphic Objects and Dynamic Attributes”on page 176.)

«  Allow operator access to the HMI, as well as log all HMI use and operator actions to an encrypted archive.
(See "Runtime Setup: Security Tab"on page 297.)

«  Assign a password to the PAC Display project to prevent unauthorized users from opening it in
PAC Display Configurator. (See “Protecting a Project with a Password”on page 46.)

«  Assign a password to individual windows in a PAC Display project to prevent unauthorized users from
opening them. (See “Modifying Draw or URL Windows" on page 94.)

«  Viewalist of the users currently logged in to PAC Display Runtime. (See “Viewing Logged-In Users in
Runtime”on page 325.)

In order to design an effective security strategy for your project, review the guidance in XXXX, which
introduces you to the user and group entities, at what phase in your development and level of Ul you add
security, and gives examples of situations.

Window Design

When you create a new project, a project window and one or more draw windows will be available in the
PAC Display main window. After deciding which windows you will use for your project, consider the design of
individual windows and how they interact with other windows. This is where the organization of your
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windows comes into play. For example, you could have the operator use the Runtime menu commands to
view different windows, or you could design buttons to let an operator jump directly to related windows.

Keep in mind that the visual state of a window can affect the performance of PAC Display and the control
engine. As more windows are opened or iconified, PAC Display will gradually start to update graphic objects
more slowly. Window states (described below) also affect how the PAC Display Runtime software application
scans the control engine and updates graphic objects.

«  Anopenwindow causes Runtime to update graphic objects with data from the built-in scanner.

«  Aniconified window causes Runtime to continue requesting data from the scanner, but graphic objects
in the iconified window are not updated.

«  Aclosed window removes the associated tags from the scanner.
o SuperTrends within a window can be configured to have Runtime request data from the scanner or not.

Other choices you will have to make are whether a window should be pop-up or full-screen, whether a
window’s visual state is affected by another window, and whether a window should have scroll bars. (This last
option is particularly useful when a project is displayed on monitors of different sizes; enabling scroll bars
allows you and the operator to bring into view information that extends beyond the borders of a window.)

These and other aspects of configuring windows are covered in "Chapter 6: Working with Graphic Objects" on
page 91 and "Chapter 10: Configuring and Using PAC Display Runtime" on page 289.

Using Multiple Monitors

If your operator interface will run on a version of Microsoft Windows that supports multiple monitors
connected to one computer, an additional project planning decision is whether to design your PAC Display
project to use more than one monitor. The additional display space gained from using multiple monitors
offers advantages such as being able to keep numerous windows open permanently. However, you should
consider the additional hardware cost and extra desktop space a multiple monitor setup requires.

An important factor to also consider is that each window in a PAC Display project requires computer memory
(RAM). If you plan to display several windows on multiple monitors, the computer running the PAC Display
project may need to have additional memory installed.

Hardware and software requirements for using multiple monitors are described in “System Requirements” on
page 4.

Resetting Dialog Box Positions

If multiple monitors are used to develop a project and then the project is re-opened using just one monitor, a
dialog box might open out of view off the edge of the screen. If you can't find a dialog box that you think
should be open, select View > Reset Dialog Positions. This resets the following dialog boxes to appear in the
middle of the active display window: Alarm Points, Application Managers, Control Engines, Historical Logs,
Event Log Viewer, Sounds, Window Managers, and the Toolbox.

CONFIGURATOR AND RUNTIME ENVIRONMENTS
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As mentioned previously, PAC Display is composed of two software applications, Configurator and Runtime.
This means there are two environments in which you will use PAC Display. In learning about the windows that
make up PAC Display, we will first discuss the main components of the Configurator environment, and then
explore the Runtime environment.

PAC Display uses standard Microsoft Windows conventions, so as you use Configurator and Runtime, you'll
recognize familiar window elements such as title bars and the menu bar, as well as controls such as the
Minimize, Maximize, and Close buttons.
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NOTE: If you need more information on working with Microsoft Windows, refer to the documentation from Microsoft
and your computer manufacturer.
Configurator Main Window

When you first start PAC Display Configurator and create a new project and select a control engine, your
screen should look similar to this:

¥ PAC Display Configurator Professional - Beta.UUI

File Edit WYiew Style Text Configure Tools Window Help

(Untitled)

B Tools

The Configurator main window consists of a title bar and a menu bar, along with other standard Windows
elements, and contains the toolbox and one or more draw windows.

Title Bar ¥ PAC Display Configurator Professional - Beta.UUI |:||§||X|
Menu Bar File Edit View Style Text Configure Tools ‘Window Help

# Tools
Toolbox

(Untitled)

Draw
Window

Hiding the Menu Bar

If you need additional space to position draw windows, you can hide the menu bar to use the space it
occupies. If you do this, note that you won't be able to access commands on the menu bar.

To hide the menu bar, do one of the following:
«  SelectView > Hide Menu Bar
o Press Esc on the keyboard.
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To view the menu bar again, press Esc on the keyboard.

Configurator Toolbox

The toolbox contains a set of graphical icons that represent tools you can use in the Configurator. Click any
tool to select it, and then use it in the draw window. Also, below the graphical icons, the toolbox displays
coordinates and object dimensions to aid you in your drawing tasks.

For descriptions of the tools and how to use shortcut keys, see “Using the Graphic Tools and Shortcut Keys”on
page 101. For more details about any tools available in the toolbox, see “6: Working with Graphic Objects”on
page 91.

:ﬁ]Tﬂols *
| ][] {o] il A VAY
Bugl A [iyc ] 25 |
(Ok]| [ el 2

Toolbox Coordinates —+¥: 601  Y: 433

Object Dimensions ~ —-¥: H:

If you want to use the space the toolbox occupies, you can hide the toolbox by selecting View > Hide Toolbox.
To open the toolbox again, select View > Show Toolbox.

Toolbox Coordinates and Object Dimensions

Just underneath the tools, you can see the toolbox coordinates and object dimensions. The coordinates show
the cursor’s position (in pixels) when it is over a draw window. The X: and Y: coordinates are read with the axis
zero-points at the top-left corner of the draw window. If you create an object, the object’s dimensions (width
and height) are shown next to W: and H:, respectively.

Configurator Draw Windows

Configurator draw windows are where all graphic objects for your PAC Display project are drawn and edited.
They contain the graphic objects and other elements you work with to create your display.
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4] PAC Display Configurator Basic- SuperTrendDgma.UUI - O *
File Edit View Style Text Configure Tools Window Help
_d SuperTrend Examples @

SuperTrend with Real-Time and Historical Modes
1.000

—0.400

M4 4 4

» o i & [Q] &[] I siNE_vALUE

I

SuperTrend -- Real-Time Only

SuperTrend -- Historical Only
1]

M« o RG] 8 Iz
B2, | R SINE_VALUE v

Redrawing an Active Draw Window

Labeled SuperTrend |

You can redraw an active draw window in PAC Display Configurator by selecting View > Redraw. Incomplete
graphic objects (such as an incomplete polygon) in the draw window are removed when you select this

command.

Runtime Main Window

When you start PAC Display Runtime, what appears on screen should look similar to this:
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Title Bar —| 4
Menu Bar File View Alarm Security Tools Window Help L‘\’
& 52
Runtime : S
Main SuperTrend with Real-Time and Historical Modes
. 1.000 1
Window | 5
—0.400 1 ] ] - - — — =1

Project AaTa) -

Windows & Event Log Viewer = O *
|2I318.-"'35.-'D'F 16:37:57 File Access: =>Initial Writing of file:
C:\Users\Public\Documents\Opto 22\PAC Project 9.6\Display Basic
Examples\Display‘\SuperTrend\RH050716.T0002
2018/05/07 16:37:57 PAC Display Buntime Basic R9.6g Build Date: Feb

Event tOg M4 44 4 S SR | QE 22 2018 OptoOPC Server version: R9.6a Build Date: 02/22/2018

Vievver ——2818/05/07 16:37:53 File Rccess: =>Initial Writing of file:

C:\Users\Public\Documents\Opto 22\PAC Project %.é&\Display Basic
Examples\Display‘\SuperTrend\RH050716.T0000

=]
2018/05/07 16:37:58 File Rccess: =>Initial Writing of file:
C:\Users\Public\Documents\0Opto 22\PAC Project 9.&\Display Basic

2

w

4]

SuperTrend -- Real-Time Only

Examples\Display\SuperTrend\RH050716.T0003

Auto Restore On New Message

] Enable ‘&waiting Connection’ messages Save ta File

Clear

Cloze Help

The Runtime main window consists of a title bar, a menu bar, other standard Windows elements, project
windows, and the Event Log Viewer. Much like a frame, Runtime’s main window contains all the elements and
actions that occur during Runtime use.

If you need additional space to position project windows and other windows in Runtime, you can hide the
menu bar to use the space it occupies. If you do this, note that you won't be able to access commands on the
menu bar.

Changing How the Main Window Appears in Runtime

You can configure the main window so that it appears without a title bar or menu bar, and also change several
other settings. See "Chapter 10: Configuring and Using PAC Display Runtime" on page 289 to learn how to
configure elements of the main window.

Hiding the Menu Bar

While working with a PAC Display project in Runtime, you can gain additional space on your screen by hiding
the menu bar. To hide the menu bar, do one of the following:

+  SelectView > Hide Menu Bar.
»  Press Esc on the keyboard.

To view the menu bar again, Press Esc on the keyboard.

Runtime Project Windows

After you've opened a project in Runtime, you see the project windows.
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42| PAC Display Runtime Basic- SuperTrendDemo1.UUI - O *
File View Alarm Security Tools Window Help
b2l 3

1.000

—0.400

SuperTrend with Real-Time and Historical Modes

I

SuperTrend -- Historical Only

(11
M« o RG] 8 Iz
2| I SINE_VALUE >

Labeled SuperTrend |

Project windows are the Configurator draw windows that you created for the project. Notice that when you
launch your project in Runtime, these windows are the same size and in the same relative position as when
you closed the Configurator project. (Depending on certain configuration options, the relative positions of the
windows may differ slightly from those in the Configurator project.)

Project windows are composed of a title bar and a workspace. The title bar displays the name of the window,
and the workspace contains all of the graphic objects work you did in the Configurator.

Configuring How Draw Windows Appear in Runtime

You can define how a draw window appears in PAC Display Runtime, including its visual state (closed,
iconified, or open), relative position, and other settings. See “Using Draw Windows and URL Windows" on

page 91 for instructions and more information.
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Runtime Event Log Viewer

The Event Log Viewer contains a list of system errors and messages that occur during Runtime. The most
recent messages appear in the list, but when there are more messages than can reasonably fit, scroll bars
appear so that you can view older messages.

Event Log Viewer - O *
al g S

2018/05/07 16:37:57 File Access: =>Initial Writing of file:
C:\Users\Public\Documents\Opto 22\PAC Project 9.6\Display Basic
Examplesh\Display'SuperTrend\RHO50716.T0O002

2018/05/07 16:37:57 PAC Display Runtime Basic R9.6g Build Date: Feb 22 2018 OptoOPC
Server wversion: R9.6a Build Date: 02/22/2018

2018/05/07 16:37:58 File Access: =>Initial Writing of file:
C:\Users\ Public\Documents\Opto 22\PRC Project 9.6\Display Basic
Examples\Display\SuperTrend\RHOS0716.TO000

2018705707 16:37:58 File Access: =>»Initial Writing of file:
C:\Users\Public\Documents\Opto 22\PAC Project 9.6\Display Basic
Examples\Display'\SuperTrend\RHOS0716.T0003

Auto Festore On New Message

] Enable ‘Swaiting Connection’ messages Save to File

Clear

Cloze Help

You can also double-click any message to view its entire contents, if they are not already completely visible.
The Event Log Viewer can be manipulated like any other standard window.

The Auto Restore on New Message option sets whether the Event Log Viewer dialog box automatically jumps
to the foreground when a new event message is received. The Enable “Awaiting Connection” messages option
is used to hide or display common startup messages.
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4: Working with Projects

INTRODUCTION

This chapter explains how to work with projects. You'll find out how project files are organized, and then learn
how to create, open, and save a project. An optional, advanced procedure for customizing how PAC Display
Configurator starts is also presented.

In This Chapter

How Projects Are Organized page 41
Creating a Project page 42
Protecting a Project with a Password page 46
Opening a Project page 47
Saving a Project page 48
Archiving a Project page 49
Exporting a Project page 49
Closing a Project page 50
Customizing Project Properties page 50
Creating a Batch File to Start and Run a Project.......vececee. page 51
Configuring Screen Snapshots page 52
Combining PAC Display Projects page 54
Configuring an ODBC Data Source page 55

HOW PROJECTS ARE ORGANIZED

A PAC Display project is a collection of all the files created in PAC Display Configurator that define one operator
interface. The project includes the windows you create, bitmaps that appear in them and their attributes, and
any other elements you set up. See Chapter 3: What Is PAC Display? to learn more about the various
components of a PAC Display project. Also see "Appendix C: PAC Display Files” for a complete list of files
associated with PAC Display.

Each PAC Display project should be located in its own directory. You'll find that separate directories make
keeping track of any one project’s files easier, especially when you back up the project or copy the files to disk.
Though not recommended, multiple projects can be stored in the same directory if necessary.
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CREATING A PROJECT

To create a new project:

1. Start PAC Display Configurator.

2. (lick File > New Project (or press Ctrl+N).
The New Project dialog box appears.

i:] Mew Project @
T o

QQ | .« Display » ioCookies » v|¢,|
Organize « MNew folder ==« 0 l@l
' Favorites — Documents library

Bl Desktop ioCookies

4. Downloads oy

Arrange by:  Folder ~

m

=] Recent Places
. PROJECT_BACKUP

4 Libraries 7 cfactory.uul

3 Documents
J‘. Music

il PAC Project
= Pictures

EE videos

- |4 i | b

File name: ~| [l PAC Display Projects ("uup ~ |

[ open |v] | cancel |

Dialog boxes in PAC Display follow common Microsoft Windows conventions, so you'll recognize familiar
items such as the file list, the Up One Level button, and the File name field.

NOTE: If you need more information on how to use dialog boxes or other common parts of Microsoft Windows,
refer to the documentation from Microsoft and your computer manufacturer.

3. Type a project name in the File name field.
When you're done creating the new project file, this name is automatically appended with the suffix .uui,
indicating a PAC Display project file.
4. If you want to save your project in a new directory, follow the sub-steps below, and then continue with
the next step.
a. (lick the Create New Folder button.
The new folder you created appears in the list of files and folders. The name of the new folder should
be highlighted, meaning you can enter a new name for the folder.
b. Type a new name for the folder, preferably one that includes the project name.
c. Double-click the new folder to open it.
5. Click Open to create the project.

!For instructions to start PAC Display Configurator, see page 7.
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Normally, the Control Engines dialog box opens next. However, if you have selected a directory that
already includes a project, a warning message appears, and you'll be allowed to try again.

8" Control Engines

M arme

6.
engine you want to connect to.

|.P. Address

In the Control Engines dialog box, click Add to locate a PAC Control strategy running on the control

‘ﬂ Strategy File Mame Selection

==l

o
Ou | . « Display » ioCookies »

Organize « MNew folder

| »

W Favorites
Bl Desktop
4. Downloads

m

=] Recent Places
4 Libraries

3 Documents

J’ Music

il PAC Project

[ Pictures

EE videos

Search ioCookies

v|¢’|

Documents library

ioCookies

MName

. PROJECT_BACKUP

L] i |

Arrange by

o
0 @

-

Folder «

3

File name:

~ | [PAC Control Strategy (*.idb)

)

Com

| Concel |

running on the control engine you plan to select.
(Pro only) To locate a legacy OptoControl strategy, click the drop-down menu in the Files of Type dialog

box and select “OptoControl Strategy *.cdb”

NOTE: The next few steps are for PAC Display Basic. To configure the control engine using PAC Display Professional,
see "Final Controller Configuration with PAC Display Professional” on page 65.

8.

Select the strategy file and click Open.

In the Strategy File Name Selection dialog box that opens, navigate to the PAC Control strategy that is
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The strategy you selected appears in the Strategy field of the Control Engine Properties dialog box.

Control Engine Properties *

Frimary Control Engine

M ame: | | Browse...

Backup Control Engine

M ame: | | Browse...

Strategy: |c::\users\public\documents\opto 22pac proiec| Browse...

Make Path Relative to Project [

Cancel Help

Now you need to select the primary control engine from which PAC Display will receive 1/0 point
information. Remember that this control engine must be running the strategy you selected.

9. (lick the Browse button in the Primary Control Engine group.
The Select Control Engine dialog box appears.

Select Contrel Engine

Configured Control Engines:

Cookie Controller

oK Cancel

All control engines that have been configured to connect to your PC are listed, whether or not they are
associated with your strategy. If you previously configured a control engine for use with PAC Control, for
example, it would appear here, even if it didn't appear earlier when you opened the Control Engines
dialog box.

NOTE: If the control engine you want to use doesn’t appear in the Select Control Engine dialog box, you must
connect and configure this control engine to make it available. Instructions for adding, modifying, and deleting
control engines appear in Chapter 4, “Working with Control Engines,” in the PAC Control User's Guide (form
1700).

10. To choose a control engine that connects with PAC Display, select its name and click OK.
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11.

12.

13.

14.

CHAPTER 4: WORKING WITH PROJECTS

The primary control engine you have added appears in the Control Engine Properties dialog box.

Contrel Engine Properties x

Primary Contral Engine

Mame; |I:00kiel:0ntm||er | I Browse... I

Backup Contral Engine

Mame; | | Browsze. .

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl Browse. ..

Make Path Relative to Project [

0K Cancel Help

To designate a backup control engine, click Browse in the Backup Control Engine group, choose a control
engine from the list and click OK.

The backup control engine you have added appears in the dialog box.

Contrel Engine Properties \E\

Primary Control Engine

Mame:  Cookie Contraller

Backup Contral Engine

Marme: | Backup Contraller

Strategy:  ohuzershpublichdocumentshopto 22hpac projec

Make Path Relative to Project [

[ Ok ” Cancel ][ Help ]

A backup control engine is used automatically in case the primary control engine fails or becomes
unavailable. Control remains on the backup controller until the backup controller goes offline; control is
not automatically returned to the primary control engine when it becomes available again.

To change the path of the strategy to be relative to the current PAC Display project, select Make Path
Relative to Project.

This allows the project to be more easily transferred to other PCs that don't have the exact same file
structure.

When all the parameters in the Control Engine Properties dialog box are correct, click OK to save your
settings and close the dialog box.

The control engine appears in the Control Engines dialog box.

NOTE: To complete setting up the control engine, you need to select primary and secondary scanners. For more
information, see “Configuring the Scanner”on page 67.

Click OK.
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When you click OK in the Control Engines dialog box, the project is created, and a draw window and
toolbox appear within the Configurator’s main window.

] Tools (=]
N[ m]=][e]ia] A VAY

@)

174 Y. &b
W H:

The untitled draw window is where you will begin drawing your operator interface. The toolbox contains
several icons representing graphic object drawing tools. For more information, see "Chapter 6: Working
with Graphic Objects" on page 91.

Extending a Project Across Multiple Monitors

If you are designing your PAC Display project to use multiple monitors connected to the same computer, after
creating the project simply extend PAC Display Configurator's main window across the monitors you want to
use.

PROTECTING A PROJECT WITH A PASSWORD

46

NOTE: For additional security features, see:

«  “Security Settings for Graphic Objects and Dynamic Attributes”on page 176 to allow or deny operator access
to individual graphic objects, based on configured, authorized users and groups.

«  "Modifying Draw or URL Windows"on page 94 to assign a password to individual windows in a PAC Display
project to prevent unauthorized users from opening them.

«  "Runtime Setup: Security Tab” on page 297 to allow operator access to the HMI, as well as log all HMI use
and operator actions to an encrypted archive.

«  “Viewing Logged-In Users in Runtime”on page 325 to view a list of the users currently logged in to PAC
Display Runtime.

You can protect your PAC Display project with a password to prevent others from opening and modifying the
project using PAC Display Configurator. (The project can still be opened and run in PAC Display Runtime.) The
maximum length for a project password is 255 characters.

CAUTION: Make sure to keep your password in a safe place. If you forget your password, you will not be able to open
your project in PAC Display Configurator.

To protect your project with a password, do the following:
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1. Click File > Password Protect Project.
The Enter Project Password dialog box opens.

Enter Paszword 4

Enter Pazsword: I:I
Confirm Passwoard: I:I
Cancel

2. Type a password in the Enter Password field.
3. Type the same password a second time in the Confirm Password field.
4. (lick OK.

Now, your PAC Display project cannot be opened in PAC Display Configurator without first entering the
password.

OPENING A PROJECT

To open an existing project in PAC Display Configurator or PAC Display Runtime, follow these steps:
1. Click File > Open Project.

(Configurator only) If you already have an open project, you will be asked if you want to save it. Click Yes
or No, or click Cancel to close the Save Project dialog box.

The Open Project dialog box appears.

Open Project

Laok jr: | |C5) PAL Display B asic Examples V| <) 5 sl FEF

IC5) Alarming

| ) Examplel
My Recent [inCackies
Documents |25 5uperTrend

@ () %Plot

Desklop

D

My Documents

My Computer

File name: | A | [ Open ]

My Network | Files of type: | &1l FAC Display Projects [ UUI) v| [ cancel |

Navigate to the folder where your project is located.
3. Double-click the file in the list to open the project. (You can also select the file, and then click Open.)
The project opens with any windows positioned just as you last left them.

NOTE: Ifthe project has been protected with a password, the Enter Password dialog box appears. Type the password
for the project, and then click OK.
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@ Converting an Older Project to PAC Display

A project created in Opto 22's earlier OptoDisplay software can be converted into a PAC Display project using
conversion utility software included with PAC Display. Converting an OptoDisplay into PAC Display can save
much time and effort that would otherwise be needed to recreate your older project in PAC Display. For
converting an OptoDisplay project to PAC Display, see the FactoryFloor to PAC Project Migration technical note
(form 1692).

SAVING A PROJECT

There are three options for saving a project in PAC Display Configurator: Save Project, Save Project As, and Save
Project and Load Runtime.

Save Project

To save your project to the same file name you opened or created, click File > Save Project (or Ctrl+9). If there
have been no changes to the project since you last saved it, no messages appear when this save occurs.

Save Project As

To save the project with a new name, click File > Save Project As (or Shift+Ctrl+S).
2. Inthe Save As dialog box, type a project name in the File name field.

When you're done saving the project file with a new name, this name is automatically appended with the
suffix .uui, indicating a PAC Display project file.

3. If you want to save your project in a new directory, follow the sub-steps below, and then continue with
the next step.

a. Click the Create New Folder button.

The new folder you created appears in the list of files and folders. The name of the new folder should
be highlighted, meaning you can enter a new name for the folder.

b. Type a new name for the folder, preferably one that includes the project name.
c. Double-click the new folder to open it.
4. C(lick Save to save the project with a new file name.

Save Project and Load Runtime

To save your project to the same file name you opened or created, and then start the project in PAC Display
Runtime, click File > Save Project and Load Runtime. This option is particularly useful when you are testing a
project and switch often between the Configurator and Runtime components.

SAVING VERSIONS OF A PROJECT

When developing a PAC Display project, you can save progressively numbered versions of the project files (for
example, MyProject_01, MyProject_02, etc.). Having these saved versions of your project as you develop it can
be valuable if you need to return to an earlier version, or need to trace the steps you took while building the
PAC Display project.

To automatically create a numbered version of modified PAC Display project files each time you save the
project, click File > Configurator Options. Then, in the Configurator Options dialog, select Auto Increment
Version on Save. Project (UUI) and window (WXX) files will be copied, renamed with a version number, and
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placed in the same directory as the current project. Other project files such as background bitmap images and
similar graphic objects are not copied.

ARCHIVING A PROJECT

To archive the current project:
1. Click either File > Archive Project or File > Archive Project and Email to Opto 22.

The project is archived to the current project directory with all the files necessary to transfer the project to
another computer.

If you choose Archive Project and Email to Opto 22, the project is attached automatically to an email
addressed to Opto 22 Product Support. In order for Product Support to better assist you, a message will
advise you to use PAC Control to archive the strategy files to submit along with the PAC Display archive.

When the archiving is finished the following dialog box appears.

Project Archived

<P Project has been archived as:
L] C:\Program FilesiOpto22\PAC Project &, 2\Display Pro
Examplest,super Trend'DisplaySuper TrendDemo 11 UI_Archive_2010-03-31_15-00-02.zip

Do wou wank ko open your File browser to this location?

2. (Click Yes to open the archive’s directory.

NOTE: PAC Control strategy files referenced by the project are NOT automatically archived. Use PAC Control to archive
the strategy files.

A project archive file uses the following naming convention:
XXX_Archive_Year-Month-Day_Hour-Minute-Second.zip

where XXX = name of the PAC Display project.

Example: SuperTrendDemol.UUI Archive 2008-03-31 15-00-02.zip

This represents a project named SuperTrendDemo1 archived on March 31, 2008 at 3:00:26 pm.

EXPORTING A PROJECT

If you want to compare one project to another—perhaps to see what has changed—you can export each
project to a text file and then use a file comparison utility (such as WinMerge) to compare the files.

Each exported text file is formatted for easy reading and includes all the information about the project,
including windows, graphic objects, dynamic attributes, alarm points, data logs, recipes, and so on.

1. Click File > Export Project.

2. Inthe Export Project As dialog box, navigate to the destination folder and enter a name for the file.
3. Click Save.

4. Repeat the steps for the next project, and then open the text files in your file comparison utility.
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CLOSING A PROJECT

To close the current project you have open, click File > Close Project. If you've modified the project since it was
last saved, you will be asked if you want to save those changes before closing the project.

Only one project can be open at any one time in PAC Display. Creating or opening a project automatically
closes any currently open project first. When this happens, you will be asked if you want to save changes if
they haven't been already saved.

CUSTOMIZING PROJECT PROPERTIES

NOTE: This procedure is not required to run PAC Display Configurator or Runtime, or to open projects.

After you've loaded a project for the first time, you'll notice that every time you start PAC Display Configurator,
the application knows which project to load, what sizes the windows are, and several other startup conditions.
At some point, you may want to change these initial PAC Display conditions. To do so, you can run the
Windows system Registry Editor utility to modify these conditions.

CAUTION: Use the Windows Registry Editor carefully. It is strongly recommended that you make a backup copy of
your Windows Registry before continuing with this procedure. Without a backup copy, if you delete the wrong
properties and cannot return the Registry to its original state, application and system files can become unusable and
will have to be reinstalled.

1. From the Windows Start menu, select Run.
The Run dialog box appears.
2. Inthe Open field, type regedit and thenand press Enter.
The Registry Editor window appears. You should see several folders listed under My Computer.

3. Open the HKEY_CURRENT_USER folder, and then continue to open each of the following sub-folders as
they appear:

- Software

- Opto22

- PACDisplay

- Configurator or Runtime
- Startup
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In the Start up folder you'll see several properties defined, as shown below.

% Registry Editor,

File Edit WYiew Favorites Help

(3 Mediafour || Hame Type Data
(3 Micrasaft W (Default) REG_SZ {walue not set)
(3 Mozilla [ab] plistPas REG_52Z 356,166,458,346
g :;fﬁ::@m i [ab)appPas REG_SZ 301,134,421,365
& opBC puting CIistPos REG_SZ 272,105,366,352
&0 optozz [2b] REG_SZ 7,13,421,372
D iaCantral | REG_DWORD 0x0000024b (S87)
=] ioDisplay Iitasini REG_DWORD 0X00000000 {0
=23 Configurato MRU oA EilachCinko2winBesiack Software
3 ElRI Delete these properties ~ [*ft"are
{2 Runtime oftware
(21 ioManager to reset oftware
[ ioTerm PAC Display's startup 4 Displ
[Z3 OptoOpcServer Conﬂguration, oftware
(3 paim oftware
(23 Policies oftware
3 PureText C:\Program Files\OpkoZ22iioProject Software

(21 RealMetworks

[Z software

(21 TechSmith

(21 u.5. Robaotics

{2 vB and YEA Progran

C:\Program Files\OpkoZ22iioProject Software
000000001 (13

301,132,421,372

C:\Program Files\OpkoZ22iioProject Software

D Wintertree REG_DWORD 000000327 {307}
(2 WinZip Computing REG_5Z 301,132,421,372
D Mero REG_DWORD 000000028 {40)
D UNICODE Program Grou % REG_DWORD 00000007c {124)
< | ¥ < 1 s

My ComputeriHKEY _CURRENT _IUSER! Software)OptoZ22lioDisplayt ConfiguratoriStart up

4. Select the following properties:

- Height

- Maximized

- Project Name

- Width

- X

- Y

Do not select the (Default) property.
5. Click Edit > Delete, or press Delete on the keyboard.
6. Click Registry > Exit to close the Registry Editor.

PAC Display has now been initialized to its original startup conditions, and will open as if no project had ever
been loaded.

CREATING A BATCH FILE TO START AND RUN A PROJECT

You can use a batch file to start PAC Display Runtime and run a project. The batch file you create can be
associated with an icon on the Windows desktop. This is a convenient way for an operator to quickly start a
PAC Display project without having to search for the project file in a dialog box.

To create a batch file that opens a project in PAC Display Runtime, do the following:
1. Openan empty text file using Windows Notepad or another text editor.
2. Type Windows command prompt commands that perform the following tasks:
—  Change drives to the drive containing the project.
—  Change directories to the directory containing the project.
- Start PAC Display Runtime.
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3. Save the file using the .bat file extension.

Example Batch File

C:
cd “C:\Program Files\Opto22\PAC Project 10.5\”
start DisplayR.pro.exe "c:\Opto 22\Projects\myproject.UUI" 10

Here’s what each line of the batch file does:
«  Thefirst line changes drives to the C: drive.
«  Thesecond line changes the current directory to C:\Program Files\Opto22\PAC Project 10.5\

«  Thethird line starts PAC Display Runtime and loads the project located at
C\Opto 22\Projects\myproject.UUL.
The number 10 at the end of the third line delays the start of PAC Display for 10 seconds.
This can be helpful when you want to make sure some other process or program is running before PAC
Display starts.

Once you have created the batch file, you can make a Windows shortcut for your batch file and place it on the
Windows desktop for easy access. Alternately, you can place the shortcut in the Windows Startup folder so the
project starts to run when the computer starts up.

CONFIGURING SCREEN SNAPSHOTS

A Snapshot is a whole-screen capture saved as a bitmap file. You can use snapshots to review what occurred
in Runtime over a period of time, or to capture a triggered event. Snapshots are taken according to a time
interval that you configure. You can use triggers to start and stop the process.

There are four basic ways to configure snapshots:

Time Interval Only: With no start or stop trigger, snapshots start to be taken when Runtime has fully loaded
the project and starts displaying data. Snapshots continue to be taken at the specified interval until Runtime
closes the project or it is shut down.

Start Trigger Only: When the start trigger is activated, snapshots are taken at the specified interval until
Runtime closes the project or it is shut down.

Stop Trigger Only: With no start trigger, snapshots start when Runtime has fully loaded the project and starts
displaying data. Snapshots continue to be taken at the specified interval until the stop trigger is activated.

Start Trigger and Stop Trigger: Once the start trigger is activated, snapshots are taken at the specified
interval until the stop trigger is activated.

To configure snapshots:
1. Click Configure > Snapshots.
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2. Inthe Snapshots Configuration dialog box, click New.

Ml Snapshots Configuration El
Snapshats
MHew
Delete
Configuration
Mame; || |

Save Snapzhots To: |I::'\F'mgram Filez'\Opto22hPAC Project 9.| Browse. ..

Save Snaphat Every | 0 | | Seconds hd |
Start Trigger
| | Clear
Stop Trigger
| | Clear
Add Cahicel
Ok [ Cahicel ] [ Help

3. Enteraname for the snapshot.

4. For Save Snapshots To, choose the location where the snapshots will be placed. Use either the default
setting (the Project directory), or click Browse to choose a different location.

5. For Save Snapshot Every, enter a time interval for the snapshots in the range of 1 — 255 Seconds, Minutes,
or Hours.

If no start or stop trigger is configured, snapshots will be taken at the specified interval beginning when
Runtime has fully loaded the project and starts displaying data until Runtime closes the project or the
project is shut down.

6. If you want to use a trigger to activate snapshots, click Start Trigger to launch the Configure Snapshot
Trigger dialog box.

Configure Snapshot Trigger El

Tag

Mame:

Setup by Dizcrete Current % alue
(%) Current Value uli;

[ 1] 4 ][ Cancel H Help ]
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—  Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC controller name tag.

- Select Discrete or Current Value in the Setup By group.

Discrete sets, clears, or toggles the tag’s on or off state. Current Value sets the tag value. To set a
Current Value, select Set or Offset in the Current Values group and then enter a tag value.

- (lick OK to close the dialog box.

7. Ifyou want a stop trigger, click Stop Trigger, and then configure the stop trigger in the same manner as
for the Start Trigger.

8.  On the Snapshots Configuration dialog box, click Add.

The Snapshot configuration appears in the list.
9. Repeat the previous steps for each snapshot configuration you want to create.
10. Click OK to close the dialog box.

Modifying a Snapshot
To modify an existing snapshot, click its name in the list, and make your changes. When finished, click the
Moadify link to accept the changes, or click Cancel to cancel any changes

Snapshot Files in Runtime

In Runtime, the snapshot files are saved with the following format:

[Snapshot Name]_YYYY_MM_DD_HH_MM_SS.bmp

where:

YYYY = year
MM = month
DD = day

HH = hour
MM = minute
SS = second.

If the name of the snapshot contains an illegal characters (such as “&”), the illegal character is replaced with an
underscore. For example, “Tank & Level 10 seconds”becomes “Tank_Level 10 seconds.”

COMBINING PAC DISPLAY PROJECTS

54

If you want to combine PAC Display projects, first archive each of the PAC Control strategies and PAC Display
projects to your hard drive as described below. This allows you to recover the original versions if there are
problems at some point. Then use the import and export features in PAC Display to combine projects. If you
are integrating multiple PAC controllers into a single system, make sure that each control engine and each
strategy has a unique name.

The best way to share data between multiple PAC controllers is with the scratch pad using the I/0 Unit—
Scratch Pad Commands. For more information, see “Programming with Commands”in the PAC Control User’s
Guide (form 1700).

Archiving and Renaming Multiple PAC Control Strategies

NOTE: See also, Archiving Strategies in the PAC Control User’s Guide (form 1700).

1. Click File > Archive Strategy to archive each strategy.
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2. Make sure each strategy has a unique name.
To re-name a strategy, open it in PAC Control and click File > Save Strategy As.
3. Make sure each control engine has a unique name to distinguish it from other controllers.
To rename a control engine, open a strategy in PAC Control and click Configure > Control Engines.

4. Ifyouchange the name of a strategy or control engine, you'll need to point the PAC Display project to the
new strategy name or control engine name as follows:

a. Start PAC Display in Configure mode and click Configure > Control Engine(s).
b. Select the control engine, click the Replace button, and then click OK.

c. ClickTools > AutoCorrect Tags.
d

When you download the updated PAC Control strategy, you will need to run the updated PAC
Display project. It is important to keep your PAC Display project in sync with the strategies that are
running on the control engines.

NOTE: For more information, see “Configuring Control Engines”on page 61.

5. Click File > Archive Strategy to manually archive the strategy.

NOTE: In PAC Control you can automatically archive a strategy to your hard drive or to the controller. This helps
you track changes during development and provides a backup in case of a failure on the control engine or
computer. For more information, see the PAC Control User’s Guide (form 1700).

Archiving and Combining PAC Display Projects

Open your project in PAC Display Configurator and click File > Archive Project.
2. ClickTools > AutoCorrect Tags to identify any existing problems.

3. Fixany problems in your project before proceeding. If you make changes in the project, save it and then
make another archive.

4. Open the main project (the one you are adding other projects to), and then add each of the other control
engines and strategies.

In order to do this, each strategy and control engine must have a different name as described in the
previous section.

5. Save the main project.

To combine your projects, see “Using Draw Windows and URL Windows"on page 91 and “Importing,
Exporting, and Saving Windows" on page 98.

Make sure to run Auto Correct tags and the save the project with each window you import.
7.  When you have finished combining projects, run AutoCorrect Tags again to check for any problems.

CONFIGURING AN ODBC DATA SOURCE

(Pro only) Before you can exchange SuperTrend, historical, Runtime operator data, or recipe data with a
database, you must use Windows to configure one or more ODBC connectors. Then, in PAC Display, you select
the ODBC connector to use for the project.

ODBC connectors tell PAC Display and Windows how to send data to and from a database. Supported
databases include MySQL, Microsoft Access, and Microsoft SQL Server. If your database is Microsoft Access, see
also “Granting Privileges in Microsoft Access”on page 58.

Also see the following sections:

«  "Saving a SuperTrend to a Database”on page 208

«  “Logging Historical Data to a Database” on page 220

«  "Configuring a Runtime Operator Log Database”on page 314
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»  “Logging a Recipe File to or from a Database” on page 257

To configure an ODBC connector in Windows and an ODBC data source in PAC Display:
1.  In Windows:

a. Pressthe Windows Start key |&#4, type ODBC Data Sources (32-bit) andthen pressthe
Enter key to open the Windows ODBC Data Source Administrator (32-bit).

Configure ODBC %5 ODBC Data Source Administrator (32-bit) X

connectors on the
System DSN  File DSN  Dri Traci Connection Pooli About
User DSN tab. / em ile vers Tracing Connection Pooling  Abo

User Data Sources:

Name Platform  Driver Add...
dBASE Files 32bit Microsoft Access dBASE Driver (.dbf, *nd
Excel Files 32bit Microsoft Excel Driver ("xds, “xdsx, “xdsm, Remaove

M5 Access Database 32bit Microsoft Access Driver (*mdb, * accdb)
Configure...

An ODBC User data source stores information about how to connect to the indicated data provider. A
m;| User data source is only visible to you and can only be used on this computer.
et

Cancel Foply | [ Hap

b. On the User DSN tab, click Add to open the Create New Data Source dialog box.

Create Mew Data Source *

Select a driver for which you want to set up a data source.

Name (o

L \
- 1

Ll Driver do Microsoft Access (*mdb) 1
Driver do Microsoft dBase (*.dbf) 1
Driver do Microsoft Excel{”xls) 1
Driver do Microsoft Paradox (*.db ) 1
Driver para o Microsoft Visual FoxPro P
Microsoft Access dBASE Driver (*.dbf, *ndx, *mdx) 1

v

< >

< Back . Cancel

c. Highlight the appropriate driver for your data source, and then click Finish. A dialog box opens for
configuring the ODBC connector. To configure the driver, you may need to refer to the driver’s user
documentation.

NOTE: If you're using Microsoft Access and you don't see the Access driver in the list, you'll need to download the
driver and then install it.

- For Access 2007, download the driver from:
https://www.microsoft.com/en-us/download/details.aspx?id=23734

- For Access 2010 or higher, download the driver from:
https://www.microsoft.com/en-us/download/details.aspx?id=13255
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For example, here’s a dialog box for the MySQL connector:

MySQL Connector/ODBC Data Source Configuration @

A
My QL =y
Connector/ODBC .

Connection Parameters

Data Source Name: |

Description:
@ TCP/IP Server: Port: 3306
Mamed Pipe:
User:
Password:
Database: - Test
o

d.  When you've finished configuring the driver, click OK to save the settings.
2. InPACDisplay Configurator:
a. Inthe menu bar, click Configure > ODBC Data Source.
The Select ODBC Data Source dialog box opens.
The field below “ODBC Data Source”shows the data source configured for the project.
If no ODBC data source is configured, the field shows “None.”

Select ODBC Data Source
ODBC Data Source:
Mone =
Uszername:

Pazsword:

[ n] ][ Cancel ][ Help ]

Under ODBC Data Source, select the ODBC connector that is configured for the target database.
Enter any required username and password.
d. To test the connection to the ODBC Data Source, click the Test button.
If the ODBC connector is set up properly, a pop-up message says, “Successfully connected to
Database!”
e. (lick OKto save the settings and close the dialog box.

n

TIP:When you configure an ODBC data source, PAC Display creates an internal link between the project and the ODBC
connector. If you ever need to temporarily or permanently disassociate your PAC Display project from the ODBC data
source, select “None” as the data source.
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A warning message reminds you to find all objects in the project that are configured to use the data source,
and then reconfigure the object to use a file as the source (or destination, as the case may be). Otherwise, if
the data source isn't accessible during Runtime, an error message will be written to the Event Log.

ODBC Data Source Change *

WARNMIMG: Selecting Mone will break the links in ohjects configured to
! use the current data source.

To prevent errors during Runtime, reconfigure the objects to use afile

as the data source.

How PAC Display Handles Database Connections

Each time you open a project, PAC Display checks to see if an ODBC database source has been configured. If
so, PAC Display writes to the Event Log a message stating which ODBC data source it's monitoring. (For more
information about the Event Log, see “Enabling the Event Log Viewer”on page 312 and “Using the Event Log
Viewer”on page 325.)

When an object configured to send data to (or receive data from) a database is triggered during Runtime, PAC
Display Runtime attempts to connect to the database.

«  Ifthe attempt is successful, Runtime writes the data to (or from) the database.
«  Ifthe attempt fails, Runtime performs a series of actions to recover:

- First, it writes a message to the Event Log that contains the error message it received about the
failure.

—  Then, it will keep trying to connect until either the connection is established or Runtime is shut
down.

—  When the connection is established, it writes another message to the Event Log, along with the
time the connection was established.

Granting Privileges in Microsoft Access

If you plan to load recipe files to or from a Microsoft Access database, you must also grant administrator
privileges to the MSysObjects table. How you do this depends on your version of Microsoft Access.

Microsoft Access 2000
1. Open the target database in Microsoft Access, and then click the menu bar’s Tools > Options.
The Options dialog box opens.
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2. OntheView tab, select Hidden Objects and System Objects.

view | General | Edit/Find | Keyboard | Detasheet | Forms/Reports | Advanced | Tables/Queries |

—
| ¥ tidden objects |
System objects,

v Windgws in Taskbar

V¥ Startup dialog box
¥ Ney object shortcuts

Show in macro design
[~ Names column

[ Conditions column

Click options in database window ———————  ~Dual font support
" Singleclick open [~ use substitution font:
' pouble-dick open Innai ;l
OK l Cancel

3. (lick OKto close the dialog box.

In Microsoft Access's menu bar, click Tools > Security > User and Group Permissions.

The User and Group Permissions dialog box opens.

In the User/Group Name pane, select Admin. In the Object Name pane, select MSysObjects.
In the Permissions area, select the Read Data and Update Data check boxes.

Pemissions lChung: Ovmu']
ser {Group Name: Object Name:
MSysRelationships
Order Details
Orders
Products
Shippers
Suppliers v
List: % Users  Groups Object Type: [Table vI
L liSsil 15
I~ OpenfRun
¥ Read Design
I™ Modify Design
[~ Administer

Current User; .Adm'n

[ ok | Ccancel Boly

6. Click OKto close the dialog box.

Microsoft Access 2002 and higher

1. Open the target database in Microsoft Access, and then press Ctrl+G.
The Microsoft Visual Basic for Applications window opens.

2. Inthe Immediate pane, type the following command:

CurrentProject.Connection.Execute "GRANT SELECT ON MSysObjects TO
Admin;"

3.  Press Enter.
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Microsoft Access does not display any messages, but it does grant access to the table.

Microsoft Visual Basic for Applications - PAC_Display_Recipe_DB - O *
File Edit View Inset Debug Run Tools Add-Ins Window Help Type a question for help -

- 4 BA I » oI BEY Q@

Now you're ready to log data to an ODBC database. For more information, see the following sections:
«  "Saving a SuperTrend to a Database”on page 208

«  "Logging Historical Data to a Database” on page 220

«  “Configuring a Runtime Operator Log Database” on page 314

«  "logging a Recipe File to or from a Database”on page 257
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5: Configuring Control Engines
and Tags

INTRODUCTION

This chapter shows how to define the connections to Opto 22 control engine and /0 points, or “tags,” that
PAC Display requires. PAC Display uses the data values a control engine receives from I/O points and integer,
float, and string variables to change the attributes of on-screen graphic objects. (/O points are defined when
you create a PAC Control strategy; for more information, see the PAC Control User’s Guide, form 1700.) For a
PAC Display project to receive this information on individual I/O points (called tags), you must first define a
connection to an Opto 22 control engine.

PAC Display can also connect to an Opto 22 controller running an OptoControl strategy. Tags in the
OptoControl strategy will be available in your PAC Display project the same way PAC Control tags are.

NOTE: PAC Display can access any PAC Controller or ioControl controller (Ultimate or LCE) as long as each controller
has firmware 7.0 or newer. Therefore, if you are using one integrated project that accesses multiple Opto 22 systems
of varying vintages, in order to ensure proper communication to each component, make sure each controller has

firmware 7.0 or newer.

InThis Chapter

Configuring Control Engines page 61
Configuring the Scanner page 67
Configuring Tags page /4
Correcting Tags from a Strategy page 83
Configuring a Project with No Control Engine......oooovececseee. page 86

CONFIGURING CONTROL ENGINES

Follow these steps to select and configure a control engine:
1. Start PAC Display Com‘igurator.1
2. Open a project that will be associated with the control engine.
3. (lick Configure > Control Engine.
The Control Engines dialog box opens.

!For instructions to start PAC Display Configurator, see page 7.
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If you have not previously configured a control engine for the PAC Display project you opened, the Name
list is empty and only the Add button is available.

8" Control Engines

M arme |.P. Address

4. Tolocate a PAC Control strategy running on the control engine you want to connect to, click Add.

‘ﬂ Strategy File Mame Selection @

—a

| A . <« Display » ioCookies » - |+ Search ioCookies Pl
'\../I play i

Organize « MNew folder ==« 0 @l
7t Favorites - _Docqments library AurongB B Foiter -
Bl Desktop ioCookies
4. Downloads T oy

=] Recent Places
B . PROJECT_BACKUP
4 Libraries
@ Documents
J’ Music
il PAC Project
[ Pictures

EE videos

- |4 i | b

File name: - ’PAC Control Strategy (*.idb) v]

[ open |v] | cancel |

5. Inthe Strategy File Name Selection dialog box that opens, navigate to the PAC Control strategy that is
running on the control engine you plan to select.
To locate an OptoControl strategy, click the drop-down menu in the Files of Type dialog box and select
“OptoControl Strategy *.cdb”

6. Ifyou have PAC Display Basic, see “Final Controller Configuration with PAC Display Basic” on page 62 to
complete controller configuration. If you have PAC Display Professional, see “Final Controller
Configuration with PAC Display Professional”on page 65.

@ Final Controller Configuration with PAC Display Basic

NOTE: The next few steps differ between PAC Display Basic and PAC Display Professional. Follow the set of instructions
for your version of PAC Display.

1. Select the strategy file and click Open.
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The strategy you selected appears in the Strategy field of the Control Engine Properties dialog box.

Contrel Engine Properties x

Primary Contral Engine

Mame; | | Browse...

Backup Contral Engine

Mame; | | Browsze. .

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl Browse. ..

Make Path Relative to Project [

Cancel Help

Now you need to select the primary control engine from which PAC Display will receive 1/0 point
information. Remember that this control engine must be running the strategy you selected.

Click the Browse button in the Primary Control Engine group.
The Select Control Engine dialog box appears.

Select Control Engine

Configured Control Engines:
Cookie Controller

oK Cancel

All control engines that have been configured to connect to your PC are listed, whether or not they are
associated with your strategy. If you previously configured a control engine for use with PAC Control, for
example, it would appear here, even if it didn't appear earlier when you opened the Control Engines
dialog box.

NOTE: If the control engine you want to use doesn’t appear in the Select Control Engine dialog box, you must
connect and configure this control engine to make it available. Instructions for adding, modifying, and deleting
control engines appear in Chapter 4, “Working with Control Engines,” in the PAC Control User’s Guide (form
1700). OptoControl User's Guide

To choose a control engine that connects with PAC Display, select its name and click OK.
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The primary control engine you have added appears in the Control Engine Properties dialog box.

Contrel Engine Properties x

Primary Contral Engine

Mame; |I:00kiel:0ntm||er | I Browse... I

Backup Contral Engine

Mame; | | Browsze. .

Strategy: |c:'\users'\publickdncuments'\optn 22hpac prniecl Browse. ..

Make Path Relative to Project [

0K Cancel Help

4. To designate a backup control engine, click Browse in the Backup Control Engine group, choose a control
engine from the list and click OK.

The backup control engine you have added appears in the dialog box.

Contrel Engine Properties @

Primary Control Engine

Mame:  Cookie Contraller

Backup Contral Engine

Marme: | Backup Contraller

Strategy:  ohuzershpublichdocumentshopto 22hpac projec

Make Path Relative to Project [

[ Ok ” Cancel ][ Help ]

A backup control engine is used automatically in case the primary control engine fails or becomes
unavailable. Control remains on the backup controller until the backup controller goes offline; control is
not automatically returned to the primary control engine when it becomes available again.

5. Tochange the path of the strategy to be relative to the current PAC Display project, select Make Path
Relative to Project.
This allows the project to be more easily transferred to other PCs that don't have the exact same file
structure.

6. When all the parameters in the Control Engine Properties dialog box are correct, click OK to save your
settings and close the dialog box.

NOTE: When you configure the control engine in PAC Display, you should also designate a local or remote scanner. In
PAC Display, a scanner is a software component that manages all communications with one or more control engines.
By default, the scanner runs on the same PC running the PAC Display project, but your application may benefit from
configuring a remote scanner. See “Configuring the Scanner”on page 67 for more information.
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@ Final Controller Configuration with PAC Display Professional

In PAC Display Pro, final configuration includes selecting the control engine and the primary scanner. If you
also want to set up a secondary scanner, see “Configuring a Remote Scanner in PAC Display Pro” on page 69.

1. Select the strategy file and click Open.
The strategy you selected appears in the Strategy field of the Control Engine Properties dialog box.

Control Engine Properties

Strategy:  LEN ntrolhiocoo rategyhcookies. i Browse. ..

Make Path Relative to Project [

Control Engine

Marne: Browse. .

Primany Scanner

Mode:  Thiz Computer

[ u] J[ Cancel H Help l

Now you need to select the primary control engine from which PAC Display will receive 1/0 point
information. Remember that this control engine must be running the strategy you selected.

2. C(lick the Browse button in the Primary Control Engine group.
The Select Control Engine dialog box appears.

Select Control Engine

Configured Control Engines:

Cookie Controller

oK Cancel

All control engines that have been configured to connect to your PC are listed, whether or not they are
associated with your strategy. If you previously configured a control engine for use with PAC Control, for
example, it would appear here, even if it didn't appear earlier when you opened the Control Engines
dialog box.

NOTE: If the control engine you want to use doesn’t appear in the Select Control Engine dialog box, you must
connect and configure this control engine to make it available. Instructions for adding, modifying, and deleting
control engines appear in Chapter 4, “Working with Control Engines,” in the PAC Control User’s Guide (form
1700). OptoControl User's Guide

3. Tochoose a control engine that connects with PAC Display, select its name and click OK.
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The primary control engine you have added appears in the Control Engine Properties dialog box.

Control Engine Properties @

Strateqy:  |:\uzershpublichdocumentshopto 22%pac projec Browse. ..
Make Path Relative to Project [

Cantral Engine

Mamme:  PAL Contral Engine
[ Choose.

Primary Scanner

MNode;  This Computer Choosze..,

[ 0K ” Cancel ][ Help ]

4. Toselect a primary scanner, click the Choose... button.

Select Primary Scanner Location Iﬁl

Current Location of Scanner:
This Computer

Chooge Location of Scanner:

@) This Computer | Remaote DptoDF’CSel{er...

[ Ok, l[ Cancel ] [ Help ‘

5. To use the local computer as the primary scanner, select This Computer and then click OK to exit the
dialog box and finish the configuration.
However, to designate a different computer as the primary scanner, click the Remote OptoOPCServer
button.

Choose Rernote OptoOPCServer Location @

Select Location

g etvork)

G- OPTO 22
[ OPTOZ2
- WEB

-8 WORKGROUP

[ 0K J[ Cancel ]

In the list of computers that appears, navigate to the PC that has OptoOPCServer software installed and
configured. Select the computer and click OK.
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IMPORTANT: To successfully use OptoOPCServer on a remote computer with PAC Display, Windows user and
application permission settings on both local and remote computers must be correctly configured. For detailed
instructions for configuring OptoOPCServer and OPC clients for network operation, see the OptoOPCServer
User's Guide (form 1439), included with the purchase of OptoOPCServer.

6. Click OKto close the dialog box and save your settings.

To set up a secondary scanner, see “Configuring the Scanner”on page 67.

Ethernet Link Redundancy

NOTE: If you have configured redundant controllers for your control system, the Ethernet link redundancy feature
described in this section cannot be used. For more information on using redundant controllers, see the SNAP PAC
Redundancy Option User's Guide (form 1831).

The two Ethernet interfaces on a SNAP PAC controller allow you to have redundant Ethernet network links for
your control system. Using PAC Manager, you assign a different IP address for each interface—a primary and a
secondary address. Then, using PAC Control, you assign the two addresses to the control engine.

Once this has been set up, you can use the primary and secondary IP addresses in a PAC Display project to
access data from the PAC Control strategy running on the control engine.

In a system with link redundancy, one address is always active. If the primary address is unavailable, then the
secondary address becomes the active address and PAC Display will automatically shift to the secondary
address. If the secondary address fails, then the primary address becomes the active address and it will
automatically try the primary address again. If communication to the active address fails and the control
engine is not able to switch to the other address, then communication to the 1/0 unit becomes disabled.
Communication is tested on each valid address that is enabled (any address other than 0.0.0.0) when a
strategy is started or when communication to an I/0 unit is changed from disabled to enabled.

On a SoftPAC controller, the PC running SoftPAC must have two network interface cards (NICs) configured
with static primary and secondary IP addresses on different subnets.

To set up Ethernet link redundancy:

1. Using PAC Manager, assign the primary and secondary IP addresses to the control engine.
For details, see “Configuring Devices”in the PAC Manager User's Guide (form 1704).

2. Using PAC Control, configure link redundancy for the control engine.
For details, see “Using Ethernet Link Redundancy in PAC Control”in the PAC Control User's Guide (form
1700).

Once you have set up link redundancy for the control engine you are using in your PAC Control strategy, it
works automatically in PAC Display.

@ To view which control engine is currently running, click View > Configuration in Runtime.

CONFIGURING THE SCANNER

PAC Display exchanges information with one or more Opto 22 controllers using a software component called
a scanner. This scanner is automatically installed on the same computer as PAC Display software, but can also
run on a different computer. See “Using OptoOPCServer as a Remote Scanner” below.

NOTE: No configuration is needed to run the scanner on the same computer as PAC Display.

When a PAC Display project is running, PAC Display periodically checks to see if the scanner is operating. If the
scanner is not operating, an error message is displayed in the Runtime Error Log. Configuring how often the
scanner is checked is described in “Setting Scanner Heartbeat Interval”on page 72.
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Using OptoOPCServer as a Remote Scanner

Different PAC Display projects—or copies of the same project—can run on multiple computers which are
connected on a network. For example, for supervisory reasons you may need to run several monitor-only
versions of PAC Display projects on office computers in addition to using regular monitor-and-control versions
of PAC Display at operator workstations.

If you need to run multiple instances of PAC Display on separate computers, use Opto 22's OptoOPCServer
software as a centralized scanner. Running on a PC or network server, OptoOPCServer centralizes
communications with Opto 22 control engines. This greatly increases the efficiency with which computers
running PAC Display can exchange information with control engines. OptoOPCServer software is sold
separately from PAC Display, and is available from Opto 22 and local Opto 22 distributors.

Computers running % % %

PAC Display projects

) OptoOPCServer provides a
Computer running \ remote scanner for PAC
OptoOPCServer R

Display. This centralizes the
exchange of /0 data
between computers running
PAC Display and controllers.

Opto 22 industrial
controllers running
PAC Control
strategies

NOTE: PAC Display software can communicate only with its built-in scanner or with OptoOPCServer software. PAC
Display is not a generic OPC client, and cannot be used with third-party OPC servers.

In addition to serving as a remote scanner for PAC Display, OptoOPCServer supports third-party SCADA, HMI,
data collection, and other OPC-client software. For these third-party OPC clients, OptoOPCServer can supply
/0 point data from SNAP PAC systems that is not supported by PAC Display.

IMPORTANT: OptoOPCServer must be correctly installed and configured on a network server or workstation before a
PAC Display project can use it as a scanner. For detailed information on installing OptoOPCServer and configuring it
for network operation (including DCOM), see the OptoOPCServer User's Guide (form 1439), included with the
purchase of OptoOPCServer.

For Basic, see “Configuring a Remote Scanner Location in PAC Display Basic” below.

For Pro, see “Configuring a Remote Scanner in PAC Display Pro”on page 69.

@ Configuring a Remote Scanner Location in PAC Display Basic

To use a remote computer running OptoOPCServer as a scanner:
1. Start PAC Display Configurator.
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2. Inthe menu bar, click Configure > Scanner Location.
3. Inthe Select Scanner Location dialog box that opens, click Remote OptoOPCServer.

Select Primary Scann

er Location

Current Location of 5 canner:

| This Computer|

Chooge Location of Scanner:

() This Camputer

Remate Dpta0FPCServer...

Scanner Heartbeat Che

Send Heartbeat Chec

[] Enable "éwaiting Cor

Lok J[ ca

Select Location

Choose Remote OptoOPCServer . “cation

&L OPTOZ2
S WER

S WORKGROUP

Lok J|

Cancel l

4. Inthe list of computers that appears, navigate to the PC that has OptoOPCServer software installed and
configured. Select the computer and click OK.

IMPORTANT: To successfully use OptoOPCServer on a remote computer with PAC Display, Windows user and
application permission settings on both local and remote computers must be correctly configured. For detailed
instructions for configuring OptoOPCServer and OPC clients for network operation, see the OptoOPCServer
User's Guide (form 1439), included with the purchase of OptoOPCServer.

5. (Click OKto close the dialog box and save your settings.

@ Configuring a Remote Scanner in PAC Display Pro
1. Click Configure > Control Engine(s).
2. Inthe Control Engines dialog box, double-click the control engine you want to configure.

2For instructions to start PAC Display Configurator, see page 7.
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Double-click
the control
engine
3.
4,

7| Centrol Engines @
Mame |.P. &ddress Shategy Mame
e ; - . Add..
PAL Contral Engine M C idh
PAC Sim cokiesidb
[ 0k, ] [ Cancel ] [ Help ]

In the Control Engine Properties dialog box, click the Choose... button.

X5

Control Engine Properties

Strateqy:  |:\uzershpublichdocumentshopto 22%pac projec Browse. ..
Make Path Relative to Project [

Cantral Engine

Mame; PAC Control Engine

Primary Scanner

MNode: Choosze..,

[ Choose.

Thiz Carnputer

[ 0K J[ Cancel ][ Help ]

Click the Remote OptoOPCServer button.

X5

Select Primary Scanner Location

Current Location of Scanner:

This Computer

Chooge Location of Scanner:

@) This Computer Remate DptoDF’CSel{er...

][ Cancel ] [ Help ]

[ o
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5.
configured. Select the computer and click OK.

Choose Remote OptoOPCServer Location

Select Location

In the list of computers that appears, navigate to the PC that has OptoOPCServer software installed and

X5

oy etk
&6 OFT0 22

- S \WEB
(- & WORKGROUP

[ ok ][ Cancel ]

IMPORTANT: To successfully use OptoOPCServer on a remote computer with PAC Display, Windows user and
application permission settings on both local and remote computers must be correctly configured. For detailed
instructions for configuring OptoOPCServer and OPC clients for network operation, see the OptoOPCServer
User's Guide (form 1439), included with the purchase of OptoOPCServer.

6. Click OKin each open dialog box to save your changes.

Pro.”

To set up a secondary scanner, see the next section, “Configuring a Secondary Remote Scanner in PAC Display

Configuring a Secondary Remote Scanner in PAC Display Pro

Configure Secondary Scanner

Frimary Scanner Location:
iT his Comptter v]

Configured Secondary

Select Secondar...

][ Cancel ][ Help ]

[ o

For each local or remote scanner the PAC Display project uses, you can set up a secondary scanner that will be
used when the primary scanner is not available.

1. In PAC Display Configurator, click Configure > Secondary Scanner Location.

The Configure Secondary Scanner dialog box appears.
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2. Make sure the correct computer is selected for Primary Scanner Location and then click Select Secondary.

Select Secondary Scanner Location @

Current Location of Scanner;

Thiz Computer

Choose Location of Scanner:

@ This Computer ’F!emc-te Opta0PCServer... ]

[ 0k Jl Cancel l l Help l

3. Inthe Select Secondary Scanner Location dialog box, click Remote OptoOPCServer and select a
computer from the list tree that you want to use for the remote secondary scanner. Click OK when done.

Choose Rernote OptoQPCServer Location @

Select Location

@ Mehwark
&L OPTO 22

& OPT022
- WEB

- & WORKGROUP

IMPORTANT: To successfully use OptoOPCServer on a remote computer with PAC Display, Windows user and
application permission settings on both local and remote computers must be correctly configured. For detailed
instructions for configuring OptoOPCServer and OPC clients for network operation, see the OptoOPCServer
User's Guide (form 1439), included with the purchase of OptoOPCServer.

Click OK to save your changes and close the Select Secondary Scanner Location dialog box.
5. Inthe Configure Secondary Scanner dialog box, click OK to save your changes.

Setting Scanner Heartbeat Interval

When a PAC Display project is running, PAC Display periodically checks to see if the scanner is operating. If the
scanner is not operating, an error message is displayed in the Runtime Error Log. The Scanner Heartbeat Check
Interval is the interval in seconds at which PAC Display will check to see if the scanner is operating.

To set how often PAC Display checks the operation of the scanner:

1. In PAC Display Configurator Basic, select Configure > Scanner Location.
In Pro, select Configure > Scanner Defaults.
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For Basic, the Select Scanner Location dialog box appears.

Select Primary Scanner, Location E|

Current Location of Scanner;
Thi:E: Compute |

Chooze Location of Scanner:

(%) This Computer l Remate Opto0PCServer... ]

Scanner Heartbeat Check Interval

Send Heartbeat Check Every Seconds.

[ ]Enable "Awaiting Connection” messages.

I 0k H Cancel H Help l

For Pro, the Configure Scanner Defaults dialog box appears.

Configure Scanner Defaults

Scanner Heartbeat Check Interval

Send Heartbeat Check Every Seconds.

[ ]Enable "Awaiting Connection” messages.

I 0k H Cancel H Help l

2. InScanner Heartbeat Check Interval, enter the interval in seconds at which PAC Display will check to see
if the scanner is operating.

You can enter a value between 1 and 3600 seconds (integer values only). The default value of 10 seconds
is suitable for most applications. If there is a slow communications link between the computer running
the PAC Display project and the computer running the scanner, use a longer heartbeat interval to reduce
network traffic.

3. (lick OKto close the dialog box and save your settings.

Hiding or Displaying Runtime Startup Messages

When a PAC Display project starts in Runtime, multiple “Bad Quality”or “Not Connected” messages often
appear in the Event Log Viewer. These startup messages appear when the PAC Display scanner has not yet
connected to a control engine specified in the project. To hide or display these Runtime startup messages, do
the following:

1. In PAC Display Configurator Basic, select Configure > Scanner Location.
In Pro, select Configure > Scanner Defaults.
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The Select Scanner Location dialog box appears.

Select Primary Scanner, Location E|

Current Location of Scanner;

| T his Compute

Chooze Location of Scanner:

(%) This Computer l Remate Opto0PCServer... ]

Select the Enable “Awaiting Scanner Heartbeat Check Interval
Connection”Messages check box to

. Send Heartbeat Check E 5 ds.
display all startup messages. Deselect Fne Nearbeat -nes VBW Feangs

this check box to hide Bad Quality and
Not Connected startup messages. ——&—F1 Enable 'éwaiting Cannection” messages.

I 0k H Cancel H Help l

2. Select or deselect the Enable “Awaiting Connection”Messages check box to display or hide any “Bad
Quality”or “Not Connected” messages that may occur when the PAC Display project starts.

3. (lick OKto close the dialog box and save your settings.
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Graphic objects in PAC Display can be linked directly to the values of PAC Control tags, so you will configure
tags quite often as you develop PAC Display projects. (For detailed information on item types and names in
PAC Control strategies, see the PAC Control User’s Guide (form 1700).

There are two ways to configure tags:
«  TheTag Selection dialog box
«  QuickTag Entry

If you aren't familiar with the tag names in your PAC Control strategy, use the Tag Selection dialog box
(page 76). This option displays all of the tag names (filtered by type), so you can scroll down to find the one
you want.

If you know at least the first few letters of the tag name, the Quick Tag Entry method is fast and easy (page 74).

Using Quick Tag Entry

To access Quick Tag Entry:
1. Click anywhere in the Tag Name field of a Dynamic Attribute dialog box.

PAC Display User's Guide


http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165

Quick Tag Entry appears.
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Tag
Controller:

i Cookie Corntraller w
|

Width: | 53 Height: | 19 Hint... Security...
e
Itern Mame: Field / Bit
bChipDi vl ?

Source
(®) Fixed data

Fixed D1ata
@ Set
(O Clear
A7) Togole

(O Prompt for data

Frompted Data
i}

In each text box, start typing the value you want. As you type, PAC Display filters the list of matching
values. When the value you want appears, press Tab to save the value and advance to the next field.

TIP:In a long list of values, start typing the value you want, and then press the down-arrow key to scroll through
the list of matching values.

3. Afteryou select a value in the last field, press Tab to save your selections and close Quick Tag Entry.

Using the Tag Selection Dialog Box

You access the Tag Selection dialog box from many dialog boxes in PAC Display Configurator by clicking the

Tag Selection button |

(71 .

The tags that appear in the Tag Selection dialog box are actively filtered; rather than display all possible item
types and item names, only the item types available for the selected control engine appear in the Item Type
list, and only the item names available for a selected item type appear in the ltem Name list.

To configure a tag, complete the fields as described in “Tag Selection Dialog Box" below.
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Tag Selection Dialog Box

Value Tag Selection d
Cantraller: Itemn Type:
SHAP PAC Chart
Contral Engine B
Dovan Tirmer
Float
A
Item Mame: .
— Selected Fields -1 D
bChipDizpensetalve ~
bChipLevelSwitch Field: — E
C Bl oughDizpensze'alve F
bloughLewelSwitch Element: l Bit [0-31]: G
b oughPressureControlvalve
bEStop Start Indes: Hum Elements:
blnzpectionP azsF ailSwitch | H
bRejectalve
bStartFlag
nChartStatus v — 1
J— Cancel Help

&
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(Pro only)(A) Controller. Select the control engine that contains the tag you wish to use. If only one
control engine is available, it is automatically selected. Choosing a control engine updates the Item Type list
(B) so that it displays only the PAC Control data types available in that control engine’s PAC Control strategy.

(B) Item Type. Select the type of data you wish to use. The list contains the data types available in the
selected control engine’s PAC Control strategy. (The data types that appear depend on which data type was
selected in the “Setup by"field in the preceding dialog box.) When you select a specific item type, a list of all
the tags of that selection type appears in the Item Name list box (C). Your Item Type selection also determines
the options available in the Selected Fields group (D).

PAC Display can access tags for most types of variables and other information in a PAC Control or OptoControl
strategy. See the PAC Control User's Guide (form 1700) or the OptoControl User's Guide (form 724), for
information on a specific type of variable.

NOTE: In order to get the value referenced by a pointer, use the variable’s actual type, such Integer, Float, and so on.
You cannot use a variable from a Pointer Table.

PAC Display can also access memory-map-based Scratch Pad variables in SNAP Ultimate controller/brains, the
SNAP-LCE controller, and SNAP PAC controllers; see “Selecting Tags for I/O Unit Scratch Pad Variables”on
page 80 for information on configuring Scratch Pad variables in the Tag Selection dialog box.

See also, “Tag Types You Can Save to a Historical Data Log”on page 216.

(C) Item Name. This is an alphabetical list of the available PAC Control tags of the type specified in the /tem
Type list. Select the tag you want to use from this list.

(D) Selected Fields. The item type of the tag you select determines which of these fields, if any, need to
have contents specified. If an entry is not needed, then the option is not available.

IMPORTANT: There are differences in how some tags are configured in this dialog box.
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If SNAP high-density digital modules are used in your I/0 system, see “Tag Selection Dialog Box (High Density Digital
Tag Type)” on page 79 for more information.

If the Scratch Pad feature available in some SNAP brains is used to store bit, integer, floating point, or string values,
see “Selecting Tags for I/0 Unit Scratch Pad Variables” on page 80 for more information.

(E) Field. Specifies the data that is associated with the selected tag. For example, if the selected tag is of Item
Type Digital Input Point, the available field is State. If the tag Item Type is Float, the Field list box is disabled.

For the Send String tag type:

«  Time returns the control engine’s current time.

«  Datereturns the control engine’s current date.

«  Strategy Date returns the date stamp of the strategy file in the control engine.
«  Strategy Time returns the time stamp of the strategy file in the control engine.

For the PID Loop tag type:

«  Auto/Manual Flag This option is not recommended; it is available only for backward compatibility. It is not
available for not-Ethernet PID tags. If PAC Display is configured to scan I/0 tags from the 1/0 unit (the
default), this option determines if the PID loop is in manual mode (Manual = True (1) = Discrete ON; Auto
= False (0) = Discrete OFF). However, if PAC Display is configured to scan I/O tags through the controller, it
will determine whether the PID loop is in Auto (Auto = True (1); Manual = False (0)). For all new
development, use the Is Manual? option instead.

o [sManual? This is the recommended option and should be used for all new development. Itis not
available for non-Ethernet PID tags. It determines if the PID loop is in manual mode. When in manual
mode, the value will be True (1); when in Auto mode, the value will be False (0). It is consistent whether
PAC Display is configured to scan the I/O tags through the controller or directly from the I/0 unit.

« Ifthe PID loop is in manual, it will return a discrete ON. If the PID loop is in Auto, it will return a discrete
OFF.

« Toput the loop in Auto, set the Is Manual? option to discrete OFF. To put the loop into manual, set it to
discrete ON.

NOTE: To set whether tags are retrieved directly from the I/O unit or through the controller, go to Configure >
Runtime and choose the 10 Unit Tags tab. If an I/0 unit is checked, the tags are retrieved directly though the I/0O
unit. Ifunchecked, the tags are retrieved through the controller. For more information, see “Runtime Setup: I/O
Unit Tag Tab” on page 319

«  Configuration Flags PID 0: Configuration flags:
1 = Enable square root of Input.
2 = Force output when Input is out of range.
4 = Switch to manual mode when input goes out of range.

(F) Element. If the selected Item Type is one of the Table types and only a single element of the table is
desired, enter the index of that element in this field.

(G) Bit. If the base type is Integer, a specific bit in the range specified may be selected from the integer.

For configuring a Discrete control engine-driven dynamic attribute, if you are configuring an integer tag type
and do not specify a bit index and the integer value is 0, the tag will evaluate to FALSE. Any non-zero value will
be considered TRUE. However, if you do specify a bit and the bit is OFF, the tag will evaluate to FALSE; if the bit
is ON, the tag will evaluate to TRUE.

For configuring the Send Discrete operator-driven dynamic attribute, if you specify a bit, the following
message will appear: “No bit index is specified. All bits will be set. OK to continue?”However, if you select a bit
index, then only that bit will be modified.
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For more information, see “Dynamic Attributes and Their Features”on page 140.

(H) Start Index. To select multiple elements from Item Type Table, use the Start Index to specify the first
element and Num Elements to specify how many.

(1) Refresh Time. If a control engine-driven attribute is being edited, select the refresh time group to be
used for scanning. All tags that are defined as part of the same refresh time group are scanned at the same
time. A time group with a refresh time of 0 seconds is scanned as quickly as the speed of the communications
link permits.

(J) OK. Click OK to save your settings. (Click Cancel to close the dialog box without making any changes.)

Selecting Tags for SNAP High-Density Digital Modules

For high-density digital points configured in PAC Control with a name, you can select tags in the same manner
as for standard density digital modules, or you can use the High Density Digital tag type in the Tag Selection
dialog box. For high-density digital points without a name, use the High Density Digital tag type in the Tag
Selection dialog box. See “Tag Selection Dialog Box (High Density Digital Tag Type).”

NOTE: Points configured in PAC Control 7.1 or earlier are not named. To select tags for these points, you must use the
High Density Digital tag type.

Using the High Density Digital tag type, it is possible to configure a tag that refers to either a named
high-density digital point or to one that is not named. For example, if a high-density digital point named
HDDI_A has been configured at module 0, channel 15, you can configure a tag for this point using one of the
following methods in the Tag Selection dialog box:

«  Select Digital Input Points as the Item Type. Under Item Name, select HDDI_A.

«  Select High Density Digital as the Item Type. Then under Selected Fields, enter 0 in the Module field and
15 in the Point field.

High-Density digital modules provide 32 digital input or output points in one SNAP module. See the
PAC Control User’s Guide (form 1700) for information on using these modules in a PAC Control strategy. For
more information, see the SNAP High-Density Digital Module User's Guide (form 1547).
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Tag Selection Dialog Box (High Density Digital Tag Type)

X]

Value Tag Selection

Cantroller: Item Type:

S Chart
Control Engine
Down Timer
Float
High Density Digital Modules —1 A
Integer

Itern Mame: .
Selected Fieldz

Loopback.
Field: | State ——1 8
Element: |_'__| Bit (0-31) @ E
Start Indesx: I:I Hum EIements:lZI

I 0k l [ Cancel ] l Help l

(A) Item Type. Select the item type “High Density Digital”to see all /0 units configured in the PAC Control
strategy for your PAC Display project.

If the PAC Control strategy has at least one configured 1/0 unit, “High Density Digital” always appears in the
Item Type list, even if a SNAP high-density digital module is not used in your I/O system.

(B) Item Name. Select the name of the I/0 unit where the SNAP high-density digital module you want to
use is installed.

(C) Field. Choose a field based on the type of dynamic attribute (control engine-driven or operator-driven),
and whether you want to work with a single point on the high-density module or all 32 points. One or more of
the following fields will be available:

Must specify:
Dynamic Attribute Tag Description
Discrete E;tnutms on/off status of specified P P
Control engine-driven i
Value Returns a 32-bit integer indicating Py n/a
status of all 32 points.
State Send / t stat d
. ends a true/set to set state and a
Discrete false/clear to clear state. ® o
Operator-driven
Value Sends a 32-bit integer to set states of Py n/a
all 32 points.
Discrete n/a n/a n/a
Control engine-driven _bit i i
Value Rgturns a 32-bit integer for a single Py P
Counts point.
Discrete
Operator-driven See “Read and Clear” on page 151.
Value
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Must specify:
Dynamic Attribute Tag Description
. Returns Latch (ON) status of speci-
Discrete | point. o o
Control engine-driven
Returns a 32-bit integer indicating
Value status of all 32 points. o n/a
Latch (ON) Clears ON latch. Choose “Set” to
Discrete | clear latch if “prompt for value” dialog o o
Operator-driven box is used.
Value Sends a 32-bit integer to clear ON n/a
latches of all 32 points.
Discrete Return§ Latch (OFF) status of speci- P
fied point.
Control engine-driven
Value Returns a 32-bit integer indicating n/a
status of all 32 points.
Latch (OFF) Clears OFF latch. Choose “Set” to
Discrete | clear latch if “prompt for value” dialog o o
Operator-driven box is used.
Sends a 32-bit integer to clear OFF
Vel latches of all 32 points. ® e

(D) Module. Enter the position (0-16) where the high-density digital module is installed on the mounting
rack.

(E) Point. Enter the number (0-31) of the module’s digital input or output point.

Selecting Tags for /0 Unit Scratch Pad Variables

Opto 22 SNAP PAC controllers have a section of memory called the Scratch Pad where bit, integer, floating
point, and string values can be stored and accessed. The Scratch Pad is convenient for making information
available to other Ethernet-enabled Opto 22 brains and controllers, as well as Opto 22 software and custom
software applications written using Opto 22's OptoMMP Communication Toolkit.

See the PAC Manager User’s Guide (form 1704) and the PAC Control User’s Guide (form 1700) for information
on using bit, integer, floating point, and string Scratch Pads.

NOTE: The SNAP controller or brain using the Scratch Pad must be defined as an I/O unit in the PAC Control strategy
that the PAC Display project is using.

In PAC Display, tags for Scratch Pad integer and floating point values are configured the same way as tags for a
PAC Control numeric table variable. Like a table variable, for these Scratch Pads you must specify an index
number and the number of elements to be read. Scratch Pads for integer and floating point values can have
up to 10,240 elements, but unlike PAC Control table variables, the elements in these Scratch Pads are
non-contiguous. This means that when you specify a range that exceeds 1024 elements (indexes 0-1023), the
range must be divided between two tags as shown below.

Itt.am Name in Tag Selection Description First Last
Dialog Box Element Element
10_Unit_Name:SP_INT Scratch Pad integer value 0 1023
10_Unit_Name:SP_INT_EXT Scratch Pad integer value, extended 1024 10239
10_Unit_Name:SP_FLOAT Scratch Pad floating point value 0 1023
10_Unit_Name:SP_FLOAT_EXT  Scratch Pad floating point value, extended 1024 10239
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Example: The I/0 unit labeled “Station_01"has floating point values stored in elements 0 to 2047.To display
all these values using, for instance, PAC Display’s Table object you would need to do the following:

1.
2.
3.
4

5.

Create one table control, which can display up to sixteen separate Table objects.
In the Tag Selection dialog box for the first table object, select the ltem Name “Station_01:5P_FLOAT.”
For the Start Index value, enter 0, and for Number of Elements, enter 1024.

In the Tag Selection dialog box for the second table object, select the Item Name
“Station_01:SP_FLOAT_EXT."

For the Start Index value, enter 1024, and for Number of Elements, enter 1024.

When the project is run in PAC Display Runtime, the first table will show floating point values in indexes 0
through 1023, while the second table will show values in indexes 1024 through 2047.

Searching for Tags in a PAC Display Project

See also, “Finding and Replacing Tags in a PAC Display Project” below.

You can search a PAC Display project to find where a PAC Control tag has been used.

1.
2.

o v »

Click View > Find Tag. The Find Tag dialog box appears.
Highlight the tag you want to find.

Find Tag = *

Select Controller: Select Tag:

bChipDispenszeyfalve
bChipLevelSwitch
bDoughDispenzey alve

bl oughLevelSwitch

bl oughPressureControlfalve

bEStop
blnspectionFazsF ailSwitch
bRejectyalve v
Find TagIn.. Optiors
[windows [ Sound Managers Highlight T ag

[ &lam Paints [ &pplication Managers [] Show Repart
[ Historical Logs ['window Managers

[ Recipe Managers
[ Select &1 [] Shapshat Managers

Find Next

Under Find Tag In, choose where to search for the tag.
To quickly select all “Find Tag In"options, click Select All.
Under Options, select how to display the results.

Click Find Next to find the tag.

Click Done to close the dialog box.

Finding and Replacing Tags in a PAC Display Project

You can find and replace tags in an entire PAC Display project, or just in one or more selected graphic objects.
This find and replace feature works with tags for a control engine, item name, table index, or bit index.

1.

In a draw window in PAC Display Configurator, select the graphic objects you want to search and replace
tags in. To search graphic objects in the entire PAC Display project, select at least one object on the
screen.

Click Edit > Replace. (You can also right-click a graphic object and select Replace from the pop-up
menu.)

The Find and Replace dialog box appears.
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Find and Replace Dialog Box

Find and Replace

Search Scope

() Allwindows () Chosen graphics @) Entire Project

Search For

@ Cantral Engine T able Index () Refresh Group

) Item Name Bit Index (") Exact Text
Findwhat:  [FAC Sim x|
Replace with: [P,-’.\I: Sim 1 D

Ok

I

Cancel l [ Help

(A) Search Scope. Select one:

All windows to search and replace in all windows in the PAC Display project.

Chosen graphics to search and replace tags in just the graphic objects you've selected.
Entire Project to search and replace tags in all parts of the PAC Display project.

(B) Search For. Select the type of tag to search and replace.

Refresh Group: A refresh time group determines how often the tag is scanned. To change all tags in the search
scope from one refresh group to another, in Find what (C), enter the number of the refresh group to change
from. In Replace with (D), enter the number of the refresh group to change to. The numbers must be in the
range 0-13. For more information, see “Scanning to Update Graphic Objects”on page 182.

Offset By: If you select Table Index or Bit Index, the Offset By option appears. To offset a bit or table index, either
enter the value or use the up and down arrows.

Fitid what:
Replace with:

Offzet By

0

This feature allows you to select one or several graphic objects and change the index easily. For example, if
you want to copy a set of graphic objects so that the second set of objects looks at a different table or bit
index than the first set, rather than manually changing all the tags, you can just select all the objects in the
new set and use Offset By to change all the table or bit indexes at once.

NOTE: If you enter a value in either the Find what or the Replace with field, the Offset By controls are disabled.

Exact Text: Search and replace text in tag names, button text, labels, trend pens, refresh group text, combo box
entries, and so on. Choose from the following options to further define the scope of the search.

Tags: Searches tags, triggers, and notifications.

Text on Window Objects: Searches labels, button text, combo box text, and so on. It does not
search/replace the names of the windows themselves.

Everywhere: Searches for both Tags and Text on Window Objects. It does not search recipe files.
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(C) Find What. Enter the name of the tag to find. If either Control Engine or Item Name is selected in Search
For (B), you can choose the item from a drop-down menu. For Item Name, you can also enter the exact name
of the item directly in the text field. For all other tag types, enter in the text field the name of the tag exactly as
it appears in the PAC Control strategy.

(D) Replace With. Enter the name of the tag to replace the tag found in Find What (C). The replacement
item must be the same kind of item as the item being searched for. If either Control Engine or [tem Name is
selected in Search For (B), you can choose the item from a drop-down menu. For Item Name, you can also
enter the exact name of the item directly in the text field. For all other tag types, enter in the text field the
name of the tag exactly as it appears in the PAC Control strategy.

(E) OK. Click OK to start the search, or click Cancel to close the dialog box without any changes.

CORRECTING TAGS FROM A STRATEGY

When you select a PAC Control strategy to use with your PAC Display project, PAC Display automatically
imports that strategy’s tag name database. This is unlike most other HMI software applications, which require
you to create a separate SCADA database in addition to the strategy or control program itself.

This tight connection with the strategy’s tag name database, however, can sometimes cause problems when
the current PAC Control strategy used by a PAC Display project is modified. PAC Display may incorrectly read
the tags associated with the resulting strategy. PAC Display Configurator includes a feature called AutoCorrect
Tags that fixes most tag errors that may occur this way.

The AutoCorrect Tags feature works by comparing all tag names, IDs, and table index references that are used
with dynamic attributes in the PAC Display project. If discrepancies are found between the items in the tag
name database and the PAC Display project, the errors that can be corrected are fixed. Both corrected tags as
well as those that could not be corrected are listed in the results report AutoCorrect Tags generates.

When to Use AutoCorrect Tags

It's generally advisable to use the AutoCorrect Tags option after making any changes to the PAC Control
strategy associated with your PAC Display project. Specifically, you should run AutoCorrect Tags in the
following situations:

« Ifyou use a PAC Display project that contains objects you imported or copied from an OptoDisplay
project. (OptoDisplay is the HMI authoring tool for Opto 22's FactoryFloor Software Suite.)

« Ifyouimport a window created in a different PAC Display project. (Window files can be exported from a
PAC Display project, saved as files, and imported into another project. See “Importing, Exporting, and
Saving Windows" on page 98 for information.)

There are some tag errors in a PAC Display project that AutoCorrect Tags cannot fix. These errors include if you
do either of the following:

«  Delete atag from a strategy
«  Shorten the length of a table in a strategy

You may also get unreliable results if you delete a tag from a strategy, and then create a new tag with the
same name.

Using AutoCorrect Tags

IMPORTANT: Always save changes to your PAC Display project before using the AutoCorrect Tags option.

If you don't want to use the corrections made by AutoCorrect Tags, simply close the project without saving.
Remember that not saving the project means you will lose any other changes you have made to the project.
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Follow these steps to correct tags in your PAC Display project:
1. ClickTools > AutoCorrect Tags.
The following warning appears.

AutoCorrect Tag X

Control engine tags will be potentially modified through this option,
These changes will be saved when the project is saved.

These changes can only be discarded by not saving the project.,
This operation may nok be undone,

Do wou want ko continue?

2. C(lickYes.The Select Window dialog box appears.

Select Window

Cookie Factom

il

I 0k H Cancel H Help l

3. Select one or more windows to run AutoCorrect Tags on.

This is useful for large PAC Display projects that may contain hundreds of windows, but have only a few

windows that have been modified or imported.

4, If PAC Display finds any problems with the tags and can fix them, it will do so. The changes, however,
won't become a permanent part of your project until you actually save the project.

5. To correct tags, click Yes. (Click No to close the window and not make any changes.)

The Windows application WordPad launches, displaying a results file that describes any problems
AutoCorrect Tags may have found with the tags from the strategy. The results file has a name of the form

Opton.$$$, where n is an arbitrary number.
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The following sample file shows the results created by AutoCorrect Tags:

Title:PAC Display AutoCorrect Tags Results File
Project:C:\Opto22\PAC Display\Examples\Factory.uui
Av—-File:C:\Temp\Opt02.$$$
B— pate:2001/10/03
Time:13:05:58
Comment:This file is not deleted automatically.
Summary information is provided at the end of this file.
C__'Table length changed in strategy (tag corrected):
Tag name: Marvinl38:Float Table.RecipeFloatTbl (1)
0ld Length: 5
New Length: 3
Location: Window - master, Ellipse at 38,159, DynAttrColor
__Tag not found in strategy (cannot correct):
Tag name: Marvinl38:Integer.HistoricLogTrigger?2
E Location: Historical Log - Mass Storage, Start Trigger
" Name changed in strategy (tag corrected):
0ld Tag Name: Marvinl38:Integer.DOWNLOAD TRIGGER
New Tag Name: Marvinl38:Integer.ACTIVATE DOWNLOAD
__ Location: Recipes - Peanut Butter Cookies, Trigger
Name changed in strategy (tag corrected):
Table length changed in strategy (tag corrected):
Index into table out of bounds (cannot correct):
0ld Tag Name: Marvinl38:Integer Table.RecipelntegerTbl (4)
New Tag Name: Marvinl38:Integer Table.RecipeIndex (4)
0ld Length: 5
New Length: 3
Location: Recipes - Peanut Butter Cookies, Notification

D

G— Number of tags changed: 4
Number of tags not found: 1
Number of tags index into tables out of bounds: 1

Here's an explanation of what the results file contains:
(A). Name and location of the results file created by AutoCorrect Tags.
(B). Date and time the file was created.

(C). Warning message that reports that the table length of RecipeFloatThl changed from an old length of five
elements to a new length of three elements. “Location” shows where the tag was used in the PAC Display
project. In this example, it was found in a window called “master,” attached to an ellipse at x: and y:
coordinates of 38 and 159, with the color dynamic attribute.

(D). Error message that the tag “HistoricLogTrigger2”is no longer part of the PAC Control strategy, and this
could not be corrected by the AutoCorrect Tags tool. The tag was used as the start trigger for a data log called
“Mass Storage.”

To fix this error, you'll have to assign another tag in your PAC Display project to use as the start trigger for this
log. (Note that PAC Display won't recreate the connection to the tag if you open your PAC Control strategy and
add the old tag name again. Internally, PAC Display can't correlate the old tag name and the new, similarly
named tag.)
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(E). Warning message that the tag name "“DOWNLOAD_TRIGGER" changed to “"ACTIVATE_DOWNLOAD"in the
strategy. The old and new tag names are reported, and the PAC Display project is corrected to use the new tag
name. The tag was used in a recipe called “Peanut Butter Cookies”as its trigger.

(F). Warning message that multiple errors have been found for one tag name:

«  The table name “RecipelntegerTbl” changed to “Recipelndex,”and its length changed from five elements
to three elements. The PAC Display project is updated with this change.

«  An‘index into table out of bounds”error was detected and couldn’t be corrected. Specifically, the project
tried to use the fifth element of the table (RecipelntegerTbl[4]), but the fifth element no longer exists. To
correct this problem you must specify a valid index. The tag was used in a recipe called “Peanut Butter
Cookies.”When the recipe is successfully downloaded, PAC Display writes a value to this notification tag.

(G). The final tally of all the warnings and errors found by AutoCorrect Tags is reported here.

Note that if you run AutoCorrect Tags again, you will see only those errors that were reported as “cannot
correct.” The other reported errors have been corrected.

When you no longer need the Opton.$$5 file, you can delete the file from your hard drive.
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If you have a system with Ethernet I/O but no control engine, you can configure your PAC Display project to
access your Ethernet I/0 units. This requires creating a PAC Control strategy and configuring your I/0 units and
points as well as a control engine with an IP address that does not exist on the network.

Before you begin, make sure that you have created a PAC Control strategy that has properly configured I/O units
and points, which PAC Display will use for its tag database. The strategy does not need to have any logic. For
information on creating a PAC Control strategy, see the PAC Control User’s Guide (form 1700).

1. Start PAC Display Configurator®, and then open a project that will be associated with the control engine.
2. (lick Configure > Control Engines.
The Control Engines dialog box opens.

8" Control Engines

M arme |.P. Address

If you have not previously configured a control engine for the PAC Display project you opened, the Name
list is empty and only the Add button is available.

3. Tolocate a PAC Control strategy, click Add.

3For instructions to start PAC Display Configurator, see page 7.
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The Strategy File Name Selection dialog box appears.

‘ﬂ Strategy File Mame Selection

==l

OO | .« Display » ioCookies »

Organize « MNew folder

W Favorites
Bl Desktop
4. Downloads

m

= Recent Places

4 Libraries
3 Documents
J? Music
il PAC Project
= Pictures

EE videos

Search ioCookies

v|¢’|

Documents library

ioCookies

Arrange by:

MName

. PROJECT_BACKUP

L] i |

o
- A @

Folder «

3

File name:

- ’PAC Control Strate;

gy (idb)  ~|

Coren

M |

Cancel ]

NOTE: PAC Display gets its tag database from a PAC Control strategy that you provide with properly configured
1/0 units and points. The strategy does not need to have any logic. For information on creating a PAC Control

strategy, see the PAC Control User’s Guide (form 1700).

Navigate to the PAC Control strategy, select the strategy file and click Open.

The strategy you selected appears in the Strategy field of the Control Engine Properties dialog box.

Contrel Engine Properties

Primary Control Engine

X

M arme: |

| Browsze. .

Backup Contral Engine

M arme: |

| Browse...

Strateqy: |c:'\users'\public\documenls'\opto 22\pac prniecl

Browsze. .

Cancel

Make Path Relative to Project [

Help

NOTE: This dialog box is slightly different in PAC Display Professional, but the Strategy section and corresponding

Browse button are the same.

Click the Browse button in the Primary Control Engine group. You do not need to define a Backup Control

Engine.
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The Select Control Engine dialog box opens.

Select Control Engine

Configured Control Engines:

- Add...
Maodify...
Delete
W

6. Click Add to add a control engine.
The Control Engine Configuration dialog box appears.

Control Engine Configuration x

Configure Ethemet Connection

Configure control engine name and parameters:

Contral Engine Name: ||

System Type
(®) Standard
() Redundant Networks (PRO only)
() Redundant Contrallers (PRO anly)

Settings
IP Address/Hostname: [0.0.0.0

Controller Port:

Software Retries:

Software Timeout: msec

Cancel

7. Enter a Control Engine Name.
The name can contain letters, numbers, spaces, and most other characters except colons and square
brackets. Spaces cannot be used as first or last characters.

8. Enteravalid IP address that does not exist on the network. For assistance, ask your system administrator.
9. Make sure that you have not changed the values in the Port, Retries, and Timeout, and then click OK.
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The non-existent control engine appears in the Select Control Engine dialog box.

Select Control Engine

Configured Control Engines:

Cookie Controller

[ OK ]’ Cancel l

Add...

PAC Control Engine
Phantom Control Engine k

10. Click the new control engine to select it, and then click OK.
The Control Engine Properties dialog box appears with the new control engine listed in the Primary

Control Engine group.

Control Engine Properties

Primary Contral Engine

Mame:  Phantom Control Engine

Backup Contral Engine

Mame;

Strategy:  ohuzershpublichdocumentshopto 22hpac projec

X5

Browsze. ..

Browse. .

Make Path Relative to Project [

[ 0K ][ Cancel ][

Help

]

11. To change the path of the strategy to be relative to the current PAC Display project, select Make Path

Relative to Project.

This allows the project to be more easily transferred to other PCs that don't have the exact same file

structure.
12. Click OK.
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The Control Engines dialog box appears with the new control engine.

7 | Control Engines @

Hame I.F. Addrezs Strategy Mame

Add..
Phantom Control.. 115115115115 Fhantar Contral —

| k. |l Cancel ” Help ]

13. Click OK to finish configuring the control engine.
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6: Working with Graphic Objects

INTRODUCTION

This chapter describes how to use PAC Display Configurator to create and edit graphic objects, and how to
import images. It also describes how to configure the windows in which these items appear.

In This Chapter

Using Draw Windows and URL Windows page 91
Drawing Graphic Objects page 100
Selecting Graphic Objects page 103
Grouping and Locking Graphic Objects page 105
Applying or Changing Line Attributes page 105
Applying or Changing Fill Attributes page 107
Importing Graphics page 107
Saving Objects as Bitmaps page 109
Copying, Duplicating, and Pasting page 109
Moving and Resizing Graphic Objects page 110
Changing Stacking Order page 113
Deleting Graphic Objects page 115
Aligning Graphic Objects page 115
Rotating Objects page 116
Flipping Objects page 118
Applying Transparency to Graphic Objects.......esveesonen page 118
Working with Text page 119
Adding a Windows Button or a PID BUTION......cccccceeereceriereesssnns page 121
Adding a Windows Combo Box page 124
Adding a URL Control page 131
Working with Tables page 134
Printing page 137

USING DRAW WINDOWS AND URL WINDOWS

Draw windows in PAC Display Configurator are “blank pages”in a PAC Display project where you place and
edit graphic objects (including Trend, SuperTrend, and alarm objects). When you create a draw window, you
can define its size, position, and color, as well as its behavior (child window or popup window) when the
project opens in Runtime.

(Pro Only) In addition to draw windows, you can configure URL window, which are a simplified browser
window that opens a specific URL. For example, you can use a URL window to display information at a
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particular website, or display a web-based interface such as Opto 22's groov (see "Adding a groov URL
Window” on page 93). When you create a URL window, you can define its size and position, as well as its
behavior (child or popup) when the project opens in PAC Display Runtime. Forward and back buttons are
provided for navigation. There is no keyboard support for static web pages in a URL window. See also, “Adding
a URL Control”on page 131.

Draw windows and URL windows can be protected with a password, and be set up to open when an alarm is
triggered. You can also configure whether menus, borders, scroll bars, and other standard window elements
appear.

Creating and Deleting Windows

When you create a new PAC Display project, one draw window appears in the main project window. To create
additional draw windows, you can create a new window, or copy an existing window and its attributes.

Making a New Window
1. InBasic, click Window > New.
In Pro, click Window > New > Graphic Window (or URL Window).
The New Window dialog box opens.
2. Enteraname for the window, and configure other settings as necessary.
See “Modifying Draw or URL Windows” below for instructions on configuring windows.
3. Click OK when done.
The new window appears in the project window.

Copying an Existing Window
1. Click Window > Copy.
The Copy Window dialog box opens.
2. Entera new name for the window, and configure the existing settings if necessary.
See "Modifying Draw or URL Windows” below for instructions on configuring windows.
3. Click OKwhen done.
The new window appears in the project window.

Deleting Existing Draw Windows
1. Click Window > Delete.
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The Delete Window(s) dialog box appears.

Delete Window(s) %

Select One or More Windows to Delete

Select Al

SuperTrend Examples

Cancel Help

2. Selectasingle window, or select multiple windows by clicking Select All or by holding down the Ctrl key
while selecting windows.

3. Click OK.
If you selected more than one window, a message warns that deleting the windows cannot be undone.
4. C(lickYes in the message box that appears to confirm the deletion.

Adding a groov URL Window

If you have Opto 22's groov on your network, you can access your groov project in Runtime by creating a URL
window that points to groov. When you create the window, make sure to enter the exact same URL for groov
as you would in a regular browser including “https://."

PAC Display User's Guide 93



USING DRAW WINDOWS AND URL WINDOWS

Because groov is a web application rather than a static web page, you can use all of groov features from within
a PAC Display URL window. For more information about groov, see the groov Build and View User’s Guide (form
2027). Also see, “Adding a groov URL Control”on page 133.

-

groov

— Vo lde o\ V4 -
Machine Power

True Power Sum (watts): 1,284.0
(@] )

Phase A

121.87

" 5 140+
/w |° SN :
S0 MW, 130 -
[ S ~ 2
[20 = =80 | 1207
\ 105/ Sen / 110=
r N .

0 (484 )100 100+
__AMPS :

—— 90~

Volts
Amps: 5 Volts: 122

Watts: 416 Volt-Amps: 564

Phase B

Modifying Draw or URL Windows

NOTE: For additional security features, see:

«  “Protecting a Project with a Password"on page 46 to assign a password to the PAC Display project to
prevent unauthorized users from opening it in PAC Display Configurator.

o “Security Settings for Graphic Objects and Dynamic Attributes”on page 176 to allow or deny operator access
to individual graphic objects, based on configured, authorized users and groups.

«  "Runtime Setup: Security Tab” on page 297 to allow operator access to the HMI, as well as log all HMI use
and operator actions to an encrypted archive.

«  “Viewing Logged-In Users in Runtime”on page 325 to view a list of the users currently logged in to PAC
Display Runtime.

You can change many properties of a new or existing window, such as the window’s position and behavior,
among others . These properties are set in the Window Properties dialog box. To open this dialog box, do one
of the following:

«  (Create a new window or copy an existing one.

o (lickawindow to select it, and then choose Window > Properties.

The Window Properties dialog box appears.
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Window Properties Dialog Box

Window Properties *
Runtime Options -1 G

é ——Mame: |Alarms | Alwayz in memory [fastest access]

% Position: Width: Open when there are new alarms
C— [] Disable close if there are active

' Pozition: |1 Height: |15 alarms
D —— [ showScrolbars  Fescale on Fesize q L] Allow controller switching
E Password Protect. — H

Tranzparency.. ———— T — |

F — 1 Control Behavior Background Color J

Eorder Size handles (®) Child K

Caption Syztem meny tinimize bos () Popup

Cancel Help

(A) Name. Enter the name of the window. This name appears in the window's title bar unless the title bar is
hidden by unselecting the Caption option in the Control group (F).

(B) Width and Height. Enter the width and height of the window. Width and height are measured in
pixels.

(C) Xand Y Position. Enter the X and Y coordinates where the window appears in the project window. The
X andY coordinates indicate the location, in pixels, of the draw window's upper-left corner; the upper-left
corner of the project window has X and Y coordinates of 0.

(D) Show Scroll Bars. Select this option to display scroll bars when graphic objects extend beyond the
borders of the window. This option overrides the global Configurator Options scroll bars setting (see
“Configurator Options” on page 356).

NOTE: Changing this setting after initially creating the window clears undo history for the project; you will be
unable to undo (Edit > Undo) any changes you made to the project.

(E) Rescale on Resize. Check this box to rescale the window graphic objects when the window size is
changed in this dialog box. In order for window graphic objects to be correctly scaled, make sure to disable
“Show window contents while dragging”in Windows as described below. You can undo a rescaled graphic
object using this method. However, undo is not exact, due to rounding when the graphic object is rescaled.
Combo Box graphic objects rescale only their width, not height.

To disable “Show window contents while dragging:”

1. In the Windows Control Panel, click System.

2. Onthe left sidebar, click “Advanced system settings.”

3. Inthe Performance section, click Settings.

4. Uncheck “Show window contents while dragging,”and click OK.

(F) Control. Use the options in the Control group to configure the appearance of the window. Select or
unselect the following options:

Border—Hides or displays the narrow edge of the window. This option must be selected for the other
options in the Control group to be available.

PAC Display User's Guide 95



USING DRAW WINDOWS AND URL WINDOWS

96

Caption—Hides or displays the bar at the top of the window where the window name appears. This
option must be selected to move the window within the larger project window.

Size handles—If selected, lets you resize the window by clicking and dragging an edge or corner of the
window.

System menu—Hides or displays the small system menu icon and the Close Window button located at
the top of the window. This option is unavailable if the Caption option has not been selected.

Minimize box—Hides or displays the standard Windows close box in the upper-right corner of the
window. This option is unavailable if the System menu option has not been selected.

(G) (Draw window only) Runtime Options. (Use the items in the Runtime Options group to configure
how the window opens when the project is run in PAC Display Runtime. Select or unselect the following
options:
Always in memory (fastest access)—If selected, the window's information is loaded and saved in the
computer’s memory when the project runs. Use this option for a window that you know will be opened
and closed often. This option is selected automatically if you place an alarm graphic in a window.

Normally, only windows that have been opened or iconified are saved in memory. If you use this option
with many windows, more computer memaory is required, and your PAC Display project will require more
time to start up. Using this option with fewer windows uses less memory, and your project will start up
more quickly.

Open when there are new alarms—If selected, a closed or iconified window that contains an alarm
graphic will open when the alarm is triggered. This option is available only if a window contains an alarm
graphic that s set to summary or detailed view. For more information on configuring alarms, see “Adding
Alarm Graphics”on page 273.

Disable close if there are active alarms—If selected, prevents an open window that contains one or
more active alarms from being closed. All active alarms in a window must be acknowledged before the
window can be closed. For more information on working with alarms, see “Viewing Alarm Graphics”on
page 330, "Modifying Alarm Points”on page 331, and “Disabling Alarm Points in Runtime” on page 333.
Allow control engine switching—If selected, all graphic objects in the window can use data from the
same PAC Control strategy running on a different control engine. The operator switches between control
engines in Runtime. For more information on using data from multiple control engines, see “Switching a
Window Between Control Engines”on page 329.

(H) Password Protect. To assign a password to a window, click here and then enter a password in the
dialog box that appears. When a password is assigned to a draw window, a closed window cannot be opened
without first entering the password. (Open windows that are iconified or hidden are not affected.)

You cannot assign a password to a window that both contains an alarm and has the Runtime option “Open
when there are new alarms” selected.

(1) Transparency. (Applicable only when using Windows 8.1 or higher) This feature applies transparency at
Runtime to a draw window or (Pro only) URL window. This way, you can make an entire window (and all the
objects in it) partially or totally transparent to Runtime users. (To apply transparency to individual graphic
objects and not to the window, see page 118.)

To apply transparency to the window and its objects:
1. Click the Transparency button to open the Set Transparency dialog box.

2. Use the slider bar control (or type a number in the Current Transparency field) to define the window’s
transparency. A value of 0 is completely opaque (no transparency); a value of 100 is completely
transparent.

As you change the transparency value, the transparency of the window and its objects change so that
you can see how they will appear in Runtime.

3. Select OK to save the setting and close the dialog box.
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When you close the dialog box, the window and its objects are displayed as completely opaque. This lets you
see them so you can configure them. However, in Runtime, the window and its objects are displayed with the
configured transparency setting.

(J) Behavior. Use the options in the Behavior group to set how the window appears on-screen when the
project is run in PAC Display Runtime. Select one of the following options:
Child—prevents the window from being moved or minimized outside the boundaries of the main
project window.
Popup—Iets the window be moved or minimized outside of the main project window.

(K) Background Color. (Graphic window only) To set the background color of a window, click the color
square and then select a color in the dialog box that appears.

URL Window Properties Dialog Box (Pro Only)

Window Properties X

Runtime Ophions

Marne; |Dpto 22

% Position: IZI Width: Open when there are new alamsz

Dizable cloge if there are active

' Pogition; ICI Height; alarmz

Always in memony [fastest access)

Allove controller swaitching

|http:.-’f'www.opto22.corn Pazzword Pratect. .

Refresh Every:; EI gec, | Userbgent.
[ Hide Navigation Contrals

Transparency...

Cattrol Behavior Background Calor

Border Size handlies (®) Child l:l
Caption [ Svstemmenu | Minimize box ) Popup

Cancel Help

A URL window has these additional properties:

URL window options.
URL—Type the URL of the target webpage.
Refresh Every ____sec.—To refresh the webpage at a specific interval, type the number of seconds in
the text box. This is useful for updating static images like a weather radar or images from a security
camera.
User Agent— To specify the target browser and operating system, click the User Agent button, and
then, in the User Agent String dialog box, type a correctly formatted user agent string. This feature lets
you override the default User-Agent value in header messages sent to the web server. (User-agent strings
are typically advanced settings used when testing web applications with different browsers.) For help
creating user agent strings, contact your IT department, or see the Microsoft Developer's Network
website at https://msdn.microsoft.com/en-us/library/ms537503(v=vs.85).aspx.
To set a global user agent string for all URL controls and URL windows in all of your PAC Display projects
(which takes precedence over objects configured with the User Agent button), perform these steps:
a. InWindows File Explorer, navigate to the folder where PAC Display is installed. (The default folder is
C:\Program Files (x86)\Opt022\PAC Project.)
In the folder, create a text file and name it PAC DisplayUserAgentString.txt
c. Inthetext file, type a correctly formatted user agent string. Don't type anything else in the text file.
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d. Close and save the text file. When a project is loaded in Runtime, PAC Display uses the user agent
string in the PAC DisplayUserAgentString.txt for all URL controls and URL windows

Hide Navigation Controls—Check the box to hide the forward and back navigation buttons.

Opening and Closing Draw and URL Windows

To open or close a draw or URL window in your PAC Display project:

1. From the Windows menu, select Open or Close.
The Open Windows or Close Windows dialog box appears.

2. (lick the name of the window you want to open or close, and then click OK.
See the next section to learn how to select or deselect multiple window names.

Other ways of opening and closing windows include the following:

«  Toopen awindow that has been opened previously, select its name from the bottom of the Windows
menu.

«  Toclose awindow in which the system menu appears, click the Close button E3 in the upper-right
corner.

Working with Multiple Windows

There are several ways to select or deselect multiple window names in the Open Windows or Close Windows
dialog box.

»  Toselect individual window names, hold down the Shift key and click each window name.
«  Tohighlight all names in the list, click Select All.

«  Tonot select any name in the list, click Deselect All.

«  Toeasily close or open all but one window, click a single name and then click Inverse.

Importing, Exporting, and Saving Windows

A PAC Display window can be exported from one project, saved as a file, and then imported into another PAC
Display project. The exported window file contains all the objects and tags that were in the original window.
Exporting and importing draw windows is a convenient way to reuse the same window in different PAC
Display projects.

Exporting Windows

To export a window in a PAC Display project:

1. Select the window in your PAC Display project that you want to export.
The window must be open within the Configurator window.

2. Click Window > Export Window.
The Export Window As dialog box opens.

3. Navigate to the location where you want to save the exported window file, name the file, and then click
Save.

Importing Windows

To import a window in a PAC Display project, do the following:
1. Select Window > Import Window.
The Import Window dialog box opens.
2. Navigate to the location where the exported window file is saved, select the file, and then click Open.
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The Choose Imported Window Control Engines dialog box opens.

Choose Impeorted Window Centrol Engines

Imparted “Window Cantrol Engines Current Contral Enagines

D Mame Usze this; D Mame
5 o PAC R1

[ Ok ][ Cancel H Help l

S

The left pane lists control engines configured in the imported window. The right pane lists control
engines configured for the current project.

To map a control engine to the imported window:
a. Select a control engine in the left pane, and then select a current control engine in the right pane.

The name of the mapped control engine appears in the “Use this” column of the Imported Window
panel (left panel).

“Use this" column

Cheose Imported Window Control Engines
Imported “window Contral Enagines Current Control Engines
I Hame Use this: I Hame
0o PAL Sim Cartral Engine o FAC R1
b. Click OK.
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The Window Properties dialog box appears.

Window Properties @

Buntime Options

[l rported e ird o [] Aalwways in memary [fastest access)

% Positian: 0 width: 400 Open when there are new alarms

Dizable close if there are active
Y Pogtion, 0 Height: 400 alarmsz

. Al troll ithi
et Gl [T] Allow controller switching

[ Password Protect... ]

LControl Behavior Background Color
Border Size handles @ Child l:l
Caption [ Spstem menu irirmize box () Popup

[ ok l [ Cancel ] l Help l

In the Name field, change the default name “Imported Window" to a suitable name for your project.
5. Change other properties of the window if needed, and then click OK. See “Modifying Draw or URL

Windows"on page 94 for more information on changing window properties.

The window is added to the PAC Display project.

6. Ifthe new window is not visible in the project window, select Window > Open, choose the window in
the list that appears, and then click OK.

NOTE: When a window is imported into a PAC Display project, the tags used by objects in that window are not verified

for accuracy. Run AutoCorrect tags on the window after importing it. See “When to Use AutoCorrect Tags” on page 83
for instructions.

DRAWING GRAPHIC OBJECTS

Once you've opened a project in PAC Display Configurator, you can use the drawing tools in the PAC Display
toolbox to create graphic objects in your active window. For descriptions of the tools and shortcut keys, see
“Using the Graphic Tools and Shortcut Keys"on page 101.

Follow these general steps to draw a graphic object:

1. If your toolbox is not visible, click View > Toolbox to see the toolbox as it appears below. (You can close
the toolbox by selecting View > Hide Toolbox.)

ﬂTﬂDB x
> |O[o[o]o|w|N
Bgl A [pv | 751 | /)
[0w)| = )

A B01 Y 433

W H:

2. Select a drawing tool from the toolbox by clicking it.
The cursor will turn into a crosshair.
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3. (lickthe crosshair in a window, then drag it in any direction to create a graphic object.

Sample Window

In the example above, the Round Rectangle tool @ was selected.

Using the Graphic Tools and Shortcut Keys

Select a tool either by clicking it in the toolbox or by using a shortcut key shown in the table below. For some
tools, you can use additional keys to change what the tool does.

To use the additional keys:

1. Select the tool using either a button or shortcut key.
2. Ifyou used a shortcut key, release it.

3. Hold down the additional keys as you draw the graphic object.

Tool Shortcut Key Additional Keys Use
Select
ro- Enter or Select, move, and resize graphic objects
P Spacebar ’ ’ grap 4 '
Line Draw straight lines.
\ \ Ctrl Draw constrained straight lines at angles of
90 degrees.
Draw squares and rectangles.
Draw squares with the reference point in the top left
Rectangle Ctrl comer.
[
|:| Shift Draw rectangles with the reference point in the
center.
Shift+Ctrl Draw squares with the reference point in the center.
Draw squares and rectangles with rounded corners.
ctrl Draw squares with rounded corners with the
Round reference point in the top left corner.
Rectangle
R Shift Draw rectangles with rounded corners with the
[:I reference point in the center.
. Draw squares with rounded corners with the
A reference point in the center.
Draw circles and ellipses.
Ellipse ctrl Draw circles with the reference point in the top left
E corner.
O : — —
Shift Draw ellipses with the reference point in the center.
Shift+Ctrl Draws circles with the reference point in the center.
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Shortcut Key Additional Keys

Draw polygons as follows:

 Drag and click to form vertex points.

* Double-click the last vertex to close the polygon.

= Sizing handles appear around the object. If you

O can’t select the polygon later with the Select tool,
the polygon is not complete.

» Refresh the window (View > Redraw) to remove
incomplete graphic objects.

Polygon

Draw connected lines as follows:

* Drag and click to draw connected lines.

* Double-click the last line drawn to finish the

L polyline. Sizing handles appear around the object.

M If you can’t select the polyline later with the Select
tool, the polyline is not complete.

* Refresh the window (View > Redraw) to remove
incomplete graphic objects.

Polyline

Draw curves as follows:

¢ Click at least four points in the draw window to
draw a curve.

 Thereafter, click points one at a time in groups of

Bezier Curve three to continue drawing the curve.

J/-\"-. C * Double-click the last point to finish the curve.

Sizing handles appear around the object. If you

can’t select the curve later with the Select tool, the
curve is not complete.

* Refresh the window (View > Redraw) to remove
incomplete graphic objects.

Bitmap Place bitmap graphic files selected with File >
BH B Choose Bitmap. Once the bitmap has been chosen,
P just click to place the bitmap in the window.

Write text for labels and titles.

* Put your cursor where you want the text to start.

¢ Type your text.

¢ When finished, click the mouse away from the text
you just typed or press Enter.

Text  Modify text by selecting it with the Select tool and

A T by using Edit > Edit Text.

The text tool is also used to create text objects

which, when configured with the Text-In (from

Control Engine) dynamic attribute, are used for

viewing strings and other values from the control

engine. See “Text In from Control Engine” on

page 157 for more information.

Trend Used to draw graphs that display real-time data
EE G against time. See Chapter , “8: Working with
Trends,” for more information.

SuperTrend Draw graphs that display both real-time and
lf_\?' Y historical data against time. See Chapter , “8: Work-
..... ing with Trends,” for more information.

Alarm Draw objects that display alarms and other status
i A information. See Chapter , “9: Configuring Trig-
@ ger-Based Events,” for more information.

XY Plot Draw graphs that display data plotted on x and y
l_ X axes. See Chapter , “8: Working with Trends,” for
E3 more information.
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Tool Shortcut Key Additional Keys Use
Table Display data from up to sixteen tables. See
D Q “Working with Tables” on page 134 for more
information.

Resize a window and the graphic objects inside at

7 the same time. See “Resizing a Window and the

E] Graphic Objects Inside” on page 111 for more
information.

Scale Window

Windows Button Add a Windows button. See also, “Adding a Win-

v dows Button or a PID Button” on page 121.
EENLELES M Add a combo box. See also, “Adding a Windows
Combo Box” on page 124.

(Pro only) Add a PID button. See also, “Adding a
Windows Button or a PID Button” on page 121

(Pro only) Create a URL control. See also, “Adding
a URL Control” on page 131.

18 5| 3|

SELECTING GRAPHIC OBJECTS

You can use the Select tool to choose one or more graphic objects in a draw window.

When a graphic object is selected, several solid black sizing handles appear, along with one transparent
selection mark. The selection mark shows you whether you've selected a single graphic object or several
objects in a group. Each graphic object in a group has a selection mark. Sizing handles can be used to resize
the graphic object, which we'll talk about a little later in this chapter.

Selecting One Graphic Object

The simplest way to select a graphic object in a window is to click it with the Select tool. You can also select a
graphic object by clicking and dragging.
1. Choose the Select tool m from the toolbox.

2. (lick the cursor just outside the graphic object you want to select and drag the cursor completely over
the object.

A selection box should appear as shown below:

Sample Window
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NOTE: Ifyou drag the cursor from left to right, you must completely enclose the object in the selection box to
select it. However, you can also select an object by dragging the cursor from right to left over only part of the
object.

3. After you release the mouse button, several sizing handles and one selection mark appear around the
selected object.

Sample Window

Selection Mark . -
- - | Sizing Handle
.
[ | [ ] [ ]

Selecting More Than One Graphic Object

There are a few ways to select multiple graphic objects. The simplest way is to click and drag.
1. Choose the Select tool . from the toolbox.

2. (lick the pointer just outside the objects you want to select and drag the pointer across the group of
objects you want to select.

Make sure that you include all the objects within the selection box that appears.

After you release the mouse button, several sizing handles and one selection mark will appear around
the selected objects.

Sample Window

Another way to select several objects is to choose the first graphic object using the Select tool, then hold
down the Shift key and click each additional object you want included in the selection group. Notice that a
selection handle appears on each object you add to your group of objects.

Selecting All Graphic Objects

To select all the graphic objects that appear in your active window, choose Edit > Select All (Alt+E+S). You
can also right-click and choose Select All from the pop-up menu.

Deselecting One or More Graphic Objects

The easiest way to deselect one or all graphic objects is to click anywhere outside the sizing handles. All of the
handles disappear and no graphic objects are selected.
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From a selected group of objects, you may need to pick some graphic objects you actually want as part of a

final selection group. You can do this by using key combinations.

«  Todeselect an object within a group of selected objects, hold down the Shift key and click the object you
don’'t want to include.

«  Toselect only one object within a group of selected objects, hold down the Ctrl key and click the object.
This deselects all other objects.

GROUPING AND LOCKING GRAPHIC OBJECTS

You can combine two or more graphic objects into a group so that they are handled as one object. You can
then manipulate the graphic object as one unit. As a unit, the grouped graphic objects can be selected,
moved, resized, and have dynamic attributes assigned. You can also lock the position of a graphic objectin a
draw window so it can't be moved.

NOTE: You cannot group:

Buttons URL controls Combo boxes PID buttons

CAUTION: If you group objects, PAC Display Runtime processes only the dynamic attributes assigned to the group.
Dynamic attributes assigned to individual members of a group are ignored. If a group is later ungrouped, any
previously configured dynamic attributes of the individual graphic objects will be recognized and processed in
Runtime.

To group objects:

1. Select two or more graphic objects.

2. Choose Edit > Group. (You can also right-click and choose Group from the pop-up menu.)
There will be no visible change, but the objects are collected into one group.

To ungroup objects:
3. Select a set of graphic objects that were previously grouped.
4. Choose Edit > Ungroup, or right-click and choose Ungroup from the pop-up menu.

You will see the sizing handles still appear around the former group. Click off the graphic objects and
then click an individual object. You will see it's not part of the group anymore.

To lock objects in position:

After you've arranged several objects in a draw window, sometimes it can be useful to lock the position of one
or more items so they aren't accidentally moved. To lock one or more graphic objects, select the item(s) and
click Edit > Lock Position. To unlock graphic objects, select the item(s) and click Edit > Unlock Position.

APPLYING OR CHANGING LINE ATTRIBUTES

NOTE: Ifyou select more than one graphic object and the objects have different line or fill attributes, no attributes will
appear in the menus and dialog boxes for each attribute. However, you can still select new attributes for all selected
lines.

1. Do one of the following:
- To change attributes for one or more existing objects, select the object(s) using the Select tool.
- Toset attributes for subsequent graphic objects that you create, do not select any object.

2. Choose the line attributes you want to apply to the selected object(s).

- Tochange the line color, click Style > Line Color, then choose a color from the Color dialog box and
click OK. (You can also right-click the line, and then choose Line > Color from the pop-up menu.)

- To change the line width of a solid line:
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Tho

Right-click the line, and in the pop-up menu, click Line > Width (or click Style > Line Style from the
menu bar).

In the Pen Width dialog box, type the desired pen width. (Pen widths are measured in pixels.)
Click OK to close the dialog box and save the setting.

Non-solid (for example, dotted or dashed) lines have a maximum pen width of 1 pixel, unless you
apply the transparency feature (described on page 118) before configuring the line width. For
example, if you create a dashed line (without first applying the transparency feature) and then
change the width to a value greater than 1 pixel, the dashes disappear and the line becomes a solid
line.

To create a non-solid line that is greater than 1 pixel wide:

- Right-click the line, and in the pop-up menu, click Line > Style.

—  Then, select the desired style. The pop-up menu automatically closes.

Right-click the line again, and in the pop-up menu, click Transparency. In the Set Transparency
dialog box, type a value greater than 0. (100—completely transparent—is the maximum value.)
Click OK to close the dialog box and save the setting.

Right-click the line again, and in the pop-up menu, click Line > Width.

In the Pen Width dialog box, type the desired with in pixels, and then click OK to close the dialog
box and save the setting.

To change the line style, click Style > Line Style, then choose a line style from the list that appears
(shown below). (You can also right-click the object, choose Line > Style from the pop-up menu,
then select a line style from the list that appears.)

¥ PAC Display Configurator, Professional - cfactory.UUI

File Edit Wiew BEEUEN Text  Configure  Tools  Window  Help

Line Colar,..
Line Width. ..

Dash Q

Fill Colar, ..
Background Color, .,
Fill Pattern

0ul

Dashdat

Drashdokdak
Opaque Invisible

v Transparent

To change the opaque or transparent attributes of a line, select the appropriate attribute from the
Style menu.

The opaque attribute lets the background color of the window show between the dashes in a line.
The transparent attribute lets an object’s color show between the dashes in a line.

(The transparent attribute is not the same as the transparency feature. To apply transparency to a
line, see page 118
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Samples of opaque and transparent line attributes are shown in the image below.

Sample Window

—— Opaque

—— Transparent

APPLYING OR CHANGING FILL ATTRIBUTES

NOTE: If you select more than one object and the graphic objects have different line or fill attributes, no attributes will
appear in the menus and dialog boxes for each attribute. However, you can still select new attributes for all selected
lines.

1. Do one of the following:

- To change attributes for one or more existing graphic objects, select the object(s) using the Select
tool.

- Toset attributes for subsequent graphic objects that you create, do not select any object.

2. Choose the fill attributes you want to apply to the selected object(s):

- To change the fill color, click Style > Fill Color, then choose a color from the Color dialog box and
click OK. (You can also right-click, choose Fill > Color from the pop-up menu, choose a color from
the Color dialog box, and click OK.)

- To change the fill pattern, click Style > Fill Pattern and choose a fill attribute. A fill color other than
white needs to be in effect in order to see the new fill pattern. (You can also right-click, choose Fill >
Pattern from the pop-up menu, and choose a pattern.)

- To change the background color used behind a fill pattern, click Style > Background Color, then
choose a color from the Color dialog box and click OK. (You can also right-click, choose Background
> Color from the pop-up menu, choose a color from the Color dialog box, and click OK)

IMPORTING GRAPHICS

You can easily import bitmap graphics, Windows Metafile graphics, JPEG, PNG, and GIF images into a PAC
Display window to enhance or add detail to your operator interface. For your convenience, PAC Display also
includes the Symbol Factory, a large library of graphics designed especially for industrial applications.

“Importing a Bitmap Graphic” (below)

“Importing a Metafile, JPEG, or PNG Graphic”on page 108
“Importing a GIF Graphic”on page 108

“Importing a Graphic from the Symbol Factory”on page 109

Importing a Bitmap Graphic

A bitmap graphic is a picture, drawing, or other image saved in Microsoft Windows BMP file format. Bitmap
graphic files have the file extension .bmp. If you'd like to use bitmap graphics in your project which have been
saved in another graphic file format, such as TIFF (file extension tif), you must first convert the file to BMP
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format. Commercial and shareware applications that can do this are widely available; two popular commercial
image editing and conversion applications for Microsoft Windows are Paint Shop Pro® and Photoshop®.

To import a bitmap graphic into your PAC Display project, first choose the bitmap image you want to use, and
then use the Bitmap tool to place the bitmap in the window.

1. Click File > Choose Bitmap.

2. Inthe Choose a Bitmap dialog box that appears, navigate to the folder that contains the bitmap graphic
you want to use, and then select the file name and click Open.

3. Select the Bitmap tool in the toolbox and click the pointer in the desired location in the window.
The bitmap is centered at the location you have clicked.

Importing a Metafile, JPEG, or PNG Graphic

The Microsoft Windows Metafile (WMF) format was first introduced by Microsoft in 1988. Like GIF and PNG,
the WMF format supports transparency. However, PNG and GIF images usually look better than WMF images
in PAC Display.

The Joint Photographic Experts Group (JPEG) file format is a highly compressed format commonly used for
photographs. This format is often used for displaying images in a Web browser.

The Portable Network Graphics (PNG) file format provides transparency, and it supports lossless data
compression so that the image is perfectly reconstructed from the compressed data. PNG images are a good
choice for use in your PAC Display project.

To import a Windows Metafile, JPEG, or PNG graphic into your PAC Display project:

1. Click Edit > Paste from File > Import (Metafile, JPEG, or PNG). (You can also right-click and select Import
Metafile, Import JPEG, or Import PNG from the pop-up menu.)

2. Inthe Import dialog box that appears, navigate to the folder that contains the graphic you want to use,
and then select the file name and click Open.

The selected file is placed in the active draw window.

You can also import a Metafile, JPEG, or PNG graphic used in another program by copying or cutting the
graphic to the Windows clipboard, and then pasting it in the project draw window.

Importing a GIF Graphic

You can import either static or animated GIF images into a PAC Display project. When using GIF images in PAC
Display, keep the following things in mind:
«  Onceimported, GIF images cannot be resized or rotated.

«  Animated GIFs appear as static GIFs in Configurator, displaying only the first frame of the animation.
Animation occurs in Runtime.

«  The GIF image's transparent color may not be set or changed in PAC Display. Use another image editing
program to change the transparent color before importing the image into PAC Display.

«  Visibility/Blink is the only Control Engine Driven attribute that can be applied to GIF images. The only
options are Visible and Invisible. Blink options are not available for GIF images.

To import a GIF graphic:
1. Click Edit > Paste from File > Import GIF. (You can also right-click and select Import GIF from the pop-up
menu.)

2. Inthe Import dialog box that appears, navigate to the folder that contains the graphic you want to use,
and then select the file name and click Open.

The selected file is placed in the active draw window.
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Importing a Graphic from the Symbol Factory

To import a graphic as a Windows Metafile graphic from the Symbol Factory into your PAC Display project:
1. Click Edit > Paste from File > Symbol Factory. (You can also right-click and select Symbol Factory from
the pop-up menu.)
The Symbol Factory window opens.

2. Browse through the categories and thumbnails of graphics until you find the graphic that you want to
use.

3. (lick the graphic and drag it into the PAC Display draw window.
You can also click Edit > Paste as Picture (.wmf) Only.

The selected graphic is now available as a Metafile graphic in the active draw window. The Symbol Factory
window will remain open until you close it, or until you exit PAC Display Configurator.

Bitmap Graphics in Symbol Factory

Although Symbol Factory graphics are provided as Metafiles, you can also import these graphics as bitmaps.
To import a graphic as a bitmap graphic from the Symbol Factory into your PAC Display project:

1. Click Edit > Paste from File > Symbol Factory. (You can also right-click and select Symbol Factory from
the pop-up menu.)
The Symbol Factory window opens.
2. Browse through the categories and thumbnails of graphics until you find the graphic you want to use.
3. (lick the graphic and then click Edit > Copy.
4. Switch to the PAC Display draw window and click Edit > Paste.

The selected graphic is now available as a bitmap graphic object in the active draw window. The Symbol
Factory window will remain open until you close it, or until you exit PAC Display Configurator.

SAVING OBJECTS AS BITMAPS

After creating one or more objects in a draw window, you may want to save the object as a bitmap graphic
file. This is useful, for example, if you want to document your operator interface.

NOTE: Saving a graphic object as a bitmap graphic file is not the same as copying an object, then pasting it into
another window. When a graphic object is saved as a bitmap, it loses all dynamic attributes and other properties it
has been configured with.

1. Use the Select tool to select the graphic object you want to save as a bitmap.
If you don't select a graphic object, the entire active window will be saved as a bitmap file.
2. (lick File > Save as Bitmap.

3. Inthe Save as Bitmap dialog box that appears, navigate to the desired folder and enter a file name. (You
can enter a three-letter extension other than .bmp, but the file will still be saved as a bitmap image.)

4. C(lick Save to save the image.

COPYING, DUPLICATING, AND PASTING

There are two ways that you can make copies of graphic objects you've created or added to a window. You
can copy one or more graphic objects to the Windows clipboard, or duplicate the selected object(s) in the
same window without affecting the contents of the clipboard.

You can also copy graphic objects into your PAC Display project from another project, but both projects must
be created with the same version of PAC Display. Graphic objects created in an OptoDisplay project cannot be
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used in a PAC Display project. (OptoDisplay is an HMI application similar to PAC Display that is part of Opto 22's
FactoryFloor software suite.)

Copying and Pasting a Graphic Object

Select one or more graphic objects.

2. Choose Edit > Copy. (The keyboard shortcut for this command is Ctrl+C or Ctrl+Ins. You can also
right-click and choose Copy from the pop-up menu.)

The selected objects are copied to the Windows clipboard.
3. (lickthe window where you want to paste the object(s).

Choose Edit > Paste. (The keyboard shortcut for this command is Ctrl+V. You can also right-click and
choose Paste from the pop-up menu.)

The clipboard contents are pasted in the center of the active window.

Duplicating a Graphic Object

Select one or more graphic objects.

2. Choose Edit > Duplicate. (The keyboard shortcut for this command is Ctrl+D. You can also right-click and
choose Duplicate from the pop-up menu.)

A copy of the graphic object is placed immediately below the selected object. Note that the contents of
the Windows clipboard are not affected by duplicating a graphic object.

MOVING AND RESIZING GRAPHIC OBJECTS
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To build your operator interface, you will need to be able to position, resize, and reshape graphic objects. This
is done using the Select tool with different options. (Objects can also be positioned and resized by entering
values in the Graphic Dynamic Attributes dialog box; see "Chapter 7: Using Animated Graphic Objects" on
page 139 for more information.)

“Moving Graphic Objects” (below)
“Reshaping Graphic Objects”on page 113

Moving Graphic Objects

Choose one or more graphic objects to move using the Select tool .
2. To move a graphic object, click the object (but not on a sizing handle) and drag it to the new position.

You can't drag graphic objects from one window to another. You must copy or cut graphic objects to
move them between windows.

Sample Window

| u
Moving object
. |~ from here...

..fo here.
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Resizing a Graphic Object Using Its Sizing Handles

Select one or more graphic objects to resize using the Select tool [£--].
2. Toresize a graphic object, position the pointer over a square handle, click, and drag.

As illustrated below, the pointer turns into an arrow, and the size of the graphic object changes relative to
the sizing handle you're dragging.

Sample Window

3. When the graphic object(s) are the size you want, release the mouse button.

Resizing Multiple Graphic Objects to Equal Dimensions

When multiple graphic objects are selected, they can be resized equally so that all the objects have the same
height and width. This works on all graphic objects except for the following: alarm graphics, SuperTrend,
Trend, XY plot, Table controls, buttons, URL controls (Pro only), and PID buttons (Pro only).

1. Click on the Select tool .
2. Choose two or more graphic objects to resize.

NOTE: Ifyou include any of the unsupported graphic objects, you won't be able to select Size as described in the
next step.

3. (lick Edit > Size, then one of the following options:

- Grow to Largest Height—All selected objects are resized to the height of the tallest object
selected.

- Grow to Largest Width—All selected objects are resized to the width of the widest object
selected.

—  Shrink to Smallest Height—All selected objects are resized to the height of the smallest object
selected.

—  Shrink to Smallest Width—All selected objects are resized to the width of the least wide object
selected.

You can also select these options by right-clicking the selected objects, selecting Size from the pop-up
menu, and then choosing a Grow or Shrink option.

Resizing a Window and the Graphic Objects Inside

The Scale Window tool allows you to resize a window and the graphic objects inside at the same time.

NOTE: Resizing graphic objects in this manner is not exact. Graphic objects are resized in units of whole-number
percentages, not fractional percentages, and the vertical and horizontal dimensions are resized independently. So if
awindow is returned to its original size after it has been modified, it may not look exactly the same as it did before it
was resized. Also, resizing a window using this method cannot be undone.

1. Inthe Windows Control Panel, click System.
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On the left sidebar, click “Advanced system settings.”

In the Performance section, click Settings.

Make sure that “Show window contents while dragging”is unchecked, and then click OK.
(Recommended) Make a copy of the window to test the results.

Click in the window you want to resize to activate that window.

Choose the Scale Window tool EIJ from the toolbox.

The Scale Window Tool Selected dialog box appears.

NowvewhN

Scale Window Tool Selected 23
In order for window graphics to be correctly scaled, you must have disabled
"Show Window Contents While Dragging” from the Windows Display Settings.
Combobox graphics will only rescale their width, not height,
This acticn cannet be undone,

Do you want to continue?

8. Click Yes to continue.

NOTE: If you click in a window other than the active one, the dialog box will close and the Scale Window tool
will revert to the Select tool, just as though you had clicked the No button.

9. Grabthe border of the active window to resize both the window and the graphic objects inside. The new
size is shown in the Toolbox.

NOTE: If you click in or try resize a different window, or if you move the cursor back inside the drawing area of
the active window, the Scale Window reverts to the Select tool.

Peppers Peppers

Choose the Scale Window tool and then
grab the border of the window to resize
both the window and the graphic
objects inside.
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Reshaping Graphic Objects

You can adjust the individual points that make up a polyline, polygon, or Bezier curve object.

1. Using the Select tool , select a polyline, polygon, or Bezier curve object.

2. (lick Edit > Edit Points, or right-click and choose “Edit Points” from the pop-up menu.

3. Move the cursor over a point on the selected object.
When the cursor is over a point on the object, the point is highlighted with a small black square.

4. C(lick the highlighted point, drag it to the desired location, and then release the mouse button.
The highlighted point will appear in the new location.

5. When you are done adjusting points on the object, click outside of the object to deselect it.

CHANGING STACKING ORDER

When graphic objects in a window overlap, they're assigned a stacking order (or “Z-order”) to define which
object appears in front of or in back of another object. With the Z-Order function, you can change the order in
which objects are stacked. (When graphic objects are grouped, the group is treated as a single object in the
stack. For details about grouping objects, see page 105.)

NOTE: You can't change the Z-order of:

Buttons URL controls Combo boxes PID buttons

Alarm graphics Table controls SuperTrends

To change the Z-order of overlapping graphic objects, right-click an object in the stack, and from the pop-up
menu, click Z-Order. (Alternatively, you can select an object and click Edit > Z-Order from the menu bar.) Then,
choose from these options:

«  Arrange (described on page 113)
»  Bring to Front

«  Move Forward

«  SendtoBack

«  Move Backward

Bring to Front, Send to Back, Move Forward, Move Backward

If you select Bring to Front, the graphic object is moved to the front of other objects.
Likewise, if you select Send to Back, the graphic object is moved behind all other objects.

The commands Move Forward and Move Backward work similarly, except that the graphic object you select is
moved ahead or behind one object, not ahead or behind all other objects.

Sample Window Sample Window

=l S

Before Bring to Front After Bring to Front
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Arrange

The Arrange feature is the easiest way to rearrange the order of overlapping objects. You can also use the
Arrange feature to quickly open an object’s Graphic Dynamic Attributes dialog box (or the Trend Configuration
dialog bo, if the object you select is a trend.)

When you choose the Arrange option, the Z-Order dialog box displays thumbnails and descriptions of the
object you selected and the ones beneath it in the stack, in order from top to bottom.

Z-Order *

ETN 2 Label = Move To Top

. Rectangle Move Up
m:l Trend Mowve Down

- Line Move to Bottom

Cancel Help

To re-arrange the Z-order, click an item in the list, and then drag and drop it to a different position in the
stack. As you drag the item, a guideline shows its new position.

Alternatively, you can click the item, and then click a button to move the object up, down, to the top, or to the
bottom of the stack. Buttons that aren’t applicable to the item you've selected are grayed out. (For example, if
you've selected the top item in the list, the Move to Top and Move Up buttons are grayed out.)

The Note on page 113 lists graphic objects whose Z-order cannot be changed. If any of these objects are
contained in your selection, they will not appear in the Z-Order dialog box.
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To display an object’s Graphic Dynamic Attributes dialog box, double-click an item in the list. This
feature lets you configure an object’s dynamic attributes without having to separate it from the stack. (If the
item you selected is a trend, the Trend Configuration dialog box is displayed.)

Z-Order * :
§
4
I:mh 2 Maove To Top Graphic Dynamic Attributes }4
L
b
Rectangle Move L !
& z 8 Object: Text e i Width: 92 “
M D L
Eﬁl ared oL Control Engine Driven &
7
- Line Mave to Bottom Text Calor < |
] visibility Blink 3
Y [ Rotate 2
5 2 [] Horizontal Position {
[ vertical Position x
Cancel Help [ Text In from Control Engine "'
-
5
1
1
Operator Driven ';
[0  Horizontal Slider ~ ‘_'
[0 vertical Slider 4
[ Send Value 1
[ ® send Discrete ‘3
[] # send string b
Windows LY
[0  bownload Recipe
— L. . R 2 {
< > d
1
Focus-frame enabled L
Beep enabled {
Hotkey: [Jctd  []shift | <Mone= i
P
{
3
Cancel Help 1
1
2

DELETING GRAPHIC OBJECTS

There are several ways to delete a graphic object in a window. Depending on the commands you use, the
method you choose may affect the contents of the Windows clipboard.

1. Select one or more graphic objects. (Use Edit > Select All to select all objects.)
2. Delete the graphic objects using one of the following methods:

- Tocut a graphic object and save it in the Windows clipboard so you can use it elsewhere, choose
Edit > Cut, or press Shift+Del, or press Ctrl+X, or right-click and choose Cut from the pop-up menu.

You can paste the graphic object into another window or elsewhere in the same window.

- Topermanently delete a graphic object, choose Edit > Delete, or press the Del key, or right-click and
choose Delete from the pop-up menu.

The graphic objects are not copied to the clipboard and cannot be retrieved.

ALIGNING GRAPHIC OBJECTS

You can align selected graphic objects based on common edges, or based on common centers through
objects. You can also adjust the space between graphic objects.

1. Select the graphic objects you want to align.
You have to select at least two objects to enable this command.
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2. Select the Edit > Align command and choose an option to base the alignment on. (You can also
right-click and choose Align from the pop-up menu.)

The following illustration shows the results of applying the different alignment options:

Sample Window

[ ]
O

After Left Align

Sample Window

OL 1

After Top Align
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Sample Window

[ ]
O

Sample Window

>

Before Alignment

Sample Window

O

After Center Align

Sample Window

O]

After Middle Align

After Space Evenly Vertically

[ ]

]
@
|

After Right Align

Sample Window

O]

After Bottom Align

Sample Window

After Space Evenly Horizontally

You can rotate the following objects: Bitmaps, Metafiles, Curves, Polygons, Ellipses, Polylines, JPEGs, PNGs,
Rectangles, Lines, and Text.

To rotate an object or a group of objects:
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1. Select one or more objects.
2. Choose Edit > Flip/Rotate > Rotate to open the Rotate Object dialog box.

3. Foroneobject:
Enter the degrees of rotation, then click OK.

Rotate Object gl

Clockwize Rotation [degrees):

Riotation Options

Rotate each object individually

Fotate all objects around center of group

I ok H Cancel H Help

For more than one object:
Enter the degrees of rotation, select one of the Rotation Options, and then click OK.

Rotate Object |z|

Clockwize Rotation [degrees):

Rotation Options

(%) Raotate each object individually

() Rotate all objects around center of group

I Ok H Cancel ][ Help ]

Rotate each object individually rotates each object the specified number of degrees around its own
center.
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Rotate all objects around center of group rotates each object around the center point of all the

selected objects

Each object rotated individually

Unrotated objects &

All objects rotated around center of the group

FLIPPING OBJECTS

You can flip the following objects: Curves, Polygons, Ellipses, Polylines, Rectangles, and Lines.

To flip an object around a central horizontal or vertical axis:
1. Select one or more objects.

2. Choose Edit > Flip/Rotate and select an option, or right-click and choose Flip/Rotate from the pop-up
menu.

- Toflip a graphic object from right to left (or vice versa), choose Flip Horizontal.
- Toflip a graphic object from top to bottom (or vice versa), choose Flip Vertical.

APPLYING TRANSPARENCY TO GRAPHIC OBJECTS

NOTE: To apply transparency to a draw window or (Pro only) URL window, see “Window Properties Dialog Box” on
page 95.

You can apply transparency to graphic objects (with a few exceptions') so that in Runtime, operators can see
through them.

By using a slider control or by entering a value between 0 and 100, you can set the transparency of an object
(or group of objects) from completely invisible to entirely opaque.

Note that some PAC Display controls” support transparency only in Windows 8.1 or higher.

To apply transparency to an object or group of objects:

' All graphic image formats support transparency except Microsoft Windows-format metafiles (WMF and .EMF).

2Controls that support transparency only in Windows 8.1 and higher: SuperTrends, alarms, tables, buttons, PID
buttons, combo boxes, URL controls, and URL windows.
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1. Select one or more objects, and then right-click to display the pop-up menu. (For graphic objects, the
Transparency feature is available only from the pop-up menu. Itis not an option in the PAC Display menu
bar.)

2. From the pop-up menu, click Transparency.

The Set Transparency dialog box is displayed.

Set Transparency *
Current Transparency: l:l
o 100

Cancel Help

3. Use the slider bar control (or type a number in the Current Transparency field) to define the object’s
transparency. A value of 0 is completely opague (no transparency); a value of 100 is completely
transparent. When applying the transparency feature to a line

NOTE: When applying the transparency feature to a non-solid (for example, dotted or dashed) line, you must
first set the transparency value, and then you can configure the line style. For details about line styles, see
"Applying or Changing Line Attributes” on page 105.

When you stop moving the slider (or after typing a number in the Current Transparency field), the
selected graphic objects appear with the configured transparency.

Graphic objects are displayed in

p = “ | their transparency setting
*  Set Transparency * _|7\/
: e

!_: Current Transparency:

£ 0 w. |, REACTOR

g : VESSEL

4 [ |

: :

il Cancel Help -?_-

-

: o] oy

4. Select OKto save the setting and close the dialog box. Otherwise, click Cancel to reset the graphic
objects to their original transparency.

WORKING WITH TEXT

The Text tool is a convenient way to label, title, and add impact to your graphic objects. Text that you add to a
graphic object can be changed at any time, and formatted using different fonts, font sizes, and colors.

IMPORTANT: The text tool is also used to create objects that display values and string data from a control engine.
Configure the text object you create using the Text In (from control engine) dynamic attribute; see “Text In from
Control Engine” on page 157 for specific instructions.

“Adding Text" (below)
“Editing Text"on page 120
“Formatting Text"on page 120
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Adding Text

Choose the Text tool from the toolbox, or right-click and select Text from the pop-up menu.
Click the cursor where you want to place your text.

You can also choose to place the text somewhere other than its final location, work on the text until it's
ready to use, and then move it to the desired location.

Type the text.

When you're done with the text you want to type, either press Enter on the keyboard or click outside the
text area.

The text you've typed is now an object that you can select and manipulate like other objects.

Editing Text

With the Select tool, choose the text object you want to modify.

Choose Edit > Edit Text, or right-click and choose Edit Text from the pop-up menu.
Enter the new text in the Edit Text dialog box that appears, then click OK.

The text object is now modified with the new text.

Formatting Text

With the Select tool, choose the text object you want to modify.

Choose a formatting option from the Text menu, or right-click the text object and select an option from
the pop-up menu. The following formatting options are available:

—  Font—Changes the font family used for the text in a text object. You can use any fixed or TrueType
font family installed on the computer.

- Size—Changes the size of the characters in a text object.
—  Color—Defines the color in which the text appears.

- Background—Defines the color of the area directly behind a text object. This formatting option is
visible only when the Opaque attribute is selected.

- Style—Changes the weight, italicization, and other characteristics of the characters in a text object.
Styles available are Normal, Bold, /talic, Underline, and Strikeeut.

—  Opaque—Determines how text appears when overlapping other objects. Opaque style is applied
to text just like any other style. If the text is set to Opaque, objects under the text will be overwritten
by the text background color.

Object overwritten
Opaqua by opaque text
Example of Opaque Text

- Transparent—Determines how text appears when overlapping other objects. The opposite of
opaque, if the text is set to transparent, objects under the text will remain visible and unaffected by
the text background color.

Object is visible
Transpa-/ under text

Example of Transparent Text

The text object is now modified with the format changes.

See"Text Menu” on page 366 for additional information on creating and formatting a text object.
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ADDING AWINDOWS BUTTON OR APID BUTTON

The Button tool adds an unlabeled Windows button to the active display window. The PID Button
tool (Pro only) adds PID button.

1. Ifyourtoolbox is not visible, click View > Toolbox to open the toolbox.

ﬂTonIs |E|
. N m][=]{e] =] AN TA
P e
(O] () e

X 1108 Y: 577

Wi H:

2. Select either the Button tool or the PID Button tool.
The cursor turns into a crosshair.

3. Click the crosshair in a window, then drag it in any direction to create a frame for the button.

Display Window

]

4. Toadd a label to the button, right-click and select Edit Text from the pop-up menu.
The Set Button Text dialog box opens.

5. Enterthe text, and then click OK.

Set Button Text 5]

Enter Test for this Button
Download Recipe

[ (]9 H Cancel ]

If you want to add control engine-driven dynamic text, see “Assigning a Control Engine-Driven Dynamic
Attribute to Windows Button Text"on page 122.

The new label appears on the button.

Display Window

Download Recipe
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122

6. To change the font on the label, right-click the button and select Change Font from the pop-up menu.

NOTE: Buttons cannot be grouped or have their Z-order changed.

Assigning Operator-Driven Dynamic Attributes to a Windows Button

You can assign any of the operator-driven dynamic attributes to a Windows button except for Read and Clear.
For more information on assigning dynamic attributes, see “Assigning a Dynamic Attribute to a Graphic
Object”on page 165. As described in step 5 of “Adding a Windows Button or a PID Button,” you can also assign
a dynamic attribute to the button’s text.

NOTE: The focus-frame enabled option is disabled for Windows buttons, since Windows automatically highlights the
button when the mouse is moved over it. For more information on the “Focus-frame enabled” option, see “Assigning
a Dynamic Attribute to a Graphic Object” on page 165.

Assigning a Control Engine-Driven Dynamic Attribute to Windows Button Text

Using this feature, a Windows button can display varying dynamic text depending on the button’s current
function. For example, a Windows button could be configured with the text, “Begin # batch,” where the # is
tied to a string variable in the strategy that indicates what kind of cookie is supposed to be made. The # would
be replaced by either “Peanut Butter” or “Chocolate Chip,” and the button would display “Begin Peanut Butter
batch” or “Begin Chocolate Chip batch.”

To add a control engine-driven dynamic attribute to text on a Windows button:
1. Create a Windows button as described in “Adding a Windows Button or a PID Button”on page 121.

2. Inserta pound sign (#) sign in the button’s text to indicate where to place a string that reads a tag from a
control engine and displays a string based on a received numeric value, string, or discrete value. You can
use more than one pound sign, or you can combine text and pound signs:

Display Window Display Window

——

Pound sign only Text and pound sign

3. Double-click the button to open the Configure Dynamic Attributes dialog box.
Below the Visibility/Blink option, you'll see the Text in From Controller option.

Contral Engine Driven Attributes

[T wisibility/Blirik. Edit...
Text In from W Tt In from I::.:untn:*EnginEe

LClear

Control Engine

NOTE: You must have entered a pound sign on the Windows button in the previous step. Otherwise, the Text In
from Control Engine option is not displayed.

4. Double-click Text In from Control Engine to configure this control engine-driven dynamic attribute. See
“Text In from Control Engine”on page 157 for specific instructions.
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Configuring a PID Button

Double-clicking a PID button opens the PID Configuration dialog box.

To configure a PID button:

1. Selectan 10 Unit from the “Select 10 Units” pane, and then select a configured PID that appears in the
right pane.

PID Button Configuration fg|

Select [0 Unit Select PID

i Contral Engine:PAC_ B2 Temperature: Contral ——PID
101823617 Brain
10.182.36.12:0ther

< | 3 @ >
kit / b aw Walues for Trend Dizplay Options
Setpoint: [ Enable &uto / Manual
Mir: |D.D | Max: |D.D | []Enable Tune
Olutput: Trend Time Span [min.)
Fir: |U,|:| | M ax: |EI.D |
|t
Mir: | 0.0 | Max: 10.0 |
[ QK ] l Cancel l [ Help ]

Part of the PAC Display Runtime PID Window is a SuperTrend that plots the Input, Output and Setpoint
values.

2. Enter the minimum and maximum values to display on the SuperTrend that appears the PAC Display
Runtime PID Window.
The PID SuperTrend plots the Input, Output, and Setpoint values. In general, you should obtain the initial
values from the control strategy, but you can modify them to suit your needs.

NOTE: These values are for the SuperTrend display only. The values configured in the PAC Control strategy are not
changed.

3. You can configure the Options as follows:

—  Enable Auto / Manual: Select this check box to allow a user to switch between Auto and Manual
mode from within the PID window in Runtime. Also, you can configure a password to allow
changing the mode in Runtime.

- Enable Tune: Select this check box to allow a user to adjust PID tuning parameters in Runtime. The
available parameters include Gain, Integral, Derivative, and Scan Rate. You can configure a password
to allow tuning in Runtime.

—  Trend Time Span (min): This is the time span (in minutes) of the SuperTrend in the Runtime PID
Window. The default is 5 minutes. Enter a new time span if desired.

4. |f desired, click Security to configure security attributes for the PID Button itself. This is configured the
same way as for any other graphic dynamic attribute (see “Security Settings for Graphic Objects and
Dynamic Attributes”on page 176). PID button security allows only specified users to launch the Runtime
PID Window.

NOTE: PID Buttons may not be grouped with other PAC Display graphic objects or have their Z-order changed.
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For information on using a PID button in Runtime, see “Using a PID Button”on page 337.

ADDING A WINDOWS COMBO BOX

See also, “How a Combo Box Behaves in Runtime” on page 337

The Combo Box tool @ adds a Windows combo box to the active display window.
1. Ifyourtoolbox is not visible, click View > Toolbox to open the toolbox.

ﬂTonIs |E|
> [O[o]o[ow]
P e
[OK]| =1 el

X 1108 Y: 577

Wi H:

2. Select the Combo Box tool.
The cursor turns into a crosshair.

3. lick the crosshair in a window, then drag it in any direction to create a frame for the button.

Display Window

]

A combo box appears in the display window.

Display Window

NOTE: The height of the combo is fixed and cannot be changed. Using the Select tool, you can change only the
width.

Creating a Combo Box List

Each list item that you add to the new combo box can be assigned one or more of the following dynamic
attributes.

Control Engine Driven: Text-in from Control Engine
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Operator Driven:

+  SendValue

«  Send Discrete

«  Send String

«  Window

«  Download Recipe
«  Upload Recipe

«  Launch Application
»  Execute Menu Item

NOTE: The operator-driven dynamic attribute Read and Clear cannot be used with a combo box.

See the following two sections to add a list item to a combo box, and then assign one or more dynamic
attributes to the item.

"Adding a List Item to a Combo Box" (below)

“Assigning One or More Dynamic Attributes to a Combo Box List ltem”on page 127

Adding a List Item to a Combo Box
1. Using the Select tool, double click on the combo box.

Display Window

L

This opens the Combo Box Dynamic Attributes dialog box:

ComboBox Dynamic Attributes @
Items: Drpnamic Attributes:
Add... SendValue. Enabled
Modify. Send Discrete... Enabled
Send String.... Enabled
Decie Windows... Enabled
TR D/L Recipe. .. Enabled
U/ Recipe... Enabled
fovve Dowin Application... Ehabled
Menu ltem... Enabled
Security... TeutIn.. Enabled
[ ak J [ Cancel ] [ Help ]

You'll add individual list items for the combo box to the [tems text box.
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2. C(lick the Add button to open the Add Entry dialog box.
Add Entry 5]
Enter Mew kem [255 characters max.]
[ 0K ] [ Cancel ]
3. Entertext for the list item, then click OK.

Add Entry

Enter Mew kem [255 characters max.]

[l

Diownload peanut butter cookie recipe

[ (]9 ][ Cancel ]

L List item text

The new list item appears in the ltems list:

ComboBox Dynamic Attributes

Diynamic Attributes:

| ok

” Cancel H

Help

)

SendWalue... Enabled

Send Dizcrete.. Enabled
Send String... Enabled

Windows. .. Enabled
TEa D/l Recipe... Enabled
U/L Recipe. .. Enabled

fovve Dowin Application. .. Enabled
kenu Itenm... Enabled

Security... TestIn... Enabled

To modify the text of an item, click the Modify button, make changes to the text, and then click OK.

If there is more than one item in the list and you want to re-arrange the order of the items, select the item
you want to move and click the Move Up or Move Down button.

Follow the instructions in the next section to assign one or more dynamic attributes to an item.
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Assigning One or More Dynamic Attributes to a Combo Box List Item

1. Inthe Combo Box Dynamic Attributes dialog box, highlight an item to activate the Dynamic Attributes

controls:

ComboBox Dynamic Attributes

Iternz:
Download peanut butter cookie recipe

Maove Up

tove Down

Security...

l u] ” Cancel H Help

)

=

Diynamic Attributes:

Send Value... Enabled
Send Discrete... Enabled
Send String... Enabled
Windows... Enabled
D/l Recipe... Enabled
U/L Recipe. .. Enabled
Application. .. Enabled
Menu ltenm... Enabled
Testln... Enabled

—— Dynamic

Attributes
controls

NOTE: If no “Text-in from control engine” placeholder character (#) is embedded in the text, the Text In fields are
disabled. See “Text In from Control Engine” on page 157 for more information.

As mentioned previously, you can assign one or more dynamic attributes to each entry in the list. For
example, “Download peanut butter cookie recipe”item may have a Send Value, a Send Discrete, and a

Download Recipe assigned to it.

2. To configure a dynamic attribute, click the link for the desired attribute.

Dynamic Attributes:
Send Va&:e...
Send Digkrete...
Send String. ..
Windows. .

D/L Recipe...

/L Recipe...
Application..

Click the link

tenu ltem...

TextIn...

Enablad
Enabled
Enablzd
Enabled
Enabled
Enabled
Enabled
Enabled
Enabled
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This opens a Dynamic Attribute dialog box for that specific attribute.

Dynamic Attribute - Send Value @

Tag

Marme:

Source Destination
@ Fixed data () Prompt for data @ Set () Offzet
Fined Drata Prompted Data:
Walue:
[ 0K ] [ Cancel ] [ Help ]

3. Configure the dynamic attribute, and then click OK.

Once an attribute has been configured, the Enabled check box is selected. To disable the attribute,
uncheck this check box. Also, the Security button becomes enabled.

ComboBox Dynamic Attributes @
|temns: Dynamic Attributes:

D' ownload peanut butter cookie recipe Add. Send Value Enabled | Dyna mic
. attribute

: Send Discrete... Enabled
) selected

Send String... Enabled

Windows... Enabled

Miavels /L Recipe... Enabled

/L Recipe... Enabled

tove Down Application... Enabled

Fd e Itern... Enabled

Security... TestIn... Enabled

[ ok J[ Cahcel H Help ]

Security button enabled

Changing the Font or Spacing of Combo Box Items

Using the Change Font and Multiply Runtime Height By commands you can change the font or spacing of
text items listed in a combo box.

To access these commands in Configurator, right-click on a combo box with the Select tool.

] L
u u
u Change Font

Multiply Runtime Height By...

Cut
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«  Change Font opens the standard font dialog box. If you change the size of the text, the height of the

combo box is changed to accommodate the new size.

«  Multiply Runtime Height By... increases the space beneath each item in the list by a factor of 1,
2, 3,4, or 5. This does not change the text height, nor does it change the size of the closed comb box.
Note that there is no visible change in Configurator because there are no items in the list in Configurator.

(They are added only in Runtime.)

Set Runtime Item Height Multiplier

Enter alue [must be between 1 and 5)

I (]S ][ Cancel ]

Example 1: The combo box has the default font, but has a Runtime Height
Multiplier of 2. This results in additional space between each item, but the
combo box size stays the same.

Example 2: The font has changed to Myriad Pro 16, but the Height Multiplier
has the default value of 1. The result is that the text is larger and so is the size
of the combo box. The spacing between items remains unchanged.

Example 3: As in example 2, the font has changed to Myriad Pro 16.
However, the Height Multiplier is now 3. The combo box will be the same size

as in example 2, but the spacing between each item increases by a factor of 3.

Adding Security to a Combo Box

L3

Diownload
Upload

Execute

Phasel -
Phase 1
Phase 2

Phase 3

Phasel )

Phase 1

Phase 2

Phase 3

To add security to a combo box, click the Security button. This is configured in the manner as for other graphic
objects in PAC Display. For more information, see “Security Settings for Graphic Objects and Dynamic

Attributes”on page 176.

The following characteristics apply to combo box security:

«  Security is applied to all configured dynamic attributes of the item. However, in Runtime, the Security
dialog box appears only once per selected list item. For example, if a single entry has Send Value, Send

PAC Display User's Guide 129



ADDING A WINDOWS COMBO BOX

String and Menu Item, rather than the security dialog box appearing three times (once per dynamic
attribute) it appears only once for the list item.

o Each list item may have its own security configured

«  Security attributes may be copied and pasted from one item to another

« Itis not possible to configure security for the combo box as a whole

Once security has been configured for a dynamic attribute, the security may be copied and pasted to other
entries in the Items list as described below.

To copy and paste security attributes from one item to another:

1. Open the Dynamic Attributes dialog box for the Combo Box.

2. Select an item that has one or more dynamic attributes assigned to it.

3. Right-click on the item and choose Security > Copy Security Attributes from the pop-up menu.

ComboBox Dynamic Attributes @
Itermns: Dynamic Attributes:;

[Diowwnload peanut butter : . .. bled
Upload pearut butter co Security 2 Copy Security Permissions m Elalls

Paste Security Permissions abled

SERAT ST Fhabled

Windows... Enabled

TR D/L Recipe. .. Enabled

U/ Recipe... Enabled

Application... Enabled

Menu ltem... Enabled

TextIn.. Enabled

[ Ok ][ Cancel ][ Help ]

4. Right-click on a different item and choose Security > Paste Security Attributes from the pop-up menu.

ComboBox Dynamic Attributes @
Itermns: Diynamic Attributes:
D owanload peanut butter cookie recipe | [ Add... ] G Yale [7] Erahbled
lnad peanut butter cookie recipe . z .
Security 2 Copy Security Permissions

Paste Security Permissions M

Bl eT™ T Windoms. Enabled
D/l Recipe... Enabled

U/L Recipe. .. Enabled
fovve Dowin Application. .. Enabled
kenu Itenm... Enabled

Textln... Enabled

l u] ” Cancel H Help l

NOTE: The “Focus-frame enabled” option is disabled for combo boxes, since Windows automatically highlights the
combo box when the mouse is moved over it. For more information on the “Focus-frame enabled” option, see
"Assigning a Dynamic Attribute to a Graphic Object” on page 165.
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NOTE: Combo boxes may not be grouped with other PAC Display graphic objects or have their Z-order changed.

ADDING A URL CONTROL

@

(Pro only) The URL Control tool @ adds a simplified browser to the active display window. Like a URL
window (see “Using Draw Windows and URL Windows" on page 91), this allows you to display a specific
website within your project, or a web application such as Opto 22's groov (see "Adding a groov URL Control”
on page 133). However, unlike a URL window, a URL control browser is placed within a draw window. While
this allows you to add other graphic objects within the same draw window, in Runtime the user cannot resize
a URL control browser. But the browser does provide scrollbars to allow you to see the entire page, and
forward and back buttons are provided for navigation. There is no keyboard support for static web pagesin a
URL control.

NOTE: A window cannot contain both an alarm control and a URL control.

NOTE: If a window in Configurator contains a URL control, the Always in Memory option in the Window > Properties
dialog box is disabled and cannot be used for that window.

1. Ifyourtoolbox is not visible, click View > Toolbox to open the toolbox.

ﬂTnols ot
= NS
o] 8 ]

(] URL Control tool

X B01 Y. 433
W H:

2. Select the URL Control tool.
The cursor turns into a crosshair.
3. lick the crosshair in a window, and then drag it in any direction to create a frame for the browser.

NOTE: Remember that the browser cannot be resized in Runtime, so make sure that the frame is big enough to
display the information in the target website.

URL Control
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4. Using the Select tool, double-click the control to open the URL Control Options dialog box.

URL Control Options

A JRAL: |http:a’£www.npt022.cnm |

B Refresh Eveny: IZI zecohds

C — [ Hide Navigation Buttons User-Agent.,
Cancel Help

URL—Type the URL of the target webpage.
Refresh Every ___ sec.—To refresh the control at a specific interval, type the number of seconds in the
text box. This is useful for updating static images like a weather radar or images from a security camera.
User Agent— To specify the target browser and operating system, click the User Agent button, and
then, in the User Agent String dialog box, type a correctly formatted user agent string. This feature lets
you override the default User-Agent value in header messages sent to the web server. (User-agent strings
are typically advanced settings used when testing web applications with different browsers.) For help
creating user agent strings, contact your IT department, or see the Microsoft Developer's Network
website at https://msdn.microsoft.com/en-us/library/ms537503(v=vs.85).aspx.
To set a global user agent string for all URL controls and URL windows in all of your PAC Display projects
(which takes precedence over objects configured with the User Agent button), perform these steps:
a. InWindows File Explorer, navigate to the folder where PAC Display is installed. (The default folder is
C:\Program Files (x86)\Opt022\PAC Project.)
In the folder, create a text file and name it PAC DisplayUserAgentString.txt
c. Inthetextfile, type a correctly formatted user agent string. Don't type anything else in the text file.

d. Close and save the text file. When a project is loaded in Runtime, PAC Display uses the user agent
string in the PAC DisplayUserAgentString.txt for all URL controls and URL windows

Hide Navigation Controls—Check the box to hide the forward and back navigation buttons.
5.  When finished, click OK to save your changes and close the dialog box.
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The URL you entered appears in the center of the control to show which webpage will be loaded in Runtime.
In Runtime, the browser looks like this:

Opto 22 Window

Products Support ‘Watch How to Buy About Opto

R E——
‘ About Us

Opto 22 manufactures... New to Opto 227 Welcome Back! Free OptoWebinars
...controllers, 1/0, solid-state- See Wired+Wireless PACs and /O = OptoKnowledgeBase Live WebEx seminars on a variety ¢
relays, and software products = Firmware updates industrial automation topics.

Learn more about PAC controllers
that link electrical, mechanical, and = Forums and Blogs
electronic devices to networks and Expand your Allen-Bradley PLC = Documents MNext Topic: Basic Troubleshaoting

computers. system with intelligent remote /O = Downloads for the SNAP PAC System v
i | 3

[~

Adding a groov URL Control

If you have Opto 22's groov on your network, you can access your groov project in Runtime by creating a URL
control in Build that points to groov. When you create the control, make sure to enter the exact same URL for
groov as you would in a regular browser including “https://.”

Because groov is a web application rather than a static web page, you can use all of groov features from within
a PAC Display URL control. Keep in mind that a user cannot change the size of a URL control, but they can
change the size of a URL window (see “Adding a groov URL Window" on page 93).

If the groov project has a URL link to an external webpage, when you click the URL in Runtime, the webpage
will open in a new popup window. When the popup containing the external webpage is closed, any popup
windows that originated from that window will also be closed.
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For more information about groov, see the (form 2027).
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WORKING WITH TABLES

Using PAC Display’s Table tool , you can add an object to display the contents of tables used in a PAC
Control project. In a single on-screen object, you can display the contents of up to sixteen separate tables. The
tables can contain 32-bit and 64-bit integers, floating point values, or text strings.

For information on changing individual table elements in PAC Display Runtime, see “Writing Directly to
Individual Elements”on page 336. For information on changing multiple table elements at the same time, see
“Configuring Recipes”on page 239.

“Creating a Table"on page 134
“Configuring a Table”on page 135

Creating a Table

1. Select the Table tool in the toolbox.
2. (lick the mouse button, drag the mouse to the desired size, and then release the mouse button.
The table object appears.

(Untitled)

Index
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Configuring a Table

After creating a table object in a draw window, you must specify which table(s) will be displayed. For each
table, you can optionally specify which table elements will be displayed.

1. Double-click the table object with the Select tool.
The Configure Table dialog box appears.

Configure Table

Appearance Configure Tables
Ui s Ciftr T Table1... Table 5. Table d.. Table 13...
Table 2. Table 6... Table 10... Table 14...
Background Color: l:l
Table 3... Table 7... Table 11... Table 15...
Fant...
Table 4... Table 8. Table12... Table 16...

[ Use same font for headsr
[ Use Relative Dffzets

Cancel Help

2. Inthe Appearance area:
- Ifdesired, type a new title for the Index Column. (By default, the title is “Index.”)

NOTE: To hide the Index column, delete any text in the Index Column Title field. (This hides the
Index column in both Runtime and Configurator,)

- Ifdesired, choose the background color and font used in the table object.

- Toselect a background color, click the white square next to Background Color, select a color in
the Windows color selector that appears, and then click OK.

- Toselect the font, click Font, select a font in the Windows font selector that appears, and then
click OK.

—  Touse the selected font in the header of each table column, select “Use same font for header.”

—  When Use Relative Offsets is selected, all table data will begin at the top row of the table
control, regardless of which actual data table index is being displayed.

For example, if Table 1 is configured to show elements 0 — 50 of a table, and Table 2 shows elements

200-250 of a different table, then the top row of the table control for Table 1 corresponds to the data

at element 0, and the top row of the table control for Table 2 corresponds to the data at element
200.

PAC Display User's Guide 135



WORKING WITH TABLES

3.

136

In the Configure Tables area, click Table 1. The Configure Tables dialog box appears.

Configure Tables

Description: | |

Tag: | | i

Align Data

(®) Laft
() Center

) Right

Table Options
Enahbled

Allow Edit
Pazzword...
Dizplay Integer 64 Values Az

() Decimal

() Hexadecimal
() Binary

Delete T able

Cancel Help

If desired, type a description. Up to 12 characters of the description will appear on the Table button when
you close the dialog box. (If you don't type a description, after you configure a tag, the tag’s item name is
displayed in the Description field.)
Click the Tag Selection button ], and in the Tag Selection dialog box that appears, select a table.

— Todisplay a range of table elements, type a start index (usually 0) and the number of elements
(10240 maximum) to be displayed.

T

e

Selected Fields
Field: L

nter a starting index (usually 0) and the
Element; Bit [0-31]; number of table elements to use.

Start Index: '_l Ftm Elements 1

e plEek e Snam (L rec) e o L)

- You can also configure a refresh time for the table object. For details, see “Refresh Time Groups”on
page 183.

Click OK to exit the Tag Selection dialog box. The Configure Tables dialog box appears, where you can

configure additional options:

- Align Data. To align the data in the table, select the appropriate option for left, center, or
right-justified data.

— Display Integer 64 Values As. By default, discrete bits and digital point states stored in an Integer
64 value are displayed in decimal format. To see four bits at a time, select Hexadecimal. To see each
bit or point state, select Binary. (This option is disabled if you did not select an integer-64 table.)

- Floating Point Decimal Places. To configure the number of floating point decimal places to be
displayed in the table, select a value from 0 to 6. (This option is disabled if you did not select a float
table.)

- Table Options. By default, Enabled is selected to allow the operator to use the table in Runtime.
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Allow Edit is also enabled, and allows the Runtime operator to click on a cell in the table, and then
enter a new value. To prevent an operator from editing the data, deselect Allow Edit.

To require a password to edit data in a table, select the table’s Allow Edit option, and then click
Password. In the dialog that appears, type the password, confirm it, and then click OK.

7. Click OK to exit the Configure Tables dialog box and return to the Configure Table dialog box.

8. To configure additional tables, click its Table button, and then repeat steps 4 through 7. When you have
finished configuring tables, click OK to close the Configure Table dialog box.

To delete a table, click its Table button, and then click Delete Table. The remaining tables are reordered.

To print the displayed windows, click File > Print to display the Print dialog box. If the settings are correct for
your printer, click OK.

If you need to change printer settings, click the Properties button in the Print dialog box. You can also change
the printer settings without printing the Configurator screens by selecting the File > Printer Setup command.
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7: Using Animated Graphic
Objects

INTRODUCTION

This chapter describes how to animate graphic objects to show how I/0 data and other values change in real
time. It also describes how PAC Display scans data from control engines to update its graphic objects, and how
you can adjust this scanning to optimize your PAC Display project for best performance.

InThis Chapter

About Animated Graphic Objects page 139
Dynamic Attributes and Their Features page 140
Assigning a Dynamic Attribute to a Graphic Object.............. page 165

Copying Configured Attributes to other Graphic Objects....... page 169

Assigning Send Value, Send Discrete, and Send String.... page 169
Assigning a Chart State Value to a Graphic Object.................... page 172
Adding Hint Text to a Graphic Object page 175
Security Settings for Graphic Objects and Dynamic Attributespage 176
Viewing Tags and Dynamic Attributes page 180
Scanning to Update Graphic Objects page 182

ABOUT ANIMATED GRAPHIC OBJECTS

As your PAC Control strategy runs on the control engine, values and states of tags in the PAC Control strategy
database are continuously updated. PAC Display uses this changing data to modify attributes (such as size,
position, and color) of the graphic objects that you have connected to the tags. The end result is an animated,
continually updated display that shows status information about a control process.

To animate graphic objects, you must assign dynamic attributes to objects you've drawn. These are attributes
that make the graphic object change based on the values read from or sent to control engines, based on
events that happened, or based on how the operator interacts with the interface.

Two types of dynamic attributes can be assigned to a graphic object: control engine-driven attributes and
operator-driven attributes.

Control engine-driven attributes are always linked to a tag (/0 point, value, and so forth) in a PAC Control
strategy. This type of attribute can change the object’s appearance depending on the tag’s value when the
control engine reads it. For example, if the tag reflects an alarm condition for a process, you could configure
the attribute to change the object’s color to red for the Runtime operator to see.

Operator-driven attributes are assigned to a graphic object. These attributes change the object as an
operator interacts with the interface. As a result, events may be triggered, or new tag values may be sent to an

PAC Display User’s Guide 139



DYNAMIC ATTRIBUTES AND THEIR FEATURES

attached control engine. For example, you could configure an attribute to close a valve when the operator
clicks a button in the HMI.

DYNAMIC ATTRIBUTES AND THEIR FEATURES

This section describes each dynamic attribute and explains its configurable features.

Some dynamic attributes cannot be assigned to certain graphic objects. When that's the case, the Not
Available indicator @ appears next to the attribute’s name in the Graphic Dynamic Attribute dialog box. (For
more information, see “Assigning a Dynamic Attribute to a Graphic Object”on page 165.)

Type
operator-driven

operator-driven
operator-driven
operator-driven

operator-driven

operator-driven

operator-driven
operator-driven
operator-driven
operator-driven

operator-driven

control engine-driven

control engine-driven

control engine-driven
control engine-driven

control engine-driven
control engine-driven

control engine-driven
control engine-driven
control engine-driven
control engine-driven

control engine-driven

control engine-driven

Dynamic Attribute

Download Recipe, page 142

Execute Menu ltem, page 144
Horizontal Slider, page 147
Launch Application, page 148

Read and Clear, page 151

Send Discrete, page 153

Send String, page 154
Send Value, page 154

Upload Recipe, page 158
Vertical Slider, page 161

Windows, page 163

Alarm Point, page 140

Control Engine Status, page 141

Fill Color, page 144

Horizontal Position, page 146

Horizontal Size (Width), page 146

Line Color, page 150

Rotate, page 152
Text Color, page 155

Text In from Control Engine, page 157
Vertical Position, page 160
Vertical Size (Height), page 160

Visibility/Blink, page 162

Function

Downloads a recipe file to the control engine
Executes a single menu item

Creates a horizontal slider that an operator
can use to change values in a tag.

Starts an application

Reads a tag’s value and simultaneously clears
(resets) it

Sends a discrete value to a tag in the control
engine

Sends a string to a tag in the control engine
Sends a value to a tag in the control engine
Uploads a recipe file from a control engine
Configures a vertical slider

Changes the state of a window in the HMI

Changes the graphic object’s color based on
the state of an alarm point

Changes the graphic object’s color based on
the status of one or more control engines

Changes the graphic object’s color
Adjusts the graphic object’s horizontal position
Adjusts the graphic object’s width

Changes a line’s color or the color of the line
around the graphic object

Rotate the graphic object

Changes the color of text in the HMI
Displays a tag value in a text object
Adjusts the graphic object’s vertical position
Adjusts the graphic object’s height

Makes a graphic object visible or invisible, or
causes it to blink

Alarm Point

Use this attribute to change the color of a graphic object based on the state of an alarm point. You can use this
attribute with circles, rectangles, and polygons. By default, the color of the graphic object corresponds to the
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Normal, or unalarmed, state. See also, “Configuring Alarm Points” on page 258 and “Configuring Project
Alarms”on page 277

In the Graphic Dynamic Attributes dialog box, click Alarm Point (in the Control Engine Driven list) to display its
features.

Control Engine Driven: Alarm Point

Alarm Paints
A—
Digcrete
B——0n 0F Acked Silenced
Walue
C HiHi Hi Momal Lo Lolo  Ack'ed Silenced

B /BN N

(A) Alarm Points. The names of the alarm points configured for the project appear here. Click an alarm
point in the list, and then set the colors that will be used for the graphic object in the Discrete group or the
Value group.

Alarm points that monitor digital points are configured as discrete alarm points, and have four states: On, Off,
Ack’ed, and Silenced. Alarm points that monitor analog points are configured as value alarm points, and have
six states: HiHi, Hi, Normal, Lo LolLo, Ack’ed, and Silenced. See “Configuring Alarm Points”on page 258 for more
information about setting up alarm points.

(B) Discrete. To select colors for a discrete alarm point’s On and Off states, click the color box for each state
and then choose a color in the dialog box that appears. If you have selected an alarm point for a digital I/O
point, only the Discrete group will appear in the Dynamic Attribute - Alarm Point dialog box.

(C) Value. To select colors for a value alarm point’s HiHi, Hi, Normal, Lo LoLo, Ack’ed, and Silenced states, click
the color box for each state and then choose a color in the dialog box that appears. If you have selected an
alarm point for an analog I/0 point, only the Value group will appear in the Dynamic Attribute - Alarm Point
dialog box.

Control Engine Status

Use this attribute to change the color of a graphic object based on the status of one or more control engines.
You can use this attribute with circles, rectangles, and polygons.

NOTE: When the Control Engine Status dynamic attribute is selected, the Not Available indicator @ appears next to
all other Control Engine-driven attributes to indicate they are disabled. (They can't be used together with Control
Engine Status.)

If the Control Engine Status attribute is used to monitor multiple control engines, the graphic object will
display the status color for the control engine that is in the most critical condition. Least critical to most critical
status is shown below:
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Least Critical - P  Most Critical

Attached Last Known Comm
Value Failure

In the Graphic Dynamic Attributes dialog box, click Control Engine Status (in the Control Engine Driven list) to
display its features.

Control Engine Driven: Control Engine Status

Select Controller
A —— |[Leaming Center
10198 14
Boiler
Chamber 1
PALC Sim

B —— [Jselect 2

c Colors
Attached Last Known Yalue Comm Failure

(A) Select Controller. The names of the control engines configured for the project appear here.

Select a control engine. To select multiple control engines, hold down the Ctrl key and click each one you
want to select.

(B) Select All. To select all control engines in the list, click Select All.

(C) Colors. To select colors for a control engine’s state, click the color box for the state and then choose a
color in the dialog box that appears.

Download Recipe

Use this attribute to download a recipe file to a control engine when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text. For more information about recipes, see “Configuring Recipes”on page 239.

In the Graphic Dynamic Attributes dialog box, click Download Recipe (in the Operator Driven list) to display its

features.
Operator Driver: Downlfoad Recipe
Recipe File
A‘D-'mnw-—l— - | LogFrom.. | ——B
Make Path Relative to Project [ ] ——— C
D File: Mame

() Prompt for name

® Fied name Fixed Mame: | Extension: — F
iy 3

() From strategy
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Name (Trigger-based recipe download). Enter a name for this recipe. This name is used to refer to this
trigger-based recipe in the Recipe Managers list dialog box. The name can be up to 40 characters long.

(A) Directory. Enter the directory location of the recipe file. Use the button B to quickly enter a directory
name.

(B) (Basic only) Browse. Click to quickly find the recipe file directory for A. Use the Select Download File
Directory dialog box that appears to navigate to the desired directory, and then click OK.

(B) (Pro only) Log From. Click to select whether to log from an ASCII recipe file or from a database table.

« Ifyouclick Log File in the pop-up menu, use the Browse for Folder dialog box to navigate to the desired
directory, and then click OK.

« Ifyouclick Log File in the pop-up menu, use the Select Database Table dialog box to select the desired
table, and then click OK. For more information about logging to a database table, see “Configuring an
ODBC Data Source”on page 55.

(C) Make Path Relative to Project. When selected, if you copy the project and recipe files to a different
computer, PAC Display will look in the same relative location to find the recipe files in Configurator and
Runtime.

For example, if the project is saved in C:\proj\ and you configure recipes files to be in C:\proj\recipes\, then the
relative path would be this: \recipes\

If you then saved the project to C:\temp\newproj\, PAC Display would look for recipe files in the new location’s
relative path: C:\temp\newproj\recipes\

(D) File Name. Choose the source of the recipe file name:
Fixed Name

Check this if the recipe file is a file name you want to configure at this time. If this option is selected, the
File Name edit box appears, prompting you for a file name. Make sure the file exists in the Directory entry,
otherwise an error is posted. The file name may not be changed at Runtime.

The Extension parameter also appears and prompts for a one to three character long extension that's
appended to the Fixed Name. The extension must not contain a period or a DOS wild card character. The
default extension is "rcp".

Prompt For Name

Check this if the recipe file name is to be prompted at Runtime when the trigger occurs. If this option is
selected, the Extension parameter also appears. Enter a one to three character long extension which does
not contain a period or a DOS wild card. This extension is used as a filter to select which files are displayed
when prompting a user for the recipe name at Runtime, however files with different extensions may be
selected.

From Strategy

Check this option if you want to use a string tag name from the control engine strategy to specify the
recipe file name. If this option is selected, the String Name edit box appears, prompting for the name of
the PAC Control tagname you want to use. Use either Quick Tag Entry (see page 74) or the Tag Selection
dialog box (see page 75) to select a tagname.

(E) Fixed Name. If Fixed Name was selected in File Name (D), enter the name of the recipe file located in
Directory (A). Notice the file extension is .rcp.

(F) Extension. Specify the file extension for the recipe files available to this dynamic attribute by entering
the extension in the File Extension field. The extension must be one to three characters long and must not
contain a period or DOS wild card characters.
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If Fixed Name is checked, this extension will be appended to the File Name entry to create the name for the
recipe file. If Prompt For Name is checked, this extension will be used as a filter to select the files for display in
a file selection dialog box when PAC Display Runtime executes this dynamic attribute; however, you may
override this filtering if you wish to select a file with a different extension.

(G) String Name. If From strategy was selected in Fixed Name (D), use either Quick Tag Entry (see page 74)
or the Tag Selection dialog box (see page 75) to select a tagname.

Execute Menu Item

Use this attribute to run a single Runtime command when an object is clicked. This is useful if you want to
hide the menu bar and allow only limited access to certain items. This is an operator-driven attribute and is
available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.

In the Graphic Dynamic Attributes dialog box, click Execute Menu Item (in the Operator Driven list) to display
its features.

Operator Diven: Execute Menu Fem

fdenu ltem:;

Alarmz/alarms Enabled A
Alarmns/Dizable Alarm Points..
Alarmz/todify Alarm Points
Alarmz/Priority Filter /100 And Above
Alarmz/Pricrity Filber /200 And Above
Alarmz/Priority Filter /300 And Above
Alarmz/Pricrity Filker /400 And Above
Alarmz/Priority Filter /500 And Above
Alarmz/Priority Filter B00 And Above
Alarmz/Priority Filter/ 700 And Above
Alarmz/Pricrity Filber 200 And Above
Alarmz/Priority Filter 300 And Above
Alarmz/Pricrity Filter 241 Levels
File/Change Printer. ..

File/Exit PALC Display Runtime
File/Open Project..

File:/Pririt
File/Printer Setup... v

Select a command from the Menu Item list. For more information on the Runtime commands, see “Runtime
Menus”on page 370.

Fill Color

Use this attribute to change a graphic object’s fill color based on a tag value from the control engine. This is a
control engine-driven attribute and is available for rectangles, round rectangles, ellipses, and polygons.
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In the Graphic Dynamic Attributes dialog box, click Fill Color (in the Control Engine Driven list) to display its
features.

Control Engine Diven: Al Color
Tag

M arme:

A—— ?

Setup By Dizcrete
B—— ) |

() Dizcrete

(® Current Value

C
Current ¥ alue
D —futoff values

<=|:|< <=|:|< <=| |< <=| |<
e—l H H BEH B

Husterasis:

F—p |

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: 1 = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.

For example, let's say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.
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Horizontal Position

Use this attribute to adjust the horizontal position of a graphic object based on a tag value from the control
engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses,
and polygons, polylines, curves, bitmaps, and text.

In the Graphic Dynamic Attributes dialog box, click Horizontal Position (in the Control Engine Driven list) to
display its features.

Control Engine Driven: Horizontal Position
Tag

Mame;

A— IE

B Walue At Left: I:I Movement Left:
Walue At Right: I:I M avement Right:

Reference

D (O Left (@ Center () Right Deadband: D —E

I
[ ]

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes, the graphic object’s horizontal position is changed.

(B) Value at Left/Right. Enter the leftmost and rightmost value for the tagname in A. For example, if you
know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0to 50.

(C) Movement Left/Right. Enter the leftmost and rightmost movement the object can change. The
movement units are in pixels. Suppose your left and right values are 0 and 100, and your left and right
movements are 0 and 200. When the tag value is 50, the object will be moved 100 pixels to the right.

(D) Reference. Select the reference point for the object. The choices are left, center, and right. The
Horizontal Size (Width) dynamic attribute must also be configured in order for this option to affect the graphic
object.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the graphic object’s movement will actually change. Using our previous example in C, let’s say the deadband
is 5. Atag is read and has a value of 50. The next tag reading must be greater than 55 in order for the graphic

object to move.

Horizontal Size (Width)

Use this attribute to adjust the width of a graphic object based on a tag value from the control engine. This is
a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses, polygons,
polylines, and curves.
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In the Graphic Dynamic Attributes dialog box, click Horizontal Size (width) (in the Control Engine Driven list) to
display its features.

Control Engine Driven: Horizontal Size (width)
Tag

Mame:

A—|— 1K

B b airnLnn W alue: I:I b ax Percent Width: I:I
b irirnurn % alue: I:I Wi Percent width: I:I

Anchor

(JLeft (@ Center () Right Deadband: D —E

c

D

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes in the PAC Control strategy, the graphic object’s width is
changed.

(B) Maximum/Minimum Value. Enter the maximum and minimum value for the tagname in A. For
example, if you know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a
subset of this range, such as 0 to 50.

(C) Max/Min Percent Width. Enter the maximum and minimum percentage the object can change. The
percentage range is from 0 to 1,000 percent. Suppose your minimum value is 0 and your maximum value is
10, and the minimum and maximum percentages range is 0 to 200. When the tag value is 10, the object will
be twice as big as you've originally drawn it. When the tag value is 5, the object will be the same size you've
drawn it, which is 100 percent.

(D) Anchor. Enter the anchor point for the object. This is the reference point on the object from which the
graphic object changes. The choices are left, center, and right.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the graphic object’s width will actually change.

Horizontal Slider

Use this attribute to configure a horizontal slider when a graphic object is clicked. This is an operator-driven
attribute and is available for lines, rectangles, round rectangles, ellipses, polygons, and bitmaps.

PAC Display User's Guide 147



DYNAMIC ATTRIBUTES AND THEIR FEATURES

148

In the Graphic Dynamic Attributes dialog box, click Horizontal Slider (in the Operator Driven list) to display its
features.

Operator Driven: Horizontal Slider
Tag

M arme:

A—TE [

B Walue At Left; I:I Movement Left;
Walue At Right: I:I Mowement Right: I:I

D Beference

(O Left (@ Center () Right Deadband: D E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. The distance the horizontal slider is moved affects the value sent to the tag in the
control engine.

(B) Value at Left/Right. Enter the leftmost and rightmost value for the tagname in A. For example, if you
know your tag values can be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0 to 50.

(C) Movement Left/Right. Enter the leftmost and rightmost movement the object can change. The
movement units are in pixels. Suppose your left and right values are 0 and 100, and your left and right
movements are 0 and 200. If you move the tag 100 pixels to the right, the tag value sent will be 50.

(D) Reference. Select the reference point for the object. The choices are left, center, and right. Note that you
must also separately configure the Horizontal Size (Width) dynamic attribute to use this option.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the tag value should be changed.

Using our previous example in C, let’s say the deadband is 5. A tag is read and has a value of 50. The next
graphic object movement must be greater than 55 in order for the tag value to change.
Launch Application

Use this attribute to start an application when a graphic object is clicked. This is an operator-driven attribute
and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.

PAC Display User's Guide



CHAPTER 7: USING ANIMATED GRAPHIC OBJECTS

In the Graphic Dynamic Attributes dialog box, click Launch Application (in the Operator Driven list) to display
its features.

Operator Driven: Launch Application

A whorking Directary: | | Browse.. 7T B
Make Path Relative to Project

Cc Command Lire: | | Browse.. —— D

E —Append Sting: | | 2%

F Launch Options; (® Multiple instances () Single instance

G —Shaw Options: (®) Marmal () Minimized () Maximized

(A) Working Directory. (Optional) Enter the working directory you want to be in when you start the
application. Use the Browse button B to quickly enter a directory name. If a working directory is not specified,
the current PAC Display Runtime directory is used when launching the application. You can change the
working directory at any time.

(B) Browse. Click to find the directory for A. The Working Directory Selection dialog box appears. Use it to
navigate to the desired directory and click OK when you're done.

(C) Command Line. Enter the complete path and file name of the application you want to launch. Use the
Browse button (D) to quickly enter the path.

(D) Browse. Click to find the path and application name for C. The Application Manager Executable File
Selection dialog box appears. Use it to select an application and click Open when you're done.

(E) Append String. (Optional) Enter the name of a string tag to use to append to the path entered in
Command Line (C). The string appended may be a file name the launched application should open.

Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a PAC Control
tag name.

Use the Delete button to clear an entry you may have made in this field. Only tag names may be entered.
Literal strings are not accepted. If the appended string is a parameter, a space must be included in the
Command Line string to separate it from the main command line.

(F) Launch Options. Select Single instance to have PAC Display Runtime check whether the graphic object
has previously launched an application that is currently running. If the object has not previously started a
currently running application, the application will be launched.

Select Multiple instances to allow the graphic object to start more than one instance of an application. Some
applications allow only one session of an application to run, while others allow multiple sessions.

Note that the Single Instance option doesn’t limit the number of active sessions of an application that is
launched by other graphic objects and triggers. For example, if the graphic object launches a Microsoft Word
session, that object can't launch any other application until the Word session ends. However, a trigger-based
event can launch a second, separate session of Word, so two Microsoft Word sessions will be running
concurrently.

(G) Show Options. Click here to configure how the application window will appear. Your choices are
Normal, Minimized, and Maximized.
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Line Color

Use this attribute to change a line color or the line color around a graphic object based on a tag value from the
control engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles,
ellipses, polygons, polylines, and Bezier curves.

In the Graphic Dynamic Attributes dialog box, click Line Color (in the Control Engine Driven list) to display its
features.

Control Engine Diven: Line Color

Tag

M arme:
A—— >
B Setup By Dizcrete

() Dizcrete

(® Current Yalue
C

Current ¥ alue
D Cutoff walues:

<=| |< <=| |< <=| |< <=| |<

tF—1 H H BEH B

Huysteresis:

F— ]

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: T = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.
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For example, let's say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.

Read and Clear

Use this attribute to read a tag value and then clear (reset) it. This is an operator-driven attribute and is
available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.

In the Graphic Dynamic Attributes dialog box, click Read and Clear (in the Operator Driven list) to display its
features.

Operator Driven: Read and Clear

Tag
M ame:
A" 0
Action: Options
B Counts V (®) Decimal () Binary
c () Hexadecimal () Exponential

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name.

(B) Action. Choose the item to be read and cleared when the operator clicks the graphic object:
«  Counts (returns an integer value and then clears counts)
«  Ontime total

o Offtime total

«  Latch (ON)

o Latch (OFF)

«  Onpulse measure

«  Off pulse measure

«  Period

e Minimum

«  Maximum

(C) Options. Formatting options for how values appear when read appear here. Depending on the item you
selected in Action (B), one of the following option groups will be available:

«  Numerical formats—Decimal, binary, hexadecimal, and exponential formats are available for values
returned as numbers (for example, the state of all 32 points on a high-density module).

o Text formats—Custom text that corresponds to a discrete value's on and off states can be entered here.

Notes:

« Ifthe Read and Clear dynamic attribute has been assigned to an object, a “Text In from Control Engine”
dynamic attribute cannot also be assigned to that same object.

« Ifatextplaceholder (##) is used to view return values, these placeholder characters will appear that way
in Runtime until the operator triggers the read and clear. Once this has happened, the graphic object will
not change until the read and clear is triggered again.
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«  If more than one graphic object in a PAC Display window is configured with the same Read and Clear
dynamic attribute, each object is treated independently. The graphic objects are not linked to each other,
so when one object is read and cleared, the other object will not reflect this.

Rotate

Use this control engine-driven to rotate any of the following graphic objects based on a tag value from the
control engine: Bitmap, Metafile, Curve, Polygon, Ellipse, Polyline, JPEG, PNG, Rectangle, Line, or Text.

NOTE: Dynamic rotation can be a CPU intensive. Use dynamic rotation judiciously.

In the Graphic Dynamic Attributes dialog box, click Rotate (in the Control Engine Driven list) to display its
features.

Control Engine Diven: Rotate
Tag

M arme:

A—— || 2

Walue at Max COw: I:I tdaw COW Rotation: I:I Deaqrees
Walue at Max Cw: I:I tdaw O Rotation: I:I Deaqrees

Ratation Anchor Point [Offzet fram Object Centerpaint]

Harizontal: Vertical: I:I Deadband: @ E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, the graphic object’s line rotates.

(B) Value at Max. These fields are used to specify the return data from the tag that will produce the
maximum counterclockwise (CCW) and maximum clockwise (CW) rotation. The Value at Max CCW may be
either less than or greater than the Value at Max CW, so that rotation may proceed in either direction as the
data from the tag increases or decreases. Therefore, the term “exceeds”is used below to indicate a value that
may be either greater than or less than the CCW or CW Max value.

When the tag returns data that is equal to or exceeds the Value at Max CCW to PAC Display, the graphic object
will rotate counterclockwise as far as possible, as specified by the Max CCW Rotation value explained below.
When the tag returns data that is equal to or exceeds the Value at Max CW Rotation to PAC Display, the
graphic object will rotate clockwise as far as possible, as specified by the Max CW Rotation value explained
below.

(C) Max Rotation. These fields are used to specify the maximum counterclockwise and clockwise rotation
angle that the graphic object may undergo (in degrees from its configured location). The entered values must
be non-negative numbers. The Max CCW Rotation angle is achieved when the tag returns data that is equal to
or exceeds the Value at Max CCW, as explained above. The Max CW Rotation angle is achieved when the tag
returns data that is equal to or exceeds the Value at Max CW, as explained earlier in this section.

(D) Rotation Anchor Point. The rotation anchor point is used to specify the fixed location that the graphic
object rotates around. This location is specified in terms of an offset (in units of pixels) from the center point of
the graphic object at its configured location.

In the Horizontal field, enter a negative value to specify a position that is to the left of the configured location
or enter a positive value to specify a position that is to the right of the configured location. In the Vertical field,
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enter a negative value to specify a position that is above the configured location or enter a positive value to
specify a position that is below the configured location. If a value of zero is specified for both fields, then the
graphic object will rotate about its center point.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the line’s rotation angle should change.

For example, let’s say the deadband is 2. A tag with a value of 50 is read. The next tag value read is 51. The line
does not rotate because the value read is within the deadband range.

Send Discrete

Use this attribute to send a discrete value to a tag in the control engine when a graphic object is clicked. This is
an operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.

In the Graphic Dynamic Attributes dialog box, click Send Discrete (in the Operator Driven list) to display its
features.

Operator Driven: Send Discrete
Tag

Marne:

A—I= [B

Source
(@ Fized data () Prompt for data

B

Fixed D ata Prompted D ata D
(®) Set

() Clear

(O Toggle

() Reverse

() Direct

C —

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the tag value entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the setting selected
in the Fixed Data field (C) is sent to the tag. If you select Prompt for data, the Prompted Data field (D) is
activated and you can enter a message that will prompt the operator to select a discrete state for the tag.

(C) Fixed Data. If Fixed Data was selected in Source (B), enter the setting to be sent to the tag. The Set
option turns the tag on; Clear turns the tag off; Toggle changes the tag to the opposite of its current state
(from on to off, or from off to on); Reverse changes the tag's state to off when the mouse is clicked on the
graphic object, and on when the mouse button is released; Direct changes the tag state to on when the
mouse is clicked on the graphic object, and off when the mouse is released.

(D) Prompted Data. If Prompt for Data was selected Source (B), enter a message here that will prompt the
operator to select a tag state. Two buttons will be displayed to the operator. Enter the labels for the Set Button
and the Clear Button. The Set Button sends a discrete value to set the tag to the on state, and the Clear Button
sends a discrete value to set the tag to the off state.
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Send String

Use this attribute to send a string to the control engine when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.In the Graphic Dynamic Attributes dialog box, click Send String (in the Operator Driven
list) to display its features.

Operator Driven: Send Sitring
Tag

Mame;

A—— ]

Source
(®) Fixed data () Prompt for data

B

Fixed Data Prompted D ata
String Out;

C

Hide characters

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the string tag entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the setting selected
in Fixed Data (C) is sent to the tag. If you select Prompt for data, the field in Prompted Data (D) is activated
and you can enter a message that will prompt the operator to enter a string to send to the tag.

(C) Fixed Data. If Fixed Data was selected in Source (B), enter the string to send to the tag.

(D) Prompted Data. If Prompt for Data was selected in Source (B), enter a message to prompt the
operator to enter a string. Choose the Hide characters option if you don't want the text entered by the
operator to be displayed.

Send Value

Use this attribute to send a value to a tag name in the control engine when a graphic object is clicked. This is
an operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.
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In the Graphic Dynamic Attributes dialog box, click Send Value (in the Operator Driven list) to display its
features.

Operator Driven: Send Value
Tag

M ame:

A—HE B

B Source Destination (o]
(®) Fixed data () Prompt for data (@ 5et () Offget

Fined Data Prompted Data: — E

D alue;

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the tag value entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the value entered in
the Fixed Data field (D) is sent to the tag. If you select Prompt for data, the Prompted Data field (E) is activated
and you can enter a message that will prompt the operator to input a value to send to the tag.

(C) Destination. Choose Set to assign the sent value to the tag, or choose Offset to add the value to the tag.

(D) Fixed Data. If Fixed Data was selected in Source (B), enter the value to send to the tag.

This value can be either a decimal or hexadecimal number. If entering a hexadecimal number, the number
must be preceded by “0x"and contain no spaces (for example, “Ox7FFFFFFF”and not “Ox 7FFF FFFF").

(E) Prompted Data. If Prompt for Data was selected in Source (B), enter a message to prompt the operator
for a value. Enter a minimum and maximum value the entered data should be within.

IMPORTANT: If using hexadecimal numbers, enter a minimum number of 0x80000000 and a maximum number of
Ox7FFFFFFF.

Text Color

Use this attribute to change the color of text in the interface based on a tag value from a control engine. This is
a control engine-driven attribute and is available for grouped objects and text.
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In the Graphic Dynamic Attributes dialog box, click Text Color (in the Control Engine Driven list) to display its
features.

Control Engine Driven: Text Color

Tag

Mame;
A—— )
B Setup By Discrete

() Discrete

(®) Cument Walue
C

Current Value
D Cutaff walues:

<=| |< <=| |< <=| |< <=| |<

E—IH H H BEH B

Hystereszis:

F—0 |

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: T = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.

For example, let’s say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.
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Text In from Control Engine

Use this attribute to read a tag from a control engine and display various strings to the operator. You can read
in a numeric value, a string, or a discrete value, and set up a string that will be displayed based on what was
received. This is a control engine-driven attribute and is available for a text object.

A #sign in the text object indicates where the text string should be displayed. Only one # is needed to display
an entire string. If there’s no # sign within the text object, then the string will be appended to the end of the
text object. You can configure how a floating point number is displayed by using a decimal point along with
the # signs. For every decimal place you want displayed after a decimal point, use a # sign. For example, your
text object could say: “Low level reading: ###.#. Your tag value is 200.55, so your displayed string is: “Low level
reading: 200.6.

NOTE: The extra # signs to the left of the decimal point aren't required, but are useful for determining how much space
the text will require in your display.

In the Graphic Dynamic Attributes dialog box, click Text In from Control Engine (in the Control Engine Driven
list) to display its features.

Control Engine Driven: Text In from Control Engine

Tag
Mame;
A— IE
Setup By Walue Tent Justification Mumerical Format
B—— D
(®) Value Deadband: (®) Left (®) Decimal
() Discrete v () Center (O Hexadecimal E
() Sting ) Right () Binary
C () Exponential
F Dizcrete

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object. The tagname you enter is affected by the setting for Setup By (B).

(B) Setup By. Choose whether the tag you're reading is a numeric value, a discrete value (with ON and OFF
values), or a string. If you choose Value, the Deadband and Text Justification fields (C and D) are activated. If

you choose Discrete, the Numerical Format group (E) is activated. The choice you make in this selection must
match the choice you made in Name (A).

If you choose Value, the value read will be converted into a string based on the rules mentioned at the
beginning of this “Text In” section.

If you choose Discrete, use Numerical Format group (E) to enter the strings that will be displayed for the ON
and OFF states. If you choose String, the text string from the control engine is displayed.

(C) Deadband. If you selected Value in Setup By (B), enter the value to be added and subtracted from the
previously read tag value to determine whether the new value is displayed.

(D) Text Justification. Select the format in which numeric values will be displayed: decimal, hexadecimal,
binary, or exponential. Hexadecimal numbers are prefixed with “0X"and appear in uppercase letters. Float
values may not be displayed as hexadecimal or binary.
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(E) Numerical Format. Select the text justification for the string from the control engine.

(F) Discrete. This section is highlighted if Discrete was chosen in Setup By (B). Enter the string to be
displayed if the tag's discrete value is ON, and enter the string to be displayed if the tag's discrete value is OFF.

Upload Recipe

Use this attribute to upload a recipe file from a control engine when graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text. For more information about recipes, see “"on page 239.

In the Graphic Dynamic Attributes dialog box, click Upload Recipe (in the Operator Driven list) to display its
features.

Operator Driven: Uplead Recipe
Faormat File

A —D'ITEEtUrp'—'_ | Browse — B

Make Path Relative to Project [ ]——— C

D File: Mame

E (®) Fived name Fited biameal | E stension:

() Prompt for name

i
F () Fram strategy |

Destination File

Diirectary: | | Log To.———— H

G

Make Path Relative to Project [

e | | Estension: K

?

File: Mame
(®) Fixed name

) Prompt for name
L () From strategy |

(A) Name. Enter the directory location of the recipe format file. Use the Browse button B to quickly select a
directory name. The recipe format file is used to tell the control engine what data to read. Often, it's the
original downloaded recipe. For example, the number of lines with data values represents how many values
should be read from the control engine.

(B) Browse. Click to quickly find the recipe format file directory for A. The Select Format File Directory dialog
box appears. Use it to navigate to the desired directory and click OK when you're done.

(C) Make Path Relative to Project. \When selected, if you copy the project and recipe format files to a
different computer, PAC Display will look in the same relative location to find the recipe format files in
Configurator and Runtime.

For example, if the project is saved in C:\proj\ and you configure recipes format files to be in C:\proj\recipes\,
then the relative path would be this: \recipes\

If you then saved the project to C:\temp\newproj\, PAC Display would look for recipe format files in the new
location’s relative path: C:\temp\newproj\recipes\

(D) File Name. Choose the source of the recipe format file name:

«  Ifyou choose Fixed name, the Fixed Name field (E) is highlighted.

«  If Prompt for name is selected, the operator is prompted for the recipe format file name.
«  If From strategy is selected, the String Name field (F) is highlighted.
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(E) Fixed Name. If Fixed Name was selected in D, enter the name of the recipe format file located in
directory A. Notice the file extension is .rcp.

(F) String Name. If From strategy was selected in D, use either Quick Tag Entry (see page 74) or the Tag
Selection dialog box (see page 75) to select a PAC Control tag name of type string that contains the recipe
format file name.

(G) Directory. Enter the directory location of the recipe file that will receive the information. Use the button
(H) to quickly enter a directory name.

(H) (Basic only) Browse. Click to quickly find the recipe file directory for G. The Select Destination File
Directory dialog box appears. Use it to navigate to the desired directory and click OK when you're done.

(H) (Pro only) Log To. Click to select whether to log to an ASClI recipe file or to a database table. If you click
Log File in the pop-up menu:
«  Use the Browse for Folder dialog box to navigate to the desired directory, and then click OK.

«  Use the Select Database Table dialog box to select the desired table, and then click OK. For more
information about logging to a database table, see “Configuring an ODBC Data Source” on page 55.

(1) File Name. Choose the file name for the recipe data that will be read from the control engine.

«  Fixed Name—Check this if the template file is a file name you want to configure at this time. If this
option is selected, the File Name edit box appears, prompting you for a file name. Make sure the file exists
in the Directory entry, otherwise an error is posted. The file name may not be changed at Runtime.

The "Extension" parameter also appears and prompts for a one to three character long extension that's
appended to the "Fixed Name". The extension must not contain a period or a DOS wild card character.
The default extension is "rcp".

«  Prompt For Name—Check this if the template file name is to be prompted at Runtime when the trigger
occurs. If this option is selected, the Extension parameter also appears. Enter a one to three character
long extension which does not contain a period or a DOS wild card. This extension is used as a filter to
select which files are displayed when prompting a user for the recipe name at Runtime, however files
with different extensions may be selected.

«  From Strategy—Check this option if you want to use a string tag name from the control engine
strategy to specify the template file name. If this option is selected, the String Name dialog box appears,
prompting for the tag name you want to use. Use the "?" button to enter the tag name from the Tag
Selection dialog box.

(J) Fixed Name. If Fixed Name was selected in |, enter the name of the file to receive the information. This
file will be located in the Directory field (G).

(K) Extension. Specify the file extension for the recipe files available to this dynamic attribute by entering
the extension in the File Extension field. The extension must be one to three characters long and must not
contain a period or DOS wild card characters.

If Fixed Name is checked, this extension will append to the File Name entry to create the name for the recipe
file. If Prompt For Name is checked, this extension will be used as a filter to select the files for display in a file
selection dialog box when Runtime executes this dynamic attribute. However, you may override this filter if
you wish to select a file with a different extension.

(L) Mistic String. If From strategy was selected in I, use either Quick Tag Entry (see page 74) or the Tag
Selection dialog box (see page 75) to select a PAC Control tag name of type string that contains the file name.
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Vertical Position

Use this attribute to adjust the vertical position of a graphic object based on a tag value from the control
engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses,
and polygons, polylines, curves, bitmaps, and text.

In the Graphic Dynamic Attributes dialog box, click Vertical Position (in the Control Engine Driven list) to
display its features.

Control Engine Diven: Vertical Position
Tag

M ame:

A— |[2

B Walue A Top: I:I tovement Up: I:I C
Walue At Bottom; I:I tovement D own; I:I

Reference

D ()Top (@ Center () Bottom Deadband: I:I —E

(A) Name. EUse either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes, the graphic object’s horizontal position is changed.

(B) Value at Top/Bottom. Enter the top and bottom values for the graphic object. For example, if you
know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range
such as 0to 50.

(C) Movement Up/Down. Enter the maximum top and bottom movement the object can change. The
movement units are in pixels. For example, if your bottom and top values are 0 and 100, your bottom and top
movements are 0 and 200, and your point of reference (D) is from the bottom when the tag value is 50, the
object will be moved 100 pixels from the bottom.

(D) Reference. Enter the reference point for the object. This is the reference point from which the object will
move. The choices are top, center, and bottom. The Vertical Size (Height) dynamic attribute must also be
configured in order for this option to affect the graphic object.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s position will actually change. Using our previous example in C, let’s say the
deadband is 5. A tag is read and has a value of 50. The next tag reading must be greater than 55 in order for
the graphic object to move.

Vertical Size (Height)

Use this attribute to change the height of a graphic object based on a tag value from the control engine. This
is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses, and

polygons.
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In the Graphic Dynamic Attributes dialog box, click Vertical Size (height) (in the Control Engine Driven list) to
display its features.

Control Engine Diven: Vertical Size (height)
Tag

M ame:

A—— |[7

B

b amimumm W alue; I:I M ax Percent Height: I:I
Firirmum % alue: I:I Min Percent Height:

Anchor

()Top (@ Center () Bottom Deadband: I:I —E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object.

(B) Maximum/Minimum Value. Enter the maximum and minimum value for the tagname in A. For
example, if you know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a
subset of this range, such as 0 to 50.

(C) Max/Min Height. Enter the maximum and minimum percentage the object can change. The
percentage range is from 0 to 1,000. Suppose your minimum value is 0 and your maximum value is 10, and
the minimum and maximum percentages range from 0 to 200. When the tag value is 10, the object will be
twice as big as you've originally drawn it. When the tag value is 5, the object will be the same size you've
drawn it, which is 100 percent.

(D) Anchor. Enter the anchor point from which the object will “grow.” The choices are Top, Center, and
Bottom. For example, if you want to create a bar that grows up from the bottom, select Bottom. If you want to
create an object that grows both up and down from the center, select Center. An object with a Top anchor
grows down from the top.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s height will actually change. For example, let's say the values are 0 to 100, the
percentages are 0 to 100, and the deadband is 5. A tag is read and has a value of 10. The next tag reading must
be greater than 15 in order for the graphic object to change.

Vertical Slider

Use this attribute to configure a vertical slider when a graphic object is clicked. This is an operator-driven
attribute and is available for lines, rectangles, round rectangles, ellipses, polygons, and bitmaps.

PAC Display User's Guide 161



DYNAMIC ATTRIBUTES AND THEIR FEATURES

162

In the Graphic Dynamic Attributes dialog box, click Vertical (in the Operator Driven list) to display its features.

Operator Driven: Vertical Sfider
Tag

Mame;

A— 2

Walue At Top: I:I Mavement Lip: I:I
B ——C
alue At Bottor: I:I Movement Dowe: I:I

Reference

() Top @ Center () Bottom Deadband: D E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. The amount of movement the vertical slider makes affects the value sent to the tag in
the control engine.

(B) Value at Top/Bottom. Enter the top and bottom values for the tagname in A. For example, if you
know your tag values can be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0to 50.

(C) Movement Up/Down. Enter the maximum top and bottom movement the object can change. The
movement units are in pixels. This means if your bottom and top values are 0 and 100, and your bottom and
top movements are 0 and 200, if you move the tag 100 pixels toward the bottom, the tag value sent will be 50.

(D) Reference. Select the reference point for the object. The choices are top, center, and bottom. Note that
you must also separately configure the Vertical Size (Height) dynamic attribute to use this option.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the tag value should be changed.

Using our previous example in C, let’s say the deadband is 5. A tag is written and has a value of 50. The next
graphic object movement must be greater than 55 in order for the tag value to change.

Visibility/Blink

Use this attribute to make a graphic object visible or invisible or to cause it to blink based on a tag value from
the control engine. This is a control engine-driven attribute and is available for lines, rectangles, round
rectangles, ellipses, polygons, polylines, curves, bitmaps, Windows button controls, and text.

In the Graphic Dynamic Attributes dialog box, click Visibility/Blink (in the Control Engine Driven list) to display
its features.
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Control Engine Driven: Visibility Blink

Tag
Hame;
A—r ?
Setup by Discrete
B —=F
() Discrete
(®) Current Value YWisible Irvisible
C
Current Value
Cutoff walues:
D <=| |< <=| |< <=| |< <=| |<
E —|¥isible | |Wisble | [Misble ~  (Misble  w [ Wisible
Deadband:

F—f |

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object.

(B) Setup By. Choose whether the tag you're configuring is a discrete value (with ON and OFF values), or
whether it’s a current value you're looking for. If you choose Discrete, the C group is highlighted; if you choose
Current value, the D group is highlighted. The choice you make in this selection must match the tag choices
you made in the Name field (A).

(C) Discrete. Select the visibility state you want for the ON state from the drop-down list options. Your
choices are Invisible, Visible, Slow Blink, Med. Blink, and Fast Blink. In the same manner, choose the visibility
state for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value field to specify the range of values for each visibility
group configured in the visibility fields. Values entered must be in increasing order. Each Cutoff Value field
must have a numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks
in the first Cutoff Value field requiring a value.

(E) Visibility. To configure a visibility state for the ranges set up in Cutoff Values (D), click a visibility field's
drop-down button. Your choices are Invisible, Visible, Slow Blink, Med. Blink, and Fast Blink. In the same
manner, choose the visibility state for each range of values.

(F) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s visibility will actually change.

For example, let's say the Cutoff values are 1, 10, 20, and 30, and the visibility fields are Invisible, Visible, Slow
Blink, Med. Blink, and Fast Blink. The Deadband is 2. A tag is read with a value of 10. The next value read must
be greater than 12 in order for the graphic object to change.

Windows

Use the Windows attribute to change window states when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.
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In the Graphic Dynamic Attributes dialog box, click Windows (in the Operator Driven list) to display its features.

Operator Driven: Windows

Windaws: Action  Affected Windows

Mew Action
A | Cookie Factary I D
B "Windows 22 | Open
Cc Append -» F
Cloze
Default
E |conify
(® Open
() Close
f Femove Selected G
() lconify
Remowe Al
Deselect Al
H All Others
It Open If Clozed It Iconified
Mo change Mao change Mo change
lconify Open Open
Cloze |conify Close

(A) Windows. Initially, this list shows all the windows available for the project. Select the window that has
the window state you want to change. You can also select more than one window by using a couple of key
combinations. One way is to select a window, press Shift, and then click on another window name in the list.
This selects all the windows in between the two window names. Another way is to select a window name,
press the Ctrl key, and click on each window name you want selected.

(B) Insert. Use to insert the selected window(s) in Action/Affected Windows (D). The window name will be
inserted above the highlighted window(s) in (A).

(C) Append. Use to add the selected window(s) to the bottom of the window list in Action/Affected
Windows (D). The window name will be inserted after the last window in Action/Affected Windows (D).

(D) Action/Affected Windows. Lists the windows and what window state they will go to when the
graphic object is clicked.

(E) Default. Use this group as a handy window state assignment key for the windows you've highlighted in
(A). When the windows are copied over to Action/Affected Windows (D), you will see they all have the
default window state you've assigned. The window state choices are Open, Close, and Iconify.

(F) New Action. Use this group to change any window states listed in Action/Affected Windows (D).
Highlight one or more windows and select the new window state action. Your choices are Open, Close, and
Iconify.

(G) Remove/Deselect. Use this group to modify the window name list in Action/Affected Windows (D).
The Remove Selected option removes only those windows you've highlighted; the Remove All option
removes all windows from the list; and the Deselect All option deselects and quickly unhighlights all window
names.

(H) All Others. For all windows leftin (A), use this grouping to affect their window states. For example, if a
window state is open and the graphic object is clicked, the window state can stay the same, be iconified, or be
closed. Likewise, you can alter the window states of closed and iconified windows.
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ASSIGNING A DYNAMIC ATTRIBUTE TO A GRAPHIC OBJECT

See also: Appendix , “F: Using the Old-Style Dynamic Attribute Dialog Boxes,".

As you finish drawing your operator interface, you can start assigning dynamic attributes to graphic objects.
Here's how:

1.

2.

With the Select tool |£__t|, double-click the graphic object that you want to assign a dynamic attribute to.
(Or, you can click the object once, and then click Edit > Edit Dynamic Attributes in the PAC Display menu
bar).

The Graphic Dynamic Attributes dialog box appears.

This label shows the type Use these fields to change the object’s location (X and Y coordinates) and size.
of object you selected. The Width and Height fields are grayed-out for this object because you can't
\ change a Text Box's size using this dialog box.
AR

Graphic\N<amic Attributes \ X

Object: Text w[E ] v Width: | 51 | Height: | 18 Hint... Security. .

Control Engine Driven

[ Text Calor

[ visibility,Blink

[ Rotate

[ Horizontal Position

[ vertical Position

[] Text In from Control Engine

After you select an attribute, its features are displayed here,
in the center of this dialog box.

Operator Driven

[0 Horizontal Slider -~
[0 vertical Slider

[ ® Send value

D + Send Discrete

D [ Send Siring

O windows Attributes are listed by type.
E Download Redpe If you don't see a specific attribute,
PR > it means the attribute doesn't apply
P to the object you selected.
[“1Beep enabled
Hotkey: [Jctrl []shift | <Nonex
Cancel Help

Click the name of the attribute you want to assign to the object. (Note: Click its name, not its check box.)
In this example, we'll select Visibility/Blink.
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The attribute’s features are then displayed in the center of the dialog box.

Graphic Dynamic Attributes *
Object: Text ¥ = Width: 51 Height: = 18 Hint... Security...
Control Engine Driven Control Engine Driven: Visibility/Blink
[ Text Color Taa  These are the features of the Visibility/Blink attribute.
(W] visibility fBlink Narne:
[ rotate | | 7
[ Horizontal Position ;
[ vertical Position Sl Dicre
[] Text In from Control Engine R ISCI? %
(O Discrete oM OFF
(®) Current Yalue Wizible Irwvisible
TR Current Yalue
E Horizontal Slider - Cutoff values:
Vertical Slider
<= $ L= < <= < <= <
i e [« <[ _J¢ «[J¢ <[]
[ ® send Discrete
[ # send String Vigible  ~ Migible s~ |Migble s~ |Migble ~ | Vigble
OO windows
[0  bownload Recipe v %:
L | Lisa af >
£ >
Focus-frame enabled
Beep enabled
Hotkey: [Jctl  [shift |<Mone>
I P R T e T gy S _‘J' e )

indicating that configuration is in progress and the changes have not yet been saved.

If you select a feature that can't be used with another of the attribute’s features, the other feature is
grayed out so you can't configure it.

Clicktheattribute’scheck

box after you've finished

configuring its features.
—

TIP: Quick Tag Entry
makes it easy to select
tags. For details, see
“Using Quick Tag Entry”
on page 74

Click OK after you've
checked the boxes for all
the attributes you want
to assign to the object.
(You can add or change
attributes later.)

e ke SPESPE SR R Tl S

4, ¥: Width: | 51

Object: Text

Control Engine Driven

gy W T e

Height:

-

18

Control Engine Driven: Visibility/Blink

Configure the features. As you start to make changes, the color of the attribute’s name changes to green,

Hint. . Sead

1
8

-«

Tag £

{

[ visibility Contraller: Item M ame: Field / [Index] +
L2 [ Learming Center | [TREND_PEN_1 | ][z 4

[ Horizontal Position i
[ vertical Position . g
i

Control Engine Seunby DISC[_Et? e ]
(O Discrete (] OFF L8
(®) Current Yalue Wizible Invizible {'I

b,

25 Rl R Current Yalue “,
E Horizontal Slider - Clhtofaalies ‘)

Vertical Slider
<= (10 < <=
# Send Value 1‘(
[ ® Send Discrete ' : (
[ @ send 5tring Wisible  ~ | Inwisible | | Invisible Invigible | Invisible ~
OO windows '
O DJownIoad Recipe e adhand: é
— MRS 1 " " .

< > Because the “Current Value”feature is selected, 7
e the fields for “Discrete” are grayed out. 3
Beep enabled I
Hotkey: [Jctd  []shift |<MNonex  ~ 4
i

{

Cancel Help 4
<

4
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4. When you're finished configuring the feature, click the attribute’s check box. Any errors in
configuration will be displayed in a message box, and you'll need to fix them before the check box will
stay checked.

If there are no errors, the green color disappears from the attribute’s name.

To assign another attribute to the object, repeat steps 2—4.

NOTE: The Send Value, Send Discrete, and Send String attributes can be assigned more than once to the same

object. For details, see “Assigning Send Value, Send Discrete, and Send String” on page 169.

5. Aslong as you have assigned at least one attribute to the graphic object, you can also assign these
options:

- Focus-frame enabled—If this option is checked, a light border will appear around the object in
Runtime when the operator moves the cursor over it. This border can be used as a visual aid to let
the operator know that an event will occur when the object is clicked.

- Beep enabled—If this option is checked, the operator will hear a beep when the object is clicked.
Use this as an audio confirmation.

—  Hot Key—This option associates a keystroke sequence with the object. A hot key is a key on the
keyboard (sometimes in combination with the Ctrl or Shift key) that when pressed, activates the
object’s operator-driver attributes. This lets the operator use a predefined keystroke sequence
(instead of using a mouse click) to select a graphic object, thereby allowing PAC Display Runtime to
be operated without a mouse or similar device.

NOTE: The hot key works only for graphic objects that are in an opened or minimized window; closed
windows are not affected.

- Security—This option defines whether the operator can use the object. For details, see “Security
Settings for Graphic Objects and Dynamic Attributes”on page 176.

—  Hint—This option will display Toolbar text when the operator hovers the mouse pointer over the
object. (Applicable only to basic objects such as lines, rectangles, ellipses, and text). For details, see
“Adding Hint Text to a Graphic Object”on page 175.)

6. When you've finished assigning attributes to the graphic object, check to see if any other attribute’s name
is green.

- Ifyou want to keep the attribute, finish configuring it, and then check the box next to its name.

- Ifyou don't want to keep it, just ignore it. It will be cleared (reset) when you close the dialog box.

Then, click OK to save the configuration and close the dialog box.

Notes

You can assign dynamic attributes to only one object at a time. If you want several objects to have the
same attributes, select the objects, and then choose Edit > Group to make them one object. (You can
also right-click the selected graphic objects and choose Group from the pop-up menu.)

NOTE: Ifyou ungroup the objects, the attributes you configured when they were a group aren't retained.

Sometimes after configuring an attribute and checking its check box, the Not Available indicator ()
appears in a different attribute’s check box. This means that you can’t configure the other attribute
because the two attributes cannot be used together in the same graphic object.

When you assign more than one operator-driven dynamic attribute to a graphic object, the attributes are
executed in the order they appear in the Operator Driven Attributes list.

The color of an attribute’s name changes to green when:
- Atag has been selected for the attribute.
—  One of the attribute’s features has been changed.
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Its name remains green until you check its check box save the changes, or until you click OK and then
click Yes on the dialog box that warns your changes will be lost.

4
< Inthisexample, the
¢ configuration hasn't been
Object: Rectangle X ¥ Width: Height: Hint... i_ saved for Fill Color and
2 Visibility/Blink. (Their check
Control Engine Driven Controfl Engine Driven: Visibility. Blink ¢ boxes are not checked )
[ Line Colar ~ Tag 7
[ Fill color Mame: 2

[] visibility Bl
[ rotate
[ Horizontal Size (width) o

[ vertical Size (height) Some attributes [shown in green) have not been fully
@) Horizontal Position configured, or their checkmark has not been checked.

Dynamic Attributes

4 This message appears when
- Qx the user clicks the OK button
_ to close the dialog box.

< > These will not be saved.

will close and the attributes in
green will be reset.

Operator Driven Do you want to continue?

{ If you click Yes, the dialog box
{
X

Horizontal Slider ~ :

[0  vertical Slider . i
# Send Value Yes No 1
[ ® send Discrete 3

[Vishle  ~| |Visble | |Visble | |Visble | |Visble <

[ ® send String
el S F,
You don't need to completely configure one attribute before starting to configure another. You can start
another by clicking its name. Just remember to complete the configuration and check the box next to
the attribute’s name before closing the Graphic Dynamic Attributes dialog box.

Modifying a Graphic Object’s Dynamic Attributes

NOTE: For the Send Value, Send Discrete, and Send String attributes, see “Assigning Send Value, Send Discrete, and
Send String” on page 169.

To change a graphic object’s dynamic attributes:

1.

Open the object’s Graphic Dynamic Attribute dialog box (either by double-clicking the object, or clicking
Edit > Edit Dynamic Attributes in the PAC Display menu bar).

Click the name of the attribute you want to change. (Note: Click its name, not its check box.)
As you make changes, the attribute’s check box is cleared.

When you've finished changing features, click the attribute’s check box to store the changes.
Click OK to save all changes and close the dialog box.

Clearing a Single Dynamic Attribute

NOTE: For the Send Value, Send Discrete, and Send String attributes, see "Assigning Send Value, Send Discrete, and
Send String” on page 169.

To clear (reset) a dynamic attribute for a graphic object:

1.
2.
3.

In the Graphic Dynamic Attributes dialog box, click the name of the attribute you want to clear.
Then, uncheck the attribute’s check box.
Click OK to save the changes and close the dialog box.

Clearing All of a Graphic Object’s Dynamic Attributes

To clear (reset) all dynamic attributes for a graphic object:

1.
2.

168

If the Graphic Dynamic Attributes dialog box is open, close it.
Using the Select tool, click the graphic object you want to clear.
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NOTE: If the graphic object is a group, clearing its attributes will clear the attributes of all objects in the group.
To modify only one object in the group, first ungroup the objects (Edit > Ungroup), and then continue to step 3.

3. InPAC Display’'s menu bar, click Edit > Delete Dynamic Attributes.
Another way you can do this is to right-click the graphic object (to display the pop-up menu), and then
click Dynamic Attributes > Delete.

All of the attributes are instantly cleared. (Note that this action does not display a confirmation message.)

COPYING CONFIGURED ATTRIBUTES TO OTHER GRAPHIC OBJECTS

Once a dynamic attribute has been added to a graphic object, you can easily assign those attributes to other
objects using PAC Display menu options.

Copying Dynamic Attributes from a Graphic Object

To copy a set of dynamic attributes from one graphic object to another:

1. With the Select tool |.._i], click the graphic object whose dynamic attributes you want to copy.

2. Inthe PAC Display menu bar, click Edit > Copy Dynamic Attributes (or use Shift+Ctrl+C) to copy the
attributes to the Windows clipboard.
Another way you can do this is to right-click the graphic object (to display the pop-up menu), and then
click Dynamic Attributes > Copy.

You can now assign these dynamic attributes to another graphic object using Edit > Paste Dynamic
Attributes.

Pasting Dynamic Attributes to a Graphic Object

NOTE: Pasting will paste all attributes that are valid for the destination object. For example, if you attempt to paste a
Text Color attribute and a Vertical Position attribute from a text object to a rectangle object, only the Vertical Position
attribute will be pasted, because Text Color is not valid for rectangle objects.

After copying dynamic attributes from a graphic object, follow these steps to paste them to another:

1. With the Select tool . click one or more graphic objects to which you want to paste the dynamic
attributes.
2. Inthe PAC Display menu bar, click Edit > Paste Dynamic Attributes, and then do one of the following:
- Todelete any existing dynamic attributes the graphic object may already have, select Delete
Existing.
- Toadd the (valid) copied attributes to existing attributes and replace any that might be of the same
type, select Replace Duplicates.

- Toadd the attribute to existing attributes and not change any attributes that might be of the same
type, select Ignore Duplicates.

Another way you can do this is to right-click the graphic object (to display the pop-up menu), and then
click Dynamic Attributes > Paste.

ASSIGNING SEND VALUE, SEND DISCRETE, AND SEND STRING

NOTE: For details about each of these attributes, see “Dynamic Attributes and Their Features” on page 140.

You can assign more than one Send Value, Send Discrete, and Send String attribute to a graphic object. The
steps are basically the same as assigning any other attribute.
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1. Inthe Graphic Dynamic Attribute dialog box, click the name of the attribute you want to assign to the
object. (Click the name, not the check box.) In this example, we'll select Send Value.

The attribute’s features are then displayed in the center of the dialog box.

Graphic Dynamic Attributes *

Object: Rectangle X i Width: Height: Hint... Security...

Control Engine Driven Operator Driven: Send Value
[ Line Colar ~ Tag
[ Fill Colar Mame:
[ visibility Blink | |
[ rotate

[ Horizontal Size (width)

[] vertical Size (height) Soline Destination

[[] Harizontal Position ®) Fived data (O Prompt for data @ 5et (O Offset
v

< >

Fixed Data Prompted D ata:

QOperator Driven

[0 Horizontal Slider - Wil l:l
[0 vertical Slider

O
[ ® send Discrete

[J ® send String

0 windows

[0  bownload Recipe

/i i i

v
< >

Focus-frame enabled
Beep enabled

HotKey: []ctrl []shift |<Nonex

Cancel Help

2. Configure the features. As you start to make changes, the color of the attribute’s name changes to green,
indicating that configuration is in progress and the changes have not yet been saved.
3. When you're finished configuring the features, click the attribute’s check box. Any errors in

configuration will be displayed in a message box, and you'll need to fix them before the check box will
stay checked.

TIP: To see the tag name of the first Send Value, Send Discrete, or Send String in the list, click the attribute name
and look at its Name field.

4. Toassign another attribute to the object, , click the + icon next to attribute’s name (in this example, Send
Value).

-
[ i =

" Fia,

Operator Driven L ~When you click the first Send Value's check box,
(] Harizontal Slider ~ /ﬁfits color changes from green to black.

[ vertical Slider % When you click the + icon, another Send Value

= becomes available for configuration.
[0 <avaiabl

i

(] ® send Discrete ‘,‘l
[ ® send String {
1

4

F

D Windows
L - . ‘—_

£ >

L P
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Nowy, click <available>, and then configure its features.

Control Engine Driven

[ Line Colar

[ Fill Colar

[ visibility fBlink

[ rotate

[ Horizontal Size (width)
[ vertical Size (height)
[ Horizontal Position

< >

QOperator Driven

[0 Horizontal Slider
[0 vertical Slider
= Send Value

[0 <avaiable>
[ ® send Discrete
[ ® send String
OO windows
L | . .

Pl ¥ r Py

Tag

Controller:

Operator Driven: Send Value

Item M ame: Field / [Index]

|Leaming Center

Y IE]

- | | R ampyalue

Source

(®) Fixed data (O Prompt for data

Fixed D1ata

Walue:

Destination

@ Set () Offset

rroiWhen you select <available>, its features are displayed
u:erfor configuration.
win:When you start to configure it, its name turns green.

When you're finished configuring the features, click the attribute’s check box. The tag name is now
displayed in place of <available>.

To see the tag name for the first attribute in
the list, click the attribute’s name. The tag
name is displayed in the Name field.

Control Engine Qriven

[ Line Colar
[ Fill Colar
[ visibility fBlimk
[ rotate
[ Horizontal
[ vertical siz
[] Horizontal

ize (width)
(height)
‘osition

< >

QOperator Driven

[0 Horizongel Slider

O 'v'erﬁca!ider

= Send Value
Learning Center:fR
[0  <avaiable>

[ ® send Discrete

[] # send 5tring

L | PO

< - >

Ll

Tag

M ame:

Operator Driven: Send Value

| Learning Center:fRampY alue

|2

Source

(®) Fixed data (O Prompt for data

Fixed D1ata

Walue:

For subsequent attributes in the list, the label
changes from <available> to the the

attribute’s tag name.
Tfompted

Click OK to close the dialog box and save the changes.

Clearing an Individual Send Value, Send Discrete, or Send String
See also “Clearing All of a Graphic Object’s Dynamic Attributes” on page 168.

To clear a single instance of a Send Value, Send Discrete, or Send String attribute:

Click the + icon next to the attribute name to expand the list.
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NOTE: To see the tag name of the first attribute in the list, click the attribute name and look at its Name field.

Control Engine Driven Operator Driven: Send Value
[ Line Colar ~ Tag
[ Fill Colar Mame:
[ visibility Blink |Leaming Center: fConveyors peedContral |
[ rotate

[ Horizontal Size (width)

(] Vertical Size (height) Source Destination
[ Horizontal Position (®) Fixed data (O Prompt for data @® Set () Offset
v
e < .
Fixed Data Prompted D ata:

Horizontal Slider

[0 vertical Slider

e
Learning Center:fR
O  <avaiable>

[ ® send Discrete

[ ® send String

L | bl

Qperator Driven i i

re MET ’

2. Uncheck the box next to the attribute you want to clear.

NOTE: The attributes listed below the one you cleared now move up in the list.

3. (lick OKto close the dialog box and save the changes.

Reordering Attributes

NOTE: Top-level attributes (such as Send Value) cannot be moved.

Multiple attributes of Send Value, Send Discrete, and Send String are sent to the device in the order displayed
in the list. To change the order of the sends:

1. Click the + sign to expand the list.
2. Selectan attribute, and then drag it to a new position in the list.
3. (lick OKto close the dialog box and save the changes.

ASSIGNING A CHART STATE VALUE TO A GRAPHIC OBJECT

You can assign chart states (such as Stopped and Running) to a graphic object either as control engine-driven
attributes or as operator-driven attributes.

Control Engine-Driven

To assign chart states as control engine-driven attributes:
1. Double-click the graphic object to which you will assign a chart state attribute.
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2. Inthe Control Engine Driven list, click the name of one of the color attributes you want to use. In this
example, we'll use Fill Color. (See also, “Fill Color” on page 144.)

Corttrol Engine Driven: Filf Color
Tan

M armne:

| ?

Setup By Discrete
() Discrete
(®) Current Yalue

Current Value
Cutoff values:

[ Je e[ e e[ e «[ ]«
Huysteresis:

]

3. Configure a tag for this dynamic attribute. (See also, “Configuring Tags”on page 74.)
In the Setup By area, leave the default setting (Current Value).

5. Inthe Current Value area, enter values from the table below to represent the different states a chart can
have, and then select a color for each value.

Value Chart State

0 N/A*

1 Stopped
2 Suspended
3 Running

* 0 is used to represent the range of values from 0 through to and including 1.

Control Engine Driven: Fill Color
Tag
Contraller: Item Marne: Field / [Index]
| Coakie Cantraller v ||nChartStatus o ||| w | 7

Setup By Discrete
() Discrete
(® Current Yalue

Current Value
Cutaff values:
“fo_J¢ «f_J «P

Il N [

Hysteresis:

I

6. When you've finished, click the check box next to the attribute name to save its configuration, and then
click OK to close the dialog box.

PAC Display User's Guide 173



ASSIGNING A CHART STATE VALUE TO A GRAPHIC OBJECT

Operator-Driven

To assign a chart state as an operator-driven attribute:
1. Double-click the graphic object to which you will assign a chart state attribute.
2. Inthe Operator Driven list, click Send Value (—its name, not its check box). (See also, “Send Value” on

page 154.)
Operator Driven: Send Value
Tag
Mame;
| IE]
Source Destination
(®) Fized data () Prompt for data (@ 5et () Offgat

Fined Data Frompted Data:

Walue: I:I

3. Configure a tag for this dynamic attribute. (See also, “Configuring Tags”on page 74.)
4. Under Source, select either Fixed data or Prompt for data.
For Fixed Data, enter one of the following values:

Value Chart State

1 Stop
2 Suspend
3 Start
4 Continue

Or, for Prompted Data:

a. Create a User Message.
b. EnteraMinValue of 1.
c. EnteraMax Value of 4.

In Runtime, the user enters 1, 2, 3, or 4 to stop, suspend, start, or continue the chart as indicated in the
table above. In this example, we selected Prompt for data.

Operator Driven: Send Value

Tag

Controller: Item M ame: Field / [Index]
|Eookie Cantraller w ||nEhartStatus ~ || ~ |
Source Destination

() Fixed data (®) Prompt for data ®Set ) Offset
Fixed D ata Prompted D ata:

Uzer Message: |'I=S top;2=5uspend;3=5tart:4=Cont |

bin W alue: b 3 W alue:

5. When you've finished, click the check box next to the attribute name to save its configuration, and then
click OK to close the dialog box.

174 PAC Display User's Guide



CHAPTER 7: USING ANIMATED GRAPHIC OBJECTS

ADDING HINT TEXT TO A GRAPHIC OBJECT

Follow the steps below to add hint text to the Tooltips box of a basic graphic object such as a line, rectangle,
ellipse, or text. The hint is displayed in the Tooltips box when an operator hovers the mouse over the graphic
object in Runtime.

NOTE: Only one instance of hint text can be applied to a graphic object. Hint text is not attribute-specific.

1.

Double-click the graphic object to which you will provide hint text. This opens the Graphic Dynamic
Attributes dialog box.

On the right side of the Graphic Dynamic Attributes dialog box, click the Hint... button to open the Hint
Text dialog box.

Hint Text X

Enter Hint Text (80 chars. max)

Cancel

Enter the hint text. For example, you might enter, “To start the process, click the Start button.” Hint text is
limited to 80 characters.
To wrap text to the next line, add \r to the text. For example, if you enter the following text,

Boiler Door Open?\rYellow = Yes\rRed = No

Hint Text X

Enter Hint Text (80 chars. max)

Boiler Door Open?'ryellow = Yes\rRed = Nao | |

Cancel

The portions of text beginning with “Yellow”and “Red” will each wrap to the next line. In Runtime, the
Tooltips box in Runtime will appear like this:

Boiler Doar Open?
vellow = Yes
Red = Mo

Click OK to save the hint, and then click OK to close the dialog box.
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5. Next, in the PAC Display menu bar, click Configure > Runtime to open the Runtime Setup dialog box.
Then click the Control Engine tab.

Runtime Setup >

General Windows/Dialogs Cortrol Engine  Security 140 Unit Tags

Qff-line Control Engine Color Options

Last Known ¥ alue colar: - Comm. failure color: -

Enable graphic color change
Synchronize Control Engine Clocks to PC Clock
Every 7 daysat 2 00 Abd

[] Enable suto Synchronization [ Sunchronize at Runtime startup

Synchronize Control Engine “With

(®) Local Computer () Remate Computer |

Controller Driven Dynamic Attibutes
[ &llowe Runtime Toolips ] Shaw Hint Text Only

Read /wiite Timeoul

Timeout [sec.]

~ Check this box to display Hints in
Runtime

Ok Cancel Help

6. Select Allow Runtime Tooltips, and then click OK to close the dialog box and save the settings.
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For additional security features, see:

«  "Protecting a Project with a Password” on page 46 to assign a password to the PAC Display project to
prevent unauthorized users from opening it in PAC Display Configurator.

«  "Modifying Draw or URL Windows"on page 94 to assign a password to individual windows in a PAC
Display project to prevent unauthorized users from opening them.

«  "Runtime Setup: Security Tab”on page 297 to allow operator access to the HMI, as well as log all HMI use
and operator actions to an encrypted archive.

«  "Viewing Logged-In Users in Runtime”on page 325 to view a list of the users currently logged in to PAC
Display Runtime.

Your application requirements and the environment in which it is used may require strict control over access
to the operator interface you create in PAC Display. You can configure PAC Display to provide this level of
security by defining user authentication permissions for individual graphic objects.

When the PAC Display project is launched in PAC Display Runtime and an operator clicks a graphic object that
is configured for security, Runtime prompts the operator for a username and password. If the login
information is incorrect or if the operator is not permitted to use that object, an alert message is displayed. If
Runtime operator logging is active for the project, the login attempt (successful or not) is added to the
Runtime operator log.

Important Considerations for User- and Group-Level Security Settings

There are several important considerations to keep in mind when configuring user- and group-level
authentication for a graphic object.
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If you don't configure security (either Runtime user logins or security for a graphic object), anyone who
can log in to PAC Display can use a graphic object in Runtime.

[tisn't necessary to configure security if anyone in your company is allowed to use Runtime. But if that's
not the case, you should configure Runtime user logins (see page 301) to prevent unauthorized users
from accessing the graphic objects in your projects.

After you configure at least one Runtime user, Runtime displays a login screen each time a project is
loaded in Runtime.

By default, all operators have permission to use the graphic objects in a project. To prevent unauthorized
users from using a particular graphic object, configure security permissions for the object (see page 177).
Security permissions cannot be configured for the Send Discrete dynamic attribute when it is configured
as “Direct”or “Reverse.” See “Send Discrete”on page 153 for descriptions of these options.

When the project is running in Runtime and a restricted graphic object is clicked, “Deny Access” security
permissions have priority over “Grant Access” permissions. This means that if an operator has been
granted access, but is a member of a group that has been denied access, the operator will not be able to
use the on-screen object.

Configuring Security Permissions for Graphic Objects

NOTE: Security permissions are applied to all dynamic attributes selected before you click the Security button. If a
graphic object needs to have multiple dynamic attributes, make sure to select and configure all attributes before
configuring security settings.

To assign user- and group-based security permissions to a graphic object:

Double-click the graphic object to which you will assign one or more operator-driven dynamic attributes.

The Graphic Dynamic Attributes dialog box opens. Note that the Security button on the right side is not
active.

The Security button isn't active until you've configured
an operator-driven attribute

Graphic Dynamic Attributes *

Object: Round Rectangle X ¥: Width: Height: Hint... Security...

Control Engine Driven

PAC Display User's Guide 177



SECURITY SETTINGS FOR GRAPHIC OBJECTS AND DYNAMIC ATTRIBUTES

2. Configure an operator-driven attribute. When you click the attribute’s check box to save its configuration,
the Security button is enabled.

Graphic Dynamic Attributes *

Object: Round Rectangle X ¥ Width: Height: Hint...

Control Engine Driven Operator Driven: Execute Menu lfem
[ Line Colar - Menu ltem:
[ Fill Colar
[ visibility fBlink
0 rotate Alarms/Modiy A
Alarms/Priority Filter/100 &nd &b : . .
[ Horizontal Size (width) e Priorit Filor/200 fnd Abave After configuring one or more operator-driven
L] vertical Size (height) Alains Eriority Fier/ 300 And ahove dynamic attributes, click Security to configure user-
[ Harizontal Position Alarmz/Priority Filker/400 And Above . R . .
= gl ¥ | | Alams/Prioity Fiter/500 &nd Abave and group-level authentication for the graphic object.
< > Alarmz/Priority Filker/600 And Above
Alarmz/Priority Filker/700 And Above
Operator Driven Alarmz/Priority Filker/800 And Above
e Alarmz/Priority Filker/900 And Above
L @ send sting ~ | [BlamsPricrity Fier/41 Levels
O windows File/Change Printer...
[0 Download Redpe File/E xit PAL Dizplay Runtime
= File/Open Project...
E Upload ReuPe . File/Prit
Launch Application File/Printer Setup... e
[0  resdand Clear o
< >

Focus-frame enabled
Beep enabled

HotKey: []ctrl []shift |<None»

3. Click Security to configure user- and group-level authentication for the graphic object.
The Define Security Permissions dialog box opens.

Define Security Permissions Dialog Box

Define Security Permissions *

Select Uszer / Group

Darmair: Runtime Ueerz / Groups » LA
Users / Groups: Supervisors = — B
C Permiszions
| O Giantdccess () Deny Access
D——LShow Configured Users. . Cleardl - 1 E

F— Cancel Help

(A) Domain. To set permissions based on Windows authentication, select the Windows domain that
contains the operator (or group) to whom you want to grant or deny access. To select a custom-configured
user or user group, select Runtime Users / Groups.

(B) User/Groups. Select the user or group to whom you want to grant or deny access to the object.

(C) Permissions. For the selected user or group, select Grant Access or Deny Access.
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(D) Show Configured Users. Click Show Configured Users to view all permissions currently assigned for
the graphic object.

(E) Clear All. Click Clear All to erase all configured permissions for the graphic object.

(F) OK. Click OK to save changes, or click Cancel to close the dialog box without any changes being made.

Copying Security Permissions to Other Graphic Objects

To make security configuration easier and less error-prone, you can copy a graphic object’s security
permissions and then apply them to:

«  One or more selected graphic object
« Al graphic objects in a PAC Display window
« Al graphic objects in a project

To copy and apply security permissions:
1. Click the graphic object whose security permissions you want to copy.

(Sizing handles—the small black boxes around the graphic object—indicate that it has been selected.)
2. Copy the graphic object’s permissions. There are two ways you can do this:

- (lick the graphic object, and from the menu bar, click Edit > Security Permissions > Copy.

NOTE: This method is required when copying or applying permissions to Alarms, XY Plots, Trend, and
SuperTrends.

- Right-click the graphic object, and from the pop-up menu, click Security Permissions > Copy
Security Permissions > Copy.

NOTE: Ifthe Copy selection is grayed out, it means the graphic object you selected doesn't have configured
security permissions. First, you must configure permissions for the graphic object; then Copy will be enabled
when you select the object.

3. Select the graphic object to receive the copied security permissions.
- To select more than one graphic object, press and hold the Shift key while clicking the objects.

- Toselect all graphic objects in a window or all graphic objects in the project, click anywhere in the
window.

NOTE: In order to receive the copied permissions, the target graphic object must have at least one configured
operator-driven dynamic attribute.

PAC Display User's Guide 179



VIEWING TAGS AND DYNAMIC ATTRIBUTES

4. Right-click to display the pop-up submenu (or in the menu bar, click Edit > Security Permissions).

Cut

Copy
Paste
Delete
Duplicate

Replace...
Z-Order b

Align b

Size >
Group
Transparency...

Lock Position

Unlock Position

Dynamic Attributes

—  Select Paste to overwrite the target graphic objects’ existing security permissions.

- Select Merge to keep the target graphic objects’existing permissions and add the copied
permissions.]

The Security Attributes dialog box opens.

If you select Merge, the Merge Security Attributes

dialog box opens.

It has the same options as the Paste Security Attributes dialog
box.

Paste Security Attributes *

Paste Aftibutes To

®
(O This Window

O Al windows

I QK || Cancel || Help

5. Choose the target:
—  Chosen graphics—Selects only the currently selected graphic object (or objects).
- This Window—Selects all graphic objects in the current window.
- All windows—Selects all graphic objects in all windows in the project.

6. Click OK to save the settings and close the dialog box.
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As you develop or document a PAC Display project, it can be useful to know about the dynamic attributes and
tags used by the objects in the project’s windows.

"When permissions conflict—for example, when you paste a Grant Access permission to a graphic object that is
already configured with Deny Access for the same user (or user group)—PAC Display always applies the most
restrictive permission. In this example, the user (or group) would be denied access to the graphic object.
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Dynamic Attributes for Individual Objects

To view the dynamic attributes configured for an individual graphic object or a group of objects, select one or
more objects in a window, right-click the mouse, and click Dynamic Attributes > View from the pop-up
menu. The dynamic attributes assigned to that object or objects will be shown in the Dynamic Attributes
window.

Viewing Tags for One or More Objects

To view the tags that a particular object or objects is connected to, click the object (or group of objects), and
move the cursor over it. The tags used will be shown next to the cursor.

Dynamic Attributes for All Objects

To generate a report that lists the dynamic attributes for all objects in all project windows, as well as all the

alarm points configured for a project:

1. In PAC Display Configurator, click View > Dynamic Attributes.

2. Inthe dialog box that opens, select one or more windows whose dynamic attributes you want to view
and click OK.
The Microsoft Windows Notepad application opens and displays a report similar to the following
example:

Project Name: C:\Opto22\PAC
Display\Examples\ioCookies\Display\cfactory.uui

Window: Cookie Factory
Ak hkrkkhkhkhkhkkhkhkhkhhkkhhkkhxkk

GroupX = 530Y = 332W = 86H = 28

Operator-Driven Dynamic Attribute Tags

Send Value:

Cookie Control Engine:Conveyor Speed Control.Value
Refresh Group: Group 0

Source : Prompt for Data
Destination: Set
Message : Enter Conveyor Speed

Min. Value : 0.00
Max. Value : 100.00

GroupX = 133Y = 213W = 21H = 3

control engine-Driven Dynamic Attribute Tags
Visibility/Blink:
Cookie Control Engine:Dough Dispense Valve.State
Refresh Group: Group 0

Setup By : Discrete

On : Invisible

Off : Visible

Using the TaginfoView Utility Program

After you have selected View > Dynamic Attributes, you can use a small utility program called TagInfoView to
sort and view the tag information in greater detail.

1. Click View > Launch TagInfoView Utility.
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2. IntheTag Information Viewer dialog box that opens, verify that the TagInfo.txt file appears in the file field

at the top.

Browse for Taglnfod.tat file

& Tag Information Viewer 3.0

| B azic ExampleshDisplayhioCookiesh T aglnfo. t:-:t| [ Browse. . i

2] Select First and Second Sort Criteria, then click "'Display Results”

First Sort By: Then By:
(®) Tag Mame () Tag Mame
() Window (®) Window
() Refresh Group () Refresh Group

Display Results

Close

3. Inthe Sort By sections, select how you want the tag information sorted.
4. C(lick Display Results. The results should look something like this:

| Tag-Window-Sort.tit - Notepad - [m} *

File Edit Format View Help

hag HName Window Name Refresh al

Group Tag Type

:bStartFlag Cookie Factory Group B
Integer (Integer)

========== This Tag used in 1 windows

PAC Sim:Alarms:Alarms Cookie Factory Group B
Chart (NULL)
========== This Tag used in 1 windows

PAC 5im:Start_Flag Cookie Factory Group B
Integer (Integer)
========== This Tag used in 1 windows

PAC Sim:bChipDispenseValve, ; P e, Coekis Factory . Grour @

SCANNING TO UPDATE GRAPHIC OBJECTS

As you configure your project and connect PAC Control tags to PAC Display graphic objects, you are setting up
the connections that will animate your objects in PAC Display Runtime as the tag data changes. PAC Display
acquires this tag data using an internal scanner that monitors one or more control engines. Understanding
how the scanner works and how it gets its data will help you optimize your system’s performance.

Scanning is PAC Display’s process of requesting data about I/0 points and variables from the Opto 22 control
engine. When the control engine receives this request, it must first determine if its data for the requested tags
is current. If the data is not current, the control engine will access the I/0 units connected to it and request the
latest readings. This tag information is then sent back to PAC Display. Depending on the data and how it is
connected to objects in your PAC Display project, graphic objects then change their attributes.
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Refresh Time Groups

Each tag connected to a PAC Display graphic object belongs to a refresh time group that determines how
often the tag is scanned. You define the characteristics of refresh time groups by setting a scan rate. See
“Configuring Scan Rates” (below) to learn how to set these values.

System performance is affected by how a refresh time group is set up, so it's important to define refresh time
groups carefully. Follow these guidelines when configuring refresh time groups for your project:

o Select scan rates that reflect the rate at which the process variables change. For example, the outside air
temperature changes slowly, and could be scanned every 15 minutes or so.

« Asagood engineering practice, select the slowest possible scan rate that is acceptable for your
application. This will help prevent the system from being overloaded by needlessly scanning too much
information too quickly.

« Ifthe amount of data being scanned is too much for the selected scan rate, decrease the scan rate to
better match what the actual throughput will allow.

If you have tried the preceding guidelines and scanning speed does not improve, then there may be too
much data being requested from one control engine, or there may be too much data being scanned by
one computer, or both. To eliminate the bottlenecks, you may need to add more control engines, divide
the PAC Display projects over multiple computers, or both.

Configuring Scan Rates

You assign refresh time groups whenever you configure a tag based on how often you think it makes sense to
update the tag. (Note that the same refresh time group is usually used by several tags.) For example, an analog
point reading an outside temperature would use a longer scan rate since the temperature isn't likely to
change suddenly. On the other hand, a digital point that's monitoring the on/off state of a valve would need a
shorter scan rate to accurately reflect whether a valve is open or closed.

To configure scan rates, click Configure > Refresh Times. The Refresh Times dialog box appears.

Refresh Times Dialog Box

Refresh Times X

AL Groups 0-6  Groups 7-13

B Marne can Fate

c Walue LIriits
|m | | 1 | Seconds w
[Group 1 || 20| |Milisecands ~
|Group 2 | | 1 | Seconds w~
|Group 3 | | 1 | Seconds ~
|Group 4 | | 1 | Seconds w
|Group 5 | | 1 | Seconds ~
|Group B | | 1 | Seconds ~

D i 0K | Cancel Help
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(A) Group Tabs. Up to fourteen refresh time groups are available, divided between two tabs in the Refresh
Times dialog box.

(B) Name. In the Name column, you will see the refresh time group names. By default, their names are
“Group 0", “Group 1", and on up to “Group 6" You can change these default names if you wish.

Names can be up to 15 characters long, but avoid using the exclamation point (!) and vertical bar ()
characters in the name. Spaces are also valid characters, but when referencing names with spaces, don't omit
the spaces or substitute the underscore ( _ ) character for spaces.

(C) Scan Rate. In the Value field of the Scan Rate column, enter a number from 1 to 9999. In the Units field,
select a unit of time from the Units drop-down list. (Unit options are milliseconds, seconds, minutes, hours,
days, and months.)

The greater the value, the more time between I/0 readings and the fewer times the control engine is scanned.

(D) OK. Click OK to save your settings.

Improving Data Throughput For PAC Display

When using PAC Display on a system with Ethernet I/O Units, the default configuration is for PAC Display to
scan /0 tags directly from the I/O units and only scan strategy tags (variables and tables) from the control
engine. This default configuration provides the best overall throughput. It is possible to change the
configuration to scan all tag types, including I/0 tags, through the control engine, however this reduces
overall throughput.

To optimize data throughput for PAC Display, do the following:

» Identify and correct any configuration issues. In PAC Display Configurator, open the project and choose
Configure > AutoCorrect Tags. Correct any discrepancies that are identified.

«  Use the default PAC Display option of scanning Ethernet I/0 unit tags directly from the I/0O units. This
requires an Ethernet network configuration where the I/0 units are accessible by the PAC Display
computer. This can be configured by viewing
Configure > Runtime > 1/0 Unit Tags.

«  Keepl/O tags in refresh groups that are separate from PAC Control strategy tags. Group strategy variable
and table tags into refresh groups that do not have I/0 tags.

«  Use reasonable Refresh Group time intervals.

o For Serial I/0 units, the most efficient method is to use /0O Unit commands (instead of individual I/0
point commands) in strategy logic to move serial /0 unit tags into tables. Then scan the data from the
tables instead of scanning I/0 points directly. If you must scan serial 1/0 tags directly, you should keep this
to a minimum because serial I/0 tags must be scanned through the control engine. In addition, only one
command can be active on a serial port at a time. If a host scans serial I/O information through the
control engine, it causes the controller to have to scan all of the appropriate serial /O units at that time,
and it can only reply to the host after getting the responses from all appropriate I/0 units.

For more optimization tips, see the Optimizing PAC Project System Performance technical note (form 1776).
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8: Working with Trends

INTRODUCTION

This chapter describes how you can create and configure graphs that display real-time and historical
information about selected I/0 points.

InThis Chapter

About Trends page 185
Types of Trends page 185
Working with Basic Trends page 186
Working with SuperTrends page 190
SuperTrend Historical Log Files page 200
Using XY Plots page 210

ABOUT TRENDS

PAC Display trends are objects that visually plot control engine values, including I/0O points and results of a
calculation. Using a trend, you can show how real-time and historical data changes over time, or how one set
of data relates to another one. In PAC Display Runtime, trends are created when active I/O point values, or tags,
are read from a PAC Control strategy running on a control engine and visually plotted.

Tag values are graphed on a two-dimensional x-axis and y-axis coordinate system. Depending on the type of
trend used, the x-axis can represent time or a set of tag values. The y-axis can represent either the range of
values for a tag or a set of tag values. You can set features for each trend line used, and there is no limit to the
number of trends that can be displayed in a window. For trends that graph data over time, the maximum time
span supported is 14 days.

You can easily set or modify the following elements in a trend:

«  x-and y-axis ranges and the major and minor divisions that appear on the graph
«  Graph backgrounds and border colors

«  Pen colors for trend lines

«  Tag value scanning, which can be turned on or off for a specific trend.

TYPES OF TRENDS

There are three types of trends that you can use in a PAC Display project: basic trends, SuperTrends, and XY
plots. Basic trends and SuperTrends display tag values as trend lines plotted over time; XY plots graph data
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from two numeric tables, using data from one table for x-axis values and data from the other table for y-axis
values.

«  Basic Trends—Using a basic trend, up to four trend lines can be displayed on a graph. Basic trends can
plot only real-time data (not historical data). For details, see “Working with Basic Trends” (below).

«  SuperTrends—Using a SuperTrend, up to 16 trend lines can be displayed on a graph. SuperTrends can
plot both real-time and historical data. For details, see “Working with SuperTrends”on page 190.

« XY Plots—Using an XY plot, up to six individual trend lines can be displayed on a graph. XY plots can
plot only data in numeric tables. For details, see “Using XY Plots”on page 210.

WORKING WITH BASIC TRENDS

You use basic trends to plot real-time values for up to four tags.

Creating a Basic Trend

1. Select the basic trend tool from the toolbox and position the cursor where you want the trend to
begin in the window.

2. (lick the mouse button, drag the mouse to the desired size, and then release the mouse button.
The trend that appears should resemble the example below:

Trend Example

100

a0

Y-axis Layout

-Label Position = Left 80
-Label Range:

- Max Val =100 —
-MinVal=0 0

-Minor Divisions = 4
-Major Divisions =5
-Label Intervals = 1 }_

o X-axis Layout
MSE HHMAAES HHMAAES HHMAAES HH:h ) AR
L& .Minor Divisions = 2
| -Major Divisions = 4
| -Label Intervals =2

| Label Position = Bottom
Label Format = Hours, Minutes, and Seconds

Modifying a Basic Trend

Choose the Select tool and double-click the trend to open the Trend Configuration dialog box.
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Trend Configuration Dialog Box

Trend Configuration E|
A+ Marne: |
B
Timne Spar: |EU | | Seconds w | —_— E
Fen 2.
Refresh Time: | Group 011 zec] - | ——F
C N
Chart Color: l:l Border Colar: _ Dizable Trend: | Never b | G
D
H-awiz Lagpout T-awiz Lagpout
Calar Calar
H{ MHumber of Majar Divizsions: MHumber of Majar Divizions: —-—— M

I
| —— Mumber of Minor Divisions: - MHumber of Minor Divisions: —-—— N
- Label Interval in b aj Div.: —-—— 0
K —— Latel Pasitior: Label Paozitian: —P

L ——— Label Format: [#] Hours [#] Minutes [#] Seconds Label Range: Min Val EI Mau Val —4—Q

J —— Label Interval in Major Div.:

R——F QK H Cancel ” Help ]

(A) Name. Enter the name of the trend here.

(B) Pen Configuration Buttons. Use these pen configuration buttons to associate each pen with one PAC
Control tag, to define its pen color and width, and to specify a range of values for the tag. You can configure up
to four pens per trend. See “Optimizing Pen Settings”on page 190 for more information.

(C) Chart Color. Click here to select a background color for the trend graph. In the Color dialog box that
appears, choose a color and click OK.

(D) Border Color. Click here to enter the graph’s border color. In the Color dialog box that appears, choose a
color and click OK.

(E) Time Span. Enter the time span the trend represents. (Remember that the time span is indicated on the
x-axis). Choose the time units from the drop-down list. Your choices are seconds, minutes, or hours. The
maximum time span is 14 days, or 336 hours.

(F) Refresh Time. Select one of fourteen refresh time groups. The scan rate appears in parentheses
alongside the refresh group number. All tags associated with the pens in B are scanned at the same rate.

You can find out more about refresh times in “Scanning to Update Graphic Objects”on page 182. Also see
“Optimizing Pen Settings”on page 190 to learn how pen settings affect how PAC Display communicates with
a control engine.

(G) Disable Trend. Choose whether to disable a trend based on the state of its window. If you disable the
trend, the tags associated with the pens in B won't be updated with new data from the PAC Control strategy
until the trend is enabled again. Disabling a trend saves the control engine processing time, since it doesn’t
have to respond to regular requests from PAC Display for tag updates.

NOTE: Trends that are enabled are always updated, regardless of the window's visual state (normal, iconified, etc.).
This means PAC Display continually requests data from the control engine to update its trends. Keep this in mind
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when you're considering the number of enabled trends you are including in the project. The more enabled trends you
have, the more the control engine has to spend time reading its I/O to update the data.

(H) Number of Major Divisions (X Axis). Enter the number of major x-axis divisions for the trend. This is
the number of main sections the trend is divided into. You can also choose a color for the major divisions by
clicking the Color field. In the Color dialog box that appears, choose a color and click OK.

NOTE: For both x- and y-axis divisions, the lines dividing the major divisions appear thicker than the minor divisions.

(1) Number of Minor Divisions (X Axis). Enter the number of minor x-axis divisions for the trend. This
will be the number of sections the major divisions are divided into. The minimum number of divisions is one.

You can also choose a color for the minor x-axis divisions by clicking the Color field. In the Color dialog box
that appears, choose a color and click OK.

(J) Label Interval in Major Divisions (X Axis). Enter how often you want the major x-axis labeled.

NOTE: For both x- and y-axis labels, if you enter 1, every major division is labeled; if you enter 2, every other major
division is labeled.

(K) Label Position (X Axis). Choose the label position for the x-axis. By default, the x-axis is labeled at the
bottom, but you can choose to label the top, top and bottom, or have no labeling at all.

(L) Label Format (X Axis). Enter the label format by checking off any combination of hours, minutes, and
seconds. The label appears in the following format: HH:MM:SS, where HH is hours, MM is minutes, and SS is
seconds.

(M) Number of Major Divisions (Y Axis). Enter the number of major y-axis divisions for the trend. This is
the number of main sections the trend is divided into. You can also choose a color for the major divisions by
clicking the Color field. In the dialog box that appears, choose a color and click OK.

(N) Number of Minor Divisions (Y Axis). Enter the number of minor y-axis divisions for the trend. This
will be the number of sections the major divisions are divided into. The minimum number of divisions is one.

You can also choose a color for the minor y-axis divisions by clicking the Color field. In the Color dialog box
that appears, choose a color and click OK.

(O) Label Interval in Major Divisions (Y Axis). Enter how often you want the major y-axis labeled.

(P) Label Position (Y Axis). Choose the label position for the y-axis. If you choose Left, Right, or Left and
Right, only pens that fall within the minimum and maximum values of the Label Range are displayed; pen
data outside the range is not displayed.
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However, if you choose None, no labels are shown on the y-axis, multiple ranges appear to overlap, and all
pens are displayed. As shown in the following example, if pen A has a range of 0-100 and pen B has a range of
300-400, the y-axis has a range of 0-100 and 300-400 simultaneously and both pens are displayed.

Trend Example

100

30

62
G0
T
Pen 1
40
—
Pen 2
20 7
/
305
IJIu1:SS HH:W:55 HH:W:55 HH:W:55 HH:h

(Q) Label Range (Y Axis). Enter the minimum and maximum values for the y-axis.

(R) OK. Click OK to save your settings.

Configuring Basic Trend Pens

Click a pen configuration button in the Trend Configuration dialog box to open the Trend Pen Configuration
dialog box.

Trend Pen Configuration Dialog Box

Trend Pen #1 Configuration

F_

Tag

Mame:

=

b &xirnurn ' alue: I:I
bimirum Y alue: I:I

Pen Calar: -

Pen\width: |1

_[_

OK

][ Cancel ][

Help

]

(A) Name. Enter a PAC Control tagname here by clicking the Tag Selection Button (B).

(B) Tag Selection Button. To enter a tagname in A, click here. The Tag Selection dialog box is displayed so
you can select a tag. See “Configuring Tags” on page 74 to learn more about configuring tags in your project.

(C) Maximum/Minimum Value. Enter the maximum and minimum value the tag selected in A can be.
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(D) Pen Color. Click here to choose a pen color. In the Color dialog box that appears, choose a color and
click OK.

E) Pen Width. Enter the width of the line you want created by the pen. The width is specified in pixels.

(F) OK. Click OK to save your settings.

Optimizing Pen Settings

The scan rates you select when configuring a pen can impact the speed and performance of your PAC Display
project and the control engine. When selecting scan rates for long trends, you should choose optimal scan
times for the pens as follows:
1. Determine the trend width in pixels by using the X: value in the Coordinates window.
First, subtract the X: value of the left trend border from the X: value of the right trend border. Then divide
the trend width in seconds by the trend width in pixels.
For example, an eight-hour trend that is 500 pixels wide yields a number of 57.6 seconds (8 x 3600/500).
2. Round this to the nearest increment of 10.

In the example, the value would be rounded up to 60 seconds. This means that for optimum PAC Display
performance, the trend should not be updated more frequently than every 60 seconds.

NOTE: A small compromise to increase the accuracy of the trend is to divide the result by four. In our example,
this would result in a scan time of every 15 seconds. Using a 15-second scan time allows a maximum of four
readings per pixel on the trend. Updating any faster than that is counterproductive; the excess data is discarded,
and the extra requests for data from the control engine add overhead to the control system.
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SuperTrends are trends that can track both real-time and historical data. You can also use up to 16 pens with a
SuperTrend; basic trends support only four pens. SuperTrends are drawn and configured in PAC Display
Configurator, like any other on-screen object, but the graphs can also be manipulated by the operator in PAC
Display Runtime. See “Using Runtime” on page 320 to learn how to use SuperTrend options in Runtime.

“Memory Requirements for SuperTrend Pens” (below)
“Creating a SuperTrend”on page 191

“Configuring SuperTrend Setup Parameters”on page 191
“Configuring X-Axis Parameters”on page 193
“Configuring Y-Axis Parameters”on page 194
“Configuring Zoom Parameters” on page 196
“Configuring Hot Keys” on page 196

“Configuring SuperTrend Pens”on page 197

“Setting an Individual Pen”on page 199

Memory Requirements for SuperTrend Pens

When several SuperTrends—each using several pens—are used in a PAC Display project, the
memory requirements for the PC running the project can become very high. Keep this in mind when
developing your PAC Display project. Use the following formula to determine the amount of RAM required for
each penin a SuperTrend:

19.2 X SuperTrend’s x-axis time span (sec.)

RAM required per pen (bytes) =
SuperTrend’s scan rate (sec.)
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For example, the memory required for each pen in a SuperTrend having a six-hour scan time (21,600 sec.) and
a 500 ms scan rate (0.5 sec.) would be calculated as follows:

19.2 X 21600 sec.
0.5 sec.

= 829,400 bytes

This is approximately 800 KB for each pen. If this example SuperTrend contains five pens, it would use
approximately 4,000 KB of RAM, or just under 4 MB.

Each time you configure a SuperTrend, the approximate amount of RAM required for that object is displayed.

Creating a SuperTrend

1. Select the SuperTrend tool E from the toolbox and position the cursor where you want the trend to
begin in the window.

2. (lickthe mouse button, drag the mouse to the desired size, and then release the mouse button.
The SuperTrend appears.

SuperTrend

o
107 01/

If you do not draw the SuperTrend wide enough, some of the command buttons are placed in a second
row.

Configuring SuperTrend Setup Parameters

To configure a SuperTrend, choose the Select tool, and then double-click the SuperTrend.
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SuperTrend Setup Dialog Box, Setup Tab

SuperTrend Setup @
Setup | Xads | Y-ads | Zoom | Hot Keys | Pens 1-8 | Pens 316
A Trend Type Historical Setup Size / Pogition B
) Real-Time Computer Saving Data to File: . e
C T Histoncal Local computer )
A 453
D Log Te...
— {_LogTo. | Wl
Background: Lt H: 237
] @ TextFile () Binary File F
G Fiefresh Time: [Gr.:.up 01 sec] v]
H Dizable Scanning: ’Never vl
I — oK || Cancel || Hep |

(A) Trend Type. Select Real-Time to configure the selected SuperTrend graph to display real-time data in
Runtime; select Historical to display SuperTrend historical data. When a Runtime operator clicks a SuperTrend
historical graph, Runtime prompts the operator for the historical log file that contains the data to display. If you
select Combined, you can configure one SuperTrend graph that allows the Runtime operator to switch
between real-time and historical trending when the project is running.

(B) Size / Position. Enter the X and Y coordinates to position the SuperTrend. To change the size, enter the
width in pixels (W) or height (H).

(C) Computer Saving Data to File. This read-only field displays the computer that is configured to
collect and process data for SuperTrend historical log files. “Local Computer’—the default value—means that
the computer running PAC Display Runtime will collect and process the SuperTrend data. Any other value in
this field means that one specific PAC Display Runtime computer (sometimes called the “remote computer”)
has been configured to process the data.

IMPORTANT: In a system with multiple nodes of PAC Display Runtime, Opto 22 recommends designating a remote
computerto handle SuperTrend historical data logging. This way, only the remote computer will be writing to the log
file, and this avoids file access issues when more than one computer is configured to write to the same destination.
For details, see “SuperTrend Logging” on page 200.

Note that the location where the files are saved is configured in the Historical Log File Configuration dialog
box. For details, see “Configuring SuperTrend Log Files”on page 202.

(D)Log To. Allows you to log to afile or to a database.

- LogFile
Displays the Historical Log File Configuration Dialog Box. (See “Defining the Historical Data Log File”
on page 221.) In this dialog box, you can specify file parameters such as the rollover period and the
amount of data to buffer in memory. For details, see “SuperTrend Historical Log File Names”on
page 202.

- (PAC Display Professional only) Log to Database
Displays the Database Table dialog box that allows you to configure a table for logging SuperTrend
data. For details, see “Saving a SuperTrend to a Database”on page 208.
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(E) Color. Click here to select a background color for the SuperTrend graph. In the Color dialog box that
appears, choose a color and click OK.

(F) Text File/Binary File. Select whether the SuperTrend historical log will be saved to a file in text or
binary format. When the SuperTrend data is saved in ASCII text format, the data in the file is human-readable,
and the file includes a header that contains information about tags assigned to the SuperTrend pens. When
the data is saved in binary format, the data in the file is not human-readable, and the file does not include a
header.

NOTE: Trend data from a binary file usually plots more quickly than trend data from a text file.

If there are existing data files for a SuperTrend and you reconfigure the SuperTrend to switch the file format
between text and binary, the Select Log File To Convert To dialog box appears. In this dialog box, you can
select a log file to convert to the appropriate format. See page 205 to learn more about switching between
text and binary file formats.

(G) Refresh Time. Choose one of fourteen refresh time groups. The scan rate appears in parentheses
alongside the refresh group number. You can find out more about refresh times in “Scanning to Update
Graphic Objects”on page 182. All tags associated with the pens in this trend are scanned at the same rate.

(H) Disable Scanning. Choose whether to disable a trend based on its window's state. If you disable the
trend, the tags associated with the pens won't be updated with new data from the PAC Control strategy until
the trend is enabled again. Disabling a trend saves processing time since the control engine doesn't have to
respond to regular requests for tag updates from PAC Display.

The trend retains its recorded data at the time the trend was disabled.
«  Never:The trend is never disabled. It always collects data.

«  When Window Closed: The trend stops scanning when its window is closed. It starts scanning again
when the window is restored.

+  When Window Minimized: The trend stops scanning when its window is minimized. It starts scanning
again when the window is restored.

(1) OK. Click OK to save your settings.

Configuring X-Axis Parameters

Click the X-axis tab to configure x-axis parameters for the SuperTrend.
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SuperTrend Setup Dialog Box, X-axis Tab

SuperTrend Setup fg|
Satup | Heavis |Y-a:<is Zoom | Hot Keps | Pens 1-8 | Pens 9-16
Grid
A Tirme Span: |5 | |Minutes V|
B Majar divisions: |1 ||Minutes V|
Cc tinor divisions: EI
D Colors
t ajor divisions: -
tinar divisions: -
Labels: I:I
E { ak. ” Cancel ]l Help |

(A) Time Span. Enter the time span (x-axis) the trend represents. Choose the time units from the drop-down
list. Your choices are seconds, minutes, hours, and days. The maximum time span is 49 days, or 1,176 hours.

(B) Major Divisions. Enter the number of major x-axis divisions for the trend. The trend will be divided into
this number of main sections. You can choose a color for the main section dividers in Colors (D). The lines
dividing the main sections will appear thicker than the lines dividing the minor sections.

(C) Minor Divisions. Enter the number of minor x-axis divisions for the trend. The major sections will be
divided into this number of minor sections. The minimum number of divisions is one. You can choose a color
for the minor section dividers in Colors (D).

(D) Colors. Click on the boxes to set the colors for the major divisions, minor divisions, and labels. In the
Color dialog box that appears for each item, choose a color and click OK.

(E) OK. Click OK to save your settings.

Configuring Y-Axis Parameters

Click the Y-axis tab to configure y-axis parameters for the SuperTrend.
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SuperTrend Setup @
Setup | X-mds | Y-ais | Zoom | Hot Keys | Pens 1-8 | Pens 916

Grid Scale
A Major divisions: Scaling: ) Default @ Pen C
B Minor divizions: 4 100
D L | abel Mumeric Format ] s

L [ Logarithrmic
E Calors

Major divisions: @ Color - () Active Pen Color

Minar divisions: @) Color - () Active Pen Color

Labels: @ Calar I:I (7) Active Pen Colar
F [ oKk || Cancel || Hep |

(A) Major Divisions (Grid). Enter the number of major y-axis divisions for the trend.

(B) Minor Divisions (Grid). Enter the number of minor y-axis divisions for the trend.

(C) Scale. Click here to select the scaling.

- Ifyou choose Default, the trend will always have the same fixed scale. You must enter values for the
Default Max. Value and Default Min. Value. These values specify the range of pen tag values. This
scaling is static and cannot be changed in Runtime.

- Ifyou choose Pen, the trend will have the scale of the active pen.

NOTE: To see all pens scaled the same in Runtime when using Pen scaling, see “Using SuperTrends in Runtime”

on page 333.

- Ifyouselect the Logarithmic check box, the trend will have a logarithmic y-axis based on the scale of
the active pen. The logarithmic y-axis is determined by rounding down the minimum pen value to
the next lowest factor of ten, and rounding up the maximum pen value to the next greatest factor of
ten. For example, if a pen’s range has a minimum value of 500 and a maximum value of 8500, the
y-axis will have a minimum value of 100 and a maximum value of 10,000.

(D) Label Numeric Format. Click this button to open the Y-Axis Numeric Format dialog.

SuperTrend ¥-Axis Numeric Format

Dizplay ¥-Auis Labels as:

@ Decirmnal
[T] Exponential if Greater Thar:
[7] Exponential if Less Than:

() Exponential Drly

Mumber of Decimal Places:

X

1000.000
-1000.000

(]9 H Cancel H
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Fill in the options as you like for displaying the Y-axis labels. Y-axis values can be shown in decimal or
exponent form, or a mixture of both.

(E) Colors. Click on the boxes to set the colors for the major divisions, minor divisions, and labels in the trend.
If you want the y-axis to use the color of the pen that's currently active, select Active Pen Color.

In the Color dialog box that appears for each item, choose a color and click OK.

(F) OK. Click OK to save your settings.

Configuring Zoom Parameters

When a SuperTrend is in historical mode, the operator can zoom in to view a more detailed section of the
trend, or zoom out to view a less detailed section of the trend. Click the Zoom tab to set magnification levels.
The Zoom page, shown below, configures the zoom levels by defining scales for the x-axis.

SuperTrend Setup Dialog Box, Zoom Tab

SuperTrend Setup g|
Setup | H-axiz | r-axis | Zoam |H0t Keys | Penz 1-8 || Pens 9-16
Histarical Time-5pan Zoom
Zoom In Zoom Out
A Time Spar: |3U ||Seconds Vl |3U ||Minutes Vl
B M ajor division: |1D ||Seconds vl |1D ||Minutes vl
C kinor divisions:
D [ Ok, ] l Cancel l [ Hep |

(A) Time. Enter the amount of time to display on the trend while in zoom in/zoom out mode. Unit choices,
selected from the dropdown box, are seconds, minutes, hours, or days.

(B) Major Divisions. Enter the amount of time that constitutes one major division while in zoom in/zoom
out mode. Unit choices, selected from the dropdown box, are seconds, minutes, hours, or days.

(C) Minor Divisions. Enter the number of minor divisions per major division while in zoom in/zoom out
mode. This number must be 1 or greater.

(D) OK. Click OK to save your settings.

Configuring Hot Keys

All of the buttons that appear at the bottom of a SuperTrend can be associated with a combination of
keystrokes called a hot key. Hot keys allow the Runtime operator to use the SuperTrend without needing a
mouse. If a button has a hot key configured, the operator can either click the button or press the hot key
combination.

NOTE: If a command is available only in historical mode, its associated hot key will work only in historical mode.
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To configure hot keys, click the Hot Keys tab.

SuperTrend Setup Dialog Box, Hot Keys Tab

SuperTrend Setup

()

Setup | H-axiz | -adiz | Zoom | Hot Keps |F'ens1-8 Fenz 8-16

A LCommands Hat Fey
Zoom n Madifiers: [ ]Chl ] Shit B
Zoom Mormal
%oom Eut Kew: <MNones ~ c
oom Pen
Select Pen

Higtorical Mode
Real-Time Mode

Log - Begining

Log - Back Screen
Log - Back

Log - Farward

Log - Forward Screen

ok J[ cancel |[ Hep |

(A) Commandes. This field displays the Runtime commands that may be associated with a hot key. Highlight
a command to configure a hot key for it, or to view the existing hot key settings.

(B) Modifiers. Check the box labeled Ctrl if you want the Ctrl key to be part of the hot key. Check the box
labeled Shift if you want the Shift key to be part of the hot key. You may select none, one, or both.

(C) Key. This drop-down box lists all available keys that can be hot keys. Make sure not to assign the same hot
key to more than one SuperTrend command.

(D) OK. Click OK to save your settings.

Configuring SuperTrend Pens

Unlike a basic trend, a SuperTrend can plot trend lines for up to 16 tag values (pens). Pens 1 through 8 are
configured on the “Pens 1-8"tab shown below. Pens 9 through 16 are configured identically on the “Pens
9-16"tab. There is one row for each pen.
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SuperTrend Setup Dialog Box, Pens 1-8 Tab

SuperTrend Setup g|
| Setup | ¥-awis | -asis | Zoom | Hot Keys:.| Pens 1-8 |-F'ens 9-1Ei C
é | | ||ﬁ[ Modify ] [ L,IEEII\]\\\D
CIPenz | [] (Madiy.. ] [(Clear E
[JPenz: | |D[ b odify... ] [ Clear ]
[JPen 4 | |D[ b odify... ] [ Clear ]
[[]Pens: | |D[ Modify.. | [ Clear |
[(]PenE: | |D[ Maodify... ] [ Clear ]
CIPenz: | |[] (Hodiy... ] [(Ciear ]
[JPensg: | |D[ b odify... ] [ Clear ]
F |[ Ok ] l Cancel l [ Help ]

(A) Pen #. Check this box to enable the pen in this row (or uncheck the box to disable the pen). The pen is
enabled automatically when it is first created.

(B) Name. Once a pen is configured, its name appears here.
(C) Color. Click here to select the pen color. In the Color dialog box that appears, choose a color and click OK.

(D) Modify. Click here to configure a pen or to modify its configuration. The SuperTrend Pen # configuration
dialog box appears. Configure the pen and click OK. The pen name will be listed in B.

(E) Clear. Click here to clear the pen configuration.

(F) OK. Click OK to save your settings.
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Setting an Individual Pen

In the SuperTrend Setup dialog box, click the Modify button for a pen to open the SuperTrend Pen dialog box.
(The number of the pen to be configured is shown in the title bar.)

SuperTrend Pen 1 §|
A—t Mame: | |
B — Tag: | | e c
Range Line Point marker

D 1 MaxWalue: Calar: l:l [] Enabled
[ | sz G

[readband [for logging only] Runtime Options H
(%) No Deadband [] Cannot Disable
I — () Enable Discrete Deadband

(") Enable Value Deadband:  alue: l:l
J ——— Forze Logging Every l:|

K _—f ak. l ’ Cancel ] ’ Help ]

(A) Name. Enter a SuperTrend pen name, if desired. By default, when a tag is selected in B, the name will be
the same as the tagname. In Runtime, this name is displayed in the SuperTrend’s Active Pen drop-down list.

(B) Tag. Enter a PAC Control tagname here by clicking the Tag Selection button in C.

(C) Tag Selection Button. To enter a tagname in B, click here and select a tag in the Tag Selection dialog
box that appears. See “Configuring Tags”on page 74 for more information about selecting and configuring
tags.

(D) Range. These fields configure the range of displayed data points:
- The Max Value, or maximum value, is the tag value that will position the pen at the top of the trend.
If a scanned value of the tag is greater than the Max Value, the point will be plotted but will not be
visible on the trend.

When graphing integers, the Max Value must be a multiple of the y-axis major divisions, otherwise
there will be rounding errors. For example, if the y-axis major divisions is 7, the Max Value might be
21 (3x7),49 (7x7), or 84 (12x7). The y-axis major divisions is set on the Y-axis tab. See “Configuring
Y-Axis Parameters”on page 194.

- The Min Value, or minimum value, is the tag value that will position the pen at the bottom of the
trend. If a scanned value of the tag is less than the Min Value, the point will be plotted but will not
be visible on the trend.

(E) Line. Click in the box next to Color to choose a pen color. In the Color dialog box that appears, choose a
color and click OK. Enter the width of the line you want created by the pen. The width is specified in pixels.

(F) Point Marker Enabled. Click here to have point markers displayed for every scanned point. Point
markers make it easy to identify scanned data. In historical mode, you can click on a scanned point to display
its data (value, time scanned, etc.).

(G) Point Marker Size. Choose a point marker width, which is measured in pixels.

(H) Runtime Options. Select Cannot Disable to prevent the pen from being manually disabled in Runtime.

PAC Display User's Guide 199



SUPERTREND HISTORICAL LOG FILES

(1) Deadband. If a SuperTrend's Trend Type is set to Combined on the Setup tab of the SuperTrend Setup
dialog box, use Deadband to produce smaller, more manageable log files. Without deadbanding, a combined
SuperTrend writes point data to a log file even when the data does not change. The resulting log file might
contain many hundreds or even thousands of identical entries.

No Deadband: Choose this option if you do not want deadbanding.

Enable Discrete Deadband: Logging occurs only when the specified discrete value toggles either a tag's on or
off state, or the bit in an integer.

NOTE: Use Enable Discrete Deadband only for discrete values. PAC Display actually uses a value of 0.5 for the
deadband amount. If a floating point value is being trended, and Enable Discrete Deadband is selected, unexpected
results may occur.

Enable Value Deadband: Logging occurs only at the specified refresh time if the newly plotted point value
exceeds the previous point by more than this value. Only positive values are accepted.

(J) Force Logging. When deadbanding is enabled, use this option to force a log file entry to be generated
even if the value for the pen has not exceeded the specified deadband amount. This is useful for logging
values that rarely change more than the deadband amount, but you need verification that logging occurred
over a set time span.

Enter a positive whole number, and select either Minutes or Hours.

(K) OK. Click OK to save your settings.

SUPERTREND HISTORICAL LOG FILES

NOTE: In PAC Display Professional, data can also be logged to a database. For details, see page 208.

Runtime operators use the buttons and controls on a SuperTrend graph to open and view SuperTrend
historical log files. (For details, see page 333.) Tag data from SuperTrend graphs can also be saved to historical
log files for later viewing and analysis.

SuperTrend historical log files are similar to historical data log files; the major difference is that SuperTrend
historical log files also contain the additional pen information that a SuperTrend collects.

This section shows how to configure options for creating and saving SuperTrend historical log files.

SuperTrend Logging

When you run a PAC Display project on more than one Runtime computer, all of the Runtime computers can

plot and display trend data in SuperTrend graphs. As data is received, a date/time stamp is recorded, and the

date/time stamp and data are buffered in the computer's memory until they reach the configured buffer-size
limit. When the limit is reached, the buffer contents are written to a SuperTrend historical log file. (To select the
location where the log files are saved, see “Configuring SuperTrend Log Files”on page 202.)

You can configure whether each individual Runtime computer performs the work to process the data for
SuperTrend historical log files, or if just one of them does all the work.

IMPORTANT: In a system with multiple nodes of PAC Display Runtime, Opto 22 recommends designating a remote
computer to handle SuperTrend historical data logging. This way, only this one computer will be writing to the log
file, and this avoids file access issues when more than one computer is configured to write to the same destination.
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«  Configure a remote computer for Super Trend logging.
«  Copy the project to Runtime computers.

SuperTrend Logging

Which Runtime Made Wil Lag Data? «  The remote computer must also run the project to collect and
() Runtime on This Computer process the data.
(®)iRuntime on a Differsnt Computer «  The remote computer processes SuperTrend data.
|Local Computer Browse... +  AllRuntime computers can display the data in SuperTrend
graphs.
Cancel Help

Ny Nah N

IS IS IS
th th th

SuperTrend Logging Dialog Box

To configure which computer will process SuperTrend historical log files:

1. Inthe PAC Display Configurator menu bar, click Configure > SuperTrend Logging to open the SuperTrend
Logging dialog box.

SuperTrend Logging

YWhich Runtime Mode 'Wwill Log Data?
(®):Funtime on This Computer

() Runtime on a Different Computer

| Local Computer Browsze. .

Cancel Help

2. Select the computer:

— Ifonly one computer will run the project in Runtime, select Runtime on This Computer, and then
click OK. By default, SuperTrend historical log files are saved in the PAC Display project folder.

If more than one computer will run the project and you select Runtime on This Computer, each
computer running the project will collect, process, and save SuperTrend historical log files in the
configured destination.

- When more than one computer will run the project in Runtime, Opto 22 recommends you choose
Runtime on a Different Computer. Having one computer process SuperTrend historical log files can
prevent issues caused by multiple computers sending data to the same destination.

a. Select Runtime on a Different Computer, and then click Browse.

b. Inthe Choose Logging Computer dialog box, expand the network computer tree until you find the
computer you want.

c. (lickthe computer to select it, and then click OK.
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In a multi-computer environment, the “different computer” (typically, a remote computer) must be running
the project in order to collect the data and create and save the log files to the configured location.

SuperTrend Historical Log File Names

See also, (PAC Display Professional only) “Saving a SuperTrend to a Database” on page 208.

SuperTrend historical log file names are created automatically. Because the file names are referenced internally
by the PAC Display application, you should never manually change the name of a SuperTrend historical log
file.

SuperTrend historical log file names are based on the date the file was created and a configured rollover period.
File rollover is used to separate data log files according to configured time periods; when a rollover period
ends, the active log file is closed and a new data log file is created. You can configure monthly, weekly, daily,
and hourly rollover periods; you can even configure logs to be created when a PAC Control strategy tag's value
matches configured conditions. You can also choose a “None”rollover period, in which case all data is stored
in asingle file.

Key

yyyy = four-digit year

yy = 2-digit year

mm = month

pp = day that the file was started (applicable only to weekly rollovers)
dd = day

hh = hour (0-23)

MM_SS = minutes and seconds

.H = file extension prefix for a historical data log

.T = file extension prefix for a SuperTrend historical data log

#### = an internal ID number for the historical data log or SuperTrend.

Rollover period Naming Format

RMyymm. H#H##

Monthly RMyymm . T####
RWyymmpp. H##H#H#
Gz RWyymmpp. T####
Dail RDyymmdd. H#H###H#
Y RDyymmdd. T####
RHyyyy mmddhh. H####
AU RHyyyy_mmddhh. T####
Triager RT_yy_mm_dd_hh_MM_SS.H####
99 RT_yy_mm_dd_hh_MM_SS.T####
HISTLOG. H##H#Ht
None

STREND. T####

For more information, see “When Are Rollover Files Created?”on page 231.

Configuring SuperTrend Log Files

To save SuperTrend historical data:
1. Choose the Select tool and double-click the SuperTrend.
The SuperTrend Setup dialog box appears.
2. (lickLogTo.
- In PAC Display Basic, the Historical Log File Configuration dialog box appears.
Continue to step 3.
- InPAC Display Professional, a pop-up menu appears.
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Select Log File to display the Historical Log File Configuration dialog box. (To log to a database, see
“Saving a SuperTrend to a Database”on page 208.)

SuperTrend Setup @
Setup | Xauds | Y-awds [ Zoom [ Hot Keys | Pens 18 | Pens 9-15]
Trend Type Historical Setup Size / Position
) Real-Time Computer Saving D ata to File: T
) Histarical Local computer
2 : Y 240
@ Combined
5 Log To— T
Caolar Log File... =0
Background: 1D:0000 Log to Database I 42
- @ Test Fie——wroramprme Ly
Refresh Time: [G[oup 01 sec) ']
Dizable Scanning: [Never v]
[ ok ][ cancd |[ Hep |

Note that in the File Name area, only the Automatic option is available; user-defined names are not
allowed for SuperTrend historical log files. Likewise, in the Lines area, Line Format is grayed out because
you can't change the log file format of a SuperTrend historical log file.

Historical Log File Configuration >
Directary Path
(®) Mame: | Browse...
() Use project directory [] Make Path Relative to Project
File: M arme:

Source:  (®) Automatic Fised From strategy

7
Lires Files
Line Farmat... Mumber of Files To Fetain:
Lines Buffered: Rolover: | Days ) Tuesday
? | | 5

[JKeep file open Usge 0.01 Sec. Rezolution

Cancel Help

Do one of the following:

To save the log files for this SuperTrend locally in the PAC Display project directory, select Use Project
Directory and click OK.

SuperTrend historical log files will now be saved locally in the same directory as your PAC Display
project. The Use Project Directory setting applies to each computer that is running this PAC Display

project, which means that each computer will save SuperTrend historical log files in its local project
directory.
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NOTE: If you have configured a remote computer to save SuperTrend historical log files, the Use
Project Directory option is not available. You must click Browse and select a directory from the list
of network directories that appears, even if the directory you select is the same as the project
directory.

- Tossave thefiles to a folder relative to the folder that the project is in, select Make Path Relative to
Project. If you then save the project to a different folder (or even to a different computer), PAC
Display will save the files to the relative path.

For example, if the project is saved in C:\proj\ and you configure the files to be saved in
C\proj\data\, then the relative path would be this: \data\

If you then saved the project to C:\temp\newproj\, the files would be saved to the new location’s
relative path: C:\temp\newproj\data\

- Tosave the log files for this SuperTrend in a location other than the PAC Display project directory,
perform the steps below. If there are lots of log files, you can speed up the display time by saving the
log files for each SuperTrend in its own folder.

Helect Name and click Browse.

If you have selected remote SuperTrend logging, the Choose Remote Logging Location dialog box
appears. Otherwise, the Select Directory dialog box appears.

Navigate in the file dialog box that appears until you find a computer and directory (Choose
Remote Logging dialog box) or mapped local or network drive and directory (Select Directory
dialog box) where you want to save the log files for this SuperTrend.

Helect the directory where the files will be saved and click OK.

When your project is running, SuperTrend historical log files are saved in the directory path you
configured. This setting applies to each computer that is running the PAC Display project; each
computer will save SuperTrend historical log files in the directory path you configured.

Saving a Log in Text or Binary Format

When you configure the SuperTrend object, you can choose to save a SuperTrend historical log file in either
text or binary format.

Text—When saved as an ASClI text file, a SuperTrend historical log file includes a header with information
about tags assigned to the SuperTrend pens. One advantage of saving a log file in text format is accessibility—
the file can be opened and viewed using any text editor, such as Windows Notepad. The disadvantage to this
file format is that when a large amount of historical trend information is opened and plotted in a SuperTrend
graph, the graph may be drawn slowly.

Binary—When a SuperTrend historical log file is saved in binary format, the file does not include a header
containing information about tags assigned to the SuperTrend pens. A major advantage to saving a log file in
binary format is speed—historical trend information from a binary file is usually graphed much more quickly
than when using the same information from a text file. A disadvantage to binary file format is that the data
cannot be opened and read using a text editor.

To change the file format of an existing SuperTrend historical log file between text and binary in PAC
Display Configurator, perform the steps below. (For log files to be present, you will need to have previously run
your PAC Display project and collected historical data.)

1. Double-click a previously configured SuperTrend object that has generated one or more log files.

PAC Display User's Guide



CHAPTER 8: WORKING WITH TRENDS

The SuperTrend Setup dialog box appears with either Text File or Binary File selected, depending on how
you originally configured the SuperTrend.

SuperTrend Setup @

Setup | Xads | Y-ads | Zoom | Hot Keys | Pens 1-8 | Pens 316

Options to choose the file format of

Trend Tupe Historical Setup Size / Pogition a SuperTrend historical log file
) Real-Time Computer Saving Data to File: e
) Histarical Local computer

45

Calor

Background: 1B: 6000

- [G TextFile () Binary File
Refresh Time: [Gr.:.up 001 zec] v]
Dizable Scanning: ’Never 'l

[ ok || Cancel || Help |

2. IfTextFileis selected, choose Binary File; if Binary File is selected, choose Text File.

The Select Log File to Convert to dialog box appears. In the example below, text files that can be
converted to binary format appear in the list:

Select Log File to Convert to Binary &l

Avwailable SuperT rend hiztonic log files:
File: M ame Start Time End Time

iR RN 02/24/2003 10:11:15.913 02/24/2003 10:11:30.210
RHO21713.70000 021742003 131258171 02/17/2003 13:13158.083
RHO21709.70000  02/17/42003 03:30:11.871 02/17/2003 09:30:22.046
RHO21708.70000 021742003 08:13:13.347 02/17/2003 03:13:35.213
RHOZ1615.70000  02/16/2003 15:24:32.026 02/16/2009 15:55:23.158

[ Ok ][ Cancel ][ Help ]

3. Highlight a log file to convert and then click OK.
4. Now click OK to close the SuperTrend Setup dialog box.

Converting SuperTrend Historical Log Files to Text Format for Viewing

While you can't view the contents of a SuperTrend historical log file saved in binary format, a simple software
utility (including source code) is included with PAC Display that lets you convert binary log files to text format
in order to view their contents. (The utility can also convert text files to binary format.) Once you have
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converted a binary SuperTrend historical log file to text format, you can easily view its contents using a text
editor or other application.

NOTE: This utility creates a separate, new file in text (or binary) format that is not used by PAC Display. The format of
the original SuperTrend historical log file is not changed. If you want to change the format in which this original log
file is saved, see “Saving a Log in Text or Binary Format”on page 204.

Important Guidelines for Using This Utility

« Do not rename or modify any original SuperTrend historical log files. These are files with the file
extension T#### (for example, .T0003, .T0004, and so forth). PAC Display uses the file names to access
and update log files.

« Ifyourename the new files that are created by the utility, do not use the name or file extension of the
original SuperTrend historical log file.

« If you convert a text file to binary format, the header information in the text file will be
removed. This information cannot be recovered, even if you convert the binary file back to text format.

Converting a SuperTrend Historical Log File for Viewing

The utility for converting SuperTrend historical log files is available in PAC Display and also in a command line
version.

To use the PAC Display version:

This utility is available in both PAC Display Configurator and Runtime.
1. ClickTools > Convert SuperTrend Files to open the Convert SuperTrend Files application.

& Convert SuperTrend Files |Z||E|rg|

Browze for Folder IC:\F‘rogram FileztDpto225PaC Project 3, 04Dizplay Pro Examplesh !

Files Select Al

M arne Type
[] RHOO710.T0000 Binary
[ RHM0711.T0000 Birany

The current project folder is selected by default. To browse to a different folder, click the Browse for Folder
link. All SuperTrend files located in that folder are listed with either Text or Binary shown as the type.

2. Check the box next to one or more file names, and then click Convert.
The files are converted to the correct format even if files of both types are selected.
Files are converted as follows:

- Text to Binary: Each new binary file has the same name as the original with “bin”appended to the
end. For example, RD160319.T0000 becomes RD160319.T0000.bin.
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—  Binary to Text: Each new text file has the same name as the original with “txt”appended to the end.
For example, RD160319.T0000 becomes RD160319.T0000.txt.

To use the command line version of the conversion utility:
1. Openacommand prompt window.

To open a command prompt window, press and hold the Windows Start key , and then press R.

2. Atthe command prompt, enter the command to navigate to the folder where PAC Display is installed. For
example, if PAC Display version 10.5 is installed on your computer's C:\ drive, the command would be:

cd "C:\Program Files (x86)\Opto22\PAC Project 10.5"
This image shows the command and the response:

BE¥ Command Prompt - o x /Type this Command, and then
press Enter.

~The response shows the
directory you are currently in

3. Atthe command prompt, enter the conversion command and the log file's path and filename.
Syntax: STRNDCVT.EXE [path\log filename]
where STRNDCVT.EXE is the conversion command
and [path\log filename] is the name of the SuperTrend historical log file to be converted.

For example, to convert a log file named RD161005.T0000 and located in the C:\PAC Display\Logs folder,
you would enter:

STRNDCVT.EXE "C:\PAC Display\Logs\RD161005.T0000"
The format change occurs automatically: If the log file is in binary format, it will be converted to text; the new

text file has the extension .txt. If the file is in text format, it will be converted to binary; the new binary file has
the file extension .bin.

AC Project 9.5"

AC Project

AC Project

Share

View

L T « Local Disk (C:) » PAC Display » Logs v O Search Logs 2
MName Date modified Type Size
7 Quick access
| RD161005.T0000 10/5/2016 4:44 PM  TOOODO File TKB
& OneDrive | RD161005.T0000.bin 10/5/2016 5:38 PM  BIN File 3KB

[ This PC
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Saving a SuperTrend to a Database

(Pro only) If you have configured an ODBC-compliant database (such as Microsoft SQL Server, MySQL, or
Microsoft Access), you can also log SuperTrend data to a database. For information about configuring ODBC
data sources, see page 55.

1. From the SuperTrend Setup dialog, click the Log To button and choose Log to Database from the popup

menu.
SuperTrend Setup *
Setup  X-axis Y-axis Zoom Hot Keys Pens 1-8 Pens 316
Trend Type Historical Setup Size / Position
) Real-Time Computer Saving Data to File: y
(® Combined LT i 104
ogTo..
Colar !
Background: ID: 0000 H 204
- @ TextFile () Binary Fils
Riefresh Time: Group 0 (1 sec] ~
Dizable Scanning: | Neyer v
Cancel Help

If a database is configured, a dialog shows the default settings for the table that will be created and

logged to.
Database Table

Table Mame: SuperTrend_0000

Table Columns
Column Mame Column Type
Trend_Id INT
Pen_Id INT
Log Time DATETIME
Pen_“alue FLOAT

 F—rpyi—— [ Cancel ] [ Help ]

2. If desired, modify the table name or the column names.
To modify a column name:
a. (lick the name to highlight the row.
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Database Table

Table Marme: SuperTrend_0000

Table Colurnns

Pen

Calurnn Mame
Trend_Id
Pen_Id
Log Time

Column Type

INT
INT

DATETIME

FLOAT

[ o

][ Cancel ][

Help ]

c. Type anew name, and then press Enter.
d. Click OKto confirm your changes and close the dialog box.

NOTES

«  Table and column names may not contain the following characters: (space) [ ] :

« Column names cannot begin with a SQL reserved word for that database type.
Examples: INTEGER, VALUE, BACKUP, CURRENT DATE

Here is a sample of a table created using a Microsoft Access database:

=== <)

Pen_Id

| Log_Time | Temperature

Tank_#1: Table
Trend_Id

id

¥ |

I .

o0 000 OO O

114 10:23:29 AM
114 10:23:30 AM
114 10:23:31 AM
114 10:23:32 AM
1/14 10:23:33 AM
114 10:23:34 AM
114 10:23:35 AM
114 10:23:36 AM
114 10:23:37 AM

Record: 14| 4 |[T 1 b [»1[px|of 9

Changing the Database Table Name

77.6915588379
77.7220764160
77.7220764160
77.6915588379
77.7220764160
77.6915588379
77.6915588379
77.7220764160
77.6915588379

When you create or modify a table for logging SuperTrend data in a database, you can change the database
table name. However, after Runtime logs data to the database, if you then try to change the database table
name in Configurator, a message is displayed, that says the table already exists.

When the message appears, do one of the following:

«  C(lickYes to create a new table and start logging to that table.

»  Click No to rename the existing table and continue logging to that table.
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USING XY PLOTS

You can use XY plots to graph real-time tag information. XY plots do not graph data over time, but instead plot
points on a two-dimensional graph using data from two float or integer tables in the PAC Control strategy. (For
information on using numeric tables in a strategy, see the PAC Control User’s Guide, form 1700.)

The value in each element of the numeric tables defines the coordinates for a single point on the x-axis and
y-axis coordinate system. The example below shows how two numeric tables, each having three elements,
would be used to draw three consecutive points on an XY plot.

Table Element Numeric_Table_1 Numeric_Table_2 XY Coordinates
0 3 8 (3.8)
1 5.25 10 (5.25,10)
2 2 3.3 (2,3.3)

An XY plot is useful in applications where one value must be graphed against another value. Common
examples in industrial settings include graphing temperature versus pressure, displacement versus input, or
voltage versus current.

Creating an XY Plot

1. Select the XY Plot tool from the toolbox and position the cursor where you want the XY plot object
to begin in the window.

2. (lick the mouse button, drag the mouse to the desired size, and then release the mouse button.
The XY plot that appears should resemble the example below:

XY Plot

W oAxiz = 2customizes. Y Axiz = <customizes
100
Y-Axis Layout &0
-Label Position = Bottom
-Max. Val =100 g0
-Min.Val=0
-Major Divisions = 5 40
-Minor Divisions = 2
20
0
0 20 40 &0 0 100

X-Axis Layout

-Label Position = Left. Major Divisions = 5
-Min. Val = 0. Minor Divisions = 2
-Max.Val = 100

Modifying an XY Plot

Choose the Select tool and double-click the XY plot to open the XY Plot Configuration dialog box.
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XY Plot Configuration Dialog Box

X-Y Plot Configuration

General Configure Individual Plotz

A —— Title: 1=-=1: Az = <custarizesr '.:-:':5:=-=::c:l_J:z:h:urnize:::- @ @ E’ D
: E

Bl Border Colar: - Bai{l;_::;u;:niiocrhgl O [
o | e L] Hliofinine = O

Hdis Wiz
F_1 Mumber of Major Divisions: Color: - MHumber of Major Divisions: Color: - J
G Mumber of Minor Divizions: Color; I:I Mumber of Minor Divisions: Color; I:I K
H Min. Value m GERS \a"alun.a: Fin. Value: Fax, Walue: L
I Labels on Left |_T_| Labelz on Right m Labelz on Top Labelz on Bottom M
N—+ QK. ] [ Cancel ] [ Help ]

The XY Plot Configuration dialog box is used to set the parameters of an XY plot, including the number of
plotted lines that are displayed and the scaling used for the x-axis and y-axis.

(A) Title. Enter the title of the XY plot here.

(B) Border and Chart Color. Click a color button to enter the color for the chart, the chart’s background,
and the chart's border. In the Color dialog box that appears, choose a color and click OK.

(C) Allow Range Change in Runtime. Select the Allow Range Change in Runtime check box to allow the
user to change the x-axis and y-axis range values in PAC Display Runtime.

(D) Pens. Use the plot configuration buttons to define up to six individual plotted points in the XY plot. Each
individual plot uses x-axis and y-axis coordinates from two PAC Control tags. You can also define the plotted
point’s color and width, and specify line style and whether a legend should appear. See “Configuring
Individual Plots in an Object”on page 212 for more information.

(E) Pen Check Box. Check this box to display a configured individual plot. Uncheck the box to hide the plot.

(F) X-Axis Number of Major Divisions. Enter the number of major x-axis divisions for the XY plot. This is
the number of main sections the graph is divided into. You can also choose a color for the major divisions by
clicking the Color field. In the Color dialog box that appears, choose a color and click OK.

NOTE: For both x- and y-axis divisions, the lines dividing the major divisions appear thicker than the minor divisions.

(G) X-Axis Number of Minor Divisions. Enter the number of minor x-axis divisions for the XY plot. This
will be the number of sections the major divisions are divided into. The minimum number of divisions is one.

You can also choose a color for the minor x-axis divisions by clicking the Color field. In the Color dialog box
that appears, choose a color and click OK.

(H) X-Axis Min/Max Value. Enter the minimum and maximum values for the x-axis. In addition to whole
numbers and decimals, you can also use negative exponents for numbers less than 1. For example, for the
number .0000001, you would enter 1.00e-07.
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(1) X-Axis Labels on Left/Right. Enter the label position for the x-axis. By default, the x-axis is labeled on
the left, but you can also choose to have the label on the right or on both sides.

(J) Y-Axis Number of Major Divisions. Enter the number of major y-axis divisions for the XY plot. This is
the number of main sections the graph is divided into. You can also choose a color for the major divisions by
clicking the Color field. In the Color dialog box that appears, choose a color and click OK.

NOTE: For both x- and y-axis divisions, the lines dividing the major divisions appear thicker than the minor divisions.

(K) Y-Axis Number of Minor Divisions. Enter the number of minor y-axis divisions for the XY plot. This
will be the number of sections the major divisions are divided into. The minimum number of divisions is one.

You can also choose a color for the minor y-axis divisions by clicking the Color field. In the Color dialog box
that appears, choose a color and click OK.

(L) Y-Axis Min/Max Value. Enter the minimum and maximum values for the y-axis. In addition to whole
numbers and decimals, you can also use negative exponents for numbers less than 1. For example, for the
number .0000002, you would enter 2.00e-07.

(M) Y-Axis Labels on Top/Bottom. Enter the label position for the y-axis. By default, the y-axis is labeled
at the bottom, but you can also choose to have the label at the top, or at both top and bottom.

(N) OK. Click OK to save your settings.

Configuring Individual Plots in an Object

In the XY Plot Configuration dialog bo, click the configuration button for an individual plot (for example,
Pen 1) to open the Configure XY Plot dialog box.

Configure XY Plot Dialog Box

Configure XY Pen 1 E|
bz
A__Table: | |._ —B
Az
C__Table: | |.— —D
Options

E—— Fen Color: - Pen Wwidth: |1 F

G Show Legend in Runtime m Diraw Connecting Lines

| __"' 0k H Cancel H Help l

(A) X-Axis Table. Enter a PAC Control tagname here that will provide the x-axis values. Click the Tag
Selection Button (B) to open the Tag Selection dialog box.

(B) Tag Selection Dialog Button (X-Axis). To enter a tagname in A, click here. The Tag Selection dialog
box is displayed so you can select a tag for a numeric table. For the table you select, also enter the starting
index (usually 0) and the number of table elements to be used in the plot.
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The fields for these values are shown in the illustration below. To learn more about configuring tags in your
project, see “Configuring Tags”on page 74.

o T, A xxr——r—
For a selected numeric table,

Selected Fields enter a starting index (usually
0) and the number of table
L elements to use.

Field:
Element; Bit [0-31]:

Start Index: _] 4m EIements'

(C) Y-Axis Table. Same as the X-Axis Table setting (A) above, but sets the tag for the y-axis.

(D) Tag Selection Dialog Button (X-Axis). Same as the x-axis tag selection (B) above, but selects the
tag used for the y-axis.

(E) Pen Color. Click here to choose a pen color. In the Color dialog box that appears, choose a color and click
OK.

(F) Pen Width. Type the width of the line for the pen to create. The width is specified in pixels.

(G) Show Legend in Runtime. Select the Show Legend in Runtime check box to have the names of the
tags used appear under the graph'’s x-axis.

(H) Draw Connecting Lines. Select Draw Connecting lines to have lines connect each x-y coordinate.

(1) OK. Click OK to save your settings.
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9: Configuring Trigger-Based
Events

INTRODUCTION

In this chapter, you will learn how to make different types of events occur based on the value of a tag in a PAC
Control strategy. These events include saving a historical data log, launching an application, playing a sound,
changing a window’s state, downloading and uploading a recipe to the control engine, and starting an alarm.

InThis Chapter

What is a Trigger-Based Event? page 215
Historical Data Logs page 215
Launching Applications page 233
Sounds page 236
Configuring Trigger-Based Window States...........envreresne page 238
Configuring Recipes page 239
Configuring Alarm Points page 258
Adding Alarm Graphics page 273
Configuring Project Alarms page 277

WHAT IS A TRIGGER-BASED EVENT?

In PAC Display, you can make things happen based on the value of a tag in a PAC Control strategy. When the
tag equals a specific value or falls within a defined range of values, it starts, or triggers, an event that you have
specified.

You can use trigger-based events in many different ways. Here are a few examples:

«  Monitoring temperature—Play a recorded warning sound to indicate an alarm condition if a tag
exceeds a value.

«  Changing control system parameters for different products—Download a new recipe (series of
values) to a control engine when a tag reaches a set value.

» Logging non-standard conditions or errors—Print a log whenever monitored tags fall outside a
previously defined range of values.

HISTORICAL DATA LOGS

A historical data log lets you collect and store data from your control process to a file on your computer, or on
a remote computer on a network. Once it is saved in a file, historical data about your control process can be
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used by spreadsheet applications (such as Microsoft Excel) to generate reports, or the data can be archived for
later reference.

By default, PAC Display saves historical data logs as text files in Unicode (UTF-16) format. To save all logs in
ASClI format, select the Save log files in ASCII format check box in the Runtime Setup dialog box. For details,
see “Runtime Setup: General Tab”on page 290.

NOTE: To ensure that the correct time and date information appear in a historical data log, make sure to set the time
and date on your PC prior to starting PAC Display.

Historical data logging begins when PAC Display starts scanning the control engine for data, and ends when
PAC Display stops scanning the control engine for data. (Scanning starts when the PAC Display project is
opened in Runtime, and stops when the project is closed.) You can use a start or stop trigger, however, to start
or stop historical data logging only (for example) when a tag is within a range of preset values, or a
preconfigured number of samples have been taken. Start and stop triggers may be attached to any control
engine variable.

Tag Types You Can Save to a Historical Data Log

You can record the following types of tags in a historical data log:
» Integers and integer tables

«  Floats and float tables

«  Strings and string tables

NOTE: If a historical data log is logging string tables, make sure that only string tables are used in that log. You
cannot log string tables and integers in the same log file.

o Discretes

With integer tables and float tables, you can select individual elements, groups of elements, or all elements in
the table. For more information on working with tables in a PAC Control strategy, see the PAC Control User’s
Guide (form 1700).

NOTE: To save data from more than one control engine, you must create a separate historical data log file for each
control engine that will be monitored. Data from multiple control engines cannot be saved in the same historical
data log file.

Configuring a Historical Data Log

To configure a historical data log in your PAC Display project, choose Configure > Historical Data Log.

The Historical Logs dialog box that appears allows you to add new historical data logs to the project or modify
or delete previously configured historical data logs. You can add up to 1000 historical data logs per project.

7| Historic Logs @

Hame:

Example Historic Log _— A
[ wea. |{—B
[ o | 1—C
[Dwiess ]+—D
+E

[ QK J [ Cancel ] [ Help —— F
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IMPORTANT: To save data from more than one control engine in a historical data log file, you must create a separate
historical data log file for each control engine that will be monitored. If data from multiple control engines is saved in
the same historical data log file, it is difficult to extract and use the log data from each control engine.

If there are no historical data logs in the project, the Modify and Delete buttons cannot be selected. Selecting
a configured historical data log enables the Modify, Delete, and Duplicate buttons.

(A) Add. Click Add to create a new historical data log in the Historical Log Configuration dialog box that
appears.

(B) Modify. Highlight an existing log and click Modify to change it in the Historical Log Configuration dialog
box that appears.

(C) Delete. Highlight an existing log and click Delete to remove it.
(D) Duplicate. Highlight an existing log and click Duplicate to create a copy of the log.

(E) Import. Click this button to display the following import options.
Import from Subfolder: Select one or more binary (.hle) files import into the current project.

Import from Comma Delimited File: Select one or more comma-delimited (.csv) files to import into
the current project.

(F) Export. Highlight one or more files you want to export, then click this button to display the following
options.
Export to Subfolder: Exports the selected historical data logs in binary format to the current project’s
Exported Historical Logs subfolder. Each file has the name of the historical data log with the .hle
extension. For example: Pressures Log.hle
Export to Comma Delimited File: Exports the selected historical data logs in binary format to the
current project’s Exported Historical Logs subfolder. Each file has the name of the historical data log with
the .csv extension (so it automatically opens in Excel).
For example: Water Log.csv
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Historical Log Configuration Dialog Box

To open the Historical Log Configuration dialog box, choose Configure > Historical Data Log, and then click
the Add button.

Histerical Leg Configuration ot
A ——Hame: Example Historical Log o: o0 —— B
C —|— Refresh Time: Group 01 sec) w Samples per Refresh Time ——— D
Hiztorical Log LogTo.. —— E
F
bSppend.. —1—— G
Inzet. ——H
Madify... ——1
Delete ——3J
Move Up —
. [—K
Move Dovarr
| N
Mumber of
L——Start Trigger... ® StTp Trigger... Saul.;nm:;.'j Matifization. .. —0
M g
Enabled Enabled Enabled
P Cancel Help

(A) Name. Enter the name of the historical data log here. Use this name to refer to the historical log group
you're configuring. (This name does not affect the name of the historical data log file that is saved to disk.)

NOTE: The name in this field must be different from all historical data logs within the project or you will get an error
message when you exit the dialog box.

(B) ID. This field shows a unique numeric identifier for the historical data log. This identifier, which starts out
at 00 and increases sequentially, is used as the last two characters of the three-character file name extension
for a historical data log file. The first character of this file name extension is an uppercase “H’, so with the
identifier, a typical file name extension for a historical data log would be “H00"

(C) Refresh Time. Select a previously configured refresh time group to scan the historical log point tags.
This scan rate applies to every log point configured within this historical data log. For more information on
setting up refresh time groups, see “Refresh Time Groups”on page 183.

(D) Samples per Refresh Time. Enter the number of times per each Refresh Time unit that a tag value is
scanned. This does not change how often the historical data log is written to (the Refresh Time); it only
changes how often a tag value is scanned.

To calculate the actual time interval between each scan, divide the Refresh Time by the Samples per Refresh
Time. For example, if the Refresh Time scan rate is 1 second, a Samples per Refresh Time value of 3 will sample
the tag value every .333 seconds. If the Refresh Time scan rate is 2 seconds, a value of 3 will sample the tag
value every 666 seconds. To ensure that the freshest data is added to the historical data log, enter an odd
number greater than 1 and less than 10.

(E) Log To. Allows you to specify where to log the file.
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If you're using PAC Display Basic, clicking this button opens the Historical Log File Configuration dialog box.
(See "Defining the Historical Data Log File"on page 221.)

(Pro only) If you're using PAC Display Pro, clicking this button prompts you to select one of the following:

- LogFile
Click to specify the directory where the historical data log file should be saved, the file name and
format, and, if applicable, the rollover parameters for the file. See “Defining the Historical Data Log
File"on page 221 for more information.

- Logto Database
Click to configure a table for logging SuperTrend data. See “Saving a SuperTrend to a Database”on
page 208.

(F) Historical Log Points. This list shows all configured historical log points for this log file. The order of the
points in the list (top to bottom) is the order in which the points will be logged. To change the order of the list,
select a point, and then choose one of the Move buttons in J.

(G) Append. Click to add a historical log point to the end of the historical log point list (E). See “Configuring
a Historical Log Point”on page 228 for more information.

(H) Insert. Click to insert a historical log point above a highlighted historical log point.
(1) Modify. Lets you modify the highlighted historical log point.
(J) Delete. Deletes the highlighted historical log point from the list (E).

(K) Move Up/Down. Highlight the log point you want to move, and then click Move Up or Move Down to
change the position of the point in the historical log point list.

(L) Start Trigger. Using a start trigger is optional. Click to configure the PAC Control tag that will start
scanning the listed historical log points. Check the Enabled box to make the start trigger active. See
“Configuring a Start or Stop Trigger”on page 228 for more information.

Since the start trigger can be activated only from a non-triggered state, you must also configure a stop trigger
at L or a number of scan times at M.

(M) Stop Trigger. Click to configure the PAC Control tag that will stop scanning the listed historical log
points. Check the Enabled box to make the stop trigger active. A stop trigger is required only when you have
configured a start trigger. Additionally, a stop trigger is edge-sensitive and only activates on a false-to-true
state transition. See “Configuring a Start or Stop Trigger”on page 228 for more information on setting up a
stop trigger.

(N) Number of Samples. Another way to stop scanning the historical log points is to set the number of
samples, or times the points are scanned. Select Number of Samples, and then enter a discrete number of
samples to take once the start trigger occurs.

(O) Notification. Click this button to assign a value to a tag when historical log sampling has stopped.
Check the Enabled box to make notification active. See “Notification When a Trigger Has Stopped”on
page 229 for more information.

(P) OK. Click OK to save your settings and close the dialog box.

Now we'll look at the additional steps needed to complete the settings in the Historical Log Configuration
dialog box.
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Logging Historical Data to a Database

(Pro only) If you have configured an ODBC-compliant database (such as Microsoft SQL Server, MySQL, or
Microsoft Access), you can also log historical data to a database. For information about configuring ODBC data
sources, see page 55. Also, see “Defining the Historical Data Log File” on page 221.

To log to a database:

1. Choose Configure > Historical Data Log.

2. (lick the Add button to display the Historical Log Configuration dialog box.

3. (lickthe Log To button and then choose Log to Database from the popup menu.

Historic Log Configuration @
[REEIE =ample Histonic Log) 10; 00
Befresh Time: [Group 01 sec) hd 1 Samples per Refresh Time
Historic Log Points: o
= Log To..
PALC Sim:dtCookieh otion Timer Log File...
i I itch
@ Leg to Database M
Loy
et
Modify...
Delete
Move Up
M ave Down

- Mumber of P
SLartTrigger...] 'E'[Stog Trigger... samples:

Enabl=d Enabled Enabl=d

[ (n] ][ Cancel ][ Help ]

If there is a database configured, a dialog shows the default settings for the table that will be created and
logged to.

Database Table

Table Marne: Example Historic

Table Colurnng

Colurmn Mame Column Type
Date_Time DATETIME
Point_Mame YARCHAR
Point_alue VARCHAR

E Ok, ][ Cancel ][ Help
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No matter what the point names are, they appear under the Point_Name column, and the values appear
under the Point_Value column. The Point_Value column is always a string representation of the value. So
if the point is a FLOAT (for example, temperature) the Point_Value might show 78.4, but this is not a
FLOAT. Itis the literal string “78.4". Any queries performed against this table will need to convert the string
to a float (if needed).

4. If desired, modify the table name or the column names.
Modify a column name as follows:
a. Click the name to highlight the row.
b. Clickthe name once again to make it editable.

Database Table

Table Mame: Example_Historic_Log

Table Columns

Colurmn M arme Colurn Type
Date_Time DATETIME
Paint_Mame WARCHAR
Paint_ alue WARCHAR

[ QK ][ Cancel ][ Help ]

c. Type anew name, and then press Enter.
d. Click OKto confirm your changes and close the dialog box.

NOTES

. Table and column names may not contain the following characters: (space) [ ] :

« Column names cannot begin with a SQL reserved word for that database type.
Examples: INTEGER, VALUE, BACKUP, CURRENT DATE

Changing the Database Table Name

When you create or modify a table for logging historical data in a database, you can change the database
table name. However, when some data has been logged in Runtime, if you then change the database table
name in Configurator, a message will appear saying that the table already exists.

When the message appears, do one of the following:
«  C(lickYes to create a new table and start logging to that table.
«  C(lick No to rename the existing table and continue logging to that table.

Defining the Historical Data Log File

You can name the historical data log file, determine where it will be located, configure how the data lines will
appear, and define its rollover parameters in the Historical Log File Configuration dialog box.

Note that a historical data log file is not the same log file used to record data from a SuperTrend. A SuperTrend
historical log file contains different data about log points, and is configured separately from a historical data
log file. See “SuperTrend Historical Log Files”on page 200 for more information. Alarm log files, which contain
data about alarms that have been triggered, are also different from Historical data log files. See “Alarm Logging
Options”on page 284 for more information.
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If you want to save data from more than one control engine, you should create a separate historical data log
file for each control engine that will be monitored. If data from multiple control engines is saved in the same
historical data log file, it is difficult to identify data that corresponds to a specific control engine.

To define a historical data log file, click the Log To button in the Historical Log Configuration dialog box and
enter information in the Historical Log File Configuration dialog box that appears.

Historical Log File Configuration *
Directary Path
A —— O Mame: Browse...
(®) Use praject directary kM ake Path Relative to Project
File: Mame
B ——Souce: @ aAutomatic (O Fived () From strategy
C |
D )
E
Lines Files
F—1 1 Line Format... MHumber of Files To Retain: L H
G —|_ Lines Buffered: Rollover, | Daps ke ead |
il | |[%
L []Keep file open Uze 0.01 Sec. Fesolution
' J
K
Cancel Help

(A) Name. Choose the directory where the historical data log file will be saved. Click Name and enter the
directory path in the field next to it, or click Browse to find a directory path.

Click Use Project Directory to save the historical data log file to the PAC Display project directory. (This occurs
by default if you don't specify a location.)

Select Make Path Relative to Project to save the files to a folder relative to the folder that the project isin. If you
then save the project to a different folder (or even to a different computer), PAC Display will save the files to
the relative path.

For example, if the project is saved in C:\proj\ and you configure the files to be saved in C:\proj\logs\, then the
relative path would be this: \logs\

If you then saved the project to C:\temp\newproj\, the files would be saved to the new location’s relative path:
C\temp\newproj\logs\

(B) Source. Select Automatic, Fixed, or From strategy to determine how the historical data log file name will
be created, and then fill in additional information as needed for that option.

If the Automatic option is used, historical data log files are named based on internal naming rules described in
“Naming Historical Data Log Files”"on page 230. If rollover is not used, the file is named "HISTLOG.H####,"
where #### is the four-digit historical data log ID number. The Automatic option is used by default if you do
not select another option.
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(C) Fixed Name. If you selected the Fixed option in B, enter a file name here. The file name can be any valid,
eight-character DOS file name and doesn't require a three-character file extension. Note that if you don't
specify an extension, one is not added automatically.

You must configure and enable a Start Trigger for this type of file (see page 228). When the trigger starts the
historical data log, the new data is appended to the file if the file already exists. If the file doesn't already exist,
it is created. The rollover naming convention doesn't apply to this type of file name.

(D) String Name. If you selected the From strategy string option, enter a PAC Control string tagname here.
Use the Tag Selection button [ 2] to quickly enter the tag containing the name of the historical data log file.
You must configure and enable a Start Trigger for this type of file (see page 228). When the trigger starts the
historical data log, the string containing the file name is read, and the new data is appended to the log file if
the file already exists. If the file doesn't already exist, it is created. The rollover naming convention doesn't
apply to this type of file name.

If the string name in D is an invalid file name, the default name of the log file is created using the following
rules:

«  Ifthe string is empty, the project directory is added to the Default Name (E) and the extension is an
uppercase “H" followed by the historical data log ID number.

« Ifthe string is not empty and a project directory is not specified as the directory path, the Name in A'is
added to the Default Name (E).

« Ifthe project directory is specified as the path, or the previous step failed, the project directory is added
to the Default Name (E) and the extension is an uppercase “H" followed by the historical data log ID
number. If the project directory is read-only or there is not enough room left on the drive containing the
project directory, an error message indicates the file could not be created.

(E) Default Name. Enter a default file name in E in case the file name in String Name (D) is invalid. The file
name can be any valid, eight-character DOS file name. The five-character file extension is assigned by PAC
Display, and will start with an uppercase “H"followed by the historical data log’s ID (for example: .H0000, if the
ID is 0000).

(F) Line Format. Click to configure the character, or delimiter, used to separate the data in the log file, to
choose the type of quotes used for each data line, and where to insert carriage returns. You configure these
parameters in the Line Format dialog box that appears. See page 230 for more information.

(G) Lines Buffered. Enter the number of lines of data your PC will save to a memory buffer before writing
the information to the historical data log file. When choosing a number, keep in mind that the lower the
number of buffered data lines, the more frequently the computer has to write to the file. Alternately, the
higher the number of data lines buffered in memory, the more data that will be lost if your PC loses power or
has a system failure. A valid entry is any number between 0 and 999; the default is 20 lines.

(H) Number of Files to Retain. Enter the maximum number of historical data log files that can be created
using rollover before the oldest file is overwritten. For example, if you enter 10 and your rollover time period is
set to hours, you will have 10 historical data log files created for 10 hours of data before the oldest file is
overwritten with new data. See page 230 for more information on rollover settings.

(1) Rollover. Choose the rollover time period here. Select None to have all logged data placed in a single
data file named HISTLOG H####, where #### is the ID number assigned to the historical data log. If you select
Weeks, also select the day of the week to have the files rollover. Logging begins when the PAC Display project
is loaded, and data collected will be appended to the existing data file. The size of the file is limited only by
available disk space.

To use the Trigger option, see page 227.Logging begins when the Start Trigger is activated, and data collected
is appended to the existing data file. For more information about rollover files, see “Naming Historical Data Log
Files”on page 230.
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(J) Use 0.01 Sec Resolution. Select this option to log the time in hundredths of a second.

(K) Keep File Open. Select Keep file open to leave the log file open to allow data to be appended to the
historical data log file more quickly. If you leave this box unchecked (the default setting), the file is closed after
each time data is written to it. This provides greater data integrity than leaving the file open.

(L) OK. Click OK to save your settings and close the dialog box.

Exporting Historical Data Logs to Binary or Comma-Delimited Files

You can export the historical data logs from your project to either a binary file or a comma-delimited file, and
then import the file into another project. Both projects must refer to the same tag database(s) for the historical
data logs that are to be imported. The database may be a PAC Control, ioControl (Pro only), or OptoControl
tag database file.

If you want to export and import historical data logs quickly, use a binary file (the Export to Subfolder
command) to export and import historical data logs. However, if you want to use a spreadsheet program
(such as Excel) to view, edit, or create the attributes of the historical data logs before importing them into
another project, use a comma-delimited file.

To export one or more historical data logs to a file:
1. In Configurator, choose Configure > Historical Data Log to display the Historical Logs dialog box.
2. Select one or more historical data logs from the list.

3. Click Export, and then choose from the pop-up menu either Export to Subfolder (for a binary file) or
Export to Comma-Delimited File.

B Historical Logs ¥
Marne:
Alsha Loi Add...
Madify...
Delete
Duplicate
Import...
Ewport.. L
' Export to Subfolder
Export to Comma Delimited File...
Caticel Help

A message confirms success.

Export Historical Logs >

Historical Logs have been exported to the 'Exported Historical Logs' subfolder of
the current project.
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Each historical data log is automatically exported in a separate file to the Exported Historical Logs
subfolder of the current project.

Comma-delimited files have the format:
<Name of historical data log>.csv
Binary files have the format:

<Name of historical data log>.hle

To import the alarm points into another project, see the next section, “Importing Historical Data Logs.”

Importing Historical Data Logs

Historical data logs may be imported from one project into another project that both refer to the same tag
database. Before importing, you must export the historical data logs to a file as described in “Exporting
Historical Data Logs to Binary or Comma-Delimited Files”on page 224.

1.
2.
3.

o v »

In Configurator, choose Configure > Historical Data Log to open the Historical Logs dialog box.
Click the Import button.

Select either Import from Subfolder (for a binary file) or Import from Comma-Delimited File from the
POpP-Up Menu.

B Historical Logs >
M arne;
Add...
Beta Log
Modify...
Delete
Duplicate
Import..
| Import from Subfolder
Ewport.. . .
1 Import from Comma Delimited File...
Cancel Help

An Import Historical Log dialog box opens for you to navigate to the folder containing the file.
Select the file (either .hle or .csv) to import.

Click Open. The files are imported and added to the list.

Click OK to confirm.

NOTE: Ifthere are errors during the import, PAC Display displays a message indicating the error. The import fails
at the first error. PAC Display makes no attempt to guess what the intended field should contain nor does it try
to correct the error or present possible solutions. If an error is encountered, check the contents of each field with
the table in “Exported CSV File Format.” The table details the possible values for the fields.

Structure of Historical Data Log Comma-Delimited File

The structure of the comma-delimited file for historical data logs is described below. The length of the data
will be a minimum of 58 fields, plus an additional 14 fields for each historical log point configured.
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Tag Definition Format. The following table describes a single Tag definition in the comma-delimited file.
There are ten fields, all of which are required for tags that are configured.

If tags are not configured, only the first three fields may be blank. The remaining fields (4-10) must have the
default values indicated. See “Tag Definition Format”on page 263.

Notification Definition Format. This table describes the definition for the notifications. There are a total
of 13 fields per notification. See “Notification Definition Format”on page 264.

NOTE: If notifications are not configured for an alarm point, the seven required tag fields (fields 4-10 in the previous
table) are still required.

Exported CSV File Format. This table shows the format of an exported comma-delimited (.csv) historical

data log file.
Field Description Values
1 Historical Log Name Name of the historical data log

2 Refresh Time Group Refresh group for the historical data log

Entries 3-28 are the Log File Settings:

© 0 N o o b W

15
16
17

18

19-28
The fol
1-10
1

12

13

Log Path
Rollover

Lines Buffered
Keep File Open
Max Files
Delimiter

QuoteType
UseCREvery

Nth Element

Add Space

Use Project Dir

File Source

Fixed Name
Default if Bad
Weekday

Use.01

Tag to be logged
Name
FloatResolution

reserved
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Strategy tag for file name

lowing fields are for each

Path to file location if not project directory; otherwise blank
Index of rollover drop-down menu

# lines buffered

0=unchecked; 1=checked

Maximum # of files to keep

ASCI!I value of delimiter character

Index of “Quotes around strings” drop-down menu

1 = checked;
0 = not checked

Value of the “carriage return every [value] elements” entry

Value of “Include space after delimiter”;
0=not checked;
1=checked

O=false;
1=true

0=Automatic;
1=Fixed;
2=From Strategy

User defined fixed name of file (if “File Source” = 1)
Default Name if “Name from Strategy” String is invalid (i.e., File Source = 2)
0=Sunday; 6=Saturday

Value of “Use.01 sec resolution” option;
O=false; 1=true

See Tag Definition Format table
historical log point configured:
See Tag Definition Format table
User defined name

Floating point resolution

Do not edit this value
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Field Description Values
Integer64 display format
0=decimal;
14 LogFormat 1=hexadecimal;
2=binary
After the Historical Log Point information is the Trigger information:
1-10 | Start Trigger Tag See Tag Definition Format table
11 Value The value that the start trigger is tested against (if not using a Discrete test)
0: >
1:=
12 | Condition 2:<
3:>=
4: <=
5: not=
13 SetupType 0=Discrete; 1=Value
14 DiscreteCond 0=0n; 1=0ff
15 Enabled 0=no; 1=yes
Stop trigger type
16 StopT 0=from tag;
1= number of samples
17 NumSamples Number of samples collected if no stop trigger

After the Trigger information is the Notification information:

1-13 | Notification See Notification Definition Format table

Using the Rollover Trigger Option

When configuring a historical data log or a SuperTrend log, in addition to the time frame rollovers (such as
Hours, Days, Weeks, etc.), you can configure the files to rollover based on a user-defined trigger.

To use a tag to trigger a rollover:

1. Open the Historical Log File Configuration dialog box (see “Defining the Historical Data Log File”on
page 221).

2. Inthe Files group, select Trigger from the combo box next to Rollover.

3. Click the question mark [ 7] to open the File Trigger dialog box.

File Trigger
Marme:
|
Setup by Dizcrete Current Y alue
() Dizcrete On |> v| |
(®) Current Walue Qi
l 0k l [ Cancel ] l Help l

4. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to choose a tag to
trigger the rollover.
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5. Inthe Setup by area, select Discrete or Current Value.
Discrete triggers the rollover based on the tag’s on or off state (which you choose in the Discrete area).
Current Value allows you to choose the tag value that triggers the rollover. To configure the value, select
an operator in the Current Value drop-down list, and then enter the trigger value. When the tag’s current
value meets the configured conditions, PAC Display creates the rollover file.

Configuring a Historical Log Point

This dialog box allows you to select tags whose values are recorded to the historical data log file during
runtime.

IMPORTANT: Although you can select tags from different control engines that have been configured for your PAC
Display project, it is not recommended to do so. To save data from more than one control engine in a historical data
log file, create a separate historical data log file for each control engine that will be monitored.

1. Toadd or change a historical log point in the Historical Log Configuration dialog box, click Append or
Insert to add a point, or click Modify to change a point.

The Historical Log Point Configuration dialog box appears.

Historic Log Point Configuration

Mame: 1I:I.1IHE.54.EEEI:Ir'|t B4 _T.able[D-9

Tag  [10.1925468Int_64_Table[05] (2]

Log Integer B4 Walues As. ..

D (#) Decimal () Hexadecimal () Binary

I 0k H Cancel H Help l

(Optional) Enter a user-defined name for the historical log point.

3. Click the Tag Selection button [?] and select a PAC Control tag to be a historical log point. See
“Configuring Tags”on page 74 for more information about selecting tags.

NOTE: When creating log tables using table variables, the number of elements can be modified in the Tag
Selection dialog box. The maximum number of elements in a log table is 1 million.

4. (Optional) If you picked a float tag type, enter a number in the Floating Point Resolution box to specify
how many places to the right of the decimal point are recorded for floating point numbers.

5. (Optional) If you picked an Integer 64 tag type, select the format: Decimal, Hexadecimal, or Binary.
6. Click OKto save your settings and close the dialog box.

Configuring a Start or Stop Trigger

1. To configure which tag and value will start or stop historical logging, click Start Trigger or Stop Trigger in
the Historical Log Configuration dialog box.
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The Historical Log Configuration dialog box for either Start Triggers or Stop Triggers appears. These dialog
boxes are identical. (The Historical Log Start Trigger Configuration dialog box is shown below.)

Historic Log Start Trigger Configuration

Tag
M arme:
| [
Setup by Dizcrete Current Y alue
() Dizcrete On |> v| |
(%) Current Walue ulii
l 0k l [ Cancel ] l Help l

2. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag to be a Start or Stop Trigger.

3. Select Discrete or Current Value in the Setup By group.

Discrete makes the tag's on or off state trigger the log. Current Value sets the tag value that will trigger
the log. To set a Current Value, select an operator in the drop-down menu, and then enter a value to
compare the tag to.

Notification When a Trigger Has Stopped

When logging has stopped, you can set a tag to a given state or value. This tag setting will act as a flag to
indicate data isn't being added to the log file anymore.

1. Inthe Historical Log Configuration dialog box, click Notification to open the Historical Log Stop Trigger
Notification dialog box.

Historic Log Stop Trigger Notification

Tag

M arme:

| |||
Setup By Dizcrete Current Y alue

() Dizcrete Set %15et () Offset

(%) Current Walue Clear Walue Out: I:I

Toggle

l u] 4 ” Cancel H Help l

2. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name.

3. Inthe Setup By group, select Discrete or Current Value.

Discrete. Select the Discrete option to specify an on/off trigger state for tags that have a discrete base type.
Once Discrete is selected, choose one of the following options to define the desired trigger state.

«  Set: Switches the trigger state to On.
«  Clear: Switches the trigger state to Off.
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«  Toggle: Switches the trigger state from its current condition to the opposite (for example, an On setting
is switched to Off).

Current Value. Select the Value option to define the floating point or integer value written to the specified
tag. The specific value is defined using the Set/Offset options and the Value Out field.

«  Set: Select Set if you want the value used as a replacement for the tag's current value.
«  Offset: Select Offset if you want the value added to the tag's current value.
«  Value Out: Enter the floating point or integer value to be written to the specified tag.

Setting Log File Line Format

1. Todefine how lines of data are stored in the historical and log file, click Line Format in the Historical Log
File Configuration dialog box. The Line Format dialog box appears.

Line Format rg|
Drelimiter
Ofab O Space
Mull {7 Camiage Retumn

(%) Other: I:I

[Include space after defimiter

Guotes Around Stringz. | {hone} W

[] Camriage return every elements

I 0k H Cancel H Help l

2. Inthe Line Format dialog box, select from the choices in the Delimiter group a character (delimiter) that
will separate data in the log file. To use a delimiter that's not listed, choose Other and enter the character
you want to use. Select Include space after delimiter to put a space after each delimiter.

3. From the choices in the drop-down list “Quotes Around Strings,” select the quotes that will appear
around each string in the log file.

4. Toinserta carriage return after a certain number of data elements, select the check box “Carriage return
every”and enter the number of data elements.

The maximum number of elements that can be entered is 99,999. This option is intended for historical
logs with very long data lines which are read by programs that cannot handle long data lines. The date
and time information at the beginning of a data line are not counted as data elements. See “Historical

Data Log Elements” below for more information about data elements in log files.

Naming Historical Data Log Files

There are three ways to name a historical data log file: by using a fixed name, by using a PAC Control strategy
string tag name, or by using the File Rollover feature (described below) which bases the file name on the date
the file was created and a configured rollover period. (Note that PAC Display automatically creates files name for
SuperTrend historical log files. For details, see page 202.)
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File Rollover

File rollover is used to separate data log files according to configured time periods; when a rollover period
ends, the active log file is closed and a new data log file is created. You can configure monthly, weekly, daily,
and hourly rollover periods; you can even configure logs to be created when a PAC Control strategy tag's value
matches configured conditions. You can also choose a “None” rollover period, in which case all data is stored
in asingle file.

Key

yyyy = four-digit year

yy = 2-digit year

mm = month

pp = day that the file was started (applicable only to weekly rollovers)
dd = day

hh = hour (0-23)

MM_SS = minutes and seconds

.H = file extension prefix for a historical data log

.T = file extension prefix for a SuperTrend historical data log

####H = an internal ID number for the historical data log or SuperTrend.

Rollover period Naming Format

RMyymm.H##HH#

Monthly RMyymm . T####
RWyymmpp. H##H#H#
Weekly RWyymmpp. T####
Dail RDyymmdd. HiHH#
y RDyymmdd. T####
RHyyyy _mmddhh.H###
AL RHyyyy_mmddhh. T###
Triqqer RT_yy_mm_dd_hh_MM_SS.H####
99 RT_yy_mm_dd_hh_MM_SS.T####
HISTLOG. HH##H
None

STREND. T####

When Are Rollover Files Created?

When you enable data file logging in your PAC Display project, logging begins when the project is loaded—
or, in the case of trigger-based logging, when a configured start trigger occurs.

For historical data logs, logging continues until either a specific number of samples has been collected, or a
tag's value matches the conditions of a configured stop trigger. (Note that SuperTrend historical log files stop
when Runtime is stopped.) You can also use the Notification feature to configure a flag to write a value to a tag
when logging stops (see “Notification When a Trigger Has Stopped” on page 229).

Hours. If you select Hours, a new data file is created at the top of every hour. For example, if data logging
begins at 8:30 a.m., the first data file will contain data from 8:30 a.m. through 8:59:59 a.m. After that, data files
contain one hour's worth of data for every hour thereafter: 9:00 a.m. through 9:59:59 a.m.; 10:00 a.m. through
10:59:59 a.m.; and so forth.

Days. Select Days for a new data file to be created at the beginning of every day at 12:00 a.m. For example, if
data logging is triggered at 7:00 p.m. on the 5th, the first data file will contain data from 7:00 p.m. through
11:59:59 p.m. on the 5th. After that, data files contain data from 12:00 a.m. through 11:59:59 p.m. on the 6th;
12:00 a.m. through 11:59:59 p.m. on the 7th; and so forth.

Weeks. If you select Weeks as the rollover period, logging begins when the project is loaded, and a new data

file is created every week at the beginning of the selected day at 12:00 a.m. For example, if data logging starts
on a Wednesday and the rollover period is set for every Monday, the first data file will contain data from
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Wednesday through 11:59:59 p.m. on Sunday night. After that, the weekly data files contain data from
Monday at 12:00 a.m. through Sunday at 11:59:59 p.m.

In the weekly rollover file name, pp represents the day that the log file was started. For example, if weekly
logging is set to rollover every Saturday, and the project is loaded on Tuesday, October 4, 2016, a log file
named RW161004.T0001 is created (assuming 0001 is the SuperTrend’s internal ID). The file will contain data
collected from Tuesday through 11:59:59 p.m. on Friday night. At 12:00 a.m. on Saturday, October 8, a new file
named RW161008.T0001 is created. The new file will contain a week’s worth of data, from Saturday, October
08 through 11:59:59 p.m. on Friday, October 14,

Months. Select Months for a new data file to be created on the first day of every month at 12:00 a.m. For
example, if data logging started on January 27th, the first data file will contain data from the 27th of January
through 11:59:59 p.m. on January 31st. After that, data files contain data from 12:00 a.m. on February 1st
through the end of February, 12:00 a.m. on March 1st through the end of March, and so forth.

Trigger-based. Trigger-based log files are created when the configured tag's value matches the conditions
configured in the Historical Log Start Trigger Configuration dialog box (see page 228).

None. If you select None, logging begins when the project is loaded. All logging is done is a single file, and
logging continues until the conditions of a configured stop trigger are met. If you don't configure a stop
trigger, data logging continues indefinitely. (Note that SuperTrend historical log files stop when Runtime is
stopped.)

Historical Data Log Elements

Historical data logs consist of header lines and data lines.

Header Line. The first line of the file, a header line shows the name of each data field. Lines of data samples
then follow the header line.

Here's an example:
Date, Time,CNTR1:Float.TEMP208,CNTR1:Float.PRES209,CNTR1:Float.LEVEL218
Date and Time show where time stamp information will appear in the data lines.

CNTR1:TEMP208, CNTR1:PRES209, and CNTR1:LEVEL218 show that information will be recorded for
three PAC Control tags: TEMP208, PRES209, and LEVEL218. These tags are all on the control engine named
CNTR1.

Data Lines. Data lines follow a header line, and have the following format:
Date<delimiter>Time<delimiter>TAG1<delimiter>TAG2. . TAG1000<crIf>

Date is the current system date with the format: YYYY/MM/DD, where YYYY=year, MM=month, DD=day.
Time is the current system time with the format: hh:mm:ss, where hh=hour, mm=minute, ss=seconds.
TAG1...TAG1000 are valid PAC Control tags with the format: control engine_Name:ltem_Type.Tag.
<delimiter> is any printable ASCII character.

<crlf> is a carriage return, line feed.

Here's an example of what the file might look like:

Date, Time, Cookie:Float.TEMP208, Cookie:Float.PRES209,Cookie:Float.LEVEL
218

2010/03/01,17:00:00,120.02,14.96,12.09
2010/03/01,18:00:00,120.06,14.98,12.03
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2010/03/01,19:00:00,120.03,14.99,12.02
2010/03/01, 20:00:00,120.04,15.01,12.05

In this sample file, data is being sampled every hour from a control engine named “Cookie,”and a temperature
(TEMP208), pressure (PRES209), and tank level (LEVEL218) are being recorded.

LAUNCHING APPLICATIONS

You can use PAC Display to start, or launch, other applications in two ways:

« By configuring a dynamic attribute for a graphic object, and then selecting the object during Runtime.
See "Chapter 7: Using Animated Graphic Objects" on page 139 to learn how to do this in PAC Display
Configurator.

« By configuring an application manager to associate a tag with an application, and then launching the
application using triggers. See “Configuring an Application Launch”below.

Configuring an Application Launch

To use PAC Display Configurator to configure an application launch using a trigger, choose Configure >
Applications, and in the Application Managers dialog box that appears do the following:

«  To create a new application manager, click Add. You can configure up to 1,000 application managers per
project.

«  Tochange an existing application manager, highlight it and click Modify.

«  Toremove an existing application manager, highlight it and click Delete.

If you are creating or changing an application manager, the Application Manager Dialog Box will open (see
below).

Application Manager Dialog Box

Application Manager E|

A —Name: E:-:-arn |e Application kanager

C— — LCommand Line: |

|

B ——working Directory: | | l Browsze. ]
|
|

D ——2ppend Sting: |

E — — Launch Options: () Multiple instances () Single instance
F —Show Options: @ Nomal ) Minimized () Maximized
G ——Trigger

| | l Trigger...

H— Matification... Motification enabled

| __" ok l [ Cancel ] l Help

(A) Name. Enter the name of the application manager here. This name refers to this application launch
setup, and must be different from all application managers within the project.
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234

(B) Working Directory. Enter the path name of the working directory to use after launching the
application. If a working directory isn't specified, the current project directory is used. Click Browse to quickly
choose a directory path in the Working Directory Selection dialog box (see page 234).

(C) Command Line. Enter the path and file name of the program you want to run when the trigger
condition occurs. Click Browse to quickly choose the path and file name in the standard Windows file selection
dialog box.

(D) Append String. (Optional) Select a string tag from the PAC Control strategy to be appended to the
Command Line string in C. If the appended string is a command line option, a space must be included in the
Command Line string to separate it from the main command line.

Use the Tag Selection button [2] to select the string tag name. See “Configuring Tags”on page 74 for more
information on tags. Click the Clear button to quickly remove an entry from D.

(E) Launch Options. Select Single instance to have PAC Display Runtime check whether the trigger has
already launched a session, or instance, of an application. If the trigger hasn't already launched the
application, it will be started. Select Multiple instances to let the trigger start any number of sessions of the
same application.

The Single Instance option doesn't prevent an application from being launched by other graphic objects and
triggers, so multiple instances of an application can still occur. For example, if a trigger launches a Microsoft
Word session, it can't launch any other application until this Word session ends. A toggled graphic object or
another trigger, however, could launch another session of Word, so two instances of the same application
would be running concurrently.

CAUTION: Running multiple instances of the same application on your PC is not recommended. Just like running
several different applications at the same time, running multiple instances of the same application requires
additional memory and other system resources. This may slow your PC’s performance, as well as that of PAC Display
Runtime.

(F) Show Options. Select how the application’s window will appear on-screen: Normal, Minimized, or
Maximized.

(G) Trigger. Click Trigger to select the PAC Control tag used to trigger the application launch. The trigger is
edge-sensitive and activates only from a non-triggered state. See “Selecting a Trigger to Launch an
Application”on page 235 for more information.

(H) Notification. Click Notification to assign a value to a tag when an application is successfully launched.
See “Notification When an Application Has Been Launched”on page 236 for more information. A check mark
in the Notification enabled box indicates a notification tag is configured.

(1) OK. Click OK to save your settings and close the dialog box.

Now we'll look at the additional steps needed to complete the settings in the Application Manager dialog box.

Selecting a Working Directory for a Launched Application

1. Toset up the working directory the launched application should use, click Browse in the Application
Manager dialog box.
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In the Working Directory Selection dialog box that appears, navigate to the working directory path and

click OK. (Click Network to select a network drive.)

Working Directory Selection

Diirectories:

b Spac project 9.08dizplay projects

= ot

[= PROGRAM FILES
= OPTOZ22
[= PAC PROJECT 8.0

Diizplay Project

&9 |

|

Dirives:
| BHe

Selecting the Application File to Run
1. To choose the application you want to run, in
button next to the Command Line field.

2.

you'd like to run, highlight it, and click OK.

the Application Manager dialog box click the Browse

In the Application Manager Executable File Selection dialog box that appears, navigate to the application

Application Manager Executable File Selection

Look i | (=5 Intermet Explarer

v| O F e E-

(D) Connection Wizard

(MU
My Recent | [CDPLUGINS
Diocuments = =l
— Eiedw.exe
Degklop

&

My Documents

-

ty Computer

File name: |iBHD|DIB.EHB

a9

dpen ]

ty Netwark, Files of twpe:

| &l Execs [ EXE)

v | [ Cancel ]

Selecting a Trigger to Launch an Application
1.

To select the trigger that will launch an application, click Trigger in the Application Manager dialog box.
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The Application Manager Trigger Selection dialog box appears.

Application Manager Trigger Selection

M arme:
| [
Setup by Dizcrete Current Y alue
() Dizcrete On |> v| |
(%) Current Walue ulii
l 0k l [ Cancel ] l Help l

2. Useeither Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to choose a tag to
trigger the application launch.

3. Select Discrete or Current value in the Setup by group.

Discrete makes the tag's on or off state trigger the application. Current Value sets the tag value that will
trigger the application. To enter a value in the Current Value field, select an operator in the drop-down
menu, and then enter a value to compare the tag to.

Notification When an Application Has Been Launched

You can set a tag to a given state or value when an application has been successfully launched by a trigger.

1. Inthe Application Manager dialog box, click Notification to open the Launch Application Trigger
Notification dialog box.

Launch Application Trigger Motification

Tag
M arme:
| |
Setup By Dizcrete Current Y alue
() Dizcrete Set %15et () Offset
(¥ Current Value Clear Walue Out: I:I
Toggle
l u] 4 l [ Cancel ] l Help l

2. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag as the flag to indicate the application was launched successfully.

3. Select Set or Offset, and then enter the value that will be sent to the tag in the Value Out field. Choose Set
to replace the tag's current value with the number in the Value Out field. Choose Offset to add that
number to the tag's current value.

SOUNDS

Sounds can provide important feedback, such as alerts or warnings, for the operator using your PAC Display
project. You can add sounds to your PAC Display project by configuring triggers to start and stop standard
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Windows sound files. To use this capability, the PC running the project must have a properly configured sound
card and corresponding system software, as well as a set of speakers. You can use both digitized sound (WAV)
and MIDI music (MID) files in your project.

Sounds can also be used with project alarms. See page 287 for more information.

Configuring a Sound

To configure a sound, choose Configure > Sounds. The Sounds dialog box that appears lists all of the sound
events that are configured for the current PAC Display project.

«  (lick Add to add a new sound event. You can configure up to 1,000 sound events per project.
«  Highlight an existing sound event and click Modify to change it.
«  Highlight an existing sound event and click Delete to remove it.

NOTE: If there are no sound events in the project, the Modify and Delete buttons cannot be selected.

If you are creating or changing a sound event, the Sound Configuration dialog box will appear.

Seund Configuration >
Mame;
AL | |
B Sound File; | | Browse...
|Jze project directon Make Path Relative to Project
Start Trigger
Cc | | Start Trigger...
Stop Trigger
D (@) Play zound tirnel)
O | Stop Trigger...
E |
Cancel Help
F——

(A) Name. Enter a name for the sound event. No two sound events in a project may have the same name.

(B) Sound File. Click Browse and select the sound file you want to play in the standard Windows file
selection dialog box that appears. If the Use project directory option is checked, you can choose only those
sound files located in your project directory.

To use a sound file in a folder relative to the folder that the project is in, select Make Path Relative to Project. If
you then save the project to a different folder (or even to a different computer), PAC Display looks for files in
the relative path.

For example, if the project is saved in C:\proj\ and you configure the file to be in C:\proj\sounds\, then the
relative path would be this: \sounds\

If you then saved the project to C:\temp\newproj\, PAC Display would look for the file in the new location’s
relative path: C\temp\newproj\sounds\

(C) Start Trigger. Click Start Trigger to configure a trigger to start playing the sound. See “Configuring Start
and Stop Triggers for Sounds” below to learn how to configure this trigger.
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(D) Play Sound. Select the Play sound option if you want the sound to play a specific number of times
before stopping. Enter the number of times the sound will play in the field next to the option. The default
value is one.

(E) Stop Trigger. Click Stop Trigger to configure a trigger to stop the sound that is playing. See “Configuring
Start and Stop Triggers for Sounds” below to learn how to configure this trigger.

(F) OK. Click OK to save your settings and close the dialog box.

Configuring Start and Stop Triggers for Sounds

1. To configure the tag and value that will start or stop a sound, click Start Trigger or Stop Trigger in the
Sound Configuration dialog box.
The Sound Trigger Configuration dialog box for either Start Triggers or Stop Triggers appears. These
dialog boxes are identical. (The Sound Start Trigger Configuration dialog box is shown below.)

Sound Start Trigger Configuration

Tag
M arme:
| @
Setup by Dizcrete Current Y alue
() Dizcrete |> v| |
(%) Current Walue
l 0k l [ Cancel ] l Help l

2. Useeither Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to choose a tag
from the Tag Selection dialog box.

3. Select Discrete or Current Value in the Setup by group. Current value sets the tag value that will trigger
the sound. Select an operator in the drop-down menu, and then enter a value to compare the tag to.
Discrete makes the tag's on or off state trigger the sound.

CONFIGURING TRIGGER-BASED WINDOW STATES

You can use a trigger to modify the appearance of windows that appear in Runtime. Changing the
appearance of windows can be effective when you want to immediately attract an operator’s attention, or to
prompt operators to take the next action.

To configure a window state, choose Configure > Window State, and in the Window Managers dialog box
that appears.

«  C(lick Add to add a new window manager. You can configure up to 1,000 window managers per project.
«  Highlight an existing window manager and click Modify to change it.
«  Highlight an existing window manager and click Delete to remove it.

If you are creating or changing a window manager, the Window Manager Configuration dialog box will
appear.
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NOTE: If there are no window manager events in the project, the Modify and Delete buttons cannot be selected.

Window Manager Configuration [‘5_<|

Marme: E:-:arn il Witdon b anager

window b anagement Canfiguration

Trigger

| | [ Trigger...

I QK. H Cancel ][ Help ]

To set up a window manager, do the following:
1. Enter the name of the window manager in the Name field.

2. C(lick Pop Window to configure window states for one or more windows. See “Windows"on page 163 for
more information about changing window states.

3. (ClickTrigger to configure the trigger that will change the window state.
The Window Manager Start Trigger Configuration dialog box appears.

Window Manager Start Trigger Configuration

M arme:
| [
Setup by Dizcrete Current Y alue
() Dizcrete On |> v| |
(%) Current Walue ulii
l 0k l [ Cancel ] l Help l

Use the Tag Selection button |2,
5. Select Discrete or Current Value in the Setup By group. Current Value sets the tag value that will trigger

the change in window state. Select an operator in the drop-down menu, and then enter a value to

compare the tag to. Discrete makes the tag’s on or off state trigger the change in window state.

to quickly choose a tag from the Tag Selection dialog box.

RECIPES

Recipes are a way of exchanging data between a control engine and a PC running PAC Display: recipe
downloadfiles send process data and chart control instructions to a control engine; recipe uploadfiles create a
record of the values currently being used in a strategy table. For example, you can use recipe upload files to
save a controller’s critical process settings; recipe download files can be used to restore a system'’s data after a
failure, or to make changes to program variables without the need for manual intervention. Recipes are also
handy for batch processes when system variables are predetermined and vary between runs or product types.
For important information about using a database table as the source for a recipe download, see page 240.
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Recipes can be configured to perform their specified actions by:
«  Animated Graphic—The recipe action happens when an operator selects a graphic object.
«  Trigger—The recipe action occurs when a tag value meets a defined value.

In PAC Display Basic, recipes are ASClI text files. In PAC Display Professional, recipes can be ASCII text files or
they can be a configured database table and columns. (To configure a database for use with PAC Display
Professional, see “Configuring an ODBC Data Source” on page 55.)

The basic steps to using recipes are:
1. Configure a recipe file that identifies the PAC Control strategy, control engine, and data you want to send
or receive.
- To configure a recipe download file that copies data down to a controller, see “Creating a Recipe
Download File”on page 241.
- To configure a recipe upload file that sends data to an ASClI recipe file or (Pro only) to a database,
see "Creating a Recipe Upload Template” on page 243.
2. Activate the recipe so that the controller can send or receive data.
- Toactivate the recipe by using an animated graphic object, see “Download Recipe”on page 142
and “Upload Recipe”on page 158.
- Toactivate the recipe by using a trigger, see “Configuring a Recipe Upload”on page 252 and
“Configuring a Recipe Download” on page 255.

Using a Database Table as the Source for a Recipe Download

If you're going to use a database to store data for recipe downloads, you'll need a database table with the
following columns in the order specified below. PAC Display doesn't accept spaces or reserved words in
columns names. (In database languages such as SQL, reserved words are programming commands; examples
include Alter, Delete, Rename, Update, and Stop.) Otherwise, the column name doesn't matter; what's
important is that the columns contain the data in the order shown.

g:shijt'i‘;: Data Type Contains
1 String Controller name or IP address
2 String Tag type
3 String Tag name
4 String Indexes and values for each element to be downloaded

IMPORTANT: A space character must precede the first index bracket.

This table structure ensures that PAC Display gets the data it needs to successfully process the downloaded
recipe.

Example: Microsoft Access table structure

7 Recipe_Upload | = Recipe_ Download "

Field Name Data Type
Caontroller Name Text
Tag Type Text
Tag_Mame Text
Download_Data Memo ~
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Example: Space characters must precede download data

A space must precede the first bracket in each set of download recipe data.
Controller_Name - Tag_Type -
10.192.54.68 Integer Table Int_5_Elemen

F 10.192.54.68 Integer Table SuperlongX
*

Name - Download_Data -
[0]112345[1]23456[2]34567[3]45678[4]56789
[0]12345[1]0[2]0[3]0[4]0[S]0[6]0[7]0[8]0[3]0[10]0]

Creating a Recipe Download File

To create a recipe download file to send data from a recipe to a control engine:
1. From PAC Display Configurator's menu bar, click Tools > Create Recipe File.

The Create Recipe File dialog box appears. By default, the recipe file type is Download, and the strategy
file is from the current PAC Display project.

Create Recipe File

Select Recipe File Tupe
(®) Download (O Upload

Strategy File:

basic paccontrol example stre

Contral Engine:

PAC Sim ~
Table:

[_rvalues ~| | »>
Charts

Examplel_chart w| | x>
Choose Yariable Tuoe...

< Mone » = (B

Unda Feda

Cancel Help

2. Select the PAC Control strategy and control engine for this recipe file.
3. IntheTable areg, select a table, and then click Add .
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The Recipe Table Data dialog box appears. The Index column lists all the available indexes for the
currently selected table.

Recipe Table Data

Enter table data. Only indices with data will be added to the recipe file.

Index Yalue Comment {

A @ @ L R = O

Configure Multiple...

Cancel Help

NOTE: Using the Create Recipe Dialog, you can enter only one set of indexes foreach table in a recipe file. To enter
another set of indexes for the table later in the recipe, you must use a text editor to edit the recipe. For details, see
“Basic Recipe File Format” on page 246.

Enter values using the following guidelines. PAC Display automatically limits the index value to the

maximum configurable index for the selected table.

-~ FloatTable: Use numeric data only. Spaces, commas or other non-numeric characters are not
accepted. A decimal point is not required.

- Integer Table: Decimal points are not accepted. Spaces, commas or other non-numeric characters
are not accepted.

- String Table: You may use any character except square brackets ([ and ]) which are reserved for
marking table indexes and cannot be included in strings. To enter a single string for one index, click
in the Value field next to the index number and enter the string.

- (Integer and Float Tables only) To enter the same value for more than one index, select multiple
items using the either the Shift key or the Ctrl key, and then click Configure Multiple. In the dialog
box that opens, enter the value and a comment (if any), and click OK.

NOTE: PAC Display validates your entries and automatically clears invalid data. For example, if you type a string
in a float table, your entry is deleted and a message like this is displayed:

Select Recipe File Ty .

Download
Enter table data. Only indices with data will be added to the recipe file.
Shiateouhl Index alue Comment L)
maintest.idb 1]
1 14 /\
Corl € Invalid Entry x
1 The number was either not a floating point number, or contained commas
5
Table: I3
Float_T able 7
g
a v
Charts < >

In the Charts area, select a chart, and then click the Add button .
The Recipe Chart Action dialog box appears.
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6. Inthe Recipe Chart Action dialog box, select a chart action (Start, Stop, Suspend, or Continue) and then
click OK.
The action is added to the recipe file, and the dialog box closes.

To add an individual integer, float, or string tag:

7. Click Choose Variable Type, and then select a type from the pop-up menu.

8. (lick the down-arrow below Choose Variable Type, and then select a variable.
9. (lickthe Add button to open a configuration dialog box.

Pt AN e AT N N e 1 Choose Variable

Charts

E=ampled_chart /

Chooze Variable Tvoe...

[_Awerage_Deviation

MMWMMI‘quﬁq__\}

ak Cancel | Enter Camment:
Enter Walue: fguret .
| box
QK. Cancel Help

10. Enteravalue and a comment (if desired), and then click OK.

11. Ifyou need to remove the last entry, click Undo. Clicking Undo again removes the next to last entries, and
so on. The Redo button restores entries in the same order they were removed.

12. Click OK to close the Create Recipe File dialog box and confirm the configuration.
The Save Recipe File As dialog box opens.

13. Type a filename for the file.
If you want to use an extension other than .RCP or .TXT, place quotation marks around the filename (for
example, “My Recipe File.myExt").

14. Click Save to save the recipe file and close the dialog box.

Creating a Recipe Upload Template

Create a recipe upload template to send data from a strategy table to a recipe file or (Pro only) to a database:
1. From PAC Display Configurator's menu bar, click Tools > Create Recipe File.
The Create Recipe File dialog box appears.
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2. Select Upload as the file type.

Create Recipe File

Select Recipe File Type

(O Download ®

Strategy File:

bagic paccontrol example stre

Control Engine:

PAC Sim ~
Table:
W alues | e

Choose Variable Tvpe...

< Mone » e

Unda Redo

Cancel Help

3. Select the PAC Control strategy and control engine for this recipe file.
4. IntheTable area, select a table, and then click the Add button .
The Recipe Upload Table Elements dialog box opens.

Recipe Upload Table Elements

Select one or more elements to upload.

Index Comment ~ | Select Al |

QK Cancel Help

- Toselect or deselect an individual index, click the square next to the Index number. The Select All
button selects all table indexes. The Clear All button deselects them.

- Toadd a comment, select an index, click in the comment field, and type the comment.
5. Click OKto close the dialog box.
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The selected indexes are listed. Comments are displayed above the index number.

3 _Thisareais read-only.

4

Create Recipe File

Select Recipe File Type P
PAL Sim:Float Table.f_‘YWalues You edit a recipe file by
Download Upload 0 . . ¢ .
1 selecting different options in
Strateqy File: i :  this dialog box, or by opening
T p————r— g_Cunent value of alarm variables the reci pe file in a text editor
g and making changes.
Control Engine: g
PAL Sim v '
4
Table:

_Walues w

Wwi

If you need to remove the last entries, click Undo. Clicking Undo again removes the next to last entries,
and so on. The Redo button restores entries in the same order they were removed.

To add an individual integer, float, or string tag, click Choose Variable Type, and then select a type from
the pop-up menu.
a. (lick the down-arrow, and then select a variable.

b. Clickthe Add button next to the variable you just selected to add a comment about the
variable.

The Enter Value field is disabled for uploads because the value is obtained from the control engine.
Click OK to close the Create Recipe File dialog box and confirm the configuration.

The Save As dialog box opens.

Select the filename and extension for the file.

If you want to use an extension other than .RCP or .TXT, place quotation marks around the filename (for
example, “My Recipe File.myExt").

10. Click OK, and then click OK again.

Editing a Recipe Download File

To edit a recipe file:

1. Choose Tools > Edit Recipe File to open the Select Recipe File dialog box.

Select Recipe File

Select Recipe File

File: [|

Browse...

Fecipe File Type
(O Download

(O Upload

Cancel

Help

2. Browse to the file, select the file type, and then click OK.
The Edit Recipe File dialog box appears.

3. Toedit the file, you select different options in the Edit Recipe File dialog box. (For details, see either
“Creating a Recipe Download File” on page 241 or “Creating a Recipe Upload Template”on page 243.)

Note that you cannot edit the file by typing in the Edit Recipe File view pane—the data in the pane is

read-only.
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Another alternative is to edit the recipe file in a text editor. For details, see “Basic Recipe File Format”on
page 246.

Basic Recipe File Format

NOTE: To create a new recipe file, see “Creating a Recipe Download File” on page 241 or “Creating a Recipe Upload
Template” on page 243.

When you use the Create or Edit Recipe File dialog box, you can enter only one set of indexes for each table in
a recipe file. If you want to enter another set of indexes or make other changes that you can't do using the
Create or Edit Recipe File dialog box, you can use a text editor to edit the recipe. PAC Display expects the recipe
file to follow a predefined format (syntax) according to the format described in this section. Note that the text
editor must be able to save files in ASCIl format.

After you edit the file, use the Validate Recipe File utility to check for formatting errors. For details, see
“Validating a Recipe File"on page 251.

As shown in the example below, each recipe file contains at least one PAC Control table tag followed by data
values and blank lines. Recipes may also contain comments, and a download recipe might include chart
control instructions as well.

Comment —— | /Recipe file for Peanut Butter Cookies
/
PAC Control —— | Cookie Controller:Float Table.Temps
table tag 1:300.0
2:350.0
I:Itslleeselement— 4:200.0
7:150.0
Blank lines < /End of recipe file
(two carriage
returns)
Comment ——— | /Recipe file for Peanut Butter Cookies
/
PACControl —— | Cookie Controller:Float Table.Temps
table tag 1:300.0
Table element 2:350.0
values 4:200.0
7:150.0
Blaqklines(tw< /End of recipe file
carriage
returns)

Comment Line—Any line that starts with a / (forward slash) is a comment, and is ignored by PAC Display.
Use comments to explain the recipe and to make notes.

PAC Control Tag—Identifies the table tag in the PAC Control strategy that the recipe uses. Only integer, float,
and string tags are valid tag types. The tag is in the following format:

<Control Engine Name>:<Type>.<Name>
«  <Control Engine Name> is the Opto 22 control engine name.
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«  <Type> includes one of the following keywords: Integer Table, Integer 64 Table, Integer, Float Table,
Float, String, or String Table. They identify the variable type and are separated from <Control Engine
Name> by a colon ().

«  <Name> is the PAC Control table tag name. It must be of the type specified by <Type>. A period ()
separates it from <Table Type>.

Element values—These are the values downloaded to the control engine or uploaded to the PC.

Blank line—This is a required element of a recipe file. Make sure to create a blank line at the end of a data list
and at the end of the file by entering two carriage returns.
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Example: Recipe Download File

This example has four table elements, one chart control instruction, and one single variable:

/Recipe file for Chocolate Chip Cookies

/
/My table is a table with 10 elements
/This recipe will download values to 4 elements

/
Cookie Controller:Float Table.My table
A—|34.0
Table B—|3:98.6
elements C— |35
D—|9:2.5
Single variable ——| Cookie Controller:INTEGER.My counter
4
Qhaﬂcpnud Cookie Controller:Chart.My Chart
instruction - -
RUN
/End of recipe file
/Recipe file for Chocolate Chip Cookies
/
/My table is a table with 10 elements
/This recipe will download values to 4 elements
/
Cookie Controller:Float Table.My table
A—|34.0
Table B—|3:98.6
elements C—35
D—|9:2.5
Single variable ——| Cookie Controller:INTEGER.My counter
4
cmnCWMM — | Cookie Controller:Chart.My Chart
instruction - -
RUN
/End of recipe file

The table elements in the example are used as follows:

A—No index reference is indicated for the first data value, 34.0. Therefore, by default it is assigned to zero or
My_table[Q].

B—The next line, 3:98.6, has an index reference of 3. This means the value 98.6 would be sent to My_table[3],
the fourth element of the table.
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C—The next value, 35, would be sent to My_table[4].

D—The last data line, 9:2.5, would send 2.5 to the tenth element, My_table[9]. Make sure to leave the next
line blank by entering two carriage returns after the last data line. The blank line indicates that all the data for
that particular table has been specified. Do not put blank lines between lines that contain data for the table.

Single variable. The example, Cookie_Controller:INTEGER.My_counter, would set the value of the integer tag
"My_counter" to 4.

Chart control instructions such as STOP, SUSPEND, START, and CONTINUE control the execution state of one
or more PAC Control charts when a recipe file is downloaded. You can use a chart control instruction to start a
chart that can then move downloaded table values to other program variables.

Chart control instructions have the following format:

<Control Engine Name>:Chart.<Chart Name>
<Chart State>

«  <Control Engine Name> is the name of the Opto 22 control engine.

«  Chart identifies the keyword identifying this line as a chart instruction. “Chart”is separated from
<Control Engine Name> by a colon ().

«  <Chart Name> is the PAC Control strategy chart name, and is separated from Chart by a period (.).

«  <Chart State> is the chart instruction, and must include one of the following keywords: STOP, SUSPEND,
START, and CONTINUE. This instruction must be on the line following the <Chart Name>. The last line in
a chart control instruction must be a blank line and contain only a carriage return.

Example: Recipe Upload File

A recipe upload file tells PAC Display which table elements to upload to a destination file on the PC or (Pro
only) a database table. A recipe upload file uses the basic recipe file format (see page 246), but does not
usually contain data.

A recipe upload file must have at least one table element index and an index for every table element to be
uploaded. The example below shows that you can include table element indexes for multiple tables, as long
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as you put a blank line before each new section of data and at the end of the file.
You create a blank line by pressing the Enter key twice at the end of a line.

Table element
indexes

Table element
indexes
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/Recipe file for macadamia Nut Cookies
/

Cookie Controller:Float Table.Temps

0:

1:

2:

34:

40:

| 41:

Cookie Controller:Float Table.My table
0:
2:
5:

/End of upload format file

/Recipe file for macadamia Nut Cookies
/

Cookie Controller:Float Table.Temps

0:

1:

2:

34:

40:

41:

Cookie Controller:Float Table.My table
0:
2:
5:

/End of upload format file
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Reusing a Destination File

After an upload, the destination file contains data, and it may contain chart control instructions.
To save time, you can reuse a destination file as a recipe download file, because the control engine ignores the
data and any control instructions.

/Recipe file for Macadamia Nut Cookies

/
My Controller:Integer Table.My Int Table

0: 1
/100

Data My Controller:Float Table.My Float Table
0. 1.234
1: 100.567
Chart control Cookie Controller:Chart.My Chart
instructions RUN
/End of download recipe file
/Recipe file for macadamia Nut Cookies
/
My Controller:Integer Table.My Int Table
0: 1
177100
Data My Controller:Float Table.My Float Table
O 1.234
1: 100.567
Chart control Cookie Controller:Chart.My Chart
instructions [ RUN
/End of download recipe file

Validating a Recipe File

If you manually edit a recipe file, use the Validate Recipe File utility to make sure you haven't made any
formatting errors. The utility validates the format of a recipe file, including the structure, tags, and index values
by checking the following:

«  Arethe lines correctly formatted?
Are values specified in a download file?
Are colons present in an upload template file?

« Isthe referenced control engine part of the current PAC Display project?
«  (an the strategy file referenced by the controller be opened?
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«  Arethe available types correctly spelled (for example, “Integer Table’, “Integer 64 Table’, “Float Table”,
“String Table” or “Chart”)?

«  Arethe table and/or chart names valid?

« Ifatableisreferenced, is an index out of range?

«  Arecarriage return / line feed pairs properly placed?
«  Arethere blank lines between table / chart entries?

NOTE: The utility does not test whether the values for a table in a download file match the table type.

1. Choose Tools > Validate Recipe File to open the Validation dialog box.

Validate Recipe File

Fiecipe File
Select Recipe Type: (O) Download () Upload

Select Recipe File: Browse. .

Results:

Edit Fecipe File... Fie-test file

Cancel Help

Select the type of file to be validated, either Upload or Download.
3. Click Browse.

The Open Recipe File dialog box opens.
4. Locate the recipe file, and then click Open.

The utility validates the file and displays the results.

5. [Ifthere are any errors, click Edit Recipe File to open a text editor and make the corrections. Save the file,
and then use the Re-test button to check the file again.

6. Click OKto close the dialog box.

Configuring a Recipe Upload

To configure a recipe to upload using a trigger:
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dialog box.
Recipe Managers
Download Recipes
Add...
Modify...
Delete
Upload Recipes
Add...
Modify...
Delete
Cancel Help
2. Inthe Upload Recipes section of the Recipe Managers dialog box:
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To create a new upload recipe manager, click Add.
To change an existing upload recipe manager, highlight it and click Modify.
To remove an existing upload recipe manager, highlight it and click Delete.

From PAC Display Configurator’s menu bar, click Configure > Recipes to open the Recipe Managers

If you are creating or changing an upload recipe manager, the Upload Recipe Manager dialog box appears.
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Upload Recipe Manager Dialog Box

Uplead Recipe Manager @

A 4 —Mame: |
Format File
Directony: — B

Make Path Relative to Project [——— C

File: M arne:

D =% | E
@) Fixed name Fived Mame: Extenzion: rcp c

~) Prarmpt for nare [ . '

() From strateqy - G
Destination File (In Pro only, the label

Directony: says “Log To."

Make Path Relative to Project [

H - File: M arme: |

@ Fined name Fined Marne: Extension: rcp L J
(1 Prompt for name p

() From strateqy =" | K
Trigger

L ks
M — Maotifization enabled

N—++ ok || cancel || Hep |

(A) Name. Enter the name of the upload recipe manager. This name is used to refer to the recipe group
you're configuring in the Configurator. The name in this field must be different from all recipe managers in this
project.

(B) Format File Directory. Choose the directory the recipe file resides in. You can type the directory in the
edit box or click Browse to quickly find and enter the path.

(C) Make Path Relative to Project. When selected, if you copy the project and recipe manager files to a
different computer, PAC Display will look in the same relative location to find the recipe manager files in
Configurator and Runtime.

For example, if the project is saved in C:\proj\ and you configure recipe manager files to be in C:\proj\recipes\,
then the relative path would be this: \recipes\

If you then saved the project to C:\temp\newproj\, PAC Display would look for recipe manager files in the new
location’s relative path: C:\temp\newproj\recipes\

(D) File Name. Choose the source of the recipe file name.

«  Ifyou choose Fixed name, E is highlighted.

«  Ifyou choose Prompt for name, the operator will be asked for the name of the recipe file to be uploaded.
«  Ifyou choose From strategy, F is highlighted.

(E) Fixed Name. If Fixed name was selected in C, enter the name of the recipe file located in directory B.
Notice the file extension is .rcp.
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(F) String Name. If From strategy was selected in C, click the Tag Selection button [ 2] to enter a tagname
of type string that contains the recipe file name. See “Configuring Tags” on page 74 for more information
about using tags.

(G) File Directory. Click Browse and choose the directory location of the recipe file that will (uploads only)
receive the data or (downloads only) be the source of the data.

(Pro only) In PAC Display Professional, Browse is replaced by a “Log To"button. (For a recipe download file, the
button is “Log From.”)

Click Log To (or Log From) to select whether to log the data to (or from) an ASClI file or a database table. For
details on logging to or from a database table, see page 257.

(H) File Name. Choose the source of the recipe file name.
«  Ifyou choose Fixed name, I is highlighted.

«  Ifyou choose Prompt for name, the operator will be asked for the name of the recipe file to be uploaded
to.

«  If From strategy string is selected, K'is highlighted.
(1) Fixed Name. If Fixed name was selected in D, enter the name of the recipe file located in directory B.

(J) Extension. Specify the file extension for the recipe files available to this dynamic attribute by entering
the extension in the File Extension field. The extension must be one to three characters long and must not
contain a period or DOS wild card characters.

If Fixed Name is checked, this extension will append to the File Name entry to create the name for the recipe
file. If Prompt For Name is checked, this extension will be used as a filter to select the files for display in a file
selection dialog box when Runtime executes this dynamic attribute. However, you may override this filter if
you wish to select a file with a different extension.

(K) String Name. If From strategy was selected in C, click the Tag Selection button [ 7] to enter a tagname
of type string that contains the recipe file name. See “Configuring Tags” on page 74 for more information
about using tags.

(L) Trigger (Trigger-based recipe upload). Click Trigger to select a PAC Control tagname that will
trigger the upload recipe action. The trigger can be activated only from a non-triggered state. See “Selecting a
Trigger to Start the Recipe Upload/Download”on page 256 to learn how to configure this trigger. Pressing the
Trigger button displays the Recipe Trigger Configuration dialog box.

(M) Notification (Trigger-based recipe upload). Click Notification to assign a value to a tag when a
recipe has successfully uploaded. Pressing this button displays the Recipe Upload Completed Notification
dialog box. Check the Enabled box to make notification active. See “Notification When Recipe Has Been
Downloaded/Uploaded”on page 257 for more information.

(N) OK. Click OK to save your settings and close the dialog box.

Configuring a Recipe Download

Use the Recipe Manager dialog box to configure conditions that trigger a recipe download or upload.

In either the Download Recipes or Upload Recipes section of the dialog box:
«  (lick Add to create a new recipe manager.

»  Tochange an existing recipe manager, highlight it and click Modify.

«  Toremove an existing recipe manager, highlight it and click Delete.
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When you click Add or Modify, the Recipe Manager dialog box appears.

Download Recipe Manager Dialog Box

Download Recipe Manager @ G InPro only,
the label says
A ——Hame: | “Log From.”
Recipe File

Make Path Relative to Project [S5—1— C

D —— File Name E
@) Fixed name Fived Name: Estenzior:  rcp
() Prompt far name
_ &1 F
() From strateqy
Trigger

L
M — Matification enabled

N——[— QE. H Cancel H Help l

For descriptions of the items on this dialog box, please see “Upload Recipe Manager Dialog Box"on page 254.

Selecting a Trigger to Start the Recipe Upload/Download

1. Toselect the trigger that will start a recipe upload or download, click Trigger in the Download/Upload
Recipe Manager dialog box.
The Recipe Trigger Configuration dialog box appears.

Recipe Trigger Configuration *

Tag

M arme:

| 2]

Setup by Dizcrete Current Y alue
() Discrete On 5w I:I
(®) Current Walue ulii
ok Cancel Help

2. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to choose a tag to
trigger the recipe upload/download.

3. Select Discrete or Current value in the Setup by group. Current value sets the tag value that will trigger
the recipe download/upload. Select an operator in the drop-down menu, and then enter a value to
compare the tag to. Discrete makes the tag's on or off state trigger the application.

256 PAC Display User's Guide



@

CHAPTER 9: CONFIGURING TRIGGER-BASED EVENTS

Notification When Recipe Has Been Downloaded/Uploaded

1. Inthe Download/Upload Recipe Manager dialog box, click Notification to open the Recipe Download
Completed Notification dialog box.

Recipe Download Completed Motification >

Tag

M arme:

| L2

Setup By Dizcrete Current Y alue
() Discrete Set ®5et () Offset
(®) Curent Value Clear walue Oub I:I
Toggle
Ok Cancel Help

2. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag as the flag to indicate the recipe upload or download was successful.

3. Select Discrete or Current Value in the Setup By group.

Discrete sets, clears, or toggles the tag's on or off state. Current Value sets the tag value. To set a Current
Value, select Set or Offset in the Current Values group and then enter a tag value.

Logging a Recipe File to or from a Database

(Pro only) The Directory fields in the Recipe Manager and Dynamic Attribute - Recipe dialog boxes have a
“Log To" (or “Log From”) button. (In PAC Display Basic, the label says “Browse.”) When you click the button, you
can choose to load the recipe file to (or from) a database.

This image shows the Directory field configured for a recipe download:

Download Recipe Manager

Mame: |My_Recipe_Download

Fecipe File

Directory: | Using Databaze T able: RecipeDownload

Recipe file downloads can be used to collect snapshots of your variable data at specific points in time; uploads
are useful for copying data from a database table to variables in a strategy, and for restoring data to a strategy.
To create or configure a recipe file, see:

«  “Creating a Recipe Download File”on page 241 and “Configuring a Recipe Upload”on page 252.
«  "Creating a Recipe Upload Template” on page 243 and “Configuring a Recipe Upload”on page 252.

To log a recipe to or from a database:

1. Make sure you have configured the ODBC data source to be used with PAC Display. For details, see
page 55.

2. Toopen the Open either:
- The Recipe Manager dialog box (Configure > Recipes > Add or Modify); or

- The Dynamic Attribute dialog box (Edit > Edit Dynamic Attribute, and then, in the Operator Drive
Attributes area, double-click either Download Recipe or Upload Recipe).
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3. (lickLog To (or Log From), and then select Database in the pop-up menu.
In the Download (or Upload) Recipe Manager dialog box, click Log to, and then select Log to Database
from the pop-up menu. The Database Table dialog box opens, displaying a default table and columns.
5. Inthe Table Name field, you can type the name of a different database table, but the database table must
contain the columns listed in the Table Columns pane. You cannot change the column names or column
types.

CONFIGURING ALARM POINTS

You can incorporate alarm features into your operator interface by adding a PAC Display alarm graphic (see
also “Adding Alarm Graphics”on page 273). In a project, alarm graphics monitor alarm points associated with
PAC Control tags, and alert the operator when predefined alarm conditions are reached. Alarm information
can be logged to a file or sent to a printer.

Like a historical log point, an alarm point is linked to a PAC Control tag. When an alarm point matches a
defined alarm state, it is displayed on all alarm graphics that include that alarm point. If configured to do so, an
alarm point can also be sent to any configured file or printer log.

Once it is set up, an alarm point can be included in any number of alarm graphics in a PAC Display project.
(Data for an alarm point can still be collected if the alarm point has not been included in a graphic.) You can
easily generate a report that lists all the alarm points for a project; see “Viewing Tags and Dynamic Attributes”
on page 180 for more information.

1. To configure an alarm point, choose Configure > Alarm Points.

The Alarm Points dialog box lists configured alarm points. The “Ref Count” column shows the number of
alarm windows in which each alarm point is used.

Alarm Points
Mame Ref Count Add...
Dough Weszel Prezsure 1] Madify...
Oven Temperature 0
Delete
Duplicate
Import...
E spaort
Cancel Help Ref Counts

2. Do one of the following:
- (lick Add to create a new alarm point.
— Highlight an existing alarm point and click Modify to change it.

- Highlight one or more alarm points and click Delete to remove them. To select multiple alarm
points, hold down either the Shift key (for selecting contiguous items) or the Ctrl key (for selecting
non-contiguous items) and click an alarm point name.
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Highlight one or more alarm points and click Duplicate. In the dialog box that appears for each
alarm point, enter a new name, and then click OK to add each duplicate to the list.

Mew AlarmPoint Mame

Enter MNews Alarmn Point N are

*

BIT01

Cancel

Click Import to import alarm points from a comma-delimited file. Or, click Export to export alarm
points to a comma-delimited file. See, “Importing Alarm Points”on page 262.

Click Ref Counts to update the values in the Reference Count column.

If you are creating or changing an alarm point, the Alarm Point dialog box appears.

Alarm Point Dialog Box

Alarm Point =
Setup Discrete Value  Control Engines
A Hame: || |
B+ Taq: | | 1 — C

D—— Husteresiz: I:I

E ——SetupBy

Motification Options

- F
O Disorete Alamn... [JEnabled &lamn Clear | [JEnabled
(®) Current Value : . G
() Contraller Status &cknowledge.. | []Enabled [] Display Dislog when &lamed. H
m Shova W arning State |
K ——FEnable J
(®) Always Enabled
() Condition; | | Madify. . L

M_|

Sound Options

Sound File: |

Browze. .. Clear

[J Play Sound ‘wWhen &larmed

take Path Relative to Project

| 0K | Cancel Help

(A) Name. Enter a name for the alarm point here. The name of each alarm point in a project must be unique
and must be less than 128 characters. The PAC Control tag name appears by default.

(B) Tag. Displays the name of the PAC Control tag that you select with the Tag Selection button.

(C) Tag Selection Button. Click the Tag Selection button [ 7] to select a PAC Control tag for the alarm
point. Note that the choice of tags available is determined by the type of tag you select in Setup By (E).

(D) Hysteresis. Enter a hysteresis value that is applied to the tag value of a triggered alarm point as it moves
toward the Normal alarm value. The alarm point will remain in the triggered state until it reaches its threshold
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value plus the hysteresis value (if the alarm point is below Normal) or minus the hysteresis value (if the alarm
point is above Normal).

For example, for a triggered HiHi alarm point, suppose the threshold value is 50, the hysteresis value is 5, and
the current triggered alarm point value is 53. If the next tag read has a value of 49 (that is, it has descended
past the configured threshold of 50), the alarm point will still remain in the triggered HiHi state until the tag
reading is less than 45.

(E) Setup By. Select the type of tag to be linked to the alarm point.

«  Choose Discrete for discrete tags, such as a digital input. Selecting this option enables the Discrete page
in the Alarm Point dialog box. See “Entering Discrete Alarm Conditions”on page 270 for configuration
information.

«  Choose Value for analog points, floats, or similar values. Selecting this option enables the Value page in
the Alarm Point dialog box. See “Entering Alarm Values”on page 271 for configuration information.

«  Choose Control Engine Status to link the status of a control engine to the alarm point. The alarm will be
triggered whenever the linked control engine is not in Attached state. See “Setting Control Engine Status
Alarm Points”on page 272 for configuration information.

(F) Alarm. Click here to display the Alarm Notification dialog box, where you can have a specified value
written to a selected tag when the alarm point enters an alarm condition. See “Alarm, Acknowledge, and
Alarm Clear Notifications” below for information on setting up alarm notification.

Select Enabled to make Alarm Notification active. (You can't select Enabled until Alarm Notification is
configured.)

(G) Alarm Cleatr. Click here to display the Alarm Clear Notification dialog box. Use this dialog box to have a
tag value be set or cleared when the current alarm returns to Normal from an alarmed state. See “Alarm,
Acknowledge, and Alarm Clear Notifications”below for information on setting up alarm notification.

Select Enabled to make Alarm Clear Notification active. (You can't select Enabled until Alarm Clear is
configured.)

(H) Display Dialog When Alarmed. Check this box to display the alarm dialog when the alarm point
goes into an alarmed state in Runtime. This check box defaults to the current Display Message Box for New
Alarm Points setting in the Alarming Setup dialog. See “Alarm Runtime and User Options”on page 277 to
adjust this setting globally.

NOTE: Setting or clearing the Display Message Box for New Alarm Points setting in the Alarming Setup dialog will set
or clear this option for all alarm points. Therefore, it is highly recommended to set this global default first, and then
adjust the setting on a per-alarm point basis.

(1) Show Warning State. Check this option to enable this alarm point to display in the alarm graphic when
this point enters the warning state.

An alarm point is considered to be in a warning state when in one or both of the following conditions:

«  Anpersistence time has been configured for the alarm point (see “Entering Discrete Alarm Conditions”on
page 270 and “Entering Alarm Values”on page 271 and the alarm has been triggered, but is waiting for
the persistence time to expire.

« Analarm point has the Re-Alarm Time option configured and is still in the triggered state after being
acknowledged. To see the Re-Alarm option, select Configure > Alarm Points. Then click the Add or
Moadify button, click the Discrete or Value tab (depending on the alarm type), and click one of the More
buttons.

See also “Alarm Runtime and User Options”on page 277.
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(J) Acknowledge. Click here to display the Acknowledge Notification dialog box, where you can have a
specified value written to a selected tag when the alarm point is acknowledged by the operator. See “Alarm,
Acknowledge, and Alarm Clear Notifications”below for information on setting up acknowledge notification.

Select Enabled to make Acknowledge Notification active. (You can't select Enabled until Acknowledge
Notification is configured.)

(K) Enable. Choose Condition to make the alarm point dependent on the value of another tag. Click the
Modify button (J) to select the tag and define the conditions it needs to meet.

Select Always Enabled for the alarm point not to be dependent on the value of another PAC Control tag.

(L) Modify. If you've selected Condition under Enable (I) to make the alarm point dependent on the value of
another tag, click Modify and configure the tag and conditions in the Alarm Point Conditional Enabling Setup
dialog box that appears. See “Setting Conditional Alarm Points” on page 269 for configuration information.

(M) Sound Options. Click the Browse button to select a sound file in a specific folder. Make sure Play Sound
When Alarmed is selected. Otherwise, the sound will not play when the point is in an alarmed state.

Click the Clear button to remove the sound file.
See also, “Configuring a Sound”on page 237.

NOTES: If no sound file is configured, and the Play Sound When Alarmed check box is selected (the default), then the
global sound file will be used. If no global sound file has been configured a message appears warning you that no
sound will play when this alarm point is in an alarmed state unless you select a sound file either for the alarm point
or for the global sound. The global sound file is configured in the Configure > Alarming Setup dialog on the Sound
tab.

If you do not select a sound file for this alarm point and no global sound file is specified on the Sound tab of the
Configure > Alarming Setup dialog box, you cannot enable this option and an error message will appear if you try.

If an alarm point has been configured to play the global sound file, but then the global sound file is cleared in the
Sound tab of the Configure > Alarming Setup dialog box, a message will warn you that no sound will play when an
alarm pointis in an alarmed state unless you configure a default sound or change the sound options for the alarm
points.

(N) OK. Click OK to save your settings and close the dialog box.

Now we'll look at the additional steps needed to complete the settings in the Setup, Discrete, and Value pages
of the Alarm Point dialog box.

Exporting Alarm Points to a Binary or Comma-Delimited File

Alarm Points may be exported from a project to either a binary file or a comma-delimited file, and then
imported from the file into another project. Both projects must refer to the same tag database(s) for the alarm
points that are to be imported. The database may be a PAC Control, ioControl (Pro only), or OptoControl tag
database file.

If you want to export and import alarm points quickly, use a binary file (the Export to Subfolder command) to
export and import alarm points. However, if you want to use a spreadsheet program (such as Excel) to view,
edit, or create the attributes of the alarm points before importing them into another project, use a
comma-delimited file.

To export one or more alarm points to a file:
1. In Configurator, choose Configure > Alarm Points to display the Alarm Points dialog box.
2. Select one or more alarm points from the list.
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3. (lick Export, and then choose from the pop-up menu either Export to Subfolder (for a binary file) or
Export to Comma-Delimited File.

Alarm Points
Mame Ref Count Add...
L] . Maodiy...
BITO1 [
Contraller 1 Delete
FLOAT_1 3
FLOAT_Z2 3
INT_1 3 )
INT 2 5 Duplicate
Import....
Export
Export to Subfolder
Export to Cormnma Delimited File...
Cancel Help Ref Counts

If you select Export to Subfolder (for a binary file), a message confirms success.

Export Alarm Points *

Alarm Points have been exported to the 'Exported AlarmPoints' subfolder of the
current project.

Each alarm point is automatically exported in a separate file to the Exported Alarm Points subfolder of the
current project. These binary files have the format:

<Name of Alarm Point>.ape
Readable text files are also created that provide details for each exported alarm point.

If you select Export to Comma-Delimited File, the Export Alarm Points dialog box opens. Select the
target directory, name the file, and click Save. These files have the format:

<Name you assign>.adl

NOTE: Ifyou select the same file again later, you will have the option of overwriting the existing file. If you select
No, the alarm points are appended to the selected file.

If there are errors, the message displays up to 10 alarm points in an error list.

To import the alarm points into another project, see the next section, “Importing Alarm Points.”

Importing Alarm Points

Alarm Points may be imported from one project into another project that both refer to the same tag database.
Before importing, you must export the alarm points to a file as described in “Exporting Alarm Points to a Binary
or Comma-Delimited File”on page 261.

1. In Configurator, choose Configure > Alarm Points to open the Alarm Points dialog box.
2. Click the Import button.
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3. Select either Import from Subfolder (for a binary file) or Import from Comma-Delimited File from the

pop-up menu.
Alarm Points
Mame Ref Count Add...
A 3 Mocily. .
BITO! =
Controller 1 Delete
FLOAT_1 3
FLOAT_2 3
INT_1 3 "
INT_2 5 Duplicate
Impot...
Export Import from Subfolder
Import from Comma Delimited File...
Cancel Help Fief Counts

For a binary file, an Import Alarm Point dialog opens showing exported alarm point files in the Exported
Alarm Points subfolder under the current project.

For a comma-delimited file, navigate to the folder containing the file.

4. Forabinary file, select one or more alarm point files (.ape) to import. Or, for a comma-delimited file,
select the single file (.adl) to import.

5. Click Open.The alarm points are imported and added to the list.
Click OK to confirm.

NOTE: If there are errors during the import, PAC Display displays a message indicating the error. The import fails
at the first error. PAC Display makes no attempt to guess what the intended field should contain nor does it try
to correct the error or present possible solutions. If an error is encountered, check the contents of each field with
the table in "Tag Definition Format.” The table details the possible values for the 160 fields of each alarm point.

Structure of Alarm Point Comma-Delimited File

The structure of the comma-delimited file for alarm points is described below. There are a total of 165 fields.

Tag Definition Format. The following table describes a single Tag definition in the comma-delimited file.
There are ten fields, all of which are required for tags that are configured.

If tags are not configured (i.e., no alarm point notifications, conditional tag, HiHi tag, etc.), only the first three
fields may be blank. The remaining fields (4-10) must have the default values indicated.

Field Description Values
1 Control Engine Name The case-sensitive name of the control engine.

The case-sensitive name of the item.
2 Iltem Name NOTE: If Configuring a Controller Status alarm point, this value
must be the same as the Control Engine Name.

The case-sensitive name of field (Value, Gain, Counts, etc.).
3 Field Type NOTE: If Configuring a Controller Status alarm point, this value
must be “# Of Errors”.

4 Element Index Element index or —1 if not used.

5 Bit Index Bit index or 255 if not used.

6 Start Index Start Index or —1 if not used.

7 Number of Elements Number of elements or —1 if not used.
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Field
8

10

Description

Refresh Group

Reserved1

Reserved2

Values
0-based index of refresh group (0 — 13) or 0 if not used.

If file has been exported, do not modify this value.
For a new alarm point, must be —1.

If file has been exported, do not modify this value.
For a new alarm point, must be 0.

Notification Definition Format. This table describes the definition for the notifications (Alarm,
Acknowledge, and Clear) used in describing an alarm point. There are a total of 13 fields per notification.

NOTE: If notifications are not configured for an alarm point, the seven required tag fields (fields 4-10 in the previous
table) are still required.

Field
1-10

11

12

13

Description

Tag Description

Send Type

Send Value

Enabled Flag

Values
See “Tag Definition Format” on page 263

Must be one of the following:
Set (the default if not configured)
Discrete Set

Clear

Toggle

Offset

The value or offset if configured, blank if not needed

Must be ENABLED or NOT_ENABLED (the default if not
configured)

Alarm Point Definition Format. The entire alarm point definition file is described below.

Field
1

2-1

12

13

14-26

27-39

40-52

264

Description

Alarm Point Name
Alarm Point Tag

Deadband

Setup Type

Acknowledge Notification

Alarm Notification

Clear Notification

Display Dialog When Alarmed?
Include Warning State

Always Enabled?

Conditional Tag

PAC Display User's Guide

Values Required
The name of the alarm point Yes
See “Tag Definition Format” on
Yes
page 263
Deadband Value or 0 if not used Yes
Must be one of the following:
Current Value
. Yes
Discrete
Controller
See “Notification Definition Format” on "
No
page 264
See “Notification Definition Format” on "
No
page 264
See “Notification Definition Format” on .
No
page 264
0if No, 1if Yes Yes
0if No, 1if Yes Yes
0if No, 1if Yes Yes
See “Tag Definition Format” on No*

page 263



Field

66

67

68

69

70

71

72

73

74

75

76

77

78

79

80

81

82

83

84-93

94

95

96

97

98

Description

Conditional Tag Comparison
Condition

Conditional Value Compare
Alarm Point Specific Sound File
Play Sound when Alarmed?

Discrete — Alarm When:

Discrete Alarm Priority
Discrete Alarm Comment

Discrete Normal Enabled

Discrete Normal Priority

Discrete Normal Comment

Discrete Persistence Time
(msec)

RESERVED

Discrete Re-Alarm time (msec)
RESERVED

HiHi Enabled?

HiHi Value

HiHi Priority

HiHi - Use Tag?

HiHi Tag

HiHi Comment

HiHi Runtime Adjustable?

HiHi Persistence Time (msec)

RESERVED

HiHi Re-Alarm Time (msec)
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Values

Must be one of the following numbers:
0 - Not Used or Greater Than (>)

1 —Equal To (=)

2 — Less Than (<)

3 — Greater or Equal (>=)

4 — Less or Equal (<=)

5 — ON (Discrete)

6 — OFF (Discrete)

0 or value used

Full path to sound file or blank if not
used

0 =No (or N/A) ;1 =Yes

0 = Off/False (or Not Used);
1 =0n/True

Priority or 0 if Not Used

Comment or blank if Not Used***

0 = False (or Not Used)
1="True

Priority or O if Not Used

Comment or blank if Not Used***

Persistence time, in milliseconds, or 0
if not used

MUST BE 0

Re-alarm time, in milliseconds, or 0 if
not used

MUST BE 0

0 = No (default); 1 = Yes

HiHi value or 0 if Not Used

Priority or 0 if Not Used

0 if FALSE 1 if TRUE

See “Tag Definition Format” on
page 263

Comment or Blank if Not Used***

0 = No or if Not Used,;
1 =True

Persistence time, in milliseconds, or 0
if not used

MUST BE 0

Re-alarm time, in milliseconds, or 0 if
Not Used

PAC Display User's Guide

Required

Yes

No
No

Yes

Yes, even if not a
discrete alarm point

Yes, even if not a
discrete alarm point

No

Yes, even if not a
discrete alarm point

Yes, even if not a
discrete alarm point

No

Yes, even if not a
discrete alarm point

Yes, even if not a
discrete alarm point

Yes, even if not a
discrete alarm point

Yes, even if not a
discrete alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes
NO**

No

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point
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Field

99

100

101

102

103

104-113

114

115

116

17

118

119

120

121

122

123

124

125

126

127-136

137

138

139

140

141

142

143

Description

RESERVED

Hi Enabled?

Hi Value

Hi Priority

Hi - Use Tag?
Hi Tag

Hi Comment

Hi Runtime Adjustable?

Hi Persistence Time (msec)

RESERVED

Hi Re-Alarm Time (msec)

RESERVED

Normal Enabled?

Normal Priority
Normal Comment

Lo Enabled?

Lo Value

Lo Priority

Lo Use Tag?
Lo Tag

Lo Comment

Lo Runtime Adjustable?

Lo Persistence Time (msec)

RESERVED

Lo Re-Alarm Time (msec)

RESERVED

LoLo Enabled?
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Values

MUST BE 0

0 = No (default); 1 = Yes

Hi value or 0 if Not Used

Priority or O if Not Used

0 if FALSE 1 if TRUE

See “Tag Definition Format” on
page 263

Comment or Blank if Not Used***

0 = No or if Not Used;
1="True

Persistence time, in milliseconds, or 0

if not used

MUST BE 0

Re-alarm time, in milliseconds, or 0 if

Not Used
MUST BE 0

0 = No or if Not Used;
1=Yes

Priority or 0 if Not Used
Comment or Blank if Not Used***

0 = No (default); 1 = Yes

Lo value or 0 if Not Used

Priority or 0 if Not Used

0 if FALSE 1 if TRUE
See Tag Description
Comment or Blank if Not Used***

0 = No or if Not Used;
1 =True

Persistence time, in milliseconds, or 0

if not used

MUST BE 0

Re-alarm time, in milliseconds, or 0 if

Not Used

MUST BE 0

0 = No (default); 1 = Yes

Required

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes
NO**

No

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

No

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes
NO**
No

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point

Yes, even if not a
Value alarm point
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Field Description Values Required
144 Lolo Value LoLo value or 0 if Not Used Yes, even ifnot a
Value alarm point
145 LoLo Priority Priority or O if Not Used e, el i &
Value alarm point

146 LoLo-UseTag 0 if FALSE 1 if TRUE Yes

See “Tag Definition Format” on

147-156 LolLo Tag page 263 No
157 LoLo Comment Comment or Blank if Not Used*** No
158 LoLo Runtime Adjustable? 0 i No or if Not Used; Yes, even if not. a
1 =True Value alarm point

Persistence time, in milliseconds, or 0  Yes, even if not a

159 LoLo Persistence Time (msec) if not used Value alarm point
160  RESERVED MUST BE 0 Yes, evenifnot a
Value alarm point
161 LoLo Re-Alarm Time (msec) Re-alarm time, in milliseconds, or 0 if  Yes, even if not. a
Not Used Value alarm point
162  RESERVED MUST BE 0 Yes, even ifnot a
Value alarm point
163 Control Engine Name for Con- Control Engine Name or blank if Not No
troller Status Alarm Point Used
164 Last Known Value Priority Priority or 99998 if Not Used Yes
165 Comm Failure Priority Priority or 99999 if Not Used Yes

* Even if no notifications are configured, there are required fields. See “Notification Definition Format” on
page 264.

** Even if the tag is not configured, there are required fields. See “Tag Definition Format” on page 263.
*** Alarm Point Comments may not contain commas.

Sample alarm point entries:

Controller Status,10.192.54.68,10.192.54.68,# Of
Errors,-1,255,-1,-1,0,-1,37,0.000000,Controller,,,,-1,255,-1,-1,0,-1,0, Se
t,,NOT_ ENABLED,,,,-1,255,-1,-1,0,-1,0,Set,,NOT ENABLED,,,,-1,255,-1,-1,0,
-1,0,Set,,NOT_ENABLED,O0,0,1,,,,-1,255,-1,-1,0,-1,0,0,0.000000,C:\Projects
\GLASS.WAV,0,0,0,,1,0,,0,0,0,22,1,0.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,
0,31588528,0,0,1,0.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,0,0,0,17,1,0,,1,0
.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,0,22,0,31588528,1,0.000000,0,0,,,,-
1,255,-1,-1,0,-1,0,,0,0,433212520,0,0,10.192.54.68,99998,99999

10.192.54.68:MyTable[1].BIT01,10.192.54.68,MyTable,,1,1,-1,-1,0,0,5,0.000
000, Discrete,,,,-1,255,-1,-1,0,-1,0,Set, ,NOT_ ENABLED,,,,-1,255,-1,-1,0,-1
,0,Set,,NOT_ENABLED,,,,-1,255,-1,-1,0,-1,0,Set,,NOT_ENABLED,O0,0,1,,,,-1,2
55,-1,-1,0,-1,0,0,0.000000,C:\Projects\DRUMROLL.WAV,1,1,0,,1,0,,0,0,0,0,1
,0.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,0,0,0,0,1,0.000000,0,0,,,,-1,255,
-1,-1,0,-1,0,,0,0,0,0,0,1,0,,1,0.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,0,0
,0,0,1,0.000000,0,0,,,,-1,255,-1,-1,0,-1,0,,0,0,0,0,0,,99998,99999

Alarm, Acknowledge, and Alarm Clear Notifications

You can have a value sent to a tag when any of the following alarm events occur:
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«  Analarm occurs
«  Anactive alarm is acknowledged
o Anactive alarm returns to Normal from an alarmed state.

To configure an alarm point for these events, click Alarm, Alarm Clear, or Acknowledge in the Alarm Point
dialog box (Configure > Alarm Points > Add or Modify button > Set up tab).

Alarm Point *

Setup  Discrete  Value  Control Engines

Name:  [BITDI |

Tag  [PACSmBITS_1.BITOT R

Hysteresis: l:l

Setup By Motification Options

@ Discrete Alarm... [JEnabled Alarm Clear []Enabled
(O Curent Yalue - :
O Controllr Status Acknowledge... | []Enabled Dizplay Dialog When Alarmed.

[ Show Wwamning State

Enable
(® Always Enabled

O Contior: | Modify...

Sound Options
Sound File: |

Browse... Clear

Play Sound When Alarmed 4 ake Path Relative to Project

Cancel Help

The Alarm Notification, Alarm Clear, or Acknowledge Notification dialog box appears. These dialog boxes are
identical. (The Alarm Notification dialog box is shown below.)

Alarm Motification 4

Tag

M arme:

| L2

Setup By Dizcrete Current Y alue
() Discrete Set ®5et () Offset
(®) Curent Value Clear walue Oub I:I
Toggle
Ok Cancel Help

1. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name.

2. Inthe Setup By group, select Discrete or Value.

Discrete specifies an on/off trigger state for the selected tag. After you select Discrete, define the trigger
value by choosing one of the following options:

- Set—Switches the trigger state to On.
—  Clear—Switches the trigger state to Off.
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- Toggle—Switches the trigger state from its current condition to the opposite (for example, On is
switched to Off).

Value defines the floating point or integer value that is written to the tag. After you select Value, define
the value by choosing one of the following options, then entering a value in the Value Out field:

- Set—Replaces the tag’s current value with the value you enter in the Value Out field.
- Offset—Adds the value you enter in the Value Out field to the tag’s current value.

3. (lick OKto save your settings and close the dialog box.

Setting Conditional Alarm Points

1. To make the alarm point dependent on the value of another tag, select Condition in the Alarm Point >
Setup tab, then click Modify.

Setup  Discrete  Value Control Engines

Name:  [BITDI |

Tag  [PACSmBITS_1.BITOT Rk

‘ Hysteresis: l:l ,

Setup By Motification Options
(@ Discrete

(O Curent Yalue 5 :
() Cantraller Status Acknowledge... | [] Enabled Dizplay Dialog When Alarmed.

[ Show wamning State |

Alarm... [ Enabled Alarm Clear [ Enabled

Enable
(L lnans Fnahblad

( @® Contior: | Modify... ) :

Sound Options

Sound File: | | Browse... Clear

Play Sound When Alarmed ake Path Relative to Project

| oK Cancel Help

The Alarm Point Conditional Enabling Setup dialog box opens.

Alarm Point Conditienal Enabling Setup *

Tag

Mame;

| 2]

Setup by Dizcrete Current Y alue
() Discrete On 3w D
(®) Cument Walue o

Ok Cancel Help

2. Configure the tag and conditions.

3. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag. This tag's value will be compared to a value you define.
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4. Select Discrete or Current value in the Setup by group. Current Value sets the tag value that will trigger
the alarm point. Select an operator in the drop-down menu, and then enter a value to compare the tag
to. Discrete makes the tag’s on or off state trigger the alarm point.

NOTE: Triggers are edge sensitive, and activate only on a positive transition from a non-triggered state.

5. (Click OKto save your settings and close the dialog box.

Entering Discrete Alarm Conditions

If you selected Discrete in the Setup by field on the Alarm Point Setup page, complete the alarm point setup
by configuring the alarm’s state in the Discrete page.

Alarm Point *
Setup Discrete  Value  Control Engines

dlam when: (O True/On (@) Falses/0F

Pricrity: Comment;
Alarm: |EED | | |
MNormal: |D | | |

tare...

Cancel Help

1. Toselect the state of the alarm condition tag, select True/On to have the alarm point be in the alarm state
when the associated tag is “on”for Discretes, or “true”for integer bits. Select False/Off to have the alarm
point be in the alarm state when the associated tag is “off"for Discretes or “false”for integer bits.

2. Select the check box next to Normal to have the normal state displayed in history windows and logs. The
normal state is the opposite of the alarm state.

3. Whenan alarm point state occurs, you can define how long it must be in that state (the persistence time)
before the alarm point is triggered. Click More and enter the Persistence Time in milliseconds or seconds.

Configure AlarmPoint (cont'd)

Configure Persistence Time

Persistence Time: Milliseconds e

Configure Automatic Re-Alaming Time

Re-alarm Time: D Milliseconds ~

Cancel

4. When an alarm point state remains after the alarm has been triggered and acknowledged, you can define
how much time must elapse before the alarm point is re-triggered. Click More and enter the Re-Alarm
Time in milliseconds or seconds.
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Enter an integer value between 0 and 999 in the fields to define an alarm value for each alarm level. The
highest priority is represented by 999, and 0 represents the lowest. Priority values can be useful in
Runtime for displaying the relative importance of alarm points, and for filtering out alarms with lower
priorities.

(Optional) In the Comment fields, enter text that will be displayed in alarm graphics for each alarm level.
The comment can have a maximum of 256 characters. This comment can display information about the
alarm point, for example, or provide instructions to the operator.

Click OK to save your settings and close the dialog box.

Entering Alarm Values

If you selected Current Value in the Setup by field on the Alarm Point Setup page, complete the alarm point
setup by configuring the alarm’s state in the Value page.

Alarm Point *
Setup Discrete Value  Control Engines
HiHi
Enable (@ Value () Tag ?
Mare.. | Priority: Comment: Operstar
ore | | M e
Hi
Enable (@ Value (O Tag ?
Mare.. | Prioty: 300 Comment: Operstar
s | | B2 Adiustable
Marmal
Enable  Priarity: IZI Comment: | |
La
Enable (@ Value () Tag 2
Pricrity: {500 Cornrnent: Operator
LT E v 50| | | O Adiustable
Laola
Enable (@ Value () Tag ?
Priciity: Corarnent: Dperator
More... ¥ | | Adjustable
Cancel Help

You must define values for each alarm level that will be used with the alarm point. The following
alarm levels are available:

HiHi alarms occur when the tag value is greater than or equal to the HiHi value.

Hi alarms occur when the tag value is greater than or equal to the Hi value and less than the
HiHi value.

Normal is between the Hi and Lo values.

Lo alarms occur when the tag value is less than or equal to the Lo value and greater than the
LolLo value.

LoLo alarms occur when the tag value is less than or equal to the Lolo level.

For each alarm level you want to use with the alarm point:
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1. Toselect the state of the alarm condition tag, select True/On to have the alarm point be in the alarm state
when the associated tag is “on”for discretes, or “true”for integer bits. Select False/Off to have the alarm
point be in the alarm state when the associated tag is “off"for discretes or “false”for integer bits.

2. Select the check box next to Normal to have the normal state displayed in history windows and logs. The
normal state is the opposite of the alarm state.

3. When an alarm point state occurs, you can define how long it must be in that state (the persistence time)
before the alarm point is triggered. Click More and enter the Persistence Time in milliseconds or seconds.

Configure AlarmPoint (cont'd)

Configure Persistence Time

Persistence Time: Milliseconds ~

Configure Automatic Re-Alaming Time

Re-Alarm Time: l:l Milizeconds ~

Cancel

4. When an alarm point state remains after the alarm has been triggered and acknowledged, you can define
how much time must elapse before the alarm point is re-triggered. Click More and enter the Re-Alarm
Time in milliseconds or seconds.

5. Enteraninteger value between 0 and 999 in the Priority fields to define an alarm value for each alarm
level. The highest priority is represented by 999, and O represents the lowest. Priority values can be useful
in Runtime for displaying the relative importance of alarm points, and for filtering out alarms with lower
priorities.

6. (Optional) In the Comment fields, enter text that will be displayed in alarm graphics for each alarm level.
The comment can have a maximum of 256 characters. This comment can display information about the
alarm point, for example, or provide instructions to the operator.

7. (Click OKto save your settings and close the dialog box.

Setting Control Engine Status Alarm Points

If you selected Controller Status in the Setup by field on the Alarm Point Setup page, complete the alarm point
setup by selecting a control engine from the list on the control engines page. Only control engines that have
been added to the PAC Display project are available. See “Configuring Control Engines”on page 61 for more
information on adding primary and backup control engines to a PAC Display project.
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NOTE: When the Control Engine Status option is selected, no other feature in the Alarm Point dialog box is available.

Alarm Point *

Setup Discrete  Value  Control Engines

Yalue Priorty: |99998 Cornm Failure Pricrity 93339

Cancel Help

To configure an alarm point based on control engine status, do the following:
1. Click the Control Engines tab in the Alarm Point dialog box.
2. Inthelist of available control engines, select the control engine that will be linked to the alarm point.

3. Ifyouwantto change the Last Known Value Priority or Comm Failure Priority levels, enter a new value in
the corresponding field.
Using the default settings, these priority levels cannot be filtered out by the user since they are higher
than 999. If you want the user to be able to filter out control engine status alarms, set either—or both—
values to 999 or less.
Click the Setup tab and enter a name for the alarm point in the Name field.

5. (Click OKto close the dialog box and save your settings.

ADDING ALARM GRAPHICS

Alarm graphics monitor alarm points associated with PAC Control tags, and alert the operator when
pre-defined alarm conditions are reached.

Alarm graphics can be placed and resized just like a trend or any other graphic object. You can place multiple
alarm graphics in any window. See also, “Configuring Alarm Points”on page 258.

To create an alarm graphic:
1. Select the Alarm tool from the Toolbox.
2. C(lickand drag a large rectangle, and release the mouse.
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An alarm graphic similar to the example below appears.

Tirme [rate Marme Skate Prio...  Malue Comment

£ .

Acknowledge ] l Acknowledge All

TIP: Use your mouse pointer to manually adjust columns to the preferred width, or use the Column Format
button (page 215) to set the width in pixels.

3. To configure alarms for this graphic, choose the Select tool and double-click the graphic.
The Alarm Configuration dialog box opens.

Alarm Configuration Dialog Box

Alarm Cenfiguration @
Alarm Pointz

A 5 [ [ add. — B

Come | C

D — Alarm Type Optians
() Detailed () Sumrnary @) Histary — F
E _ Calor [[]Use for Headesr ——— G

Alarr: - Ack'ed:- H
Marrmal: - Silenced:-

S
Warning: I:I Backaround: I:I Hot Keps...

MaxLines: 1000 — 1 J
[7] Lock Descending K
[ Lock Azcending

L ——{— QK H Cancel ” Help ]

(A) Alarm Points. The Alarm Points list shows configured alarm points that are associated with the alarm
graphic. To add an alarm point to the list, click Add (B). To remove an alarm point from the list, click Delete

(C).

(B) Add. Click Add to add an alarm point to the PAC Display project. In the Alarm Points dialog box that
appears, you can select previously configured alarm points or configure new points as needed. To select more
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than one alarm point at a time, press and hold the Ctrl key and then click each point you want to add. See
“Configuring Alarm Points”on page 258 for information on adding and configuring alarm points.

(C) Delete. Select an alarm point in the list and click Delete to remove it from the alarm graphic. The alarm
point is not deleted from the PAC Display project or from any other alarm graphic.

(D) Alarm Type. Choose the type of the alarm graphic by selecting Detailed, Summary, or History.

«  Detailed alarms treat each alarm point state as a separate alarm condition. The operator must
acknowledge each alarm point before its name is cleared from the alarm graphic.

For example, if an alarm is in the Lo state and changes to the Lol o state, alarms for both states are listed
in the graphic. Alarm points can be selected and acknowledged from a detailed alarm.

«  Summary alarms display only the state of the current alarm.

Forexample, if an alarm is in the Lo state and changes to the Lolo state, only the LoLo state alarm is listed
in the graphic. Alarm points can be selected and acknowledged from a summary alarm.

«  History alarms list each change of state for each alarm point. Alarm points cannot be acknowledged
from a history alarm.

(E) Color. For each of the following items, click a color square and select a color in the Color dialog box that
appears.

- Alarm—Alarm points in an alarm condition

- Normal—Alarm points that have returned to their normal state
- Waming—Warning state text

- Ack'd—Alarm points that have been acknowledged

- Silenced—Alarm points that have been silenced

- Background—Background color of an alarm graphic

(F) Alarm Font. Click Alarm Font to select the font used in the alarm graphic.

(G) Use for Header. Select Use for Header to have the alarm font you selected appear in the alarm graphic’s
column headers.

(H) Column Format. Click Column Format to set the information that appears on the alarm graphic. In the
Alarm Format dialog box that appears, select the information the alarm graphic will display, and the width
alarm graphic columns will appear on screen. See “Setting the Alarm Format” below for configuration
information.

(1) Hot Keys. Click Hot Keys to configure keys on the keyboard that the operator can use to acknowledge
alarms. In the Alarm Hot Keys dialog box that appears, select keys or key combinations the operator can use to
acknowledge one or more alarms. Only detailed and summary alarm graphics can have hot keys. See
"Assigning Alarm Hot Keys”on page 276 for more information.

(J) Max Lines. Enter a number to set the maximum number of alarm point lines a history alarm graphic can
contain. When this number is exceeded, the oldest alarm point is removed to make room for the new point.
The History alarm type must be selected for this option to be available.

(K) Lock Ascending/Descending. You can lock the history alarm display in either ascending or
descending order. By default, the display order is not locked. If locked, no sort arrow appears in the column
header and clicking on a column header does not sort by the column.

(L) OK. Click OK to save your settings and close the dialog box.

Now we'll look at the additional steps needed to complete the settings in the Alarm Configuration dialog box.
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Setting the Alarm Format

You can customize the alarm information that appears when an alarm graphic is displayed on screen, or when
an alarm log file is sent to a printer.

1. Click the Column Format button on the Alarm Configuration dialog box.
The Alarm Format dialog box appears.

Alarm Format El

Colurnn Format
Enable: Wwidth;

Time
Date
Mame
State
Friciity
Walue
Comment

I Ok H Cancel ][ Help ]

2. Select the check box next to the name of each column that you want to appear in the alarm graphic or
printed alarm log.

3. Foreach column name that you want to use, enter the desired column width (in pixels) in the Width field.

For alarm graphics, the widths are an approximate guideline for how wide the columns will appear on
screen. For printed alarm logs, the widths are absolute values. If a number or text cannot fit into a printer
column, it will be truncated.

Assigning Alarm Hot Keys

Alarm hot keys are keystrokes or keystroke combinations that the operator can quickly use to respond to
alarms. When a hot key is defined for an alarm, pressing a key on the keyboard (along with an optional Ctrl or
Shift key) performs the same action as clicking the mouse on an object.

NOTE: Hot keys can also be defined for dynamic objects in a PAC Display project, but these hot keys are defined
separately from alarm hot keys. See “"Assigning a Dynamic Attribute to a Graphic Object” on page 165 to learn how
to set up hot keys for a dynamic graphic.

To configure hot keys for an alarm:
1. Click the Hot Keys button on the Alarm Configuration dialog box.

Alarm Hot Keys r5_<|

Hat Keys

Ak Al [lc [ shit
SelectList  []Cul [] Shit

Ok H Cancel ][ Help ]
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Select a key in the drop-down list for the function you want to use:
- Acknowledge. This hot key will have the same effect as pushing the alarm’s "Acknowledge" button
- Acknowledge All. This hot key will have the same effect as pushing the alarm’s "Acknowledge All"

button

—  Select List. This highlights the alarm point list on the display. Once the alarm point list is
highlighted, cursor keys can be used to select alarm points for acknowledgment.

If you want to use the Ctrl and/or Shift keys in combination with the key you've chosen, select Ctrl, Shift,

or both.

CONFIGURING PROJECT ALARMS

To configure alarm features for the whole project, click Configure > Alarming Setup and configure the
following settings as needed in the Alarming Setup dialog box described in:

“Alarm Runtime and User Options”on page 277
“Email Options”on page 279

“Alert Window Options”on page 283

“Alarm Logging Options”on page 284

“Alarm Sound Options”on page 287

Alarm Runtime and User Options

The Options tab allows you to configure how an alarm appears in PAC Display Runtime. It also provides
options for how a user can work with alarms in a PAC Display project.

Alarming Setup

Options  EMail ~ Alett Window  Logging  Sound

Riuntime Options
All alarmz enabled at startup
Alarmg Enabled menu item

Fricrity Filker manu item Set Priarity Alarm Colars...

] Display message box for new alarm points

[ Show Waming State LChonze.

|Jzer Adjustable

Enable / Disable &lam Levels
Alarm Level Values

Alarm Lewvel Pricrity

Cancel Help

x

To set how an alarm appears in PAC Display Runtime, select one or more of the following options in the
Runtime Options group:

All alarms enabled at startup—Enables all alarms when the project starts in Runtime.
Alarms Enabled menu item—NMakes the Alarms Enabled menu available for the user to enable and

disable all alarms.

Priority Filter menu item—Makes the Priority Filter menu available for the user to control whether to view
all alarms, or only alarms exceeding a specified priority value.
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Set Priority Alarm Colors—Click the link to display the Alarm Priority Colors dialog box where you can
customize the color of alarms and warnings based on priority.

Alarm Priority Colors X

Alarm Priority Lewvel Alarm Color Y/ arhing Color

100 and above

200 and above

300 and above

400 and above

500 and above

B00 and above

700 and above

800 and above

900 and above

EREEREEER
JO000000bOO

QK Cancel Help

a. (licka colorto display the Color dialog box, where you can select a color or configure a custom
color. When you've finished configuring the color, click OK to close the dialog box.

b. If desired, configure additional alarm and warning colors. When you've finished, click OK to close the

Alarm Priority Colors dialog box.

—Display message box for new alarm points—Makes a dialog box appear containing information
about the alarm point. The user can acknowledge the alarm in this dialog box, or close it and
acknowledge the alarm at a later time. See also, “Configuring Alarm Points”on page 258 to
adjust this setting on a per-alarm basis.

NOTE: Setting or clearing this setting in the Alarming Setup dialog will set or clear this option for all alarm
points. Therefore, you should set this global default first, and then adjust the setting on a per-alarm point

basis.

—Show Warning State—An alarm point is considered to be in a warning state when in one or both
of the following conditions:
c. A persistence time has been configured for the alarm point (see “Entering Discrete Alarm
Conditions”on page 270 and “Entering Alarm Values”on page 271) and the alarm has been
triggered, but is waiting for the persistence time to expire.

d. Analarm point has the Re-Alarm Time option configured and is still in the triggered state after being

acknowledged. To see the Re-Alarm option, select Configure > Alarm Points. Then click the Add or
Modify button, click the Discrete or Value tab (depending on the alarm type), and click one of the
More buttons.

When selected, the Show Warning State option enables all alarm points to be displayed in the alarm

graphic when these points enter the warning state. If alarm points have already been configured,
you can select specific alarm points to be displayed in the warning state. To do this, first select this
option, then click Choose... to open the Choose Warning State dialog box. Select the alarm points

you to display in the alarm state, then click OK. Select All to select all of the alarm points. Select Clear

All to de-select them.
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See also, “Configuring Alarm Points” on page 258.

Choose Warning States

Alarm Paints

Alarm Point Marne
Alarm Point

[ Select &1

Cancel Help

NOTE: To override this behavior when configuring new alarm points or modifying existing alarm points, use the
Show Warning State option in the Notification Options section of the Alarm Point dialog. See “Configuring
Alarm Points” on page 258.

To define the changes a user can make to an alarm in PAC Display Runtime, select one or more of the following
options in the User Adjustable group:

«  Enable/Disable Alarm Levels—Allows the user to enable or disable alarm points
«  Alarm Level Values—Allows the user to change alarm point values
o Alarm Level Priority—Allows the user to change alarm point priorities

Click OK to save your settings and close the dialog box.

Email Options

Use the Email tab to configure email to be sent when alarms occur:
1. Select Configure > Alarming Setup, and then click the Email tab.

Alarming Setup *
Options  Email  Alet Window  Logging  Sound

Enable Alarm Point Email Configure Email ...

Email Options

(O Send Email only for alam points | choose  Choose,.

(O Send Email for alarm points with priorities »= o
Email D etails
Alarm Paint Mame + (] State Yalue

Comment Friority
[ Include ‘warming State Send To...

Cancel Help

2. Toenable sending emails, make sure Enable Alarm Point Email is selected, and then click Configure Email.
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The Configure Email dialog box appears.

Configure Email

Choose Email Server:

GMail [use TLS) 5
A —— Usemame: | |
B———Password | |
C——GendTestEmailTo: | |
D [

Cancel Help

a. From the drop-down list, select the email server that will send the email:
- AOL®—uses TLS protocol
- Custom—allows you to configure an email server that is not in the list

|TM

- Gmail™—uses SSL protocol
- Gmail™—uses TLS protocol
- Hotmail®—uses TLS protocol
- System default—uses Outlook Express®
- Yahoo®—uses SSL protocol
b. Ifyou selected Custom in step a, continue to step 3.
If you did not select Custom in step a:
For all options except System Default, in the A Username and B Password fields, type
the email address and password to be used when PAC Display logs on to the email server.
When an email is sent, the email address in the Username field will appear in the email’s “From”field.

NOTE: The Username and Password fields are disabled for the System Default option, because the system uses
the default Microsoft Outlook user name and password for the computer where PAC Display is installed.

c. Totest the email server configuration, type a recipient’s email address in the € Send Test Email To
field, and then click D Test.

If your configuration is valid, a “Mail sent successfully!” message is displayed, and an email with the
subject “Test Email message from PAC Display”is sent to the recipient.

If the test is fails, an error message is displayed.

d. Click OKto save the changes and close the dialog box.
The Alarming Setup dialog box is again displayed.
Continue to step 4.
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If you selected Custom in step 23, the Configure Email dialog box looks like this:

d.

Configure Email L\\,

Choose Email Server:

iCustarn... HRYS
A ——— Email Server: |
B e Port Number: l:l
C —— Security Mone S
D = LI sername: | |
E —— Password: | |
F —Gend Test Email To: | |
G —| Test

Cancel Help

Complete the fields:
A Email Server—The IP address or domain name of your outgoing email server.
B Port Number—The port number that the Email Server listens on.

C Security—Select the cryptographic Internet protocol that the server uses. Options are None, SSL,
orTLS.

In the (D) Username and (E) Password fields, type the email address and password to be used
when PAC Display logs on to the email server.
When an email is sent, the email address in the Username field will appear in the email’s “From”field.

To test the email server configuration, type a recipient’s email address in the (F) Send Test Email To
field, and then click (G) Test.

If your configuration is valid, a “Mail sent successfully!”message is displayed, and an email with the
subject “Test Email message from PAC Display”is sent to the recipient.

If the test is fails, an error message is displayed.
Click OK to save the changes and close the dialog box.
The Alarming Setup dialog box is again displayed.

In the Email Options area of the Alarming Setup > Email tab, select one of the following options:

Send Email for all alarm points—Creates and sends an email to the recipients you enter.
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- Send Email only for alarm points | choose—Click Choose to open a dialog box listing all alarm
points currently configured.

Alarm Points

Alarm Point M ame

[Jeimoo
Jeimm
[ Contraller
[] FLOAT 1
[] FLO&T 2
[JINT_A
[CJINT 2

[ Select &1

Ok Cancel Help

-Check the alarm points for which an email is to be sent. Choose Select All to select all alarm points.
Choose Clear All to clear all selected alarm points.

«Click OK to save your selections and close the dialog box.

- Send Email for alarm points with priorities >= —Sends email only for alarm points with a priority
greater than or equal to that specified. This is useful for alarm points where only a specific state
(such as HiHi or LoLo) warrant an email, or for other critical alarm points.

5. Inthe Email Details area of the Alarming Setup dialog box, select the level of information that will be sent
in the email. By default, all emails will include the name of the alarm point. You can also select State,
Value, Comment and Priority to be included.

6. Select Include Warning State if you want to send an email when the alarm point enters the Warning state.

7. (Click Send To to launch the Email Recipients dialog box:

EMail Recipients

EMail Recipients:

To-»

Bec -»

[ &llows EMail to be edited before sent

Cancel Help

a. (lickTo, Cc, or Bcc to open a dialog to enter the email addresses of the recipients. When you have
entered an email address, you can do any of the following things:
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- To modify an entry, double-click the entry in the list to open the Email Recipient dialog box:

EMail Recipient To *

EMail address for To:

RickBlaine @RicksCafeAmericain.co.ma

Cancel

—  Enter the change, and then click OK.

- Todelete an entry from any list, click on the entry and press the Delete key. In the confirmation
dialog box, click Yes to delete the entry.

(Optional) To allow users to make changes to the configured email recipients, select Allow Email to

be edited before sent.

When enabled, this option displays the email in the default email window, so the user can edit the

email before sending it. If this option is not selected, Runtime sends the email with no user
interaction.

NOTE: When an email is sent with no user interaction, a prompt may appear asking whether you want to send
the email. Click Yes to send the email. For information on how to set up your mail client to handle this kind of
message, see the documentation for your mail client.

Alert Window Options

Use the Alert Window tab to enable alarm points that have entered a Warning state to appear in the Alert
Window in Runtime.

Alarming Setup f'5__<|

Options | Erail | Alert Window |Logging Sound

[VlEnable Alaim Pant Alert windavd
When Mo dlarm Paints in dlert Window:
() Hide the Window

() Minimize Window but Leave Visible on Screen

() Leave Window Open and Yisible on Scresn

[ aF. H Cancel ]

1. Select Enable Alarm Point Alert Window to enable alarm points that have entered a Warning state to
appear in the Alert Window in Runtime.

Under When No Alarm Points in Alert Window select one of the following options:

Hide the Window—Removes the Alert Window from the screen when the last alarm point has been
removed from the window.
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Minimize Window but Leave Visible on Screen—Collapses the contents of the window to just the
caption bar when the last alarm point has been removed from the window, and leaves the collapsed
window on screen.

- Leave Window Open and Visible on Screen—Leaves the window open and visible when the last
alarm point has been removed from the window.

Alarm Logging Options

Use the Logging tab to configure how alarm data is sent to a printer or saved in a file.

4.

Alarming Setup &l

Optionz | Ebail .&Ieerindowl Logging |Sound

Printer Logging
Selected Printers:
CWMEMGPS HPS

[] Printing Enabled
File Logging

- [ File Logging Enabled

[ QK. H Cancel ][ Help ]

To choose a printer to send alarm data to, select Printing Enabled and then choose a printer from the
Selected Printers list. If you want to use a printer that does not appear on the list, you will need to install
the printer so that it can be accessed from your PC. If you aren’t sure how to do this, refer to
documentation from Microsoft and your computer manufacturer.

Note that if you move the PAC Display project from one Windows operating system to another,
you must reselect the printers.

To choose the alarm information that appears on the printed alarm log, click the Column Format button.
In the Alarm Format dialog box that appears, set the format in which the alarm graphic will appear on
screen and the information it will contain. See “Setting the Alarm Format”on page 276 for configuration
information.

If you want History Alarm windows to be refreshed (have their contents updated) each time they open,
select Reload History Alarms. This option is available only when file logging has also been enabled.

To save a log file of alarm data to disk, select File Logging Enabled and click File Setup.

In the Alarm Logging File Access dialog box that opens, you can configure the name, location, line format, and
other settings for the log file where the alarm data will be saved. By default, PAC Display saves alarm logs as
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text files in Unicode (UTF-16) format. To save all logs in ASCII format, select the “Save log files in ASCIl format”
check box in the Runtime Setup dialog box. For details, see “"Runtime Setup: General Tab”on page 290.

Alarm Logging File Access d
Directony Path
A__O Mare Browse. .
(®) Usze project directory take Path Relative to Project
File Mame

B ——Souce: ® Automatic () Fized () From strategy

Cc
D 7
E
Lines Files
F ——FLine Format... Murnber of Files To Retain: L H
G —— Lines Buffired: Rollover: |Days  ~ Foesday |
3 | |[&
? F.eep file open Use 0.00 Sec. Resolution———  J
K

L — Cancel Help

(A) Directory Path. Choose the directory where the alarm log file will be saved. Click Name and enter the
directory path in the field next to it, or click Browse to find a directory path.

Click Use Project Directory to save the alarm log file to the PAC Display project directory. (This occurs by
default if you don't specify another location.)

To save alarm log files in a folder relative to the folder that the project is in, select Make Path Relative to Project.
If you then save the project to a different folder (or even to a different computer), PAC Display will save and
look for files in the relative path.

For example, if the project is saved in C:\proj\ and you configure log files to be in C:\proj\alarms\, then the
relative path would be this: \alarms\

If you then saved the project to C:\temp\newproj\, PAC Display would save and look for log files in the new
location’s relative path: C:\temp\newproj\alarms\

(B) File Name. Select Automatic, Fixed, or From strategy to determine how the alarm log file name will be
created, and then fill in additional information as needed for that option.

If the Automatic option is used, log files are named based on the rules described in “Naming Historical Data
Log Files”on page 230. If you select this option, files are named using the rollover convention if required; this is
described in more detail on page 230. If rollover is not used, the file is named “alarmlog.alm.” The Automatic
option is used by default if you do not select another option.

(C) Fixed Name. If you selected the Fixed option in B, enter a file name here. The file name can be any valid,
eight-character DOS file name and doesn't require a three-character file extension. Note that if you don't
specify an extension, one is not added automatically.
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(D) String Name. If you selected the From strategy option in B, enter a PAC Control string tagname here.
Use the Tag Selection button [ 2] to quickly enter the tag containing the name of the alarm log file. When the
trigger starts the alarm log, the string containing the file name is read, and the new data is appended to the
log file if the file already exists. If the file doesn't already exist, it is created. The rollover naming convention
doesn't apply to this type of file name.

If the string in D is an invalid file name, the default name of the log file is created using the following rules:
«  Ifthe string is empty, the project directory is added to Default Name (E) and the extension .alm is used.

«  Ifthe string is not empty and a project directory is not specified as the directory path, the Name in A'is
added to Default Name (E) .

« Ifthe project directory is specified as the path, or the previous step failed, the project directory is added
to Default Name (E) and the extension .alm is used. If the project directory is read-only or there is not
enough room left on the drive containing the project directory, an error message indicates that the file
could not be created.

(E) Default Name. Enter a default file name here in case the file name used in String Name (D) is invalid.
The file name can be any valid, eight-character DOS file name. The three-character file extension .almis
assigned by PAC Display.

(F) Line Format. Click to configure the character, or delimiter, used to separate the data in the log file, to
choose the type of quotes used for each data line, and where to insert carriage returns. You configure these
parameters in the Line Format dialog box that appears. See page 230 for more information.

(G) Lines Buffered. Enter the number of lines of data your PC will save to a memory buffer before writing
the information to the alarm log file. When choosing a number, keep in mind that the lower the number of
buffered data lines, the more frequently the computer has to write to the file. Alternately, the higher the
number of data lines buffered in memory, the more data that will be lost if your PC loses power or has a
system failure. A valid entry is any number between 0 and 999; the default is 20 files.

(H) Number of Files to Retain. Enter the maximum number of alarm log files that can be created using
rollover before the oldest file is overwritten. For example, if you enter 10 and your rollover time period is set to
hours, you will have 10 alarm log files created for 10 hours of data before the oldest file is overwritten with
new data. See page 230 for more information on rollover settings.

(1) Rollover. Choose the rollover time period here. Select None to have all logged data placed in a single
data file named ALARMLOG.ALM. If you select Weeks, also select the day of the week to have the files rollover.
Logging begins when the PAC Display project is loaded, and data collected will be appended to the existing
data file. The size of the file is limited only by available disk space.

To use the Trigger option, see “Using the Rollover Trigger Option”on page 227. Logging begins when the Start
Trigger is activated, and data collected is appended to the existing data file.

(J) Use 0.01 Sec Resolution. Select this option to log the time in hundredths of a second.

(K) Keep File Open. Select Keep File Open to allow buffered data to be appended to the alarm log file more
quickly. If you leave this box unchecked (the default setting), the file is closed after each time data is written to
it. This provides greater data integrity than leaving the file open.

(L) OK. Click OK to save your settings and close the dialog box.
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Alarm Sound Options

NOTE: To play sound files, the PC running the project must have a properly configured sound card and corresponding
system software, as well as a set of speakers. You can use both digitized sound (wav) and MIDI music (.mid) files in
your project.

The Sound tab allows you to define an alarm sound and the conditions when it is played.

Alarming Setup &l

Dptions | EMail | Alert window | Loaging| Sound |

Sound File:

[]Use Praject Directory

Options
(%) Play sound once when any alam is active
() Play sound continuously when any alam is active

(7 Play sound continuously until any alarm iz acknowledged

[ QK. H Cancel ][ Help ]

1. Toenter the name of the sound you want played, click Browse and locate the sound file.

If you select Use Project Directory, the sound file must reside in the project directory. This option is useful
if the project directory might be moved to a different location.

NOTE: Only one sound file can be selected in the Alarming Setup dialog box, but PAC Display has other ways of
playing sounds. See “Configuring a Sound” on page 237 and “Configuring Alarm Points” on page 258 for more
information.

2. Select an option to determine how many times the sound will play when a new alarm occurs:
- Play sound once when any alarm is active—The sound plays once, then stops.

- Play sound continuously when any alarm is active—The sound continues to play until the operator
acknowledges all active alarms.

- Play sound continuously until any alarm is acknowledged—The sound continues to play until the
operator acknowledges at least one active alarm.

3. (lick OKto save your settings and close the dialog box.
See also “Configuring Alarm Points” on page 258 to assign a sound to a specific alarm point.

NOTE: If an alarm point has been configured to play the global sound file, but then the global sound file is cleared in
this dialog box, a message will ask you to configure a default sound or proceed with this choice for the alarm point.
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10: Configuring and Using
PAC Display Runtime

This chapter describes the versions of PAC Display Runtime that can be used, and explains how to customize
features that are available when your project runs in PAC Display Runtime. It also explains how to use features
that an operator sees and works with when using Runtime.

InThis Chapter

Configuring Runtime page 289
Runtime Setup: General Tab page 290
Runtime Setup: Control Engine Tab page 294
Runtime Setup: Security Tab page 297
Runtime Setup: I/0 Unit Tag Tab page 319
Using Runtime page 320

CONFIGURING RUNTIME

You can configure some of the ways that a PAC Display project appears in Runtime. Using PAC Display
Configurator, you can specify which windows are open or closed, whether the menu is displayed, and whether
or not the operator can exit the program. You can also customize options for the Event Log Viewer, a window
that displays messages about the status and other characteristics of a PAC Display project. And you can control
whether a PAC Display project gathers I/0 unit information, such as I/0 point states and values, from tags on a
control engine or directly from an I/O unit itself.

NOTE: If you want to run your PAC Display project on a computer with multiple monitors, in PAC Display Configurator
simply extend the project’s main window across the monitors you want to use. When you open the project in
Runtime, the main window will appear the way you positioned it over the monitors. For more information on using
multiple computer monitors, see the PAC Display User's Guide “System Requirements”on page 4 and “Using Multiple
Monitors” on page 34.

To set up a project for Runtime, click Configure > Runtime from the PAC Display Configurator, then configure
the settings in the Runtime Setup dialog box.

“Runtime Setup: General Tab” (below)

“Runtime Setup: Windows/Dialogs Tab, Multi-Monitor Options: Center Dialogs on” on page 293
“Runtime Setup: Control Engine Tab”on page 294

“Runtime Setup: Security Tab”on page 297

“Runtime Setup: I/0 Unit Tag Tab” on page 319
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RUNTIME SETUP: GENERAL TAB

290

| Runtime Setup X |

General Windows/Dialogs Control Engine  Securty /0 Unit Tags

A Ciraw wWindow Initial State Drate Format F
(®) MM-DD-yyY  Sample: 01-27-2015
Define Default.. O DDMMYYY  Sample: 27-01-2015
B M ain window Style Options

[] Aalways maximized System menu Title bar
Minimize button M asimize button

[JUse custom caption: |Sample Cugtom String

C—— Keyboard Setup

[JUse on-screen keyboard for touchscresns

Include Tnzert ASCI' in screen-kepboard

D—— Riuntime Options
Farmat Walue Data with Commas [ Dizable Exit Confirmation
[ Trend B ackward Compatibility [ 5end +1 for Discrete Integer Wiites

[]5ave log files in ASCI format Uze Legacy Log Date Farmat
E Sound Options Allovs bultiple Buntines (G Inbal]—G
] Play sounds simultaneously [ Allows Multiple Instances to Fun

Cancel Help

(A) Draw Window Initial State. Use these options to configure how the project’s windows will look
when the project is first opened in Runtime. To set the default options, check the Use Default check box, and
then click Define Default to set the default options. In the Pop Window dialog box that opens, select windows
and configure whether the window is opened, closed, or iconified. See “Using Draw Windows and URL
Windows"on page 91 for additional options for configuring window states in Runtime.

(B) Main Window Style Options. Use these options to customize the PAC Display Runtime application
window.

«  Always Maximized keeps the main window completely open, covering the entire screen.

When this option is selected, the Minimize and Maximize button options are not available; deselect
Always Maximize if you want to choose the minimize or maximize options.

«  Use Custom Caption lets you enter a title that will appear in the title bar of the main window. Enter the
title in the Custom Caption field.

If a customized caption ends with a hyphen (-), the project file name is added to the caption.

«  Title Bar displays the Windows title bar for the main window. If space is limited on your operator
interface, deselect this option to slightly increase the viewable area that's available.
If you deselect the Title Bar option, note that all options within the group except for Always Maximized
are unavailable.

(C) Keyboard Setup. Use these options to set up your PAC Display project to run on a touchscreen
terminal.
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Use On-Screen Keyboard for Touchscreens. Check this option to enable the use of an on-screen
keyboard with the Send String and Send Value Dynamic Attributes. Use this option when PAC Display
Runtime is running on a computer without a physical keyboard and has a touchscreen. Selecting this
option enables all Send String and Send Value Dynamic Attributes in a project.

Include 'Insert ASCII' in Screen-Keyboard. Select this option to include the 'Insert ASCII' parameter in
the On-Screen Send String dialog box. The 'Insert ASCII' feature allows a user to enter any character value
between 0-255. This option is available only for the Send String Dynamic Attribute. The Use On-Screen
Keyboard for Touch Screens option must be checked in order for this option to be available.

(D) Runtime Options. Use these options to configure the following:

Format Value Data with Commas. Displays large numbers using commas. For example, one million
displays as 1,000,000. However, if a data field in an existing project is too small to display large numbers
with commas, you can deselect this option. Without commas, one million displays as 1000000.

Trend Backward Compeatibility. Displays Trend data in the same manner as it is displayed in
OptoDisplay. This is the same effect as selecting None as the y-axis Label Position on the Trend
Configuration dialog box, except that the labels are displayed. Multiple ranges appear to overlap, and all
pens are displayed. As shown in the following example, if pen 1 has a range of 0-100 and pen 2 has a
range of 300-400, the y-axis has a range of 0-100 and 300-400 simultaneously and both pens are
displayed. By default, this option is disabled.

Save log files in ASCIl format. Saves all alarm logs, event logs, historical data logs, and Runtime
operator logs in ASCII format.

Disable Exit Confirmation. Keeps PAC Display Runtime from displaying a confirmation message when
you close the program.

Send +1 for Discrete Integer Writes. Allows PAC Display Runtime to mimic OptoDisplay Runtime
when sending Discrete Writes to integer variables that have no bit index specified (the bit index field is
left blank). This is helpful when upgrading projects from FactoryFloor or OptoDisplay, or when there is
logic in strategies that tests against true rather than not false. Note that false is defined as zero (0) and true
is defined as any value that is “not false.”

If the bit index field is left blank when configuring a discrete write to an integer, a message says, “No Bit
Index specified. All bits will be modified.” If you click Yes, Runtime will send a value of -1 (all
bits set) when sending Discrete Writes to integer variables whose bit index field is blank.
By using this option, Runtime sets only the first bit of the integer to a 1, resulting in an actual integer
value of +1 (the same as OptoDisplay). This option affects all the discrete write options: Set, Toggle,
Direct, and Reverse.

Use Legacy Log Date Format. Ensures that the date/time format for records in historical data logs is

YYYY/MM/DD, HH:MM:SS.SSS. This option is selected by default. Deselect this option to log records using
the MM/DD/YYYY, HH:MM:SS.SSS date/time format.

(E) Sound Options. If you want all sounds to play as they occur, select “Play sounds simultaneously.” This
allows each sound that occurs to play at the same time other sounds are playing. If this option is not selected,
each sound that occurs will play one at a time in a round-robin fashion.

(F) Date Format. Use the Date Format options to change how the date appears in Alarm windows,
SuperTrend objects, and historical data log files. When you switch from one date format to another, any
SuperTrends placed in a window are immediately updated to reflect the selected date format.

You can select one of two date formats:

MM-DD-YYYY displays the date as month, day, and year.
For example, October 31, 1999 would be displayed as 10-31-1999.
DD-MM-YYYY displays the date as day, month, and year.
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292

For example, October 31, 1999 would be displayed as 31-10-1999.

Trend Example

100
a0
7
62 -
Pen 1 -
40
_\"\—u__
Pen 2
0 —
i
305
T HHAAASS HHAAASS HHAAASS HH:h

If the “Play sounds simultaneously”is checked, sounds start playing immediately, regardless if other sounds
are still playing, and will overlap any currently playing sounds.

For examples, see “Setting Up Sound Options”on page 292

(G) Allow Multiple Runtimes. Select this option to allow multiple runtimes to run at the same time.

CAUTION: Before using this option, consider the following:

« Ifeach project is logging to files (SuperTrend, Historical, Operator Logging, etc.), are the projects saving
data to the same file(s)? If so, system instability or a crash may occur.

«  Performance will be reduced for each Runtime project.

See also, “Running Multiple Runtimes” on page 323

Setting Up Sound Options

If you want all sounds to play as they occur, select “Play sounds simultaneously.” This allows each sound that
occurs to play at the same time other sounds are playing. If this option is not selected, each sound that occurs
will play one at a time in a round-robin fashion.

If the “Play sounds simultaneously”is checked, sounds start playing immediately, regardless if other sounds
are still playing, and will overlap any currently playing sounds

In the following examples, sounds A and B may be configured for alarms, triggers, etc. Sound A is configured
to repeat five times. Sound B is configured to repeat three times.

Scenario 1. Sound A and sound B are triggered at the same time.

«  Ifthe "Play sounds simultaneously”is not checked, sound A will play five times, and then sound B will
play three times.
AAAAABBB
(time —>)

« Ifthe "Play sounds simultaneously”is checked, sounds A and B will play at the same time with sound A
playing five times, and sound B playing three times.
AAAAA
BBB
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(time —>)

Scenario 2. Sound A is triggered. While it is playing, sound A is triggered again.

If the “Play sounds simultaneously”is not checked, the initial five instances of sound A will continue to
play until all five have played. Then the next five instances of sound A will play.

AAAAAAAAARA
(time —>)
If the “Play sounds simultaneously”is checked, when sound A is triggered the second time, it will start
immediately, and it may overlap the initial five sounds from the first trigger.
ARAAAA

AAAARA
(time —>)

Scenario 3. Both sounds are triggered at the same time. Sound A is one second long, and sound B is three
seconds long.

If the “Play sounds simultaneously”is not checked, the sounds will play one after the other.
AAAAAB--B--B--

(time —>)

If the “Play sounds simultaneously”is checked, the sounds will play at the same time. Sound A will end
before sound B.

AAAAA
B--B--B--—
(time —>)

If you deselect the Title Bar option, note that all options within the group except for Always Maximized
are unavailable.

RUNTIME SETUP: WINDOWS/DIALOGS TAB, MULTI-MONITOR OPTIONS: CENTER

DIALOGS ON

Select this option to specify where PAC Display Runtime dialog boxes should open when Runtime is running
on a computer with more than one monitor.

NOTE: This option cannot center the following Microsoft Windows common dialog boxes: Color, Font, File Open, File
Close, and Print. These dialog boxes open where they were last positioned.

Runtime Setup *

General Windows/Dialogs Cortrol Engine  Security  1/0 Unit Tags

ettt o B AP ittt | s s g

Multiple bonitar Options

Center Dialogs on Center of Runtime ‘Window

Center of Huntime
Ovwerall center of m
Primary manitor (0,0 - 1920,1080]
Secondary monitar (-1920,0 - 0,1080)
Secondary monitor [1920.0 - 3840,1080]

Center of Runtime Window. (Default) Dialog boxes are centered on the main Runtime window. They will
keep centering on the main window, even if you move it to a different monitor.
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Overall center of monitors. (For use with an odd number—3, 5, 7, and so forth—of monitors.) Dialog
boxes are centered at the center of all monitors. (The center of all monitors is defined by your computer’s
graphics card settings or Microsoft Windows display settings.)

Primary monitor. (n,n - nnnn,nnnn)Dialog boxes are centered on the primary monitor, regardless of which
monitor displays PAC Display Runtime. (The primary monitor is defined by your computer’s graphics card
settings or Microsoft Windows display settings.)

The numbers in the parentheses are the top left and bottom right coordinates of the primary monitor. These
numbers may differ depending on the monitor’s size and position relative to the other monitors being used.

Secondary monitor. (nnnn,nnnn - nnnn,nnnn). Dialog boxes are centered on the secondary monitor(s). All
monitors other than the primary monitor are displayed in the list as “Secondary” monitors.

The numbers in parentheses are the monitor's top left and bottom right coordinates relative to the primary
monitor. For example, a secondary monitor with coordinates of (-1920,0 - 0,1080) would be to the "left" of the
primary monitor, and a secondary monitor with (1920,0 - 3840,1080) coordinates would be to the “right”of
the primary.

RUNTIME SETUP: CONTROL ENGINE TAB

294

Runtime Setup @
General | Control Engine |Security I /0 Unit Tagsl
A Off-line Cantrol Engine Colar Options
Last Fnown Yalue color; ‘ Cormnm. failure color: -
Enable graphic color change
B Synchronize Contral Engine Clacks ta PC Clock.
Every |7 dayzat |2 |00 Akd
[] Enable &uta Synchronization [ Sunchronize at Funtime startup
Synchronize Contral Engine ‘With
@ Local Computer ) Remote Cornmputer
C Contraller Driven Dynamic Aktibutes
[ &llows Fiuntime Toolips [ Show Hint Text Only
D Fead /Wwiite Timeout
Timeout [sec. ] 3
| oKk || cancel || Hep |

(A) Off-line Control Engine Color Options. If one or more control engines stops communicating, you
can have all graphics with dynamic attributes tied to the control engine(s) change color to indicate the control
engine’s state.

«  Last Known Value color—If communication is lost during Runtime, PAC Display Runtime changes the
colors configured for the graphic object’s dynamic attributes (for example, Text Color, Control Engine
Status color, or Text In from Control Engine color) to the color you configure here. Data displayed in the
Last Known Value color represents the last value returned before communication was lost.
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«  Comm Failure color—PAC Display Runtime changes the graphic object’s normal color to the color you
configure if communication cannot be established when Runtime launches.

When your PAC Display project includes data from multiple control engines, configuring colors for both
conditions makes it easier to know whether communication for a particular source was lost or was never
established.

If any graphic object in the project uses the View Control Engine Status dynamic attribute, the object will still
change color based on control engine status. If the color used for this dynamic attribute is different from the
“Offline control engine” color, you must confirm which color setting to use.

(B) Synchronize Control Engine Clocks to PC Clock. Enable control engine clocks to be synchronized

with the PC clock on the PC that is running OptoOPCServer.

«  Enable Auto Synchronization: When enabled, set the day and time that the control engine clock is
automatically synchronized with the PC clock.

«  Synchronize at Runtime startup: When enabled, the control engines are synchronized with the PC
clock every time Runtime is started.

«  Synchronize Control Engine With: \When enabled, choose which PC to use to sync the control engine's
clock. If you choose Remote Computer, a dialog box appears to browse to the remote computer. This
option is useful if there are several PCs running the same PAC Display project gathering data from the
same control engine because clocks may vary considerably from one PC to the next.

(C) Controller Driven Dynamic Attributes. If Allow Runtime Tooltips is enabled, when a user places the
cursor over a graphic object that has control engine-driven attributes in Runtime, the current values are
displayed in a pop-up tooltip. See also, Using Allow Runtime Tooltips.

(D) Read/Write Timeout. Enter the read/write timeout in seconds. The default is 3 seconds. This is the
timeout setting for Send Value, Send Discrete and Send String (writes) and Discrete Toggles (reads), and other
operator-driven actions that require an immediate read of a value. This does not apply to control
engine-driven attributes where the values are read (text-in, fill color, etc.) or things like historical data log and
SuperTrends. If the tag can't be written to (or read from) in the configured time, a message is put in the event

log.

Using Allow Runtime Tooltips

If Allow Runtime Tooltips is selected on the Control Engine tab of the Runtime Setup dialog box, when a user
places the cursor over a graphic object that has Control Engine-driven dynamic attributes in Runtime, the
current values are displayed in a pop-up tooltip.

NOTE: The tooltip will NOT display for Trends, SuperTrends, XY-Plots or Alarm Graphics.
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Examples

This example shows a graphic object with two different dynamic attributes: a line and fill color from two
different tags.

=2 Line f Fill Cohor

23 Line f Fill Color

e “ L -
' ' ine[10,192.54.65:Ink_1: 136
10.192.54.68:Flogt_1: 1:36.0000

If a graphic object is configured with the Control Engine Status dynamic attribute, the tooltip will display the
status of each control engine that is currently being monitored. The next example shows the status of two
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control engines. The color is always the color of the worst-case control engine—in this case, the one that has
a COMM FAILURE.

v Controller Status

=73 Controller Status

10019254, 68 ATTACHED
10,192.54.69: COMM FAILURE

If a graphic object is displaying a Control Engine-driven dynamic attribute for an alarm point status, the tooltip
shows the state of the alarm point as well as the value of the point as shown here.

=21 AlarmPoint Graphic

N

10,192.54.68:A1_16.Yalue: Normal; 186,9760

RUNTIME SETUP: SECURITY TAB

NOTE: For additional security features, see:

«  "Protecting a Project with a Password” on page 46 to assign a password to the PAC Display project to prevent
unauthorized users from opening it in PAC Display Configurator.

«  "Modifying Draw or URL Windows" on page 94 to assign a password to individual windows in a PAC Display
project to prevent unauthorized users from opening them.

o “Security Settings for Graphic Objects and Dynamic Attributes” on page 176 to allow or deny operator access
to individual graphic objects, based on configured, authorized users and groups.

«  "Viewing Logged-In Users in Runtime”on page 325 to view a list of the users currently logged in to PAC
Display Runtime.
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The options on the Security tab control allow you to control who can log in to Runtime and whether to log
their actions during Runtime. The options also control some general PAC Display features available to the
operator during Runtime.

Runtime Setup ¥
General Control EnginefO Unit Tags
A—— Security Optionz Ewvent Log Optionz D

[ Prevent user exit ] Prevent disabling
[] Hide menu bar permarnently

(® Start Enabled
[ Clear Send Dialog Input Fields () Start Hidden
B—|— Global Operatar Configuration Uzers and Grougp E
Uzer / Group Permizzsions. ..
Apply permizsions to all Groups...

Operator Driven Attibutes

‘Add / Modify User' Pazsword. .

C — Runtime Logaing
[] Enable Runtime Operatar Action Logging
Header Line: | Runtime Operatar Log File
Log To... Encrypt Log File
QK Cancel Help
(A) Security Options

»  Select Prevent user exit to prevent the Runtime operator from exiting PAC Display Runtime once the
project starts in Runtime. This also prevents the operator from changing the project currently open in
PAC Display Runtime.

+  Hide menu bar permanently hides the PAC Display Runtime menu bar from the Runtime operator. This
restricts operator interaction with Runtime menu commands to only what you've defined in the project
itself. For example, pressing the EsC key will not activate the menu bar, and pressing F1 won't invoke the
Runtime online help system. (To offer access to the online help system when the menu bar is hidden, you
should configure a graphic object using an Execute Menu Item dynamic attribute that specifies the Help
menu item. For details, see “Execute Menu Item”on page 144.)

»  Clear Send Dialog Input Fields. Normally, Runtime copies the last value sent into the Send Value and
Send String dialog boxes. However, you might want to prevent this when the last sent value is, for
example, the operator's password. Select Clear Send Dialog Input Fields to clear the last sent value, which
prevents it from being visible the next time the Send Value or Send String dialog box is displayed.

(B) Global Operator Configuration

«  User/ Group Permissions lets you grant or restrict users and user groups from accessing all of the
project’s graphics objects that have been configured for security. For details, see “Configuring Global
Operators”on page 309.

«  Apply permissions to all Operator Driven Attributes. Check this option to apply the selected
permission (grant or deny access) to all graphic objects with operator-driven attributes. (Note that this
applies even if no individual graphic object security permissions are set up.)
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If you don't select this option, permissions for global operators are automatically added only to graphic
objects that have been individually configured for security (see page 177).

(C) Runtime Logging

Enable Runtime Operator Action Logging. Check this option to enable the Header Line, Log To, and

Encrypt file features for logging Runtime operator actions.

Header Line. Enter text that will appear at the top of the Runtime Operator Action log file. (Pro only) If

you choose to log actions to a database table:

—  Header Line text will be the table name.

—  PACDisplay replaces spaces in the Header Line with underscores ( _) because table names cannot
contain spaces.

Log To. Click this button to specify the name and contents of the Runtime Operator Action log.

If you choose to log actions to an ASCII text file:

- Configure the file name and other parameters in the Event Log Configuration dialog box that
appears.

(Pro only) If you choose to log actions to a database table:

Encrypt Log File. Check this option to encrypt data that is logged to an Operator Log File. (This option is

not available when logging to a database.)

(D) Event Log Options

Prevent Disabling. Select this option to prevent a user from disabling the Event Log Viewer during
Runtime. You must first select Start enabled to get this option.

Start Enabled. Select this option to enable the Event Log Viewer at startup.

Start Hidden. Select this option to prevent the Event Log Viewer from displaying when Runtime
launches; it runs in the background instead-. In this mode you can see the Event Log Viewer by choosing
View > Event Log in Runtime.

See also, “Enabling the Event Log Viewer”on page 312.

(E) Users and Groups

Users. Choose this option to add, modify, and delete logins for users who are allowed to log in to PAC
Display Runtime. You can also copy the permissions of an existing user to create new users with the same
permissions. For details, see “Configuring Runtime Users”on page 301.To prevent authorized users from
accessing specific graphic objects, see “Security Settings for Graphic Objects and Dynamic Attributes”on
page 176.

Groups. Choose this option to create, modify, and delete user groups, and to see a list of users in a group.
Generally speaking, all users in a group have the same security permissions to the project’s graphic
objects. However, you can override group permissions on an individual basis. See also “Configuring
Global Operators”on page 309 and “Security Settings for Graphic Objects and Dynamic Attributes” on
page 176.

“Add / Modify User” Password. Choose this option to create a password that Runtime users must enter
before they can modify the list of users with permission to log in to Runtime. See also “Configuring a
Password to Modify Runtime Users” on page 305.

Restricting the Operator

In addition to securing access to graphic objects (see page 176) and preventing login access to Runtime (see
page 301), there are a few more ways to control an operator’s interactions with PAC Display Runtime:

To prevent the operator from exiting PAC Display Runtime, select Prevent User Exit in the Security Option
group. Once the project starts in Runtime, an operator won't be able to exit the PAC Display Runtime
application.
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«  To hide the menu bar from the operator, select Hide Menu Bar Permanently. This restricts operator
interaction with Runtime menu commands to only what you've defined in the project itself. The EsC key
will not activate the menu bar, and pressing the F1 key won't invoke the Runtime online help system.

«  Toallow selected users to log in to PAC Display Runtime or to set up global operator-driven permissions,
see “Configuring Runtime Users” below.

You can also configure a graphic object so that Runtime commands execute when the object is clicked. This is
done by assigning Runtime menu commands to the graphic object using the Execute Menu Item dynamic
attribute; see “Execute Menu Item”on page 144 for instructions.

Understanding Runtime Users, User Groups, and Permissions

There are a variety of ways you can create and manage runtime users and user groups, as well as grant or deny
them permission to access certain windows and functionality in your PAC Display project. It's important that
you understand how the choices you make in granting or denying (or not configuring) permissions to users
and user groups affects their ability to access certain windows or perform functions.

Users and User Groups. You can create either of the following types of runtime users:
«  Microsoft Windows users, which are users you defined on the local computer or domain.
«  PACDisplay Runtime users, which are users you create in PAC Display Runtime.

You can also create groups of these users:

«  Microsoft Windows users into Microsoft Windows groups. You add, edit, delete, and manage Microsoft
Windows users and groups with tools provided by Microsoft.

«  PACDisplay Runtime users into PAC Display groups. You manage PAC Display Runtime users and groups
within the PAC Display Runtime, as described in this chapter.

Permissions. You can grant or deny permissions for:
« Anindividual graphic object configured with operator-driven attributes.
«  Forall graphic objects in a project that are configured with operator-driven attributes.

You can also grant or deny permission to PAC Display Runtime.

Not configuring permissions (neither granting nor denying) to an individual graphic object defaults to
granting permission, unless other permissions are set. For example:

« Ifyou grant permission to an individual graphic object for UserX,

«  but do not configure permission (which means neither granting nor denying) for UserY,

then UserY does not get access to the object because it has been explicitly set for UserX.

As you can see, without careful planning, permissions can become confusing and you may not achieve the
results you want. To help clarify these rules, the following table explains what happens when three different
PAC Display Runtime users (UserX, UserY, and UserZ) are granted, denied, or not configured with access to an
individual graphic object, while at the same time, permissions for all graphic objects in a project are granted,
denied, or not configured:

If access for... is____ for the graphic object andis for the entire project, then the user’s access to the object is:

UserX not configured not configured granted
UserY not configured not configured granted
UserZ not configured not configured granted
UserX not configured granted granted
UserY not configured not configured denied®
UserZ not configured not configured denied?
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is ___ for the graphic object and is for the entire project,

then the user’s access to the object is:

UserX not configured denied denied
UserY not configured not configured denied?
UserZ not configured not configured denied?
UserX granted granted granted
UserY not configured not configured denied?
UserZ not configured not configured denied?
UserX denied not configured denied
UserY not configured not configured denied?
UserZ not configured not configured denied?
UserX granted not configured granted
UserY not configured granted granted
UserZ not configured not configured denied?
UserX granted not configured granted
UserY not configured denied denied
UserZ not configured not configured denied?
UserX denied not configured denied
UserY not configured granted granted
UserZ not configured not configured denied?
UserX denied granted granted
UserY granted denied granted
UserZ not configured not configured denied?

#These users are denied access to the graphic object because another user has their access specifically set (either as granted or denied) to that
same graphic object.

Combining Users, User Groups, and Permissions

Generally speaking, all users in a group have the same security permissions to the project’s graphic objects.
However, for greater flexibility, you can override permissions to graphic objects on an individual basis. This
means that an individual PAC Display Runtime user’s permissions can differ from the group (or groups) he or
she is assigned to. For example, you can create a Supervisors group and set very liberal permissions for anyone
assigned to the group. But if there is a certain supervisor who shouldn’t have access to one certain graphic
object, you can deny access at the user level, and display an error message if the operator tries to access the
graphic object.

Such flexibility can be very helpful, but because you can assign a Runtime user to multiple user groups, it can
also be confusing. Simply stated, “Deny Access” security permissions have priority over “Grant Access”
permissions. This means that if a user has been granted access, but is a member of a group that has been
denied access, the user will not be able to use the on-screen object.

Configuring Runtime Users

NOTE: If no Runtime users are configured, anyone with access to PAC Display can open and use Runtime.

To control access to PAC Display Runtime, graphic objects, and operator-driven dynamic attributes, you
configure users and (optionally) user groups. When a PAC Display project is launched in Runtime, Runtime
prompts the operator for a username and password. (To prevent operators from accessing specific Runtime
graphic objects, see “Security Settings for Graphic Objects and Dynamic Attributes” on page 176.)
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302

You can add, modify, delete, and copy Runtime users in:
«  PACDisplay Configurator > Configure > Runtime > Security tab > Users
«  PAC Display Runtime > Security > Add / Modify User

NOTE: To configure Runtime users in Runtime, you must first configure an “Add / Modify User” password. For
details, see page 305.

When considering security for your Runtime environment, keep the following points in mind:
« Ifno Runtime users are configured, anyone with access to PAC Display can open and user Runtime.

«  Runtime user logins are a special kind of login that you create in PAC Display Configurator; they are not
the same as Windows logins that allow users to login to a particular computer or network.

«  Llogging in and out of Runtime does not change the user currently logged in to the PC in Windows. The
user who initially logged in to Windows remains the Windows user.

«  IfnoRuntime users are configured, the option to log out of Runtime is disabled in Runtime.

Open the Runtime Users Dialog Box
In Configurator, click Configure > Runtime > Security tab > Users.
Or, in Runtime, click Security > Add / Modify User.

The Runtime Users dialog box opens.

Runtime Users *
Runtine Uzers
— Add..

todify. .

Delete. ..
NOTE: The Save and Load buttons

CLT are not available in the Runtime
version

Save..

Load...

Ok Cancel
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Add a Runtime User Login
1. Inthe Runtime Users dialog box, click Add to open the Add Runtime User dialog box.

Add Runtime User *

Runtime User Mame: || |

Password: | |

Re-enter Pazsword: | |

Allowed Log In Schedule Options
Any time | from A, oy AM. Inactivity Timeout:
0 JHows
Enable additional scheduled time i o
Ay bime fram A, b A Change Every:

Months — ~

Enable additional scheduled time

Any time fram LRCR to: b

Enable additional scheduled time

Any time from Ahd, b Ak,

Cancel Help

2. Inthe Add Runtime User dialog box:
a. Inthe Runtime User Name field, type a username.
b. Inthe Password field and in the Re-enter Password field, type a password.

This is the username and password that the operator will use to log in to Runtime, and also when
prompted for access to a security-restricted graphic object.

NOTE: The Runtime username and password are case-sensitive.

c.  (Optional) In the Allowed Log In Schedule area, configure the days and times that the operator is
allowed to log in to Runtime. You can choose a specific day of the week, weekdays, weekends,
never, or any time.

For each additional login period, select “Enable additional scheduled time,”and then select the login
time. To disable a schedule, deselect “Enable additional scheduled time”for that time period.

d. Toautomatically log an operator out of Runtime after a specified period of inactivity, in the Inactivity
Timeout fields, type an amount and select the time unit (Minutes, Hours, Days, or Weeks). To disable
the automatic log out feature, type a 0 (zero) in the text box.

A PAC Display Runtime project is considered “inactive”if (within the configured time period):
—  The mouse has not moved; or

— A menu command has not been performed; or

- An operator-driven attribute is not been clicked.

NOTE: Trigger-based commands are not included in the above list. For example, if a window opens or closes, a
recipe uploads or downloads, or an alarm point state changes, these are not considered to be operator
interactions in PAC Display.

3. Torequire an operator to change his or her password after a specified amount of time, under Require
Password Change Every, enter the amount of time. The units can be set in Days, Weeks, and Months.

Beginning 14 days prior to the expiration of a password, the operator will be notified when logging in
that the password will expire, and be given the option to change it.

To disable this feature, enter a 0 in the text entry field.
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4. Tomap an operator's Runtime login user name to his or her global operator-driven user name, select Has
Global Operator Driven Access, and then enter the global operator-driven user name. This option must
be configured in order for the operator logged in to PAC Display Runtime to modify operator-driven
attributes without having to log in for each attribute. See also, “Configuring Global Operators”on
page 309.

5. (lick OK. The new username is added to the list of Runtime users.

Modify a Runtime User

1. Inthe Runtime Users dialog box, highlight the username, and then click Modify (Configure > Runtime >
Security tab > Users).

2. Make the desired changes, and then click OK to close the dialog box and save the changes.

Delete a Runtime User

When you delete a Runtime user, PAC Display also removes the user from any groups he or she may belong to.
For information on user groups, see page 307.

1. Inthe Runtime Users dialog box, highlight the username, and then click Delete (Configure > Runtime >
Security tab > Users).

2. (lick OKto confirm the deletion and save the change.

Copy a Runtime User

To save time when configuring Runtime users, you can copy an existing user's permissions and group
memberships, and then assign them to a new Runtime user. (The Copy feature does not copy the selected
user's password.)

NOTE: The user you copy must belong to at least one User Group.

1. Inthe Runtime Users dialog box, highlight a Runtime user whose permissions and group memberships
you want to duplicate.

Runtime Users *
Runtine Uzers
Name Add..
Carlos Moty .
Hans Delete. ..
Jaohn
Liam
Save..
Load...
Cancel
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2. Click Copy. A new Runtime user is added to the list.

Runtime Users *
Runtine Uzers
Name Add..
Carlos Modify...
Fred
Hans Delete...
John
"
Save...
Load...
Ok Cancel

3. Tochange the new user's name and create a password, highlight the name, and then click Modify.
4. Inthe Modify Runtime User dialog box, make the desired changes, and then:

a. (lick OKto close the Modify Runtime User dialog box.

b. Click OK to save the new user and close the Runtime Users dialog box.

The new Runtime user has the same permissions and group memberships as the user you copied. You can
also modify the new user's permissions for individual graphic objects. For details, see “Security Settings for
Graphic Objects and Dynamic Attributes” on page 176.

Configuring a Password to Modify Runtime Users

The "Add / Modify Password” function lets you configure a password that operators can enter in Runtime to
modify the list of Runtime users.

1. In Configurator, choose Configure > Runtime > Security tab, and in the Users and Groups area, click “Add
/ Modify User”Password. The Enter Password dialog box opens.

Enter Paszword 4

Enter Pazsword: I:I
Confirm Passwoard: I:I
Cancel

2. Type the new password in both fields, and then click OK to close the dialog box and save the changes. In
Runtime, the operator is prompted to enter the password when Security > Add / Modify User is clicked.

Add / Modify Users . 3
In Runtime, an operator types the configured

password in this dialog box after he clicks
Security > Add / Modify User.

Enter Password

I |
Cancel
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Saving User Configuration Information to an External File

Once users have been configured, you can save the user information to an encrypted file external to the
project file. By saving user permissions information to an external file, you can simply load the user
information file to a new project (instead of having to reconfigure users for the new project).

Alogin configuration file has the extension .pdlin.

1. Make sure you have one or more users configured for this project. See “Configuring Runtime Users” on
page 301.

2. InConfigurator, choose Configure > Runtime > Security tab, and then, in the Users and Groups area, click
Users. The Runtime Users dialog box opens.

Runtime Users *
Funtime Users

— Add..

Carloz todify. .

Hansz

Frad Delete...

Jahn

Liam
Copy...
Save..
Load...

ak Cancel

3. Inthe Runtime Users dialog box, click Save to open the Save Options dialog box.

Save Options d
Save to External File Location

[ Extemal File Browsze. .

Copy Tao Browse. .

Cancel Help

4. Foreach of the following options, click Browse to locate the target directory, then enter a filename and
click OK.

a. Click External File to specify the primary location for the user login configuration file.

b. Click Copy To to specify the backup location for the user login configuration file. This option is
enabled when you select External File. The backup copy is used if the primary file becomes
corrupted or is otherwise unavailable.

5. Click OKto close the Save Options dialog box.
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Loading User Configuration Information from an External File

Once the user login configuration information has been saved to an external file, you can load that user
information into another PAC Display project. The user names in the external file will replace any user names
currently in the target project.

1. Inthe Runtime Users dialog box, click Load, browse to the external file, and then click Open.
The users in the file appear in the list of Runtime users.

Runtime Users *
Funtime Users

— Add..

Carloz todify. .

Hansz

Frad Delete...

Jahn

Liam
Copy...
Save..
Load...

ak Cancel

2. (lick OKto close the dialog box.

NOTE: Once a file is loaded via the Load button, the file’s location is automatically set to be the primary external file
location.

Configuring User Groups

To reduce the amount of configuration needed to restrict access to PAC Display Runtime and graphic objects,
you can assign individual Runtime users to user groups. A user group is a set of users who typically perform the
same job function. For example, you can configure a “Supervisors”group, and then assign all the individual
supervisors to the group.

Note: You must configure at least one Runtime User before you can configure a user group.

Add a User Group

1. In Configurator, click Configure > Runtime > Security tab, and in the Users and Groups area, click Groups
to open the Runtime User Groups dialog box.

Runtime User Groups 5 *
Funtime Jser Groups
Group Mame Uszer Count Add Group
Modify Group
Delete Group
Wigw Users..
QK Cancel Help
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2. (lick Add Group. In the Add Group dialog box, type the group name, and then click OK to save the
change and close the dialog box. The User Count is 0 (zero) because the group has no members.

Runtime User Groups S *
Funtime Jser Groups
Group Mame Uszer Count | Add Group |
Supervizors 1]
Modify Group
Delete Group
Wigw Users..
QK Cancel Help

Add Members to a User Group
1. Inthe Runtime User Groups dialog box, click the group name to highlight it, and then click View Users
The Group Member dialog box opens.

2. Inthe Group Member dialog box, click Add User to open the Add User to Group dialog box.

|
Runtime User Groups

Click the group name to highlight it, and

then click View Users.
Group Mame User Count Add Group

0

Supervizors

Modity Group

Delete Group

Click Add User to select

Runtime users for the group.
Wiew Users...
| oK Supervisors —
Group Members
Uszer Mame Add User
Femove User

Add User To Group *
Select User:
Carlos
Fred
Hans

()8 Cancel| | 30hn

Liam

Cancel Help

3. (lickthe names to add to the group, and then click OK.

The member names appear in the Group Members dialog box.
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4. C(lick OKto save the changes. The Runtime User Group dialog box opens, and the number of members is
displayed in the User Count column.

Runtime User Groups S *
Funtime Jser Groups

Group Mame Uszer Count Add Group

Supervizors 4
Modify Group
Delete Group
Wigw Users..

QK Cancel Help

Remove Members from a User Group

1. Inthe Runtime User Groups dialog bo, click the group name to highlight it, and then click View Users.
The Group Member dialog box opens.

2. Inthe Group Member dialog box, click the user to delete.
To delete more than one user, hold down the Ctrl key and click the users to delete.

3. Click Remove User, and at the prompt, click Yes.
Then click OK to save the changes and close the dialog box.

Modify a User Group.
1. Inthe Runtime User Groups dialog box, click the group name to highlight it, and then click Modify Group.
2. Type the new name, and then click OK to save the change and close the dialog box.

If you modify a user group and then decide to add more members, you must first save the changes by clicking
OKto close the Runtime User Groups dialog box. When you click Groups to reopen the Runtime User Groups
dialog box, the View Users button is enabled so you can click it and add new members to the group.

Delete a User Group
1. Inthe Runtime User Groups dialog box, click the group name to highlight it, and then click Delete Group.
2. Atthe prompt, click Yes to delete the group and close the dialog box.

Configuring Global Operators

Configuring global operators is an easy way to grant or deny access to all operator-driven attributes in a

PAC Display project. Users (or user groups) configured as global operators are automatically added to graphic
objects that have been individually configured for security (see page 177). In addition, when a global operator
logs in using the special Global Operator Access login, he or she can execute any operator-driven dynamic
attribute without having to enter a username and password each time (PAC Display Runtime menu bar >
Security > Global Operator Access > Log in). Simply stated, global operator security is similar to graphic object
security, with the added benefit that the global operator can execute security-configured operator-driven
attributes without having to enter login credentials each time.

Note that a global operator is different from a Runtime user (see page 301). Typically, you configure Runtime
user logins for people who use PAC Display Runtime as part of their day-to-day work, and you configure
global operators for people who occasionally need temporary access to a project’s graphic objects (for
example, to approve an override). However, you can configure a Runtime user as a global operator; when
that's the case, the Runtime is automatically logged in with global operator permissions when he or she user
logs in to PAC Display Runtime.
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You also have the option to allow or restrict access to all graphic objects with operator-driven attributes—
even if security has not been configured for an individual object.
Configure global operators

1. In Configurator, click Configure > Runtime to open the Runtime Setup dialog box, and then click the
Security tab.

Runtime Setup

General Control Engine  Securty 10 Unit Tags
Security Optiong Ewvent
] Prevent user exit P
[]Hide menu bar permanently @ st
[ Clear Send Dialog Input Fields Os

Global Operator Configuration Uzers

I Uzer / Group Permizzsions. .. I

O Apply permizsions to all
Operator Driven Attibutes

Runtime Logging

2. In Global Operator Configuration area, click User / Group Permissions to open the Define Security
Permissions dialog box.

Define Security Permissions >
Select User / Group
Darmair: Runtime Uszers / Groups w
Users / Groups: | SUPErvisars ~
Permiszions

() Grant &ccess () Denw Access

Shaow Configured Uzers. . Clear All

Cancel Help
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3. Select the Domain, and then select the user or group from the Users/Groups drop-down list. Then, select
either Grant Access or Deny Access.

Define Security Permissions *

Select Uzer / Group

Dromair: Runtime Users / Groups ~
Users / Groups; | SUpervisors =
Permissions

@ Grant Access () Deny Access

Show Configured Users... Clear Al

Cancel Help

Click Show Configured Users to see the list of users and user groups that have been granted and denied
global permissions.

Click Clear All to remove all global permissions from all users and user groups.
Click OK to close the dialog box and save the changes.

5. (Optional) When a graphic object is configured for security (see page 176), operators must login every
time they try to modify an operator-driven attribute. To prevent the system from requiring a login for
every secure graphic object, select the Apply permissions to all Operator Driven Attributes check box.

6. Select the Apply permissions to all Operator Driven Attributes check box to apply the global permissions
(from step 3) to all graphic objects configured with operator-driven attributes. (This way, you don't have
to individually configure security permissions for each graphic that needs security.)

7.  Onthe Runtime Setup > Security tab, click OK to close the dialog box and save the changes.

Logging In to and Out of Operator Driven Attribute Access in Runtime

If global users are configured (see “Configuring Global Operators”on page 309), a configured user can log in
and access any security-configured operator-driven dynamic attribute.

See also, “Logging In to and Out of Runtime” on page 322.

NOTE: The Operator Driven Attribute Access submenu is not available in the Read Only version of Runtime.

1. InRuntime, choose Security > Operator Driven Attribute Access > Log In (or Log Out).

Leg In to PAC Display Runtime

Runtirie Uzer Mame: | - Select User Mame - ~

Pazzword:

Exit Fiuntime

2. Selectthe user name from the drop-down list, type the password in the Password field, and then click OK.

CAUTION: As long as a globally configured user is logged in, anyone can access the security-configured
operator-driven dynamic attributes. To prevent unauthorized access, it is the responsibility of the configured user to
log out when finished.
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Enabling the Event Log Viewer

Use the Event Log Options on the Security tab of the Runtime Setup dialog box to configure the Event Log
Viewer. The Event Log Viewer displays messages in PAC Display Runtime about system events and a project’s
communication transactions. By default, the Event Log Viewer is enabled when Runtime starts.

Prevent disabling. Select this option to prevent a user from disabling the Event Log Viewer during
Runtime. You must first select Start enabled to get this option.

Start enabled. Select this option to enable the Event Log Viewer at startup. Uncheck this option to keep the
Event Log Viewer running in the background rather than on top.

Start hidden. Select this option to prevent the Event Log Viewer from displaying when Runtime launches.
In this mode you can see the Event Log Viewer by choosing View > Event Log in Runtime.

See “Using the Event Log Viewer”on page 325 for information on using the Event Log Viewer in Runtime, and
“Configuring the Event Log File” on page 316 to learn about enabling saving the event log to a file and setting
the format in which event log files are saved. By default, the event log is not saved to a file.

Logging Runtime Operator Actions

When an operator uses a PAC Display project in Runtime, general information about how and when the
project is used can be recorded in the Runtime operator log file. Detailed information such as which on-screen
controls were used and which values or states were changed can also be recorded in this log file. For security,
the log file can be optionally encrypted.

By default, PAC Display saves Runtime operator logs as text files in Unicode (UTF-16) format. To save all logs in
ASClI format, select the Save log files in ASCII format check box in the Runtime Setup dialog box. For details,
see “Runtime Setup: General Tab”on page 290.

NOTE: You can also configure security settings for an object to restrict its use to authenticated users and groups. See
“Security Settings for Graphic Objects and Dynamic Attributes”on page 176 to learn how to configure user and group
authentication for a graphic object.

Data Recorded in the Runtime Logging File

When the PAC Display project runs in PAC Display Runtime, the following information about operator actions
is recorded:

«  Date—Date of action (month/day/year)
e Time—Time of action (24-hour)
«  Action Taken—Description of action and PAC Display project file used

«  Control Engine—Control engine running the PAC Control strategy that the PAC Display project is
accessing

«  Tag—Complete name of tag being modified

o OldValue—tag value before being modified

»  New Value—tag value after being modified

o User—Name of user logged into computer running PAC Display project
«  Computer—Computer running the PAC Display project

Discrete controller variables display Off values as 0, and On/Set values as 1. Discrete 1/0 points are logged as 0
(Off) and -1 (minus 1) - for On/Set.
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In this example, the log shows that the operator “edgar” opened and closed the PAC Display project
“cfactory.UUI" using the computer “MFG-00".

PAC Display Runtime Operator Log File

Line Formats:

12/11/2010 10:22:28.230 Open project: cfactory.UUI executed edgar MFG-00

12/11/2010 10:59:57.442 Close project: cfactory.UUI executed edgar MFG-00

The next example shows that the same operator “edgar” changed the setpoint value of
“fTemperatureSetpoint”from 200 to 150 on the same project.

PAC Display Runtime Operator Log File

Line Formats:

12/11/2010 10:56:06.852 Cookie Controller Cookie Controller:fTemperatureSetpoint 200.0000 150.0000 edgar MFG-00

Configuring a Runtime Operator Log File

Also see “Configuring a Runtime Operator Log Database”on page 314.

To record operator actions in a log file:

1.

2.
3.
4

In Configurator, select Configure > Runtime to open the Runtime Setup dialog box.
Click the Security tab, and select Enable Runtime Operator Action Logging.

If necessary, change the header line to meet your application’s requirements.

Click Log To, and then choose Log File from the popup menu.

T T T i N WP R
Rurtime Logging

[VIEnable Runtime Dperator Action Logging

Header Line: Runtime Operator Log File

Log File.... Liaae L\@

Database...

[ ok || cCocel |[ Hep |

The Runtime Logging File Setup dialog box appears. Configuring a Runtime operator log file is identical
to configuring an event log file; follow the instructions in “Configuring the Event Log File”on page 316
and then go to the next step.
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NOTE: To create a single networked file that logs the operator actions of all the networked PCs running PAC
Display, make sure each PC writes to the same networked file. This allows you to view all the operator actions of
the networked PCs from a central location. In order for the date and time stamps to be useful, make sure that
the time on each PC is synchronized with the standard network server time.

5. Select Encrypt Log File if you want the log file saved as an encrypted document. See “Encrypting and
Decrypting the Runtime Operator Log File”on page 315 for information on using encrypted files.

@ Configuring a Runtime Operator Log Database

(Pro only) If you have configured an ODBC-compliant database (such as Microsoft SQL Server, MySQL, or
Microsoft Access), you can also Runtime operator log action log data to a database. For information about
configuring ODBC data sources, see page 55. Also, see “Configuring a Runtime Operator Log File”on page 313.
To log operator actions to a database:

1. In Configurator, select Configure > Runtime to open the Runtime Setup dialog box.

2. C(lick the Security tab, and select Enable Runtime Operator Action Logging.

3. If necessary, change the header line to meet your application’s requirements.

4. (lick Log To, and choose Database from the popup menu.

e N an WSV (9
Runtime Logging

[VIEnable Runtime Dperator Action Loaging

Header Line: Funtime Operator Log File

Log Ta... Fc t 1 on Tl

Log File...

Database... h

[ oK || Cancel |[ Heb |

If a database is configured, a dialog box shows the default settings for the table that will be created and

logged to.
Database Table
Table Mame:
Table Colurnng
Colurmn Mame Column Type
Diate_Time DATETIME
Operator VARCHAR
Control_Engine_Tag YARCHAR
014 % alue FLOAT
Mew Yalue FLOAT
01d_String WARCHAR
Mew_Sting YARCHAR
Action_Taken YaRCHAR
Computer WARCHAR
[ (u] 4 ] [ Cancel ] [ Help
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5. If desired, modify the table name or the column names.
Moadify a column name as follows:
a. Click the name to highlight the row.
b. Clickthe name once again to make it editable.

Database Table

Table Marme: Runtime_Operator_Log

Table Colurnns

Column Mame Column Type
Date_Time DATETIME
Operatar WARCHaR
Control_Engine_Tag VARCHAR
0ld_Walue FLOAT
MHew Yalue FLOAT
01d_Sting WaRCHAR
evi_Sitrin WaRCHAR
WaRCHAR
Computer YaRCHAR

[ u] ][ Cancel ][ Help ]

c. Type anew name, and then press Enter.
d. Click OKto confirm your changes and close the dialog box.

NOTES

Table and column names may not contain the following characters: (space) [] :

Column names cannot begin with a SQL reserved word for that database type.
Examples: INTEGER, VALUE, BACKUP, CURRENT DATE

Changing the Database Table Name

When you create or modify a table for logging operator actions in a database, you can change the database
table name. However, after Runtime logs data to the database, if you then try to change the database table
name in Configurator, a message is displayed, that says the table already exists.

When the message appears, do one of the following:
«  C(lickYes to create a new table and start logging to that table.
«  (lick No to rename the existing table and continue logging to that table.

Encrypting and Decrypting the Runtime Operator Log File

To save a Runtime operator log file in an encrypted format, select Encrypt Log File in the Security tab of the
Runtime Setup dialog box.

To decrypt the log file, do the following:
1. In PAC Display Configurator, select View > Decrypt Operator Log File.
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The log file decryption window opens.

- De-encrypt OptoDisplay Operator Log File |Z||E|E|

Log file to de-encrypt;

| | Browsze...
Destination lag file name
| Browse

Options
[]¥iew de-encypted fil in Notepad

[ Delete enciypted log file

De-encrypt! Status:

l oK ” Cancel ]

2. (lick Browse next to the “Log file to decrypt”field and locate the encrypted operator action log file.

3. Click Browse next to the “Destination log file name”field and select a filename and location where the
decrypted file will be saved.

Skip this step if the default name and destination for the decrypted file is acceptable.

4. Select "View decrypted file in Notepad”to automatically open the file in Windows Notepad after it is
decrypted.

When this option is selected, you can also select “Delete decrypted file after viewing”to have the file
deleted automatically when Notepad closes.

5. Select “Delete encrypted log file"to have the encrypted log file deleted automatically after it is
decrypted.

6. Click Decrypt to decrypt the file.
7. Click OKto close the log file decryption window.

Configuring the Event Log File

As events occur in a project in Runtime, messages with a date and time stamp are posted to the Event Log
Viewer. These messages can be saved to an event log file and archived to provide an operations record for a
PAC Display project.

NOTE: A project can have only one event log file active (open) at a time.

By default, PAC Display saves event logs as text files in Unicode (UTF-16) format. To save all logs in ASClI format,
select the Save log files in ASCII format check box in the Runtime Setup dialog box. For details, see “Runtime
Setup: General Tab”on page 290.

(Pro only) If you have configured an ODBC-compliant database (such as Microsoft SQL Server, MySQL, or
Microsoft Access), you can also send event log messages to a database. For information about configuring
ODBC data sources, see page 55.
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To configure an event log, select Configure > Event Log.

Event Log Configuration Dialog Box

PAC Display Basic PAC Display Professjonal
Event Log Configuration * Event Log Configuration *
Log File Setup Log File Setup
Enabled File Setup... Enabled

Database Record... Enabled

QK Cancel Help Cancel Help

To create an event log file when you start the project in Runtime, select Enabled (next to the File Setup
button), and then click File Setup.

The Event Log File Configuration dialog box appears. In the Event Log File Configuration dialog box, you

configure where the event log data will be stored, how the data lines will appear, and the log’s rollover

parameters. For details, see “Event Log File Configuration Dialog Box"on page 318.

(Pro only) To send event log messages to a database:

a. Select Enabled (next to the Database Record button). Note that you can select the Enabled check
box only if an ODBC data source has already been configured. For details, see page 55.

b. Click the Database Record button.

The Database Table dialog box appears, showing the default database table and columns that the
event messages will be logged to.

Database Table

Table Mame: Event_Log

Table Columns

Colurmn Mame Colurn Type
Date_Time DATETIME
Meszage WARCHAR

Cancel Help

To change the Table Name, highlight the name and then type a new name. Note that the name
cannot contain a space.

If Runtime logs data to the database, a message appears, saying that the table already exists.

—  (lickYes to create a new table and start logging to that table.
- (lick No to rename the existing table and continue logging to that table.

PAC Display User's Guide 317



RUNTIME SETUP: SECURITY TAB

To change a column name, click the name to highlight the row. (You cannot change a column
type.) Click the name once again to make it editable.

Database Table

Table Mame: Event_Log

Table Columns

Colurmn Mame Colurn Type

Date_Time DATETIME
h YARCHAR

Cancel Help

4. Type anew name, and then press Enter.

The name cannot contain spaces, and it cannot begin with a SQL reserved word for that database type.
Examples: INTEGER, VALUE BACKUP CURRENT DATE

5. Click OKto confirm your changes and close the dialog box.

Event Log File Configuration Dialog Box

Event Log File Configuration

Directary Path
A () Marne: ||Dgfi|e | [ Browse... ]

() Use project directory

File Mame

Source: (%) Automatic

Lines Files

C Line Format... Murmnber of Filez To Retain: — E
D Lines Buffered: | 20 Rollover: | Days  —+ F

? Keep file open Uge 0.00 Sec. Resolution

| [[ Ok H Cancel ][ Help ]

(A) Name. Choose the directory where the event log file will be saved. Click Name and enter the directory
path in the field next to it, or click Browse to find a directory path. Click Use Project Directory to save the event
log file to the PAC Display project directory. (This occurs by default if you don't specify a location.)
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NOTE: To create a single networked file that logs the events of all the networked PCs running PAC Display, make sure
each PC writes to the same networked file. This allows you to view all the events of the networked PCs from a central
location. In order for the date and time stamps to be useful, make sure that the time on each PC is synchronized with
the standard network server time.

(B) Source. Automatic is the only choice for creating the event log file name, and is selected by default.

(C) Line Format. Click to configure the character, or delimiter, used to separate the data in the log file, to
choose the type of quotes used for each data line, and where to insert carriage returns. You configure these
parameters in the Line Format dialog box that appears. See “Setting Log File Line Format”on page 230 for
more information.

(D) Lines Buffered. Enter the number of lines of data your PC will save to a memory buffer before writing
the information to the event log file. When choosing a number, keep in mind that the lower the number of
buffered data lines, the more frequently the computer has to write to the file. Alternately, the higher the
number of data lines buffered in memory, the more data that will be lost if your PC loses power or has a
system failure. A valid entry is any number between 0 and 999; the default is 20 files.

(E) Number of Files to Retain. Enter the maximum number of event log files that can be created using
rollover before the oldest file is overwritten. For example, if you enter 10 and your rollover time period is set to
hours, you will have 10 event log files created for 10 hours of data before the oldest file is overwritten with
new data. See “Naming Historical Data Log Files”on page 230 for more information on rollover settings.

(F) Rollover. \When you enable file logging, the default rollover period is Daily. To configure a different
rollover period, select an option in the Rollover drop-down list. (For details about rollover files, see “Naming
Historical Data Log Files”on page 230.) The size of the data log files is limited only by available disk space.

To save all data in a single data log file, select None. The file is named EVENTLOG.MSG.

If you select Weeks, also select the day of the week to have the files rollover. A new data file is created every
week on the selected day at midnight. For example, if the configured rollover period is Monday, and data
logging starts on Wednesday, the first log file will contain data from Wednesday until 11:59:59 on Sunday
night. A new log file is created at 12:00 a.m. on Monday; thereafter, the weekly data files will contain data from
12:00 a.m. on Monday through 11:59:59 on Sunday night.

To use the Trigger option, see “Using the Rollover Trigger Option”on page 227. Logging begins when the Start
Trigger is activated, and data collected will be appended to the existing data file.

(G) Use 0.01 Sec Resolution. Select this option to log the time in hundredths of a second.

(H) Keep File Open. Select Keep File Open to allow buffered data to be appended to the event log file more
quickly. If you leave this box unchecked (the default setting), the file is closed after each time data is written to
it. This provides greater data integrity than leaving the file open.

(1) OK. Click OK to save your settings and close the dialog box.

RUNTIME SETUP: I/0 UNIT TAG TAB

For the current PAC Display project, any Ethernet-based I/0 units that are configured in the associated PAC
Control strategy will be listed on the I/0 Unit Tags tab of the Runtime Setup dialog box. All I/O units are
selected by default. For each 1/0 unit, do the following:

«  Select the check box to have the PAC Display project communicate directly with that I/0 unit.

«  Deselect the check box to have the PAC Display project not communicate directly with that I/0 unit, and
instead access /0 tags through the control engine.
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NOTE: To protect a strategy in case of a power loss, be sure to save the strategy to flash memory. You can save it to
flash just once, when needed, or save every time the strategy is downloaded. For more information, see the
PAC Control User’s Guide (form 1700).

Runtime Setup @

| General | Cortrol Engine | Security | 140 Unit Tags

10 Unit Tags
Read tags directly from theze 1/0 Units:

Contral Engine : 120 Unit Hame

PALC R : Loopback
FALC R1: OptobdtPonPC
PALC R : Optowest

[ ok |[ Canced |[ Hep |

Your control system probably uses Ethernet-based I/0 units, which combine Opto 22 SNAP PAC R-series
controllers or EB-series brains with 1/0 modules and an I/0 rack. In the 1/0 Unit Tags tab, you can configure
how the PAC Display project communicates with these units. Controlling how the PAC Display project
communicates with an I/0 unit can improve the response time for reading and writing remote 1/0 points over
getting that information from the controller.

Normally a PAC Display project running on a PC gets information such as I/0 point state or value by
communicating directly with the I/0 unit itself. Other information, however, is not obtained from an I/0 unit
(for example, the result of a calculation). Instead, this information comes from the tag variables on the control
engine running the PAC Control or OptoControl strategy. In the I/0 Unit Tags tab, you can configure whether
the PAC Display project accesses I/0 unit information directly from the unit, or accesses that information only
from the control engine.

NOTE: Being able to specify how this communication occurs also allows you to use the dual Ethernet interfaces of the
SNAP PAC R-series brains to segment part of an Ethernet network.
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“Runtime Regular and Monitor-Only Versions”on page 321
“Opening a Project in Runtime”on page 321

“Logging In to and Out of Runtime” on page 322
“Running Multiple Runtimes”on page 323

“Using the Event Log Viewer”on page 325

“Viewing Logged-In Users in Runtime”on page 325

320 PAC Display User's Guide


http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165" target="_blank
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165

CHAPTER 10: CONFIGURING AND USING PAC DISPLAY RUNTIME

“Viewing and Changing Control Engines”on page 326
“Viewing and Changing Scanner Status”on page 327
“Switching a Window Between Control Engines”on page 329
“Viewing Alarm Graphics”on page 330

“Modifying Alarm Points”on page 331

“Disabling Alarm Points in Runtime”on page 333
“Using SuperTrends in Runtime”on page 333

“Using XY Plots in Runtime” on page 336

“Writing Directly to Individual Elements”on page 336
“How a Combo Box Behaves in Runtime”on page 337
“Using a PID Button”on page 337

Runtime Regular and Monitor-Only Versions

Two versions of PAC Display’s Runtime application are provided with PAC Display: the regular version and a
monitor-only version. The primary difference between these two versions is that the monitor-only version of
PAC Display Runtime does not allow values to be sent to a control engine. This is a useful feature when
operator intervention is not required or must be prohibited.

The monitor-only version of PAC Display Runtime has the following features:

«  The File and Help menus are the only menu items displayed. If the PAC Display project has been
configured to hide the menu bar, however, even these menus are not visible. See “Restricting the
Operator”on page 299 for information on configuring the menu bar in Runtime.

«  Opening and closing windows are the only operator-driven dynamic attributes that can be used in the
Runtime monitor-only version. Keep this in mind when developing the PAC Display project; if, for
example, there is a window that you do not want the operator to see, do not use the open/close dynamic
attribute with a graphic object.

Using Monitor-Only Runtime and Configurator

To use the monitor-only version of Runtime with this feature, you must change the file name of the
application.

1. InWindows Explorer, change the file name of the regular version of PAC Display to a temporary name.
For example, change “DisplayR.basic.exe”to “orig_DisplayR.basic.exe” or something similar.

2. Now change the file name of the monitor-only Runtime application to the original name of the regular
version. This is done by changing “DisplayX basic.exe”to “DisplayR.basic.exe”

After making these changes, the monitor-only version of Runtime will start when you select Save Project and
Load Runtime in PAC Display Configurator.

To use the regular version of Runtime again, reverse the steps above.

Opening a Project in Runtime

When your PAC Display project is complete and you're ready to open it in Runtime, you can open it:
«  Using PAC Display Configurator.
«  Using PAC Display Runtime.
«  Using a batch file. (For details, see “Creating a Batch File to Start and Run a Project”on page 51.)
«  Using PAC Display Configurator.

- Inthe PAC Display Configurator menu bar, click File > Save Project and Load Runtime.

Changes to the current project in PAC Display Configurator are saved, and the project is opened in
Runtime. The Save Project and Load Runtime feature lets you switch quickly from Configurator to
Runtime, and is a convenient way to test a PAC Display project as you develop it.
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«  Using PAC Display Runtime.

~  Start PAC Display Runtime.!

— Inthe PAC Display Runtime menu, click File > Open Project.

— Inthe Open Project dialog box that appears, select the PAC Display project you want to open.
When the project opens, it will start running and you'll see the operator interface created in PAC Display
Configurator. The initial state of the draw windows that appear (open, closed, or iconified) is determined by

the Runtime setup configuration. Unless you chose to hide the menu bar when you configured the project,
the menu bar for the main window also appears.

Logging In to and Out of Runtime

If multiple users have been configured in Configurator, you can log out of Runtime to allow another user to log
in.
See also, “Logging In to and Out of Operator Driven Attribute Access in Runtime”on page 311.
1. Tolog out of Runtime, choose Security > Log Out of PAC Display Runtime.
A dialog box asks you to confirm logging out.

Exit PAC Display Runtime Basic

o Do you really want to exit PAC Display Runtime?

2. ClickYes.

If Enable Runtime Operator Action Logging is enabled on the Runtime setup dialog box, an entry is made
in the log and the Log In dialog box opens for the next user.

Leg In to PAC Display Runtime

Runtirie Uzer Mame: | - Select User Mame - ~
Password;
Exit Fiuntime

3. Tologin, select your name from the drop-down list, type the password, and then click OK.
Or, click Exit Runtime to shut down PAC Display Runtime.

IMPORTANT: During the time this dialog is displayed, there can be no interaction between a user and PAC
Display Runtime. The current Windows user cannot log off, nor can Windows be shut down.

If the Runtime operator log is enabled, an entry in the log is made indicating whether the log in was
successful or not and the operator who attempted or succeeded at the log in.

Also, the newly logged in user is set as the user whose actions will be logged in the Runtime operator log file.

!For instructions to start PAC Display Runtime, see page 27.
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Running Multiple Runtimes

You can run more than one Runtime on the same PC either for the same project or for multiple projects.

CAUTION: Before using this option, consider the following things:

Ifeach project is logging to files (SuperTrend, Historical, Operator Logging, etc.), are the projects saving data to
the same file(s)? If so, system instability or a crash may occur.

Performance will be reduced for each Runtime project.

To configure Runtime to allow more than one Runtime:

1. Click Configure > Runtime to open the Runtime Setup dialog box.

2. Atthe bottom of the General tab under Allow Multiple Runtimes, select Allow Multiple Instances to Run.
3. (lickOK.

Running the Same Project in a New, Separate Runtime
1. Launch the first Runtime in Configurator by selecting File > Save Project and Load Runtime.

2. Llaunch a second Runtime directly through Windows.
In the PAC Display Runtime menu, click File > Open Project.
Navigate to the location of the project file.
Click the project to select it, and then click Open.

Running a Different Project in a New, Separate Runtime

To run a different project in a new, separate Runtime, you can use a Launch Application dynamic attribute tied
to a graphic object in a currently running Runtime. Alternatively, you can use a command line or a batch file.

Using a Launch Application Dynamic Attribute
1. Using the Select tool, double-click the graphic object to which you want to assign the dynamic attribute.
For more information, see “Assigning a Dynamic Attribute to a Graphic Object”on page 165.

2. Inthe Graphic Dynamic Attributes dialog box, under Operator Driven Attributes, double-click Launch
Application.

The Dynamic Attribute — Launch Application dialog box appears.

Operator Driven: Launch Application

Wworking Directany: | | Browse. ..

Make Path Relative to Project

Command Line; | | Browse...
Append Sting: | | R
Launch Options; (® Multiple instances () Single instance

Show Options: (®) Marmal () Minimized () Maximized

3. Forthe Working Directory, enter the full path to Runtime.
Example:C:\Program Files (x86) \Opto22\PACProject
4. Forthe Command Line, enter DisplayR.<basic or pro>.exe “<Full Path To .UUI Project File>"
Examples:
DisplayR.basic.exe "C:\My Projects\My PAC Display Project.UUI"
DisplayR.pro.exe "C:\My Projects\My PAC Display Project.UUI"
5. Next to Launch Options, select Multiple instances.
Click OK, then click OK again.
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Using a Command Line or Batch File

To start one or more Runtimes using a command line or batch file, use the following format:

cd “<Full Path To Runtime>"

DisplayR.<basic or pro>.exe"<Full Path To .UUI Project File>"

Example:

cd "C:\Program Files\Opto22\PACProject"
DisplayR.basic.exe "C:\My Projects\ProjectA\ProjectA.UUI"

Example: Using Batch Files to Run Multiple Projects

The following example shows one way to use batch files to run multiple Runtimes on the same PC. A master
batch file launches two project batch files, each of which launches a different project.

1.

Create a batch file for each project. In this example there are two projects: Project A and Project B.
Each project batch file has the following format:

cd "<Full Path To Runtime>"

DisplayR.<basic or pro>.exe "<Full Path To .UUI Project File>"

exit

The Project A batch file is named LaunchProjectA.bat:

cd "C:\Program Files\Opto22\PACProject"

DisplayR.basic.exe "C:\My Projects\ProjectA\ProjectA.UUI"

exit

The Project B batch file is named LaunchProjectB.bat:

cd "C:\Program Files\Opto22\PAC Project 9.1"
DisplayR.basic.exe "C:\My Projects\ProjectB\ProjectB.UUI"
exit

NOTE: You can substitute DisplayR.pro.exe. Make sure to include the surrounding quotes.

Create a master batch file that will run both of the project batch files. This is the batch file that is actually
invoked.

The master batch file has the following format.

cd “<Full Path To The Directory Containing Project Batch Files>"

START <Name of Project A Batch File>

START <Name of Project B Batch File>

exit

Both LaunchProjectA.bat and LaunchProjectB.bat are in the same directory, C:\batch:

cd "C:\batch"

START LaunchProjectA.bat
START LaunchProjectB.bat
exit

324 PAC Display User's Guide



CHAPTER 10: CONFIGURING AND USING PAC DISPLAY RUNTIME

Using the Event Log Viewer

The Event Log Viewer is started at Runtime by default. This window displays a list of communication
transactions and error messages for a project. If the Event Log Viewer is not open, choose View > Event Log to
open it. The window that appears will be similar to the following example.

(7] Event Log Viewer

2008/04/02 10:19:12 Zerwver: =>Quality error for group 0D SuperTrend Group 01 Item: A
A [CONT |ipltcp:10.192,54.115: 22001 ]F;Value ; 3INE AND COSINE Reason: Dewice Failure
2008/04/02 10:19:12 Server: =>Quality error for group 0D JuperTrend Group 01 Item:
[CONT |ipltcp:10.192.54.115: 22001 ]FValue ; SINE_AND 3AWTOOH Reason: Dewice Failure

Auto Restore On Mew Message

[] Enable "#waiting Connection” messages

Clear

|r Cloge ] [ Help ]

m O O®

(A) List Area. The list area posts event messages as they occur. Messages will have a date and time stamp,
and a brief message describing the communications event that occurred.

See also, "Appendix A: PAC Display Troubleshooting”.

Messages posted to the event log can also be saved to a disk file. Refer to “Configuring the Event Log File"on
page 316 for more information about doing this.

(B) Auto Restore on New Message. To make the Event Log Viewer appear in the foreground whenever a
new message is posted, select Auto Restore on New Message. This option won't be available if Prevent
disabling was selected when the project was set up in PAC Display Configurator.

(C) Enable “Awaiting Connection” Messages. To display or hide common error messages that occur
when a PAC Display project starts, select or deselect the Enable “Awaiting Connection” Messages option.

(D) Clear. Click Clear to erase the list of event messages.

(E) Close. After reviewing an event message, you can keep the Event Log Viewer window open, or close it
using the Close button (E).

Viewing Logged-In Users in Runtime

NOTE: For additional security features, see:

«  "Protecting a Project with a Password” on page 46 to assign a password to the PAC Display project to
prevent unauthorized users from opening it in PAC Display Configurator.

«  "Modifying Draw or URL Windows" on page 94 to assign a password to individual windows in a PAC
Display project to prevent unauthorized users from opening them.

o “"Security Settings for Graphic Objects and Dynamic Attributes”on page 176 to allow or deny operator
access to individual graphic objects, based on configured, authorized users and groups.

«  "Runtime Setup: Security Tab” on page 297 to allow operator access to the HMI, as well as log all HMI use
and operator actions to an encrypted archive.
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In the Runtime menu bar, click Security > View Logged-in User to view users who are currently logged in to
the project.

ﬂ Convenience Store 1
File View Alarm Security Tools Window Help

Main Log Out of PAC Display Runtime

Change Legin Password...
View Logged in User...

I Global Operator Access
ne Add/Modify User... Current Logged In User

Ne one is currently logged in.

Viewing and Changing Control Engines

To view and change the control engines and I/0 units configured for the PAC Display project, choose View >
Configuration Status to open the Current Device Configuration window and then click the Devices tab. The
information in this window updates automatically as control engines and I/0 units—or devices—are enabled
or disabled, or change states between active and inactive.

The Current Device Configuration window can be left open or minimized while the PAC Display project is
running.

Current Device Configuration

Devices  Scanners
Device |.P. Address Device Mame  Enable..  Active?  Timeouwt  Feties Connect Timeout Enable
A 10192 54.68: 22001 10.152.54.68 Yes Yes RO00 ] RO00 :
10152 40.33: 2001 Dizable
10,192 54,66 2001 :
10,192 0.0: 2001 Set Active ]
10.192.0.45: 2001 —
10,192 54.69: 2001
10.192.54.68:2001 Yes Yes 5000 0 B0 EErpand 1 |
Collapze &l
[JEnable Log
o > _. Wiew Log —D
CfK Help

(A) IP Addresses. IP addresses for both primary and secondary control engines, as well as any
Ethernet-based I/0 units used with those control engines, are listed here. For each device the following

information is displayed:

Device IP Address. Assigned IP address for the device. If a secondary control engine or an I/0 unit has been
configured for that device, a plus sign “+"appears in front of the IP address. Click the plus sign “+"to see the IP
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address and status information for that device. Primary control engine IP addresses are displayed in red, and
other devices are displayed in blue.

Device Name. User-friendly name for the controller (typically configured in PAC Control or PAC Terminal). If
aname has not been configured, the device's IP address is displayed.

Enabled/Disabled State. Device availability status; if the device is enabled, it is available for use with a PAC
Display project and can be made active. If the device is disabled, it cannot be made active.

Active/Inactive State. Device activity status; an active device is a control engine or I/0 unit that the PAC
Display project is currently trying to communicate with. An inactive device is one that is not being used for
communication.

Timeout. When a connection has been established with a device, this is the length of time (in ms) that the
PAC Display project will attempt to communicate with the control engine after no communications are
received.

Retries. \When sending and receiving information to and from the primary control engine, this is the number
of times that the PAC Display project will attempt to communicate with the control engine after no
communications are received.

Connect Timeout. When trying to connect to the primary control engine, this is the length of time (in ms)
that the PAC Display project will try to communicate before switching to another control engine.

(B) Enable/Disable/Set Active. Select a device and do one of the following:
- Click Enable to make that device available for use by the PAC Display project.
- (lick Disable to make the selected device unavailable to the PAC Display project.
- Click Set Active to deactivate any currently active device and make the selected device active.

Timeouts and Retries—For any control engine that's selected, you can also change Timeout, Retries, and
Connect Timeout values.

(C) Expand/Collapse All. Click Expand All to show primary and secondary control engines plus any
Ethernet-based /0 units. Click Collapse All to show only the primary control engines and /O units.

(D) View Log. Click View Log to open the file Configinfo.txt in Windows Notepad. This text file is created and
updated whenever any of the listed device parameters are modified.

(E) Close and Save. Click OK to close the window and save any changes you made.

Viewing and Changing Scanner Status

To view and change the status of scanners used in the PAC Display project, choose View > Configuration
Status to open the Configuration Status window, and then click the Scanners tab. This window updates
automatically as the scanners are enabled or disable, or change states between active and inactive, and can
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be left open or minimized while the PAC Display project is running. (For information on what a scanner is, see
“Configuring the Scanner”on page 67.)

Current Device Configuration

Devices Scanners|
Scanner Location Active?  Enabl..  Backup Mode —‘
A This Computer Tes es Mot Configured. J B
" VlewLog ...... ] c
1
D

(A) List Area. Scanners used by the PAC Display project are listed here by the Windows Network name of the
computer the scanner is running on. For each scanner the following information is displayed:

Scanner Location. Name of the PC running the scanner. Primary scanners are displayed in red, and
secondary scanners are displayed in blue.

Active/Inactive State. Scanner activity status; an active scanner is checking control engine tags and I/0
unit values, while an inactive one is not.

Enabled/Disabled State. Scanner availability status; if the scanner is enabled, it can be used with a PAC
Display project and can be made active. If the scanner is disabled, it cannot be made active.

Backup Node. If a secondary scanner has been configured, that scanner is listed here. (See "Configuring a
Remote Scanner in PAC Display Pro”on page 69 for instructions on doing this.)

(B) Disable/Activate. For an inactive scanner, select the scanner and do the following:
«  Click Disable to prevent the PAC Display project from using this scanner.

«  Click Activate to force the PAC Display project to switch to this scanner from the scanner listed under
Backup Node.

For a currently active scanner, select the scanner and do the following:

Click Disable to stop this scanner and force the PAC Display project to switch to the secondary scanner (if one
has been defined).

(C) View Log. Click View Log to open the file ConfigStatus.txt in Windows Notepad. This text file is created
and updated whenever any of the device parameters listed in B are modified.

(D) Close. Click Close to close the window and save any changes you made.
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Switching a Window Between Control Engines

If a draw window's properties have been set to allow switching between control engines, you can access
different control engines that are running the same PAC Control strategy. When you switch control engines in
Runtime, graphic objects that display control engine data will be updated to show data from the newly
selected control engine. For example, if five control engines are all running the identical strategy, you create
only one draw window instead of making a separate window for each control engine. For instructions on
setting up a draw window, see “Modifying Draw or URL Windows" on page 94.

There are some important considerations to note when using this feature:

Additional control engines that you want to switch between must be associated with the PAC Display
project using the Configure > Control Engines menu item.

If you switch to a different control engine and then exit PAC Display Runtime, when the project is
restarted the default control engine for the project—not the one you switched to earlier—will be
selected.

Trends and SuperTrends must have the Disable Scanning option set to either “When Closed” or “When
Minimized and Closed.”

All tags for the graphic objects in the window must reference the same control engine.

Tag names should not include the name of a control engine. For example, don't name a variable “Control
Enginel_flowrate”in PAC Control if the strategy uses a control engine named “Control Enginel.”

Control engine names must be at least three characters in length.

The "Always in memory” windows property should not be selected.

Alarms and graphic objects using the Alarm Point control engine-driven attribute may not be used.
Recipes cannot be used.

To switch between control engines, start the PAC Display project and do the following:

1.

2.
3.
4.

Select Window > Switch Control Engines.
The Select Window(s) for Control Engine Switching dialog box appears.

Select Window(s) for Control Engine Switching

Step 1: Select Window(z) Step 2 Select Control Engine
(ERAMPLE WANDOW SHAP PAC
SMAP PAC 02
[ Selectall | | Deselectal |
I 0k l [ Cancel ] l Help l

Select the name of the window you want to view.
Select the name of the control engine you want to view.
Click OK.
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Graphic objects with dynamic attributes now use values from the control engine you selected. The name of
the currently connected control engine appears in the window’s title bar.

Viewing Alarm Graphics

You may see detailed, summary, and history alarms in a PAC Display project if it has been configured to let the
operator do so. See “Adding Alarm Graphics”on page 273 to learn more about these types of alarms.

The image below shows an example of three types of alarm graphics: Detailed, Summary, and History. Note
that alarm data can be configured to indicate its status (Alarm, Normal, Warning, Acknowledged, and

Silenced).
L
Detailed
A —Date MName State  Priority  Value Comment
0116, INT_2 HiHi 900 95
01116{... FLOAT 1 Lo 850 35.384617
B 0116).. FLOAT 2 AC... 150 91.538460 D
B Acw&nuwledge All Silence UnSilence ]
C — 7 Summary E
Tirme MNarme State Value Comment
11:11:.... INT_ 2 HiHi 95
11:11:... FLOAT_1 Lo 35.384617
11:15:.... FLOAT 2 A.. 91.538460
Acknowledge | Acknowledge All 5'
o] i
" Tirme MName State Priority Value Comment 1
11:15:23 FLOAT 2 ACK... 150 91.538460 i
11:15:21 FLOAT_1 ACK.. 950 0.000000 i
11:11:31 INT_ 2 HiHi 900 95
11:11:27 FLOAT_1 Lo 850 35.384617 '
11:11:23 FLOAT 1 Lolo 950 0.000000 :b
11:11:22 FLOAT_2 HiHi 150 91.538460
F\\ 10,0014 CLOMT 9 aeow iz 1arc 71 ranacno
Clear
1
el ] e e .S

(A) List Area. To sort the information, click the column name of the item you'd like to sort by. Click the
column name again to reverse the sort order. To change the location where columns appear in an alarm
graphic, click the name of a column and drag it to a new location.

(B) Acknowledge. To acknowledge and turn off a single active alarm, select an alarm and click
Acknowledge.

(C) Acknowledge All. Click this button to acknowledge and turn off all active alarms.
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(D) Silence. (Detailed alarms only) To silence a single active alarm, select an alarm and click Silence.
Silencing an alarm is similar to acknowledging an alarm, and the alarm will not re-alarm until it has been
unsilenced.

(E) UnSilence. (Detailed alarms only) To unsilence an alarm that has been silenced, select the alarm and
click UnSilence.

(F) Clear. (History alarms only) Clears the list of alarms.

Modifying Alarm Points

You may be able to modify alarm points in the PAC Display project if it has been configured to let the operator
do so. See “Configuring Alarm Points”on page 258 to learn more about configuring alarm points. Also see
“Configuring Project Alarms”on page 277 for information about setting alarm options in Runtime.

Alarm point settings can be changed in each one of the four alarm ranges available: HiHi, Hi, Normal, Lo, and
LoLo. Each alarm point state has a value that defines its range:

«  HiHi alarms are greater than or equal to the HiHi Value.

« Hialarms are greater than or equal to the Hi value and less than the HiHi value.
«  Loalarms are less than or equal to the Lo value and greater than the LoLo value.
«  LoLoalarm are less than or equal to the LoLo level.

The normal state is between the Hi and Lo values. Each level can enabled or disabled, but at least one alarm
state (HiHi, Hi, Lo, or LoLo) must be enabled.

To view the alarm point settings:
1. Select Alarm > Modify Alarm Points to open the Alarm Points dialog box.

Alarm Points

Marmne Ref Count tdadify. ..

Alarm Point |0 |

QK. H Cancel ][ Help
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2. Select the alarm point name and then click Modify.

Modify Alarm Point

!

>
|

Valuer |9 Mare... L B

Priority: |7

[~ C

f

Hi
[“]Enable  alue: [0 More... [~ D
Priority: I:I
Lo
Enable I:I Mare..
L]
Lolo
Enable I:I Mare..
L]
I ok l [ Cancel ] l Help l

(A) Enable. Select this check box to enable the alarm level for an alarm range.

(B) More. Click the More button to change the Persistence Time or the Automatic Re-Alarming Time in
milliseconds or seconds. The persistence time is the time that elapses before the alarm point is triggered. The
re-alarming time is the time that elapses before the alarm point is re-triggered.

Modify Alarm Point (cont'd)

Configure Persistence Time

Persiztence Time: |E | | Millizeconds w |

[T Use far all levels

Configure Automatic Re-4larming Time

Re-alarm Time: |EI | |Mi||isec:nnds v

[T Use far all levels

I 0k H Cancel ]l Help l

(B) Value. Enter the value for an alarm level in the Value field.

(C) Priority. To set a priority for an alarm point, enter an integer value between 0 and 999.

Priority fields define an integer value for each alarm level, and can be useful for displaying the relative
importance of different alarm points. Additionally, you can filter out alarms with lower priorities.
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Disabling Alarm Points in Runtime

You can disable individual alarm points in Runtime for the current Runtime session only. This is not a
persistent option. Disabling an alarm point takes effect after any current processing is being performed on the
selected alarm point.

To disable one or more alarm points:
1. Select Alarm > Disable Alarm Points.

M Disable Alarm Points EE

AlarmP oints bo Disable

Alarm Paint M arne

] Contral Engine:Process_T emperature. Value

[ Select Al

I Ok H Cancel ][ Help ]

2. Inthe Disable Alarm Points dialog box, select individual that want to disable, or select Select All.
3. Click OK.
NOTE: Ifyou re-enable an alarm point, re-enabling will not actually take effect until the current value of the alarm

point changes. If the alarm point is re-enabled while in an alarmed state, this could mean that an alarm point will
not appear in an alarm graphic, and its configured sound may not play.

Using SuperTrends in Runtime

If a SuperTrend is included in a PAC Display project, you can control how you view the trend data that appears
in the SuperTrend window. For example, you can zoom in to see a smaller slice of a trend line, or, if historical
data is being collected, you can switch between views of real-time and historical data.

A sample SuperTrend window appears below. It shows the controls you can use to display SuperTrend
information. Note that most of the controls that appear below are available only when historical mode has
been selected.
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Superlrend Examples @

SuperTrend with Real-Time and Historical Modes
1. oD

Ll gy lp [ ATe A s
|

EEE

To beginning Active pen selector
Back one screen Active pen scaling adjustment
Back one major division Zoom out Zoom Historical mode
Forward one major division Normal view Controls Real-time mode
Forward one screen Zoomin
Toend

Scrolling Controls

»  Use scrolling controls to move back and forth in a graph of historical data.

«  Use zoom controls to increase or reduce the image visible in the graph.

«  Toselect an active pen, click the drop-down list and select a pen from the names that appear. If the
y-axis scaling was based on pens (see “Configuring Y-Axis Parameters”on page 194), the scale of the
active pen will be displayed.

« Tochange the scale of an active pen, click the Active pen scaling tool and enter new minimum and
maximum values in the dialog box that appears.

If the y-axis scaling is Logarithmic (see “Configuring Y-Axis Parameters”on page 194), the pen Default
Min and Default Max values are limited to powers of ten. For example, if you want to plot a pen in the
range of 1 to 50 with a logarithmic SuperTrend, the SuperTrend will calculate the Default Max value to
100, since that is the smallest factor of 10 greater than 50. If you want to be able to zoom in on the active
pen, use a range such as 1-10,0.1-1, or .001-10. If you want to zoom out, use something like 10-1000 or
1-1000.

» Toseeall pens scaled the same when using Pen scaling, select a pen, click the scaling button

(magnifying glass), enter the scale, and hold the Shift key down while clicking OK.
SuperTrends are normally set up in Configurator with Pen scaling (see “Configuring Y-Axis Parameters”on
page 194). But with Pen scaling, when one pen is selected in the display, only that pen matches the
scaling shown; other pens do not appear to be at the correct value. By holding down the Shift key while
clicking OK, Default scaling is used so that all pens are scaled the same.

« Torevert to Pen scaling (each pen individually scaled), select a pen, click the scaling button
(magnifying glass) and hold the Ctrl key while clicking OK. Nothing needs to be entered or changed in
this dialog box. All pens will revert to Pen scaling.

Switching between Historical and Real-Time Modes

If a SuperTrend is both a historical and a real-time trend (that is, historical data is being collected), you can
easily change views to see real-time or collected historical data.
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To switch between historical and real-time modes, click the Historical mode button [E2 | or the Real-time
mode button Eﬁ:j| )

When you switch from Real-time mode to Historical mode, the SuperTrend Historical Log Files dialog box

opens, listing the names of SuperTrend historical log files and the time each log started and stopped

recording.

NOTE: Ifthere are a lot of historical log files, it can take a long time to display the files. To view the files more
quickly, hold down the Shift key when you click the Historical mode button. This lists the log files by name only
without the start and end times. You can also speed up the display time by having each SuperTrend log its files
to a different folder. See “SuperTrend Historical Log File Names” on page 202.

SuperTrend Historic Log Files

Available SuperTrend histanic log files:

| File Mame

Start Time

04/06/2005 04:00:00.934
04/06/2005 0300:00.572
04/06/2005 02:00:00.547
04/06/2005 01:00:00.525
04/06/2005 00:00:00.915
04/05/2005 2300:00.517
04/05/2005 22:00:00.017
04/05/2005 21:00:00.603
04/05/2005 20:00:00.863
04,/05/2005 13:00:00.697
04/05/2005 12:00:00.183
04/05/2005 17:00:00.535
04/05/2005 16:00:00.020
04/05/2005 15:47:47.845

B

04/06/2005 04:53:59.376
04/06/2005 0%53:59.973
04/06/2005 02:53:59.556
04/06/2005 01:53:59.931
04/06/2005 00:53:53.503
04/05/2005 2353:53.300
04/05/2005 22:53:59.501
04,/05/2005 21:53:59.001
04/05/2005 20:53.53.587
04/05/2005 1%53:59.853
04/05/2005 12:53:59.681
04/05/2005 17:53.53.173
04/05/2005 16:53:53.580
04/05/2005 1%:53.59.064

[ ok

H Cancel H Help l

Browse...

2. Toview SuperTrend historical log files, select one or more files and click OK.

To select multiple log files, hold down either the Shift key (for selecting contiguous items) or the Ctrl key
(for selecting non-contiguous items) and click a file name.

To open a different SuperTrend historical log file, click the Browse button and browse to the folder

containing the file.

The information in the log file will be shown in the SuperTrend graph. Use the controls at the bottom of
the graph to view the information. (See “Using SuperTrends in Runtime”on page 333.)

3. When you are finished viewing the SuperTrend historical log file, click the Real-time Mode button to
return to the real-time view of SuperTrend information. Note that you will need to reselect log files each
time you switch to historical mode.

Enabling and Disabling SuperTrend Pens

Individual SuperTrend pens can be displayed (enabled) or hidden (disabled) in Runtime.
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1. Right-click a SuperTrend to open the Enable SuperTrend Pen dialog box.

Enable SuperTrend Pen E|
Pen Mame Fen State
. SIME_WALUE Erabled
= SawTOOTH_0 100 Enabled
= SIME_aAND_S2wWTOOH Erabled
[ QK. ] l Cancel l l Help l

2. (licka pen name to toggle it between these states:
- Enabled—pen data is being scanned and logged to a file (if configured).

—  Hidden—pen data is being scanned and logged to afile (if configured), but the pen data is not
graphed on the SuperTrend.

- Not Scanning—pen data is not scanned or logged to a file (if configured).

When enabling and disabling SuperTrend pens, note that the active pen in the SuperTrend object cannot be
toggled between enabled, hidden, and not scanning.

Converting SuperTrend Historical Log Files

A software utility is included with PAC Display that converts binary log files to text format in order to view their
contents. This utility is also available in PAC Display Configurator. For guidelines and instructions, see
“Converting SuperTrend Historical Log Files to Text Format for Viewing” on page 205.

Using XY Plots in Runtime

You can change the range of values used for the x-axis and y-axis of an XY plot object if this option has been
set in PAC Display Configurator. To change range values, right-click the XY plot and in the dialog box that
appears enter new minimum and maximum values for each axis.

Writing Directly to Individual Elements

If you use tables in PAC Control to organize variables used for similar tasks, you can modify individual integer,
float, and string table elements in PAC Display Runtime. For example, you can change things such as the
setpoint of a PID controlling the AC, an oven temperature or cook time, or the speed of a conveyor belt. To
learn how to modify multiple variables all at once, see " on page 239.

NOTE: You can use this feature only if the table has the Allow Edit feature turned on in PAC Display Configurator. See
“Creating a Table” on page 134.

To modify an individual table element:
1. Click the table element.
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The element is selected and a border appears around the table element.

Index  FT_Static -~ Index  FT_Static -~
0 0.0000 0 0.0000
1 0.0000 1 0.0000
2 0.0000 2 0.0000
3 0.0000 3 0.0000
s [ NI ~ 1 ~
< > < >

2. Enterthe new value and then press Enter to confirm, or press ESC to cancel.

How a Combo Box Behaves in Runtime

In Runtime, a combo box you created in Configurator behaves as follows:
+ A combo box appears initially with no items selected.

«  Onceyou select an item from the list, its operator-driven dynamic attributes are executed (after verifying
Security, if configured).

«  Anyitems that have the “Text-in"attribute are updated in real time when you click the drop-down arrow
to display the list, and when the item is the item you have selected in the list.

See also, “Adding a Windows Combo Box"on page 124.

Using a PID Button

Click a configured PID Button in Runtime (see “Adding a Windows Button or a PID Button”on page 121) to
display a SuperTrend in the PIDViewer for the configured PID loop. If Security has been configured for the PID
button, then security restrictions may apply for a given user or group.

B PIDViewer - Temperature @@@

B——p __Input w

C——Input: 40,9 Output: 0.0 Setpoint: oo b ah. - F
D——1/0] (/0] (/0]

E —Gain 00| Turel: [0.4 Tune D:[0.0 Scan Rate: [ 1.0 ‘ Hide G
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(A) Plots. The SuperTrend plots the Setpoint in red, the Input in green, and the Output in blue.

(B) Pen Scale. Click the icon to change the scale of an active pen. In the dialog box that appears, enter new
minimum and maximum values.

(C) Pen Value. Shows the numerical value for the Input, Output, and Setpoint pens. To change a value, see
“Changing the PID Values in Runtime.”

(D) Source/Destination. Indicates the source/destination of the field: Host, | / O, or PID.

(E) PID Tuning. Use Gain, Tune |, Tune D, and Scan Rate to tune the PID.

For more information on PID tuning, see the PAC Control User’s Guide (form 1700). See also, the OptoTutorial:
SNAP PAC PID (form 1641), which we highly recommend for detailed information on PIDs on Ethernet-based
/0 units. Both forms are available for download from our website at www.opto22.com.

(F) Manual/Auto. The PIDViewer starts in its current mode, either auto or manual. Switch to manual mode
by clicking the Man button, or switch to auto mode by clicking the Auto button. A password will need to be
entered if one has been assigned.

(G) Tune/Hide. Click Tune to display the four PID tuning fields (Gain, Tune I, Tune D, and Scan Rate). Click
Hide to hide them. A password will need to be entered if one has been assigned.

Changing the PID Values in Runtime

The following chart shows whether the fields may be changed in Auto and Manual mode, depending on the
Source or Destination of the fields:

Mode Source/Destination Input Output Setpoint
1/0 (PID) No Yes No
Manual
Host No Yes Yes
1/0 (PID) No No No
Auto
Host No No Yes

The fields update in real-time as the values of the PID change. To manually send a value to the field, click in the
field and enter a new value.

For touchscreen terminals, if “Use on-screen keyboard for touchscreens”is set in the Configure > Runtime
preferences dialog, an on-screen keyboard will appear for a writable edit field when the user clicks inside the
field. For more information, see the description for Keyboard Setup in “Runtime Setup: General Tab”on

page 290.
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A: PAC Display Troubleshooting

This appendix provides tips and procedures for resolving problems you may encounter while creating or
running your PAC Display project.

If you are having problems with creating a PAC Control strategy, see Appendix A, “PAC Control
Troubleshooting,”in the PAC Control User's Guide (form 1700). For information about types of errors and lists of
error messages that may appear in PAC Display Runtime, see "Appendix B: PAC Display Errors.”

HOW TO BEGIN TROUBLESHOOTING

Most errors that you encounter in PAC Display occur when you run your project in the Runtime component.
Runtime errors can be the result of several factors: problems communicating with the control engine,
problems in communication between the control engine and I/0, or problems in how an on-screen object is
configured. Errors occurring in PAC Display Configurator, on the other hand, are usually due to incorrect values
being entered in dialog boxes.

The following steps may help you track down the cause of a PAC Display error:

1. Read any Error or Event Messages

Error messages in PAC Display Configurator appear in standard message windows. These messages usually
indicate how to correct the reported problem, as shown in the examples below:

Maximum Percent _ Maximum Value El

'j Integer not within required range: : g
! 0 s i s T ! Mumeric walue required

Error or event messages in PAC Display Runtime appear in the Event Log Viewer as the project runs. To open
the Event Log Viewer window, select View > Event Log. The messages appear along with other diagnostic
information related to your project, as shown in the example below:
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7] Event Log Viewer |:||§|g|

Diagnostic
information from the
control engine.

2008/04/02 10:19:12  Server:Synchronized control engine: =»=3NAPF PAC

The time and date of
the event message
appears here. The error or event
message appears
here.

Auto Restare On Mew Meszage

[]Enable "#waiting Connection' messages

Clear

l Cloze l [ Help ]

See "Appendix B: PAC Display Errors” for information about error messages that may appear in PAC Display
Runtime.

2. Check Communication with the Control Engine

If no error message appears, or the error indicates that there may be a communication problem, first check
whether the computer running PAC Display is communicating with the control engine. Next, check that
communication settings specific to PAC Display are configured correctly.

1. Follow the communication troubleshooting procedure in Appendix A, “Checking Communication with
the Control Engine,"in the PAC Control User’s Guide (form 1700). If the message is “Cannot connect to
scanner,”see also “Problems Due to Microsoft Fast Startup/Fast Reboot” on page 344.

2. Check the refresh time settings used in the PAC Display project (Configure > Refresh Times). These
settings determine how frequently a tag on a control engine is scanned by PAC Display.

See "Chapter 5: Configuring Control Engines and Tags" on page 61 and “Scanning to Update Graphic
Objects”on page 182 to learn how these settings are configured and optimized.

3. Review Other Sections in this Appendix

Check the other sections in this appendix for the following items:

«  If multiple “Bad Quality” or “Not Connected” messages appear when PAC Display Runtime starts, see
“Hiding or Displaying Runtime Startup Messages” on page 341.

«  Ifyou are having problems saving project files to your hard drive or other storage location, see “Problems
Saving a Project”on page 342.

«  Ifanon-screen text string object disappears when you run the project, see “Making an Empty String
Visible”on page 342.

4. Call Product Support

If you cannot find the help you need in this book or in the PAC Control User’s Guide (form 1700), call Opto 22
Product Support. See “Product Support”on page 3 for contact information.
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HIDING OR DISPLAYING RUNTIME STARTUP MESSAGES

When a PAC Display project starts in Runtime, multiple “Bad Quality” or “Not Connected” messages may
appear in the Event Log Viewer. These startup messages appear when the PAC Display project requests values
from the scanner before the scanner communicates with the control engine.

PAC Display Configurator

You can use PAC Display Configurator to prevent these messages from appearing. To hide or display these
Runtime startup messages, do the following:

1. Start PAC Display Configurator', and in the menu bar, click Configure > Scanner Location.
The Select Scanner Location dialog box appears.

2. Select or deselect the Enable “Awaiting Connection” Messages check box to display or hide any “Bad
Quality” or “Not Connected” messages that may occur when the PAC Display project starts.

3. (lick OKto close the dialog box and save your settings.

PAC Display Runtime

When running the project in PAC Display Runtime, the operator can also prevent these error messages from
appearing in the Event Log Viewer. To hide or display these Runtime startup errors, do the following:

1. Start PAC Display Runtime?, and in the menu bar, click View > Event Log.

2. Inthe Event Log Viewer window that appears, select or deselect the Enable “Awaiting Connection”
Messages check box to display or hide any messages that may appear when the PAC Display project
starts.

3. (lick OKto close the Event Log Viewer.

PROBLEMS STARTING PAC DISPLAY RUNTIME PROFESSIONAL

If you are running on Windows 10 and observe any of these issues, the problem may be with a Windows
security setting:
« In PAC Display Configurator Professional, if you select File > Save and Load Runtime, nothing happens
and no error message is displayed.
«  You start PAC Display Runtime Professional with either of the following methods:
—  From the start menu or by double-clicking the application.
—  The technique described in “Creating a Batch File to Start and Run a Project”on page 51.
and you consistently see this message:

DisplayR.pro.exe - Application Error

Py The application was unable to start correctly (0xc0000604).

Click OK to close the application.

To resolve this issue, you need to change a Windows 10 security setting:
1. Onthe Windows Task bar, click Start, then click Settings.
2. Inthe Settings window, click Update & Security > Windows Security > App & browser control.

TFor instructions to start PAC Display Configurator, see page 7.
2For instructions to start PAC Display Runtime, see page 27.
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3. Inthe Exploit Protection section, click Exploit protection settings, then click the Program Settings tab.
Click "+" Add program to customize, then choose “Add by program name”.

5. Inthe Add program to customize window, type DisplayR.pro.exe in the Enter program name field.
Click Add.

6. Windows displays the Program Settings: DisplayR.pro.exe window. In the Arbitrary Code Guard (ACG)
section:

—  If Override system settings is not checked, select the checkbox. If the is slider set to Off, leave it as
Off. If the slider is set to On, click on it to switch it to Off.

- Ifthe Override system settings is checked, make sure that the slider underneath it is set to Off. If it is
not, click on it to switch it to Off.

7. Click Apply. If Windows displays a message asking you to confirm that you want to allow the app to
change your device, click Yes.

8. You can close the Windows Security window and the Settings window.

PROBLEMS SAVING A PROJECT

When trying to save a project in PAC Display Configurator, you may see an error message stating that no
storage space is available on the computer’s hard drive. If this message appears, yet you know that there is
enough storage space for the PAC Display project files, check to see if one or more files are marked “Read Only.

"

To do this, open the PAC Display project folder in Windows Explorer, right-click a project file, and select
Properties from the pop-up menu that appears. If the file is marked Read Only, the check box “Read Only”at
the bottom of the Properties window is checked. Clear this check box, click OK to close the Properties window,
and try saving the project again in PAC Display Configurator.

For additional information on viewing file properties in Windows, see the documentation from Microsoft and
your computer manufacturer.

MAKING AN EMPTY STRING VISIBLE

342

In a PAC Display project, if a text string object in a display sends an empty string to a control engine, the text
string object becomes invisible and can't be selected again. This might happen, for example, if an operator
accidentally cleared a field while entering values in a display.

This problem occurs because the control engine’s string variable is empty, so when the text string object
linked to this variable checks the control engine, it has nothing to display.

To correct this condition, do the following:
1. Open the PAC Display project.
2. Draw orimport a graphic object to be used as a push button.
The object should be approximately the same size as the text string object.

3. Double-click the new graphic object and, in the Graphic Dynamic Attributes dialog box that opens,
double-click “Send String” from the Operator Driven Attributes list.

4. Inthe Dynamic Attributes - Send String dialog box that appears, select “Prompt for Data”in the Source
group and click OK.

5. Click OKto close the Graphic Dynamic Attributes dialog box and save your changes.
Now place the new graphic object behind the text string object as follows:

a. Using the Select tool, select the graphic object and move it until it's directly over the text string
object.

b. With the graphic object still selected, choose Edit > Z-Order > Send to Back.
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7. Save your project and run it in PAC Display Runtime.

If you click in the area of the text string object and new push button graphic object, the Enter String
dialog box should appear, even if an empty string has been sent to the control engine.

PROBLEMS WITH WINDOWS USER PERMISSIONS

When you set up controllers on a computer running the Microsoft Windows operating system, typically you
are using the computer with top-level “administrator” privileges. If someone later uses this same computer to
run PAC Control or PAC Display, but logs in to the computer with lower-level, non-administrator privileges, the
application may not recognize control engines that have been previously configured.

If this problem occurs, you can modify the permissions to let specific users access previously configured
control engines without having administrator access. This is done using the Registry Editor utility. Follow the
steps below.

CAUTION: Use the Windows Registry Editor carefully. It is strongly recommended that you make a backup copy of
your Windows Registry before continuing with this procedure. Without a backup copy, if you delete the wrong
properties and cannot return the Registry to its original state, application and system files can become unusable and
will have to be reinstalled.

Log on as an administrator on the computer where PAC Control or PAC Display is installed.

2. Onyourkeyboard, press the Windows Start key, type run and then press Enter. The Run dialog box
appears.

3. Inthe Openfield, type regedt32 and then press Enter:
NOTE: This is NOT regedit.exe, which is a similar tool.

If a User Account Control window appears, click Yes to continue.
The Registry Editor window appears.
4. Inthe left pane, double-click the HKEY_LOCAL_MACHINE folder to expand it.
5. Inthe HKEY_LOCAL_MACHINE folder, double-click the SOFTWARE folder to expand it.
6. Navigate to the Opto 22 folder by following the instructions for your system type.
- For 32-bit operating systems, in the SOFTWARE folder, click the Opto22 folder to highlight it.
- For 64-bit operating systems:
— Inthe SOFTWARE folder, double-click the WOW6432Node folder to expand it.
- Inthe WOW®6432Node folder, click the Opto22 folder to highlight it.
7. With the Opto22 folder highlighted, click Edit > Permissions on the Registry Editor menu bar.
The Permissions for Opto22 dialog box opens.
8. (lick Add.

9. Inthe Select Users, Computers, or Groups dialog box, type the name of the user or group that should
have control engine access, and then click OK.

The Permissions for Opto22 dialog box reappears.
10. Ifitis not already selected, check the “Full Control—Allow”box in the Permissions area.
11. Click OK to save your changes and close the dialog box.
12. Click File > Exit to close the Registry Editor.

The added users will need to restart their computers for the new permissions to take effect. Then they will be
able to use control engines without having administrator access.
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PROBLEMS DUE TO MICROSOFT FAST STARTUP/FAST REBOOT

Windows Fast Startup (called Fast Boot in older Windows) is a default Windows setting that helps computers
boot up faster.

When Fast Startup/Fast Boot is enabled, Windows does not perform a fresh boot when you start your PC.
Instead, it reuses some information about Windows that it saved when you shut down the PC.

Some applications (including PAC Display, OptoOPCServer, OptoDataLink, and SoftPAC) need a fresh boot up

to properly function and communicate with other applications. When Fast Startup/Fast Boot circumvents this

process, you may see issues such as these:

«  Windows reports an error reading or finding a DLL file.

«  Communication failures ("Cannot connect to scanner” errors) may prevent PAC applications from reading
or updating tag values.

To resolve the issue, disable Windows Fast Startup/Fast Boot, and then restart the computer in order to get a
fresh start.

Another solution that sometimes works is to uninstall PAC Project, reboot the computer, and then reinstall
PAC Project.

For more information, see OptoKnowledgeBase article KB87235, Windows Fast Startup (Fast Boot) can cause
issues.

OPTODISPLS AND PAC DISPLAY RUNTIME

Applicable only to PAC Display versions R9.4g and lower—OptoDispLS.exe is a Windows service that is
installed with PAC Display versions R9.4g and lower. This file is not used in PAC Display R9.5a and higher.

For PAC Display Runtime versions R9.4g and lower to launch properly, Windows must start the OptoDispLS.exe
service before it starts PAC Display Runtime. Under normal circumstances, Windows starts OptoDispLS.exe
when the computer boots up. However, if you have added PAC Display Runtime to your Windows Startup
menu, OptoDispLS.exe may not finish loading by the time Windows starts Runtime.

To make sure that the OptoDispLS.exe service starts first, you can create a batch file that delays the automatic
startup of Runtime. For details, see “Creating a Batch File to Start and Run a Project”on page 51.

OTHER TROUBLESHOOTING TOOLS

344

Checking PAC Project File Versions

Sometimes problems may be caused by older or misplaced files. Product Support may ask you to run
OptoVersion to check the versions and paths of your Opto 22 .DLL and .EXE files. Here’s how:

1. Start OptoVersion:
- InWindows 10, click the Windows Start button, and then click Opto 22 > OptoVersion 10.5.

2. Inthe OptoVersion window, click Find.
The utility searches your hard drive and prints a list of Opto-related files found.

3. Tosee more information on any file, double-click its name. To sort the list in a different order, click any
column heading.

4. To e-mail the information to Opto 22 Product Support, click E-mail.
The utility saves the list to a file named Version.bd in the same directory that contains OptoVersion.exe. If
you use Microsoft Outlook as your e-mail program, a new message automatically appears addressed to
Product Support, with the version file attached.
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5. Ifyou use Microsoft Outlook, add comments to the new message and click Send.

6. Ifyou use another e-mail program, attach the Version.bd file to an e-mail message and address the
message to support@opto22.com, along with an explanation of the problem you're experiencing.
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B: PAC Display Errors

This appendix lists error messages you may see while running a project in PAC Display Runtime. The cause of
each error message is described, and, if possible, corrective action you can take to resolve the problem.

TYPES OF ERRORS

While using the Configurator and Runtime components of PAC Display, several types of errors may occur due
to incorrect equipment setup, out-of-date files, or equipment failure. These errors generally fall into three
categories:

Runtime Errors—These may occur while running a project in PAC Display Runtime. Most of these errors
can be traced to control engine configuration problems or configuration problems with the I/0 unit(s)
connected to the control engine. Runtime errors can be further grouped into several subcategories
based on the type of error that occurs; see “Error Messages in PAC Display Runtime”on page 347 for lists
of error messages in each subcategory.

Configurator Errors—These may occur as you use PAC Display Configurator to create a project (for
instance, adding a dynamic attribute to a graphic object). Errors most commonly occur when entering
data into a dialog box; if an error occurs while doing this, simply re-enter an appropriate value and
continue.

Windows Errors—These may occur while using either the Runtime or Configurator components of
PAC Display. The most common Windows errors occur when too many applications are running at the
same time, reducing the amount of memory available for the operating system. These errors are issued
by the Microsoft Windows operating system running on your computer; see the documentation from
Microsoft and your computer manufacturer for more information about Windows errors.

NOTE: If Windows reports an error reading or finding a DLL when you try to start PAC Display, see “Problems Due
to Microsoft Fast Startup/Fast Reboot” on page 344.

ERROR MESSAGES IN PAC DISPLAY RUNTIME

Error messages that may appear in PAC Display Runtime can be grouped into several categories, which appear
in the table below. Messages for each category, as well as possible causes for the error and corrective actions
to resolve it, are listed for each category.
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NOTE: Many of these error messages also appear when running PAC Control. For additional troubleshooting
information, see Appendix A, “PAC Control Troubleshooting,” and Appendix B, “PAC Control Errors,”in the PAC Control
User's Guide (form 1700).

Runtime Error Category See

File Access Errors page 348
Launch Application Errors page 348
Port Errors page 349
Recipe Upload/Download Errors page 349
Scanner Errors (Quality Errors) page 350
System Errors page 352

File Access Errors

The File Access errors listed below are generated by PAC Display if an error occurred while PAC Display is
working with files or with historical logs.

File access errors usually occur because PAC Display is attempting to modify a file that is marked as Read Only.
If a file access error occurs, first check the Windows file settings for the file being modified (or written to). Make
sure that Read Only is not selected, and verify that the file has the correct access permissions for the operators
who need to use the PAC Display project.

Error Message Possible Causes

The tag name used as a source for a file name could not be used.
Bad string, using default file name. The default file name will be used instead. The default file name was
set up in the Configurator.

A directory could not be created. Check if the directory is being

Can’t make directory created in a read-only directory. Change the protection to allow you to
create it.
Directory now created. Status message indicating that the directory was created.

A file was being written to a drive, but not enough free space was

IR il W) 2 (2520 SIS, available to complete the transaction. Free up some space on the

pended. drive to continue.

Drive is no longer full. Writing has been  Status message indicating that the destination drive has enough
resumed. space available to complete the file writing transaction.

Initial Writing of file: File name Status message indicating that a file name is going to be created.
Invalid directory bad directory name. The specified directory could not be used. The default directory will
Using default. be used instead. The default directory was set up in the Configurator.

Launch Application Errors

The following error messages may appear if an error occurred while working with the Launch Applications
feature of PAC Display:

Error Message Possible Causes

The executable file specified for a launch application setup could not

File not found be found. Verify the directory where the file actually resides.

The drive/directory path specified for the executable in a launch
Path not found application setup does not exist. Verify the actual path of the execut-
able file.
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Error Message Possible Causes

A Windows executable error occurred. Check Microsoft help sources

WinExec error # for clarification about the error number.

The working directory specified for a launch application setup is

WSO PN incorrect. Verify the drive and path.

Port Errors
The following errors are generated by PAC Display if a port-related error occurred:

Error Message Possible Causes

Could not read value(s) from Registry  The registry could be corrupt. Contact Opto 22 Product Support.

Could not write new entry to Registry.
Make sure you have administrative
rights for the computer.

There was a problem writing information to the registry. Contact your
network administrator.

Please reboot for changes in the

Registry to take effect Reboot your computer so that changes to the registry are activated.

Recipe Upload/Download Errors
The following error messages are displayed if an error occurs while downloading or uploading a recipe:

Error Message Possible Causes

Could not find the selected directory for

the recipe destination file. Please The path configured for the destination file of the uploaded recipe is
check to ensure the path is correct. invalid. Make sure the drive/directory path is correct.

(Recipe Upload)

Could not find the selected directory for

the recipe format file. Please check to  The path configured for the format file of the uploaded recipe is
ensure the path is correct. (Recipe invalid. Make sure the drive/directory path is correct.

Upload)

Could not find the selected recipe
format file. Please check to ensure the
file name is correct.

The file name configured for the format file of the uploaded recipe
was not found. Make sure you configured the correct tag name.

The path configured in the destination path could not be created.
Check the drive specified in the path. Also check the read/write pro-
tection of the directory.

Could not make directory for
Destination File: (Recipe Upload)

Invalid type specified. Valid types are:
“Integer Table, Integer 64 Table, Float
Table, String Table, and Chart”

An invalid type was specified in the recipe. Only tags of types integer
table, float table, string table, and chart are allowed in a recipe.

A PAC Control tag name was configured to contain the name of the
destination file, but its contents were empty. Make sure you configure
the correct tag name.

String for destination file was empty:
(Recipe Upload)

A PAC Control tag name was configured to contain the name of the
String for format file was empty format file, but its contents were empty. Make sure you configured the
correct tag name.

The recipe file does not exist! (Recipe
Upload)

The specified chart state is invalid.
Valid states are Stop, Suspend, Start,
or Continue.

The recipe upload file does not exist. Verify the spelling of the file.

Make sure the chart state sent in a chart control instruction was Stop,
Suspend, Start, or Continue.
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Error Message Possible Causes

The control engine specified in the recipe’s PAC Control tag is not
recognized by this project. Verify the control engine name for the tag
name requested. Check the control engine’s spelling.

The specified control engine does not
exist in this project.

The syntax for the PAC Control tag is incorrect. Make sure it follows
this pattern: Control Engine Name:Tag Type.Tagname, where Control
Engine Name is the name of the control engine; Tag Type is

“Integer Table,” “Integer 64 Table,” “Float Table,” “String Table,” or
“Chart;” and Tagname is the name of a PAC Control tag or chart
name of the type specified in Tag Type.

The tag info is formatted incorrectly.
Should be: “Control Engine:Tag
Type.Tag Name”

Check the syntax of the tag value(s) specified for the indexes. Make
sure a colon separates the index from the actual value, and also
verify that the index is within the table’s range.

The tag value is formatted incorrectly.
Should be: “Index (optional): Value”

Uploaded/Downloaded to File: file

name Status message indicating file name was uploaded or downloaded.

Scanner Errors (Quality Errors)
The PAC Display Runtime error messages listed below are displayed if an error occurs with the scanner.

Error Message ‘ Possible Causes

Non-specific The value is bad but no specific reason is known.

Typically caused by a communication failure. Follow the communication trouble-
shooting procedure in Appendix A, “Checking Communication with the Control

Cannot connect to scanner  Engine,” in the PAC Control User’s Guide (form 1700). If the message is “Cannot
connect to scanner,” see also “Problems Due to Microsoft Fast Startup/Fast
Reboot” on page 344.

There is some server-specific problem with the configuration. For example, the
item in question has been deleted from the configuration.

Reading a tag that is a type that should contain a floating point value (analog
input, Float variable, or Float table element) that does not contain a valid floating
point number (it contains an invalid floating point number); in other words, the
value is "not a number", which is sometimes represented as "NAN", "nan",
"-1.#QNAN", or "1 #QNAN".

A "NAN” can occur in the following situations:
» Afloating point variable that is the result of a division by zero
* An analog input point where the analog module is not installed
Configuration Error An analog input point where the brain cannot read the analog module (the brain
thinks the module is not installed).

To troubleshoot the root cause:

1. Use the PAC Control Debugger to inspect the variable or analog input point to
find out what the current value is.

2. Inspect the controller's message queue, which may contain related errors or
warning messages.

3. Inspect the 1/0O unit using PAC Manager to check the 1/0O point configuration
and view the Status Read page to check the "Smart Modules Present" mask and
the "Module <module number> Times Discovered" fields.

4. Measure the voltage downstream of the fuse on the rack where the analog
appropriate input module is installed. The voltage should be 5.00 to 5.20 VDC.

The input is required to be logically connected to something but is not. This may
Awaiting Connection reflect that no value is currently available, for reasons such as the value not
having been provided by the data source.
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Error Message Possible Causes

The control engine has returned an Undefined Command error (-1).
Device Failure This error usually occurs because the requested tag is not defined in the
downloaded strategy.

A sensor failure had been detected (the Limits field can provide additional

Sensor Failure . . oo A
diagnostic information in some situations).

Communications have failed, but the last known value is available. Note that the

Last Known Value “age” of the value may be determined from the TIMESTAMP in the
OPCITEMSTATE.
Comm Failure Communications have failed and no last known value is available.

The block is off scan or otherwise locked. This quality is also used when the

Out of Service active state of the item or the group containing the item is Inactive.

Whatever was writing this value has stopped doing so. The returned value
should be regarded as ‘stale’. Note that this differs from a bad value with
Substatus 5 (Last Known Value). That status is associated specifically with a

Last Usable Value detectable communications error on a ‘fetched’ value. This error is associated
with the failure of some external source to ‘put’ something into the value within
an acceptable period of time. Note that the ‘age’ of the value can be determined
from the TIMESTAMP in OPCITEMSTATE.

Either the value has reached a sensor’s minimum or maximum limit (in which
case the limit field should be set to 1 or 2), or the sensor is otherwise known to
be out of calibration via some form of internal diagnostics (in which case the limit
field should be 0).

Sensor Not Accurate

The returned value is outside the limits defined for this parameter. Note that in
this case (per the Fieldbus Specification) the ‘Limits’ field indicates which limit

has been exceeded but does not necessarily imply that the value cannot move
farther out of range.

Engineering Units Exceeded

The value is derived from multiple sources and has less than the required

Sub-Normal number of Good sources.

The value has been Overridden. Typically this is means the input has been

Local Override . ) ,
disconnected and a manually entered value has been 'forced'.

Invalid item ID. PAC Display generated an invalid ID (typically, for an MMIO tag).

Verify:

» Port numbers of affected tags. (Be sure you're using port 2001 and not port
0xC0040008 22001.)

» IP addresses of affected 1/O units.

After verifying IP addresses and port numbers, use the PAC Display > Tools

menu to autocorrect the tags and regenerate I/O scanner tag names.
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Error Message ‘ Possible Causes

This invalid class string is usually caused by an improperly-installed
OptoOPCServer.
To test this, start the OptoOPCServer Registry Checker:

«  InWindows 7, click the Windows Start button, and then click All Programs
> Opto 22 > PAC Project 10.5 > OptoOPCServer > Registry Checker 10.5.

e InWindows 10 or 11, click the Windows Start button, and then click
Opto 22 > Registry Checker 10.5.

If any entries in the Value column read "Key not found" or something similar, then

OptoOPCServer is installed improperly.

To correct this problem:

0x800401F3 Re-install PAC Project. This is likely to fix it. If it doesn’t, open a command

prompt, navigate to the Windows\system32\OptoCom\ folder, and try the next

solution.

+ If the error is for the first entry (OptoOPC.exe), run this command:
OptoOPC.exe -regserver

* For any of the other dynamic-link library files (DLLs), if they are located in the
OptoCom folder, run this command: regsvr32.exe -<dllname>

If it is successful, a message will appear saying "DIIRegisterServer succeeded

for <DLL name>"

NOTE: Some of the DLLs are located in the Program Files\...\PAC Project X.X

folder. If that is the case, navigate to that folder in the command window and run

the same command.

System Errors

The following error is displayed if a system error occurred:

Error Message Possible Causes

The data returned from the control engine was detected to have a
System: Floating point error N caught  floating point error. This error could have occurred during data
by signal handler manipulations at the control engine. Verify that the data has been
handled or cast properly according to its type.
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This appendix lists the files used in a PAC Display project, including those created automatically when a project
is saved. Use this information as a reference when you are looking through your PAC Display files or working

directory.

DisplayC.basic.exe
DisplayC.pro.exe
DisplayR.basic.exe
DisplayR.pro.exe
DisplayX.basic.exe
DisplayX.pro.exe
*$8$

*alm

* bin
*bmp
* Hit#4
*idb
*ini
*ixw

.uui

PAC Display Configurator Basic executable program file.

PAC Display Configurator Professional executable program file.

PAC Display Runtime Basic Runtime executable program file.

PAC Display Runtime Professional executable program file.

PAC Display Runtime Basic monitor-only version executable program file.
PAC Display Runtime Pro monitor-only version executable program file.

ASClI text file created by PAC Display Configurator using the AutoCorrect Tags option.
The file displays any changes made by the AutoCorrect Tags tools to tag names in
strategies that were incompatible with PAC Display. The file also lists tag name errors
that could not be corrected.

Alarm log file.
SuperTrend historical log file saved in binary format.

Bitmap file, created by other programs or by PAC Display. Graphic objects saved as
bitmaps from PAC Display are not saved with any dynamic attributes that may have
been configured.

Historical data log file, created by PAC Display Runtime. (#### represents the data log
file's internal ID number.)

Main strategy file from a PAC Control program. Lists all objects and other global
information used in a program, as well as control engine configuration information.

The PAC Display initialization file created by PAC Display Configurator. Microsoft
Windows typically names the file type as a Configuration Settings file.

Exported window file created using PAC Display Configurator. Contains all objects and
tags in a specified window in a PAC Display project.

Main project file for a PAC Display project.
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*.msg

*rcp

*smb

* THHH

*ixt

* Wi
*adl
*mpdlin
*pdlinh

*pdlin

PAC Display User's Guide

Event log file, created by PAC Display Runtime.

Recipe file, created by a text editor. Used to send a set of parameters or to read a set
of parameters from a control engine.

Symbol file, created by PAC Display Configurator. Symbol files contain graphic objects
and their configured attributes for use in PAC Display projects.

SuperTrend historical log file, created by PAC Display Runtime. (#### represents the
SuperTrend's internal ID number.)

Dynamic attribute (or “tag info”) report file, created by PAC Display Configurator.
Draw window file, generated by the PAC Display Configurator.
Comma-delimited file containing exported alarm points.

Internal use only.

Internal use only.

Saved user login file.



D: Menus

This section lists in detail the contents of PAC Display menus for both Configurator and Runtime components:
«  "Configurator Menus” (below).
«  “Runtime Menus"on page 370

Note that if a keyboard shortcut is available for a menu command, the shortcut is listed next to the command
in the menu as shown in the example below:

Undo Add Line Ctr+Z

Keyboard
Command Cut Chrl —— Y

shortcut

Copy Chrl+C

Paste Chrl+y

Delete Dl

Duplicate Chrl+D

Select Al

Many menu commands can also be accessed by right-clicking an object or in a window, and then choosing
the command from the pop-up menu that appears.

CONFIGURATOR MENUS

File Menu

New Project. (Ctrl+N) Creates a new project. After selecting this menu option, choose a location and
provide a name for the project in the dialog box that appears. See “Creating a Project”on page 42.

Open Project. (Ctrl+0) Opens an existing project. After selecting this menu option, navigate to and select
the project you want to open in the dialog box that appears. Only one PAC Display project may be open at a
time. See "Opening a Project”on page 47.

Close Project. Closes the project that is currently open. If the project has been modified, you are prompted
to save changes. See “Closing a Project”on page 50.

Save Project. (Ctrl+5) Saves any modifications to the files for the current project. See “Saving a Project” on
page 48.
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Save Project As. (Shift+Ctrl+S) Saves any modifications to the current project to a name and project
directory. This menu option is similar to Save Project, except that you can specify a new name and location for
the saved project in the dialog box that appears. This is a good way to make a copy or a backup version of a
project. See “Saving a Project” on page 48.

You can also copy a PAC Display project to a different computer or drive without using the Save Project As
menu option. To do this, use “Archive Project”.

Save Project and Load Runtime. Saves the current project and then opens it in PAC Display Runtime.
This is a quick way of switching between Configurator and Runtime when you are developing a project. See
“Saving a Project”on page 48.

Archive Project. The project is archived to the current project directory with all the files necessary to
transfer the project to another computer. See “Archiving a Project” on page 49.

Archive Project and Email to Opto 22. The project is archived to the current project directory with all
the files necessary to transfer the project to another computer. The project is attached automatically to an
email addressed to Opto 22 Product Support. In order for Product Support to better assist you, a message will
advise you to use PAC Control to archive the strategy files to submit along with the PAC Display archive. See
“Archiving a Project”on page 49.

Export Project. Exports the project to a text file, which can be used to compare to another project’s
exported text file using a file comparison utility. See “Exporting a Project”on page 49

Each exported text file is formatted for easy reading and includes all the information about the project,
including windows, graphic objects, dynamic attributes, alarm points, historical logs, recipes, and so on.

Project Path. Displays the full directory path to the project’s saved location. The project’s path is also
displayed in the title bar, but if it is too long to fit there, you can use this command to see the directory path.
Click the Open Folder button to open the project’s folder in Windows File Explorer.

Password Protect Project. Protects your PAC Display project with a password to prevent others from
opening and modifying the project using PAC Display Configurator. The project can still be opened and run in
PAC Display Runtime. See “Protecting a Project with a Password” on page 46.

CAUTION: Make sure to keep your password in a safe place. If you forget your password, you will not be able to open
your project in PAC Display Configurator.

Configurator Options. Opens the Configurator Options dialog box.

Load Previous Project at Startup—Select this option to have last project that was opened in Configurator open
automatically the next time the application is run.

Auto Increment Version on Save—Select this option to have a numbered version of the PAC Display project file
created each time the project is saved.

Use Older Dynamic Attribute Dialogs—Select this option to follow the process used in PAC Display R9.6 for
configuring dynamic attributes. For more information, see Appendix , “F: Using the Old-Style Dynamic
Attribute Dialog Boxes,".

Scroll Bars in Windows (Project must be saved, closed, and re-opened)—Select this option to globally add (or
remove) scrolling capabilities for all existing windows in the project (both in Configurator and in Runtime).
Enabling scroll bars allows you to bring into view information that extends beyond the borders of a window.

Notes:

«  Toenable ordisable scroll bars on individual windows, see “Show Scroll Bars” on the “Window Properties
Dialog Box"on page 316.
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«  After you change this option, you must the save, close, and then re-open the project in order for the
change to take effect.

«  This option adds scroll bars to (or removes them from) windows currently in the project. If you enable
scroll bars and then add new windows to the project, the new windows will not have scroll bars. (If this
happens and you want all windows to have scroll bars, unselect this option, save, close, and restart the
project, and then re-enable the option.

Search Grouped Objects—Select this option if you want AutoCorrect Tags to search the dynamic attributes of
individual graphic objects inside a group of objects. If this option is not selected (default), AutoCorrect Tags
searches the dynamic attributes only of the graphic object group (and not of the individual objects in the
group). Selecting this option results in a more thorough search and prevents errors caused when a graphic
object with dynamic attributes that refer to invalid tags is separated from a group. See also “Saving Versions of
a Project”on page 48.

Multi-Monitor Options: Center Dialogs on—Select this option to specify where PAC Display Configurator dialog
boxes should open when you have more than one monitor.

NOTE: This option cannot center the following Microsoft Windows common dialog boxes: Color, Font, File Open, File
Close, and Print. These dialog boxes open where they were last positioned.

e p——
Multiple bonitar Options
Eepieilaloalon Center of Configurator ‘Window w
Center of Configuratar Wfindaw
Overall center of mo
Primary monitor (0,0 - 1920,1080]
Cant ¢.econdary mariitor [-1920.0 - 0,1080]

«  Center of Configurator Window. (Default) Dialog boxes are centered on the main window of PAC Display
Configurator. They will keep centering on PAC Display’s main window, even if you move the main
window to a different monitor.

«  Overall center of monitors. (For use with an odd number—3, 5, 7, and so forth—of monitors.) Dialog
boxes are centered at the center of all monitors. (The center of all monitors is defined by your computer’s
graphics card settings or Microsoft Windows display settings.)

«  Primary monitor (n,n - nnnn,nnnn). Dialog boxes are centered on the primary monitor, regardless of which
monitor displays PAC Display Configurator. (The primary monitor is defined by your computer’s graphics
card settings or Microsoft Windows display settings.)

The numbers in the parentheses are the top left and bottom right coordinates of the primary monitor.
These numbers may differ depending on the monitor’s size and position relative to the other monitors
being used.

«  Secondary monitor (nnnn,nnnn - nnnn,nnnn). Dialog boxes are centered on the secondary monitor(s). All
monitors other than the primary monitor are displayed in the list as “Secondary” monitors.

The numbers in parentheses are the monitor's top left and bottom right coordinates relative to the
primary monitor. For example, a secondary monitor with coordinates of (-1920,0 - 0,1080) would be to
the "left" of the primary monitor, and a secondary monitor with (1920,0 - 3840,1080) coordinates would
be to the “right”of the primary.

Choose Bitmap. Selects a bitmap file for use in the project. After selecting this menu option, in the dialog
box that appears, navigate to and select the bitmap you want to include in the project. Use the Bitmap tool to
place the selected bitmap in the project’s draw window. See “"Adding a Graphic Object”on page 20.

Save As Bitmap. Saves the selected graphic object(s) as a bitmap. After selecting this menu option, in the
dialog box that appears, specify a file name and location for the new bitmap. If no graphic objects are
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selected, then everything in the draw window is saved to the bitmap file name. Any dynamic attributes you
have configured are not saved with the bitmap. See “Saving Objects as Bitmaps”on page 109.

Printer Setup. Selects an available printer and sets its attributes. See “Printing”on page 137.

Print. Prints the contents of any displayed main and draw windows. You can specify the number of copies to
be printed and other options in the Printer Setup command. See “Printing” on page 137.

(Previous File List). The names and directory paths of projects that had been previously opened in
Configurator are listed near the bottom of the File menu.

Exit. Closes the current Configurator windows and exits the application. If you modified the current project,
you will be prompted to save it.

Edit Menu

Undo/Redo. (Available only when you have performed an action that can be undone or redone.) Reverses
an earlier action you have performed, or repeats an action performed earlier. For example, if you have deleted
a graphic object from a window, select Undo to restore the object. If, after restoring the graphic object, you
decide again to delete it, select Redo to repeat the earlier deletion. You can undo up to 50 actions.

Cut. (Ctrl+X) (Available only when you have selected something.) Copies selected graphic objects onto the
clipboard and removes them from the draw window. Cutting something replaces anything stored there
previously. See “Deleting Graphic Objects”on page 115.

Copy. (Ctrl+C) (Available only when you have selected something.) Copies selected graphic objects onto the
clipboard without removing them from the draw window. Copying something to the clipboard replaces
anything stored there previously. See “Copying, Duplicating, and Pasting”on page 109.

Paste. (Ctrl+P) (Available only when something has been copied or cut into the clipboard.) Inserts a copy of
the clipboard contents into the middle of the active draw window. See “Copying, Duplicating, and Pasting”on
page 109.

Delete. (Del) (Available only when you have selected something.) Removes selected graphic object(s) from a
draw window. Unlike the Cut command, Delete removes the selection without placing it in the clipboard;
once you delete something, you cannot retrieve it. See “Deleting Graphic Objects”on page 115.

Duplicate. (Ctrl+D) (Available only when you have selected something.) Creates a duplicate of the selected
graphic object(s). The duplicate is placed directly below the selected graphic objects. Duplicating a selected
graphic object does not use the clipboard. See “Copying, Duplicating, and Pasting”on page 109.

Select All. Selects all the completed graphic objects in the active draw window. Anything that is not selected
within the active draw window when you use this command may be incomplete. Incomplete graphic objects
can be erased by using the Redraw command under the View menu. See “Selecting All Graphic Objects”on
page 104.

Replace. Modifies tag names attached to a graphic object or objects. Allows you to link graphic objects to a
different control engine, item name, table index, or bit index. You can find and replace tags in the entire
project, or just in the selected graphic object(s). See “Finding and Replacing Tags in a PAC Display Project”on
page 81.

Z-Order. (Available only when you have selected something.) As objects are placed in draw windows, they're
assigned a stacking order (or “Z-order”) to define which object appears in front of or in back of another object.
See “Changing Stacking Order”on page 113.
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The position of objects in this stacking order can be modified as follows:

«  Bring to Front—(Available only when you have selected something.) Positions the selected graphic
objects in front of any other objects in the window.

«  Move Forward—(Available only when you have selected something.) Moves the selected graphic
objects one position forward in the stack.

«  Send to Back—(Available only when you have selected something.) Positions the selected graphic
objects in back of any other objects in the window.

«  Move Backward—(Available only when you have selected something.) Moves the selected graphic
objects one position backward in the stack.

Align. (Available only when you have selected more than one object.) Aligns selected objects in a variety of
ways. See “Aligning Graphic Objects”on page 115.
The following choices are available:

«  Left—Aligns the left edges of the selected graphic objects. All selected graphic objects are moved left to
align with the left-most object in the group.

«  Center—Aligns the vertical centers of the selected graphic objects. All selected graphic objects are
moved left or right to align their centers with an imaginary vertical line down the center of the selected
objects.

«  Right—Aligns the right edges of the selected graphic objects. All selected graphic objects are moved
right to align with the right-most object in the group.

«  Top—Aligns the top edges of the selected graphic objects. All selected graphic objects are moved up to
align with the top-most object in the group.

«  Middle—Aligns the horizontal centers of the selected graphic objects. All selected graphic objects are
moved up or down to align their centers with an imaginary horizontal line running across the center of
the selected object.

«  Bottom—Aligns the bottom edges of the selected graphic objects. All selected graphic objects are
moved down to align with the bottom-most object in the group.

«  Space Evenly Vertically—Distributes the selected graphic objects so there is an equal amount of
vertical space between each object.

«  Space Evenly Horizontally—Distributes the selected graphic objects so there is an equal amount of
horizontal space between each object.

Size. When multiple graphic objects are selected, they can be resized equally so that all the objects have the
same height and width. See “Resizing Multiple Graphic Objects to Equal Dimensions”on page 111.

The following choices are available:
«  Grow to Largest Height—All selected objects are resized to the height of the tallest object selected.
«  Grow to Largest Width—All selected objects are resized to the width of the widest object selected.

«  Shrink to Smallest Height—All selected objects are resized to the height of the smallest object
selected.

«  Shrink to Smallest Width—All selected objects are resized to the width of the least wide object
selected.

Flip/Rotate. (Available only when you have selected one or more objects.) Changes the orientation and
rotation of objects. See “Rotating Objects”on page 116.
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Flip Horizontal—Removes selected graphic objects and replaces them with mirror images of the
objects flipped over a vertical center point. Text, trends, bitmaps, and metafiles have their positions

changed but are not mirrored.
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Before flip After flip

Horizontal Flip of a single graphic object
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Before flip After flip
Horizontal Flip of multiple selected graphic objects

Flip Vertical—Removes selected graphic objects and replaces them with mirror images of the objects
flipped over a horizontal center point. Text, trends, bitmaps, and metafiles have their positions changed

but are not mirrored.
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Before flip  After flip

Vertical Flip of a single graphic object
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Before flip After flip

Vertical Flip of multiple selected graphic objects
«  Rotate—Rotates the selected graphic object clockwise.

You can rotate the following objects: Bitmaps, Metafiles, Curves, Polygons, Ellipses, Polylines, JPEGs, PNGs,
Rectangles, Lines, and Text
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For one object:
Enter the degrees of rotation, then click OK.

x]

Rotate Object

Claockwize Rotation [degrees]:

Ratation Options

Rotate each object individually

Fotate all objects around center of group

I ok H Cancel H Help

For more than one object:
Enter the degrees of rotation, select one of the Rotation Options, and then click OK.

Rotate Object &|

Clockwize Fotation [degrees]:

Fatation Options

(*) Fotate each object individually

() Rotate all objects around center of group

I 0k H Cancel H Help l

Rotate each object individually rotates each object the specified number of degrees around its own
center.

Rotate all objects around center of group rotates each object around the center point of all the

selected objects.

Each object rotated individually

Unrotated objects &

All objects rotated around center of group
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Group. (Available only when you have selected more than one object.) Gathers any combination of two or
more graphic objects into a single object. You can then select the graphic object, move it, size it, or assign
dynamic attributes to it as a single entity. In Runtime, only the dynamic attributes assigned to the grouped
object are processed; any dynamic attributes assigned to individual objects that make up the group are
ignored, including trends. See “Grouping and Locking Graphic Objects”on page 105.

Group. (Available only when you have selected more than one object.) Gathers any combination of two or
more graphic objects into a single object. You can then select the graphic object, move it, size it, or assign
dynamic attributes to it as a single entity. In Runtime, only the dynamic attributes assigned to the grouped
object are processed; any dynamic attributes assigned to individual objects that make up the group are
ignored, including trends. See “Grouping and Locking Graphic Objects”on page 105.

Ungroup. (Available only when you have selected a grouped object.) Splits a graphic object on which the
Group command has been used into its original individual components. This allows each graphic object to be
individually selected. If any of the graphic objects had individual dynamic attributes prior to grouping, those
dynamic attributes will be restored, and then configured and processed at Runtime. See “Grouping and
Locking Graphic Objects”on page 105.

Copy to File. (Available only when you have something selected.) Saves the selected object(s) to a file and
saves any dynamic attributes you've assigned to the object(s). Specify the file name, location, and file format
when prompted. The default file name extension is .smb.

Save Metafile As. (Available only when you have a metafile graphic selected.) Saves a selected Windows
metafile graphic to a file. Specify the file name, location, and file format when prompted. You can save the
selected metafile graphic to the Windows Metafile (WMF) format or to the Enhanced Metafile (EMF) format.
Windows metafiles have the file name extensions .wmf and .emf.

Paste from File. Retrieves graphics from a file or from an included library of industrial graphics. See
“Importing a Metafile, JPEG, or PNG Graphic”on page 108.

You can select a graphic using the following menu commands:

—  Built-in symbols—Select this to choose a graphic that has been saved as a PAC Display symbol file.
A dialog box prompts you for the file name, location, and file format of the file you'd like to open.
(Symbol files have the file extension .smb.) Click the Open button to import the selected graphic.

- Symbol Factory—Select this to choose a graphic from a large library of graphics designed for
industrial applications. These graphics are in Windows metafile (WMF) and other file formats. When
the Symbol Factory window opens, browse through the categories and thumbnails provided to find
an appropriate graphic, and then double-click the graphic to copy it to the Windows clipboard.
(Another way to copy a graphic in the Symbol Factory is to select it and click the Copy button.)

Now click the PAC Display project draw window to make it active, and then select Paste from the
Edit menu to add the copied graphic to the window. (You can also paste the graphic by pressing
Ctrl+V on the keyboard, or by right-clicking and selecting Paste from the pop-up menu.)

- Import metafile—Select this to choose a graphic that has been saved in either WMF or EMF
(Enhanced Metafile) format. A dialog box prompts you for the file name, location, and file format of
the file you'd like to open. (Metafiles have the file extensions .wmf and .emf) Click the Open button
to import the selected graphic. You are asked to navigate to and select an appropriate file.

- Import JPEG—Select this to choose a graphic that has been saved in either JPEG format. A dialog
box prompts you for the file name, location, and file format of the file you'd like to open. (JPEG files
have the file extensions jpg.) Click the Open button to import the selected graphic. You are asked to
navigate to and select an appropriate file.

- Import GIF—Select this to choose a graphic that has been saved in either GIF format. A dialog box
prompts you for the file name, location, and file format of the file you'd like to open. (GIF files have
the file extensions .gif.) Click the Open button to import the selected graphic. You are asked to
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navigate to and select an appropriate file. GIF graphics behave differently than JPEG graphics in PAC
Display. For more information, see “Importing a GIF Graphic”on page 108.

- Import PNG—Select this to choose a graphic that has been saved in either PNG format. A dialog
box prompts you for the file name, location, and file format of the file you'd like to open. (PNG files
have the file extensions .png.) Click the Open button to import the selected graphic. You are asked
to navigate to and select an appropriate file.

Edit Dynamic Attributes. (Available only when an object is selected.) Connects a graphic object to a PAC
Control data item. See “Assigning a Dynamic Attribute to a Graphic Object” on page 165. After selecting this
menu option, all applicable dynamic attributes are shown in the dialog box that opens. (You may need to
scroll down or enlarge the dialog box to see all applicable attributes.)

In the Control Engine Driven Attributes area, you configure attributes that are driven by tag values from the
PAC Control strategy running in the controller; for example, you can set up connections so the value of a PAC
Control tag changes the color and fill size of a graphic object.

In the Operator Driven Attributes area, you configure attributes driven by an operator’s interaction with a
graphic object in PAC Display; for example, operators can change the value of a tag in the controller as they
“slide”the object on the screen.

You can configure many different combinations of dynamic attributes for a graphic object. The fields you need
to configure often vary from one dynamic attribute to another.

Copy Dynamic Attributes. (Shift+Ctrl+-C) (Available only when you have a single graphic object selected
and a control engine is configured.) Creates and stores in the clipboard a copy of the selected graphic object’s
dynamic attributes. See “Copying Configured Attributes to other Graphic Objects” on page 169.

Paste Dynamic Attributes. (Available only when you have something selected and have previously
copied dynamic attributes to the clipboard.) Assigns copied dynamic attributes to a graphic object. You can
paste dynamic attributes to one or more selected graphic objects. You can delete existing attributes, or
replace or ignore any duplicate attributes. See “Copying Configured Attributes to other Graphic Objects”on
page 169.

Delete Dynamic Attributes. (Available only when you have something selected.) Removes dynamic
attributes of a selected graphic object. You can delete the dynamic attributes of more than one selected
graphic object. See “Copying Configured Attributes to other Graphic Objects”on page 169.

Edit Text. (Available only when you have a text object selected.) Changes text in a text object. Select the text
with the Select tool, choose this menu item, and then edit the text in the dialog box that appears. See
“Working with Text" on page 119.

Edit Points. (Available only when you have a polygon, polyline, or Bezier curve selected.) Changes individual
points in a polygon, polyline, or Bezier curve. Select the object with the Select tool, choose this menu item,
and then click and move individual points on the object. See “Reshaping Graphic Objects”on page 113.

Lock/Unlock Position. (Available only when you have something selected.) Locks the position of one or
more items in a draw window. See “Grouping and Locking Graphic Objects”on page 105.

View Menu

Hide Menu Bar. Hides the menu bar. The Esc key toggles the menu bar on and off. See “Hiding the Menu
Bar”on page 38.
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Hide/Show Toolbox. (Ctrl+T) Hides or displays the Toolbox. The Toolbox shows the tools you need to
create a project in PAC Display Configurator. If the Toolbox is hidden, the Show Toolbox command is displayed
in this menu. See “Configurator Toolbox"on page 36.

Configure Grid. Displays a Grid dialog box that prompts you to toggle on or off both the Grid and the Snap
On feature. Grids can aid your work in the draw window. You can also enter a Grid size in the Grains/Units area
of the dialog box. The Grid size refers to the spacing of Grid points, measured in pixels. For example, a Grid size
of 10 means a grid point will appear every 10 pixels. Sometimes grids do not appear because the grid size is
too big for the draw window. You cannot display the Grid without specifying a Grid size first.

Hide/Show Grid. (The Grid must first be displayed using the Grids menu item.) Hides or shows the Grid. If
the Grid is hidden, the Show Grid command is displayed.

Turn Snap On/Off. (The Grid must first be displayed using the Grids menu item. Also activate the Snap On
feature in the same dialog box.) Toggles the Snap On feature on or off. Snap On cannot work without an active
Grid. If Snap On is enabled, the Turn Snap Off command is shown.

Redraw. Redraws the contents of the active draw window. Incomplete graphic objects (such as an
incomplete polygon) in the draw window are removed when you select this command. See “Redrawing an
Active Draw Window" on page 37.

Reset Dialog Positions. Resets the following dialogs to appear in the middle of the active display window:
Alarm Points, Application Managers, Control Engines, Historical Data Logs, Event Log Viewer, Sounds, Window
Managers, and the Toolbox. This can help you find a dialog that you think should be open.

Dynamic Attributes. Generates a text file listing the dynamic attributes of objects in one or more draw
windows. This report also lists the configured alarm points in the PAC Display project. The text file can be
analyzed with the next command, Launch Taglnfo View Utility. See “Viewing Tags for One or More Objects” on
page 181.

Launch TaginfoView Utility. Starts a small utility program that lets you sort the order in which tags in the
PAC Display project are displayed. See “Using the TagInfoView Utility Program”on page 181.

Find Tag. Used to locate specific tags used in a PAC Display project. See “Searching for Tags in a PAC Display
Project”on page 81.

Decrypt Runtime Operator Log File. Starts a small utility program that decrypts encrypted Runtime
operator log files.

Style Menu

Use the Style Menu to control the drawing attributes of the graphic tools. Whenever a graphic object such as
a line or rectangle is drawn, the selected style attributes are applied. Combining different style settings allows
you to draw an almost infinite variety of graphic objects. Text attributes, including font style, color, and size, are
assigned in the Text menu.

NOTE: Trends and bitmaps are not affected by style settings.
Line Color. Presents a color palette you can use to assign or change the line color of the selected graphic

object. If no graphic object is selected, the color you choose is set as the default and is then applied as the line
color to all objects you subsequently draw. See “Applying or Changing Line Attributes”on page 105.
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Line Width. Assigns or changes the line width of the selected graphic object. Line widths are shown in
pixels. If no graphic object is selected, the line width you choose is set as the default and is then applied to all
objects you subsequently draw. See “Applying or Changing Line Attributes”on page 105.

O o P o=

Sample Line Widths

Line Style. Assigns or changes the line style of the selected graphic object. If no graphic object is selected,
the line style you choose is applied to all objects you subsequently draw. Line styles other than solid apply
only to objects with a line width of 1. Line widths greater than 1 are always solid. The Invisible line style is used
with rectangles, round rectangles, ellipses, and polygons. If these objects are drawn with the invisible line
style, the border line around the object is not displayed; in order to see them, you must apply a fill. See
“Applying or Changing Line Attributes”on page 105.

Solid
— — —— — Dashed
———————————— Dot
—_ - — - — - DashDot
—— - DashDotDot

Sample Line Styles

L)

With solid  With invisible
line style line style

Example of Invisible Line Style

Fill Color. Assigns or changes the fill color of the selected graphic object. If no graphic object is selected, the
fill color you choose is applied to all objects you subsequently draw. Fill colors affect only rectangles, round
rectangles, ellipses, and polygons. See “Applying or Changing Fill Attributes”on page 107.

Background Color. Assigns or changes the color used behind the fill pattern of the selected graphic
object. If no graphic object is selected, the background color you choose is applied to the fill pattern of all
objects you subsequently draw. Background colors for fill patterns affect only rectangles, round rectangles,
ellipses, and polygons. See “Applying or Changing Fill Attributes”on page 107.

Fill Pattern. Assigns or changes the fill pattern of the selected graphic object. If no graphic object is
selected, the fill pattern you choose is applied to all objects you subsequently draw. See “Applying or
Changing Fill Attributes”on page 107.

Fill patterns affect only rectangles, round rectangles, ellipses, and polygons. If you select a Fill Pattern and your
selected objects still remain unfilled, it may be that the Fill Color is set to white (or a color equal to its
background), or that the Fill Pattern is set to Invisible. Also, you cannot apply more than one Fill Pattern to any
graphic object. This includes using a Percent fill, which fills an object with a percentage of black, creating
levels of gray.

Opagque. Determines how non-solid primary graphic objects, such as dotted and dashed lines, interact with
overlapping objects and background colors. When the opaque style is set, overlapped graphic objects and
background colors are overwritten. See “Applying or Changing Line Attributes”on page 105.

PAC Display User's Guide 365



CONFIGURATOR MENUS

366

Opaque. Determines how non-solid primary graphic objects, such as dotted and dashed lines, interact with
overlapping objects and background colors. When the opaque style is set, overlapped graphic objects and
background colors are overwritten. See “Applying or Changing Line Attributes”on page 105.

Transparent. The opposite of Opaque, Transparent also determines how non-solid primary graphic objects,
such as dotted and dashed lines, interact with overlapping objects and background colors. When the
transparent style is set, overlapped graphic objects and background colors are overwritten only by the solid
portion of the line. See “Applying or Changing Line Attributes”on page 105.

Text Menu

The Text menu items allow you to control text attributes. Text attributes may be set before the text is placed in
the draw window, or changed after it is placed. Style attributes selected from the Style menu do not affect
text. See “Formatting Text”on page 120.

Font. Assigns or changes the font of the selected text. If no text is selected, the font you choose is set as the
default and is then used for all text you subsequently place.

PAC Display supports all TrueType fonts, as well as the ones shown below:

Opto 22 Fixed Serif
Opto 22 Fixed SansSerif
Opto 22 Prop Sertf
Opto 22 Prop Sansserif
Opto 22 Stroke Senf
Opto 22 Stroke SansfSerif

o 22 Jogd

Examples of Supported Fonts

Size. Assigns or changes the size of the selected text. If no text is selected, the size you choose is set as the
default and is then used for all text you subsequently place. Specify the size of the text in points; any value
between 5 and 500 may be used.

Cymmn 10 Point
Cyrano 12 Point
Cyrano 16 Point

Cyrano 20 Point

Examples of Prop Serif Font at Different Point Sizes

Color. Assigns or changes the color of the selected text. If no text is selected, the color you choose is applied
to all text you subsequently place. PAC Display also supports custom color creation.

Background. Assigns or changes the background color of the selected text. If no text is selected, the
background color you choose is applied to all text you subsequently place. Background colors apply only to
opaque text; transparent text is not affected by this setting.
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Text Style. Assigns or changes the style of the selected text. If no text is selected, the style you choose is
applied to all text you subsequently place. PAC Display supports normal, bold, italics, underline, and strikeout
text styles. You can apply multiple styles to text. For instance, you can apply both bold and italics to any text.

Opaque. Determines how text appears when overlapping other objects. Opaque style is applied to text just
like any other style. If the text is set to Opaque, objects under the text will be overwritten by the text
background color.

Object overwritten
Opagque text by opaque text

Example of Opaque Text

Transparent. Determines how text appears when overlapping other objects. The opposite of opaque, if the
text is set to transparent, objects under the text will remain visible and unaffected by the text background
color.

Object is visible
Transpa-/ under text

Example of Transparent Text

Configure Menu

Control Engine(s). Selects which PAC Control strategy (or strategies) is used for this project. The PAC
Display Configurator uses the tag database from the strategy to connect the appropriate PAC Control data
item to the dynamic attribute of a dynamic object. The control engine Properties dialog box prompts for the
PAC Control strategy. If a PAC Control strategy is not configured for this project, dynamic attributes cannot be
assigned to any dynamic objects. See “Configuring Control Engines”on page 61.

Refresh Times. Changes the scan time for a refresh time group. The Refresh Time dialog box prompts you
for the new times. See “Configuring Scan Rates”on page 183 for more information about configuring refresh
times.

Alarm Points. Displays all configured alarm points by user-specified names. This dialog box also allows you
to add, modify, or delete alarm points. See “Configuring Alarm Points”on page 258.

Alarming Setup. Configures alarming features. The Options page sets up various Runtime options, the
Logging page sets up file and printer logging, and the Sound page sets up sound functions. See “Configuring
Project Alarms”on page 277 for more information.

Historical Data Log. Creates historical data logs. A Historical Log List dialog box is displayed and lists the
historical data log files that have been created. This command allows you to modify which points are recorded
and how frequently data is logged to the files. See “Configuring a Historical Data Log” on page 216 for more
information about historical data logs.

Event Log. Records a message caused by an event which can be configured to log to a disk file. You can
change parameters such as the number of messages saved, the delimiter used between messages, and the
file rollover period. File name extensions are .msg. The number of files retained on disk for an event log is also
set within the dialog box. When the limit is reached during Runtime, the file with the oldest time stamp is
deleted. See “Using the Event Log Viewer”on page 325.

(Pro only) You can also log event messages to an ODBC-compliant database. See “Configuring the Event Log
File"on page 316.
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SuperTrend Remote Logging. If the same PAC Display project is running on more than one computer,
this menu item allows you to select the computer that will collect and process SuperTrend historical data. See
“SuperTrend Logging”on page 200.

Applications. Adds or modifies application managers for use in the project. The Application Manager List
dialog box displays available application managers for the project. The Application Manager Configuration
dialog box lets you select the program file, working directory, launch options, initial display view, and trigger
for the application manager. See “Launching Applications”on page 233 for more information about launching
applications based on a trigger.

Recipes. Configures download or upload of recipes to a control engine by a trigger. This method of recipe
management does not require a graphic object to be selected during Runtime for the recipe action to occur.
See “Configuring a Recipe Upload” on page 252 and “Configuring a Recipe Upload”on page 252 for more
information about trigger-based recipe uploads and downloads.

Snapshots. Captures the whole screen and saves it as a bitmap file. You can use snapshots to review what
occurred in Runtime over a period of time, or to capture a triggered event.

Snapshots are taken according to a time interval that you configure. You can use triggers to start and stop the
process. See “Configuring Screen Snapshots” on page 52.

Sounds. Selects sounds and assigns their trigger for use in the project. The Sounds dialog box lists the
available sounds for the project. The Sound Configuration dialog box lets you configure start and stop triggers
with the Trigger dialog box. The Sound Configuration dialog box also prompts you for the sound file. See
“Configuring a Sound” on page 237 for more information about triggering sounds.

Window State. Adds or makes changes to existing window managers. The Window Manager List dialog
box displays all currently configured window managers and allows access to the Window Manager
Configuration dialog box. The Window Manager Configuration dialog box allows you to change triggers with
the Window Manager Start Trigger dialog box and control the draw window visual state with the Pop Window
dialog box. See “Configuring Trigger-Based Window States” on page 238 for more information about
trigger-based window states.

Scanner Location. (Basic only) Allows you to use a remote computer running OptoOPCServer as a
scanner. And, you can set the Scanner Heartbeat Check Interval, the interval in seconds at which PAC Display
will check to see if the scanner is operating. Select the Enable “Awaiting Connection” Messages check box to
display all startup messages. See “Configuring the Scanner”on page 67.

Scanner Defaults. (Pro only) Opens a dialog box for you to set the Scanner Heartbeat Check Interval (the
interval in seconds at which PAC Display will check to see if the scanner is operating). Select the Enable
“Awaiting Connection” Messages check box to display all startup messages. See “Configuring the Scanner”on
page 67.

Secondary Scanner Location. (Pro only) Opens a dialog box for you to set up a secondary scanner
that will be used when the primary scanner is not available. See “Configuring a Remote Scanner in PAC Display
Pro"on page 69.

ODBC Data Source. (Pro only) Opens a dialog that allows you to select an ODBC database that has been
set up to log SuperTrend, historical, and Runtime operator data. Currently supported databases are MySQL,
Microsoft Access, and Microsoft SQL Server. In order to use this feature, the database must already have been
created, and the ODBC connector must be configured. For details, see page 55.

Runtime. Opens a configuration dialog for setting up the PAC Display Runtime session, including
appearance, security configuration, and much more. Using PAC Display Configurator, you can specify which
windows are open or closed, whether the menu is displayed, and whether or not the operator can exit the
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program. You can also customize options for the Event Log Viewer, a window that displays messages about
the status and other characteristics of a PAC Display project. And you can control whether a PAC Display
project gathers I/0 unit information, such as I/0 point states and values, from tags on a control engine or
directly from an /O unit itself. For more information, “Configuring Runtime”on page 289.

Tools Menu

AutoCorrect Tags. Run this tool when you first configure a strategy for your project and after making
changes to your project. The tool verifies tag names from a strategy for compatibility with PAC Display and
changes the tag names where necessary. The tool creates a text file with the file extension .$%$ that
summarizes the changes that the tool made to any tag names. Refer to “Correcting Tags from a Strategy” on
page 83 for more information about this command.

Regenerate 10 Scanner Tag Names. Use this option to regenerate |/O scanner tag names This is
typically done after auto-correcting invalid tags. See also error 0xC0040008, “Scanner Errors (Quality Errors)”
on page 350.

Create Recipe File. Opens the Create Recipe File dialog box for creating either recipe download file or a
recipe upload template. For more information, see “Creating a Recipe Download File” on page 241 and
“Creating a Recipe Upload Template” on page 243.

Edit Recipe File. Allows you to edit an existing recipe file. See “Editing a Recipe Download File"on page 245.

Validate Recipe File. Validates the format of a recipe file, including the structure, tags, and index values.
See "Basic Recipe File Format”on page 246.

Convert SuperTrend Files. Converts a SuperTrend either from text to binary format, or from binary to text
format. See “Converting a SuperTrend Historical Log File for Viewing”on page 206.

Window Menu

PAC Display Configurator allows you to configure several draw windows per project. The Window menu items
control the number and properties of each draw window in a project. You can create draw windows, delete
draw windows, copy draw windows, and change properties of existing draw windows.

New. Creates a new draw or URL (Pro only) window and adds it to your project. You can specify the new
window’s name, size, behavior, and other attributes. You must provide a unique name for each draw window.
See "Creating and Deleting Windows" on page 92.

Open. Opens draw and URL (Pro only) windows that are configured but are currently closed. Select which
window to open from a list of all draw that are closed. Windows that are open when a project is saved are
open when the project is started at Runtime. This can be modified using the Configure > Runtime menu
command. See “Creating and Deleting Windows”on page 92.

Close. Closes draw and URL (Pro only) windows that are currently open. Select which window to close from
a list of all windows that are open. Windows that are closed when a project is saved are closed when the
project is started at Runtime. This can be modified by using the Configure > Runtime menu command.

Copy. Duplicates the active draw window. You must enter a unique name for the duplicate and specify any

properties you wish to change. All graphic objects and their connections in the copied window remain the
same in the new copy. See “Creating and Deleting Windows”on page 92.
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Delete. Removes the active draw window from the project. All graphic objects and their connections in the
active draw window are also deleted. Use caution since deleted draw windows cannot be recovered. See
“Creating and Deleting Windows” on page 92.

Properties. Modifies the properties of the active draw window. You can change the window’s name, size,
behavior, position, color, and other attributes. See “Modifying Draw or URL Windows"on page 94.

Export/Import Window. A PAC Display window can be exported from one project, saved as a file, and
then imported into another PAC Display project. The exported window file contains all the objects and tags
that were in the original window. Exporting and importing draw windows is a convenient way to reuse the
same window in different PAC Display projects. See “Importing, Exporting, and Saving Windows” on page 98.

(Open Window List). Displays at the bottom of the Window menu the names of up to nine currently open
or iconified windows. Select a draw window's name from this list to display that draw window and bring it to
the front. If more than nine windows are open, a menu item named More Windows is added, which you can
use to select a window's name from a list to display it. A window must be open or iconified to be listed.

Help Menu

Contents and Index. Starts Help and displays help topics for PAC Display Configurator.

Manuals. Opens the online version of the PAC Display User’s Guide. This document is in Adobe pdf format,
and the Adobe Reader application is required to view it.

Opto 22 on the Web. Lists useful links to information on the Opto 22 website. Your PC must have an
installed Web browser and be connected to the Internet to access these links.

About PAC Display Configurator. Displays version information about PAC Display Configurator.

RUNTIME MENUS

Runtime menus provide access to the Runtime commands. These commands allow you to open and close
projects, view the event log, and view the control engine configurations.

File Menu

Open Project. Loads an existing project created in PAC Display Configurator. You must navigate to and
select the project you want to open. Scanning and animation begin immediately once the project is loaded.
See "Opening a Project in Runtime”on page 321.

Project Path. Displays the full directory path to the project’s saved location. The project’s path is also
displayed in the title bar, but if it is too long to fit there, you can use this command to see the directory path.
Click the Open Folder button to open the project’s folder in Windows File Explorer.

Printer Setup. Selects an available printer and sets its attributes.

Print. Prints the PAC Display Runtime window. You can specify the number of copies to be printed and also
set up the options available in the Printer Setup command.

Exit PAC Display Runtime. Stops the scanner, closes all Runtime windows, and exits the PAC Display
Runtime.
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View Menu

Hide Menu Bar. Hides the menu bar. The Esc key toggles the menu bar on and off.

Event Log. Displays the Runtime system event log. This log contains system errors and messages received
during Runtime. The list box contains the most recent system event messages generated by PAC Display. Each
message consists of a date and time stamp, and message text. The message text describes events such as
communications and 1/0 errors. Use the scroll bar to view prior messages. If the text of the message is too
wide to completely fit in the list box area, you can double-click the message to display it all. See “Using the
Event Log Viewer” on page 325.

Configuration Status. (Pro only) Opens a dialog that allows you to view and change the control engines
and I/0 units configured for the PAC Display project, or to view and change the status of scanners used in the
PAC Display project. See “Viewing and Changing Control Engines”on page 326 and "Viewing and Changing
Scanner Status”on page 327.

Sync Control Engine Time to PC. Synchronizes the control engine clocks with the clock on the PC used
to sync the control engine’s clock. To choose which PC to use to sync the control engine’s clock, see "Runtime
Setup: Control Engine Tab”on page 294. See also, “Using the Event Log Viewer"on page 325.

Alarm Menu

Modify Alarm Points. Allows the operator to change parameters for alarm points in the PAC Display
project if it has been configured to let the operator do so. See “Modifying Alarm Points”on page 331. Also see
“Configuring Alarm Points”on page 258 to learn more about configuring alarm points.

Alarm point settings can be changed in each one of the five alarm ranges available: HiHi, Hi, Normal, Lo, and
LoLo. Each alarm point state has a value that defines its range.

Alarms Enabled. Disables alarming, including all alarm graphics, sound, and logging. This can be useful
when starting or stopping a process during which alarm conditions may be expected to happen. This menu
item can be initially enabled or disabled through the Alarming Setup dialog box in the Configurator. See
“Configuring Project Alarms”on page 277. It can also be permanently grayed out and made inaccessible by
unchecking the Alarms Enabled menu item option in the Alarming Setup dialog box. This option toggles
alarms between enabled and disabled. A check mark next to Alarms Enabled indicates that alarms are
enabled. No check mark indicates that alarms are not enabled.

Disable Alarm Points. Opens a dialog box that allows you to select individual alarm points to disable for
the current Runtime session only. This is not a persistent option. Disabling an alarm point takes effect after any
current processing is being performed on the selected alarm point. See “Disabling Alarm Points in Runtime”
on page 333.

NOTE: Re-enabling an alarm point will not take effect until the current value of the alarm point changes. If the alarm
point is re-enabled while in an alarmed state, this could mean that an alarm point will not appear in an alarm
graphic, and its configured sound may not play.

Priority Filter. The priority filter level menu items can be used to accept only those alarm points with a
certain priority level. For example, during a startup or shutdown procedure, you may wish to receive only the
most serious alarms. The priority for each alarm point is configured in the Alarm Point dialog box in the
Configurator. See “Configuring Project Alarms” on page 277.

View Alarm Point Details. Lists the configured alarm points and their details.
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Security

Log Out of PAC Display Runtime. If multiple users have been configured in Configurator, you can log
out of Runtime to allow another user to log in. See “Logging In to and Out of Runtime”on page 322.

Change Login Password. Opens a dialog box for the currently logged-in user to change his or her
password.

View Logged-in User. Opens a window showing the user who is currently logged in. Also, a message is
displayed if no one is logged in. See “Logging In to and Out of Runtime” on page 322.

Operator Driven Attribute Access. If global users are configured, a configured user can log in and access
any security-configured operator-driven dynamic attribute. See “Configuring Global Operators”on page 309).

Add/Modify User. Add, modify, or delete a user name in the list of users allowed to log in to Runtime. See
“Configuring Runtime Users”on page 301.

Tools

Convert SuperTrend Files. Converts a SuperTrend either from text to binary format, or from binary to text
format. See “Converting SuperTrend Historical Log Files to Text Format for Viewing” on page 205.

Window Menu

Open. Opens any Runtime window that is currently closed. An Open Window dialog box displays a list of
closed windows from which you can select the window to open.

Close. Opens the Close Window dialog box. Use this dialog box to close windows. All currently open and
iconified windows are listed and any number of them may be selected for closing. If windows are closed in
PAC Display Runtime, any scanning of tag values associated with the windows ceases until the window is
opened again.

Switch Control Engines. Use to connect to different control engines running the same PAC Control
strategy. Select one or more project windows and then select a control engine. All objects with dynamic
attributes will now use tag values from that control engine. See “Switching a Window Between Control
Engines”on page 329 for more information.

(Open Window List). Displays currently open or iconified windows. Up to nine window names are
displayed. Select a window's name from this list to display that draw window and bring it to the front. If more
than nine windows are open, a menu item named More Windows is added; use More Windows to select a
window’s name from a list to display it. A window must be open or iconified for it to be listed.

Help Menu

Contents and Index. Starts Help and displays help topics for PAC Display Runtime.

Manuals. Opens the online version of the PAC Display User’s Guide. This document is in Adobe pdf format,
and the Adobe Reader application is required to view it.

Opto 22 on the Web. Lists useful links to information on the Opto 22 website. Your PC must have an
installed Web browser and be connected to the Internet to access these links.
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About PAC Display Runtime. Displays version information about PAC Display Runtime.
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E: International Characters

PAC Display and the Tag Information Viewer both support Unicode (UTF-16) text to support Asian, Middle
Eastern, and other international languages in an HMI. International characters can be used in the following
PAC Display items:

Text tool objects

Alarm point names and comments
SuperTrend pen names

Window names

Historical data log names and point names

Table control

Refresh group names

Recipe managers

Window managers
Application managers

XY plot titles

Button and PID button text
Combo box control items
View > Dynamic Attributes file
Project export file

Alarm point comma delimited file
Operator Runtime logging file
Alarm History file
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Samples
Text tool
ObjECtS ~—1— Epuwbl Wkl epy Blekwn
i & &=
Inclex wreyep Tafhe Table descri ptiOﬂ
0
1
2
3
[ Window | Help
Mew »
Open...
Close...
Copy...
Delete...
Properties...
Export Window...

Import window...

1 Alarms
2 grvlbbeson

Fushepe AL A0 Window names
4 epuibl Wl BH Krslswg QLITEWLY,

Alarm Points
Name Ref Count Add...
Alarm point names it sl AR ] 2 Modify
gt Bl Z2I5 2
Delete
Duplicate
Esport
[ ok ][ cencel |[ Hep |

USING THE WINDOWS CHARACTER MAP

You can insert Unicode characters using the Windows Character map as follows:
1. Press the Windows Start key, type Character Map and then press the Enter key.
2. Inthe Character Map dialog box:

- Click the Font list, and then select the font you want to use.

- Click the special character you want to insert into the document.
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- (lick Select, and then click Copy.

Open your document and click the location in the document where you want the special character to
appear.

In your document, click the Edit menu, and then click Paste.
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F: Using the Old-Style Dynamic
Attribute Dialog Boxes

NOTE: These instructions apply only if PAC Display Configurator’s options are set to display the older-style (R9.6 and
lower) dynamic attribute dialog boxes (File > Configurator Options > Use Older Dynamic Attribute Dialogs).

If you change your Configurator Options to use the older-style (PAC Display R9.6 and lower) dialog boxes, you

can use these instructions to configure dynamic attributes.

1. With the Select tool |__{|, double-click the graphic object that you want to assign a dynamic attribute to.
(Or, you can click the object once, and then click Edit > Edit Dynamic Attributes in the PAC Display menu
bar).

The Graphic Dynamic Attributes dialog box appears.

This label shows the type Use these fields to change the object’s location (X and Y coordinates) and size.
of object you selected. The Width and Height fields are grayed-out for this object because you can't
\ change a Text Box's size using this dialog box.
AR
Graphic\N<amic Attributes \ X
Object: Text X @ Y: Width: | 51 Height: = 18 Hint... Sequrity...
Control Engine Driven
[ Text Calor
[ visibility,Blink
[ Rotate

[ Horizontal Position
[ vertical Position

Text In from Control Engi . ) .
Il et i Conil e After you select an attribute, its features are displayed here,

in the center of this dialog box.

Operator Driven

[0 Horizontal Slider -~

[0 vertical Slider

[] @ send value

D + Send Discrete

D + Send Siring

O windows Attributes are listed by type.

E Download Redpe If you don't see a specific attribute,

< > it means the attribute doesn’t apply
o B cented to the object you selected.

Beep enabled
Hotkey: [Jctrl []shift | <Nonex

Cancel Help
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2,

3.

Click the name of the attribute you want to assign to the object. (Note: Click its name, not its check box.)

In this example, we'll select Visibility/Blink.
The attribute’s features are then displayed in the center of the dialog box.

Graphic Dynamic Attributes *
Object: Text X; ¥; Width: 51 | Height: 18 Hint... | Security...
Control Engine Driven Control Engine Driven: Visibility/Blink
[ Text Calor Tag  These are the features of the Visibility/Blink attribute.
M ame: )
[ rotate | | 7
[ Horizontal Position ;
[ vertical Position Sl Dicre
[ Text In from Control Engine i B
(O Discrete oM OFF
(®) Current Value isible Inwisible
oot Current ' alue
E Horizontal Slider - Cutoff values:
Vertical Slider
<= $ L= < <= < <= <
i e [« <[ _J¢ «[J¢ <[]
[ & send Discrete E §
[ # send String Vigible  ~ | (Migible  ~ | |Vigble | \Wisible | Wisible )
OO windows
[0  bownload Recipe v Dleadbandy
L | Lisa - >
£ >
Focus-frame enabled
Beep enabled
Hotkey: [Jctl  [shift |<Mone>
I e ) o PR e S P

Configure the features. As you start to make changes, the color of the attribute’s name changes to green,

indicating that configuration is in progress and the changes have not yet been saved.
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If you select a feature that can't be used with another of the attribute’s features, the other feature is
grayed out 50 you can't configure it.

Clicktheattribute’scheck
box after you've finished
configuring its features.

— ]

TIP: Quick Tag Entry
makes it easy to select
tags. For details, see
“Using Quick Tag Entry”
on page 74

Click OK after you've
checked the boxes for all
the attributes you want
to assign to the object.
(You can add or change
attributes later.)

W gl il U G iy B T VN gy gy W T eSS, - p-—,rv-_—(l
Object: Text X X= Width: 51 Height: = 18 Hint... Seoy

4

i

Control Engine Driven Control Engine Driven: Visibility/Blink <
Tag £

L

Controller: Item M ame: Field / [Index] +

|- [ Learming Center | [TREND_PEN_1 | ][z 4

[ Horizontal Position i
[ vertical Position . y
i

Control Engine Seunby DISC[E? J
(O Discrete af 1FF \

(®) Current Yalue Wizible Invizible ¥, d

b,

Operator Driven e ae \‘
E Horizontal Slider - Clhtofaalies ‘)

Vertical Slider
<= (10 < =M < <=112 < <=3 <

S [ |] 9
[ ® Send Discrete {-
[ @ send 5tring Wigible | | Invizible | |Invisible Invigible | Invisible ~
OO windows i
[0 bownload Recipe G e adhand: (‘
Loy T SR 1 u " .
< > Because the “Current Value”feature is selected,
e the fields for “Discrete” are grayed out. ‘_\
Beep enabled -
Hotkey: [Jctd  []shift |<MNonex  ~ 4
4

{

Cancel Help 3!
4

4

When you're finished configuring the feature, click the attribute’s check box. Any errors in
configuration will be displayed in a message box, and you'll need to fix them before the check box will

stay checked.

If there are no errors, the green color disappears from the attribute’s name.
To assign another attribute to the object, repeat steps 2—4.

NOTE: The Send Value, Send Discrete, and Send String attributes can be assigned more than once to the same
object. For details, see “Assigning Send Value, Send Discrete, and Send String” on page 169.

As long as you have assigned at least one attribute to the graphic object, you can also assign these

options:

- Focus-frame enabled—If this option is checked, a light border will appear around the object in
Runtime when the operator moves the cursor over it. This border can be used as a visual aid to let
the operator know that an event will occur when the object is clicked.

—  Beep enabled—If this option is checked, the operator will hear a beep when the object is clicked.
Use this as an audio confirmation.

—  Hot Key—This option associates a keystroke sequence with the object. A hot key is a key on the
keyboard (sometimes in combination with the Ctrl or Shift key) that when pressed, activates the
object’s operator-driver attributes. This lets the operator use a predefined keystroke sequence
(instead of using a mouse click) to select a graphic object, thereby allowing PAC Display Runtime to
be operated without a mouse or similar device.

NOTE: The hot key works only for graphic objects that are in an opened or minimized window; closed
windows are not affected.

- Security—This option defines whether the operator can use the object. For details, see “Security
Settings for Graphic Objects and Dynamic Attributes” on page 176.
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- Hint—This option will display Toolbar text when the operator hovers the mouse pointer over the
object. (Applicable only to basic objects such as lines, rectangles, ellipses, and text). For details, see
“Adding Hint Text to a Graphic Object”on page 175))

6. Whenyou've finished assigning attributes to the graphic object, check to see if any other attribute’s name
is green.
- If you want to keep the attribute, finish configuring it, and then check the box next to its name.
- Ifyou don't want to keep it, just ignore it. It will be cleared (reset) when you close the dialog box.
Then, click OK to save the configuration and close the dialog box.

Notes

You can assign dynamic attributes to only one object at a time. If you want several objects to have the
same attributes, select the objects, and then choose Edit > Group to make them one object. (You can
also right-click the selected graphic objects and choose Group from the pop-up menu.)

NOTE: Ifyou ungroup the objects, the attributes you configured when they were a group aren't retained.

Sometimes after configuring an attribute and checking its check box, the Not Available indicator @
appears in a different attribute’s check box. This means that you can't configure the other attribute
because the two attributes cannot be used together in the same graphic object.

When you assign more than one operator-driven dynamic attribute to a graphic object, the attributes are
executed in the order they appear in the Operator Driven Attributes list.

The color of an attribute’s name changes to green when:
—  Atag has been selected for the attribute.
—  One of the attribute’s features has been changed.

[ts name remains green until you check its check box save the changes, or until you click OK and then
click Yes on the dialog box that warns your changes will be lost.

4
< Inthisexample, the
¢ configuration hasn't been
Object: Rectangle X ¥ Width: Height: Hint... . saved for Fill Color and
< Visibility/Blink. (Their check
Control Engine Driven Control Engine Driven: Visibility./Blink ¢ boxes are not checked.)
[ Line Colar A Tag 1
[] Fill Color Mame: L Thi h
[ vis D oA ;| IS message appears wnhen
ynamic Attributes X
[ rotate % the user clicks the OK button
[ Harizantal Size (width) % to close the dialog box.
[ vertical Size (height) Some attributes [shown in green) have not been fully k.
o Fiwizonkal Posbion o configured, or their checkmark has not been checked, { . )
e 5 e If you click Yes, the dialog box
{ will close and the attributes in
Operator Driven Do you want to continue? E reen WI” be reset
Horizontal Slider A~ X 9 ’
[0 vertical Slider . :.
# Send Value Yes No 1
[ ® send Discrete - =F - - . 3
[] @ send 5tring Yisible v~ [Wisible v |Visble | (Misible v | [ Wisible <

You don't need to completely configure one attribute before starting to configure another. You can start
another by clicking its name. Just remember to complete the configuration and check the box next to
the attribute’s name before closing the Graphic Dynamic Attributes dialog box.

Editing Tag Names Manually

When editing tags for dynamic attributes, notifications and triggers, you can manually type in a valid tag
name for a control engine, item name, table index, or bit index.
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CAUTION: Use caution with this feature, as unexpected results may occur if you enter an invalid tag. For best results
when configuring and editing tags, use Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75).

Use the following guidelines for tag names:

Make sure the new tag name is the same item type. For example, if a strategy contains two Integer32
variables called MyInt_1 and MyInt_2, as well as a float variable called MyFloat, you are allowed to
change MyInt_1 to Mylnt_2 because they are both Integer32 variables. However, changing MyInt_1 to
MyFloat will result in an error because MyFloat is a different item type.

Modify only pre-existing tags. You cannot create a new tag by entering the name. If no tag has been
configured, double-clicking the tag name field will sound a beep, and the field will remain read-only.

If the existing tag has a field attribute (such as Pid.Setpoint or ControlEngine.Date), you can change only
the field attribute.

For example, ControlEngine.Date is a string tag and has a field attribute (.Date ). You cannot change
ControlEngine.Date to My_String_Variable, even though both are string types. You can change only the
Date field attribute to .Time, .StrategyName, etc. This applies to PIDs and other tags that have field
attributes.

To edit a tag:
On a Dynamic Attribute dialog box, double-click in the Name field.

1.

Dynamic Attribute - Text In from Control Engine

Tag | Double-clickin
M arme: the Name field
10.192.54 68:Floal_Vert_Shder 2
Setup By Walue Text Justification MHurnenical Farmat
() Walue Deadband: () Laft () Decimal
() Discrete D () Center () Hexadecimal
() Sting ) Right ) Binary
() Exponential
Discrete
l 0k l [ Cancel ] l Help l

A message box warns that Opto 22 does not recommend manually changing the tag name.
Click OK, and then edit the name using the guidelines detailed above.

Click OK.

If the name is not valid, a message appears.

Invalid Tag Change E|

The taq is invalid.
werify the Following:
1 - Is the item name correctly spelled?

Z - Is the item bype correct for this ikem name?
3 - Are any element or bit indices walid?
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4. C(lick OK to exit the message dialog, and then enter a valid tag name, or select a valid tag name in the
usual manner.

Assigning a Chart State Value to a Graphic Object

You can assign chart states (such as stop and start) to a graphic object either as control engine-driven
attributes or as operator-driven attributes.

Control Engine-Driven

To assign chart states as control engine-driven attributes:
1. Double-click the graphic object to which you will assign a chart state attribute.

2. Under Control Engine Driven Attributes, double-click one of the color attributes you want to use (such as
Fill Color). See also, “Fill Color” on page 397.

Control Engine Driven: Rill Color
Tag

Mame;

Setup By Dizcrete
() Discrete
(®) Current Value

Current W alue
Cutoff values:
<=| |< <=| |< <=| |< <=| |<

Husteresiz

L]

3. Under Cutoff values, enter the values as shown above. Each value (except 0, which is a placeholder)
correlates to one of the following chart states.

Value Chart State

1 Stopped
2 Suspended
3 Running

Select a color for each value.
Configure a tag for this dynamic attribute, then click OK. (See also, “Configuring Tags” on page 74.)
Click OK again to close the dialog box.

o v »

Operator-Driven

To assign a chart state as an operator-driven attribute:
1. Double-click the graphic object to which you will assign a chart state attribute.
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Under Operator Driven Attributes, double-click Send Value. See also, “Send Value”on page 406.

Operator Driven: Send Value

Tag

M ame:

| [
Source Destination

(®) Fized data () Prompt for data (@ 5et () Offgat

Fined Data Frompted Data:

Walue: I:I

Under Source, select either Fixed data or Prompt for data. For Fixed Data, enter one of the following
values:

Value Chart State

1 Stop
2 Suspend
3 Start
4 Continue

Or, for Prompted Data:

a. Create a User Message.
b. EnteraMinValue of 1.
c. EnteraMax Value of 4.

In Runtime, the user enters 1, 2, 3, or 4 to stop, suspend, start, or continue the chart as indicated in the
table above.

Configure a tag for this dynamic attribute, then click OK. (See also, “Configuring Tags” on page 74.)
Click OK again to close the dialog box.

Adding Hint Text to a Graphic Object

Follow the steps below to add hint text to the Tooltips box of a basic graphic object such as a line, rectangle,
ellipse, or text. The Tooltips box is displayed when the mouse is hovered over the graphic object in Runtime.

NOTE: Only one instance of hint text can be applied to a graphic object. Hint text is not attribute-specific.

1.

2.

Double-click the graphic object to which you will provide hint text. This opens the Graphic Dynamic
Attributes dialog box.

On the right side of the Graphic Dynamic Attributes dialog box, click the Hint... button to open the Hint

Text dialog box.

Hint Text X

Enter Hint Text (80 chars. max)

Cancel
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3.

5.

Enter the hint text. For example, you might enter, “To start the process, click the Start button.” Hint text is
limited to 80 characters.

To wrap text to the next line, add \r to the text. For example, if you enter the following text,
Boiler Door Open?\rYellow = Yes\rRed = No

Hint Text X

Enter Hint Text (80 chars. max)

Boiler Door Open?irYellow = Yes\YRed =No | |

Cancel

The portions of text beginning with “Yellow”and “Red” will each wrap to the next line. In Runtime, the
Tooltips box in Runtime will appear like this:

Boiler Door Openy
Yellow = Yes
Red = No

Click OK. Then, click Configure > Runtime to open the Runtime Setup dialog box. Then click the Control
Engine tab.

Runtime Setup >

General Windows/Dialogs Cortrol Engine  Security 140 Unit Tags

Off-line Control Engine Color Options

Last Known ¥ alue colar: - Comm. failure color: -

Enable graphic color change
Synchranize Contral Engine Clocks ta PC Clock
Every 7 daysat 2 00 Abd

[] Enable Auto Synchronization ] Synchionize at Runtime startup

Synchronize Control Engine “With

(® Local Computer () Remote Computer |

Contraller Driven D ynamic Attributes

[ &llowe Runtime Toolips ] Shaw Hint Text Only

Fead /wite Timeout

Timeout [sec.]

Ok Cancel Help

On the Control Engine tab, select Allow Runtime Tooltips, and then click OK to close the dialog box and
save the settings.

PAC Display User's Guide



APPENDIX F: USING THE OLD-STYLE DYNAMIC ATTRIBUTE DIALOG BOXES

Assigning Multiple Dynamic Attributes to a Graphic Object

When you assign more than one dynamic attribute to a graphic object, the attributes are executed in the
order they appear in the Operator Driven Attributes list.

When triggered during Runtime, multiple attributes are
performed in the order they appear in the Operator

Driven Attributes list. \}i Wwidth: Height; Hirit. .

¥
' 4
!
i

—

Operatar Driven Abtibutes

{ [0 etical Slider ~ Edit..
! o ® Send Value

;' ] @ Send Discrete Clear
i O ® Send Sting

4 e Wwindows

’ .

i [ Download Recipe

4 0 IUpload Recipe v S
fg < » -
' Focusz-frame enabled Beep enabled

{ Hot Kep: []JCl []Shitt | «<Manes ~

’

4

4

¥

ASSIGNING OPERATOR-DRIVEN SUB-ATTRIBUTES

You can assign multiple sub-attributes for three operator-driven attributes: Send Value, Send Discrete, and

Send String.

1. Choose the Select tool from the toolbox and double-click the graphic object to which you want to assign
a dynamic attribute.

2. Configure aninitial attribute for Send Value, Send Discrete, or Send String. For more information, see
“Available Dynamic Attributes”on page 393.

3. Inthe Graphic Dynamic Attributes dialog box, click the + icon next to attribute you just configured. In this

example, Send Value is used.
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A Send Value sub-attribute is now available.

Graphic Dynamic Attributes

Object: Group

Control Engine Driven Attnbutes

%[

Witk Height:

Qperator Driven Attributes

<

[] Line Colar

] Fill Calor

] Text Calar

[ wisibility/Blink

[] Rotate

] Haorizarkal Size [width)
[ wentical Size (height]
[] Horizonkal Position
] “ertical Position

[ &lam Point

£

| @

Edit...

Clear

[ o

H Cancel ][

Help ]

O
O

O
O

O
<

Horizontal Shider L Edit...
Wertical Shider
SendYalue
< available: \
Send Dizcrete

[# Send Sting
wiindowes hd

|

Focus-frame enabled Beep enabled

HotKey: []ctl [ Shit

4.

this graphic object.
A second Send Value sub-attribute is now available.

Operatar Driven Attributes

O
O

O
D 7]
O=m
<

Huorizontal Slider
Wertical Slider

| Semd Value

Contral Engine:bDaughl —

<available:
Send Digcrete
Send String bt
| >

Focus-frame enabled Beep enabled

Hot Key: (]l [ Shift i_<Ncune> L4

[ ———— ___ Second available

sub-attribute

~ Available

sub-attribute

Select the item marked <available>, and then click Edit to configure a new Send Value sub-attribute for

The Send Value item is now displayed in a bold italic font. This indicates that the dynamic attribute has at
least one sub-attribute configured. As more sub-attributes are added, additional <available> items
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appear in the attribute tree. If you collapse the Send Value item, you can still see the sub-attributes by
hovering over Send Value.

Operator Driven Attributes

[]  Horizontal Slider -~

[ wertical Shider

 Serd Value

D + Se lerete |

[] ® 5er| Contral Engine:Daugh_Chip_Contral State
O wi Contral Engine:bDoughlevelSwitch  ——

| [ Download Recipe w I

| £ >
Focus-frame enabled Beep enabled

| Tooltip shows
sub-attributes

Hot Kew []Chl [ Shift ?”<Ncune> V:

Reordering Sub-Attributes

Dynamic sub-attributes are sent to the device in the order displayed in the list. To change the order of the
sends, select a sub-attribute, and then drag it to a new position in the list.

NOTE: Only sub-attributes can be reordered. A parent attribute (such as Send Value) cannot be moved.

Clearing Dynamic Sub-Attributes

To clear a single dynamic sub-attribute:
1. Expand the attribute tree and select the sub-attribute.
2. C(ClickClear.
Any sub-attributes below the cleared sub-attribute will move up in the list.

To clear more than one sub-attribute:
1. Select the top-most dynamic attribute, such as Send Value, and then click Clear.
The Clear Operator Driven Attribute dialog box opens.

Clear Operator Driven Attribute *

(®) Clear Selected Attribute Only

() Clear &l Attributes

Carcel

2. Choose one of the options:

—  Clear Selected Attribute Only clears the top-most attribute, such as Send Value. The first
sub-attribute moves up to replace the top-most attribute. All other sub-attributes move up in the
list.
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Top-most attribute to——
be cleared

O <availablex
[] ® Send Discrete

£

[]  Horizontal Slider ~
[0 Wertical Slider
JENEN 5end Valua

Control Engine:bChipley—
Cantral Engine: T emperat

b
| @

— First sub-attribute /'

becomes the new top
Send Value attribute

[]  Horizontal Slider ”~
[0 Vertical Slider
y[] = Send Value
Contral Engine: T emperat—
[ <avaiable>
[] ® Send Discrete
[] ® Send Sting w

< |

|

—  Clear All Attributes clears the top-most attribute and all sub-attributes below it.

CONFIGURING SECURITY PERMISSIONS FOR GRAPHIC OBJECTS

NOTE: Security permissions are applied to all dynamic attributes selected before you click the Security button. If a
graphic object needs to have multiple dynamic attributes, make sure to select and configure all attributes before

390

configuring

To assign user- and group-based security permissions to a graphic object:

security settings.

1. Double-click the graphic object to which you will assign one or more operator-driven dynamic attributes.
The Graphic Dynamic Attributes dialog box opens. Note that the Security button on the right side is not

active.

2. Double-click an operator-driven attribute that you want to use, configure it as needed, and then click OK.
The Graphic Dynamic Attributes dialog box is again visible, and the Security button is now active.

Graphi

Control

Object: Round Rectangle

¢ Dynamic Attributes

| Engine Driven

i
7 wi

[ Line Colar -

[ rotate

[ Horizontal Size (width)
[ vertical Size (height)
[ Horizontal Position

Il Color
sibilityBlink

- v
£ B >
Qperator Driven
[ & send string A
Windows
[0  bownload Recipe
O Upload Recipe

Menu ke

Width: Height:

Operator Driven: Execute Menu fem

*

Sl

Alarmz/tadify Alarm Points
Alarmz/Priority Filker/100 And Above
Alarmz/Priority Filker/200 And Above
Alarmz/Priority Filker/300 And Above
Alarmz/Priority Filker/400 And Above
Alarmz/Priority Filker/500 And Above
Alarmz/Priority Filker/600 And Above
Alarmz/Priority Filker/700 And Above
Alarmz/Priority Filker/800 And Above
Alarmz/Priority Filker/900 And Above
Alarmz/Priority Filker/al Levels
File/Change Printer...

File/E =it PAC Display Runtime

File/Open Project...
il Dt

After configuring one or more
operator-driven dynamic
attributes, click Security to
configure user-and group-level
authentication for the graphic
object.

3. (Click Security to configure user- and group-level authentication for the graphic object.

The Define Security Permissions dialog box opens.
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Define Security Permissions Dialog Box

Define Security Permissions .

Select Uszer / Group

Domain: Runtime Users £ Groups A
Users / Groups: | SUpervisars —B
c_ Permisziohs

() Grant &ccess () Denw Access

D__Show Configured Users... Cleardsl ————1— E

F— Cancel Help

(A) Domain. To set permissions based on Windows authentication, select the Windows domain that
contains the operator (or group) to whom you want to grant or deny access. To select a custom-configured
user or user group, select Runtime Users / Groups.

(B) User/Groups. Select the user or group to whom you want to grant or deny access to the object.
(C) Permissions. For the selected user or group, select Grant Access or Deny Access.

(D) Show Configured Users. Click Show Configured Users to view all permissions currently assigned for
the graphic object.

(E) Clear All. Click Clear All to erase all configured permissions for the graphic object.

(F) OK. Click OK to save changes, or click Cancel to close the dialog box without any changes being made.

Copying Security Permissions to Other Graphic Objects

To make security configuration easier and less error-prone, you can copy a graphic object’s security
permissions and then apply them to:

«  One or more selected graphic object
« Al graphic objects in a PAC Display window
«  All graphic objects in a project

To copy and apply security permissions:
1. Click the graphic object whose security permissions you want to copy.

(Sizing handles—the small black boxes around the graphic object—indicate that it has been selected.)
2. Copy the graphic object’s permissions. There are two ways you can do this:

- (lick the graphic object, and from the menu bar, click Edit > Security Permissions > Copy.

NOTE: This method is required when copying or applying permissions to Alarms, XY Plots, Trend, and
SuperTrends.

- Right-click the graphic object, and from the pop-up menu, click Security Permissions > Copy
Security Permissions > Copy.
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NOTE: If the Copy selection is grayed out, it means the graphic object you selected doesn't have configured
security permissions. First, you must configure permissions for the graphic object; then Copy will be enabled
when you select the object.

3. Select the graphic object to receive the copied security permissions.
- Toselect more than one graphic object, press and hold the Shift key while clicking the objects.

- Toselect all graphic objects in a window or all graphic objects in the project, click anywhere in the
window.

NOTE: In order to receive the copied permissions, the target graphic object must have at least one configured
operator-driven dynamic attribute.

4. Right-click to display the pop-up submenu (or in the menu bar, click Edit > Security Permissions).

Cut

Copy
Paste
Delete
Duplicate

Replace...
Z-Order

Align

Size

Group
Transparency...

Lock Position

Unlock Position

Dynamic Attributes

- Select Paste to overwrite the target graphic objects’ existing security permissions.

- Select Merge to keep the target graphic objects’existing permissions and add the copied
permissions.1

The Security Attributes dialog box opens.

Paste Security Attributes X | Ifyou select Merge, the Merge Security Attributes
Paste Attributes To dialog box opens.
® f It has the same options as the Paste Security
O This Window Attributes dialog box.
(O &l windows
I QK I | Cancel | | Help |

5. Choose the target:
—  Chosen graphics—Selects only the currently selected graphic object (or objects).
- This Window—Selects all graphic objects in the current window.

"When permissions conflict—for example, when you paste a Grant Access permission to a graphic object that is
already configured with Deny Access for the same user (or user group)—PAC Display always applies the most
restrictive permission. In this example, the user (or group) would be denied access to the graphic object.
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- All windows—Selects all graphic objects in all windows in the project.

6. Click OK to save the settings and close the dialog box.

AVAILABLE DYNAMIC ATTRIBUTES

You can add the dynamic attributes listed below to a graphic object. Note that not all attribute types are
available for all types of graphic objects; only attributes that can be used with a particular graphic type appear

in the Dynamic Attributes dialog box.

For Discrete control engine-driven attributes and the Send Discrete operator-driven dynamic attribute, you
have the option of specifying a bit index for integer tag types by using either Quick Tag Entry (see page 74) or
the Tag Selection dialog box (see page 75).

Dynamic Attribute

Alarm Point, page 393

Control Engine Status, page 394
Download Recipe, page 395
Execute Menu Item, page 397
Fill Color, page 397

Horizontal Position, page 398
Horizontal Size (Width), page 399
Horizontal Slider, page 400
Launch Application, page 400
Line Color, page 402

Read and Clear, page 403
Rotate, page 404

Send Discrete, page 405

Send String, page 406

Send Value, page 406

Text Color, page 407

Text In from Control Engine, page 409
Upload Recipe, page 410
Vertical Position, page 412
Vertical Size (Height), page 412
Vertical Slider, page 413
Visibility/Blink, page 414
Windows, page 416

Type

control engine-driven
control engine-driven
operator-driven
operator-driven
control engine-driven
control engine-driven
control engine-driven
operator-driven
operator-driven
control engine-driven
operator-driven
control engine-driven
operator-driven
operator-driven
operator-driven
control engine-driven
control engine-driven
operator-driven
control engine-driven
control engine-driven
operator-driven
control engine-driven

operator-driven

Alarm Point

Use this attribute to change the color of a graphic object based on the state of an alarm point. You can use this
attribute with circles, rectangles, and polygons. By default, the color of the graphic object corresponds to the
Normal, or unalarmed, state. See also, “Configuring Alarm Points”on page 258 and “Configuring Project

Alarms”on page 277
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Double-click Alarm Point in the Graphic Dynamic Attributes dialog box to display the Dynamic
Attributes-Control Alarm Point dialog box.

Control Engine Driven: Alarm Poiint

Alarm Points
B Dizcrete
On uli} Ack'ed  Silenced
N ey
C Walue

HiHi Hi Momal Lo Lolo  Ack'ed Silenced

(A) Alarm Points. The names of the alarm points configured for the project appear here. Click an alarm
point in the list, and then set the colors that will be used for the graphic object in the Discrete group or the
Value group.

Alarm points that monitor digital points are configured as discrete alarm points, and have four states: On, Off,
Ack’ed, and Silenced. Alarm points that monitor analog points are configured as value alarm points, and have
six states: HiHi, Hi, Normal, Lo LolLo, Ack’ed, and Silenced. See “Configuring Alarm Points”on page 258 for more
information about setting up alarm points.

(B) Discrete. To select colors for a discrete alarm point’s On and Off states, click the color box for each state
and then choose a color in the dialog box that appears. If you have selected an alarm point for a digital I/O
point, only the Discrete group will appear in the Dynamic Attribute - Alarm Point dialog box.

(C) Value. To select colors for a value alarm point’s HiHi, Hi, Normal, Lo LoLo, Ack’ed, and Silenced states, click
the color box for each state and then choose a color in the dialog box that appears. If you have selected an
alarm point for an analog I/0 point, only the Value group will appear in the Dynamic Attribute - Alarm Point
dialog box.

Control Engine Status

Use this attribute to change the color of a graphic object based on the status of one or more control engines.
You can use this attribute with circles, rectangles, and polygons.

NOTE: When the Control Engine Status dynamic attribute is selected, all other Control Engine-driven attributes are
disabled.

If the Control Engine Status attribute is used to monitor multiple control engines, the graphic object will
display the status color for the control engine that is in the most critical condition. Least critical to most critical
status is shown below:

Least Critical - P  Most Critical

Attached Last Known Comm
Value Failure
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Double-click Control Engine Status in the Graphic Dynamic Attributes dialog box to display the Dynamic
Attributes-Control Engine Status dialog box.

Dynamic Attributes - Control Engine Status Dialog Box

Control Engine Driven: Control Engine Status
Select Controller
A— Leaming Center
10198 14
Boiler
Chamber 1
PALC Sim

B — [J5alact i

c Colors
Attached Last Known Yalue Comm Failure

(A) Select Controller. The names of the control engines configured for the project appear here.

Select a control engine. To select multiple control engines, hold down the Ctrl key and click each one you
want to select.

(B) Select All. To select all control engines in the list, click Select All.

(C) Colors. To select colors for a control engine’s state, click the color box for the state and then choose a
color in the dialog box that appears.

Download Recipe

Use this attribute to download a recipe file to a control engine when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text. For more information about recipes, see “Configuring Recipes”on page 239.

To display the Dynamic Attribute - Download Recipe dialog box, double-click Download Recipe in the
Graphics Dynamic Attributes dialog box (Edit > Edit Dynamic Attributes).

Operator Driver: Downlfoad Recipe

Recipe File
A— Diirectary: | | LogFrom... =™ B
take Path Relative to Project [ ] ——— c
D — File Mame

E (®) Fired name Fined Name: | Extension: — F
i ?

G () Prompt for name
() Fram strategy

Name (Trigger-based recipe download). Enter a name for this recipe. This name is used to refer to this
trigger-based recipe in the Recipe Managers list dialog box. The name can be up to 40 characters long.

(A) Directory. Enter the directory location of the recipe file. Use the button B to quickly enter a directory
name.
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(B) (Basic only) Browse. Click to quickly find the recipe file directory for A. Use the Select Download File
Directory dialog box that appears to navigate to the desired directory, and then click OK.

(B) (Pro only) Log From. Click to select whether to log from an ASClI recipe file or from a database table.

« Ifyou click Log File in the pop-up menu, use the Browse for Folder dialog box to navigate to the desired
directory, and then click OK.

« Ifyouclick Log File in the pop-up menu, use the Select Database Table dialog box to select the desired
table, and then click OK. For more information about logging to a database table, see “Configuring an
ODBC Data Source”on page 55.

(C) Make Path Relative to Project. When selected, if you copy the project and recipe files to a different
computer, PAC Display will look in the same relative location to find the recipe files in Configurator and
Runtime.

For example, if the project is saved in C:\proj\ and you configure recipes files to be in C:\proj\recipes\, then the
relative path would be this: \recipes\

If you then saved the project to C:\temp\newproj\, PAC Display would look for recipe files in the new location’s
relative path: C:\temp\newproj\recipes\

(D) File Name. Choose the source of the recipe file name:
Fixed Name

Check this if the recipe file is a file name you want to configure at this time. If this option is selected, the
File Name edit box appears, prompting you for a file name. Make sure the file exists in the Directory entry,
otherwise an error is posted. The file name may not be changed at Runtime.

The Extension parameter also appears and prompts for a one to three character long extension that's
appended to the Fixed Name. The extension must not contain a period or a DOS wild card character. The
default extension is "rcp”.

Prompt For Name

Check this if the recipe file name is to be prompted at Runtime when the trigger occurs. If this option is
selected, the Extension parameter also appears. Enter a one to three character long extension which does
not contain a period or a DOS wild card. This extension is used as a filter to select which files are displayed
when prompting a user for the recipe name at Runtime, however files with different extensions may be
selected.

From Strategy

Check this option if you want to use a string tag name from the control engine strategy to specify the
recipe file name. If this option is selected, the String Name edit box appears, prompting for the name of
the PAC Control tagname you want to use. Use either Quick Tag Entry (see page 74) or the Tag Selection
dialog box (see page 75) to select a tagname.

(E) Fixed Name. If Fixed Name was selected in File Name (D), enter the name of the recipe file located in
Directory (A). Notice the file extension is .rcp.

(F) Extension. Specify the file extension for the recipe files available to this dynamic attribute by entering
the extension in the File Extension field. The extension must be one to three characters long and must not
contain a period or DOS wild card characters.

If Fixed Name is checked, this extension will be appended to the File Name entry to create the name for the
recipe file. If Prompt For Name is checked, this extension will be used as a filter to select the files for display in
a file selection dialog box when PAC Display Runtime executes this dynamic attribute; however, you may
override this filtering if you wish to select a file with a different extension.

(G) String Name. If From strategy was selected in Fixed Name (D), use either Quick Tag Entry (see page 74)
or the Tag Selection dialog box (see page 75) to select a tagname.
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Execute Menu Item

Use this attribute to run a single Runtime command when an object is clicked. This is useful if you want to
hide the menu bar and allow only limited access to certain items. This is an operator-driven attribute and is
available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.

Double-click Execute Menu Item in the Graphics Dynamic Attributes dialog box to display the Runtime Menu
Commands.

Operator Diven: Execute Menu Fem

fdenu ltem:;

Alarmz/alarms Enabled A
Alarmns/Dizable Alarm Points..
Alarmz/todify Alarm Points
Alarmz/Priority Filter /100 And Above
Alarmz/Pricrity Filber /200 And Above
Alarmz/Priority Filter /300 And Above
Alarmz/Pricrity Filker /400 And Above
Alarmz/Priority Filter /500 And Above
Alarmz/Priority Filter B00 And Above
Alarmz/Priority Filter/ 700 And Above
Alarmz/Pricrity Filber 200 And Above
Alarmz/Priority Filter 300 And Above
Alarmz/Pricrity Filter 241 Levels
File/Change Printer. ..

File/Exit PALC Display Runtime
File/Open Project..

File:/Pririt
File/Printer Setup... v

Select a command from the Menu Item list and click OK. (Click Cancel to close the dialog box without making
any changes.) For more information on the Runtime commands, see “Runtime Menus” on page 370.

Fill Color

Use this attribute to change a graphic object’s fill color based on a tag value from the control engine. This is a
control engine-driven attribute and is available for rectangles, round rectangles, ellipses, and polygons.

Double-click Fill Color in the Graphics Dynamic Attributes dialog box to display the Dynamic Attribute - Fill
Color dialog box.

Controf Engine Driven: Filf Color

Tag
M ame:
A— 2
B —— SetupBy Discrete
() Discrete
(®) Current Value
C
Current Value
D —— Cutoff values:

t—ill I B EH B

Hysteresis:

F—f ]
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(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: 1 = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.

For example, let’s say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.

Horizontal Position

Use this attribute to adjust the horizontal position of a graphic object based on a tag value from the control
engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses,
and polygons, polylines, curves, bitmaps, and text.

Double-click Horizontal Position in the Graphics Dynamic Attributes dialog box to display the following.

Controf Engine Driven: Horzontal Position
Tag

M ame:

A— |2

B Walue &t Left: I:I tovement Left:
Walue At Right; I:I tovement Right: I:I

D — Reference

()Left (@ Center (O Right Deadband: I:I —E
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(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes, the graphic object’s horizontal position is changed.

(B) Value at Left/Right. Enter the leftmost and rightmost value for the tagname in A. For example, if you
know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0to 50.

(C) Movement Left/Right. Enter the leftmost and rightmost movement the object can change. The
movement units are in pixels. Suppose your left and right values are 0 and 100, and your left and right
movements are 0 and 200. When the tag value is 50, the object will be moved 100 pixels to the right.

(D) Reference. Select the reference point for the object. The choices are left, center, and right. The
Horizontal Size (Width) dynamic attribute must also be configured in order for this option to affect the graphic
object.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the graphic object’s movement will actually change. Using our previous example in C, let’s say the deadband
is 5. Atag is read and has a value of 50. The next tag reading must be greater than 55 in order for the graphic
object to move.

Horizontal Size (Width)

Use this attribute to adjust the width of a graphic object based on a tag value from the control engine. This is
a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses, polygons,
polylines, and curves.

Double-click Horizontal Size (Width) in the Graphics Dynamic Attributes dialog box to display the Dynamic
Attribute - Width dialog box.

Control Engine Driven: Horizontal Size (width)
Tag

Mame:

A— | IE

B b airnLnn W alue: I:I b ax Percent Width: I:I c
b irirnurn % alue: I:I Wi Percent width: I:I

Anchor

(O Left (@ Center (O Right Deadband: D —E

D

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes in the PAC Control strategy, the graphic object’s width is
changed.

(B) Maximum/Minimum Value. Enter the maximum and minimum value for the tagname in A. For
example, if you know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a
subset of this range, such as 0 to 50.

(C) Max/Min Percent Width. Enter the maximum and minimum percentage the object can change. The
percentage range is from 0 to 1,000 percent. Suppose your minimum value is 0 and your maximum value is
10, and the minimum and maximum percentages range is 0 to 200. When the tag value is 10, the object will
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be twice as big as you've originally drawn it. When the tag value is 5, the object will be the same size you've
drawn it, which is 100 percent.

(D) Anchor. Enter the anchor point for the object. This is the reference point on the object from which the
graphic object changes. The choices are left, center, and right.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the graphic object’s width will actually change.

Horizontal Slider

Use this attribute to configure a horizontal slider when a graphic object is clicked. This is an operator-driven
attribute and is available for lines, rectangles, round rectangles, ellipses, polygons, and bitmaps.

Double-click Horizontal Slider in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Horizomtal Slider
Tag

Mame;

A—F Ia

Walue At Left: I:I torvement Left: I:I C
Walue At Right: I:I tovernent Right: I:I

D — FReference

(O Left (@ Center (O Right Deadband: ICI — E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. The distance the horizontal slider is moved affects the value sent to the tag in the
control engine.

(B) Value at Left/Right. Enter the leftmost and rightmost value for the tagname in A. For example, if you
know your tag values can be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0to 50.

(C) Movement Left/Right. Enter the leftmost and rightmost movement the object can change. The
movement units are in pixels. Suppose your left and right values are 0 and 100, and your left and right
movements are 0 and 200. If you move the tag 100 pixels to the right, the tag value sent will be 50.

(D) Reference. Select the reference point for the object. The choices are left, center, and right. Note that you
must also separately configure the Horizontal Size (Width) dynamic attribute to use this option.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the tag value should be changed.

Using our previous example in C, let's say the deadband is 5. A tag is read and has a value of 50. The next
graphic object movement must be greater than 55 in order for the tag value to change.
Launch Application

Use this attribute to start an application when a graphic object is clicked. This is an operator-driven attribute
and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.
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Double-click Launch Application in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Launch Application

A— wharking Directony: | | Browse... B
take Path Relative to Project

C Command Line: | | Browse.. —— D

E_— Append String: | | TR

F Launch Options: (®) Multiple instances () Single instance

G — show Options: (®) Mormal () Minimized () Maximized

(A) Working Directory. (Optional) Enter the working directory you want to be in when you start the
application. Use the Browse button B to quickly enter a directory name. If a working directory is not specified,
the current PAC Display Runtime directory is used when launching the application. You can change the
working directory at any time.

(B) Browse. Click to find the directory for A. The Working Directory Selection dialog box appears. Use it to
navigate to the desired directory and click OK when you're done.

(C) Command Line. Enter the complete path and file name of the application you want to launch. Use the
Browse button (D) to quickly enter the path.

(D) Browse. Click to find the path and application name for C. The Application Manager Executable File
Selection dialog box appears. Use it to select an application and click Open when you're done.

(E) Append String. (Optional) Enter the name of a string tag to use to append to the path entered in
Command Line (C). The string appended may be a file name the launched application should open.

Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a PAC Control
tag name.

Use the Delete button to clear an entry you may have made in this field. Only tag names may be entered.
Literal strings are not accepted. If the appended string is a parameter, a space must be included in the
Command Line string to separate it from the main command line.

(F) Launch Options. Select Single instance to have PAC Display Runtime check whether the graphic object
has previously launched an application that is currently running. If the object has not previously started a
currently running application, the application will be launched.

Select Multiple instances to allow the graphic object to start more than one instance of an application. Some
applications allow only one session of an application to run, while others allow multiple sessions.

Note that the Single Instance option doesn't limit the number of active sessions of an application that is
launched by other graphic objects and triggers. For example, if the graphic object launches a Microsoft Word
session, that object can't launch any other application until the Word session ends. However, a trigger-based
event can launch a second, separate session of Word, so two Microsoft Word sessions will be running
concurrently.

(G) Show Options. Click here to configure how the application window will appear. Your choices are
Normal, Minimized, and Maximized.
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Line Color

Use this attribute to change a line color or the line color around a graphic object based on a tag value from the
control engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles,
ellipses, polygons, polylines, and Bezier curves.

Double-click Line Color in the Graphics Dynamic Attributes dialog box to display the following.

Control Engine Diven: Line Color

Tag

I arme:
A | >
B— Setup By Dizcrete

() Discrete

(®) Cunent Value
C

Current Walue
D Cutoff walues:

<=| |< <=| |< <=| |< <=| |<

F—1H H B B B

Hysteresis:

F—@ |

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: T = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.

For example, let’s say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
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value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.
Read and Clear

Use this attribute to read a tag value and then clear (reset) it. This is an operator-driven attribute and is
available for rectangles, round rectangles, ellipses, polygons, bitmaps, and text.

Double-click Read and Clear in the Graphics Dynamic Attributes dialog box to display the following.

Operator Diven: Read and Clear

Tag
A M ame:
| |
B — Action: Options
Counts w (®) Decimal () Binamy

() Hexadecimal () Exponential

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name.

(B) Action. Choose the item to be read and cleared when the operator clicks the graphic object:
«  Counts (returns an integer value and then clears counts)
«  Ontime total

o Offtime total

« Latch (ON)

o Latch (OFF)

«  Onpulse measure

«  Off pulse measure

«  Period

e« Minimum

«  Maximum

(C) Options. Formatting options for how values appear when read appear here. Depending on the item you
selected in Action (B), one of the following option groups will be available:

«  Numerical formats—Decimal, binary, hexadecimal, and exponential formats are available for values
returned as numbers (for example, the state of all 32 points on a high-density module).

o Text formats—Custom text that corresponds to a discrete value's on and off states can be entered here.

Notes:

«  Ifthe Read and Clear dynamic attribute has been assigned to an object, a “Text In from Control Engine”
dynamic attribute cannot also be assigned to that same object.

« Ifatextplaceholder (##) is used to view return values, these placeholder characters will appear that way
in Runtime until the operator triggers the read and clear. Once this has happened, the graphic object will
not change until the read and clear is triggered again.

«  If more than one graphic object in a PAC Display window is configured with the same Read and Clear
dynamic attribute, each object is treated independently. The graphic objects are not linked to each other,
so when one object is read and cleared, the other object will not reflect this.
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Rotate

Use this control engine-driven attribute to rotate any of the following graphic objects based on a tag value
from the control engine: Bitmap, Metafile, Curve, Polygon, Ellipse, Polyline, JPEG, PNG, Rectangle, Line, or Text.

NOTE: Dynamic rotation can be a CPU intensive. Use dynamic rotation judiciously.

Double-click Rotate in the Graphics Dynamic Attributes dialog box to display the following.

Control Engine Driven: Rotate
Tag

Mame;

A—'— || ?

Walue at Max COw: I:I tdaw COW Rotation: I:I Deaqrees
Walue at Max Cw: I:I tdaw O Rotation: I:I Deaqrees

Ratation Anchor Point [Offzet fram Object Centerpaint]

Horizontal: I:I Wertical; I:I [eadband: Eﬁ E

D

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, the graphic object’s line rotates.

(B) Value at Max. These fields are used to specify the return data from the tag that will produce the
maximum counterclockwise (CCW) and maximum clockwise (CW) rotation. The Value at Max CCW may be
either less than or greater than the Value at Max CW, so that rotation may proceed in either direction as the
data from the tag increases or decreases. Therefore, the term “exceeds”is used below to indicate a value that
may be either greater than or less than the CCW or CW Max value.

When the tag returns data that is equal to or exceeds the Value at Max CCW to PAC Display, the graphic object
will rotate counterclockwise as far as possible, as specified by the Max CCW Rotation value explained below.
When the tag returns data that is equal to or exceeds the Value at Max CW Rotation to PAC Display, the
graphic object will rotate clockwise as far as possible, as specified by the Max CW Rotation value explained
below.

(C) Max Rotation. These fields are used to specify the maximum counterclockwise and clockwise rotation
angle that the graphic object may undergo (in degrees from its configured location). The entered values must
be non-negative numbers. The Max CCW Rotation angle is achieved when the tag returns data that is equal to
or exceeds the Value at Max CCW, as explained above. The Max CW Rotation angle is achieved when the tag
returns data that is equal to or exceeds the Value at Max CW, as explained earlier in this section.

(D) Rotation Anchor Point. The rotation anchor point is used to specify the fixed location that the graphic
object rotates around. This location is specified in terms of an offset (in units of pixels) from the center point of
the graphic object at its configured location.

In the Horizontal field, enter a negative value to specify a position that is to the left of the configured location
or enter a positive value to specify a position that is to the right of the configured location. In the Vertical field,
enter a negative value to specify a position that is above the configured location or enter a positive value to
specify a position that is below the configured location. If a value of zero is specified for both fields, then the
graphic object will rotate about its center point.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine if
the line’s rotation angle should change.
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For example, let’s say the deadband is 2. A tag with a value of 50 is read. The next tag value read is 51. The line
does not rotate because the value read is within the deadband range.

Send Discrete

Use this attribute to send a discrete value to a tag in the control engine when a graphic object is clicked. This is
an operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.

Double-click Send Discrete in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Send Discrete

Tag
A —— Mame:

| IE]
B — s5ource

(@ Fized data () Prompt for data

C — FixedData Prompted D ata D
(®) Set
() Clear
() Toggle
() Reverse
() Direct

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the tag value entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the setting selected
in the Fixed Data field (C) is sent to the tag. If you select Prompt for data, the Prompted Data field (D) is
activated and you can enter a message that will prompt the operator to select a discrete state for the tag.

(C) Fixed Data. If Fixed Data was selected in Source (B), enter the setting to be sent to the tag. The Set
option turns the tag on; Clear turns the tag off; Toggle changes the tag to the opposite of its current state
(from on to off, or from off to on); Reverse changes the tag's state to off when the mouse is clicked on the
graphic object, and on when the mouse button is released; Direct changes the tag state to on when the
mouse is clicked on the graphic object, and off when the mouse is released.

(D) Prompted Data. If Prompt for Data was selected Source (B), enter a message here that will prompt the
operator to select a tag state. Two buttons will be displayed to the operator. Enter the labels for the Set Button
and the Clear Button. The Set Button sends a discrete value to set the tag to the on state, and the Clear Button
sends a discrete value to set the tag to the off state.
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Send String

Use this attribute to send a string to the control engine when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text. Double-click Send String in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Send Sitring

Tag
A—— Hame:
| |
B Source
(®) Fixed data () Prompt for data
C Fixed D'ata Prompted D ata D
String Out;

Hide characters

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the string tag entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the setting selected
in Fixed Data (C) is sent to the tag. If you select Prompt for data, the field in Prompted Data (D) is activated
and you can enter a message that will prompt the operator to enter a string to send to the tag.

(C) Fixed Data. If Fixed Data was selected in Source (B), enter the string to send to the tag.

(D) Prompted Data. If Prompt for Data was selected in Source (B), enter a message to prompt the
operator to enter a string. Choose the Hide characters option if you don't want the text entered by the
operator to be displayed.

Send Value

Use this attribute to send a value to a tag name in the control engine when a graphic object is clicked. This is
an operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.
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Double-click Send Value in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Send Value

Tag

A Marne:
| E]

B —source Destination C
(®) Fized data () Prompt for data (@ 5et () Offgat

D — Fised Data Frompted Data: E

Walue: I:I

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. This tag will receive the tag value entered by the operator or configured in this dialog
box.

(B) Source. Select the source of the value to be sent to the tag. If you select Fixed data, the value entered in
the Fixed Data field (D) is sent to the tag. If you select Prompt for data, the Prompted Data field (E) is activated
and you can enter a message that will prompt the operator to input a value to send to the tag.

(C) Destination. Choose Set to assign the sent value to the tag, or choose Offset to add the value to the tag.

(D) Fixed Data. If Fixed Data was selected in Source (B), enter the value to send to the tag.

This value can be either a decimal or hexadecimal number. If entering a hexadecimal number, the number
must be preceded by “0x"and contain no spaces (for example, “Ox7FFFFFFF”and not “Ox 7FFF FFFF).

(E) Prompted Data. If Prompt for Data was selected in Source (B), enter a message to prompt the operator
for a value. Enter a minimum and maximum value the entered data should be within.

IMPORTANT: If using hexadecimal numbers, enter a minimum number of 0x80000000 and a maximum number of
Ox/FFFFFFF

Text Color

Use this attribute to change the color of text in the interface based on a tag value from a control engine. This is
a control engine-driven attribute and is available for grouped objects and text.
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Double-click Text Color in the Graphics Dynamic Attributes dialog box to display the following.

Control Engine Driven: Text Color

Tag

Mame;
A—F— )
B Setup By Dizcrete

() Discrete

(®) Cument Walue
C

Current Value
D Cutoff values:

<=| |< <=| |< <=| |< <=| |<

eE— IH H BEH B

Hyszteresiz:

F—h |

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag value changes in the PAC Control strategy, its value will determine the color
you want.

(B) Setup By. Choose whether the tag you're configuring is a Discrete value (with a value of ON or OFF), or
whether it's a Current Value you're looking for. For example, an integer will return a value of either ON or OFF,
so you would choose Discrete. However, a chart will return the following three values: 1 = stopped, 2 =
suspended, or 3 = running, so you would choose Current Value. To change chart states, use the following
parameters: If you choose Discrete, the Discrete group (C) is highlighted; if you choose Current value, the
Cutoff Values group (D) is highlighted.

(C) Discrete. Select the color you want for the ON state by clicking on the color field below ON. The Color
dialog box appears; choose a color and click OK. Repeat this step for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value box to specify the range of values for each color group
configured in the color fields. Values entered must be in increasing order. Each Cutoff value box must have a
numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks in the first
Cutoff Value box requiring a value.

(E) Color Fields. To configure a color for the range set up in Cutoff Values (D), click on a color field. The Color
dialog box appears from which you can choose a color and then click OK to accept. Repeat this step for each
color field you want to change.

(F) Hysteresis. Enter a value to be applied to each cutoff value as it moves toward lesser values to determine
the actual value at which the color will change to the next color field.

For example, let’s say the cutoff values are 1, 10, 20, and 30, and the color fields are red, yellow, green, blue,
and black. The hysteresis is 3. A tag with a value of 11 is read, corresponding to the color green. The next tag
value read is 9. The graphic object’s color remains green because the value read is within the hysteresis value
of 3, even though a value of 9 is in the yellow range.
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Text In from Control Engine

Use this attribute to read a tag from a control engine and display various strings to the operator. You can read
in a numeric value, a string, or a discrete value, and set up a string that will be displayed based on what was
received. This is a control engine-driven attribute and is available for a text object.

A #sign in the text object indicates where the text string should be displayed. Only one # is needed to display
an entire string. If there’s no # sign within the text object, then the string will be appended to the end of the

text object. You can configure how a floating point number is displayed by using a decimal point along with

the # signs. For every decimal place you want displayed after a decimal point, use a # sign. For example, your

text object could say: “Low level reading: ###.#. Your tag value is 200.55, so your displayed string is: “Low level
reading: 200.6.

NOTE: The extra # signs to the left of the decimal point aren't required, but are useful for determining how much space
the text will require in your display.

Double-click Text In (from control engine) in the Graphics Dynamic Attributes dialog box to display the
following.

Control Engine Diven: Text In from Controf Engine

Tag

Marne:
A—r— IE

D

B Setup By Walue Text Justification Murnerical Format E

(@) Walue Deadband: (®) Laft (®) Decimal

() Discrete 0 () Center (") Hexadecimal

O Stiing O Right O Binary
C () Exponential

F — Discrete

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object. The tagname you enter is affected by the setting for Setup By (B).

(B) Setup By. Choose whether the tag you're reading is a numeric value, a discrete value (with ON and OFF

values), or a string. If you choose Value, the Deadband and Text Justification fields (C and D) are activated. If

you choose Discrete, the Numerical Format group (E) is activated. The choice you make in this selection must
match the choice you made in Name (A).

If you choose Value, the value read will be converted into a string based on the rules mentioned at the
beginning of this “Text In" section.

If you choose Discrete, use Numerical Format group (E) to enter the strings that will be displayed for the ON
and OFF states. If you choose String, the text string from the control engine is displayed.

(C) Deadband. If you selected Value in Setup By (B), enter the value to be added and subtracted from the
previously read tag value to determine whether the new value is displayed.

(D) Text Justification. Select the format in which numeric values will be displayed: decimal, hexadecimal,

binary, or exponential. Hexadecimal numbers are prefixed with “0X"and appear in uppercase letters. Float
values may not be displayed as hexadecimal or binary.
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(E) Numerical Format. Select the text justification for the string from the control engine.

(F) Discrete. This section is highlighted if Discrete was chosen in Setup By (B). Enter the string to be
displayed if the tag's discrete value is ON, and enter the string to be displayed if the tag's discrete value is OFF.

Upload Recipe

Use this attribute to upload a recipe file from a control engine when graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text. For more information about recipes, see “"on page 239.

Double-click Upload Recipe in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driven: Uplead Recipe

Faormat File
A Diirectony: | | Browse ——— B
take Path Relative to Froject —C
D — File Mame : 0

E (®) Fised name Fixed M ame: ! | E utension:

() Prompt for name

i
() Fram strategy |

Destination File

Diirectary: | | LogTo——— H

Make Path Relative to Project [
| ——— FileMame

(®) Fixed name

J Fixed M arme: | | BACTA K

() Prompt for name
?

L () From strategy |

(A) Name. Enter the directory location of the recipe format file. Use the Browse button B to quickly select a
directory name. The recipe format file is used to tell the control engine what data to read. Often, it's the
original downloaded recipe. For example, the number of lines with data values represents how many values
should be read from the control engine.

(B) Browse. Click to quickly find the recipe format file directory for A. The Select Format File Directory dialog
box appears. Use it to navigate to the desired directory and click OK when you're done.

(C) Make Path Relative to Project. When selected, if you copy the project and recipe format files to a
different computer, PAC Display will look in the same relative location to find the recipe format files in
Configurator and Runtime.

For example, if the project is saved in C:\proj\ and you configure recipes format files to be in C:\proj\recipes\,
then the relative path would be this: \recipes\

If you then saved the project to C:\temp\newproj\, PAC Display would look for recipe format files in the new
location’s relative path: C:\temp\newproj\recipes\

(D) File Name. Choose the source of the recipe format file name:

«  Ifyou choose Fixed name, the Fixed Name field (E) is highlighted.

« If Prompt for name is selected, the operator is prompted for the recipe format file name.
«  If From strategy is selected, the String Name field (F) is highlighted.
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(E) Fixed Name. If Fixed Name was selected in D, enter the name of the recipe format file located in
directory A. Notice the file extension is .rcp.

(F) String Name. If From strategy was selected in D, use either Quick Tag Entry (see page 74) or the Tag
Selection dialog box (see page 75) to select a PAC Control tag name of type string that contains the recipe
format file name.

(G) Directory. Enter the directory location of the recipe file that will receive the information. Use the button
(H) to quickly enter a directory name.

(H) (Basic only) Browse. Click to quickly find the recipe file directory for G. The Select Destination File
Directory dialog box appears. Use it to navigate to the desired directory and click OK when you're done.

(H) (Pro only) Log To. Click to select whether to log to an ASClI recipe file or to a database table. If you click
Log File in the pop-up menu:
«  Use the Browse for Folder dialog box to navigate to the desired directory, and then click OK.

«  Use the Select Database Table dialog box to select the desired table, and then click OK. For more
information about logging to a database table, see “Configuring an ODBC Data Source” on page 55.

(1) File Name. Choose the file name for the recipe data that will be read from the control engine.

«  Fixed Name—Check this if the template file is a file name you want to configure at this time. If this
option is selected, the File Name edit box appears, prompting you for a file name. Make sure the file exists
in the Directory entry, otherwise an error is posted. The file name may not be changed at Runtime.

The "Extension" parameter also appears and prompts for a one to three character long extension that's
appended to the "Fixed Name". The extension must not contain a period or a DOS wild card character.
The default extension is "rcp".

«  Prompt For Name—Check this if the template file name is to be prompted at Runtime when the trigger
occurs. If this option is selected, the Extension parameter also appears. Enter a one to three character
long extension which does not contain a period or a DOS wild card. This extension is used as a filter to
select which files are displayed when prompting a user for the recipe name at Runtime, however files
with different extensions may be selected.

«  From Strategy—Check this option if you want to use a string tag name from the control engine
strategy to specify the template file name. If this option is selected, the String Name dialog box appears,
prompting for the tag name you want to use. Use the "?" button to enter the tag name from the Tag
Selection dialog box.

(J) Fixed Name. If Fixed Name was selected in |, enter the name of the file to receive the information. This
file will be located in the Directory field (G).

(K) Extension. Specify the file extension for the recipe files available to this dynamic attribute by entering
the extension in the File Extension field. The extension must be one to three characters long and must not
contain a period or DOS wild card characters.

If Fixed Name is checked, this extension will append to the File Name entry to create the name for the recipe
file. If Prompt For Name is checked, this extension will be used as a filter to select the files for display in a file
selection dialog box when Runtime executes this dynamic attribute. However, you may override this filter if
you wish to select a file with a different extension.

(L) Mistic String. If From strategy was selected in I, use either Quick Tag Entry (see page 74) or the Tag
Selection dialog box (see page 75) to select a PAC Control tag name of type string that contains the file name.
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Vertical Position

Use this attribute to adjust the vertical position of a graphic object based on a tag value from the control
engine. This is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses,
and polygons, polylines, curves, bitmaps, and text.

Double-click Vertical Position in the Graphics Dynamic Attributes dialog box to display the following.

Control Engine Diven: Vertical Position
Tag

M arme:

A—— |2

B Walue At Top: I:I Mowement Up:
Walue At Bottom: I:I Movement Down; I:I

Reference
D

(JTop (@ Center () Bottom Deadband: I:I —E

(A) Name. EUse either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As the tag value changes, the graphic object’s horizontal position is changed.

(B) Value at Top/Bottom. Enter the top and bottom values for the graphic object. For example, if you
know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range
such as 0to 50.

(C) Movement Up/Down. Enter the maximum top and bottom movement the object can change. The
movement units are in pixels. For example, if your bottom and top values are 0 and 100, your bottom and top
movements are 0 and 200, and your point of reference (D) is from the bottom when the tag value is 50, the
object will be moved 100 pixels from the bottom.

(D) Reference. Enter the reference point for the object. This is the reference point from which the object will
move. The choices are top, center, and bottom. The Vertical Size (Height) dynamic attribute must also be
configured in order for this option to affect the graphic object.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s position will actually change. Using our previous example in C, let’s say the
deadband is 5. A tag is read and has a value of 50. The next tag reading must be greater than 55 in order for
the graphic object to move.

Vertical Size (Height)

Use this attribute to change the height of a graphic object based on a tag value from the control engine. This
is a control engine-driven attribute and is available for lines, rectangles, round rectangles, ellipses, and

polygons.
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Double-click Vertical Size in the Graphics Dynamic Attributes dialog box to display the following:

Control Engine Diven: Vertical Size (height)
Tag

Marne:

A—— | E

b anirmum YV alue: I:I M ax Percent Height: I:I c
irirnm W alue: I:I Min Percent Height: I:I

D — anchar

(J)Top (@ Center () Bottom Deadband: : E

B

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object.

(B) Maximum/Minimum Value. Enter the maximum and minimum value for the tagname in A. For
example, if you know your tag values will be from 0 to 100, you may wish to enter a range of 0 to 100 or a
subset of this range, such as 0 to 50.

(C) Max/Min Height. Enter the maximum and minimum percentage the object can change. The
percentage range is from 0 to 1,000. Suppose your minimum value is 0 and your maximum value is 10, and
the minimum and maximum percentages range from 0 to 200. When the tag value is 10, the object will be
twice as big as you've originally drawn it. When the tag value is 5, the object will be the same size you've
drawn it, which is 100 percent.

(D) Anchor. Enter the anchor point from which the object will “grow.” The choices are Top, Center, and
Bottom. For example, if you want to create a bar that grows up from the bottom, select Bottom. If you want to
create an object that grows both up and down from the center, select Center. An object with a Top anchor
grows down from the top.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s height will actually change. For example, let's say the values are 0 to 100, the
percentages are 0 to 100, and the deadband is 5. A tag is read and has a value of 10. The next tag reading must
be greater than 15 in order for the graphic object to change.

Vertical Slider

Use this attribute to configure a vertical slider when a graphic object is clicked. This is an operator-driven
attribute and is available for lines, rectangles, round rectangles, ellipses, polygons, and bitmaps.
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Double-click Vertical Slider in the Graphics Dynamic Attributes dialog box to display the following.

Operator Driver: Vertical Slider
Tag

Mame:

A= la

B Walue At Top: I:I i overnent Llp: I:I
Walue At Bottom: I:I torvernent Do I:I

Referance

D A
() Top (@ Center () Bottom Deadband: Dﬁ E

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. The amount of movement the vertical slider makes affects the value sent to the tag in
the control engine.

(B) Value at Top/Bottom. Enter the top and bottom values for the tagname in A. For example, if you
know your tag values can be from 0 to 100, you may wish to enter a range of 0 to 100 or a subset of this range,
such as 0to 50.

(C) Movement Up/Down. Enter the maximum top and bottom movement the object can change. The
movement units are in pixels. This means if your bottom and top values are 0 and 100, and your bottom and
top movements are 0 and 200, if you move the tag 100 pixels toward the bottom, the tag value sent will be 50.

(D) Reference. Select the reference point for the object. The choices are top, center, and bottom. Note that
you must also separately configure the Vertical Size (Height) dynamic attribute to use this option.

(E) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the tag value should be changed.

Using our previous example in C, let’s say the deadband is 5. A tag is written and has a value of 50. The next
graphic object movement must be greater than 55 in order for the tag value to change.

Visibility/Blink

Use this attribute to make a graphic object visible or invisible or to cause it to blink based on a tag value from
the control engine. This is a control engine-driven attribute and is available for lines, rectangles, round
rectangles, ellipses, polygons, polylines, curves, bitmaps, Windows button controls, and text.

Double-click Visibility/Blink in the Graphics Dynamic Attributes dialog box to display the following.
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Control Engine Driven: Visibility Blink

Tag

M ame;
A—r :
B— Setup by Dizcrete

() Discrete

(®) Curent YWalue Yizible Irevisible
C

Current Value
D —— Cutoff values:

<=| |< <=| |< <=| |< <=| |<

E— Wizible o Wigible w "izible w *izible | Wigible ~

Deadband:

F—_]

(A) Name. Use either Quick Tag Entry (see page 74) or the Tag Selection dialog box (see page 75) to select a
PAC Control tag name. As this tag changes value in the PAC Control strategy, its value will determine the
effects on the graphic object.

(B) Setup By. Choose whether the tag you're configuring is a discrete value (with ON and OFF values), or
whether it’s a current value you're looking for. If you choose Discrete, the C group is highlighted; if you choose
Current value, the D group is highlighted. The choice you make in this selection must match the tag choices
you made in the Name field (A).

(C) Discrete. Select the visibility state you want for the ON state from the drop-down list options. Your
choices are Invisible, Visible, Slow Blink, Med. Blink, and Fast Blink. In the same manner, choose the visibility
state for the OFF state.

(D) Cutoff Values. Enter a value in each Cutoff Value field to specify the range of values for each visibility
group configured in the visibility fields. Values entered must be in increasing order. Each Cutoff Value field
must have a numeric value entered or you will get a warning to enter one. After the warning, the cursor blinks
in the first Cutoff Value field requiring a value.

(E) Visibility. To configure a visibility state for the ranges set up in Cutoff Values (D), click a visibility field's
drop-down button. Your choices are Invisible, Visible, Slow Blink, Med. Blink, and Fast Blink. In the same
manner, choose the visibility state for each range of values.

(F) Deadband. Enter a value to be added and subtracted from the previously read tag value to determine
whether the graphic object’s visibility will actually change.

For example, let's say the Cutoff values are 1, 10, 20, and 30, and the visibility fields are Invisible, Visible, Slow
Blink, Med. Blink, and Fast Blink. The Deadband is 2. A tag is read with a value of 10. The next value read must
be greater than 12 in order for the graphic object to change.

Windows

Use the Windows attribute to change window states when a graphic object is clicked. This is an
operator-driven attribute and is available for rectangles, round rectangles, ellipses, polygons, bitmaps, and
text.
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In the Graphic Dynamic Attributes dialog box, click Windows (in the Operator Driven list) to display its features.

Operator Driven: Windows

Windaws: Action  Affected Windows

Mew Action
A | Cookie Factary I D
B "Windows 22 | Open
Cc Append -» F
Cloze
Default
E |conify
(® Open
() Close
f Femove Selected G
() lconify
Remowe Al
Deselect Al
H All Others
It Open If Clozed It Iconified
Mo change Mao change Mo change
lconify Open Open
Cloze |conify Close

(A) Windows. Initially, this list shows all the windows available for the project. Select the window that has
the window state you want to change. You can also select more than one window by using a couple of key
combinations. One way is to select a window, press Shift, and then click on another window name in the list.
This selects all the windows in between the two window names. Another way is to select a window name,
press the Ctrl key, and click on each window name you want selected.

(B) Insert. Use to insert the selected window(s) in Action/Affected Windows (D). The window name will be
inserted above the highlighted window(s) in (A).

(C) Append. Use to add the selected window(s) to the bottom of the window list in Action/Affected
Windows (D). The window name will be inserted after the last window in Action/Affected Windows (D).

(D) Action/Affected Windows. Lists the windows and what window state they will go to when the
graphic object is clicked.

(E) Default. Use this group as a handy window state assignment key for the windows you've highlighted in
(A). When the windows are copied over to Action/Affected Windows (D), you will see they all have the
default window state you've assigned. The window state choices are Open, Close, and Iconify.

(F) New Action. Use this group to change any window states listed in Action/Affected Windows (D).
Highlight one or more windows and select the new window state action. Your choices are Open, Close, and
Iconify.

(G) Remove/Deselect. Use this group to modify the window name list in Action/Affected Windows (D).
The Remove Selected option removes only those windows you've highlighted; the Remove All option
removes all windows from the list; and the Deselect All option deselects and quickly unhighlights all window
names.

(H) All Others. For all windows leftin (A), use this grouping to affect their window states. For example, if a
window state is open and the graphic object is clicked, the window state can stay the same, be iconified, or be
closed. Likewise, you can alter the window states of closed and iconified windows.
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COPYING AND DELETING DYNAMIC ATTRIBUTES

Once a dynamic attribute has been added to an on-screen graphic object, you can easily assign those
attributes to other objects using copy and paste. You can also quickly delete all dynamic attributes from a
graphic object.

Copying Dynamic Attributes from a Graphic Object

To copy a set of dynamic attributes from one graphic object to another:
1. With the Select tool , click the graphic object whose dynamic attributes you want to copy.

2. Choose Edit > Copy Dynamic Attributes (or use Shift+Ctrl+C) to copy the attributes to the Windows
clipboard.

Another way you can do this is to right-click the graphic object and click Dynamic Attributes > Copy.

You can now assign these dynamic attributes to another graphic object using Edit > Paste Dynamic
Attributes.

Pasting Dynamic Attributes to a Graphic Object

To paste dynamic attributes that were copied to the Windows clipboard:

1. With the Select tool , choose one or more graphic objects to which you want to paste the dynamic
attributes.

2. Choose Edit > Paste Dynamic Attributes, and then do one of the following:
- Todelete any existing dynamic attributes the graphic object may already have, choose Delete
Existing.
- Toadd the copied attributes to existing attributes and replace any that might be of the same type,
select Replace Duplicates.

- Toadd the attribute to existing attributes and not change any attributes that might be of the same
type, select Ignore Duplicates.

You can also perform these tasks by right-clicking the graphic object and selecting the paste option from
Dynamic Attributes > Paste.

Deleting Dynamic Attributes from a Graphic Object

To delete all dynamic attributes from a graphic object:

1. With the Select tool , choose one or more graphic objects that have dynamic attributes you want to
delete.

2. Choose Edit > Delete Dynamic Attributes.

Another way you can do this is to right-click the graphic object and click Dynamic Attributes > Delete
Existing from the pop-up menu.
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PAC Display Index

A

acknowledging alarms, 267
active address, 67
Add a Runtime user login, 303
Add Members to a User Group, 308
Add/Modify User menu item, 372
adding
alarm, 258
control engine, 61
graphic object, 100
historic data log, 216
sounds (Sounds Configuration dialog box), 236
alarm point
disabling in Runtime, 333
dynamic attributes, 140
send email, 279
Alarm Points, 258
Alarm Points menu item, 367
Alarming Setup menu item, 367
alarms
acknowledging, 267
adding, 258
configuring alarm points, 258
configuring for entire project, 367
configuring individual alarms (Alarm Menu),
371
configuring individual alarms (Configure Menu),
367
configuring printed logs, 284
configuring project alarms, 277
deleting alarm points, 258
disabling, 371
displaying comments for value alarms, 272
entering discrete alarm comments to display to
operator, 271
graphic objects, 273
hot keys, 276
logging, 284

modifying in PAC Display Runtime, 331
notification, 267
setting the format for graphic objects, 276
silencing, 331
sounds, 287
viewing in PAC Display Runtime, 330
Alarms Enabled menu item, 371
alert window, 283
Align menu item, 359
aligning graphic objects, 116
allow multiple runtimes (Runtime Setup dialog box),
292
animated graphics
and PAC Control tags, 32
configuring, 139
configuring with PAC Control tags, 74
dynamic attributes, 139
Applications menu item, 368
launching applications, 233
applications, launching, 233
applications, launching (Configure menu), 368
Applying Transparency to Graphic Objects, 118
Archive Project and Email to Opto 22 menu item,
356
how to, 49
Archive Project menu item, 356
Archive Project or File menu item, 49
AutoCorrect Tags, 369
correcting tags from a strategy, 83
results file, 85
AutoCorrect Tags menu item
Tools Menu, 369
using AutoCorrect tags, 84

B

Background Color menu item, 365
applying or changing fill attributes, 107
Background menu item, 366
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formatting text, 120
batch (BAT) file

starting project from, 51
batch (BAT) file, using for startup, 51
bitmap graphic

importing, 107

saving graphic object as, 109

C

change appearance of combo box
ComboBox dynamic attributes, 128
Change Font menu item
ComboBox dynamic attributes, 128
Change Login Password menu item, 372
changing
control engine properties, 61
PID values in Runtime, 338
size of graphic objects, 110
tag names, 358
window state, 238
chart states
assigning to a graphic, 172
recipe download file, 249
Choose Bitmap menu item, 20, 357
Clear All, 311
clearing dynamic attributes, 168
Close menu item (Configurator), 369
Close menu item (Runtime), 372
Close Project menu item, 50
File menu, 355
closing
project, 50
Color menu item, 366
formatting text, 120
combining projects, 54
combo box, 124
changing the appearance, 128
using in Runtime, 337
communication
Ethernet link redundancy, 67
with 1/0 unit or control engine, 319
comparing projects, 49
Configuration Status menu item, 371
Runtime, 326
viewing and changing scanner status, 327
Configurator, 124
Configurator Options menu item, 356
saving versions of a project, 48
Configure Grid menu item, 364
configuring
basic trends, 189
control engine, 61
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date format (Runtime setup), 291

historic data log, 367

no control engine, 86

on-screen keyboard(Runtime setup), 290
scanner, 67

security settings, 176

SNAP high-density digital modules tags, 78
snapshots, 52

sounds, 237

SuperTrends, 191

tags, /4

tags for high-density digital modules (Tag Selec-

tion dialog box), 77
window states, 238
XY plots, 210
Configuring Runtime, 289
configuring tags
Quick Tag Entry, 74
Configuring User Groups, 307
control engine
adding to project, 61
checking communications with, 340
communicating with, 319
configuring, 61
configuring without, 86
how to switch between, 329
optimizing communications with, 182
retrieving text from, 157

switching between (Window Properties dialog

box), 96
Control Engine menu item, 367
configure a control engine, 61
control engine status dynamic attributes, 141
control engine-driven attributes, 139
definition, 139
controllers, legacy, 61
Convert SuperTrend Files menu item, 372
convert to text format, 206
Runtime, 369
converting SuperTrend log files, 205
Copy Dynamic Attributes menu item, 169
Edit menu, 363
Copy menu item
Edit menu, 358
graphic objects, 110
Window menu, 369
windows, 92
Copy to File menu item, 362
copying
dynamic attributes, 169
graphic objects, 110
project files, 356
correcting tags from a strategy, 83



Create Recipe File menu item, 369
download file, 241
upload template, 243
creating
basic trend, 186
project, 42
SuperTrend, 190
Cut menu item
Edit menu, 358
graphic objects, 115

D

data logs, 230
date, setting format of (Runtime setup), 291
Decrypt Runtime Operator Log File menu item, 364
Delete an Existing Runtime User, 304
Delete Dynamic Attributes menu item, 363
Delete menu item, 358, 370
draw windows, 92
graphic objects, 115
deleting
alarm points, 258
graphic objects, 115
deleting dynamic attributes, 168
designing a PAC Display project, 33
direct communication with 1/0 unit, 319
Disable Alarm Points menu item
Alarm menu, 371
Runtime, 333
displaying alarm comments to operator, 271, 272
download recipe file, 241, 245
chart states, 249
dynamic attributes, 142
to a control engine, 142
downloading
OptoControl strategy, 25
PAC Control strategy using PAC Term, 25
draw window
closing, 98
creating, 92
definition, 32
deleting, 92
modifying, 94
opening, 98
using in project, 91
drawing tools, 36, 100, 364
Duplicate menu item, 110, 358
dynamic attributes, 140
alarm point, 140
assigning a chart state, 172
assigning to graphic object, 139, 363
configuring PAC Display to use old-style, 379

Dynamic Attributes menu item, 181, 364

E

control engine status, 141
controller-driven, 139
copying, 169

download recipe, 142
Execute menu item, 144
fill color, 144

granting or denying operator use of, 176

horizontal position, 146
horizontal size, 146
horizontal slider, 147
launch application, 148
line color, 150
old-style, 379
operator-driven, 139
operator-driven sub-attributes, 169
pasting, 169

read and clear, 157
rotate, 152

send discrete, 153

send string, 154

send value, 154

text color, 155

textin, 157

upload recipe, 158
using old-style dialog boxes, 379
vertical position, 160
vertical size, 160
vertical slider, 161
viewing, 180, 364
visibility/blink, 162
windows, 163

Edit Dynamic Attributes menu item, 363
Edit Points menu item, 113, 363

Edit Recipe File menu item, 245, 369
Edit Text menu item, 120, 363

email for alarm points, 279
errors

error messages, 339, 347

Event Log, 316, 367, 371
Event Log Viewer, 40, 312, 325

Ethernet link redundancy, 67
Event Log, 316, 367, 371

menu item
Configurator, 367
Runtime, 325, 371

Viewer, 40, 312, 325
definition, 32

Execute menu item

dynamic attributes, 144
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Exit PAC Display Runtime menu item, 370
export

alarm points, 261

graphic objects, 109

historic logs, 224
Export Project menu item, 49, 356
Export Window menu item, 98, 370

F

fill color

dynamic attributes, 144
Fill Color menu item, 107, 365
Fill Pattern menu item, 107, 365
Find Tag menu item, 81, 364
finding and replacing tags, 81
finding tags, 81
Flip menu item, 359
Flip/Rotate menu item, 117
Flipping Objects, 118
Font menu item, 120, 366

G

GIF, 107
GIF graphic
importing, 108
global operator driven access, 304
Global Operator Driven Permissions, 309
global operators, 310
graphic objects
alarms, 273, 276
aligning, 115, 359
and Symbol Factory, 107, 109
assigning dynamic attributes to, 363
changing size, 36, 110
copying, 110
deleting, 115
drawing, 100
exporting, 109
fill color and pattern, 107, 365
flipping, 118, 359, 360
grouping, 105, 362
handles, 103
importing bitmap graphic, 107
importing GIF graphic, 108
importing JPEG graphic, 108
importing Windows metafiles, 107
locking position of, 105
moving, 110
opacity, 118
rotating, 116, 359, 360
selecting, 103, 104
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transparency, 118
ungrouping, 105, 362
updating, 182
XY plot, 186
Graphic Window menu item, 92
Group menu item, 105, 362

H

hardware requirements, 4
heartbeat interval

setting, 72
help

error messages, list of, 347

online, 3

Opto 22 Product Support, 3

Product Support, 3

See also troubleshooting, 339
Hide Grid menu item, 364
Hide Menu Bar menu item, 38, 363
Hide Toolbox menu item, 36, 364
hint text, 175
historic data log

configuring a database, 220
Historic Data Log menu item, 367
historic data logs

adding, 216

configuring log files, 367

exporting, 224

file formats, 202, 231

importing, 225

notification when logging stops, 229
Historical Data Log menu item, 216
historical data logs

configuring points, 228

definition, 215

filenames, 230

saving, 202, 231

tag types recorded, 216
Historical Log File Configuration dialog box (Super-

Trends), 203

historical trending

switching to in PAC Display Runtime, 334
horizontal position

dynamic attributes, 146
horizontal size

dynamic attributes, 146
horizontal slider

dynamic attributes, 147
hot keys

in alarms, 276

in SuperTrends, 196



/0 unit, communicating with, 319
Import Window menu item, 98, 370
importing

alarm points, 262

bitmap graphic, 107

GIF graphic, 108

historic logs, 225

JPEG graphic, 107, 108

PNG graphic, 107
installing PAC Display, 4
international characters, 375

J

JPEG graphic
defined, 108
importing, 107, 108

K

keyboard
configuring
on-screen keyboard, 290
hot keys in SuperTrends, 196

L

launch application dynamic attribute, 148
Launch TagInfoView Utility menu item, 181, 364
launching applications, 233
notification, 236
trigger, 235
working directory, 234
launching applications (Configure menu), 368
legacy controllers, 61
line color
dynamic attributes, 150
Line Color menu item, 105, 364
Line Style menu item, 106, 365
Line Width menu item, 365
link redundancy
SoftPAC controller, 67
Lock Position menu item, 105, 363
log files
alarm, 284
converting a SuperTrend log file, 206
decrypting, 315
discrete controller variables, 312
discrete 1/0 points, 312
encrypting, 315
Log Out of PAC Display Runtime menu item, 322,

372
logging operator actions, 312
login
for Runtime, 305
log out user when idle, 303
login schedule, 303
requiring new password, 303

M

main window
options, 290
Make Path Relative to Project, 222
menu bar
hiding from operator, 297
hiding in PAC Display Configurator, 35
menus
PAC Display Configurator, 355
PAC Display Runtime, 370
messages
Event Log, 316, 371
Event Log Viewer, 40, 325
Modify Alarm Points menu item, 331, 371
Modify an Existing Runtime User, 304
monitor-only version of PAC Display Runtime
features, 321
monitors, multiple
requirements, 5
using, 34, 46, 289
mouse
hot keys in alarms, 276
multiple instances of PAC Display Runtime, 68, 292
multiple Runtimes, 323
multiple runtimes, 292
Multiply Runtime Height By menu item, 128

N

network redundancy, 67
New menu item, 92, 369
New Project menu item, 42, 355
notification
alarms, 267
application launched, 236
historic log files, 229
recipe download/upload, 257

O

objects
definition, 32
ODBC
configuring data source, 55
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historic log database, 220 project options, 289

Runtime Operator Action Log database, 314 project window, 38
SuperTrend log database, 208 restricting the operator, 297
old-style Dynamic Attribute dialog boxes, 379 running project, 33
Opaque menu item setting date format, 291
graphic, 365, 366 system requirements, 4
text, 120, 367 PAC Term, 25
Open menu item Password Protect Project menu item, 47, 356
Configurator, 369 passwords
Runtime, 372 protecting a project with, 46
Open Project menu item Paste Dynamic Attributes menu item, 169, 363
Configurator, 47, 355 Paste from File menu item, 108, 362
Runtime, 47, 370 Paste menu item, 110, 358
Open the Runtime Users Dialog Box, 302 pasting
operator dynamic attributes, 169
restricting activity, 297 graphic objects, 110
Operator Driven Attribute Access menu item, 311, pens
372 configuring basic trend pens, 187, 189
operator-driven attributes, 139 configuring SuperTrend pens, 197
definition, 139 optimizing settings, 190
sub-attributes, 169 performance
optimizing communications with control engine, and visual state of windows, 34
182 PID
Opto 22 Product Support button, 121, 337
contacting, 3 values, changing in Runtime, 338
OptoOPCServer planning a PAC Display project, 32
using as remote scanner, 68 PNG graphic
OptoTerm, using to download strategy, 25 defined, 108
OptoVersion, 344 importing, 107

pointer table, 76
pointer variable, using, 76

P Print menu item (Configurator), 358
PAC Display Print menu item (Runtime), 370
Basic, 1 Printer Setup menu item, 358
built-in graphics library, 109 printing, 370
Configurator displayed windows, 137
draw window, 36 Priority Filter menu item, 371
hiding menu bar, 35 project
main window, 35 closing, 50
menus, 355 combining projects, 54
files, list of, 353 components of, 32
firmware requirements, 4 copying, 356
hardware requirements, 4 creating, 42
Professional, 1 customizing, 51
differences from PAC Display Basic, 1 customizing startup
Runtime by modifying default startup properties, 50
definition, 31 definition, 32, 41
Event Log Viewer, 40 designing, 33, 41
interacting with SuperTrends, 333 opening, 47
interacting with XY plots, 336 options in PAC Display Runtime, 289
main window, 37 organizing files, 41
menus, 370 protecting with a password, 46
monitor-only version, 321 running, 27
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saving, 48

windows, 38
project comparison, 49
Project Path menu item (Configurator), 356
Project Path menu item (Runtime), 370
Properties menu item, 94, 370

Q

Quick Tag Entry, 18
Quick Tag Entry, configuring tags, 74

R

read and clear
dynamic attributes, 151
real-time mode
switching to in PAC Display Runtime, 335
recipes
chart states, 249
download file, 241, 245
downloading to a control engine, 142
file formats, 246
notification, 257
selecting a trigger, 256
upload file, 243
uploading from a control engine, 252
validating, 243
Recipes menu item, 253, 368
Redo menu item, 358
Redraw menu item, 37, 364
redundant communication links, 67
refresh time groups, 183
Refresh Times menu item, 183, 367
Regenerate 10 Scanner Tag Names menu item, 369
relative offsets, 135
remove global permissions, 311
Remove Members from a User Group, 309
removing dynamic attributes, 168
Replace menu item, 81, 358
Reset Dialog Positions menu item, 34, 364
Restricting the Operator, 299
rollover trigger option, 227
rotate
dynamic attributes, 152
Rotate menu item, 359
rotating objects, 361
running a project, 27
Runtime, 337
changing PID values, 338
login, 304, 305
multiple Runtimes, 323
tooltips, 295

Runtime menu item, 289, 368
Runtime Operator Action Log database, 314
Runtime Operator Action Log File
configuring, 313, 314
decrypting, 315
encrypting, 312, 315
Runtime Users dialog box, 302

S

Save as Bitmap menu item, 109, 357
Save Metafile As menu item, 362
Save Project and Load Runtime menu item, 48, 356
Save Project As menu item, 48, 356
Save Project menu item, 48, 355
saving
graphic object as bitmap graphic, 109, 357
project, 48
scan rates
configuring, 183
scanner
configuring, 67
setting heartbeat interval, 72
using OptoOPCServer, 68
Scanner Defaults menu item, 72, 73, 368
Scanner Location menu item, 69, 72, 73, 368
scanning, 182
optimizing, 182
refresh times, 367
Secondary Scanner Location menu item, 368
security
and the Event Log Viewer, 312
configuring, 176
described, 33
logging operator actions, 312
restricting the operator, 297
setting in Runtime, 297
setting Windows user- and group-based au-
thentication, 176
Select All menu item, 104, 358
selecting
graphic objects, 103, 104
send discrete
dynamic attributes, 153
send string
dynamic attributes, 154
Send String tags, /7
send value
dynamic attributes, 154
setting data format in project, 291
Show Configured Users, 311
Show Grid menu item, 364
Show Toolbox menu item, 36, 364
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silencing alarms, 331
Size menuitem, 111, 120, 359
Size menu item (text), 366
SNAP 32-channel digital modules, 77/
SNAP high-density digital modules, 78
Snapshots menu item, 52, 368
SoftPAC
adding a control engine, 15
link redundancy, 67
sounds, 236, 368
adding to alarms, 287
configuring, 237
digitized sound files (WAV), 237
MIDI music files (MID), 237
options, 291, 292
play sounds simultaneously, 291, 292
start and stop triggers, 238
Sounds menu item, 237, 368
static objects, 32
strategy
date, /7
downloading, 25
time, 77
Style menu item, 120
SuperTrend data logs
filenames, 230
SuperTrend log database, 208
SuperTrend Remote Logging menu item, 368
SuperTrends
configuring
pens, 197
settings, 191
x-axis, 193
y-axis, 194
converting log files, 205
creating, 190
definition, 186
hot keys, 196
log files, 200
using in PAC Display Runtime, 333
zoom parameters, 196
Switch Control Engines menu item, 329, 372
Symbol Factory, 109
Sync Control Engine Time to PC menu item, 371
Synchronize Control Engine Clocks, 295
system requirements, 4

T

tables
creating, configuring, and displaying, 134
relative offsets, 135
writing to elements, 336
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tags
configuring, 74
correcting, 83
definition, 32
finding, 81
finding and replacing, 81
Replace menu item, 358
SNAP 32-channel digital modules, 77
SNAP high-density digital modules, 78
verifying, 369
viewing, 180
tags for Send String, 77/
Technical Support. See Opto 22 Product Support, 3
text
adding, 120
changing
color, 366
font, 366
style, 366
color
dynamic attributes, 155
display value or string from control engine, 157
editing, 120
formatting, 120
in dynamic attributes, 157
transparency with other objects, 120, 367
Text Style menu item, 367
title bar custom caption, 290
toolbox, 36, 100
hiding or showing, 364
tooltips, 295
graphic hint text, 175
Transparent menu item, 366
Transparent menu item (text), 120, 367
trends
and system performance, 187
configuring
basic trend pens, 189
SuperTrend axes, 193
SuperTrend pens, 197
configuring SuperTrend axes, 194
creating
a basic trend, 186
a SuperTrend, 197
hot keys in SuperTrends, 196
interacting
with SuperTrends, 333
with XY plots, 336
types of trends, 185
trigger option, rollover, 227
trigger-based events
alarms, 258
definition, 215



historic data logs, 215

launching applications, 233

sounds, 236

window states, 238
troubleshooting

errors and messages, 347

Opto 22 Product Support, 3

problems saving project files, 342

problems using Windows NT, 343

steps to diagnose problems, 339

text string object disappears, 342
Turn Snap On/Off menu item, 364

U

Undo menu item, 358
Ungroup menu item, 105, 362
Unicode text, 375
Unlock Position menu item, 105, 363
updating graphics, 182
upload recipe
configuring, 252
creating template, 243
dynamic attributes, 158
URL control, 131
URL window
closing, 98
creating, 92
deleting, 92
modifying, 94
opening, 98
using in project, 91
URL Window menu item, 92
Use Project Directory, 222
user group, 307
user login
log out when idle, 303
login schedule, 303
requiring new password, 303

\"

Validate Recipe File menu item, 252, 369

validating recipe files, 243
verifying tags, 369
vertical position

dynamic attributes, 160
vertical size

dynamic attributes, 160
vertical slider

dynamic attributes, 161

View Alarm Point Details menu item, 371

View Logged-in User menu item, 372

viewing alarms in PAC Display Runtime, 330
visibility/blink
dynamic attributes, 162

W

Window State menu item, 238, 368
windows

and control system performance, 34

definition, 32

designing, 33

draw, 91, 369

dynamic attributes, 163

main window options, 290

project, 38

states, 238

ways to use in a display, 33
Windows button, 121
Windows combo box, 124
Windows metafiles

importing, 108
Windows NT

modifying permissions in, 343
writing to table elements, 336

X

XY plots, 186
and numeric tables, 210
configuring individual trend lines, 212
creating, 210
modifying, 210
using in PAC Display Runtime, 336

y4

Z-Order menu item, 358
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