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About groov
Opto 22’s groov makes it easy to build and deploy simple, effective operator interfaces for 
your system. groov is browser-based and uses only Internet standards (HTML5, CSS3, 
SVG, SSL). That means:

• You build groov screens using a modern web browser and you view them using a 
web browser. No additional software or plugins (like Java, Silverlight, or Flash) are 
required.

• Operators can use groov screens on 
virtually any browser-based 
device—smartphone, tablet, iPod 
touch, computer, large-screen 
TV—any device, any screen size, 
from any manufacturer. The only 
requirement is that it can run a 
modern web browser like Firefox, 
Chrome, or Safari.

• All software is contained in the groov Box, a 
small-footprint, industrially hardened network 
appliance that plugs into your control network and your 
computer network using independent Ethernet interfaces, either wired or wireless. 

• To build an operator interface, you drag a gadget, such as a gauge or button, from a 
built-in library of gadgets and drop it on the screen. All gadgets are designed to 
work either with a mouse or a touchscreen. Once placed, you can move gadgets 
around for best viewing on a PC or tablet versus a handheld device.

• When viewed, everything on the screen—gadgets, text, images, labels, even live 
video from a network IP camera—automatically scales to match the size of the 
device it will be viewed on. At the same time, gadgets and text never become too 
small to use or read on a smartphone. 

Operator interfaces built with groov are ideal as a supplement to an existing HMI for 
technicians, managers, or other people who need to securely monitor or control parts of 
your system. You can also use groov to build a complete HMI.

For more information on groov, visit groov.com.

A-B Systems and groov
The initial release of groov provides intuitive connections to Opto 22 SNAP PAC Systems 
and OptoEMU energy monitoring units. For these systems you simply point groov to the 
SNAP PAC controller or OptoEMU unit and to a tag database file that already exists, and 
the complete tag database is copied into the groov Box. When you place a gadget on the 
screen, you can tag it with any element in the tag database. 

A later release of groov will include OPC UA compatibility, so any OPC UA-enabled system 
can be similarly used.

http://groov.com/
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But right now you can use groov to create screens for an Allen-Bradley Logix system by adding a 
SNAP PAC controller as an intermediary. This is possible because SNAP PAC controllers 
communicate natively using EtherNet/IP.

Here’s how it works:

• The A-B system writes data to and reads data from the PAC’s internal Scratch Pad using 
EtherNet/IP. 

• The PAC translates Scratch Pad data to variables. 

• In groov, you use these variables to tag gadgets when you build your screens. 

• Since data can go in both directions, an operator can use groov screens for both 
monitoring and controlling the A-B system. 

The rest of this technical note shows an example of how to set up these parts so they work 
together to give you a simple, effective operator interface to your A-B system. 

Try the EtherNet/IP Gateway Strategy first
To save time, use the EtherNet/IP Gateway Strategy for groov instead of the steps in this 
technical note. The gateway strategy provides a pre-built PAC Control strategy and a tag 
database you can use in groov that correlates to your RSLogix data. You avoid having to use PAC 
Control and the EtherNet/IP Configurator. 

Check out the gateway strategy and see if it will work for you. Either follow the link above or go 
to www.opto22.com and search on Gateway Strategy. if you need additional data that the 
pre-built strategy does not provide, then come back to this technical note and build your own.

System Setup Example

Hardware 
You can use any Logix system and any SNAP PAC controller, including the software-based 
controller SoftPAC, to achieve the same result as in this example. For this example, we used the 
following hardware:

http://www.opto22.com/site/downloads/dl_drilldown.aspx?aid=4378
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• Rockwell CompactLogix L32E controller with power supply

• Opto 22 SNAP-PAC-S1 controller

• Opto 22 SNAP-PS24 power supply

• Opto 22 groov

• Computer with Windows OS

• Ethernet switch, power supply, and four Ethernet cables

NOTE: Since Opto 22 supports Explicit Messaging, you can similarly connect to SLC 5/05 and 
MicroLogix 1100 and 1400 systems.

Software 
You’ll need the following software:

• Opto 22 EtherNet/IP Configurator and PAC Control Basic (This software comes on the CD 
with the SNAP PAC controller or can be downloaded from the Opto 22 website.)

• RSLogix5000

• Web browser (Firefox or Chrome recommended)

Logix system

SNAP PAC 

Power supply

groov Box

Ethernet switch

Windows computer
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Opto 22 Documents
These documents will help you set up groov4ab. The first four are included in the PAC Project 
Basic download. If you don’t have a document, follow the link in the table or go to 
www.opto22.com and search on the form number.

Before You Begin
1. Write down the network IP addresses or device names (hostnames) you will use for 

each of these:

– Logix PLC

– SNAP PAC controller (must be a fixed IP address)

– PC

– groov Box (default hostname is on the label on the Box’s top)
2. Make sure you have installed everything from the CD that came with the SNAP PAC 

controller. If you don’t have the CD, download the following file from the Opto 22 website: 
PAC Project Basic (Or go to www.opto22.com and search on PACPROJECTBAS.)

3. Install the SNAP PAC controller following steps in the Quick Start chapter of the 
controller’s user guide (from the Start menu, choose > Programs > Opto 22 > PAC Project 
> Manuals > SNAP PAC User’s Guide). But don’t give it an IP address yet.

What You Will Do
In this example we’ll do the following: 

• Simulate a discrete input to the Logix system, called switch. Its state will be viewable in 
groov.

• Simulate a discrete output from the Logix system, called actuator. Its state will be 
controlled from groov. 

• Simulate an analog input to the Logix system, called Temperature. Its value will be viewable 
in groov. 

• Simulate an analog output from the Logix system, called Heater. Its value will be controlled 
from groov. 

For this See Document Form #

Installing the SNAP PAC controller SNAP-PAC S-series Controllers User’s Guide 1592

Programming the PAC PAC Control User’s Guide 1700

Assigning an IP address to the PAC, and 
EtherNet/IP messaging IO4AB User’s Guide 1909

Information on using the Scratch Pad PAC Manager User’s Guide 1704

Setting up & using groov groov User’s Guide 2027

http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=2668
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3161
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=3165
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4039
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To set up these inputs and outputs, we’ll complete the following steps:

Let’s get started.

Step 1: Configure Assembly Instances in EtherNet/IP 
Configurator

In this step you will configure data transfer between the SNAP PAC controller and the Logix 
controller. 
1. From the Start menu, choose Programs > Opto 22 > EtherNet-IP > EtherNet-IP 

Configurator.
2. Open the IO4AB User’s Guide (Start > Programs > Opto 22 > EtherNet-IP > IO4AB User’s 

Guide). Following steps in “Adding an Opto 22 Device” in Chapter 3, discover the SNAP PAC 
controller, give it the fixed IP address you wrote down, and name it: groov_4_AB 

3. Click the Configure Assemblies tab. In Assembly Instance 100, add two Assembly 
Members:

– Scratchpad DINT (class), Element 1 (instance) 

– Scratchpad REAL (class), Element 3 (instance)

NOTE: For more detailed steps and more options, see Chapter 6 in the IO4AB User’s Guide.

4. In Assembly Instance 101, add two Assembly Members:

– Scratchpad DINT (class), Element 0 (instance)

– Scratchpad REAL (class), Element 2 (instance)

Step 1: Configure Assembly Instances in EtherNet/IP Configurator page 5

Step 2: Configure the Logix System to Communicate with the PAC Controller in RSLogix5000 page 6

Step 3: Configure the SNAP PAC Controller in PAC Control page 9

Step 4: Configure groov for Logix Data page 15

http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4039
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4039
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5. Click the Verify tab, then click the Download button.

6. In the download confirmation dialog box, click Close. 
7. Click Save and close EtherNet/IP Configurator.

Step 2: Configure the Logix System to Communicate with the 
PAC Controller in RSLogix5000

In this step you will configure the Logix system to communicate with the SNAP PAC controller 
over EtherNet/IP. You will also configure tags to simulate the inputs and outputs from I/O cards 
in the Logix chassis, which will interact with groov.
1. Open the RSLogix5000 project that is associated with your Logix PLC.
2. Right-click the Network icon in the program tree that represents the Logix Ethernet port, 

and choose New Module. 
3. Double-click Communications, and scroll down to select Generic Ethernet Module.
4. In the Module Properties box, enter the following information:

– Name: groov_4_AB

– Comm Format: Data - DINT

– IP Address: the IP address of the SNAP PAC controller
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– Input Assembly Instance: 100 with a Size of 2

– Output Assembly Instance: 101 with a Size of 2

– Configuration Assembly Instance: 254 with a size of 0 (not used by Opto 22)

5. Click OK. When you’re asked for a Requested Packet Interval (RPI), enter 200 (ms) and 
click OK.

6. In the program tree, double-click Controller Tags and enter the following descriptions:

– Input Tag [0]: Actuator

– Input Tag [1]: Heater_RAW 

– Output Tag [0]: Switch 

– Output Tag [1]: Temperature_RAW 

Since we selected Data – DINT in the Generic Ethernet Module Comm Format, we must 
create floating point tags for the Temperature and Heater values, which are analog. 

7. In the program tree, right-click Controller Tags and choose New. Create a tag called 
Temperature_REAL of data type REAL. Repeat and create a tag called Heater_REAL 
of data type REAL.

8. Go back to the Controller Tags list and assign descriptions to these new tags: 
Temperature in Floating Point and Heater in Floating Point.
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9. In the program tree, double-click Main Routine. Add a rung of ladder logic with a CPS 
block. Set the Source as Temperature_REAL, the Destination to Output Tag [1], and the 
length to 1. 

10. Add a second rung of ladder logic with another CPS block. Set the Source to Input Tag [1], 
the Destination to Heater_REAL, and the length to 1.

11. Save the RSLogix5000 project. 
12. Download the RSLogix5000 program to the Logix PLC, but leave it in Program Mode for 

now.
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Step 3: Configure the SNAP PAC Controller in PAC Control
In this step you will configure the SNAP PAC controller to make the Logix data available to groov.
1. From the Start menu, choose > Programs > Opto 22 > PAC Project > PAC Control Basic. 

PAC Control Basic opens:

2. Choose File > New Strategy. Create a new PAC Control strategy called: groov 4 AB

If you need help, see the PAC Control User’s Guide (Start > Programs > Opto 22 > PAC 
Project > Manuals > PAC Control User’s Guide). 
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3. In the Strategy Tree at left, right-click Control Engines and add a control engine with the 
name S1 for AB groov and the IP address you assigned to the SNAP PAC. 

4. In the Strategy Tree, right-click I/O units and add an I/O Unit with the name 
S1_Scratchpad and the IP address 127.0.0.1 (Leave Type as SNAP-PAC-R1.)

5. In the Strategy Tree, right-click Charts and choose New. Create a new chart named 
Data_Exchange_for_AB. 

6. In the Strategy Tree, right-click Numeric Variables and add a variable with the name 
Status_Trashcan and type Integer 32.

7. Click the plus sign next to Charts and double-click Powerup. 
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8. Add an action block (blue rectangle) and use the connection tool to connect Block 0 to it 
with a down arrow. Right-click the new block and name it Start Chart. 

9. Double-click the Start Chart block and add a Start Chart command to start the chart 
Data_Exchange_for_AB. For Put Status In, choose Status_Trashcan. 

NOTE: The easiest way to find the command is to start typing it in the Instruction field, and then 
choose it from the dropdown list.
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10. Click OK.

11. Click Close.
12. In the Strategy Tree, right-click Numeric Variables and add the following four variables:

– Name: Switch_VAR Type: Integer 32. 

– Name: Actuator_VAR Type: Integer 32

– Name: Temperature Type: Float

– Name: Heater Type: Float
13. Click the plus sign next to Numeric Variables to see all the variables you’ve created.
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14. In the Strategy Tree under Charts, double-click Data_Exchange_for_AB. 
15. Below Block Zero, add five action blocks as shown at 

right and name them, in order:

– Scratchpad to Switch

– Actuator to Scratchpad

– Scratchpad to Temperature

– Heater to Scratchpad

– Delay 

NOTE: If you prefer scripting to flowcharting, you can use an 
OptoScript block instead, and add code as shown on 
page 20. 

16. Connect the blocks with down arrows, and loop the last 
block (Delay) back up to the first block you added (Block 
0 is simply the starting block).

17. Double-click the Scratchpad to Switch block. Add the 
command Get I/O Unit Scratch Pad Integer 32 Element, 
and enter or choose the following parameters (you may 
need to enlarge the dialog box to see them all):

– I/O Unit (All Valid Types): S1_Scratchpad

– Index (Integer 32 Literal): 0
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– Put Result in (Integer 32 Variable): Switch_VAR

– Put Status in (Integer 32 Variable): Status_Trashcan

18. Click OK., and then click Close.
19. In the same way, double-click the following blocks and add the commands and 

parameters shown.
a. Actuator to Scratchpad block. Add the command Set I/O Unit Scratch Pad Integer 32 

Element and enter or choose the following parameters:
– I/O Unit (All Valid Types): S1_Scratchpad
– Index (Integer 32 Literal): 1
– From (Integer 32 Variable): Actuator_VAR
– Put Status in (Integer 32 Variable): Status_Trashcan

b. Scratchpad to Temperature block. Add the command Get I/O Unit Scratch Pad Float 
Element, and enter the following parameters:
– I/O Unit (generic OptoMMP Device): S1_Scratchpad
– Index (Integer 32 Literal): 2
– Put Result in (Float Variable): Temperature
– Put Status in (Integer 32 Variable): Status_Trashcan

c. Heater to Scratchpad block. Add the command Set I/O Unit Scratch Pad Float Element, 
and enter the following parameters:
– I/O Unit (generic OptoMMP Device): S1_Scratchpad
– Index (Integer 32 Literal): 3
– From (Float Variable): Heater
– Put Status in (Integer 32 Variable): Status_Trashcan

d. Delay block. Add the command Delay (mSec), and for the parameter enter Integer 32 
Literal: 100
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20. Click the Save Strategy icon in the top toolbar (or choose File > Save Strategy), and click OK 
to save the strategy and charts. 

21. Click Debug to download the strategy to the PAC controller. 

22. Click Run . 

The strategy begins running on the SNAP PAC.

23. Minimize or close PAC Control Basic.
24. Go back to RSLogix5000 and put the Logix controller into Run Mode.

Step 4: Configure groov for Logix Data
In this step you will configure groov to view and control the Logix data through the SNAP PAC 
controller. You must have Editor or Admin rights in order to access groov Build.
1. If you have not yet set up groov, follow steps in the groov Quick Start to attach the groov 

Box to your networks and to power, and to open a web browser, log in, and change the 
password. If you need additional help, see the groov User’s Guide.

2. In the upper right of the groov screen, click the settings icon and choose Switch to 

groov Build. 
3. In groov Build, click the Configure menu and choose Controllers. In the Configure 

Controllers dialog box, click Add Controller. 

4. Enter the fixed IP address of your SNAP PAC controller. Leave the controller port at 22001. 
Browse to and select the groov 4 AB.idb.txt file for the strategy you created. (Make sure 
you choose the .idb.txt file, not the .idb file. Both files are in the folder where you saved 
your strategy.)

5. In the Pages pane at left, click Add Page, and name it: groov AB.
6. In the Gadget Palette at the lower right (Tags tab), expand the Tag tree so you can see all 

the tags in your strategy. 
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7. Click Switch_VAR, choose LED from the list of gadgets, and drag it onto the Desktop & 
Tablet workspace. In LED Properties at the upper right, do the following:

– For Label, enter Switch

– For color, choose green.

If the label overlaps the LED, click one of the grab points with your mouse and drag the 
box so it’s large enough to fit.

8. Similarly, for the remaining three data points, add the following gadgets and properties:
a. For Actuator_VAR, choose a Button gadget.

– Label: Actuator
– Color: Red

b. For Temperature, choose a Round Gauge.
– Min Value: 50
– Max Value: 110
– Needle color: green
– Show Value: checked
– Precision: 2
– Units: Deg F

c. For Heater, choose a Horizontal Slider.
– Label: Heater 
– Min Value: 0
– Max Value: 100
– Value: Show Percent 
– Color: Red
Extend the horizontal slider by clicking and dragging one of its side grab points.
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9. From the File menu, choose Save All Changes and Switch to groov View.

Step 5: Use groov with your Allen-Bradley System
1. In the RSLogix5000 Controller Tags Monitor Tags tab, change the Switch value from 0 to 1.

2. In groov View, notice that the switch LED has changed color from black to green.
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3. Still in groov View, click the Actuator Button. (It turns red.) In the RSLogix5000 Controller 
Tags, notice that the Actuator has changed from 0 to 1.

4. In the RSLogix Controller Tags, change the Temperature in Floating Point to 75.0.

5. In groov View, notice that the temperature gauge now shows 75 degrees F.

The live value from the controller is shown 
in blue text. All live values from the system 
are shown in blue.
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6. In groov View, move the Heater slider bar to the right, to about 85%.

7. In the RSLogix5000 Controller Tags, notice that the Heater in Floating Point has changed to 
match the groov heater control slider.

8. Now try logging into groov View with your smartphone or tablet to view and control your 
Allen-Bradley system data from there!

Lots of Options

A-B Systems and PAC Controllers
We’ve already mentioned that an assortment of Allen-Bradley products can be used with SNAP 
PACs and groov: ControlLogix, CompactLogix, and even SLC 5/05 and MicroLogix 1100 and 
1400 systems.

The intermediary Opto 22 controller can be any SNAP PAC standalone, rack-mounted, or 
software-based programmable automation controller:

• Standalone PACs are SNAP PAC S-series controllers like the one used in this example.

• Rack-mounted PACs are SNAP PAC R-series controllers, which also control analog, digital, 
and serial SNAP I/O modules on the same rack.

• SoftPAC is a software-based controller that runs on your PC. 
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Scripting
PAC Control provides programming options as well. 

For example, you can enter commands using scripting in 
a single OptoScript block (a yellow hexagon) instead of a 
series of action blocks (blue rectangles). 

Then your chart would look like the one at right.

The code in your OptoScript block for this example would 
be similar to the following:

The Scratch Pad
The Scratch Pad in the SNAP PAC controller is simply an area in the PAC’s memory map that you 
can use in any way you want. It includes the following five sections to accommodate different 
types of data: 

• Scratch Pad bits—a 64-bit mask

• Scratch Pad strings—a table of 64 elements. Each element can hold 128 characters or 128 
bytes of binary data.

• Scratch Pad floats—a table of 10,240 elements; each float is four bytes

• Scratch Pad 32-bit integers—a table of 10,240 four-byte elements

• Scratch Pad 64-bit integers—a table of 1024 eight-byte elements

In this example we used indices 0 and 1 of the Scratch Pad 32-bit integers table and indices 2 
and 3 of the Scratch Pad floats table. These are arbitrary choices; we could have used any 
indices that we aren’t already using. 

As you can see, you can accommodate a lot of data from your A-B system in the Scratch Pad.
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For More Information
For more information on groov, visit groov.com.

For questions about integration with A-B systems, contact your local Opto 22 distributor or an 
Opto 22 pre-sales engineer. There is no charge for pre-sales engineering.

• Phone (toll-free in the U.S. and Canada): 800-321-6786

• Phone (outside the U.S. and Canada): 951-695-3000

• Email: systemseng@opto22.com

Product Support
If you’ve already purchased Opto 22 products, are having problems, and can’t find the answers 
you need in this technical note or the reference documents listed on page 4, please contact 
Opto 22 Product Support. 

• Product support for groov for one year is included in the initial purchase price. After the 
first year, purchase maintenance (including product support and all updates) annually. 

• Product support on Opto 22 SNAP PAC controllers and I/O is free.

Phone: 800-TEK-OPTO (800-835-6786)
951-695-3080
(Hours are Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.

http://www.groov.com
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