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Learning Center Package Installation Form 2315-210322

INTRODUCTION

The groov® EPIC Learning Center Package is designed for the groov EPIC Learning Center (part number 
GRV-EPIC-LC). The package contains files, grouped into projects, that can help you learn how to create control 
programs that run on a groov EPIC processor and interact with groov I/O modules. The Learning Center and 
these files complement the groov EPIC® Training Series, our FREE online training course, which is available at 
training.opto22.com.

VERIFY VERSION COMPATIBILITY

Because the online training courses evolve along with the Opto 22 product line, it’s important to make sure 
that the version of the Learning Center Package that you downloaded is compatible with the firmware 
installed on your Learning Center.

The Opto 22 website always provides the most recent version of the package. If you want to keep older 
versions available for your reference, save a local copy of the older versions of the package.

Version 2.0 of the groov EPIC Learning Center Package requires the following minimum versions of software 
and firmware:
• groov EPIC Firmware 3.1.0
• CODESYS® Development System 3.5.16, Patch 4
• Opto 22 CODESYS Library Package 2.0.1.1
• PAC Control 10.3
• PAC Display 10.3

Check the version of firmware on the groov EPIC processor mounted on your Learning Center:
1. If your groov EPIC Learning Center is not on, turn it on and log in with a user ID with system level 

privileges.

If this is the first time you turn on the groov EPIC Learning Center, you’ll need to create the first system user ID. For 
important information regarding this user ID, watch the online lesson "Creating the First Administrator Account" 
or see “Creating the First System User ID and Finding the Hostname” on page 4.

2. In groov Manage, click or tap Info and Help > About.
3. In the EPIC section, if the System Version is 3.1.0-b14 or higher, your groov EPIC processor is at the correct 

level of groov EPIC Firmware. If it is lower, you’ll need to update the firmware. For instructions on updating 
the firmware, watch the video "Installing a System Update” or see “Updating Firmware on a groov EPIC” in 
the groov EPIC User’s Guide (form 2267).

WORKING WITH THE groov EPIC LEARNING CENTER PACKAGE

The files in the package are for your reference and development. Here are a few ideas on how to work with 
them:
• As you complete courses in the online training, compare your project files with the files in the package. 

This is another way to check whether the results you achieve are similar to what you may find in 
completed and functioning project files.

• If you have working knowledge and experience with the software and firmware listed in “Verify Version 
Compatibility” on page 1, you can probably skip the instructions in “Running Projects on the groov EPIC 
Processor” on page 4, which provide step-by-step instructions on installing and running the project files. 

https://www.opto22.com/products/product-container/groov-epic-lc
https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://training.opto22.com/path/groov-manage-for-groov-epic/initializing-groov-epic-with-groov-manage/734744
https://training.opto22.com/path/groov-manage-for-groov-epic/how-to-backup-update-firmware-and-restore-your-groov-epic-unit/219675
https://www.opto22.com/products/product-container/groov-epic-lc
https://www.opto22.com/products/product-container/groov-epic-lc
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-package
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-package
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You can install the projects on your own, then run the projects to review the programming, organization, 
and functionality featured in the projects.

• If you have expert knowledge with the software and firmware listed in “Verify Version Compatibility” on 
page 1, you can install the project files and modify them to give yourself a jump-start on creating a Proof 
of Concept project.

• If you are familiar with PAC Control programming and want to learn more about creating IEC61131-3 
compliant programs, note that the I/O in the CODESYS project files have the same names as the I/O in 
the PAC Control project files. 

PROJECT DEPENDENCIES AND PREREQUISITES

Review the following list to understand the dependencies between the projects included in the Learning 
Center Package, as well as any prerequisites required by a project:
• CODESYS–This project associates the devices and sensors on the Learning Center's load panel to the 

I/O channels. The project includes examples of a Ladder Diagram and Structured Text. The files for this 
project are in the CODESYS Complete folder. You also need CODESYS Development System installed on 
your computer.

• groov View–This project runs a groov View HMI for the strategy in the PAC Control Strategy project, and 
has Data Stores that work with the Node-RED project flows and the MQTT online lessons. If you want to 
run this project, you must install and run the PAC Control strategy first. The files for this project are in the 
groov View Complete folder.

• Node-RED–The flows in the Node-RED project write to the PAC Control strategy and provide data for the 
Weather page of the groov View project. If you want to run this project, you must install and run the PAC 
Control strategy first. The files for this project are in the Node-RED Complete folder.
You will also need to create an OpenWeather account and obtain an API key. For instructions, see 
“Creating an OpenWeather Account and Obtaining an API Key” on page 3.

• PAC Control Strategy–This strategy runs the logic that controls the interaction between the devices 
and sensors on the Learning Center’s load panel and the HMI (groov View or PAC Display). If you want to 
run the groov View project, the Node-RED project, or the PAC Display project, you must install and run the 
PAC Control strategy first. The files for this project are in the PAC Control Strategy Complete folder. You 
also need PAC Control installed on your computer.

• PAC Display Project–This project runs a PAC Display HMI for the strategy in the PAC Control Strategy 
project. If you want to run this project, you must install and run the PAC Control Strategy project first. The 
files for this project are in the PAC Display Project Complete folder. You also need PAC Display installed on 
your computer.

UNCOMPRESSING THE groov EPIC LEARNING CENTER PACKAGE

The Learning Center Package is a compressed file. Uncompress the file to your computer, making note of the 
path where you uncompressed the files. You will need this path information when you install and run the 
projects.

BACKING UP PREVIOUS WORK

If you already worked with your groov EPIC Learning Center and want to save any work you’ve done, review 
the instructions in “Backing up Your groov EPIC Processor” in the groov EPIC User’s Guide (form 2267) to create 
a back up of your work.

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://us.store.codesys.com/
https://www.opto22.com/products/paccontrolbas 
https://www.opto22.com/products/paccontrolbas
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SETTING UP YOUR COMPUTER

If you want to run the PAC Control, CODESYS, or PAC Display projects, you’ll need to install the corresponding 
software on your computer. The PAC Control and PAC Display software is available for download from the 
Opto 22 website (www.opto22.com). The CODESYS software is available from the CODESYS Store 
(us.store.codesys.com).

When you received your groov EPIC Learning Center, it included a printed document called groov EPIC Learning 
Center Setup (form 2311). The back page of that document included instructions on installing:
• PAC Project, which installs PAC Control and PAC Display
• CODESYS Development System and the Opto 22 Library Package for CODESYS Development System

Review the installation instructions in that document. If you can’t find that document, you can download it 
from our website or follow the instructions in the following online resources:
• PAC Project Basic download page on www.opto22.com. The PAC Project Basic software package installs 

PAC Control, PAC Display, and several other software applications. Review the description, particularly 
where it describes how you indicate which applications you want to install.

• To install CODESYS Development System and the Opto 22 Library Package for CODESYS Development 
System, go through the online course “Getting Ready to Use CODESYS.” 

• Another resource for instructions on installing CODESYS Development System and the Opto 22 Library 
Package for CODESYS Development System is the groov EPIC User’s Guide (form 2267). Follow the 
instructions in the first three sections of “Chapter 8: Configure CODESYS and groov EPIC for IEC61131-3”:
– Obtaining Your CODESYS Activation Key Certificate and Ticket ID
– Downloading and Installing CODESYS Development System
– Adding the Opto 22 Library Package to CODESYS Development System

NOTE: Typically, if you download the most recent versions of this software from their respective websites, they can run 
any version of the groov EPIC Learning Center Package. However, if you already have a version of these software 
products installed on your computer, find the version number of the installed software and compare it to the 
compatibility table in “Version History” on page 9 to make sure the software can run the projects.

CREATING AN OPENWEATHER ACCOUNT AND OBTAINING AN API KEY

If you want to run the Node-RED project, you need to create an OpenWeather account and obtain an API key. 

Go through the online course “Getting Weather Data with an API String and Browser”or follow these steps:
1. Go to the OpenWeather website (https://home.openweathermap.org).
2. Follow the instructions on the website to sign up/register for an account. 

After you confirm your email address and log in with your new account, the OpenWeather website 
shows you your API key (blurred in the following image), under your Account Settings > My API Keys.

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://www.opto22.com/products/pacprojectbas
https://www.opto22.com
https://training.opto22.com/path/codesys/getting-ready-to-use-codesys/293769
https://home.openweathermap.org
https://us.store.codesys.com/
https://training.opto22.com/path/node-red/getting-data-from-a-cloud-weather-service/717896
https://www.opto22.com/support/resources-tools/documents/2311-groov-epic-learning-center-setup
https://www.opto22.com/support/resources-tools/documents/2311-groov-epic-learning-center-setup
https://www.opto22.com/support/resources-tools/documents/2311-groov-epic-learning-center-setup
https://www.opto22.com/support/resources-tools/documents/2311-groov-epic-learning-center-setup
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3. Highlight the API key and press CTRL+C to copy the text to the computer’s clipboard.
4. Open your favorite text editor and paste the secret key into the editor. Save it with a filename like 

OpenWeatherMap_API.txt. You may want to save the file in a secure location.

When you are preparing the Node-RED project, you’ll need the OpenWeather API key when you get to 
“Configure Nodes” on page 7.

CREATING THE FIRST SYSTEM USER ID AND FINDING THE HOSTNAME

In any of the following situations, you will need to create a new system user ID:
• Turning on a new groov EPIC Learning Center for the first time.
• Turning on a groov EPIC Learning Center after installing a firmware update.
• Resetting a groov EPIC processor to factory defaults.

To create a system ID for the first time, go through online lesson “Creating the First Administrator Account.” 
Create this user ID with a password that follows strong security recommendations. This user ID is the first 
administrator level user for your Learning Center. Remember it! groov EPIC does not provide a way to recover 
a lost password or username.

You can find the groov EPIC’s hostname if you did not note it when you turned on the Learning Center for the 
first time. It’s on the Network page of groov Manage (Home > System > Network).

RUNNING PROJECTS ON THE groov EPIC PROCESSOR

The instructions in this section take you step-by-step through installing and running each project.

Running the PAC Control Project

Make sure you have PAC Control installed. (See “Setting Up Your Computer” on page 3.)
1. Start PAC Control in Config mode.
2. Load the strategy.

a. In PAC Control, click File > Open Strategy.
b. Navigate to the folder where you uncompressed the Learning Center Package and open the PAC 

Control Strategy Complete folder.

https://training.opto22.com/path/groov-manage-for-groov-epic/initializing-groov-epic-with-groov-manage/734744
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c. Select Cstore.idb and click Open.
3. Set the Control Engine to the groov EPIC processor on your Learning Center.

a. Expand the Control Engines folder in the Cstore strategy tree by clicking the + sign.
b. Double-click EpicLC.
c. In the Configure Control Engines window, click Add.
d. Find your groov EPIC Learning Center in the Select Control Engine window, select it, and click OK. If 

you haven't configured a control engine, click Add to add one. 
For help, go through the online lesson “Adding and Configuring a Control Engine.” 

e. Click Set Active in the Configure Control Engines window.
f. Click OK to close the Configure Control Engines window.

4. Open the charts.
a. Expand Charts in the strategy tree by clicking the +.
b. Double-click the Freezer Monitor chart to open it.
c. Maximize it.
d. Open all of the other charts.

5. Save changes and run the strategy.
a. Click File > Save Strategy.
b. Click Mode > Debug. In the Download Warning window, click Yes to acknowledge the warnings or 

notifications and download the strategy to the processor.
c. Click Debug > Run to run the strategy.

Running the PAC Display Project

Make sure you have PAC Display installed. (See “Setting Up Your Computer” on page 3.)
1. Start PAC Display Configurator.
2. Load the PAC Display project and select the control engine and strategy.

a. In PAC Display Configurator, click File > Open Project.
b. Navigate to the folder where you uncompressed the Learning Center Package and open the 

PAC Display Project Complete folder.
c. Select Learning_Center.UUI and click Open.
d. In the Cannot find the strategy file window, click OK.
e. In the Control Engines window, select EpicLC, then click Replace.
f. In the Primary Control Engine field of the Control Engine Properties window, click Browse.
g. In the Select Control Engine window, select your groov EPIC Learning Center control engine in the 

Configured Control Engines list, then click OK.
h. In the Strategy field, click Browse, navigate to the PAC Control Strategy Complete folder, select 

CStore.idb, and click Open.
i. Click OK to close the Control Engine Properties window.
j. Click OK to close the Control Engines window.

3. Save the project and run it.
a. Click File > Save Project and Load Runtime.
b. If a message appears indicating PAC Display needs to regenerate all IO scanner tag names, click OK.

The Event Log Viewer displays a message indicating the date and time that the PAC Display runtime 
was started, as well as the version. 

c. Click OK to close the window.

The PAC Display project is running. You can click through the interface to interact with the screen, as well as 
interact with the load panel to observe changes on the PAC Display HMI.

https://training.opto22.com/path/pac-control/creating-and-configuring-a-strategy/230757
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Running the groov View Project

1. Connect to your groov EPIC processor from a browser.
a. Open a browser and type in the hostname of your Learning Center in the URL bar: 

https://<hostname>

b. Log in with the system user ID and password you created in “Creating the First System User ID and 
Finding the Hostname” on page 4.

2. Start groov View and load the groov View project.
a. In the groov Manage Home page, click groov View.
b. Click the menu button ( ), then choose Switch to Build mode.
c. Click File > Restore Project from Computer.
d. In the Restore Project window, click Browse.
e. Navigate to the folder where you uncompressed the Learning Center Package and open the 

groov View Complete folder.
f. Select groov-View_COMPLETE_v2.0.tar.gz and then click Open.
g. In the Restore Project window, type in opto for both the user name and password.
h. Click Restore.
i. Click OK to restore the project window.

3. Set the Controller Address to the groov EPIC processor on your Learning Center.
a. From the groov Build menu, select Configure > Devices and Tags.
b. Highlight CStore, and click Edit Device.
c. Verify that the Controller Address is set to either localhost, the hostname, or the IP address of your 

groov EPIC Learning Center's processor.
4. Click File > Save All Changes and Switch to groov View.

The groov View project is now running.
5. Click the navigation icon.

The groov View pages are divided into two page categories. The C-Store 001 category has pages that are 
animated with simulated data. The Learning Center category has pages that are animated with tags that 
are connected to the groov EPIC Learning Center load panel. 
You can click through the interface to interact with the screen, as well as interact with the load panel to 
observe changes on the groov View HMI.

Running the Node-RED Project

Before you start, make sure you have your OpenWeather API key readily available.

Connect to your groov EPIC processor from a browser

1. Open a browser and type in the hostname of your Learning Center in the URL bar: 
https://<hostname>

2. Log in with the system user ID and password you created in “Creating the First System User ID and 
Finding the Hostname” on page 4.

Load the Node-RED project

1. From the groov Manage Home page, click Node-RED.
2. Click Project Management.
3. Click Upload Project.
4. Navigate to the folder where you uncompressed the Learning Center Package and open the 

Node-RED Complete folder.
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5. Select the node-red.project.COMPLETE_v2.0.zip file and click Open. groov Manage displays 
a message that it is uploading the project. When the upload is done, click Start Node-RED.

6. When groov Manage displays a message that it started Node-RED, click Close.

If Some Nodes are Missing 

Starting with groov RIO firmware v3.0.0, user-installed Node-RED nodes are included when you restore a 
project. If Node-RED indicates there are missing nodes, follow these instructions to install them. Otherwise, 
continue to “Configure Nodes” on page 7, below.
1. From the groov Manage Home page, click Node-RED > Open Node-RED Editor.
2. Click the menu button (menu.png), then Manage Palette.
3. Click the Install tab.
4. Type Opto 22 in the search field.
5. Find the node-red-contrib-groov node and click Install. In the message box, click Install. Wait 

for the installation to finish before going to the next step.
6. Find the node-red-contrib-pac node and click Install. In the message box, click Install. Wait for 

the installation to finish before going to the next step.
7. In the search field, replace Opto 22 with mssql
8. Find the node-red-contrib-mssql node and click Install. In the message box, click Install. Wait 

for the installation to finish before going to the next step.
9. Click Close, and close the Node-RED Editor tab on your browser.

Configure Nodes

You’ll configure Opto 22 pac read and groov write nodes so that they refer to the groov EPIC processor on your 
Learning Center, and add your OpenWeather API key.
1. Go to the groov Manage Home page, then click Accounts.
2. Click Users.
3. Click the user ID that will run the Node-RED project, typically the first user ID you created when you 

turned on the Learning Center for the first time. (See “Creating the First System User ID and Finding the 
Hostname” on page 4.)

4. In the API Key section, select the text in the API Key field and press CTRL+C to copy it to the computer 
clipboard.

5. Click Cancel, Accounts, and then Home.
6. Switch back to the Node-RED Editor.
7. For the temperature, fuelLevel, and SlushyStartButton nodes, repeat the following steps:

a. Double-click the node.
b. Click the modify button next to the Device field.
c. In the Address field, type in localhost.
d. In the API Key Value field, paste the API key you copied from step 4 (above).
e. Click Add.
f. Click Done.

8. For the groov write node:
a. Double-click the node.
b. Click the modify button next to the Data Store field.
c. Click the modify button next to the Groov Project field.
d. In the API Key Value field, paste the API key you copied from step 4 (above).
e. Click Add (or Update).
f. Click Update.
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g. Click Done.
9. For the OpenWeather node:

a. Double click the node.
b. Click in the URL field and move the cursor to the right until you see 

<Your_OpenWeather_API_Key>.
c. Highlight <Your_OpenWeather_API_Key> and replace it with the OpenWeather API key you 

saved. (See “Creating an OpenWeather Account and Obtaining an API Key” on page 3.)
d. Click Done.

There are MSSQL nodes in this flow that are not configured but are left in as examples of what you could do 
with the data. Read the comment node in the flow “Get all MS SQL data for this device” for more information.

Deploy the flow

1. Click Deploy in the upper-right corner of the Node-RED Editor. 
2. When you see a message about the three MSSQL nodes not being properly configured, click Confirm 

deploy. 

After a few moments, you may begin to see some activity on your screen. You can interact with the nodes on 
the flow and switch to the other tabs (for example, the Debug Messages tab) to view notifications.

Running the CODESYS Project

Make sure you have CODESYS Development System and Opto 22 CODESYS Library Package installed. (See 
“Setting Up Your Computer” on page 3.)
1. From the groov Manage Home page, select Controller > CODESYS Controller, then click Enable to start 

the CODESYS control engine.
2. Load the CStore_CODESYS_v2.0.project to CODESYS Development System.

a. Start CODESYS Development System.
b. Click File > Open.
c. Navigate to the folder where you uncompressed the Learning Center Package and open the 

CODESYS Complete folder.
d. Select CStore_CODESYS_v2.0.project and click Open.

CODESYS Development system checks whether the version of the Opto 22 Library Package installed 
in CODESYS Development System matches the level that was used to create the 
CStore_CODESYS_v2.0.project. If they do not match, CODESYS Development System displays the 
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Project Environment window, where you can indicate whether you want CODESYS Development 
System to upgrade the library in the current project to the level installed:

e. In the Action column, double-click Do not update. From the list of actions to take, choose Update 
and then click OK.

3. Add your Learning Center’s groov EPIC processor to the project; then download and run the project.
a. Double-click Device in the Devices view, then Scan Network.
b. Select your groov EPIC Learning Center processor, and click OK.
c. Click File > Save Project.
d. Click Build > Build.
e. Click Online > Login.

If you get a warning about the current application replace an existing application that’s running on 
the groov EPIC processor, click Yes.

f. Click Debug > Start.

Now that the CODESYS application is running, you can do things like set breakpoints, cycle through the ladder 
diagram, and toggle channels to see how the lights change on the Learning Center’s load panel.

VERSION HISTORY

Because the Opto 22 product line and online training are always evolving, it’s possible that the Learning 
Center Package you download or saved is incompatible with the version of firmware installed on the 
processor mounted on your Learning Center, or the software running on your computer. Review the following 
table to determine compatibility:

The version of the Opto 22 Library Package 
for CODESYS Development System currently 
installed on CODESYS Development System.

A newer version of the Opto 22 Library 
Package for CODESYS Development System 
that is available.
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If you have this version of the 
Learning Center Package...

...it works with this version of firmware and software:

2.0.0 or higher

• groov EPIC firmware 3.1.0 or higher
• CODESYS Development System 3.5.16 Patch 4
• Opto 22 CODESYS Library Package 2.0.1.1 or higher
• PAC Control 10.3
• PAC Display 10.3

1.3.2 or higher

• groov EPIC firmware 1.3.0 or higher
• CODESYS Development System 3.5.13 Patch 1
• Opto 22 CODESYS Library Package 1.0.0.1 or higher
• PAC Control 10.2
• PAC Display 10.2

1.0.0 or higher

• groov EPIC firmware 1.3.0 or higher
• CODESYS Development System 3.5.13 Patch 1
• Opto 22 CODESYS Library Package 1.0.0.0 or higher
• PAC Control 10.2
• PAC Display 10.2


