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        README: OptoDisplay
        
======================================================================

Maximize the Notepad window to read this file more easily.

Please review the following FactoryFloor topic page for information about 
FactoryFloor software and firmware updates and patches:
http://www.opto22.com/lp/factoryfloor.aspx
 
Please review and install this separate DLL patch that affects OptoDisplay:
 
http://www.opto22.com/site/knowledgebase/kb_view_article.aspx?aid=1203
 
http://www.opto22.com/site/downloads/dl_drilldown.aspx?aid=3535

======================================================================
OptoDisplay B4.1h Patch
June 28, 2010

This OptoDisplay patch requires that OptoDisplay 4.1 already be installed. 
Do not install this patch unless OptoDisplay 4.1 is already installed.

Installing the Patch
--------------------
Follow these steps to update an earlier version of OptoDisplay 4.1 to the 
current version in this patch:
  1. Stop the OptoDispLS service.
     a. Choose Start > Control Panel > Administrative Tools > Services.
     b. Early versions of the install added the service under an incorrect name. 
        If you can't locate OptoDispLS in the services applet, look for a name 
        similar to this:
        i. "FACFL~|VersionManager"
       ii. The description might say "OptoSnif".
     c. Stop the service.
  2. Back up the C:\Windows\system32\OptoDispLS.exe file.
  3. Replace OptoDispLS.exe with the one in the zip file.
  4. Start the service from the services applet.
  5. Back up the current OptoDisplay executable files (which are normally 
     located in a folder similar to C:\Program Files\Opto22\FactoryFloor 4.1\):
     a. OptoDisC.exe
     b. OptoDisR.exe
     c. OptoDsRX.exe
  6. Replace each file with the ones in the zip file.
  7. Update your project
     a. Start OptoDisplay Configurator.
     b. Open your project.
     c. Save your project.
  8. Go to Runtime.

http://www.opto22.com/site/knowledgebase/kb_view_article.aspx?aid=1203
http://www.opto22.com/lp/factoryfloor.aspx
http://www.opto22.com/site/downloads/dl_drilldown.aspx?aid=3535


Bug fixes:
----------

- B4.1h (9/4/09)
  Runtime:

  Fixed memory leak.

- B4.1d (4/20/07)
  Configurator:
 
  KB57143 - The Browse... button for the Remote Computer, under Remote 
  SuperTrend logging, was not showing the entire network, only the root entry.

- B4.1c
  Runtime:

  Corrected calculation errors for displaying a Trend with no labels.
  
- B4.1b
  Runtime:

  * Fixed random crash related to displaying metafile images.
  * New OptoDispLS security service. It no longer requires administrative 
    privileges to launch Runtime.
  * Added Pointer support to OptoDisplay scanner.
  * Fixed a bug that could cause a crash (related to checking the configured 
    security for an output dynamic attribute when the window file was being 
    read.)
  * Fixed a bug with alarm sounds not sounding if an alarm point re-appeared 
    in an alarmed state.

=====================================================================
What's New in version R4.1a?
January 17, 2005

New Features and Enhancements:
------------------------------
  * Added multiple security features so you can:

    - Configure the Operator Driven dynamic attributes of an on-screen object to
    restrict HMI use to operators who are defined in Microsoft® Windows® User-
    and Group-level security settings.

    - Encrypt the Runtime Operator Action Log file to provide a secure record of
    operator activity.

    - Have the project’s version number increase automatically whenever a
    project is modified.
    
    The new access control capabilities, plus new operator log encryption, can
    be useful for organizations which must meet U.S. FDA 21 CFR Part 11 
    requirements.

  * Added a new color version of the Symbol Factory library of industrial
  graphics.

  * Symbol Factory graphics can now be dragged and dropped directly into an



  OptoDisplay project.

  * Graphics in JPEG file format can be imported into an OptoDisplay project.

  * A new on-screen object has been added that can hold up to four numeric
  tables from an OptoControl strategy.

  * OptoControl pointer variables and integer 64 values can now be used in an
  OptoDisplay project.

  * Added an Alarm Point Persistence feature that lets you specify how long an
  alarm condition must be present before an alarm is triggered.

  * Added Automatic Re-alarming after Acknowledge feature that triggers the
  alarm if the trigger condition remains for a set period of time after the
  alarm is acknowledged.

  * New "silenced" color for Alarm Point graphics visually indicates alarms that
  have been silenced and not acknowledged.

  * Runtime Logs are now in the same format as OptoDisplay historic logs. Custom
  headers can be used in a Runtime log file.

  * A single Controller status object can now display the status of several
  controllers.

  * Multiple improvements in project authoring environment so you can:

    - Search and reveal tags used in projects.
    - View just the tags configured for an object.
    - View individual Dynamic Attributes for an object.
    - Format the text read from a controller as decimal, hexadecimal, binary, or
    exponential.

=====================================================================
What's New in version R4.0e?
April 14, 2003

Bug fixes:
----------
  Configurator:

  * The Replace feature in Configurator no longer allows trying
    to modify a bit value greater than 31 in an Integer32 variable
    type.  It does allow modifying bits greater than 31 in 
    Integer64 variables.

  * The View Dynamic Attributes now correctly shows recipe and 
    Execute Menu Item dynamic attributes.

  * A bug where the Project Password dialog would sometimes fail
    even when the correct password was entered has been fixed.

  * GDI resource leaks with fonts and metafiles have been fixed.

  Runtime:

  * Synching the PC time and controller time now works correctly.



  * A problem where Runtime would hang during rollovers of log
    files has now been fixed.

  * Sending both a discrete and a value no longer gives an error 
    message.

=====================================================================
What's New in version R4.0d?
April 9, 2002

Bug fixes:
----------

  * Problems with Configurator consuming too many GDI resources has
    been fixed.

=====================================================================
What's New in version R4.0c?
March 26, 2002

Bug fixes:
----------

  * Configurator displayed text improperly on some Windows 2000 
    systems.  This has been corrected.

  * When triggering multiple Operator Driven Dynamic attributes in
    Runtime, the "TValue Error" message is no longer generated.

  * In Runtime, pressing the ENTER key when the Event Log window was 
    active closed the window until the Runtime application was closed 
    and restarted.  This has been corrected.

Enhancements:
-------------
  * OptoDisplay Runtime Event Log now displays the "Controller Locked" 
    error message.

  * Better metafile checking has been added to Configurator to reduce 
    invalid metafiles from being imported into the project.

=====================================================================
What's New in version R4.0b?
February 08, 2002

Bug fixes:
----------
  * Sending Discrete values to bits 0 through 31 of Integer64 types
    now works correctly in Runtime.

  * Metafiles now properly paste after being copied.

  * Operator Logging no longer crashes.



  * Operator Logging now writes the file to the correct location.

  * Repeatedly sending discrete values no longer locks the controller.

=====================================================================
What's New in version R4.0a?
January 15, 2002

New Features:
-------------
  * Operator runtime logging allows all actions and modifications 
    resulting from Operator Driven Dynamic Attributes to be logged 
    to a file. Actions that can be logged include changing process 
    values or discrete items, downloading or uploading recipes, 
    launching applications, running menu commands, and detaching 
    or attaching controllers. Modifications to alarm point values 
    can also be logged.

  * Scanner Information File -- A scanner information file is a 
    text file that contains diagnostic information that can be 
    useful in debugging throughput problems with the OptoDisplay 
    scanner. The file lists information about the scan groups, 
    refresh groups, and tags that are being scanned by the 
    configured controllers. Opto 22 Product Support can also use 
    this file to help resolve scanner throughput problems.

  * Runtime can now be configured to not display the Exit dialog 
    when closing.

Updated:
--------
  * The OptoDsrX version of Runtime now has the View->Controllers menu
    option available.

Bug fixes:
----------
  * Label text in Configurator now displays correctly under 
    Windows 2000.
  
  * Selecting integer and float table ranges when configuring tags
    is only allowed if configuring an XY Plot or Historic Data
    Log points.

  * The option "Play sound continuously" now works correctly when 
    using alarm points that are not inserted into an alarm graphic.

  * Deadbands for floats now work when configuring "Text In From
    Controller" Dynamic Attributes.

  * The "Switch Controllers" menu option now appears correctly in
    Runtime.

=====================================================================
What's New in Version R3.1e?
March 23, 2001

Updated:



--------
  * The XY Plot Configuration dialog box now lets you easily enable
    or disable individual plots in an XY plot graphic object.

Bug fixes
--------
  * The XY Plot Configuration dialog box now correctly enforces the
    limit of 50 table elements for each individual plot in an XY plot
    graphic object.

  * Help buttons on the Runtime Configuration dialog and the
    Refresh Groups Configuration dialog now work correctly.

  * OptoDisplay Runtime now works correctly if both "Enable
    Synchronization at Runtime Startup" and "Enable Auto
    Synchronization" options are selected in OptoDisplay
    Configurator's Configure Runtime dialog box.

  * Metafile (WMF) graphics now display correctly in Windows 2000.

  * Importing a symbol that is associated with a controller into a project
    that has no configured controllers no longer causes OptoDisplay
    Configurator to crash.

=====================================================================
What's New in Version R3.1d?
February 15, 2001

New Features:
-------------
  * An XY Plot graphic has been added. Up to 6 separate pens can be
    displayed per graphic.

  * If the identical OptoControl strategy is running on more than
    one controller, OptoDisplay now offers the ability to have a
    window switch controllers and begin viewing data from a different
    controller.

  * Added support for SNAP-ENET-D64 digital only brain. Can read,
    clear, set, or toggle discrete bits in 64-bit integers. (64-bit
    integer values and tables are not supported)

  * A report displaying all configured dynamic attributes for any or
    all windows in a project, along with all configured Alarm Points
    may be generated.

  * Controllers may be synched to PC's time and date manually, based
    on a user-defined schedule, or each time Runtime starts.

  * The number of Refresh Groups has been increased to 14.

  * Graphics may now be locked to their window position.

  * Graphics displaying controller tag data may be configured to
    indicate invalid data by changing to a user-selected
    Detached On Error or Detached By User color if the controller goes
    off-line .



  * Added Discrete Acknowledge color to the Alarm Point
    Controller-Driven dynamic attribute.

  * Background color for fill style may be chosen.

Bug Fixes:
----------
  * Multiple sounds configured for alarms and triggers are now played
    sequentially.

  * Printing a window that spans multiple monitors now works correctly.

  * Historic log names are now properly displayed in the Configure
    Historic Log Point dialog.

=====================================================================

What's New in Version R3.1b?
June 16, 2000

Bug Fixes:
----------
Configurator:

 * Clearing a dynamic attribute from a graphic with a
   fill color, would revert the graphic to white;

 * The Window Properties dialog would sometimes disable
   the "Open when there are new alarms" and "Disable close
   if there are active alarms" checkboxes when the window
   contained alarms.

 * Memory leaks in the Tag Selection Dialog were corrected.

 * Clicking Cancel from the Edit Dynamic Attributes
   dialog no longer causes a graphic to lose it's
   fill color and revert to white.

 * When Configuring AlarmPoints, the HiHi and Hi priorities
   are not reset to 0 when the dialog is displayed.

 Note: the actual priorities in OptoDisplay Runtime were
       not affected.  Only the dialog in Configurator
       showed the incorrect values.

Runtime:

 * Release R3.1a  may cause scanning speed to be slower than previous
   versions.  R3.1b corrects this problem.

 * When opening a password-protected window, user now has
   three opportunities to enter the correct password;

 * In Discrete Alarms, if the sound was set to "Play sound
   continuously until any alarm is acknowldeged", the sound
   was never played for new alarms after the first



   acknowldegement;

 * When configuring the "Acknowledge" notification for
   alarmpoints, if bit indexes were used with the
   Discrete->Set option, a "Data Range Error" would
   appear in the event log window;

 * Memory leaks with Trends were corrected;

 * When configuring AlarmPoints, if the Conditional tag
   was set to discrete, and no Bit Index was entered
   in the Tag Selection dialog, the condition was never
   met.

 * The window password dialog now masks the password.

=====================================================================

What's New in Version R3.1a?
February 29, 2000

New Features:
-------------
 * "Alarm Point" controller driven attribute allows graphics to
   change color and blink based on the status of an alarm point.
   Colors are user-configurable.

 * Controller status may now be configured as an alarm point.

 * "Controller Status" controller driven attribute allows graphics
   to change color based on the status of controllers.  Colors
   are user-configurable.

 * "View Controller Status" operator driven attribute launches
   Runtime's Controller Status dialog for a configured controller.
   Allows manual detaching/re-attaching of controller.
   (See following item)

 * In Runtime's Controller Status dialog, controllers may now be
   detached manually.  The scanner will not attempt to re-attach to
   the controller until the Attach button is clicked.

 * An Alarm Clear notification has been added to alarm point
   configuration.

 * Individual windows can be protected with a password.

 * The entire OptoDisplay  project can be protected with a password.

 * A monitor-only version of Runtime (OptoDsrX.exe) is provided that
   disables all operator driven attributes except opening/closing
   windows.  Only the File and Help menus are available in this
   version of Runtime.

 Enhancements:
 -------------
 * Runtime no longer uses 100% CPU time.



 * Added links in the Help menu to manuals and Opto 22 Web sites.

 * When no project is loaded, a shortened menu is displayed.

 Bug Fixes:
 ----------
 * Configurator no longer crashes when you try to modify a Launch
   Application attribute.

 * A problem displaying metafiles in Runtime has been fixed.  This
   problem was due to a bug in Windows 95, Windows 98, and Windows NT
   SP 4 that caused system resources to be exhausted, resulting in
   Runtime hanging or crashing.

 * Integer tables now appear correctly when configuring the Visibilty
   blink attribute.

 * When opening an OptoDisplay version 2.2 project in OptoDisplay 3.0,
   configured historic logs now appear correctly in the Configure
   Historic Log File list box.

 * SuperTrend historic files containing header lines longer than 80
   characters (up to 255 characters) now display correctly.

 * SuperTrend remote logging now works under Windows 95 and Windows 98.
   Previously, each computer thought it was the computer saving the data,
   regardless of which computer was configured to do so.

 * Memory is no longer continuously allocated to basic trends or
   SuperTrends.  This caused all available memory to be consumed.

 * If started without a project, Runtime no longer crashes when the
   Windows "Date/Time Properties" dialog box is closed by clicking OK.

 * Runtime no longer crashes if hot-keys no longer activate valid
   dynamic attributes.

 * The "Acknowledge All" button now works correctly for Summary and
   Detailed alarms.

=====================================================================

What's New in Version R3.0b?
September 28, 1999

Bug Fixes:
----------
 * Integer and float tables now appear in the Tag Selection dialog 
   box.
 * Ctrl+Z and Ctrl+Y key combinations now work for Undo and Redo.
 * Lines no longer move or rotate when closing the Dynamic Attributes 
   dialog box.
 * Lines no longer move when dragging the origin of a line to resize 
   it.
 * In the Value tab of the Alarm Point dialog box (Configure->Alarm 
   Points, double-click an alarm point, click the Value tab), if a 



   LoLo value is configured to use a tag, the "Tag" option remains 
   selected after closing and reopening the dialog box.  Previously,
   the "Value" option would become the default.
 * In the Alarm Notification and Acknowledge Notification dialog boxes
   (Configure->Alarm Points, double-click an alarm point, click Alarm
   or Acknowledge), the "Current Value" option in the Setup By field 
   remains selected after closing and reopening the dialog box.  
   Previously, the "Discrete" option would become the default.
 * SuperTrend log files saved to locations other than the project 
   directory now appear in the Select Log File list.
 * A graphic placed over an imported metafile graphic object can now 
   be moved without having other graphics placed over the metafile 
   graphic disappear.
 * Static text no longer disappears when dynamic text is placed over 
   it.
 * The keyboard can now be used to select menu commands when 
   SuperTrends appear in OptoDisplay windows. 
 * More than 48 SuperTrend objects can have the "Keep File Open" 
   option selected at the same time.  Previously, if more than 
   48 SuperTrend objects had this option selected, a "Disk Full" 
   error would occur in Runtime after 3-5 minutes.
 * Integer and Integer tables have been re-added to the Discrete 
   Tag Type dialog box.
 * The Z-order option now appears in the Context menu when you 
   right-click a group that is made up of grouped objects.
 * The "Refresh Time" option in the Tag Selection dialog box now 
   correctly shows changes made to the value after the first time 
   it's been set.
 * In the Window Properties dialog box (Window->Properties), the 
   "Always in memory" checkbox now remains selected if an alarm 
   is not in the window.
 * Projects can now be opened by double-clicking the icon in Windows 
   Explorer if the "Reload last project at startup" checkbox is 
   selected in the Configurator Options dialog box (File->Configurator 
   Options).
 * Configurator no longer quits unexpectedly when alarm points are 
   being configured.
 * Configurator no longer behaves strangely when trying to set up
   controllers and strategies.

======================================================================

What's New in Version R3.0a?
July 14, 1999

New Features:
-------------
* 50 levels of Undo in Configurator.

* Symbol Factory: A library of 3,000 graphics designed for industrial 
  automation.

* SuperTrends: Remote Logging - collect and/or save SuperTrend data on
  a remote computer.

* Alarms: Alarm Points may be conditionally enabled based on
  controller tag value.



* Alarms: Alarm Point level values may be set by controller tag 
  values.

* Alarms: Option to adjust enabling/level values/priorities in 
  Runtime.

* Support for Windows Metafiles (.wmf) and Enhanced Metafiles (.emf).

* Launch Runtime from Configurator with current project.

* STRNDCVT: A utility for converting binary SuperTrend data to ASCII
  text for viewing.  Includes source code.

Enhancements:
-------------
* SuperTrends: Data may be stored in ASCII or binary format.

* SuperTrends: Y-axis grid may be displayed in active pen color.

* Alarms: Option to reload history alarm window data at startup.

* Alarms: Alarm columns may be dynamically sorted and moved in Runtime.

* Alarms: The Configure Alarm Points dialog now displays a reference
  count for each alarm point, indicating how many alarm windows the
  point appears in.

* Historic Data Logs: Allows user-selected name for tag.

* Improved drawing and sizing functions.

* Customizable date format for data log files, alarms, and SuperTrends.

* Option to clear Forth words from controller at Runtime startup added.

* Option to reload last Configurator project at startup added.

* Many dialogs now remember their size and position.

Bug Fixes:
----------
* Alarms: If a window contains alarms, the "Always in memory" checkbox
  is checked, and may not be unchecked.

* Menu hotkeys are now unique.

* Menu options are now context sensitive.

* Available disk is space now checked before saving a project to a
  different location.

* Current window now remains on top after executing Window->Properties
  from main menu.

* If files are missing from a project, a list of missing files is
  presented, and the project will not load.



* When bitmaps are removed from windows, they are now also removed
  from the project file.

======================================================================

What's New in Version R2.2b?
October 1, 1998

Bug Fixes:
----------
* SuperTrends: A memory leak caused when opening and closing a window 
  containing a SuperTrend has been fixed.

* SuperTrends: Problems with graphic labels interfering with a 
  SuperTrend have been fixed.

* Printing: A memory leak when printing has been fixed.

======================================================================

What's New in Version R2.2a?
June 15, 1998

New Features:
-------------
* SuperTrend: A combined real-time and historical trend.

Enhancements:
-------------

* Integer-bit scanning: The scanning of integer bits has been 
  substantially improved.

* Scanner Overruns: The "Scanner Overrun Error" message has been
  changed to "Scanner Overrun Notification".

Bug Fixes:
----------
* Alarms: AutoCorrect Tags now works with Alarms.

* Alarms: Alarm comments can now be longer than 50 characters.

* Alarms: Problems with choosing the log file's location have been 
          fixed.

* Copy Window: Canceling a Copy Window command no longer causes a 
               crash.

======================================================================

What's New in Version R2.1a?
October 2, 1997

New Features:
-------------
* Tag Search & Replace: A new tool to facilitate changing tags in



                        graphics.

* Controller verify:  When pasting graphics (from another project or
  symbol file), the controller in each tag is now verified to exist in
  the new project.

* Color Palette: Colors in the palette dialog can now be customized.

* TrueType Fonts: Text can now use any installed TrueType font

Enhancements:
-------------
* Alarm Logging: Alarm log files now have an extension of ".ALM"

* Recipes: Recipes can now use long filenames.

======================================================================

What's New in Version R2.0f?
September 25, 1997

Enhancements:
-------------
* Time Changes: The Runtime now supports changes to the clock.
  If the time changes while the Runtime is running, there will be no
  interruption in scanning.

  Note: When the time is changed, all data in all trends will be reset.
  Also, if the time is set back, historic and event logs will continue
  to use the current log file and will roll-over at the next
  configured time.  This will preserve the order in which data was
  received, but can result in data appearing to be in the wrong log
  file.

======================================================================

What's New in Version R2.0e?
August 21, 1997

Bug Fixes:
----------
* Alarming Sounds: The "Play sound once when new alarm" option in the
  Alarming Setup dialog would cause the Runtime to shut down improper-
  ly.  This would prevent any Opto 22 software from loading and could
  only be fixed by rebooting the computer.

* Historic Logs: OptoDisplay R2.0b introduced a bug that would cause
  quoted strings to be invalid.

======================================================================

What's New in Version R2.0c?
June 20, 1997

* Hot Keys:  Graphics can now have an associated key.  This removes
  the requirement that a mouse be used in the Runtime.  There is an



  addendum in the Configurator's help file that explains this new
  feature.

======================================================================

What's New in Version R2.0b?
June 9, 1997

* Alarming:  OptoDisplay now has alarming functionality.  There is an
  addendum in the Configurator's help file that explains the new
  features.

======================================================================

What's New in Version B1.2a?
March 7, 1997

* Networking: Instead of using NetBios communications to OptoMds, This
  version of OptoDisplay uses RPC communications to OptoCds. The
  advantage of RPC over NetBios is better reliability, easier network
  setup and better throughput. If using OptoDisplay-to-OptoCds network
  support, you'll need to install OptoServer. Use of RPC instead of
  NetBios solves problems such as:
  * determining correct 'LANA' numbers
  * inability to work while other network protocols are used.

* Leaks: This version fixes some memory leaks.

* Backup controllers: now a backup controller can be specified and it
  doesn't matter if the controllers are local or server-based control-
  lers.

* New compiler: This version is compiled with the newer Borland 5.01
  compiler instead of 4.52. Newer Borland DLLs are required.
  These DLLs are cw3220.dll, mbds50f.dll & mowl50f.dll.

======================================================================

What's New in Version R1.1?

Contents:
=========

What's New in Win32
New Features, Enhancements and Bug Fixes
Windows NT Installation Notes
Troubleshooting Communication Problems
Uninstallation of this Product
How to Get Help

======================================================================

What's New in Win32:
--------------------
If you are a user of the Mistic MMI and you are going to be converting
a project created with that product, the only requirement is that the
controllers be registered before running the OptoDisplay Runtime.



Refer to the "Controller Configuration" section of your user's manual
for detailed information about how to make the appropriate changes.

OptoDisplay does not require that the project file reside in a
directory with the same name as the project file itself.  To open
a project, select  File->Open Project and choose the .MMI file
from the Open Project dialog.  When saving the project, a new
directory is NOT created.  The project file is written into the
directory selected in the Save As dialog (File->Save Project As
command) or in the New Project dialog (File->New Project command).

OptoDisplay will continue to function with .GML/Cyrano type strategies.
The controllers must have the Mistic Kernel firmware (i.e., the DOS/
Win16 based kernel).  If you converted your strategy to a .CDB/
OptoControl strategy, you must update your OptoDisplay project to use
the new strategy.  Additionally, the controller must have the
OptoKernel firmware (i.e., the Win32 based kernel).  To change to the
converted strategy, use the "Configure->Controllers" dialog in the
OptoDisplay Configurator.  This dialog lists all the controllers
configured for the open project.  For each of the controllers that
had their strategies converted, select the controller and press the
Modify button.  The resulting dialog is the Controller Properties
dialog.  Use the Strategy->Browse button to locate the converted
strategy.  You will get a warning message indicating potential
problems which result from selecting the wrong strategy.  Once
all the controllers have been updated, use the Tool->AutoCorrect
Tags command to synchronise OptoDisplay and OptoControl tags.
See below for a description of this new feature.

The "Tools" menu option was changed to "Tool".  The drawing tools were
removed from this menu.  They are only accessible via the Toolbox.
Under the "Tool" menu there is a feature that can be used to
AutoCorrect Tags in the project.  It will synchronize OptoDisplay tags 
with those from the strategy.  There are a few cases in which the 
OptoDisplay tags cannot be corrected.  These include tags that have 
been deleted from the strategy and tags that index tables out of 
bounds.  In these cases, the user is given an appropriate message.  
The user must manually correct these tags.

Sound files can reside in any directory.  They can optionally reside 
in the project directory.

======================================================================

New Features, Enhancements and Bug Fixes:
-----------------------------------------

Since Version R1.0f:

New Features:
-------------
none

Enhancements:
-------------
The memory management for the trends was improved significantly.  This 
was critical for trends with a fast sample rate, and a long time span.



Bug Fixes:
----------
The list of PopWindows was getting reversed everytime a project was 
saved or when the PopWindow dialog was opened.

Fixed Send Discrete dialog to allow the enabling of an I/O Unit.

Can now use A:\ as the destination directory for a recipe upload

Could not handle closing the window that was in the middle of 
processing a graphic dynamic attribute (e.g., prompting for 
a recipe file).

When changing the tag for a graphic's dynamic attributes, the tag
selection dialog would reset the refresh group to zero.

Fixed initial open window process in runtime so that closed windows
don't show themselves.

Made choosing graphics easier allowing for 2 pixel miss.

Now put up a message if a draw windows doesn't exist.

======================================================================

Windows NT Installation Notes:
-----------------------------

Windows NT users must have write access to the registry and the 
Windows\System directory to successfully install and use this product.

Windows NT users must reboot after installation and after each 
configuration/modification of communication ports.  

======================================================================

Troubleshooting Communication Problems:
--------------------------------------

If you are a Windows NT user and are experiencing communication
problems which are indicated by the following errors, first try re-
booting your machine to ensure that all port configurations have been
correctly registered with the operating system.

"Invalid port error.  WinRT drivers might not have started."
"Invalid protocol error."
"Port setup invalid."
"Could not find other nodes in ARCNET."

======================================================================

Uninstalling this Software:
---------------------------
A utility is provided to uninstall this software.  The utility will 
remove all registry entries and files previously installed.  
Exceptions are:



- Previously configured controllers are not removed from the registry.
- The installation directory tree is not removed if any user-created
  files exist in it.
- The Win95 program folder or Windows NT program group is not removed 
  if any icons have been added by the user.

======================================================================

How to Get Help
---------------
If you have any questions about this product, contact Opto 22 Product 
Support Monday through Friday, 8 a.m. to 5 p.m., Pacific Time.

E-mail: support@opto22.com

Phone:  800/TEK-OPTO (835-6786)
        909/695-3080

Fax:    909/695-3017

Bulletin Board (BBS): 
  http://bbs.opto22.com
  909/695-1367
        (24 hours a day, 7 days a week)

When accessing the BBS, use the following modem settings:
  - No parity, 8 data bits, 1 stop bit
  - Baud rates up to 28,800
  - Z-modem protocol for uploads and downloads

Please provide the following information about your system to the 
Product Support engineer:

  - Version of this product
  - PC configuration (type of processor, speed, memory, 
    operating system)
  - A complete description of your hardware system, including:
    - jumper configuration
    - accessories installed (such as daughter cards)
    - type of power supply
    - types of I/O units installed
    - third-party devices installed (e.g., barcode readers)
  - Controller firmware version
  - Any specific error messages seen


