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Chapter 1
Chapter 1

1: Welcome

Welcome to the SNAP IO4AB Learning Center User’s Guide. Inside you’ll find instructions on how set 
up your Learning Center as well as hands-on lessons for you to experience configuring and using 
implicit messaging via EtherNet/IP™ between an Allen-Bradley® Logix controller and Opto 22’s 
intelligent remote SNAP PAC I/O™.

This guide assumes that you are already familiar with how to use Allen-Bradley’s RSLogix 5000 
software to configure Allen-Bradley devices.

Using this Guide
Chapter 1: Welcome (this chapter)—Provides information about this guide, where to find additional 
information, and how to reach Opto 22 Product Support.

Chapter 2: Setting Up the SNAP IO4AB Learning Center—Details what’s included in the Learning 
Center, how to assemble it, and how to install the EtherNet/IP Configurator software.

Chapter 3: Lessons Using Implicit Messaging—Provides hands-on lessons for you to experience 
setting up implicit messaging between the Learning Center’s I/O unit and your own Allen-Bradley 
controller.
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Documents and Online Help
For more information on the hardware included in the SNAP IO4AB Learning Center and the 
EtherNet/IP protocol, see the following Opto 22 documentation.

All documents are available on our website, www.opto22.com. The easiest way to find a document 
is to search on its form number.

Additional resources are also available on the Opto 22 Web site such as a demonstration video that 
shows how easy it is to configure and program an Allen-Bradley controller to talk to SNAP I/O. If you 
are viewing this document online and have an internet connection, click the image.

Additional Resources for EtherNet/IP

For an overview of CIP and EtherNet/IP technology, see 
http://www.odva.org/Portals/0/Library/Publications_Numbered/PUB00138R2_CIP_Adv_Tech_Se
ries_EtherNetIP.pdf

For information on the network infrastructure for EtherNet/IP, see
http://www.odva.org/Portals/0/Library/Publications_Numbered/PUB00035R0_Infrastructure_Gui
de.pdf

For a good starting point for Ethernet/IP research on the ODVA web site, see 
http://www.odva.org/default.aspx?tabid=67

For this information See this guide Form

Installing and using SNAP PAC brains SNAP PAC Brain User’s Guide 1690

Wiring, specifications, and installation information 
for SNAP Analog Input Modules

SNAP Analog Input Modules Data Sheet 1065

Wiring, specifications, and installation information 
for SNAP Analog Output Modules

SNAP Analog Output Modules Data Sheet 1066

Wiring, specifications, and installation information 
for SNAP Digital Input Modules

SNAP Digital Input Modules Data Sheet 0773

Wiring, specifications, and installation information 
for SNAP Digital Output Modules

SNAP Digital Output Modules Data Sheet 1144

Setting up EtherNet/IP messaging between an 
Allen-Bradley® Logix™ controller and Opto 22’s 
SNAP I/O, using the EtherNet/IP commands that 
can be accessed when using remote Opto 22 I/O 
with an Allen-Bradley controller

EtherNet/IP for SNAP PAC Protocol Guide 1770

http://www.opto22.com/video/players/osc_player.aspx?bcpid=1416062134&autoStart=true&continuousPlay=true&bctid=9248245001
http://www.opto22.com/video/players/osc_player.aspx?bcpid=1416062134&autoStart=true&continuousPlay=true&bctid=9248245001
http://www.opto22.com/site/documents/drilldown.aspx?aid=3166
http://www.opto22.com/
http://www.odva.org/Portals/0/Library/Publications_Numbered/PUB00138R2_CIP_Adv_Tech_Series_EtherNetIP.pdf
http://www.odva.org/Portals/0/Library/Publications_Numbered/PUB00035R0_Infrastructure_Guide.pdf
http://www.odva.org/default.aspx?tabid=67
http://www.opto22.com/site/documents/drilldown.aspx?aid=3166
http://www.opto22.com/site/documents/drilldown.aspx?aid=1708
http://www.opto22.com/site/documents/drilldown.aspx?aid=1708
http://www.opto22.com/site/documents/drilldown.aspx?aid=1709
http://www.opto22.com/site/documents/drilldown.aspx?aid=1709
http://www.opto22.com/site/documents/drilldown.aspx?aid=1664
http://www.opto22.com/site/documents/drilldown.aspx?aid=1664
http://www.opto22.com/site/documents/drilldown.aspx?aid=1742
http://www.opto22.com/site/documents/drilldown.aspx?aid=1742
http://www.opto22.com/site/documents/drilldown.aspx?aid=3672&title=EtherNet%2FIP+for+SNAP+PAC+Protocol+Guide
http://www.opto22.com/site/documents/drilldown.aspx?aid=3672&title=EtherNet%2FIP+for+SNAP+PAC+Protocol+Guide
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Product Support
If you have any questions about using EtherNet/IP to communicate with Opto 22 devices, you can 
call, fax, or email Opto 22 Product Support. Product support is free.

Phone: 800-TEK-OPTO (835-6786)
951-695-3080
(Hours are Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

When calling for technical support, be prepared to provide the following information about your 
system to the Product Support engineer:

• PC configuration (type of processor, speed, memory, and operating system)

• RSLogix 5000 version

• Allen-Bradley PLC model

• Specific error messages seen.

NOTE: Email messages and 
phone calls to Opto 22 
Product Support are 
grouped together and 
answered in the order 
received. 
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Chapter 2
Chapter 2

2: Setting Up the SNAP IO4AB 
Learning Center

This chapter describes what’s included in the SNAP IO4AB Learning Center, how to assemble it, and 
how to install the EtherNet/IP Configurator software.

It includes the following topics:

“What You Will Need” on page 5 (below)

“What’s Included” on page 6

“Installing the SNAP-PAC-RCK8 Rack” on page 7

“Installing EtherNet/IP Configurator” on page 17

What You Will Need
• A computer with at least the minimum processor required for your version of Microsoft 

Windows (1 GHz Pentium®-class or better recommended) and Ethernet capability

• VGA or higher resolution monitor

• Mouse or other pointing device

• Microsoft Windows Vista® Business (32-bit), Windows XP (with Service Pack 2) or Windows 
2000® (with Service Pack 4) workstation operating system. Microsoft Windows server and 
64-bit versions of Windows workstation operating systems are not supported.

• At least 1 GB RAM for Windows Vista, or at least 512 MB for Windows XP or Windows 2000

• RSLogix 5000, version V13 or later installed on your computer

• Three CAT-5 Ethernet cables

• Allen-Bradley controller that supports EtherNet/IP with an Ethernet port or an Ethernet adapter 
module connected to the network. The Allen-Bradley controller must support implicit 
messaging, also called I/O messaging. See “A: Supported Allen-Bradley Platforms” on page 85.

• IGMP enabled, managed industrial Ethernet switch. EtherNet/IP implicit messages are 
multicast, and a managed switch configured for IGMP Snooping filters these messages 
appropriately.
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NOTE: If you use the Learning Center only as a learning tool (that is, not in an actual installation or as 
part of any other network), any switch (managed or unmanaged) will suffice.

What’s Included
The SNAP IO4AB Learning Center includes the following items:

Component Description Graphic

SNAP-PAC-EB1 I/O and communications processor for your Allen-Bradley Logix systems

SNAP-PAC-RCK8 Rack Mounts up to eight SNAP digital, analog, and serial modules

SNAP I/O Modules (5)

Includes the following five modules:
• SNAP-IDC5D: Digital DC Input 2.5–28 VDC, 5 VDC Logic
• SNAP-ODC5SRC: Digital DC Output 5–60 VDC Source, 5 VDC Logic
• SNAP-AOV27: Analog Output Dual -10 to +10 VDC
• SNAP-AICTD: Analog Input Dual ICTD Temperature
• SNAP-AIV: Analog Input Dual ±10 or ±5 VDC

Learning Center Load Panel

The load panel consists of:
• Two toggle switches
• Two momentary switches
• One buzzer
• Three LEDs
• One meter
• One potentiometer
• Temperature sensor connection

Temperature probe 
The ICTD temperature probe on your Learning Center is actually a PID (Pro-
portional Integral Derivative) Simulator, which has—in addition to the ICTD—a 
resistor that heats up the probe to simulate a real world process.

Power cable

Input voltage range for the Learning Center is 120–300 VAC. A power cable is 
included based on your location (U.S., international, or UK). If you find that the 
cable you have is incorrect, please call Opto 22 at 800-321-6786 (toll-free in the 
U.S.) or 951-695-3000 to request the correct one. For more Product Support 
contact information, see “Product Support” on page 3.

SNAP rack extrusion For mounting the SNAP rack

DIN-rail clips (2) For mounting the rack assembly to the DIN-rail

SNAP module tool For removing a SNAP module
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Installing the SNAP-PAC-RCK8 Rack

Install the DIN-Rail Clips

1. Align the DIN-rail clips, extrusion, and the mounting screws as shown in the following diagram, 
and then install the screws.

Phillips and flat blade 
screwdrivers

For assembling the SNAP IO4AB Learning Center

Software installation CD Contains EtherNet/IP Configurator software

Component Description Graphic

DIN-rail clip

Ridge on outside 
of extrusion
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Install the SNAP Rack Extrusion and the DIN-rail Clip Assembly

1. Align the extrusion so that the taller lip is closest to the Learning Center load panel and the 
lower edge is towards the back, as shown in the next illustration.

2. Hang the fixed end of each DIN-rail clip over the top edge of the DIN rail.

3. Position the extrusion and clip assembly flat against the DIN rail.

4. Apply pressure to the bottom of the extrusion and clip assembly to snap it into position on the 
Learning Center’s DIN rail.

Install the SNAP Rack in the Rack Extrusion

1. Orient the circuit board so that the module connectors are at the bottom and the circuit board 
release notches on the circuit board are at the top.

2. Align the bottom edge of the circuit board with the top groove in the extrusion above the 
DIN-rail clip release holes as shown in the illustration below.

Slide extrusion forward 
while pushing down on 
the front.

Hook the backs of the 
DIN-rail clips (the 
spring-loaded hook) 
onto the DIN rail.

2

1
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3. Press the top of the circuit board against the extrusion and snap the board into the groove on 
the top side of the extrusion. (It’s okay to push hard.)

A correctly inserted rack appears as shown here:

Connecting the Power Supply

1. Locate the wire harness behind the load panel of the Learning Center.

2. Locate the red, black, and green wires that have bare leads at one end.

3. Connect the red wire to the +5V connection on the SNAP-PAC-RCK8 rack, and tighten its power 
connector screw. See the diagram below.

4. Connect the black wire to the -5V connection and tighten its screw.

Push this end down to insert 
the rack into the extrusion.

Insert the front of the 
rack into a groove on 
the extrusion.

NOTE: The load panel is 
not shown.

Module connectors

1

2

NOTE: The load panel is 
not shown.
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5. Connect the green wire to the ground connector and tighten its screw.

Installing the SNAP PAC Brain

1. Remove the SNAP PAC brain from its packaging.

2. Align the brain’s connector with the mating connector on the SNAP rack as shown in the 
following illustration.

3. Seat the brain onto the connector.

4. Tighten the hold-down screw to secure the brain in position.

Power connector 
screws

Red wire

Black wire

Green wire
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CAUTION: Do not overtighten the hold-down screw. Doing so may damage the connector, the brain, or 
other components on the SNAP rack.

Installing the SNAP I/O Modules

1. Remove the five SNAP I/O modules from their packaging. 

2. Remove the screw terminal connectors from the tops of the modules and set them aside.

You will not use the terminal connectors that came with the modules, as the Learning Center 
has already been wired for you.

3. Install the modules on the SNAP rack in the order shown in the table below.

Module positions are labeled on the SNAP rack. Also, the module positions are in numerical 
order from left to right as you face the load panel. 

To install each SNAP I/O module on the SNAP rack, follow these steps:

SNAP Module Position on SNAP Rack

SNAP-IDC5D 0

SNAP-ODC5SRC 1

SNAP-AOV-27 2

SNAP-AICTD 3

SNAP-AIV 4



INSTALLING THE SNAP-PAC-RCK8 RACK

SNAP IO4AB Learning Center User’s Guide12

a. Position the module over the connector, aligning the small slot at the base of the module 
with the retention bar on the rack.

b. With the module correctly aligned over the connector, push straight down on the module 
to snap it into position.

When positioning modules next to each other, be sure to align the male and female 
module keys (shown in the detailed view in the illustration below) before snapping a 
module into position.

Module keys correctly 
aligned

Retention bar
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Your Learning Center should now resemble the illustration below. If a module is positioned 
incorrectly, remove it (see “Removing a SNAP I/O Module” on page 13), and then reinstall it.

Removing a SNAP I/O Module

If you insert a module in the wrong location, you can remove it as follows: 

1. Use the SNAP module tool shown in the next illustration to retract and hold the release latch at 
the base of the module.

Note that the release latch is located on the end of the module facing the back of the Learning 
Center.

SNAP-AIV

SNAP-AICTD
SNAP-AOV-27

SNAP-ODC5SRC

SNAP-IDC5D

SNAP-PAC-EB1
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2. While holding open the release latch with the SNAP module tool, pull straight up on the 
module to remove it.

Connecting the SNAP Modules to the Wiring Harness

Snap the screw terminal connectors on the Learning Center’s wiring harness into the SNAP modules 
as follows:

1. Plug the first connector to branch off from the wiring harness (after the power wires) into the 
first module, the SNAP-IDC5D.

The SNAP module tool provides leverage to push out the 
spring-loaded module release latch, which releases the module 
from the retention bar.
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2. Plug subsequent connectors that branch off the wiring harness into the remaining modules. 
Note that the connectors are on different lengths of wire to help indicate which connector goes 
with each module. (The shortest wire corresponds to slot 0.)

3. Carefully double-check your connections by comparing them with the following list of SNAP 
modules and the corresponding wire.

Connecting the Temperature Sensor

The temperature sensor is the cable approximately 3 feet (1 meter) in length with a black plastic tip 
at one end.

1. Plug the temperature sensor into the jack on the front left-hand side of the Learning Center 
load panel.

NOTE: The four small prongs in the plug must align with the holes in the jack.

2. Tighten the threaded collar.

SNAP Module Wire Colors for Corresponding Connector on Wiring Harness

SNAP-IDC5D red, brown/white, red/white, orange/white, yellow/white

SNAP-ODC5SRC red, red, green/white, blue/white, purple/white, gray/white

SNAP-AOV-27 orange, yellow, green, blue

SNAP-AICTD gray, purple

SNAP-AIV white, black
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Connecting the Power Cable

To connect the power cable to the SNAP IO4AB Learning Center, plug the cable into the power cord 
connector located on the right side of the Learning Center base.

NOTE: Don’t turn on the Learning Center until instructed to do so in the next chapter.

Connecting the Remote SNAP I/O
Connect the assembled Learning Center, an Allen-Bradley Logix PLC, and a personal computer, to an 
Ethernet network (see note) as illustrated below.

Plug one end of a CAT-5 Ethernet cable into the managed switch and the other end into the 
Ethernet 1 network connector on the EB1 brain.

NOTE: The Ethernet 2 network connector will not work in this application.

The IP addresses of the SNAP-IO4ABLC, Allen-Bradley Logix PLC, and computer should be on the 
same subnet. You will set up the IP address on the SNAP-IO4ABLC in “Lesson 1: Establishing 
Communications” on page 20.

Ethernet 1 
network 
connector

PC

IO4AB Learning 
Center

IGMP enabled, 
managed industrial 
Ethernet switch

Allen-Bradley 
Logix Controller

Ethernet
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This setup requires some networking expertise. We recommend that first you consult with your 
network administrator.

Installing EtherNet/IP Configurator
On the PC, insert the CD that came with the Learning Center in your CD-ROM drive. The installation 
wizard should start automatically. If it doesn’t, use Windows Explorer to navigate to your CD-ROM 
drive and then double-click setup.exe. Follow directions to install the software.

If you have trouble installing the software, contact Opto 22 Product Support. See “Product Support” 
on page 3.

Resetting the Brain
If the Learning Center has been used previously, you may want to reset the brain.

1. Carefully insert a straightened paperclip or stiff wire into the small hole labeled RESET.

2. Press and hold down the RESET button as described below.

CAUTION: Do not hold down the RESET button too long. If you hold it down longer than five seconds, the 
brain will enter hardware test mode, which is indicated by the STAT LED blinking orange, rapidly and 
continuously. Hardware test mode erases all files in RAM and flash memory and resets the IP address. If 
your brain restarts in hardware test mode, cycle power; the result will be the same as restoring factory 
default settings (see table above).

If you hold down the RESET button less than five seconds but longer than the time needed to restore the 
default settings, the brain will restart in failsafe bootloader mode, which is indicated by the STAT LED 

To perform this kind of reset... ...do this Result

Simple restart Press and hold the RESET button 
for less than 1 sec. until the STAT 
LED turns off, and then immedi-
ately release the button.

OR

Turn off power to the brain and 
then turn it on again.

OR

Use PAC Manager to send the 
brain the “Restart from Powerup” 
command.

• The brain restarts.
• Any files in RAM are erased. If files 

have been stored to flash memory, 
they will not be erased.

Restore factory default 
settings

Press and hold the RESET button 
for 1 or 2 seconds until the STAT 
LED turns solid green, and then 
immediately release the button.
Don’t hold it down too long.

• The brain restarts.
• Files in RAM and flash memory 

are erased.
• IP address is reset to 0.0.0.0 and 

subnet mask to 255.255.255.0.
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blinking green 7 times quickly. This is a diagnostic mode that you don’t need to access unless you are 
troubleshooting a problem with Opto 22 Product Support. If your brain restarts in failsafe bootloader 
mode, cycle power; the result will be same as the simple restart described above.
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3: 3: Lessons Using Implicit MessagingChapter 3

3: Lessons Using Implicit 
Messaging

Introduction
The hands-on lessons in this chapter allow you to experience setting up implicit messaging 
between the Learning Center’s I/O unit and your own Allen-Bradley controller.

Also known as I/O messages, implicit messages don’t contain requests or responses. They simply 
contain real-time I/O data. Both the Allen-Bradley PLC and the Learning Center must be configured 
to agree on the content and format of the I/O data prior to establishing an implicit connection. (For 
more in implicit messaging, see form 1770, the EtherNet/IP for SNAP PAC Protocol Guide.)

In the following lessons you will use EtherNet/IP Configurator to specify the I/O data format on the 
EB1 brain by configuring assembly object data attributes. Using Allen-Bradley’s RSLogix 5000 
software, you will configure the Allen-Bradley controller to create a connection to the appropriate 
assembly instance on the SNAP PAC device and experience some of the advantages of distributed 
intelligence.

Contents

• “Lesson 1: Establishing Communications” on page 20—using EtherNet/IP Configurator to set 
up communications between the intelligent remote I/O and RSLogix 5000 and download a 
configuration

• “Lesson 2: Using Intelligent Discrete I/O Functions” on page 43—using the intelligence of the 
remote SNAP I/O for counting, pulsing for a direct output, and for setting up a communication 
watchdog

• “Lesson 3: Using Intelligent Analog I/O Functions” on page 59—using the SNAP-AOV-27 
output module and the SNAP-AIV input module to read scaled analog inputs and write a clamp 
value to an analog output

• “Lesson 4: Using Distributed PID Loop Control” on page 74—configuring and running a 
distributed PID loop in the Opto 22 intelligent remote I/O

• “What’s Next?” on page 84—where to find information to set up your own system
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What You Will Need

• SNAP IO4AB Learning Center, fully assembled. See “2: Setting Up the SNAP IO4AB Learning 
Center” on page 5.

• EtherNet/IP Configurator installed on your computer (see page 17)

• RSLogix 5000, version V13 or later installed on your computer

• A network consisting of the Learning Center, your computer, and an Allen-Bradley controller 
that supports EtherNet/IP with an Ethernet port or an Ethernet adapter module. The 
Allen-Bradley controller must support implicit messaging, also called I/O messaging. See “A: 
Supported Allen-Bradley Platforms” on page 85. See also the network diagram on page 16.

• R8.3a or newer firmware

Lesson 1: Establishing Communications
In this lesson you will use EtherNet/IP Configurator to configure the intelligent remote I/O (page 20) 
and RSLogix 5000 to set up communications with the PLC and run the program (page 33).

At the end of this lesson you will be able to toggle the Limit Switch on the Learning Center and see 
the corresponding bit in RSLogix 5000 change state. This demonstrates data being exchanged 
between the SNAP IO4AB Learning Center and the Allen-Bradley controller.

Configuring the Intelligent Remote I/O Unit

Configuring the intelligent remote I/O unit includes the following activities:

“Adding the SNAP-PAC-EB1”  (below)

“Adding the Modules” on page 23

“Configuring the Points” on page 25

“Creating Assembly Instances” on page 27

“Saving and Downloading the Configuration” on page 32

Adding the SNAP-PAC-EB1

To add the SNAP-PAC-EB1 to the configuration (and also the network), you will allow EtherNet/IP 
Configurator to discover the device. Then you will give the discovered device a name, a valid IP 
address, and a subnet mask.

1. Open EtherNet/IP Configurator by selecting 
Start→All Programs→Opto 22→EtherNet-IP→EtherNet-IP Configurator

2. With the SNAP-PAC-EB1 connected to the network, turn on the Learning Center. The power 
switch is next to the power cord connection.
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When installed and first turned on, the SNAP-PAC-EB1 sends out a BootP broadcast, requesting 
an IP address. EtherNet/IP Configurator discovers each Opto 22 device on your network that is 
broadcasting a BootP request and lists the devices in the device tree.

The discovered device is identified by a unique hardware Media Access Control (MAC) address, 
which is displayed in the device list.

The MAC address is also written on a label attached to the side of the EB1’s housing. (An 
Opto 22 device’s MAC address begins with 00.a0.3d.) If no units are listed under Discovered 
Devices, turn off your Learning Center and then turn it on again.

NOTE: If the EB1 is not new, you can reset the device using the reset button to start the BootP request. 
For more information on resetting the SNAP-PAC-EB1, see “Resetting the Brain” on page 17.

3. When the MAC address of the discovered device appears under Discovered Devices, 
double-click the MAC address.

CAUTION: EtherNet/IP Configurator lists ALL Opto 22 devices sending BootP or DHCP broadcasts. 
Assign IP addresses only to the ones you know are yours!

The Assign IP Address dialog box appears.

MAC addresses of 
discovered devices
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4. Enter the IP Address and the Subnet Mask for the EB1. Leave the Gateway Address and the DNS 
address all zeros (0.0.0.0).

NOTE: Make sure the EB1 is on the same subnet as the computer and the PLC.

WARNING! Each device on your network, including computers, routers, controllers, brains, and so 
on, must have a unique IP address. Failure to assign unique IP addresses may cause catastrophic 
network or hardware failures. If you don’t know which IP addresses are safe to use, check with your 
system administrator.

5. When the IP Address and Subnet Mask fields are correct, click OK. 

The Name This Device dialog box appears with the Device Type, IP Address and Port filled in 
automatically.

6. Fill in the rest of the dialog box as follows:

– Device Name: SNAP_IRIO

– Temperature: Fahrenheit

– Watchdog: No

7. Click OK.
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The EB1 appears in the device tree.

Adding the Modules

In this activity you will use EtherNet/IP Configurator to add and configure three of the five SNAP I/O 
modules you already installed in the Learning Center. You must do this in order to configure the 
modules’ points in the next activity.

1. In the Configure I/O Modules & Points tab, double-click module 00.

Position Type Module

00 Digital Input SNAP-IDC5D

01 Digital Output SNAP-ODC5SRC

03 Analog Input SNAP-AICTD

New device
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2. In the Add Module dialog box, under Type, select Digital Input, and under Module, select 
SNAP-IDC5D.

3. Click OK.

4. In the same manner, add a SNAP-ODC5SRC digital output module at position 01.

Digital Input

SNAP-IDC5D

Digital Output

SNAP-ODC5SRC
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5. Finally, add a SNAP-AICTD analog input module in position 03 (not 02).

When finished, the module configuration will look like this:

Notice that the module icons are color-coded by type: white for digital input, red for digital 
output, blue for analog input.

In the next activity you will add points to the modules.

Configuring the Points

In order to tell the PLC which points to connect to, you will configure the points on the EB1 brain as 
shown in the following table:

Position Module Point Name

00 SNAP-IDC5D 2 Limit Switch

01 SNAP-ODC5SRC 1 Solenoid

03 SNAP-AICTD 0 Process Temperature
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1. On the Configure I/O Modules & Points tab in EtherNet/IP Configurator, expand module 00.

2. Double-click point 2 to open the Add Digital Point dialog box.

3. Name the point Limit_Switch, and then click OK.

4. Expand module 01, and then double-click point 1. 

5. Name the point Solenoid, and then click OK.

6. Finally, expand module 3, double-click point 0, and add a new point called 
Process_Temperature.

Expand module 00
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When you have finished adding the points for this lesson, the configured modules and points should 
look like this:

Creating Assembly Instances

In this section you will create the input assembly instance (page 27) and output assembly instance 
(page 30). 

Creating the Input Assembly Instance 

The input assembly instance allows the Allen-Bradley controller to read data from the intelligent 
remote I/O unit. You will create input instance 100 that has the following members:

1. In EtherNet/IP Configurator, click the Configure Assemblies tab, and then click assembly 
instance 100.

# DINT Bit Size Class Instance Attribute

0 0 0 1 Discrete Input Point Limit_Switch Mod:00 Pt:02 Value

1 0 1 31 Pad

2 1 0 32 Analog Input Point Process_Temperature Mod:03 Pt:00 rValue

Limit_Switch

Solenoid

Process_Temperature

Configure Assemblies tab
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2. Click Add to open the Add Assembly Member dialog box.

3. Under Class, select Discrete Input Point.

4. Select Point Name, and then click the down arrow and select Limit Switch.

5. Under Attribute, select Value.

6. Click OK.

The assembly instance needs to have 32-bit words defined. Each of these 32-bit words is called 
a DINT (Double precision Integer Type).

So far you have defined only one of the 32 bits. So now you will pad the word with an 
additional 31 bits.

7. Click the Add button to open the Add Assembly Member dialog box. 
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8. Select Pad, set the Size in Bits field to a size of 31, and then click OK.

Now the total number of bits is 32.

9. Add another assembly member with the following characteristics:

– Class: Analog Input Point

– Point Name: Process Temperature

– Attribute: rValue

NOTE: An rValue is a floating point number that is used to display scaled engineering units. A 
Value on the other hand is an integer used for displaying raw counts.
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10. Click OK.

The Fill Module dialog box allows you to configure the other points the other points on the 
module the same way. But in this case you don’t want to do that.

11. Select No, and then click OK.

An rValue is 32 bits, so there is no need for a pad.

This completes assembly instance 100. You have created an input assembly instance that has 
two 32-bit DINTs as follows:

Next you will create another assembly instance to send data to a discrete output module.

Creating the Output Assembly Instance 

The output assembly allows the Allen-Bradley controller to write data to the intelligent remote 
I/O unit. You will create output instance 101 that has the following members:

1. Select assembly instance 101.

2. Add an assembly member with the following characteristics:

– Class: Discrete Input Point

– Point Name: Solenoid

– Attribute: Value

# DINT Bit Size Class Instance Attribute

0 0 0 1 Discrete Output Point Solenoid Mod:01 Pt:01 Value

1 0 1 31 Pad
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3. Click OK, and then add a 31-bit pad, just as you did in step 7 on page 28.

In addition to input assembly 100, you have now completed output assembly 101.

Input Assembly 100:

Output Assembly 101:
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4. To check the configuration, click the Verify tab.

The information on this tab indicates any errors and whether or not the assembly is configured 
properly for download. It is helpful to check for errors in this report before you download the 
configuration to the device. For a complete report, select Tools→Assembly Configuration 
Report.

Now that you have configured the modules, points, and assembly instances for the intelligent 
remote I/O unit, it is time to save and download the configuration to the Opto 22 brain.

Saving and Downloading the Configuration

Up until now, the configuration only exists on your PC. The configuration includes all of the module, 
point, and assembly instructions you have entered in EtherNet/IP Configurator up to this point. By 
saving the configuration, you will create a file on your PC that contains all of the configuration 
information. This will allow you to open the configuration at a later time and modify it as necessary 
either for use either with this brain or with another one. By downloading the configuration to the 
brain, you can then configure the PLC to access the points you configured on the brain.

1. To save the configuration, choose File→Save, browse to an appropriate directory, name the file 
SNAP_IRIO, and then click Save.

2. Click the Verify tab and then click the Download button. (Or you can choose Tools→Download 
Configuration to Opto 22 Device.)

Verify tab
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3. In the Download Configuration dialog box, select the brain’s IP address, and then click 
Download.

4. When the configuration has been downloaded successfully, click Close.

This completes the setup of the Opto 22 remote I/O for lesson 1.

Configuring RSLogix 5000 and Running the Program

Now you are ready to use RSLogix 5000 to set up communications, view the controller tags, and 
then enter some ladder logic to demonstrate turning on the Solenoid from the Limit Switch.

This section includes the following activities:

“Setting Up Communications in RSLogix 5000” on page 33

“Viewing the Controller Tags” on page 37

“Using Ladder Logic to Turn on an Output from an Input and Show Temperature in Engineering 
Units” on page 39

“Downloading and Running the Program” on page 42

Setting Up Communications in RSLogix 5000 

In this activity you will use RSLogix 5000 software to configure an Ethernet-enabled Allen-Bradley 
controller to be able to communicate with the intelligent remote I/O via a Ethernet module using 
the assembly instances you created using the EtherNet/IP Configurator.

1. Open RSLogix 5000.

2. Select File→New.

3. Enter or select the following information:

– Type: Your controller’s type

– Revision: RSLogix 5000 revision number

– Name: IO4AB
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4. Browse to the folder you want to use, and then click OK.

5. Make sure the Path is set correctly for your controller.

6. In the project tree display, expand I/O Configuration, Backplane, and 1769-L32E Ethernet Port 
LocalENB.

7. Right-click on Ethernet and select New Module.

This module will be used to add the Opto 22 intelligent remote I/O unit.

8. In the Select Module dialog box, expand Communications in the tree display.

Type

Revision

Name

Path

Expand
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9. Scroll down to select Generic Ethernet Module, and then click OK to open the New Module 
dialog box.

10. Enter or select the following information:

– Name: SNAP_IRIO

– Comm Format: Data - DINT

– IP Address: IP address of the EB1 brain

– Input Assembly Instance: 100; Size: 2 (There are two 32-bit DINTs in the input assembly 
instance you created.)

– Output Assembly Instance: 101; Size: 1 (There is only one 32-bit DINT in the output 
assembly.)

– Configuration: 1; Size: 0 (Configuration is not used. However, you must enter these values 
when not using this setting.)

NOTE: The Input Instance is an RSLogix 5000 READ assembly, and the Output Instance is an RSLogix 
5000 WRITE assembly. The Configuration values are not used, but they must be entered.
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The completed dialog box looks like this:

11. Click OK. 

The Module Properties dialog box opens.

12. Set the RPI (Requested Packet Interval) to 200.0 ms. 

The RPI is the scan time of the remote I/O unit.

13. Click OK.

The Opto 22 remote I/O has now been configured and added to the RSLogix 5000 software as a 
generic Ethernet module.

14. Select File→Save to save the configuration.

This completes the configuration of RSLogix 5000 for lesson 1. Next you will save, download, and 
run the program, and take a look at the data.
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Viewing the Controller Tags

In this activity you will view the controller tags and see how RSLogix 5000 responds to input from 
the intelligent remote I/O when you toggle a point using on the Learning Center.

1. Select Communications→Download to download the RSLogix 5000 program to the controller, 
and then click Download in the next dialog box that appears.

2. Select Communications→Run Mode.

3. In the next dialog box that appears, click Yes.

4. Under the controller name in the tree display, double-click Controller Tags, and then click the 
Show button.

5. In the Define Tag Filter dialog box, make sure that Module-Defined is selected.

6. Click OK.

7. In the Controller Tags window, expand SNAP_IRIO:I until you see the Opto 22 input tags.

8. On the Learning Center, move the Limit Switch to the on position (down) to toggle the input 
point.

Opto 22 tags

Limit Switch
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In RXLogix the value of the Opto 22 input tag changes from 0 to 1, which demonstrates that 
RSLogix 5000 is responding to input from the Opto I/O. 

9. Stop the controller by selecting Communications→Program Mode.

10. Select Communications→Go Offline.

11. Expand SNAP_IRIO:I.Data[0] so that the 32 bits are displayed.

12. For bit 0, enter Limit Switch in the Description field.

13. Collapse SNAP_IRIO:I.Data[0].

14. In the Description field for SNAP_IRIO:I.Data[1], enter Process Temperature Raw.

Input tag 
changes to 1

Description of bit 0

Bit description
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15. Expand SNAP_IRIO:O, and then in the Description field for SNAP_IRIO:OData[0].0, enter 
Solenoid.

Using Ladder Logic to Turn on an Output from an Input and Show 
Temperature in Engineering Units

Next you will create two lines of ladder logic, which will show the following things:

• How the ladder is set up in RSLogix 5000 to control the digital output point named Solenoid

• The temperature in Engineering Units (using a REAL tag). Values in Engineering Units are 
available in the intelligent remote I/O

1. In the tree display, expand Tasks until you see an icon for MainProgram, and then double-click 
MainRoutine to open the program.

2. Click the Bit tab, and then add a normally open contact by clicking the Examine On button.

NOTE: This is the XIC instruction.

Bit description

Examine On button Bit tab
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3. Double-click the contact, and then click the down arrow that appears.

4. Assign the normally open contact to the Limit Switch by selecting bit 0 of the 
SNAP_IRIO:I.Data[0] DINT. 

5. On the Bit tab again, click the Output Energize button to add an output coil.

6. Assign the output coil to the Solenoid by selecting bit 0 of the SNAP_IRIO:O.Data[0] DINT.

Double-click 
the contact

Bit 0

Normally open contact added
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So far you have set up the Limit Switch to trigger the Solenoid light on the Learning Center. 

Next you’re going to take advantage of the values in Engineering Units available for 
temperature in the remote intelligent I/O. Recall that the data was brought in as a DINT.

7. To create a controller tag, right-click Controller Tags in the tree display and select Add New Tag.

8. In the New Tag dialog box, name the tag Process_Temperature_EU and select REAL as the 
Data Type.

9. Click OK.

10. Add a new rung to the MainRoutine.

11. Click the File/Misc tab.

12. Scroll the commands until you find CPS, and then click it.

13. In the CPS instruction that appears, double-click Source.

14. Click the down arrow, expand SNAP_IRIO:I, and then select SNAP_IRIO:I.Data[1]. 

File/Misc tab CPS button
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15. Double-click Dest, and then click the down arrow and select the new Variable, 
Process_Temperature_EU, as the destination.

16. Double-click Length and enter 1.

Downloading and Running the Program

1. Select Communications→Download to download the RSLogix 5000 program to the controller. 

2. Click Download in the next two dialog boxes that appear.

3. Select Communications→Run Mode, and then click Yes in the next dialog box.

4. Toggle the Limit Switch on the Learning Center and watch the Pilot Light come on.

5. Notice in RSLogix 5000 that the value for the Process_Temperature_EU is shown in 
Engineering Units (degrees F). 

Limit Switch

Pilot Light
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6. Hold the Learning Center’s temperature probe between your fingers for a only a second or two 
and watch the value change.

Summary of Lesson 1

In lesson 1 you used Ethernet/IP Configurator to configure the modules and points for the 
SNAP-PAC-EB1 brain, and you created input and output assemblies to enable communication with 
an Allen-Bradley PLC. 

Then you viewed the controller tags in RSLogix 5000 and saw how it responds to input from the 
intelligent remote I/O when you toggle a point using a switch on the Learning Center.

In RSLogix you created two lines of ladder logic in order to control a digital output point and to view 
the temperature in Engineering Units.

You have just experienced how you can easily set up communications between the Allen-Bradley 
PLC and the SNAP I/O, read and write to digital I/O points, and take advantage of the values in 
Engineering Units of an analog value available in intelligent remote I/O.

Lesson 2: Using Intelligent Discrete I/O Functions
In the first activity of this lesson you will continue to configure the assemblies, modules, and points. 
And in subsequent activities you will use the remote I/O unit’s intelligence for counting, responding 
to a watchdog timeout, and pulsing to a direct output.

“Using a Counter” on page 49 demonstrates using a discrete input point as a counter. The discrete 
input point is configured and run in the I/O. Also, note that no ladder function block is needed in 
RSLogix 5000 to perform counting. High-speed counting (up to 20 Khz) is built into certain SNAP 
digital input modules and the SNAP-PAC-EB1 brain, so there is no need for a special HSC 
(High-Speed Counting) module.

In the “Using a Watchdog” activity on page 51 you will see how an Opto 22 watchdog allows you to 
configure the fail state of a discrete output point (or the fail value for analog output signals).

In “Using the Pulse Generator” on page 54 you will use EtherNet/IP Configurator to configure the 
pulse characteristics for a point. Then in RSLogix you'll watch the pulse you created on the 
SNAP PAC EB1.

Temperature in 
Engineering Units
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Configuring the Additional Point and Assemblies

In this activity you’ll use EtherNet/IP Configurator to add additional points and modify the existing 
assembly instances.

1. In EtherNet/IP Configurator, select File→Open and open the SNAP_IRIO.otg, the configuration 
you created in lesson 1.

2. In the Configure I/O Modules & Points tab, expand module 0 and then double-click point 0.

3. In the Add Digital Point dialog box, complete the fields as follows:

– Name: Flowmeter

– Features: Counter

For future reference, there are several other built-in intelligence features you can configure 
with this digital input module. These include:

– on-pulse and off-pulse

– frequency

– period

– on-time and off-time totalizer

4. Click OK.
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5. Click the Configure Assemblies tab, and then click input assembly instance 100.

6. Click Add.

7. In the Add Assembly Member dialog box, complete the fields as follows:

– Class: Discrete Input Point

– Point Name: Flowmeter

– Attribute: Feature Value

This Feature Value is for counter you just configured in the I/O Configuration tab. Note that the 
I/O’s built-in intelligence can also give you the attributes OnLatch and OffLatch, which require 
no configuration.

8. Click OK.

The Feature Value is 32 bits, so you don’t need to add a pad to align the data.
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9. Click output assembly instance 101.

10. Add an instance member that has the following characteristics:

– Class: Discrete Input Point

– Point Name: Flowmeter

– Attribute: Clear Feature Value

11. Click OK.

12. In the assembly instance, double-click the 31-bit pad, change it to 30 bits, and then click OK.
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13. Make sure the Solenoid is still in the bit 0 position in output assembly 101. If necessary, use the 
up and down arrows at the right to move the pad.

In Lesson 1 you created an input assembly with one 32-bit DINT, and in this lesson you added 
two more DINTs for a total of three. You created an output assembly instance that has one 
DINT.

Change to 30 bits.

Up and down arrows

Pad

Bit 0
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Input Assembly 100:

Output Assembly 101:

14. Choose File→Save to save the configuration.

15. Choose Tools→Download Configuration to Opto 22 Device.

16. In the Download Configuration dialog box, select the brain’s IP address.

17. Click Download.

18. Save the configuration.
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Using a Counter

In this activity you will re-configure RSLogix 5000 to communicate with the new assemblies you 
created. High-speed counting (up to 20 Khz) is built into certain SNAP digital input modules and the 
SNAP-PAC-EB1 brain, so there is no need for a special HSC (High-Speed Counting) module. Then 
you will see a counter working in real time and learn how to reset the counter.

1. In RSLogix 5000, open the project called IO4AB that you created in the lesson 1.

2. (Optional) If you want, you can delete the two rungs of ladder logic from lesson 1. No ladder 
logic is used in this activity to perform counting.

3. Double-click the Ethernet module to open the Module Properties dialog box.

4. For Input assembly instance 100, increase the size to 3, and then click OK. 

This is necessary because in EtherNet/IP Configurator you added a new DINT. Keep Output 
assembly instance 101 set to 1 and the Configuration set to 1 and 0.

5. Select Communications→Download to download the RSLogix 5000 program to the controller, 
and then click Download in the next dialog box that appears.

6. Select Communications→Run Mode, and then click Yes in the next dialog box.

7. Double-click Controller Tags, and then expand SNAP_IRIO:I until you see Data[0], Data[1], and 
Data[2].

Since these are 32-bit instances, there is no need to drill down to the bit level.

Increase to 3
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8. In the Description field for SNAP_IRIO:I.Data[2], enter Flowmeter Counts.

9. Notice that the value for Flowmeter Counts at Data[2] is 0.

10. Now toggle the Flowmeter switch on the Learning Center, and you’ll see that the value for 
Data[2] increases each time you toggle the switch.

Value for Flowmeter CountsData[0], [1], and [2]

Flowmeter switch

Data[2] (Flowmeter Counts) 
increases



CHAPTER 3: LESSONS USING IMPLICIT MESSAGING

SNAP IO4AB Learning Center User’s Guide 5151

11. Expand the output data, SNAP_IRIO:O, until you see bit 1 of SNAP_IRIO:O.Data[0].

12. In the Description field for SNAP_IRIO:O.1, enter Clear Flowmeter Counts.

13. Select output bit 1, change the value 0 to 1, and then press Enter on your keyboard. 

14. Change the value for output bit 1 back to 0 by selecting the value again and entering 0.

Notice that the Flowmeter Counter is reset to 0, which demonstrates another use of the remote 
I/O’s built-in intelligence: I/O attributes accessible from RSLogix 5000 can be used to write to 
outputs.

Using a Watchdog

Now let’s take a look at using a Watchdog. The watchdog monitors the health of communications 
between the PLC main rack and the remote I/O. The watchdog goes one step further by allowing 
you to configure the fail state of a discrete output point or the fail value for analog output signals.

1. In EtherNet/IP Configurator, double-click SNAP_IRIO to open the Modify Device Definition 
dialog box.

Output bit 1

Counter reset to 0

Change to 1 and then back to 0
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2. In the Modify Device Definition dialog box, select Yes for Watchdog and enter a value of 
5 seconds.

3. Click OK.

4. In the Configure I/O Modules & Points tab, expand module 1, and then double-click point 3 to 
add a new digital point.

This new point will demonstrate the fail state to be set if communication to the remote I/O is 
lost.

5. In the Add Digital Point dialog box, name the new point Pilot Light.

6. Select Yes for Watchdog and set the value to On.

7. Click OK.

8. Choose Tools→Download Configuration to Opto 22 Device.

Watchdog

Watchdog
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9. In the Download Configuration dialog box, select the brain’s IP address.

10. Click Download.

11. When the configuration has been downloaded successfully, click Close.

NOTE: If the Allen-Bradley PLC is still in Run mode, you can skip to step 14.

12. In RSLogix 5000, select Communications→Download, and then click Download in the next 
dialog box that appears.

13. Select Communications→Run Mode, and then click Yes in the next dialog box.

14. Remove the Ethernet cable from the SNAP I/O, wait five seconds, and notice that Pilot Light on 
the Learning Center lights up.

In this part of lesson 2, you’ve seen how you can configure and execute a watchdog.

15. While the Ethernet cable is still unplugged, toggle the Flowmeter switch several times. 

Pilot Light

Flowmeter switch
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16. Re-insert the cable, wait for communications to be re-established, and then notice that the 
flowmeter counts have increased.

This demonstrates the distributed, independent intelligence of the SNAP remote I/O.

Using the Pulse Generator

In this activity you’ll use EtherNet/IP Configurator to add a pulse generator for a direct output, and 
then download the configuration to the brain.

1. In EtherNet/IP Configurator, open SNAP_IRIO.otg.

2. In the Configure I/O Modules & Points tab, expand module 1, the digital output module, and 
then double-click point 2.

3. In the Add Digital Point dialog box, enter the following:

– Name: Motor Starter

– Features: Pulse Train

– Period: 2

– Percent: 50

– Initial Delay: 1

– # of Pulses: 10

Flowmeter counts
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When completed, the Add Digital Point dialog box should look like this:

4. Click OK.

5. Click the Configure Assemblies tab, and then click output assembly instance 101.

6. Add an instance member that has the following characteristics:

– Class: Pulse And TPO Generator

– Point Name: Motor Starter

– Attribute: Start

7. Click OK.
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8. If necessary, use the up and down arrows to position the assembly member under Flowmeter, 
ClearFeatureValue.

9. Double-click the pad, change the size to 29 in order to form a 32-bit DINT with the three 
one-bit assembly members.

10. Click OK.

Input assembly 100 still has three 32-bit DINTs, and output assembly 101 has one 32-bit DINT 
as follows:

Input Assembly 100:

Arrow keys
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Output Assembly 101:

11. Click the Verify tab to check the configuration.

12. Click the Download button.

In this activity you added a point called Motor Starter with the Pulse Train feature. Then you added 
the Motor Starter point to output assembly 101.

Watching the Pulse in RSLogix 5000

In RSLogix 5000 you will watch the pulse you created on the SNAP PAC EB1.

1. Make sure that the IO4AB project that you created in RSLogix 5000 in a previous lesson is open 
and running.

2. Double-click Controller Tags, and then expand SNAP_IRIO:O.
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3. Drill down to the bit level, and in the Description field for bit 2, enter Start Pulse.

4. Download, and Run.

5. Change the Start Pulse bit to 1 and watch the Motor Starter light on the Learning Center.

6. When you’ve finished watching, stop the controller, and go offline.

Summary of Lesson 2

In lesson 2 you used EtherNet/IP Configurator to configure the pulse characteristics for a point and 
then ran it in the I/O unit.

In the first activity of this lesson you continued to configure the assemblies, modules, and points. 
And in subsequent activities you used the remote I/O unit’s intelligence for counting, responding to 
a watchdog timeout, and pulsing to a direct output.

“Using a Counter” on page 49 demonstrated using a discrete input point as a counter. You 
configured the discrete input point and ran it in the I/O. You also saw a counter working in real time 
and learned how to reset the counter.

In the “Using a Watchdog” activity on page 51 you saw how an Opto 22 watchdog allowed you to 
configure the fail state of a discrete output point (or the fail value for analog output signals).

In “Using the Pulse Generator” on page 54 you used EtherNet/IP Configurator to configure the pulse 
characteristics for a point. Then in RSLogix you watched the pulse you created on the SNAP PAC EB1.
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Lesson 3: Using Intelligent Analog I/O Functions
In this lesson you will continue to configure the I/O unit and see the following features:

• Scaling—Scaling analog values at the I/O level to match field instrumentation and actual 
process value

• Engineering Unit Conversion—Setting Engineering Units at the I/O level to be read in RSLogix 
5000

• Maximum and Minimum Values—Reading process variable maximum or minimum values in 
RSLogix 5000

• Output Clamping—Simulate using a process condition to set an output clamp value that is 
executed in I/O

This lesson includes the following activities:

“Configuring the I/O Unit” on page 59

“Setting Up RSLogix 5000” on page 68

Configuring the I/O Unit

In this activity you will use EtherNet/IP Configurator to configure the two remaining modules so you 
can experience using analog output from the remote I/O in RSLogix: 

Then you will create additional members for input assembly 100 and output assembly 101.

1. In EtherNet/IP Configurator, open SNAP_IRIO.otg, the configuration you created in a previous 
lesson.

2. Click the Configure I/O Modules & Points tab.

3. Double-click module 2 to open the Add Module dialog box.

Position Type Module

02 Analog Output SNAP-AOV-27

04 Analog Input SNAP-AIV
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4. Under Type, select Analog Output, and then select the SNAP-AOV-27 module.

5. Click OK.

6. Double-click module 04 to open the Add Module dialog box.

7. Under Type, select Analog Input. Then select SNAP-AIV.

8. Click OK.

Now you are ready to add the points.

9. Expand module 2, the SNAP-AOV-27 analog output module.

10. Double-click point 0 to open the Add Analog Point dialog box.
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11. Enter the name, Proportional Valve, and then select the scalable version of the module.

12. Click the Custom button to open the Scale Analog Readings dialog box.

13. In this example, values are

14. In order to change units to scaled units representing gallons per minute, complete the fields as 
follows:

– Scaled Units: GPM

– Lower Value
Actual: 0
Scaled: 0

– Upper Value
Actual: 10
Scaled: 35

Select the 
scalable version

Lower Value

Upper Value
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15. Click OK on the Scale Analog Readings dialog box, and then click OK to close the Add Analog 
Point dialog box.

Configuring the Points on the SNAP-AIV Input Module

1. Expand module 04, the SNAP-AIV analog input module.

2. Double-click point 0 to open the Add Analog Point dialog box.

3. Enter the name, Tank Level, and then select the scalable version of the module.

4. Click the Custom button.

5. For this lesson, assume that the fuel tank holds 35 gallons, and then fill in the fields on the Scale 
Analog Readings dialog box as follows:

– Scaled Units: Gallons

– Lower Value
Actual: 0
Scaled: 0

– Upper Value:
Actual: 5
Scaled: 35
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The completed dialog box looks like this.

6. Click OK, and then click OK again.

Configuring the Assemblies

1. Click the Configure Assemblies tab, and then click input assembly instance 100.

2. In order to create a completely new input assembly, highlight the first assembly member, and 
then click the Delete button enough times to delete the existing members from the previous 
lessons.

3. Click the Add button to open the Add Assembly Member dialog box.
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4. Select the following characteristics:

– Class: Analog Input Point

– Point Name: Tank Level

– Attribute: rValue

5. Click OK.

6. Click No on the Fill Module dialog box, and then click OK.

7. Click the Add button and add another assembly member with the following characteristics:

– Class: Analog Input Point

– Point Name: Tank Level

– Attribute: Maximum rValue

8. Click OK.
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9. Click No on the Fill Module dialog box, and then click OK.

10. Add one more member to the input assembly by clicking Add again and selecting the 
following characteristics:

– Class: Analog Output Point

– Point Name: Proportional Valve

– Attribute: rValue

11. Click OK.

12. To configure the output assembly, click assembly instance 101.

13. In order to create a completely new output assembly, delete the existing members using the 
Delete button.
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14. Add an assembly member with the following characteristics:

– Class: Analog Output Point

– Point Name: Proportional Valve

– Attribute: rValue

15. Click OK.

16. Add one more member to the output assembly that has the following characteristics:

– Class: Analog Output Point

– Point Name: Proportional Valve

– Attribute: HighClamp

17. Click OK.

18. On the Fill Module dialog box, select No and then click OK.
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In this activity you have created an input assembly instance that has three 32-bit DINTs and an 
output assembly instance that has two 32-bit DINTs, as follows:

Input Assembly 100:

Output Assembly 101:

19. Save the configuration.

20. Choose Tools→Download Configuration to Opto 22 Device.

21. In the Download Configuration dialog box, select the brain’s IP address.

22. Click Download.

23. When the configuration has been downloaded successfully, click Close.

Now you are ready to set up RSLogix 5000.
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Setting Up RSLogix 5000

1. In RSLogix 5000, open IO4AB, the project from the previous lesson.

2. In the project tree display, expand I/O Configuration, Backplane, 1769-L32E Ethernet Port 
LocalENB, and Ethernet.

3. Right-click ETHERNET MODULE SNAP_IRIO and select Delete, and then click Yes to confirm.

NOTE: The remote I/O is capable of processing both analog and digital data at the same time. 
However, the Generic Ethernet Module makes you choose just one data type, which cannot be 
changed later. In Lesson 1, which dealt with thermocouple temperature, you got around this picking 
the DINT data type for the Generic Ethernet Module, and then you created a CPS instruction in ladder 
logic to change the analog tag to a user created variable of REAL data type.

4. Right-click Ethernet and select New Module.

5. Expand Communications in the tree display to open the Select Module dialog box.

6. Scroll down to select Generic Ethernet Module and then click OK to open the New Module 
dialog box.
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7. Enter or select the following information:

– Name: SNAP_IRIO

– Comm Format: Data - REAL.

– IP Address: IP address of the EB1

– Input Assembly Instance: 100, Size: 3 (There are three 32-bit input DINTs.)

– Output Assembly Instance: 101, Size: 2 (There are two 32-bit output DINTs.)

– Configuration: 1, 0 (You must enter these values.)

NOTE: The Input Instance is an RSLogix 5000 READ assembly, and the Output Instance is an RSLogix 
5000 WRITE assembly. The Configuration values are not used, but they must be entered.

The completed dialog box should look like this:

8. Click OK.

The Module Properties dialog box opens, showing the Connection tab for you to enter the 
Requested Packet Interval (RPI). The RPI is basically the scan time of the remote I/O unit.

9. Set the RPI to 200.0 ms, and then click OK.

The Opto 22 remote I/O has now been configured and added to the RSLogix 5000 software as a 
generic Ethernet module.

10. Open the Controller Tag, and then click the Edit Tags tab.
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11. Delete the Process_Temperature_EU from lesson 1 tag by right-clicking on it and then 
selecting Delete.

12. Select Communications→Download to download the RSLogix 5000 program to the controller, 
and then click Download in the next dialog box that appears.

13. Select Communications→Run Mode, and then click Yes in the next dialog box.

14. In the Controller Tags window, expand SNAP _IRIO:I until you see the Opto 22 input tags.

15. Enter a description for each of the input tags as follows:

Tag Description

0 Tank Level

1 Max Level

2 Proportional Valve

 Process_Temperature_EU tag
Edit Tags tab

Opto 22 
input tags
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The input tags will now look like this:

16. Expand SNAP _IRIO:O until you see the output tags, and then enter a description for each 
output tag as follows:

The output tags will now look like this:

Tag Description

0 Proportional Valve

1 Valve High Clamp

Input tag 
descriptions

Output tag 
descriptions
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17. Do the following things:
a. Notice the values for input [0] Tank Level and [1] Max Level.
b. Turn the Tank Level potentiometer to the right and notice that the values change.
c. Turn the Tank Level potentiometer back to the left and notice what happens. The value of 

input [0] Tank Level decreases, but the value of input [1] Max Level has captured the 
maximum tank level.

You have just read the analog value of the Tank Level and recorded the maximum Tank Level 
value, all in scaled Engineering Units. 

Using Analog Output

In this activity you will see how the Allen-Bradley PLC communicates to the SNAP analog output. 
You will also see an example of an intelligent attribute, analog output clamping.

1. Stop the controller by selecting Communications→Go Offline.

2. Open the MainRoutine and add one rung of ladder logic instruction.

3. Click the Move/Logical tab, and then click the MOV button to add a Move instruction.

4. Double-click Source, expand SNAP_IRIO:I, and then select SNAP_IRIO:I.Data[0], Tank Level.

a b c

Max tank level 
captured

Initial value Potentiometer 
turned to the right

Potentiometer turned 
back to the left

Select Source
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5. Double-click Dest, expand SNAP_IRIO:O, and then select SNAP_IRIO:O.Data[0], 
Proportional Valve.

6. Select Communications→Download, and then click Download in the next dialog box that 
appears.

7. Click Yes in the next dialog, which asks, “Change controller mode back to Remote Run?”

8. Select Communications→Run Mode, and then click Yes in the next dialog box.

9. Open the Controller Tags and expand the input and output tags. 

10. Notice on the Learning Center that there is now a value for the Proportional Valve, displayed in 
scaled Engineering Units.

11. Turn the potentiometer and watch the Proportional Valve value change in RSLogix 5000 as well 
as in the Proportional Valve display on the Learning Center.

12. Do the following things to see the intelligent I/O feature of an output clamp.
a. Turn the Tank Level potentiometer on the Learning Center to the left, close to zero.
b. In RSLogix 5000, go to the Valve High Clamp value and enter a value of 15.
c. Turn the potentiometer clockwise as far as it will go.

Select the destination

Proportional Valve
Potentiometer



LESSON 4: USING DISTRIBUTED PID LOOP CONTROL

SNAP IO4AB Learning Center User’s Guide74

In the output assembly, notice that the Proportional Valve value has gone above 15, yet in 
the input assembly the Proportional Valve has clamped at 15.

Also note that the Proportional Valve display on the Learning Center has clamped at 
approximately one half the full scale.

Summary of Lesson 3

In lesson 3 you configured analog input and output points at the I/O level to return values in 
Engineering Units that were matched to the field instrumentation. In addition you used some of the 
available intelligent I/O attributes, including Analog Input Maximum Value and Analog Output High 
Clamp.

Lesson 4: Using Distributed PID Loop Control
In this lesson you will build on the previous lesson to configure and run a distributed proportional 
integral derivative (PID) loop in the Opto 22 intelligent remote I/O. This PID loop will write to the PID 
setpoint sent from the Allen-Bradley controller to demonstrate how you can change a setpoint 
based on a process condition. You will also use the PID loop tuning tool that’s available in the 
EtherNet I/P Configurator.

Configuring the ICTD Temperature Probe

1. In EtherNet/IP Configurator, open SNAP_IRIO.otg, the configuration you created in a previous 
lesson.

2. Click the Configure I/O Modules & Points tab, and then expand module 3, the SNAP-AICTD 
analog input module.

Proportional Valve in 
output assembly

Proportional Valve in 
input assembly
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3. Double-click point 0 of module 3, the SNAP-AICTD analog input module, and name the new 
point Process_Temperature.

NOTE: The ICTD temperature probe on your Learning Center is actually a PID Simulator, which 
has—in addition to the ICTD—a resistor that heats up the probe to simulate a real world process. 
This resister is wired to point 1 of module 2, the SNAP-AOV (analog output module).

4. Click OK.

5. Expand module 2, the SNAP-AOV analog output module, and add point 1 with the following 
characteristics:

– Name: Heater_Control

– Module: Scalable
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6. Click the Custom button to open the Scale Analog Readings dialog box.

7. Complete the fields as follows:

– Scaled Units: Percent

– Lower Value
Actual: 0
Scaled: 0

– Upper Value:
Actual: 10
Scaled: 100

8. Click the Configure PID Loops tab.

9. Select PID #00 and then click the Add button.

10. On the Add PID Loop dialog box, complete the fields as follows:

– Name: Process_Control

– Input: I/O Point, Process_Temperature

– Low Range: 0

– High Range: 90

– Setpoint: PLC

– Initial Value: 0

– Output: I/O Point, Heater_Control

– Lower Clamp: 0
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– Upper Clamp: 100

– Algorithm: Velocity

– Scan Rate: 1

– Gain: -10

– Tune I: 0.4

– Tune D: 0

Leave the default settings for all other parameters. The completed dialog box should look like 
this:

The Scan Rate is the rate at which each individual PID loop is solved. It is not related to the 
communication between the Allen-Bradley controller and the SNAP intelligent remote I/O 
(RPI). You might remember that the PID loop execution is independent of the PLC and 
distributed in the SNAP I/O. Although the max scan rate can be as low as 1 millisecond for an 
individual PID loop, for this lesson we will leave the scan rate at 1 second.

11. Click OK.
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12. Click the Configure Assemblies tab, and then add the following members to input 
assembly 100:

13. Click output assembly 101, and add the following member to the existing configuration:

The updated assemblies now look like this:

Input Assembly 100:

Output Assembly 101:

14. Press Ctrl+S to save the configuration.

Number Class Instance Attribute

3 PID Loop Controller PID Loop #: 0 Setpoint

4 PID Loop Controller PID Loop #: 0 Input

5 PID Loop Controller PID Loop #: 0 Output

Number Class Instance Attribute

2 PID Loop Controller PID Loop #: 0 Setpoint
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15. Click the Verify tab.

16. Click the Download button.

17. In the Download Configuration dialog box, select the brain’s IP address.

18. Click Download.

19. When the configuration has been downloaded successfully, click Close.

This completes the setup of the Opto 22 remote I/O for lesson 4.

Configuring RSLogix 5000

1. In RSLogix 5000, open IO4AB, the project from the previous lesson.

2. In the project tree display, expand I/O Configuration, Backplane, 1769-L32E Ethernet Port 
LocalENB, and Ethernet.

3. Double-click ETHERNET MODULE SNAP_IRIO to open the Module Properties dialog box.

4. Change the size for assembly 100 to 6 and the size for 101 to 3.
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5. Click OK.

6. In the project tree display, double-click Controller Tags.

7. In the Controller Tags window, expand SNAP_IRIO:I until you see the Opto 22 input tags.

8. Click the Edit Tags tab.

You should see the existing tags from the previous lesson:

9. Enter descriptions for input tags 3, 4, and 5 as follows:

Tag Description

3 Setpoint

4 Process Temperature

5 Heater Control

Change to 6

Change to 3

Existing 
input tags



CHAPTER 3: LESSONS USING IMPLICIT MESSAGING

SNAP IO4AB Learning Center User’s Guide 8181

The input tags will now look like this:

10. Expand SNAP _IRIO:O until you see the existing output tags.

11. For the one new output tag, enter Setpoint as the description.

The output tags will now look like this:

12. Select Communications→Download to download the RSLogix 5000 program to the controller.

13. Click Download in the next dialog box that appears.

14. Select Communications→Run Mode, and then click Yes in the next dialog box.

Controlling the Setpoint

1. With the Controller Tags window open in RSLogix 5000, click the Monitor Tags tab.

2. Notice that the Process Temperature is displayed in engineering units and it shows the 
temperature in the room. 

3. Hold the probe between your fingers for a only a second or two and notice the temperature 
rise. 

New input 
tags

New output 
tag

Process Temperature
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Now you’re going to observe how the PID loop reacts when you change the Setpoint based on 
a process condition.

4. Expand the output tags so that you can see the Setpoint tag.

5. Change the Setpoint tag’s value to a few degrees higher than the current Process Temperature, 
and then press Enter.

For example, if the Process Temperature is 74, change the Setpoint to 78.

6. Watch the Heater Control and Process Temperature react.

You should see the Heater Control vary as it attempts to change the Process Temperature to 
match the Setpoint.

7. Now go to EtherNet I/P Configurator and click the Configure PID Loops tab.

8. Select Loop 00, Process_Control.

Change the 
Setpoint to a few 
degrees higher.

Watch these 
values react.

Tuning 
button
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9. Click the Tuning button.

10. Observe what happens in the View PID Loop dialog box.

In the View PID Loop dialog box, you can tune your PID loop using the Gain, Tune I, and Tune D 
parameters. To save changes to the I/O brain’s RAM, click the Apply button. Or, if you want to 
save the changes permanently to flash memory and your configuration file, click the Save 
Tuning button. The Save Tuning button does not interfere with communications to the 
Allen-Bradley controller. For more information on PID tuning and the features of the PID tuning 
tool, see form 1770, the EtherNet/IP for SNAP PAC Protocol Guide. See also, Opto 22 form 1641, 
OptoTutorial: SNAP PAC PID, which we highly recommend for detailed information on PIDs on 
Ethernet-based I/O units. Form 1641 is available for download from our website at 
www.opto22.com.

About PID Loops

PID loops (or simply PIDs) are used to drive an input (a process variable) toward a particular value 
(the setpoint) and keep the input very close to that value by controlling an output. For example, 
consider temperature control, where the input is a measurement of ambient temperature, the 
setpoint is the desired temperature, and the output is a heater. The PID for this system will use a 
mathematical formula that controls the output to maintain a desired temperature, efficiently adjust 
to changes in setpoint, and compensate for changes in load, such as the influx of cold air. In this 
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example, a temperature sensor (analog input), a thermostat (analog input), and a heater control 
(analog output) are components of one system, controlled by a PID loop.

SNAP PAC I/O units support 96 PID loops. PIDs can control isolated systems or be part of cascaded 
systems where one loop controls the setpoints or input variables of others.

The PID operates at the I/O unit, independently of the controller. Once configured and downloaded 
to the brain, a PID operates until the I/O unit loses power. Remember that changes are not written to 
the I/O unit until the configuration is downloaded to the Opto 22 device. Each PID loop must be 
individually configured and tuned.

Summary of Lesson 4

In lesson 4 you built on the previous lesson to configure and run a distributed proportional integral 
derivative (PID) loop in the Opto 22 intelligent remote I/O. The PID loop wrote to the PID setpoint 
sent from the Allen-Bradley controller to demonstrate how you can change a setpoint based on a 
process condition. You also used the PID loop tuning tool that’s available in the EtherNet I/P 
Configurator.

What’s Next?
Now that you’ve completed the lessons and are ready to move on to the next level, here’s where you 
can go for more information:

If You Need Information About: Do This:

EtherNet/IP Configurator, EtherNet/IP messaging, 
and SNAP I/O hardware

See “Documents and Online Help” on page 2

How to configure a system or technical information on 
Opto 22 products

Contact Opto 22 Pre-sales Engineering

Local: (951) 695-3000
Toll-Free (in the U.S.): (800) 321-6786
Fax: (951) 695-3095
E-mail: systemseng@opto22.com

How to find distributors
Go to: 
http://www.opto22.com/site/co_distributors.aspx

Selecting products from the Opto 22 website Go to: http://www.opto22.com/site/pr_index.aspx

http://www.opto22.com/site/co_distributors.aspx
http://www.opto22.com/site/pr_index.aspx
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4: A: Supported Allen-Bradley PlatformsAppendix A

A: Supported Allen-Bradley 
Platforms

Opto 22 supports using the ControlLogix® and CompactLogix™ controller platforms, V13-17, with 
Opto 22 SNAP I/O. Both of these platforms support Implicit Messaging (also known as I/O 
messaging) and Explicit Messaging.

The following Allen-Bradley platforms also support EtherNet/IP. While some controllers in these 
platforms only support explicit messaging, Opto 22 may be able to assist you in using them.

• MicroLogix™

• DriveLogix

• SLC-5

• FlexLogix

• PLC-5

• SoftLogix5800

NOTE: Some Allen-Bradley controller platforms have only specific models that support EtherNet/IP or 
require an adapter module or card.

For a complete and up-to-date list of Allen-Bradley platforms that support EtherNet/IP, and more 
information on which platforms support Implicit Messaging or Explicit Messaging only, please 
contact Rockwell Automation.
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