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Welcome to PAC Project 9.6
Welcome to version 9.6 of Opto 22’s PAC Project™ software suite for industrial 
automation, remote monitoring, and data acquisition applications.
PAC Project comes in two forms: PAC Project Basic and PAC Project Professional.

PAC Project Basic
PAC Project Basic is included in your purchase of a SNAP PAC controller and can also be 
downloaded for free from our website, www.opto22.com. PAC Project Basic is all you need 
for most monitoring and control needs. It includes the following software applications:

• PAC Control™ for developing control programs (strategies) to automate 
processes, monitor equipment, and acquire data from processes and 
equipment

• PAC Display™ for creating HMIs (human-machine interfaces) for technicians 
and operators to use

• PAC Manager™ for configuring hardware and troubleshooting

PAC Project Professional
• PAC Project Professional is designed for more complex projects, especially 

those requiring OLE for Process Control (OPC), database connectivity, 
redundant networks, controller redundancy, or legacy hardware support.

PAC Project Professional can be purchased as a suite or as individual applications to 
suit your needs. The suite includes the following software applications:
• PAC Control Professional for developing control programs

• PAC Display Professional for creating HMIs

• PAC Manager for configuration

• OptoOPCServer™, an OPC 2.0-compliant server for serving SNAP PAC System 
I/O and variable data to OPC clients, including PAC Display and OptoDataLink. 
OptoOPCServer is strongly recommended for multiple seats of PAC Display and 
OptoDataLink communicating with the same controller(s).

• OptoDataLink™ for exchanging SNAP PAC System data with databases 
(including Microsoft SQL Server, Microsoft Access, and MySQL), and text files

• SoftPAC™, software-based programmable automation controller (PAC) for 
PC-based control

More Information on PAC Project Basic and Pro
PAC Project works with all SNAP PAC controllers, SNAP PAC brains, SNAP PAC racks, and 
SNAP I/O modules. Free product support is included with both PAC Project Basic and 
PAC Project Professional. Free training and free pre-sales engineering help are also 
available. 

http://www.opto22.com/site/downloads/dl_drilldown.aspx?aid=3146
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• For product support, see “For Help” on page 8. 

• For training, see our website under Support > Training or email training@opto22.com. 

• For pre-sales engineering, call 1-800-321-6786 (toll-free in the U.S. and Canada) or 
1-951-695-3000.

For computer memory and operating system requirements, see “Installation Requirements” 
on page 6.

For more information about PAC Project Basic and Professional, see: 

• PAC Project Software Suite Data Sheet, Opto 22 form 1699

• PAC Project Basic and Professional Comparison Chart, Opto 22 form 1681

Click the link above, or go to www.opto22.com, and search on the document form number.

Notes for Customers with Older Systems (ioProject and 
FactoryFloor)
PAC Project is very similar to older Opto 22 software, but there are important things to 
know before you install and use it. If you’re moving to the SNAP PAC System from legacy 
systems, be sure to read these documents first:

• PAC Project 8.0 Release Notes, form 1680. See the section, “Notes for Current ioProject 
Customers.”

• SNAP PAC System Migration Technical Note, form 1688.

• (FactoryFloor customers only) FactoryFloor to PAC Project Migration Technical Note, 
form 1692.

NOTE: If you are using a SNAP-LCE or Ultimate controller, do not upgrade to PAC Project 9.6. 
Instead, use either PAC Project 8.0 or ioProject. In order to use these controllers with PAC Project 
8.0, use controller firmware version 7.2 and Ethernet brain firmware version 7.0 or newer. If you 
want to use PAC Project software version 8.1 or newer, you must use SNAP PAC controllers instead.

New Features and Enhancements
PAC Project 9.6 includes a number of new features and enhancements to make creating, 
maintaining, and running your SNAP PAC System easier than ever. New features and 
enhancements have been added to PAC Control, PAC Display, PAC Manager, and 
OptoDataLink.

PAC Control
Configure a strategy to run after downloading. You can now configure a strategy to 
start running at completion of the strategy download. Just select the "Start strategy after 
download completes" check box on the File > Strategy Options > Download tab.

http://www.opto22.com/documents/1699_PAC_Project_Data_Sheet.pdf
http://www.opto22.com/documents/1681_PAC_Project_Basic_Pro_Comparison_Chart.pdf
http://www.opto22.com/documents/1680_PAC_Project_80_Release_Notes.pdf
http://www.opto22.com/documents/1688_SNAP_PAC_System_Migration_Tech_Note.pdf
http://www.opto22.com/documents/1688_SNAP_PAC_System_Migration_Tech_Note.pdf
http://www.opto22.com/site/training.aspx
mailto:training@otpo22.com
http://www.opto22.com/site/documents/doc_documents.aspx
http://www.opto22.com/site/documents/doc_documents.aspx
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Perform command line operations. PAC Control’s Command-Line Interface (CLI) tool 
was built for customers who want a quick and easy way to modify existing strategies 
without using the PAC Control graphical user interface. The CLI tool can: 

• Move a configured I/O module or I/O point to an empty position on the same or 
different I/O unit

• Add new variables 

• Create a control engine download (.cdf ) file

From a regular Command Prompt window, you can perform individual operations, as well 
as running a series of operations from a Commands file. You can also use the CLI to load a 
strategy in PAC Control’s graphical user interface. 

Change a subroutine’s folder. The new Change Folder button (on the Subroutine Files 
dialog box) is helpful when you need to change a subroutine’s location; for example, when 
the subroutine is saved in a read-only folder (which can cause errors when you compile the 
strategy), and when you want to change the location of a subroutine that is being used by 
a strategy. 

PAC Display
Graphic object and window transparency. You can now configure the transparency of 
windows and graphical objects so that Runtime users can see through them. You can also 
apply transparency to a group of objects. By using a slider control or by simply entering a 
value between 0 and 100, you can control the opacity of an object from completely 
invisible to entirely opaque. This new feature is great for making windows and controls 
(like SuperTrends and alarm graphics) invisible or semi-transparent in Runtime. 

Note that some PAC Display controls support transparency only in Windows 8.1 or higher. 
All image formats support transparency except Microsoft Windows-format metafiles (.WMF 
and .EMF).

The transparency feature also lets you create non-solid (for example, dotted or dashed) 
lines with widths greater than 1 pixel. (Prior to R9.6000, only solid lines could be wider than 
1 pixel.)

Clearing history alarms. A new Clear button (included by default when configuring 
history alarms) lets Runtime operators quickly clear the list of alarms in alarm history 
windows.

Integer bits in SuperTrends. You can now configure SuperTrends to trend integer bits. 
This can be useful when you use bits to represent a state or alarm condition, and want to 
review their changes over time. 

Copy configured security permissions to multiple graphic objects. To complement 
the security enhancements implemented in PAC Project R9.5000, the new Copy, Paste, and 
Merge feature (in Edit > Security Permissions) lets you copy a graphic’s security 
permissions, and then apply them to a set of chosen graphics. You can even apply the 
permissions to all graphics in the window or to all graphics in the project. The Paste 
feature allows you to overwrite any previously configured permissions; the Merge feature 
adds the copied permissions to any existing permissions in the selected target graphics. 
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Improved multi-monitor support. Customers who use more than one monitor now have 
new options for positioning Configurator and Runtime dialog boxes. (These options don’t 
apply to Microsoft Common Dialogs, which open where they were last positioned.) 

Improved Z-Order feature. The Z-Order function (used to control the order of overlapping 
graphic objects) is now better and easier to use. A new Z-Order > Arrange menu item 
displays thumbnails and descriptions of the object type in order (from top to bottom) in a 
stack of overlapping objects. Click an object to select it, and then either drag and drop it to a 
different position in the stack, or click a button to move the object up, down, to the top, or to 
the bottom of the stack. You can also double-click the thumbnail to openthe object’s Graphic 
Dynamic Attributes dialog box. (Note that the Z-Order > Arrange feature does not support 
buttons, combo boxes, PID buttons, alarm graphics, table controls, URL controls, or 
SuperTrends.)

Support for user agent switching (Pro only). When you want to specify the target browser 
and operating system for a URL control or URL window, you can now enter a user agent value 
to be passed to the web server at Runtime. With this feature, the web server responds as if 
requests were coming from the browser and operating system you defined. In addition, this 
new feature provides the ability to set a global user agent value for all URL controls and URL 
windows in all of your PAC Display projects.

Hide forward and back buttons in URL windows (Pro only). To maximize the viewing 
area, you can now hide a URL window’s forward and back navigation buttons.

More support for alarm email alerts. In addition to the standard list of mail servers you can 
configure for alarm email alerts, you now have the option to configure a mail server that isn’t 
in the list. Also, you can now verify your email configuration by sending a test email. 

More descriptive message for failed alarm alert emails. When an alarm alert email fails 
to send, the message written to PAC Display’s event log is more descriptive to help you quickly 
find and fix the issue.

Open a project’s folder. The Project Path dialog box (File > Project Path) includes a new 
Open Folder button, so you can easily open the folder where the project is located.

Mouse scroll wheel enabled in tables. When a table’s length exceeds the size of the 
window it’s displayed in, you can now scroll through the rows by using the mouse’s scroll 
wheel.

PAC Manager
More easily and quickly navigate through long lists of configured devices. When 
you’ve configured six or more devices, PAC Manager provides two new time-saving 
enhancements for finding and selecting a device in the Inspect window (Tools > Inspect).

Use the Next and Back buttons (displayed to the right of the Device Name field) to navigate 
the alphabetized list of device names. For example, if the device displayed in the Device 
Name field is “Cookie Controller,” clicking the Next button displays the next configured 
device in the alphabetized list, and clicking Back displays the previous device in the list.
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In addition, the five most recently inspected devices appear at the top of the alphabetized 
list of device names. (Note that these new features aren’t visible until you’ve configured at 
least six devices—that way, they aren’t in your way if you don’t need them.)

Resize contents of Inspect windows. You can now resize table columns in Inspect 
windows to more easily see their contents. 

OptoDataLink
Improved notification when the OptoDataLinkRuntime service is stopped. If the 
OptoDataLinkRuntime service stops, a bright red notification banner is displayed in 
OptoDataLink, and a message box appears with instructions for restarting the service. (If 
you run OptoDataLink with administrator privileges, you have the option to try to restart 
the service by clicking OK on the message box.) The notification banner remains visible in 
OptoDataLink until the service is restarted. 

If the service stops when OptoDataLink is closed, an “x” appears on the OptoDataLink 
Monitor icon (displayed in the notification area of the Windows taskbar), and when you 
hover the mouse over the icon, a “Service is not running” message is displayed. If you run 
OptoDataLink with Administrator privileges, you can right-click the icon to attempt to 
restart the service.

Use OptoDataLink Monitor to start and stop the OptoDataLinkRuntime service. 
When you run OptoDataLink Monitor with administrator privileges, you can use 
OptoDataLink Monitor’s pop-up menu to start and stop the OptoDataLinkRuntime service. 

Better support for redundant controllers. OptoDataLink automatically recognizes 
when a strategy includes redundant controllers, and includes information about them in 
the OptoDataLink project. When the project runs, OptoDataLink will now detect when the 
active controller changes and will switch to scanning the new active controller.

Open recent projects. The last five projects that were opened are now listed at the 
bottom of the File menu so you can open them again with just one click. 

New Next and Back navigation buttons
and Most Recently Used list 
save time finding devices 
when you have six or more 
devices configured. 
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Bug Fixes
For a complete list of bug fixes in the 9.6 version of PAC Project, see the PAC Project Readme 
file. 

In addition, see the readme file for your control engine or brain firmware, available on our 
website at www.opto22.com. To find firmware, click Support > Downloads and filter by 
Firmware. When you locate the firmware file for your device, in addition to downloading 
the firmware, click the Related Documents tab and download the readme file, too. 

Here are some other useful sources of bug information on our website:

• OptoKB Article Search—Click the Support tab on our website and then click 
OptoKnowledgeBase to find articles by Article Number, Title, Text, or Product. 

• OptoSubscriptions—Use your my.opto22.com account to subscribe to OptoNews.

Installation
CAUTION: If you are upgrading to version 9.6 from a version of ioProject older than 7.0, do NOT 
uninstall ioProject before running the PAC Project version 9.6 installation. If you uninstall first, you 
will lose all configured control engines.

Installation Requirements
Here’s what you need to install and run PAC Project 9.6 software:

• A computer with a standard or mainstream core processor and (at least) the minimum 
memory required for your version of Microsoft Windows. (Low-end CPUs are not 
recommended.) Additional memory may be required for some configurations. 

• One of the following operating systems:

– Microsoft Windows 10 Professional (32-bit or 64-bit)

– Windows 8.1 Professional (32-bit or 64-bit)

– Windows 7 Professional (32-bit or 64-bit)

– Windows Vista® Business (32-bit only)

– (OptoOPCServer and OptoDataLink only) Windows Server 2012 R2 and Windows 
Server 2008 R2

NOTE: PAC Project will not install on Windows XP or older Windows operating systems. 
Embedded operating systems are not tested or supported. 

• Ethernet capability.

• VGA or higher resolution monitor (Super VGA recommended). Minimum size: 
800x600 with small fonts.

• Mouse or other pointing device.

• (Optional) Installed Windows printer.

http://www.opto22.com/site/myopto/my_index.aspx
http://www.opto22.com/
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Hard Disk Space Requirements 

Important Notes on Firmware
Opto 22 hardware is shipped with the most recent firmware, but you should check the 
website for additional updates that may be available.

For details on the features each firmware version includes, see the firmware readme file for 
your device. To find the readme, go to www.opto22.com and search on the PAC’s or brain’s 
part number. When you get to the product page, look under the Documents tab for the 
readme. The readme can also be found under the Related Documents tab on the firmware 
download page.

NOTE: If you are using a SNAP-LCE or Ultimate controller, do not upgrade to PAC Project 9.6. 
Instead, use either PAC Project 8.0 or ioProject. In order to use these controllers with PAC Project 
8.0, use controller firmware version 7.2 and Ethernet brain firmware version 7.0 or newer. If you 
want to use PAC Project software version 8.1 or newer, you must use SNAP PAC controllers instead.

For additional compatibility information, see form 1693, the Legacy and Current Product 
Comparison and Compatibility Charts. To obtain this form, click the link or go to the Opto 22 
website, www.opto22.com, and search on the form number, 1693.

PAC Project Examples Location
In order to comply with Microsoft’s rules regarding directory structure, we place all 
PAC Project application examples in this folder on your hard drive:

C:\Users\Public\Public Documents\Opto 22\PAC Project 9.6

Application PAC Project Professional PAC Project Basic

PAC Control 70.9 MB 69.6 MB

PAC Display 209.1 MB 162.3 MB

OptoOPCServer 16.9 MB (not included)

OptoDataLink 17.5 MB (not included)

SoftPAC 7.4 MB (not included)

PAC Manager 30.8 MB 30.8 MB

Tools (PAC Utilities) 6.9 MB 6.9 MB

EtherNet/IP Configurator 17.7 MB 17.7 MB

Total 321.6 MB*  213.9 MB*

* Installing both Pro and Basic requires a total of 348 MB of hard disk space.

http://www.opto22.com
http://www.opto22.com
http://www.opto22.com/site/documents/drilldown.aspx?aid=3135
http://www.opto22.com/site/documents/drilldown.aspx?aid=3135
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For Help
If you have any difficulty using software, documents, or firmware, contact Opto 22 Product 
Support by email or phone:

Phone: 800-TEK-OPTO 
(800-835-6786 toll-free 
in the U.S. and Canada)
951-695-3080
Monday through Friday, 
7 a.m. to 5 p.m. Pacific 
Time

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

In addition, the OptoKnowledgeBase (OptoKB) provides the latest information on support 
issues and workarounds. For more information, click the Support tab on our 
www.opto22.com website, and then click the link for the Opto 22 KnowledgeBase. 

Sign Up for My.Opto 22
We recommend signing up at My.Opto22. With a My.Opto22 account, you can purchase 
products online, try out our easy-to-use groov mobile operator interface tool, sign up for 
free training classes, build and save bills of materials (BOMs) in the SNAP I/O Configurator, 
and more.

Get Tech Tips and Find Out about New Products with OptoNews
An email newsletter that comes to you once every two weeks, OptoNews gives you tech 
tips plus news about new products, videos, and training. Sign up for OptoNews through 
your My.Opto22 account or on the OptoNews subscription page.

Checking for Updates Manually

To manually check for new releases or patches for your Opto 22 software, firmware, or 
documentation, go to the Support > Downloads section of the Opto 22 website.

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.

http://www.opto22.com
http://www.opto22.com/site/myopto/my_login.aspx
http://www.opto22.com/site/register/optonews_subscribe.aspx
mailto:support@opto22.com
http://www.opto22.com
http://www.opto22.com/site/downloads/dl_downloads.aspx?cid=0
http://www.opto22.com/site/fd_snappacconfigurator.aspx
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