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EPIC Learning Center 2 Setup Guide Form 2407-240415

The groov EPIC® Learning Center functions as a complete demonstration unit—providing a live experience for 
your pilot and Proof of Concept projects—and training unit, traveling with you to provide on-site instruction. 
The Learning Center also plays an integral role in the free OptoU Online Training (training.opto22.com), 
providing hands-on experience and the opportunity for more in-depth exercises.

NOTE: The Learning Center is meant to be used as a demonstration unit. Do not use it in production applications.

This version of the groov EPIC Learning Center comes with a GRV-EPIC-PR2 processor that is pre-installed with 
Ignition Edge®, PAC Control Engine, groov Manage, CODESYS® Runtime Engine, and more. A software package 
for this Learning Center is available on the Opto 22 website and includes pre-developed software projects, 
strategies, flows, and more based on automation for a convenience store.

What you need

• groov EPIC Learning Center 2 (part number GRV-EPIC-LC2)
• A computer or device with internet access and on the same network as the Learning Center 2

– To work with PAC Control and CODESYS, you need a Microsoft® Windows® PC
• groov EPIC Learning Center 2 Package (3.0) from the Opto 22 website

NOTE: The Learning Center 2 Package is not compatible with the older Learning Center product (GRV-EPIC-LC).
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BEFORE YOU BEGIN
1. Complete all tasks in the printed form that shipped with your groov EPIC Learning Center (groov EPIC 

Learning Center 2 Assembly, form 2409).
2. Register and create a MyOpto account on the Opto 22 website (opto22.com). This account allows you to 

download firmware updates, activate the full groov View license, access our free OptoU online training 
resources, and take advantage of many other benefits.

3. Set the panel light switch to the bottom position (programmable). Review groov EPIC Learning Center 2 
Assembly (form 2409) for detailed instructions.

https://www.opto22.com/logon?returnurl=%2f
https://www.opto22.com/
https://www.opto22.com/products/product-container/grv-epic-lc2
https://training.opto22.com/
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://www.opto22.com/support/resources-tools/documents/2409-groov-epic-learning-center-2-assembly
https://www.opto22.com/support/resources-tools/documents/2409-groov-epic-learning-center-2-assembly
https://www.opto22.com/support/resources-tools/documents/2409-groov-epic-learning-center-2-assembly
https://www.opto22.com/support/resources-tools/documents/2409-groov-epic-learning-center-2-assembly
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POWER ON YOUR groov EPIC
1. Facing the front of the Learning Center (rotate as needed), toggle the power button behind the 

touchscreen to turn on the EPIC processor. Close the touchscreen.

2. When the EPIC displays the Welcome screen (it may take a few minutes), note the Hostname and Eth0 
IP Address of your Learning Center.

3. In a web browser on your computer, type the following in the URL address bar: 
https://<hostname> where hostname is replaced with either the hostname or Eth0 IP address of 
your EPIC processor.
Examples: https://opto-03-fa-bf
        https://xxx.xxx.xxx.xxx

NOTE: Some routers cannot connect using a hostname and require an IP address. If you are unable to connect 
using the hostname, use the Eth0 IP address of your EPIC processor.

4. If your browser displays a security warning, ignore or bypass it to connect to the EPIC processor.
5. On the Welcome screen, click Let’s Get Started.

COMMISSION AND ACTIVATE YOUR groov EPIC

Once powered on, perform the following tasks to commission your groov EPIC Learning Center, which 
includes creating your first administrator-level user account and installing certificates to secure it. Before you 
complete commissioning, a best practice is to verify your firmware version.

Create an administrator-level user account

1. On the Create an Account screen, enter a username and password that meets your company security 
requirements or general security recommendations. This creates the first administrator-level user for your 
Learning Center. 

IMPORTANT: Remember these credentials! For security reasons, there is no method to recover a forgotten 
groov EPIC password or username.

2. Click Create Account. After creating the account, click Configure Device to continue.

Example Your Learning Center

Hostname:

______________________________________

Eth0 IP Address:

_______________________________________
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Finish commissioning

Finish the commissioning by completing the following lessons in the Commissioning groov EPIC online course 
(log in with your MyOpto account):

NOTE: You can skip the quizzes. They are not required to finish commissioning.

– 3. Setting the time zone.
– 4. Setting the hostname.
– 5. and 6. Creating a Server SSL Certificate and downloading the Public Certificate.
– 7. Installing the Public Certificate in your Trusted Root Certification Authorities Store.
– 8. Confirming you have a secure connection.

Activate the groov EPIC processor

Activating the groov EPIC in your Learning Center fully licenses groov View so you can avoid restarting it after 
the two-hour trial period. Follow the Activate Your groov EPIC Processor video on the Opto 22 website (you may 
need to log in with your MyOpto account) to activate the groov EPIC on your Learning Center. Note that the 
video applies to both the GRV-EPIC-PR2 and GRV-EPIC-PR1 processors (your Learning Center contains a PR2).

Your groov EPIC Learning Center is now ready for programming. The PAC Control, groov View, Node-RED, 
Ignition Edge, and CODESYS software are included with your Learning Center.

INSTALL THE SOFTWARE PACKAGE AND APPLICATIONS

The groov EPIC Learning Center 2 Package is designed for the groov EPIC Learning Center 2 (part number 
GRV-EPIC-LC2). This software package contains projects that help you learn how to create control programs, 
operator interfaces (HMIs), and connections with other devices, software, and online services to move data 
where you need it.

Software project files include:
• PAC Control (control programming)
• groov View (HMI creation and viewing)
• Node-RED (IIoT connectivity)

https://www.opto22.com/products/product-container/grv-epic-lc2
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://training.opto22.com/path/groov-manage-for-groov-epic/commissioning-groov-epic
https://www.opto22.com/support/resources-tools/videos/video-activate-your-groov-epic-pr1-processor
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• Ignition Edge (IIoT connectivity)
• CODESYS (an alternative control programming option)

You can use the Learning Center 2 and these files together with the groov EPIC Training Series, our free online 
training available for you at training.opto22.com.

Install the groov EPIC Learning Center 2 Package

1. On opto22.com, search for EPIC Learning Center 2 and click groov EPIC Learning Center 2 
Package from the search results.

2. On the groov EPIC Learning Center 2 Package page, click Download and save the file to your computer.
3. Navigate to where you saved the file and unzip (extract) the files.

Install PAC Control

PAC Control is an easy-to-use flowchart-based software for creating and running a control program on the 
groov EPIC. The control program is called a strategy. 

The PAC Control strategy runs the logic that controls the devices and sensors on the Learning Center load 
panel. The strategy also controls interaction with the groov View HMI and the Node-RED projects. If you want 
to run the groov View project or the Node-RED project, you must install and run the PAC Control strategy first. 
For more information about PAC Control, review the PAC Control User’s Guide (form 1700).

To learn how to use PAC Control, install the following software on your Windows computer:
1. Go to opto22.com, search for PAC Project Basic and select PAC Project Basic (PAC Project 

contains PAC Control).
2. On the PAC Project Basic page, click Download and save the file (.exe) to your computer.
3. Double-click the downloaded *.exe file and follow on-screen instructions to complete the 

installation.

NOTE: CODESYS is an alternative to PAC Control and included in the Learning Center 2. For more information, go to 
“Optional: the CODESYS Development System” on page 15.

Set Up Ignition Edge

If you want to learn about Ignition Edge, set up the Learning Center using the Ignition Edge Panel 
Development license included in your groov EPIC Learning Center. Review “Activate the Ignition Edge Panel 
Development License” on page 13 for complete instructions.

RUN THE PAC CONTROL STRATEGY

The files for this project are in the PAC Control Strategy Complete folder in the groov EPIC Learning 
Center 2 Package.

Start PAC Control

1. On your Windows computer, open PAC Control (ensure that you are in Config mode).
2. Click File > Open Strategy.
3. Navigate to the folder where you unzipped (extracted) the Learning Center 2 Package and open the PAC 

Control Strategy Complete folder.

https://training.opto22.com/page/groov-epic-training
https://www.opto22.com/
https://www.opto22.com/
https://www.opto22.com/support/resources-tools/downloads/pac_project_basic\
https://www.opto22.com/support/resources-tools/documents/1700-pac-control-users-guide
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
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4. Select the strategy file (ending in.idb) and click Open. If a message about a missing subroutine 
appears, click Yes.

Set the Control Engine to the groov EPIC processor on your Learning Center

1. In the CStore strategy tree in the left pane, expand Control Engines by clicking the + sign.
2. Double-click epic-lc.
3. In the Configure Control Engines window, click Modify.
4. In the Select Control Engine window, click Add.
5. In the Control Engine Configuration window, enter epic-lc in the Control Engine Name field.
6. Under Settings, change the IP Address/Hostname field to the IP address of your EPIC processor. If you 

do not know the IP address, launch groov Manage and navigate to Network > Status > Ethernet 0 > 
IP Address to view it.

7. Click OK to close the Control Engine Configuration window.
8. On the Select Control Engine window, click OK. The control engine name appears in the Active Engine 

field.
9. Click OK to close the Configure Control Engines window.
10. Choose File > Save Strategy.

Set the Location of your Learning Center

1. In the CStore strategy tree in the left pane, expand the Variables > String Variables folder (click 
the + icons).

2. Double-click Convenience_Store_Location. The Edit Variable window appears.
3. In the Initial Value field, change your_location_here to a city, state/province/region 

abbreviation (for example: Temecula, CA).
4. Click OK.
5. Choose File > Save Strategy.

Download and run the strategy 

1. Select Mode > Debug to download the strategy to your groov EPIC. If a download warning message 
appears, click Yes to continue downloading the strategy to the processor.

2. Select Debug > Run to run the strategy. If a confirmation window appears, click Start Strategy. The 
PAC Control strategy is now running on the groov EPIC Learning Center 2.

3. If you want to close PAC Control, click File > Exit.

RUN THE OPC UA DATA SERVICE

The OPC UA data service provides applications (such as Ignition Edge, Node-RED, and other third party 
applications) access to the PAC Control strategy, I/O values, and PID values in the project files.

For this Learning Center example, the OPC UA data service requires you to:
• Configure the built-in OPC UA server on the groov EPIC
• Configure two scanned devices: the groov EPIC and its groov I/O unit
• Enable public access of PID loops on the EPIC so that third party applications can access their data
• Enable the Data Service
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Configure the built-in OPC UA server

1. Access your Learning Center from groov Manage by entering the following in a web browser on your PC: 
https://<hostname or Eth0 IP address>

Log in if prompted.

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. From the groov Manage Home page, click Data Service > Configure (top right corner).
3. Click Add OPC UA.
4. Move the slider to the right so that it shows green for the following fields under Configuration:

– Enable
– Allow Anonymous Access
– Allow Writes

– None (under Security Policies)
5. Click Save. 

Configure the scanned devices

1. Click Add Local PAC Controller under Scanned Devices on the Data Service Configuration page (Data 
Service > Configure from the groov Manage Home page).

2. Enter pac_tags as the name of your EPIC’s control strategy in the Device ID field, and click Save.
3. Click Add Local I/O System under Scanned Devices.
4. Enter epic_io as the name of the your EPIC’s local I/O in the Device ID field, and click Save.
5. Click Status to return to the Data Service page.

Enable public access of PID loops

1. From the Data Service page, click Configure (top right corner).
2. In the Public Access section, click PID Loops.
3. Click PID0: PID_Store_Temperature.
4. Click Configure.
5. Scroll down and move the Public Access slider to the right so it turns green.
6. Ensure the Readable slider is green and move the Writable slider to the right so it turns green.
7. Click Save in the top right corner.
8. Use the navigate links in the top left corner to return to the groov Manage Home page.

Enable the Data Service

1. From the groov Manage Home page, click Data Service.
2. Click Enable in the Data Service Runtime field.

When the Data Service status changes to Running, the OPC UA server is ready to provide data to clients 
(like groov View, Ignition Edge Panel, and your favorite OPC UA client).
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RUN THE NODE-RED PROJECT

Node-RED is a visual programming tool you can use to wire together devices, databases, cloud applications, 
and APIs (application programming interfaces) with simple logic flows in a web browser. It is included in the 
groov EPIC processor. For more information about Node-RED, review the Node-RED OptoU courses on the 
Opto 22 website (log in with your MyOpto account).

The flows in the Node-RED project provide data for the Weather page of the groov View project, and the EPIC 
and Weather pages of the Node-RED Dashboard. If you want to run this project, you must install and run the 
PAC Control strategy first.

The files for this project are in the Node-RED Complete folder in the groov EPIC Learning Center 2 Package.

Create a Node-RED administrator-level account

The best practice is to create a separate user account for Node-RED API access in the event you ever need to 
revoke the account without affecting your primary system administrator account (created in “Create an 
administrator-level user account” on page 2). The Node-RED account must have system administrator 
permissions to use the API key in the Node-RED nodes.
1. Access your Learning Center from groov Manage by entering the following in a web browser on your PC: 

https://<hostname or Eth0 IP address>

If prompted, log in with the username and password you set up in “Create an administrator-level user 
account” on page 2.

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. Click Accounts.
3. Click Users.
4. Click Add (in the upper right corner).
5. Configure the account with the following information and permissions:

a. Enter Node-RED_API as the Username.
b. Enter opto22 as the Password.
c. Select System-wide Administrator - Yes in the Permissions field.

6. Click Save (in the upper right corner).

Create an OpenWeather account and obtain an API key

1. Go to the OpenWeather website (home.openweathermap.org).
2. Follow the instructions on the website to sign up and register for an account.

https://home.openweathermap.org
https://training.opto22.com/path/node-red
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
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3. After you confirm your email address and log in with your new account, click your username in the menu 
and select My API Keys. The OpenWeather website shows your API key (blurred in the following image):

4. In the Key field, highlight the API key and press CTRL+C to copy the text to the computer clipboard.
5. Open your favorite text editor (like Notepad) and press CTRL+V to paste the API key into the editor.
6. Save it with a filename like OpenWeatherMap_API.txt in a secure location because you need it in 

the Node-RED project.

Load the Node-RED project

1. Access your Learning Center from groov Manage by entering the following in a web browser on your PC: 
https://<hostname or Eth0 IP address>

Log in if prompted.

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. From the groov Manage Home page, click Node-RED.
3. Click Project Management > Upload Project.
4. Navigate to the folder where you unzipped (extracted) the Learning Center 2 Package and open the 

Node-RED Complete folder.
5. Select the Node-RED project file (ending in .project.zip) and click Open. groov Manage displays a 

message that it is uploading and decompressing the project.
6. When the project is uploaded, click Start.
7. When a message confirming Node-RED has started appears, click Close.

Start the Node-RED Editor

1. In groov Manage, click Status to return to the Node-RED page.
2. Click Open Node-RED Editor.
3. Click the X in the top right corner of the Node-RED welcome message.

Get the API key for your Node-RED user account

1. From the groov Manage Home page, click Accounts.
2. Click Users.
3. Click the ID of the Node-RED administrator-level user you created in “Create a Node-RED 

administrator-level account” on page 7.
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4. In the API Key area, highlight the text in the API Key field and press CTRL+C to copy it to the computer 
clipboard.

5. Click Cancel > Accounts > Home to return to the groov Manage Home page.

Configure groov I/O nodes with the groov Manage API key

1. Return to the Node-RED browser tab or window.
2. In the Example Flow, scroll to the Node-RED groov IO Dashboard group (red outline) and double-click 

the Top_Button node. 

3. In the Edit groov i/o input node panel on the right, click the pencil ( ) icon next to the Device field.
4. In the API Key field, press CTRL+V to paste the API key you copied earlier and click Update.
5. Click Done.

Because the groov I/O nodes use the same device (localhost), all the other groov I/O input nodes are 
automatically configured with this API key.

Configure groov View nodes with the groov Manage API key

1. In the Example Flow, scroll to the HTTP GET Weather Data group (green outline) and double-click the 
city node.

2. In the Edit groov read node panel on the right, click the pencil ( ) icon next to the Data Store field.
3. In the Groov Project field, click the pencil ( ) icon.
4. Press CTRL+V to paste the API key in the API Key field (this is the same API key you configured on the 

Top_Button node earlier).
5. Click Update > Update > Done to save your changes.
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Set up the OpenWeather API key

1. Open the text file that has the OpenWeather API key you obtained in “Create an OpenWeather account 
and obtain an API key” on page 7 and copy it to the Windows clipboard (highlight the API key and press 
CTRL+C).

2. In the HTTP GET Weather Data group (green outline), double-click the Set API key and generate 
URL node.

3. Under Rules, delete <YOUR_API_KEY> in the first to the value field and paste (CTRL+V) the 
OpenWeather API key.

4. Click Done.

Deploy the flow

Click Deploy in the upper-right corner of the Node-RED Editor. After the flow is deployed, a “scanning” status 
with a green indicator appears below each Opto22 node in the Node-RED groov I/O Dashboard group. This 
indicates the Node-RED flow is communicating to the configured I/O point.

Run the Node-RED Dashboard

1. Return to the groov Manage Home page and click Node-RED > Node-RED Dashboard.



OPTO 22 • 800-321-6786 • 1-951-695-3000 • www.opto22.com • sales@opto22.com

© 2024 Opto 22. All rights reserved. Dimensions and specifications are subject to change. Brand or product names used herein are trademarks or registered trademarks of their respective companies or organizations.

PAGE 11

Form 2407-240415groov EPIC Learning Center 2 Setup Guide

2. Play with the buttons, potentiometer, and temperature probe on your Learning Center 2 to discover how 
they change the dashboard as shown in the following image:

RUN THE groov VIEW PROJECT

groov View is a simple tool for building and viewing an operator interface (HMI) on any computer or mobile 
device with a web browser. To build the HMI, you just drag and drop elements into the HMI and then tag them 
with the I/O channel or variable they represent. For more information, review the groov View User’s Guide 
(form 2027).

In the groov View project, the HMI is already built. It runs an HMI for the PAC Control project strategy, and it has 
Data Stores that work with the Node-RED project flows. When you run the groov View project, it can refresh 
displayed data when the built-in OPC UA data service is configured to access PAC Control strategy tags and 
groov I/O memory map values. If you want to run this project, you must install and run the PAC Control 
strategy first.

The files for this project are in the groov View Complete folder in the groov EPIC Learning Center 2 Package.

Start groov View and load the groov View project

1. Access your Learning Center from groov Manage by entering the following in a web browser on your PC: 
https://<hostname or Eth0 IP address>

Log in if prompted.

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. From the groov Manage Home page, click groov View.
3. Verify that Running displays in the Status field and click Open groov View. If groov View is not 

running, click Enable in the Runtime field.

NOTE: If you did not activate groov View using the instructions in “Activate the groov EPIC processor” on page 3, 
you will be prompted to do so or continue in the 2-hour trial mode.

4. In the upper right, click the Menu button ( ) and choose Switch to Build mode.
5. Click File > Restore Project from Computer.

https://www.opto22.com/support/resources-tools/documents/2027-groov-view-users-guide
https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
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6. In the Restore Project window, click Browse. Navigate to the folder where you unzipped the Learning 
Center 2 Package and open the groov View Complete folder.

7. Select the groov View project file (ending in .tar.gz) and click Open.
8. In the Restore Project window, type groov for the username and epic for the password.
9. Click Restore and then click OK in the warning message to continue.
10. Click Close > Close.

The groov View project is uploaded and displayed in groov Build mode.

Run and explore groov View

You can explore groov View not just from the web browser on your computer, but also from a web browser on 
your mobile phone (or device) and from the groov EPIC touchscreen.

NOTE: If you did not activate your Learning Center (review page 3), groov View will run in trial mode for two hours 
and then you need to restart it by stopping and starting groov View from the groov Manage menu.

From a computer web browser

1. After starting and loading the groov View project (review “Start groov View and load the groov View 
project” on page 11), click File > Save All Changes and Switch to groov View in your browser.
The groov View project is now running.

2. Click the navigation icon in the upper left corner.
The groov View pages are divided into two page categories:
– Learning Center—animated with tags that are connected to the groov EPIC Learning Center 2 load 

panel.
– C-Store 022—animated with simulated data.
You can click through the interface to interact with the screen as well as interact with the load panel to 
observe changes on the groov View HMI.

From a mobile phone/device web browser

1. To use your phone or other mobile device to view the HMI, open a web browser and enter the Learning 
Center 2 hostname or Eth0 IP address of your EPIC processor as the URL: 
https://<hostname or Eth0 IP address>

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. Log in with the username and password you set up in “Create an administrator-level user account” on 
page 2.

3. Select groov View > Open groov View.
4. Tap through the interface and interact with the load panel to observe changes on the groov View HMI.

From the groov EPIC processor touchscreen

1. On the groov EPIC touchscreen, tap groov View.

NOTE: If prompted to log in, enter the credentials for the account you created in “Create an administrator-level 
user account” on page 2).

2. Tap Open groov View.
3. Tap through the interface and interact with the load panel to observe changes on the groov View HMI.
4. To return to the main menu, tap the icon on the top right and tap groov Manage.
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Display the current weather data of a city in groov View

If you established a connection to OpenWeather (review “Run the Node-RED Project” on page 7), the Weather 
page in the groov View project can be used to display the current weather data of a city you select.
1. Ensure the groov View Learning Center project is running (if not, follow the instructions in “Start 

groov View and load the groov View project” on page 11 to load the project file).
2. Click the navigation icon in the upper left corner and go to the Weather page.
3. Click in the City field (may currently display ERROR).
4. Enter the name of the desired city (such as Temecula), and click OK.

The current weather data for that city displays as shown in the following image:

ACTIVATE THE IGNITION EDGE PANEL DEVELOPMENT LICENSE

An Ignition Edge Panel Development license key is included with your groov EPIC Learning Center 2. This 
Development license gives you access to all of the features in Ignition Edge Panel, including:
• No tag or device limitations (with some exceptions)
• IIoT (MQTT) functionality
• Sync Services
• EAM
• Compute
• Historical and event logging (alarming, auditing) for 35 days in your groov EPIC’s internal storage
• Local visualization functionality

IMPORTANT: We strongly recommend that you have an internet connection to complete this process. If not, visit 
the Inductive Automation licensing activation documentation about offline license activation. The Ignition Edge 
Panel Development license is solely for evaluation and training purposes, and it is not authorized for commercial or 
production environments.

Enable and set up Ignition Edge

1. From the groov Manage Home page, click Ignition.
2. Under the Config section, confirm Platform displays Ignition Edge.
3. Slide the Enable Ignition Edge button to the right so it turns green and click Save.

https://docs.inductiveautomation.com/display/DOC81/Licensing+and+Activation#LicensingandActivation-OfflineActivationExample
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4. If a message about the HTTP Port and HTTPS Port values appears, click OK.
After a few moments, confirm the Ignition Edge field under the Status area displays Running.

5. Click Open Ignition Edge.
6. From the Inductive Automation Software License Agreement window, select I have read and agree 

with the terms and conditions and click Next.
7. Create an Ignition user account with administrative permissions by entering a Username, a Password, 

and then click Next. Ensure you remember these credentials.
8. From the Configure Ports window, keep the default values for the HTTP, HTTPS Port, and Gateway 

Network Port fields and click Finish Setup.

Activate the Ignition Edge Panel Development license

This procedure provides the steps for online (internet connection) license activation. If your EPIC processor 
does not have an internet connection, visit the Inductive Automation licensing activation documentation for 
information about offline license activation.
1. When prompted, click Start Gateway.

The Ignition Gateway starts after a few moments.
2. In the upper right corner, click Log In.
3. Enter your Username and click Continue.
4. Enter your Password and click Continue.
5. In the upper right corner, click Activate Ignition.
6. Click Activate License.
7. In the License Key field, enter the Ignition Edge Panel Development license key included with your 

Learning Center and click Submit.
8. When an internet connection is detected, click Activate.

The license is applied and the applied features are displayed.

For more about working with Ignition Edge, go to the Ignition Edge courses in Opto 22’s free groov EPIC online 
training (log in with your MyOpto account).

NOTE: Be sure to unactivate Ignition Edge prior to updating groov EPIC firmware and other tasks. For more 
information, see the Unactivating Ignition Edge License lesson in the Ignition Edge course.

https://training.opto22.com/1-getting-started-with-the-ignition-platform/1193480
https://training.opto22.com/path/ignition-edge-and-ignition
https://docs.inductiveautomation.com/display/DOC81/Licensing+and+Activation#LicensingandActivation-OfflineActivationExample
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OPTIONAL: THE CODESYS DEVELOPMENT SYSTEM

The CODESYS Development System offers an alternative control programming option to PAC Control for 
the groov EPIC. You can use CODESYS to create and compile a control program in any IEC 61131-3 compatible 
language. The CODESYS project includes examples of Ladder Diagram and Structured Text programs. Like the 
PAC Control project, the CODESYS project runs the logic that controls the devices and sensors on the Learning 
Center 2 load panel. You can run either a PAC Control strategy or a CODESYS control program on the 
groov EPIC processor.

IMPORTANT: Starting the CODESYS controller stops the PAC Control control engine and deletes the PAC Control 
strategy. It will also affect some of the gadgets in groov View that depend on PAC Control tags.

CODESYS stops after a two-hour trial period and needs to be restarted. To avoid an interruption while performing all 
the steps in this section, you can use a free CODESYS license from Opto 22. Search for GROOV-LIC-CRE on the Opto 22 
website (opto22.com) and follow the instructions to request one.

For more information about CODESYS, review the CODESYS OptoU training courses on the Opto 22 website 
(log in with your MyOpto account).

Install CODESYS

If you want to learn about CODESYS, install the following CODESYS software on your Windows computer:
1. Go to the CODESYS® Store website (us.store.codesys.com or store.codesys.com) and download 

CODESYS Development System V3.5.19.20 (32-bit version) or higher. Follow the on-screen 
instructions to complete the installation.

2. Once installed, go to opto22.com, search for CODESYS and select Opto 22 Library Package for 
CODESYS Development System.

3. On the Opto 22 Library Package page, click Download and save the file (.package) to your computer. 
Ensure you download version 3.1.0.0 or higher.

Load the Project Archive

1. Access your Learning Center from groov Manage by entering the following in a web browser on your PC: 
https://<hostname or Eth0 IP address>

Log in if prompted.

NOTE: You may encounter a site security warning when using the Eth0 IP address if the security certificate is set 
up for the hostname.

2. From the groov Manage Home page, choose Controller > CODESYS Controller.
3. Click Enable in the Runtime field to start the CODESYS control engine and click OK to confirm. When 

ready, the Controller Status field changes to Running.

NOTE: If you have PAC Control open and a strategy running, click Ignore in the warning message. This stops the 
PAC Control strategy from running. You can close PAC Control if desired.

4. Open the CODESYS Development System on your computer.
5. In CODESYS, click File > Project Archive > Extract Archive.
6. Navigate to the folder where you unzipped (extracted) the groov EPIC Learning Center 2 Package and 

open the CODESYS Complete folder.
7. Select the .projectarchive file and click Open. If prompted, select to open the file in this 

CODESYS version with different code (do not select the option to install a compatible version).

https://www.opto22.com/support/resources-tools/downloads/groov-epic-learning-center-2-package
https://www.opto22.com/products/product-container/groov-lic-cre
https://training.opto22.com/path/codesys
https://us.store.codesys.com/codesys.html?___store=en
https://store.codesys.com/codesys.html?___store=en
https://www.opto22.com/
https://www.opto22.com/
https://www.opto22.com/support/resources-tools/downloads/opto-22-library-package-for-codesys-development-sy
https://www.opto22.com/support/resources-tools/downloads/opto-22-library-package-for-codesys-development-sy
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8. In the Extract Project Archive window, select the Extract into the same folder where the archive is 
located option and click Extract.

Update the Opto 22 CODESYS Library and add missing libraries

The CODESYS Development system checks whether the version of the Opto 22 Library Package installed in 
CODESYS Development System matches the level that was used to create the project file (ending in 
.project).

If they do not match, CODESYS displays the Project Environment window:

If this is your first time running CODESYS, you may also need to add any missing libraries after you update the 
Opto 22 Library Package.
1. In the Project Environment window on the Library Versions tab, double-click Do not update in the 

Action column.
2. From the list of actions, choose Update to... and click OK. The library updates.

The version of the Opto 22 Library Package 
for CODESYS Development System currently 
installed on CODESYS Development System.

A newer version of the Opto 22 Library 
Package for CODESYS Development System 
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3. In the Devices pane, expand Device > PLC Logic > Application and double-click Library Manager.

4. In the Library Manager window, click Download Missing Libraries. If you do not have this option, you 
are not missing any libraries and can continue to “Configure the GRV-EPIC-PR2 device” on page 17.

5. In the Download Missing Libraries window, select all libraries listed and click Download. Once the 
download completes, the Library Manager window is updated.

Configure the GRV-EPIC-PR2 device

1. In the Devices pane on the left, double-click Device.
2. Click Scan Network.
3. In the Select the Network Path to the Controller pane, highlight your control engine and click OK. 

If your EPIC does not appear, the CODESYS control engine on your EPIC may have been running for more 
than two hours. In groov Manage, choose Controller > CODESYS Controller. Disable the CODESYS 
controller and then click Enable to re-enable it. Repeat these steps until you can select your control 
engine.

4. If a message about the mandatory use of user management appears, click Yes.
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5. The Add Device User window appears:

a. Enter epic in the Name field.
b. Enter epic in the Password fields.
c. Check the Keep password option to continue with the current password (you can change it to 

something stronger later).
d. Click OK.

6. In the Device User Logon window:

a. Enter epic in the User name field.
b. Enter epic in the Password field.
c. Click OK.
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7. If prompted about upgrading the storage format, click Yes. Re-enter the username and password if 
prompted again.
On the Communications Settings tab of the Device page, a green dot appears next to the Gateway and 
another green dot next to the PLC image (representing your EPIC):

Update the Device version

1. In the Devices pane on the left, right-click Device (GRV-EPIC-PR2), and choose Update Device.
2. In the Update Device window, select the GRV-EPIC-PR2 device under the Name category and click 

Update Device. The device's libraries are updated from the Opto 22 Library Package for CODESYS.

3. When the update is finished and the screen refreshes, click Close.

Define the Ethernet device's IP address

1. In the Devices pane on the left, double-click Ethernet (Ethernet).
2. On the General tab of the Ethernet page, click Browse in the Network interface field. 

If prompted, re-enter the User name (epic) and Password (epic), and click OK.
3. In the Network Adapters window, select lo with 127.0.0.1 listed in the IP address column and click OK.
4. Click File > Save Project.
5. Click Build > Generate Code.
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The Messages field shows warnings and other messages that you can ignore. If there are error 
messages, you must resolve them before you can run and download the project.

6. Click Online > Login.
7. If a warning appears about creating an application that does not exist on the device, click Yes.

If prompted, enter the User name (epic) and Password (epic), and click OK.
8. If a message appears about the device being unavailable, click OK.
9. Click Debug > Start. 

The green RUN indicator confirms the project is running on your groov EPIC.

Now that the CODESYS application is running, you can do things like set breakpoints, cycle through the ladder 
diagram, and toggle channels to see how the lights change on the Learning Center load panel.

If you are familiar with PAC Control programming, note that the I/O in the CODESYS project files have the 
same names as the I/O in the PAC Control project files. You can learn more about creating IEC61131-3 
compliant programs and using them with groov View HMIs by following the CODESYS courses in Opto 22’s 
free groov EPIC online training (log in with your MyOpto account).

TROUBLESHOOTING

Compatibility

Because the Opto 22 product line and online training are always evolving, you may encounter issues if the 
Learning Center Package you downloaded, the firmware version on the groov EPIC processor in your Learning 
Center, and the software on your computer are not all compatible.

Check the compatibility below:

To verify the groov EPIC processor firmware version

1. Navigate to Info and Help > About > System Version. The required firmware version is 3.5.1-b.85 or 
higher.

2. Open a new browser tab or window and go to the Opto 22 website (opto22.com).
3. Log into your MyOpto account.
4. Click MyOpto at the top of the page and navigate to Manage groov > Manage, and under My groov 

List, click Manage next to your Learning Center's groov EPIC processor.
5. If the version number of the groov EPIC Field Update is higher than your System Version number 

under the Latest Releases section, download and install the newer firmware from the website. Follow 
instructions in the video Installing a System Update on the Opto 22 website (opto22.com) under 
Support > Videos > groov EPIC videos.

If you have this version of the 
Learning Center 2 Package...

...it works with this version of firmware and software:

3.0.0 or higher

• groov EPIC firmware 3.5.1 or higher
• CODESYS Development System 3.5.19 Patch 2 or higher
• Opto 22 CODESYS Library Package 3.1.0.0 or higher
• PAC Control 10.5 or higher

https://training.opto22.com/path/codesys
https://www.opto22.com/
https://www.opto22.com/support/resources-tools/videos/playlist-what-is-groov-epic?wchannelid=61lkudfc8c&wmediaid=mxzzp2kudx
https://www.opto22.com/
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Connecting to your groov EPIC processor

NOTE: Some routers cannot connect using a hostname and require an IP address. If you are unable to connect 
using the hostname, use the Eth0 IP address of your EPIC processor. You may encounter a site security warning 
when using the Eth0 IP address if the security certificate is set up for the hostname.

1. Open a browser and enter the hostname or Eth0 IP address of your EPIC processor in the URL. Examples: 
https://<hostname>
https://<Eth0 IP address>

2. Log in with the system user ID and password you created when you first started the Learning Center (in 
“Create an administrator-level user account” on page 2).

Finding the groov EPIC hostname

If you didn’t note the hostname when you turned on the Learning Center for the first time, you can find it in 
groov Manage: Home > Network > Status.

Recovering forgotten user ID and password for the Learning Center

For security reasons, groov EPIC does not provide any way to recover a forgotten password or username. If you 
do not know the user ID and password of the administrator account created when the Learning Center was 
first turned on, you must reset the groov EPIC processor to factory defaults (review the groov EPIC User’s Guide 
(form 2267) for instructions).

In any of the following situations, you must create a new administrator account:
• Turning on a new groov EPIC Learning Center for the first time
• Turning on a groov EPIC Learning Center after installing a firmware update without backup settings 

enabled
• Resetting a groov EPIC processor to factory defaults through the RESET pinhole

Follow steps in the online lesson Activating Your groov EPIC to create the first administrator account. 
Remember to choose a password that follows strong security recommendations.

Backing up previous work

If you have been using your groov EPIC Learning Center and want to preserve your work, follow steps in the 
How to Backup, Update Firmware, and Restore Your groov EPIC Unit online course (log in with your MyOpto 
account).

Calibrating the touchscreen

If a graphic on the EPIC processor’s touchscreen is not responding accurately, the touchscreen may need to be 
calibrated.
1. Log into your groov EPIC processor through the touchscreen with a user ID that has administrator 

permissions.
2. Tap System.
3. Tap Display.
4. Tap Calibrate Touchscreen.
5. Follow the instructions on the screen to run through the calibration exercise (you may be prompted to 

repeat the exercise).
6. After you successfully complete the exercise and return to the Display page, tap Save.

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://training.opto22.com/path/groov-manage-for-groov-epic/initializing-groov-epic-with-groov-manage/734744
https://training.opto22.com/path/groov-manage-for-groov-epic/how-to-backup-update-firmware-and-restore-your-groov-epic-unit
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7. When prompted to restart the display, tap OK.
8. After the processor restarts, log back in.

I/O mapping

The following table can help you understand how the load panel is mapped to the modules.

FOR HELP

Sources for more information

• FREE online training—available anytime at training.opto22.com
• Premium Factory Training—hands-on, instructor-led at the Opto 22 factory and headquarters
• groov EPIC User’s Guide (form 2267)
• Developer website—more about using CODESYS, Node-RED, APIs, and more at developer.opto22.com
• OptoForums—help from the Opto 22 customer community

I/O Mapping

Digital Inputs (GRV-IACDCTTL-24) Digital Outputs (GRV-ODCI-12) Universal I/O (GRV-MM1001-10)

Ch 0: Top push button, latching Ch 0: Blue LED ring around bottom push button Ch 0: ICTD temperature probe

Ch 1: Bottom push button, momentary Ch 1: Sonalert Alarm Ch 4: Resistor in ICTD probe

Ch 6: Light rain status (from DO Ch 3) Ch 3: Light rain Ch 7: Potentiometer

Ch 8: Light rain status (from DO Ch 4) Ch 4: Light rain

Ch 10: Light rain status (from DO Ch 5) Ch 5: Light rain

Ch 12: Light rain status (from DO Ch 6) Ch 6: Light rain

Ch 7: Panel light, Red

Ch 8: Panel light, Green

Ch 9: Panel light, Blue

Ch 10: Output, software driven

Ch 11: Output, software driven

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://training.opto22.com/page/groov-epic-training
https://www.opto22.com/support/training/training-class-details
https://developer.opto22.com/
https://forums.opto22.com/top?period=quarterly
https://developer.opto22.com/
https://training.opto22.com
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Product Support

If you are having difficulty using the groov EPIC Learning Center 2 and cannot find the help you need in this 
document or on our website, contact Opto 22 Product Support. Product Support is provided by experienced 
engineers in our Temecula, California, office. Product Support is FREE.

Phone: 800-TEK-OPTO 
(800-835-6786 toll-free in the U.S. and Canada)
951-695-3080
Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time

Email: support@opto22.com

Opto 22 website: www.opto22.com

NOTE: Email messages and phone calls to Opto 22 Product Support are grouped together and answered in the order 
received.

mailto:support@opto22.com
https://www.opto22.com

